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Introduction

Welcome to the Photoshop CC Bible, the latest edition of the
bestselling reference guide on Photoshop in publishing
history. Now in its 18th year, the Photoshop Bible is the
longest continuously published title on Adobe Photoshop.
With numerous U.S. editions, dozens of localized translations
around the globe, and hundreds of thousands of copies in
print worldwide, the Photoshop Bible has become a
must-have for Photoshop users everywhere.

We have done our very best to accurately and directly address
the vast majority of functionality, features, tools, and
techniques wrapped up in your Photoshop package. As you
may notice throughout the book, we love Photoshop and like
to tell you about the great features it has to offer. You may
also notice that when something doesn't work well or is
awkward, we don't hesitate to let you know. Our intent is to
give you the best experience using Photoshop.

Is This Book for You?

Photoshop tends to collect users from a variety of
backgrounds. From casual users just playing around to
graphic designers creating professional materials to digital
artists creating fantastic artwork to medical technicians
analyzing patient images, Photoshop has something for
everyone. In fact, there really isn't one specific group that you
could call average Photoshop users.

With that in mind, the Photoshop CC Bible is designed to
provide enough information so experienced users can get
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more out of Photoshop, and users with little or no experience
with Photoshop can quickly pick up on its interface and
become experts in no time. We also discuss advanced
techniques and add step-by-step examples to the more
complex editing concepts. Although the book is large, most of
the sections are self-contained, so experienced users can
simply look up tools when they need help.

This book is really designed to be a desktop reference, but it
offers more than just a quick description of the tools and
features. We have incorporated examples designed to guide
you through various techniques, provide our experience in
tips and suggestions, and try to give you a jumpstart on how
to leverage the features in Photoshop.

The specific purpose of this book is to provide you with the
expertise you need to get the very best results. So sit back,
load up Photoshop, and enjoy the ride!

How This Book Is Organized

This book is divided into ten parts with an accompanying
website.

Part I: Getting Started with Adobe Photoshop CC

In Part I, we introduce Photoshop and familiarize you with
the basic Photoshop workspace. We introduce you to the
basics of file formats as well as opening, saving, and resizing
images in Photoshop. We discuss the basics of color as it
relates to images, and how to use the Photoshop tools to
modify the color composition of an image. Then we show you
how to use the History and Actions panels in your workflow
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as you begin editing images. Finally, we introduce you to
Adobe Bridge, a separate application that allows you to
organize and process your images.

Part II: Working with Camera Raw Images

In Part II, we discuss the basics of Camera Raw images, and
how to use the Adobe Camera Raw interface to edit images
before opening them in Photoshop. The purpose of this part is
to familiarize you with Camera Raw image editing so you can
incorporate it into your editing workflow.

Part III: Working with Selections, Layers, and Channels

In Part III, we discuss the various ways to create selections in
Photoshop. We also cover the Layers panel, and how to use it
for non-destructive editing. Then we cover using the
Channels panel to edit and use individual color channels in an
image. Selections, layers, and channels are basic features that
you need in most of your editing workflow.

Part IV: Enhancing, Correcting, and Retouching Images

In Part IV, we discuss the workflow, tools, and techniques
that you can use to enhance, correct, and retouch your images.
This part covers the Photoshop features that you can use to
make color and lighting adjustments to photos, as well as to
restore damaged images.

Part V: Using Paint, Paths, Shapes, and Text Tools

In Part V, we discuss the tools used to create images.
Specifically, we discuss using the Paint tools to use
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brushstrokes to add color, textures, and adjustments to
images. Then we discuss using the path tools to create vector
shapes. Finally, we discuss adding text elements to images.

Part VI: Creating Artistic Effects

In Part VI, we cover using some of the tools in Photoshop to
apply artistic effects to images. You can use these chapters to
learn how to distort and warp parts of an image, apply a
variety of filters, and combine elements from multiple
images.

Part VII: Working with 3-D Images

In Part VII, we cover using the 3-D capabilities in Photoshop
to create, modify, and enhance 3-D objects.

Part VIII: Working with Video and Animation

In Part VIII, we cover using the Animation panel and several
other tools and techniques to make enhancements and
corrections to video with Photoshop. These chapters discuss
various editing concepts and techniques that allow you to use
the Photoshop editing features when editing your videos. You
will also learn how to use the Animation panel to animate
images.

Part IX: Using Advanced Output Techniques

In Part IX, we cover the tools and techniques you use to
output images using Photoshop, from printing and color
management to preparing images for the web. We also
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discuss using the Photoshop batch processing and scripting
capabilities to save a lot of time in your editing workflow.

Part X: Appendixes

We provide appendixes for information that doesn't fit
elsewhere in the book but that we wanted to share with you.
You will find tables with the most commonly used keyboard
shortcuts, instructions on how to use plug-ins to add
functionality to Photoshop, and a list of web resources that
you can use to get more information about Photoshop and
download cool stuff.

How to Use This Book

Although this book is designed for a linear, cover-to-cover
read, we wanted to make it easy for you to pick and choose
what areas of Photoshop you want to learn. For the most part,
each chapter is self-contained. If you are new to Photoshop,
take some time to look at Chapters 1 through 6 to familiarize
yourself with the environment and digital editing concepts. If
a chapter relies on information from another chapter, we
mention that in the chapter introduction or by using a
Cross-Reference note. If you want to know more about a
particular workflow in Photoshop, such as color correction or
adding text, use the table of contents to find the chapter, and
read it thoroughly to learn all about the different tools and
features you can use.

Using this book as a reference

This book is organized as a reference that you can use
whenever you are having difficulties, or when you are ready
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to start a new topic. Each chapter covers a topic, making it
easy for you to find what you are looking for in the book. We
have tried to pack in as much of the Photoshop functionality
and features as possible, so you can look up items in the index
and read the sections in which we discuss them.

Making the most of the book's website

One of the most important aspects of digital images is color.
Unfortunately, the images in this book are in grayscale except
for those in the color insert. We have included several of the
figures and projects on the website. The examples on the
website enable you to see what the images look like in full
color as well as practice the tasks described in the book. You
should download the example projects from the book's
website and use them when available.

Some of the items on the website are JPEG images, some are
PSD projects, some are AVI files, and many of them have
layers and objects available for you to modify. You can
access this book's website at www.wiley.com/go/
photoshopccbible.

Throughout the book, you will see the On the Web icon
noting which figures are available on the website at
www.wiley.com/go/photoshopccbible. Each
note includes a filename that you can use to download the
item and try the concepts out for yourself.

Icons Used in This Book
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This book uses icons to indicate noteworthy points. While the
icons are generally self-explanatory, here is what each of
them indicates:

Caution

The Caution icon means that you should pay special
attention to the information or instructions because you
could cause a problem otherwise.

Cross-Reference

Cross-references refer you to a related topic
elsewhere in the book. Because you may not read this book
straight through from cover to cover, you can use
cross-references to quickly find just the information you need.

New Feature

The New Feature icon means that a feature is new to
Photoshop CC or has been significantly changed.

Note

A Note icon alerts you to some important point that requires
special attention, or additional information that may be
helpful.
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On the Web

The On the Web icon highlights references to related
material on the website at www.wiley.com/go/
photoshopccbible.

Tip

A Tip icon shows you a way to accomplish a task more
efficiently or quickly.

Contacting the Authors

We would love to hear from you! Contact us at
www.DayleyCreations.com.
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Part I: Getting Started with Adobe Photoshop CC

IN THIS PART

Chapter 1

Introducing Adobe Photoshop CC

Chapter 2

Exploring the Photoshop Workspace

Chapter 3

Performing Image Basics

Chapter 4

Understanding Colors, Histograms, Levels, and Curves

Chapter 5

Applying History and Actions

Chapter 6

Using Bridge to Organize and Process Files
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Chapter 1: Introducing Adobe Photoshop CC

In This Chapter

Getting acquainted with Photoshop CC

Benefitting from Photoshop CC

Exploring the new features of Photoshop CC

If you are reading this book, you likely have access to one of
the most intricate and extensive software applications
available. Don't let that discourage you, though. Adobe
Photoshop is also a powerful and extremely fun application to
use. With throngs of fans all over the globe, over the years,
Photoshop has become the pinnacle software application for
image editing. In fact, if you look up Photoshop at
www.wiktionary.org, you will find the term
photoshop listed as a verb meaning, “to digitally edit or alter a
picture or photograph.”

Photoshop draws such a big crowd because it provides
amazing results when you are editing images and yet is fairly
intuitive to use such that even casual users can get pretty good
results without much effort. In addition, as digital imaging
has advanced over the years, Photoshop has kept pace and
even led the advancements in many areas.

The chapter introduces Photoshop CC, shows you when to
use it, and discusses the new features that have been added
since version CS6. Chapter 2 dives into the details of the
Photoshop application workspace.
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Discovering the Versatile World of Photoshop

The simplest description of Photoshop is “a digital
image-editing application.” Photoshop provides the standard
color- and lighting-correction capabilities historically
associated with photo editing, but it also provides filtering,
painting, masking, layering, and many more tools that allow
you to take image editing to the next level.

The following sections discuss how Photoshop interacts with
the Creative Cloud, as well as how you can use Photoshop on
its own and with other applications. The purpose of these
chapters is to give you a glimpse of what Photoshop is used
for before showing you how to use it. Of course, the only real
way to understand the capabilities of Photoshop is to delve
into them as you follow along with the next 30 chapters in
this book.

Introducing Photoshop Creative Cloud Interaction

The CC in Photoshop CC stands for Creative Cloud. The
Adobe Creative Cloud is an online service that provides file
storage, application access, and several other developing
features. With Photoshop CC, Adobe has moved away from a
traditional software package such as the Creative Suite and
into a subscription-based method where you subscribe for
monthly access to the creative applications.

Many people are asking the question, “So what does the
Creative Cloud really mean for a Photoshop user?” It is really
not all that complicated. The Creative Cloud has some
advantages and one big disadvantage. One disadvantage is
that you can no longer buy a Photoshop license and have the
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software indefinitely. Another disadvantage is the
functionality such as syncing settings to the cloud is impeded
if you don't have an Internet connection. Also, for continued
access to the software, you will need to keep up a subscription
to the Creative Cloud.

The advantages of the Creative Cloud and the interaction
points with Photoshop are broken down into the following
list:

• Installation. Rather than getting a license with a set of
DVDs in a box, you subscribe to the Creative Cloud, which
allows you to download and install the application. During the
installation, you need to be logged into the Creative Cloud to
validate your subscription.

• Signing in and out. Selecting Help⇒Sign In logs you into
your Creative Cloud account. This enables you to synchronize
your settings between computers and store files in your
Creative Cloud account. Selecting Help⇒Sign Out logs you
out of the Creative Cloud, which is extremely useful if you
are sharing the computer with someone else because they can
then log into their own account to synchronize settings and
files.

• Synchronizing settings. Photoshop allows you to
synchronize settings and other data such as preferences,
swatches, shapes, patterns, tool presets, and brushes to and
from your Creative Cloud account. I love this feature because
it means I don't have to set everything up again if I move to a
new computer or have to re-install Photoshop. Photoshop
allows you to synchronize the settings by selecting Edit ?
Sync Settings⇒Sync Settings Now from the main menu or
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from an icon in the bottom frame of the document window.
You can also configure which settings should be
synchronized in the Preferences dialog box, which we discuss
in Chapter 2.

• Online storage. Adobe provides online storage with your
Creative Cloud account. This allows you to upload project
files you are working on or have completed to an online
location that you can access from anywhere.

• Sharing files on Behance. Behance is an online portfolio
platform that allows creative professionals to showcase their
work. It encompasses much more than just Photoshop files
because it covers photography, graphic design, illustration,
and fashion design. You can set up an account on Behance
that provides a portfolio location to showcase your Photoshop
work. Then you can upload your final files to be shared on
Behance by selecting File⇒Share on Behance from the main
menu in Photoshop or from the Creative Cloud file storage
interface.

Knowing when to use Photoshop

Photoshop has so many tools and so much power that it can
do an unlimited number of things. The following list
describes the most common tasks for which Photoshop is
used to help you get an idea of when you may want to use it:

• Photo corrections. Photoshop is able to correct digital
images by restoring the original color and lighting, as well as
to correct problems introduced by camera lenses. We cover
these Photoshop features in Chapter 13.
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• Photo enhancements. Photoshop also provides tools that
allow you to enhance photos. For example, you can add a blur
to soften a portrait or use a sharpening filter to remove
camera jitter. Photoshop is also great at fixing scratches and
dust marks on older images. We discuss these concepts in
Chapters 14 and 15.

• Photo compositions. One of the strengths of Photoshop is
the ability to combine multiple images to create a single
image or composition. A common use of Photoshop is to take
a headshot from one image and place it into another image.
Photoshop also enables you to merge photos that were taken
at different horizontal angles, from the same spot, and then
turn them into a single panoramic image. We discuss photo
compositions in Chapter 21.

• Artistic effects. One of the most enjoyable features of
Photoshop is the ability to use different filters and warping
tools to apply artistic effects to images. The combination of
numerous tools and filters in Photoshop means that the only
limitation you have when adding artistic effects is your own
creativity. We cover the tools used for artistic effects in
Chapters 19 and 20.

• Painting. Photoshop has always been a good painting
application, but with the addition of the wet brush capability
in CS5 as well as erodible and airbrush tips in CS6,
Photoshop is now one of the best applications available to
create digital paintings. What puts Photoshop ahead of the
competition is that many powerful features, such as layers and
masks, are also available for use with the painting tools. In
addition, the painting brushes are integrated into many of the
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other tools in Photoshop. Chapter 16 discusses the painting
tools.

• Creating vector artwork. Photoshop is also an excellent
application to use when creating vector artwork. The path
tools allow you to quickly create and manipulate vector
artwork, and add vector artwork to raster images. We discuss
vector artwork, including vector text, in Chapters 17 and 18.

• Adding text to images. Photoshop provides tools that allow
you to add text to images. You can resize, warp, and adjust
the text to create some stunning visual effects. Chapter 18
discusses adding text elements to images.

• Creating web images. Another area where Photoshop
excels is in preparing images for the web. Photoshop provides
utilities that allow you to quickly format images with the
appropriate size, file format, and colors for use in web pages.
Photoshop also provides some tools you can use to slice an
image into clickable sections and provides the HTML code
necessary to use the slices in a web page. We discuss
outputting to the web in Chapter 30.

• Print preparation. Photoshop is often used to prepare
images for printing by converting the color mode to CMYK,
adding spot colors, and creating color separations. We cover
these topics in Chapters 11 and 29.

• Creating 3D objects. The 3D tools in Photoshop just get
better and better. Photoshop has the capability to create and
manipulate 3D objects so you can incorporate them into 2-D
images or video. We cover the 3D capabilities of Photoshop
in Chapters 22, 23, and 24.
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• Adding textures to 3D objects. Photoshop has a big
advantage over other 3D applications when applying textures
to 3D objects. With the Photoshop filter and painting
capabilities, you can edit the textures of your 3D objects in
ways that you may not have thought possible. Chapter 23
discusses creating and enhancing 3D textures.

• Video corrections. Using the color, lighting, and filter
effects of Photoshop, you can quickly apply corrections to
video and even add some artistic effects. Chapter 27 discusses
applying corrections and effects to video files.

• Animating images. Another fun feature of Photoshop is the
ability to add animation to your images. Animated images can
give life to web pages and allow you to create short animated
movies. Chapter 28 discusses animating images.

Understanding the limitations of Photoshop

Believe it or not, Photoshop is not designed to do everything.
Photoshop is not designed to function as a word processor
like Microsoft Word, to create charts and graphics in
presentations like Microsoft PowerPoint, or to lay out
brochures, magazines, or books like Adobe InDesign.

For the following tasks, you would use another application:

• Word processing. Most word processing applications, such
as Word, allow you to add images to documents created with
those programs, and although Photoshop supports adding text
to images, it doesn't support text editing well and can't handle
text flowing from one page to another. You should use
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Photoshop to work with the images and then import them into
the word processing application.

• Business graphics. Photoshop doesn't do charts and
presentations very well, but you can create great images in
Photoshop and then use them in business applications such as
Microsoft Excel or PowerPoint.

• Page layout. Applications such as InDesign are much more
adept at laying out brochures, flyers, and documents that are
mostly text-based. You should create the images in Photoshop
and then import them into the layout application.

• Vector art. Although Photoshop has a lot of capability
when it comes to creating vector paths, Adobe Illustrator is a
much better application for working with clipart and
designing advertisements, flyers, and one-page layouts that
have multiple vector objects.

Looking at What's New in Photoshop CC

In addition to integration with the Creative Cloud, Adobe has
added several great new features to Photoshop CC that make
tools easier to use, extend capabilities, and add a lot of
justification for subscribing. We discuss these new changes
throughout the book. The purpose of this section is to
describe the biggest changes and let you know where in the
book you can find more information about the following new
features:

• Creative Cloud interactions. Photoshop is now integrated
with Adobe Creative Cloud, allowing it to interact with other
design programs in the Creative Cloud. Another major benefit
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of Creative Cloud interactions is it is easy to synchronize
settings as well as store and showcase your Photoshop work
online. Figure 1.1 shows the interaction among Photoshop,
the Creative Cloud, and Behance.

Figure 1.1

You can edit in Photoshop, store in the Creative Cloud, and
showcase on Behance.

• Performance enhancements. Photoshop has added several
performance enhancements to 3D rendering, filtering, and
various other features to provide faster rendering and more
responsive tools.
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• Expanded camera and lens support. Adobe continues to
update Camera Raw and Photoshop to support new cameras
and lenses.

• Retina display support. Camera Raw supports the Apple
Retina users giving the image display better resolution. Retina
users can easily jump to 200-percent zoom by pressing
while double-clicking the Zoom tool. You can zoom all
documents to 200 percent by pressing Shift+ while
double-clicking the Zoom tool.

• JPEG support. Photoshop CC now supports opening and
saving JPEG documents up to 65,535 pixels in width or
height, more than double the 30,000 pixels in previous
versions.

• Conditional actions. A new feature in the Actions panel
enables you to apply actions based on certain conditions such
as document orientation, color mode, or layer settings. Figure
1.2 shows the new Conditional Action dialog box, which we
discuss in Chapter 5.

Figure 1.2

You can now apply actions in action sets based on various
conditions in the document or layer.
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• Camera shake reduction. Photoshop CC provides a new
specialized filter for removing camera shake from images.
The Shake Reduction filter, shown in Figure 1.3, allows you
to easily and effectively remove camera-shake blur from
images. Photoshop allows you to define regions in which it
can evaluate and correct blurriness. We discuss this tool in
more detail in Chapter 14.

• Camera Raw filter. The new Camera Raw filter enables
you to perform Camera Raw adjustments on images that are
not in a Camera Raw format, as shown in Figure 1.4. It does
not replace Camera Raw for files that are in a Raw format;
however, it does provide a great interface that allows you to
perform a variety of adjustments all at once. For more
information on the Camera Raw filter, see Chapter 13. For
more information on the Camera Raw tools available in the
Camera Raw filter, see Chapter 8.

• Camera Raw Radial filter. Adobe Camera Raw has added
a new filter called the Radial filter. The Radial filter applies
adjustments to a region of an image in an elliptical shape.
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Setting the feathering allows you to soften the adjustment
around the edges of the ellipse. We discuss the Camera Raw
Radial filter, shown in Figure 1.5, in detail in Chapter 8.

Figure 1.3

Removing blurriness caused by camera shake from images is
now easy and effective.

• Blur Gallery supports Smart Object layers. A great new
feature in the Blur Gallery is that it now supports Smart
Object layers. This allows you to apply Blur Gallery filters in
a non-destructive way. The Blur Gallery adjustments can be
turned on and off just like any other Smart Object adjustment.
We discuss the Blur Gallery filters in Chapter 14.

• Default type styles. If you add a lot of text to your
Photoshop images, you will love the new Default Type Styles
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feature. The styles for paragraphs and characters that you
define in Photoshop CC can be saved as the default settings.
Any new document that you open in Photoshop automatically
uses the default settings. You can also apply the default
settings to existing documents. We discuss type styles in
detail in Chapter 18.

• Multiple path selection. Finally! If you have ever worked
with vector paths in Photoshop, you probably hated the fact
that you have only been able to apply stroke, fill, mask, and
other path operations to a single path. That meant that you
had to either join multiple paths together into a single path
first or apply the path operation one path at a time.

In Photoshop CC, the Paths panel has been updated to work
with multiple paths. Pressing Shift+Ctrl/Shift+ when
selecting paths in the Paths panel selects multiple paths just as
in the Layers panel with a multiple-layer selection. You can
delete, duplicate, and re-order multiple selected paths. You
can also press Alt/Option while dragging with the mouse to
duplicate one or more paths in the Paths panel. We discuss
vector paths in Chapter 17.

Figure 1.4

Making a variety of adjustments to a non-Raw photo is super
easy in the new, powerful Camera Raw filter.
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• Copy to CSS. The new Copy CSS feature allows you to
generate CSS code from text and vector shape layers. The
Copy CSS feature captures size, location, fill color, gradient,
stroke color, and even drop shadow information using layer
styles. For text layers, it also captures font family, font size,
font weight, line height, underline, strikethrough, superscript,
subscript, and text alignment information. You can use the
Copy CSS feature by selecting Layer⇒Copy CSS from the
main menu, as we discuss in Chapter 30.

• Read swatches from HTML. The Swatches panel now
allows you to load a swatch directly from a CSS or HTML
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file. This allows you to automatically generate a swatch that
is compatible with a webpage or website that you are creating
image elements for. We discuss this new feature in Chapter
30.

• Isolation mode layer filtering. The Layers panel now
includes a filter option that allows you to filter the active
selected layers in a document to a specific subset of the
layers. All other layers are visible, but tool changes are
restricted to just the filtered layers. You can filter on layer
type, effect, name, mode, attribute, color, and whether the
layer is selected. We discuss the Layers menu in Chapter 10.

Figure 1.5

Applying a vignette or other radial effect is very simple using
the new Radial filter in Camera Raw.
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• System and System Gray rendering. Photoshop now
includes two new rendering options to increase performance
and results. The System option is similar to subpixel rendered
text, while System Gray is similar to old non-subpixel
rendered (monochrome) text. For example, in OS X, when
“System” is selected, you see extra stroke thickness for
glyphs with un-hinted text. These new options use OS APIs to
stroke the glyph instead of the Adobe Type Engine, providing
better accuracy when rendering the text in popular browsers
like Safari and Internet Explorer.

• Image upscaling. Photoshop CC includes a new algorithm
that better preserves the crispness of edges when increasing
the size of images. We discuss resizing images in Chapter 3.
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• 3D Live Painting. The new performance enhancements in
the 3D engine have enabled Adobe to provide a much better
method to paint on 3D objects. This new method, called 3D
Live Painting, involves opening the 3D document as well as
the Texture view. As you apply brush strokes to the texture
view, Photoshop also updates the 3D document live. This
allows you to see each paint stroke in both views as you drag
the paintbrush tool. We discuss 3D Live Painting, featured in
Figure 1.6, in Chapter 24.

Figure 1.6

When using the Texture Paint System, you can paint on a
texture document and see the brushstrokes on the 3D
document.
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Summary

This chapter introduced Photoshop CC by discussing the
general uses of Photoshop and the new interaction with the
Creative Cloud. You can use Photoshop for a variety of
purposes, from photo editing to digital art to adding artistic
effects.

In this chapter, you learned that

• Photoshop can be used to edit, enhance, and create images
in several ways

• Photoshop CC provides interaction with the Adobe Creative
Cloud that allows you to store files online, synchronize
settings between computers, and showcase your work on
Behance

• Adobe has added new features such as the Camera Raw
filter, Live 3D painting, shake reduction, and much more to
increase your editing capabilities
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Chapter 2: Exploring the Photoshop Workspace

In This Chapter

Getting acquainted with the workspace

Looking at the menus

Understanding and organizing panels

Getting familiar with the Toolbox

Using presets to save tool configurations

Configuring Photoshop preferences

Creating custom menus and shortcuts

The Photoshop workspace has had years to develop into a
fine-tuned working environment, and with bigger monitors
and faster processors, working in Photoshop has only become
more fun. With all the space that larger display options give
you, you can easily organize the panels, documents, and tools
in the workspace to provide an efficient photo-editing
environment.

With all its features, Photoshop can be a bit daunting at first.
The purpose of this chapter is to familiarize you with the
Photoshop workspace, how to navigate, find tools, customize
settings, and set the environment so it works best for you.

Touring the Workspace
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At first glance, the Photoshop workspace seems a little
dreary, with a lot of gray, but that is misleading. With
beautiful photographs (or other colorful graphics) in the work
area and fascinating tools at your fingertips, you'll soon be
addicted to the Photoshop playground. In fact, you may be
glad that the background not only provides a good contrast to
colorful files, but also is easy on the eyes.

Therefore, without further ado, we give you the Photoshop
workspace, as shown in Figure 2.1. Photoshop has six main
components to the Photoshop workspace: the Photoshop
menu bar, document workspace, Toolbox, Tool Options bar,
panels, and Creative Cloud Synchroniza-tion feature. The
following sections introduce you to each of these
components, and later in this chapter, we'll explore them in
more detail.

Figure 2.1

The Photoshop workspace features four main components.
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Introducing Creative Cloud Synchronization

The Adobe Creative Cloud is a new way of working and
creating with tools like Photoshop. The most popular tools
have been reinvented to support a more natural and connected
way of creating. Creative Clouds enables you to synchronize
many of your Photoshop settings, custom shapes, brushes,
and more to your creative account, thereby streamlining the
creative process. Creative Cloud synchronization enables you
to keep your settings even if you have to re-install Photoshop.
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It also enables you to log into the creative account at another
computer and still have all your Photoshop settings available.

The Creative Cloud synchronization button seems like just a
tiny piece of the workspace; however, it greatly impacts
productivity. When you click the button, a small dialog box
appears in which you can see the last sync time, and an option
to sync the settings with the cloud. Photoshop tries to upload
any new settings to your Creative Cloud account from the
local computer and apply the settings from the cloud to the
version of Photoshop on the local computer.

Cruising the Photoshop menu bar

The Photoshop menu bar, shown in Figure 2.2, houses sets of
cascading menus that provide quick access to features, tools,
and commands in Photoshop using only a few mouse clicks.
When you click a Photoshop menu bar item, a drop-down
menu appears with several options. Each of these options
performs different tasks such as opening dialog boxes to
modify settings, performing image adjustments, or even
opening additional submenus. These menus are a critical part
of the Photoshop workspace because they are the only way to
access certain features in Photoshop.

Figure 2.2

Features of the Photoshop menu bar
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When navigating the menu bar in Photoshop, you need to
understand the following:

• If a menu item points to a submenu, there is an arrow to the
right side, and if you hover over that item, the submenu pops
up next to the open menu, as shown in Figure 2.2.

• If a menu item is only a setting, then a check mark appears
when it is active, as shown in Figure 2.2. You can toggle the
setting on and off by clicking the menu item.

• If the current document does not support the functionality of
a menu item, then the menu item is grayed out, as shown in
Figure 2.2. This means that the item is not active, and you
cannot click it.
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• If a menu item launches a dialog box, then an ellipsis (…)
appears to the right, as shown in Figure 2.2.

Looking at the document workspace

The document workspace houses the documents (image files)
that you are currently editing. You will use the document
workspace extensively as you view and edit documents in
Photoshop.

The document workspace is also home to the panels and
Toolbox, which we discuss later in this chapter. The
workspace is large enough to give you the flexibility to
expand your image to a larger size and keep your favorite
panels open and docked as well.

Note

We took the screenshots in this book at a screen resolution
of 1024 × 768, which is low, especially if you have a larger
screen. If you set your resolution higher, you have a larger
work area than you see here. If you set your resolution as
high as 1920 × 1200 (which is what we usually set ours to),
then you have enough space to expand your panels, tile your
document windows, and generally make everything
available to you at once. Of course, if you set your
resolution lower than 1024 × 768, then your work area is
smaller.

As you open image files, they appear in the center of the
document workspace, and you have several options for
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viewing them. You can modify the view size and behavior,
view specific information about a document, and arrange
multiple documents in the view area.

Changing the view size of a document

Several ways exist to change the view size of a document in
Photoshop to support the workflow that you are using.
Changing the view size of a document is one of the most
common tasks that you will perform in Photoshop, as you
need to zoom in on an image to modify specific areas,
enhance selections, and perform other tasks. You may also
want to view the print size of an image, the actual screen size,
or even fit the image to the screen so you can see all of it.

The View menu houses several different options to modify
the view size of the document. When you click the View
menu, as shown in Figure 2.3, you can choose the following
options:

Figure 2.3

You can change the way your image fits into the document
workspace by using the View menu.
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• Zoom In. Click this option, or press Ctrl+plus key/ +plus
key, to zoom the image in to the next zoom stop. The zoom
stops are in various increments, ranging from small (such as
.5, .67, 1, and 1.5 percent) to large (such as 100, 200, 300
percent, and so on).

• Zoom Out. Click this option, or press Ctrl+minus key/
+minus key, to zoom the image out to the next zoom stop.
The zoom stops are the same as for the Zoom In option.

• Fit on Screen. Click this option to see your entire image.
This is your best option if you are working on your entire
document (and not working with other files).

• 100%. Click this option to match the pixels in the image to
those on the screen. 100% is the best option if you want to see
the cleanest view of a specific area because no interpolation is

84



necessary. Similarly the 200% option will zoom the image up
to 200%.

• Print Size. Click this option to see how the document will
look when printed.

• Screen Mode. Click this option to display the available
screen modes; you can choose from Standard Screen mode,
Full Screen mode with menu bar, and Full Screen mode.

• Standard Screen Mode. This is the default mode, and it
allows you to access other applications that are running.

• Full Screen Mode With Menu Bar. This mode looks
similar to Standard Screen mode, but you can't access other
programs, for example, through the Windows taskbar.

• Full Screen Mode. This mode hides everything but the
selected document so you can work without distractions. The
Photoshop tools are still available to you; just hover over the
tool you want to use and it appears, or press the Tab key to
view all of your tools. Press Esc to return to Standard Screen
mode.

Tip

Don't use the zoom options in the View menu; you have
several better options — the Zoom tool, the Magnify box,
and the roller wheel on your mouse if you are using one —
which we discuss later in this chapter.
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In addition to the standard zoom stops, you can easily zoom
in and out on the image, depending on your editing needs.
Notice that the bottom-left corner of the document window in
Figure 2.4 displays a percentage representing the zoom value
and the document information. You can change the size of
your document by selecting the zoom value and typing a new
percentage.

Another way that you can change the magnification of an
image is to select the Zoom tool in the Toolbox, and then
click anywhere in the image and drag the mouse to the left or
right. Dragging to the left decreases the size of the image,
while dragging to the right increases it.

Viewing document information

Another useful feature in the document window is the
document information section at the bottom. By default, the
document information displays the size of your file. Keep an
eye on the file size as you begin to add multiple layers and
effects to a document; you might be surprised by how these
changes can increase the size of your document.

If you click the arrow next to the document information, a
popup menu opens, as shown in Figure 2.4, that gives you
several options for the information display.

You can choose to display the following options at the bottom
of the document workspace:

• Adobe Drive. This option shows the location of the Adobe
drive used as a scratch disk.
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• Document Sizes. This option shows the size data of the
image in the format of “print size”/”actual size.” The print
size represents the size of the image if it is in a flattened state
with no layers or additional channels. The actual size includes
the additional space that the image requires to store the
additional metadata such as channels and layers.

• Document Profile. This option displays the name of the
color profile assigned to the document.

• Document Dimensions. This option displays the
dimensions of the image in inches along with the ppi (Pixels
Per Inch) value.

• Measurement Scale. This option shows the scale of the
current zoom state of the document in pixels.

• Scratch Sizes. This option shows the scratch usage of the
document in the format of “memory used for this
document”/”total scratch memory available.”

Figure 2.4

The information section of the document window can be very
useful when you are editing images. The menu allows you to
display several types of information.
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Tip

The scratch usage can dramatically impact how Photoshop
performs. You should monitor the scratch usage when
making complex adjustments to very large images.

• Efficiency. This option displays the percentage of time that
Photoshop uses to actually perform operations instead of
reading or writing to the scratch disk. If this value is below
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100 percent, then Photoshop is using the scratch disk and
therefore operations are slower.

• Timing. This option displays the amount of time Photoshop
used to complete the last operation.

• Current Tool. This option shows the name of the currently
selected tool.

• 32-bit Exposure. This option provides a slider that allows
you to easily adjust the preview image for viewing 32-bit
HDR images on the monitor. The slider is only visible when
you are working with a 32-bit document.

• Save Progress. This option opens a progress bar when you
are saving an image. This is useful when you are saving large
images in the background and you want to monitor the
progress of the save operation.

Arranging the view of multiple documents

When multiple documents are open in the document
workspace, Photoshop provides tabs for each of them. These
tabs display the document name, and you can access the
document for editing by clicking its tab. Using the tabs is the
most economical and organized way to have multiple files
open, and you will probably prefer this option most of the
time.

Other View options are also available when you have
multiple documents open. To change how the document
windows are organized, choose Window⇒Arrange from the
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Photoshop menu bar and then choose one of the options
shown in Figure 2.5.

Figure 2.5

Using the Window⇒Arrange menu, you can easily change
the layout of multiple documents in the document workspace.

Following is a description of the multiple document
arrangements:

• Preset document arrangements. These options
automatically distribute the documents in the document work
area based on a predefined arrangement of view panes. These
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arrangements are shown next to the menu item. Each open
document takes up one pane. If fewer documents are in the
arrangement than panes, the arrangement option is inactive in
the menu. If more documents than panes are in the
arrangement, then Photoshop places the extra documents as
tabs in the top-left pane. Figure 2.6 shows the 3-up Stacked
arrangement. If the document is bigger than the pane, the
scroll bars become active, allowing you to scroll around the
image.

Tip

You can resize the view panes in a tiled or preset
arrangement by dragging borders between the panes with
the mouse. This allows you to customize your document
workspace completely to support the project on which you
are working.

• Consolidate All to Tabs. This option docks all floating
windows into the document workspace. This is great when
you have so many windows open that navigating them is
difficult. You can also consolidate windows to the document
workspace or floating group by right-clicking the tab bar at
the top and selecting Consolidate All to Here.

• Cascade. This option cascades your documents by showing
the document windows in a cascade arrangement from the
upper-left corner to the lower-right corner of your document
workspace. Figure 2.6 shows an example of a cascading
document window.
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• Tile. This option adjusts the size of all open document
windows so you can view them together in the workspace.
For example, if you are working with two or more documents
at the same time, cloning areas of one into another, you
probably want to tile your documents in the document
workspace. Figure 2.6 shows an example of tiled documents
that are in a floating state.

• Float in Window. This option floats your documents,
thereby releasing them from the document workspace or from
a floating group to their own individual windows. When the
document windows are floating, they are independent of the
Photoshop interface, and you can use the standard operating
system window controls on them. You can organize floating
windows into groups by dragging one window on top of
another window. When more than one document is in a
floating group, their tabs appear at the top of the window.
You can also float a window by grabbing its tab in the
floating group or document workspace and dragging it out.
You can add a floating document to a group or document
workspace by dragging it into the tabs.

• Float All in Windows. This option causes all windows to
float.

Tip

You can quickly cycle through open, tabbed document
windows by pressing the Ctrl+Tab/ +` hotkey sequence.
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• Match Zoom. This option sets the zoom percentage of all
open document windows to match the value of the active
document window. This is useful when you are working with
multiple images that you will eventually consolidate into a
single document.

• Match Location. This option sets the center panning
position of all open document windows to match the center
position of the active document window. This is useful if you
are working with multiple versions of the same image or a
sequence of images, and you want to quickly move to the
same location in all windows for comparison.

• Match Rotation. This option sets the rotation angle of the
image in all document windows to match the rotation angle of
the image in the active document window.

• Match All. This option sets the zoom, center panning
position, and rotation of all document windows to match the
values of the active document window.

Figure 2.6

Examples of some of the multi-document layouts in
Photoshop
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Understanding the Toolbox and tool options bar

The Toolbox provides easy access to all of the tools in
Photoshop that require mouse or stylus interaction with the
document. The Toolbox includes selection tools, painting
tools, erasing tools, and much more, as shown in Figure 2.7.
We discuss each of the tools that are available in the Toolbox
later in this chapter.
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The tool options bar, usually referred to as the “Options bar”
or the “tool menu,” sits below the Photoshop menu bar. The
options in the tool menu change, depending on the tool you
have selected in the Toolbox. Figure 2.7 shows the different
options for the Move, Brush, and Type tools.

It is always smart to keep an eye on what is going on in the
Options bar. When you initially select a tool, the options are
set to default values that are commonly used, but not
necessarily the values you would use in a particular situation.
After you change the options for any given tool, those options
stay changed, even after you use other tools. The Options bar
is useful and important, and as you use Photoshop, you will
soon become familiar with it. You'll see many examples
throughout this book of different ways to set your options
using this feature.

Figure 2.7

The Toolbox provides access to the mouse and stylus tools.
Each time you select a new tool, the tool options bar changes
to reflect settings for the new tool.
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Understanding panels

The panels in Photoshop are similar to mini-applications with
their own windows, controls, and menus. Photoshop has
many panels, each of which provides its own set of
functionality. You will rely heavily on these panels to do
most of your editing.

Panels tend to take up quite a bit of space in the work area, so
Photoshop provides different display states for them. These
states are expanded, collapsed into an icon, or hidden. To hide
or unhide a panel, select the panel from the Window menu.
Figure 2.8 shows a collapsed panel group as well as an
expanded panel group. To collapse the panel group, click the
Collapse button. To expand a panel in a collapsed group, click
its icon.

Note

You will typically only have a small number of panels that
pertain to your open workflow. This makes finding the
panels you need much easier.

A panel group is one or more panels that are connected to
each other. To add a panel to a group, drag the panel or icon
onto the group. To remove a panel from a group, drag the
panel out of the group. Organizing panel groups is no
different than organizing the items on your desktop. You can
decide which panels go in which groups; if you know where
to find a panel, you can use it much faster.
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Figure 2.8

You can collapse panel groups to icons to reduce their
footprint on the workspace.

The panel groups have the following basic components, as
shown in Figure 2.8:
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• Expanded tabs. These tabs are used to select which panel is
visible in the group and to drag panels out of the group.

• Collapse button. This button collapses the panel to an icon
to reduce its footprint in the work area.

• Expand button. This button expands a collapsed panel from
an icon to provide access to the panel settings.

• Panel controls. This area contains the panel controls that
you use to perform various tasks. Each panel has different
settings.

• Panel menu. This menu pops out of a panel when you click
the menu button in the top-right corner. The panel menus
usually contain additional features that are not included in the
main settings area. If you can't find something, it is probably
in the panel.

• Panel buttons. These buttons are located at the bottom of a
panel, and perform common tasks such as adding or deleting
items.

Another way to organize panel groups is to dock them either
together or to the sides of the Photoshop workspace. You can
dock panel groups by dragging them to the side or bottom of
another group. You can dock them to the side of the
workspace by dragging them until the mouse is on the
workspace edge.

Using workspace presets
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The workspace presets offer quick ways to change the layout
of the panels and tools in Photoshop, depending on the task
you are performing. When you select a preset, the panel
layouts are adjusted so you have easier access to the tools that
you typically use for the selected task. You select a preset by
choosing Window⇒Workspace from the Photoshop menu bar
and selecting one of the options from the drop-down menu:

• What's New. This preset displays icons for panels with new
features in Photoshop, such as the new 3D tools, paintbrushes,
paragraph and character settings, and layer options.

• Essentials. This preset gives you full access to the most
commonly used panels in Photoshop, including the
Navigation, Swatches, and Layers panels.

• Design. This preset displays the most common graphic
design panels, such as the Swatches, Character, and
Paragraph panels.

• Painting. This preset makes the paintbrush and brush
presets readily available.

• Photography. This preset provides the Histogram and
Adjustments panels that make it easy to apply adjustments to
photographs.

• 3D. This preset displays the 3D, Mask, and Layers panels
that are often used when working with 3D objects.

• Motion. This preset displays the Timeline panel and Clone
Source panel, which are frequently used in animation.
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• Reset/New/Delete. These presets take advantage of the fact
that Photoshop remembers when you select a workspace
preset and then adjust the panels, so you don't have to readjust
them each time you start the application. The Reset option
restores the currently selected workspace to the original
settings, so you can start over with a fresh set of panels. The
New option allows you to save the current panel layout as
your own custom workspace. The new workspace then shows
up in the list. The Delete option deletes the currently selected
workspace preset.

Exploring the Photoshop Menu Bar

Now that you are familiar with the Photoshop workspace, you
are ready to explore the Photoshop menu bar. The menus,
along with their keyboard shortcuts, give you access to most
of the features in Photoshop. Throughout the book, we
discuss most of the options contained in the Photoshop menu
bar in more detail. In this section, we show you the primary
purpose of each menu and highlight some of the menu options
that we may not cover in other areas of this book.

Using the File menu

The File menu has many of the options that you would
expect, and many of them are self-explanatory. Most of the
options in this menu offer different ways to open, save, or
export your documents. The first task that you will be
performing in Photoshop is opening or creating a document,
so you will first need to become familiar with the File menu.

The options in the File menu, shown in Figure 2.9, are
covered throughout this book. We cover opening and saving
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files in Chapter 3, exporting to the web and mobile devices in
Chapter 30, and batch operations on files in Chapter 31.

Exploring the Edit menu

The Edit menu is a familiar feature found in most
applications, with many recognizable options such as cut,
copy, and paste as well as additional options that are specific
to Photoshop. This menu is important for modifying the
document and workspace settings.

Figure 2.9

The File menu in Photoshop provides several options to open,
save, and export files.
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Using the Edit menu, shown in Figure 2.10, you can step
backward, undoing several of the most recent changes you
made. Farther down the menu, you find the transformation
edits, Content-Aware Scale and Puppet Warp among them;
we cover these options in Chapter 19. You learn about using
color in Chapter 4 and color profiles in Chapter 29. We cover
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setting preferences and using the menu and shortcut options
to customize menu and shortcut behavior later in this chapter.

Note

On Macs, the Preferences and Quit options are found under
the Photoshop menu option on the left side of the Photoshop
menu bar.

Figure 2.10

The Edit menu in Photoshop provides several options to
modify document and workspace settings.
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Using the Image menu

The Image menu is loaded with options for changing your
image. Making changes to your image is different from
making changes to your file, because these options actually
affect the look of your image.

Among other things, the options in your Image menu, shown
in Figure 2.11, allow you to change the color mode, and
resize, rotate, or duplicate your image. Neatly tucked into the
Adjustments submenu, you find some of the most powerful
tools for correcting the color and lighting of your image; we
cover these tools in Chapter 13. The Apply Image and
Calculations options blend the channels of your image, and
we cover these options in Chapter 11. Image variables and
data sets allow you to create multiple images with similar
components by defining and replacing layers. We cover these
options in more detail in Chapter 10.

Figure 2.11

The Image menu in Photoshop provides several adjustment
options to modify images.
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The Image menu also provides an important submenu, shown
in Figure 2.11, titled Analysis. The Analysis submenu is all
about measuring and, of course, analyzing areas in your
document. You can customize the tools found here for your
own use to measure, scale, and mark your images. You can
choose from six menu options. We don't list them in the order
they appear in the Analysis submenu because they make more
sense in the order listed here.
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Ruler Tool

The Ruler tool is simply a tool that allows you to drag from
one area in your image to another and measure it. The
measurement information appears in the Info panel. By
default, the measurement is in pixels. The Ruler tool plays an
important role in the other options found in the Analysis
submenu.

Count Tool

Selecting the Count tool and clicking your document leaves a
number behind, in increments of one. This allows you to
count and mark multiple items in your image. If you were
trying to count a flock of birds, for example, you would click
each bird until you had marked all of them. The last number
you placed would be the number of birds in the photo.

Record Measurements

Clicking Record Measurements opens the Measurement Log
panel on the bottom of your document window, as shown in
Figure 2.12. As you create measurements, you click the
Record Measurements button on the Measurement Log panel
and Photoshop records the measurement details. Notice that
the measurements were taken by the Ruler tool, and the
second measurement is taken by the Count tool.

You can also use the Measurement Log to export these
measurements. Simply click the Export icon to export the
measurements as a text file to any specified location. You can
also access the Measurement Log menu by clicking the menu
icon.
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Figure 2.12

The Measurement Log panel allows you to record and display
measurements you have taken within your document.

Set Measurement Scale

You can set the measurement scale to Default, which simply
means that one pixel is equal to one inch. If you choose the
custom option, however, it allows you to translate a set
number of pixels in your document to any other measurement
you prefer.

For example, in Figure 2.13, if you know the height of the
bottom-right window pane is 20 inches, you can choose
Image⇒Analysis⇒Set Measurement Scale⇒Custom to open
the Measurement Scale dialog box. The Measurement Scale
dialog box automatically activates the Ruler tool so you can
measure from the bottom to the top of the window pane. In
the photo, this measurement is 10 pixels, shown as the pixel
length in Figure 2.13. From here, you can enter any relative
measurement that you choose — in this case, 144 inches. You
could have just as easily entered 1 foot, 3 meters, or 7 girth
units. You can save this measurement scale by clicking Save
Preset and naming it.
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After closing the Measurement Scale dialog box, you can
activate the Ruler tool and measure other areas of the photo.
Photoshop records these measurements in the Measurement
Log panel. Notice that the third measurement in Figure 2.12
was taken after the Measurement Scale was set. The scale
indicates that 10 pixels = 10 144; the scale unit is inches and
the length is 10 (rounded up, of course).

Figure 2.13

Placing a scale marker in your image allows you to clearly
see the scale of the image.
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Select Data Points

The Measurement Log shows data on each measurement you
record. You can choose what data to keep and display by
selecting specific data points. Choose Image⇒Analysis ?
Select Data Points⇒Custom to display the Select Data Points
dialog box. In this dialog box, you can deselect the types of
information that you don't want Photoshop to record. For
example, if you don't require date and time information, you
can deselect the check box next to Date and Time. Every
measurement you take after this point no longer displays the
date and time in the Measurement Log panel.

Place Scale Marker

You can place a scale marker in your image to denote scale.
To place a scale marker, choose Place Scale Marker from the
Analysis submenu to open the Measurement Scale dialog box,
shown in Figure 2.13. You can choose the length of the scale
by selecting more than one unit of measurement.

Refer to Figure 2.13, which shows a scale marker indicating
that the unit of measurement represents the 10 inches that was
set for the measurement scale. If you were to change the
number from 1 to 2, your scale marker would appear twice as
long and would be labeled 20 inches. You can also choose to
display the text and what font and size that text will be.
Finally, you have the choice to display the scale marker at the
top or bottom of your document and in black or white.

Understanding the Layer menu
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The Layer menu is built specifically for use with the Layers
panel. Layers are an important part of working efficiently and
non-destructively in Photoshop, and you want to learn all you
can about how they work.

Layers allow you to make modifications to a document on a
separate layer from the original pixels. This allows you to
easily remove the changes, turn the changes off, or even stack
different adjustments and reorder them. The Layer menu,
shown in Figure 2.14, allows you to manage the layers in a
document. We cover layers and the Layer menu extensively
in Chapter 10.

Figure 2.14

The Layer menu in Photoshop provides several options to
control the behavior of layers.
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Examining the Type menu

The Type menu is built specifically for use with the Type
tools. Using the Type menu gives you quick access to options
such as opening the type panels, modifying size and
orientation, and extruding type to 3D.
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In addition, the Type menu, shown in Figure 2.15, allows you
to modify type layers by rasterizing them, to convert them to
shape layers, or to warp them. You can also specify which
language to use for the fonts as long as the selected fonts
support that language.

Figure 2.15

The Type menu in Photoshop provides several options to
interact with text in your documents.

Using the Select menu

Although you might not think that an entire menu could be
dedicated to selections, they are such an integral part of many
workflows in Photoshop that a selection menu is critical. The
selection tools are some of the most powerful in Photoshop.

113



They allow you to create masks, cut precise areas out of an
image, and edit only specific parts of the image.

The Select menu, shown in Figure 2.16, gives you control
over the selections. For example, you can use the Select menu
to select everything or deselect everything. You can also use
the selection tools to access dialog boxes to modify an
existing selection. The Toolbox contains several selection
tools, and we cover them, along with the Select menu, in
Chapter 9.

Figure 2.16

The Select menu in Photoshop provides several options to
manage selections.

Exploring the Filter menu
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You place filters over images to change their appearance. You
can choose from corrective filters such as Sharpen and
Reduce Noise, and also special effects filters that can make
your image look like it is being viewed through rippled glass
or embossed into chrome. Filters are definitely the fun side of
Photoshop.

The Filter menu, shown in Figure 2.17, provides a list of
several different filters that you can directly apply to an
image. It also provides access to the Filter Gallery, which
provides many more filters. You will learn more about filters
and the Filter Gallery, as well as how to use them and their
menu options, in Chapters 14 and 20.

Figure 2.17

The Filter menu in Photoshop provides several filtering
options that you can apply to images.
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Understanding the 3D menu

The 3D menu is packed full of goodies for helping you work
in the 3D environment. The 3D environment allows you to
bring in 3D models and use the powerful Photoshop tools to
make incredible changes to their appearance.

The 3D menu, shown in Figure 2.18, allows you to create and
export 3D layers. It also provides access to several 3D
utilities that allow you to perform tasks such as creating 3D
extrusions and setting paint falloff. We cover the 3D menu in
Chapter 22.

Figure 2.18
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The 3D menu in Photoshop provides access to several 3D
options and tools.

Using the View menu

The View menu functions as a catchall for everything that has
to do with displaying documents in the Photoshop work area.
Understanding this menu can be a great asset because it
provides access to a plethora of tools, such as rulers and grids,
that can enhance your workflow.

As shown in Figure 2.19, the View menu offers basic options
for adjusting the view of your document, such as its size (fit
on screen, 100%, print size, and so on) and screen mode (full
screen, full screen with menus, and standard screen), which
we discuss earlier in this chapter.
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Figure 2.19

The View menu in Photoshop allows you to customize how
documents appear in the Photoshop workspace.

Proof Options

The proof options let you soft-proof your documents before
printing; we cover these settings in more detail in Chapter 29.
Options for setting pixel aspect ratios are available as well;
you use these settings with video files, and we cover them in
Chapter 25.
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Extras and Show

You may find it interesting that the Extras option allows you
to see non-printing guides such as selections, bounding boxes,
and grids. If you deselect the Extras option, any of these items
that are visible in your document disappear.

The Show submenu lets you customize which non-printing
items are visible when you select Extras in the View menu.
The following is a list of some of the features that you can
enable using the Show submenu (refer to Figure 2.19):

• Layer Edges. This option places a bounding box around the
edge of the currently selected layer.

• Selection Edges. This option shows marching ants around
the selection. This is on by default when you make a
selection. However, you can toggle it on and off afterwards.

• Target Path. This option toggles displaying the target path
on and off.

• Grid. This option places a mesh of vertical and horizontal
lines, shown in Figure 2.20, that you can use to see the
alignment and organization of objects more easily in your
images. Photoshop also divides the grids into subdivisions of
lines that are less visible.

A great feature of Photoshop is that you can force items to
snap to grids by choosing View⇒Snap To⇒Grid from the
Photoshop menu bar. This option is useful when placing
images, text, and shapes in a document. You can configure
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the number of grid lines, colors, and styles in the Preferences
dialog box, which we discuss later in this chapter.

Figure 2.20

The guides, grids, and rulers features of Photoshop allow you
to better organize and align objects in your images.

• Guides. This option helps you with object placement and
organization. Guides are vertical or horizontal lines that you
can add to a document by choosing View ? New Guide from
the Photoshop menu bar. You can force items to snap to
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guides by choosing View⇒Snap To⇒Guides. You can adjust
the position of guides in the image by using the Move tool.

Tip

When you click and hold the mouse button on the ruler, the
cursor changes to a guide adjustment cursor. You can
quickly add guides to an image by clicking the ruler and
dragging them into the document.

• Smart Guides. This option toggles the viewing of smart
guides on and off.

• Slices. This option toggles the slice overlay on and off.
Chapter 30 discusses slices in more detail as part of preparing
images for the web.

• Notes. This option toggles the display of notes you have
added to the document on and off.

• Pixel Grid. This option toggles the display of the pixel grid
on and off.

• 3D elements. These options toggle the display of some of
the 3D elements on and off, such as cameras and lights. We
discuss 3D in more detail in Chapters 22 to 24.

• Brush Preview. This option toggles the brush preview for
the bristle and erodible tip brushes. We discuss these brush
tips, as well as the preview, in Chapter 16.
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• Mesh. This option toggles the display of the mesh on and
off when using the Puppet Warp tool. We discuss the Puppet
Warp tool in Chapter 19.

• Edit Pins. This option toggles the display of edit pins on
and off when using the Puppet Warp tool. We discuss the
Puppet Warp tool in Chapter 19.

Rulers

Select the Ruler option if you want rulers to appear in your
document window. When rulers are enabled, Photoshop
displays a vertical ruler on the left and a horizontal ruler on
the top of the document window (refer to Figure 2.20).

The rulers start at zero in the upper-left corner of your
document and measure the actual print size of your document.
You can change the rulers' unit of measure by right-clicking a
ruler and selecting the unit from the shortcut menu. While
you are moving the cursor over the documents, the exact
placement of the cursor is indicated in the ruler by a line that
moves with the mouse.

Snap and Snap To

As you move things around in your work area, whether they
are selections, panels, or objects, you can choose to have
them snap to the guides or to other objects. For example, as
you customize your panels, they snap together so you can
easily place them next to each other without space between
them or overlaps.
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The Snap To option lets you choose what elements your
objects snap to: guides, grids, layers, and so on. The elements
that have a check mark draw objects you are moving like a
magnet. If you want to place elements without the guides
snapping them one way or the other, just deselect Snap in the
View menu to regain full control.

New Guide, Lock Guides, and Clear Guides

The line under text and the bounding box around a placement
in your document are guides that help you see and move these
objects. You can make your own guides to help you with
placement and alignment in your document. Choose
View⇒New Guide, and select whether you want the guide to
run vertically or horizontally and where you want to place it
in your image. The New Guide dialog box asks you how
many inches into your image you want to place the guide, so
it's helpful to have the rulers on. You can also indicate the
position of the guide as a percentage rather than a specific
measurement.

You can lock these guides so you don't accidentally move
them by choosing Lock Guides. You can also clear them out
of the way entirely by choosing Clear Guides.

Lock Slices and Clear Slices

The Lock Slices option allows you to lock slices to prevent
them from being altered, and the Clear Slices option allows
you to clear the existing slices so you can easily clean them
up. Chapter 30 discusses slices in more detail as part of
preparing images for the web.
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Exploring the Window menu

The Window menu has three main purposes in Photoshop:
first, it provides access to the Arrange and Workspace
submenus that we talk about earlier in this chapter; second, it
provides a list of the available panels that you can toggle on
and off; and finally, it provides a list of open documents that
you can use to select a specific document so that it becomes
active.

One of the best and most common uses of the Window menu,
shown in Figure 2.21, is to toggle panels on and off. The
Window menu provides a comprehensive list of the panels
that are available to you. From this menu, you can select the
panels that you want to be visible. When a panel is visible, a
check mark appears next to it. Deselecting a visible panel in
the menu hides the panel; selecting a hidden panel makes the
panel visible. We discuss the different panels later in this
chapter.

Using the Help menu

The Help menu contains information about the Photoshop
version that you are currently running, as well as links to
online help for Photoshop. You can also use the Help menu to
see which plug-ins are installed.

Note

On a Mac, the About and Plug-in menu options are in the
Photoshop menu item on the left side of the Photoshop menu
bar.
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Figure 2.21

The Window menu in Photoshop allows you to configure the
workspace by defining the arrangement of documents and
specifying which panels are visible.

The Help menu, shown in Figure 2.22, contains web links to
various sites that Adobe thinks may interest you, such as the
Photoshop Support Center and Photoshop Online. You can
also use the Help menu to register sign in and out of your
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Creative Cloud account and update your version of
Photoshop, as well as sign in and out of your Creative Cloud
account. The two menu options worth noting are Photoshop
Help and Sign In/Sign Out.

Photoshop Help

Photoshop Help is a great resource if you have trouble
figuring something out. Click the Help link to go to the
Photoshop Help website, where you can browse through the
Help contents, search the Adobe Help resources, or even view
articles and threads from others who are looking for or
offering help.

Figure 2.22

The Help menu in Photoshop provides access to online help
for Photoshop.

Sign In/Sign Out

The Sign In help option allows you to login to your Adobe
account to receive updates and synchronize with the Creative
Cloud. The Sign Out option allows you to logout of your

126



Creative Cloud account. This is a very useful feature if you
share your computer with someone else.

Caution

The Deactivate menu option is absolutely imperative for you
to know if the Adobe anti-piracy policy lockout becomes a
problem, or if you are restructuring your system or
purchasing a new computer. In order to reinstall Photoshop
on a new system, or if you need to replace the hard drive,
you need to deactivate Photoshop. Go to the Help menu and
choose Deactivate. Doing so allows you to activate your
software the next time you install it.

Exploring Panels

The panels in Photoshop are mini-applications with their own
windows, controls, and menus. You will rely heavily on the
Photoshop panels to do most of your editing. Photoshop has
many panels, each of which provides its own set of
functionality. The functionality of some panels is limited,
while other panels are almost separate applications. We
discuss each of the panels in detail throughout this book as we
cover the features that they are used for. The purpose of this
section is to familiarize you with the panels that are available.
Figure 2.23 shows the icons for each of the panels.

Figure 2.23
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Photoshop provides several panels that act as individual
utilities. You can view these panels by selecting them from
the Window menu or clicking their icons.

As a quick guide, the following list describes the icons for
each of the panels and where we cover them in this book:

• Swatches. Provides a simple way to manage sets of colors
that you use in different documents. See Chapter 4.

• Color. Allows you to quickly select any color in the
possible ranges that Photoshop supports. See Chapter 4.

• Styles. Allows you to manage the style sets that can be
applied by various tools when painting or applying filters. See
Chapters 10 and 16.
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• Brush. Provides a robust interface that allows you to define
different types of brush qualities and behaviors that are used
by Brush tools. See Chapter 16.

• Brush Presets. Allows you to easily manage sets of brushes
that can be used by the various Brush tools. See Chapter 16.

• Clone Source. Provides a dynamic interface to control the
source used by the Clone tools to heal areas of photos and
remove unwanted items. See Chapter 15.

• Timeline. Provides a timeline-based utility that adds
animation to images. See Chapter 26.

• Character. Provides options to quickly format character
styles, fonts, and spacing of textual elements in images. See
Chapter 18.

• Paragraph. Provides options to quickly format paragraph
styles and spacing of textual elements in images. See Chapter
18.

• Paragraph Styles. Allows you to create and save paragraph
style settings that enable you to keep text consistent between
documents. See Chapter 18.

• Character Styles. Allows you to create and save character
style settings that enable you to keep text consistent between
documents. See Chapter 18.

• Tool Presets. Allows you to quickly view and select presets
for the tool that is currently selected in the Toolbox.
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• 3D. Allows you to quickly create, view, and adjust 3D
objects.

• Layers. Allows you to select, create, edit, and manage
layers. This is one of the panels you'll use most often. See
Chapter 10.

• Channels. Allows you to view and manage each of the
different color channels in an image as well as create
additional channels such as alpha channels. See Chapter 11.

• Paths. Allows you to manage and use vector paths in
images. See Chapter 17.

• Histogram. Provides a simple-to-understand view of the
overall distribution of color and levels in an image. See
Chapter 4.

• Info. Allows you to view color and other information about
individual pixels in the image by hovering the mouse over
them. See Chapter 4.

• Layer Comps. Allows you to easily create, manage, and
view multiple versions of a layout in a single Photoshop file.
See Chapter 10.

• Adjustments. Allows you to apply several adjustments to a
layer in an image. See Chapters 10 and 13.

• Properties. Provides an additional interface with properties
pertaining to other panels, such as adjustments. This has
replaced the Masks panel where you create and control
masks. See Chapter 10.
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• Navigator. Provides a simple interface that allows you to
quickly zoom in on areas of an image. The interface includes
a slider control at the bottom that zooms in on the image. It
also displays a miniature version of the image with a red
rectangle that you can move to pan to a specific area of the
image, as shown in Figure 2.24.

• Actions. Allows you to record and then reapply a series of
commands that perform common tasks such as applying filter
settings. See Chapter 5.

• History. Provides access to the history states of a document
that are recorded each time you change the document. See
Chapter 5.

Figure 2.24

The Navigator panel allows you to quickly zoom in on the
image in the document window and then pan to specific
locations.

• Measurement Log. Keeps track of measurements, as we
discuss earlier in this chapter.
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• Notes. Allows you to view and manage notes that you create
with the Note tool. We discuss the Notes feature later in this
chapter.

Understanding the Tools in the Toolbox

The Toolbox provides easy access to all the tools that you use
to interact directly with pixels in the document window. To
enable or disable the Toolbox, choose Window⇒Tools from
the Photoshop menu bar.

You can expand most of the tools in the Toolbox by pressing
and holding the mouse button over them to reveal several
other tools. Figure 2.25 shows the expanded menus of the
Toolbox. From the expanded tool menus, you can select other
tools. The icon of the currently selected tool appears in the
Toolbox, and the cursor changes to reflect the current tool as
well.

Note

As you select different tools in the Toolbox, the Options bar
changes to reflect specific options for these tools. The
settings in the Options bar define the behavior of the
selected tool in the Toolbox and extend the tool's
capabilities. When you change a tool's settings and then use
other tools, the settings for that tool remain the same when
you return to it.

Figure 2.25
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Photoshop provides several tool sets in the Toolbox, and you
can expand the tool sets to reveal additional tools.

Just as with panels, we cover the tools in the Toolbox
throughout this book. The purpose of this section is to
familiarize you with the organization of the Toolbox and what
kinds of tools you can find there.
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Tip

A great feature in Photoshop is the ability to quickly select
and even temporarily switch tools on the fly. In many of the
tool sets, you see a letter on the right side of the tooltip.
Pressing that letter on the keyboard selects that tool set.
Pressing and holding the Shift key while pressing the letter
toggles through the different tools in the tool set. You can
temporarily switch tools by pressing and holding the letter
key for the tool while you use it, and when you release the
key, Photoshop reverts to the original tool. For example, if
you press and hold the V key when another tool is selected,
Photoshop temporarily changes to the Move tool and you
can move objects. When you are finished moving items,
release the V key and the tool reverts to the original tool.

The following list briefly describes each of the tool sets in the
Toolbox, as well as where you can find more information
about them in this book:

• Move tool. This is the only tool that allows you to move
items in the document window. It allows you to move several
items, including guides, objects and shapes in shape layers,
and text objects.

• Shape Selection tools. These tools allow you to quickly
select areas of the document using rectangle, ellipse, row, and
column shapes. See Chapter 9.
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• Lasso selection tools. These tools allow you to quickly
select areas of the document by using the mouse to draw a
lasso around them. See Chapter 9.

• Quick Selection tools. These tools can intelligently select
areas of the document by detecting areas that are similar to
those selected by the mouse. See Chapter 9.

• Crop/Slice tools. The Crop tool lets you select an area of
the document to keep and remove the area around it. See
Chapter 3. The Slice tools allow you to create clickable hot
areas for web images. See Chapter 30.

• Eyedropper/Ruler/Note/Count tools. This tool set is a
catchall. The Eyedropper tool allows you to select foreground
colors directly from pixels in the image. See Chapter 4. The
Ruler tool enables you to measure areas in an image. The
Note tool allows you to add notes to an image that help you
retain information, such as to-do editing lists with the image.
The Count tool allows you to count and log items in the
image, which can be useful if you are working with medical
images. We discuss the Ruler, Note, and Count tools earlier in
the menus section of this chapter.

• Healing tools. These tools provide quick ways to apply
brush strokes that can heal areas of an image, from removing
dust and scratches to removing red eye. See Chapter 15.

• Brush tools. These tools allow you to apply painting
techniques to repair, enhance, and create images. See Chapter
16.
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• Stamp tools. These tools include the Clone Stamp and
Pattern Stamp. The Clone Stamp tool allows you to select an
area of the image and then stamp or brush that area into other
parts of the image or even other documents. See Chapter 15.
The Pattern Stamp tool allows you to apply a style pattern to
an image using brush strokes. See Chapter 16.

• Eraser tools. These tools allow you to quickly remove pixel
data from an image. See Chapter 16.

• History Brush tools. These tools enable you to repair and
enhance areas of an image by painting data from previous
editing states of the image. For example, you could change
the image to grayscale and then use brush strokes to add color
to specific areas. See Chapter 5.

• Blur/Sharpen/Smudge tools. The Blur and Sharpen tools
allow you to use brush strokes to blur or sharpen specific
areas of an image. The Smudge tool allows you to use brush
strokes to smudge existing pixels into each other. See Chapter
16.

• Gradient/Paint Bucket tools. The Gradient tool allows you
to paint a gradient pattern onto an image. The Paint Bucket
tool allows you to apply a paint color to sections of an image.
See Chapter 16.

• Dodge/Burn/Sponge tools. The Dodge and Burn tools
allow you to use brush strokes to lighten or darken areas of an
image. The Sponge tool allows you to use brush strokes to
remove or add color saturation in areas of an image. See
Chapter 16.
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• Path creation tools. These tools allow you to create vector
paths by creating lines between anchor points. See Chapter
17.

• Path Selection tools. These tools allow you to select and
manipulate vector paths by adjusting the anchor points. See
Chapter 17.

• Text tools. These tools allow you to add textual elements to
images. See Chapter 18.

• Shape tools. These tools enable you to create and
manipulate simple geometric vector shapes and lines as well
as custom vector shapes. See Chapter 17.

• Hand/Rotate View tools. The Hand tool enables you to
grab onto the image and pan by dragging the mouse. This
feature is available only when you zoom in on an image, but
it's very useful for navigating around the image. The Rotate
View tool allows you to rotate the canvas in the document
window by dragging with the mouse. If you press and hold
the Shift key while rotating the canvas, the rotation occurs in
15-degree increments. Rotating the canvas can be useful if
you need to align elements in the image with the vertical or
horizontal axis of the display screen for editing.

• Zoom tool. This tool allows you to use the mouse to drag a
specific rectangle to zoom in on the image. You can also
zoom in at 100-percent increments by simply clicking the
document with the mouse. You can zoom out at 100-percent
increments by pressing and holding the Shift key while
clicking the document. The Options bar for the Zoom tool
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provides several buttons to resize the document view based
on actual pixels, print size, and screen size.

If you have OpenCL Drawing enabled, then you can use the
Scrubby Zoom option in the Zoom tool Options bar. When
you enable Scrubby Zoom, you can click and drag the mouse
to the left and right on the image to zoom in and out.

• Background/Foreground colors. This section of the
Toolbox allows you to see and modify the current background
and foreground colors. The foreground color is used by
several tools to paint onto an image. The background color is
used by several tools when removing pixels from an image.
See Chapter 4.

Tip

Pressing D on the keyboard resets the foreground and
background colors to black and white, respectively. Pressing
X on the keyboard swaps the foreground and background
colors.

The foreground is represented by the front square, and the
background by the back square. You can change the color of
each square by clicking the square to launch a color chooser.
You can switch the two colors by clicking the curved line
with arrows on each end. To revert to the default colors of
black and white, click the small black-and-white icon.

• Edit in Quick Mask mode. This option toggles between
Normal and Quick Mask mode. The Edit in Quick Mask
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mode option allows you to tweak selections using the Brush
tool to paint the exact mask shape. See Chapter 9.

• Screen Mode selector. This option allows you to quickly
toggle between Standard, Full Screen, and Full Screen with
Menu Bar modes.

Tip

You can activate the Quick Mask mode by pressing Q on
the keyboard whenever you have an active selection in the
document.

Configuring Presets

As you become more familiar with the options that are
available for different tool panels in Photoshop, you realize
that it takes a while to optimize some tool settings and panels
for what you need them to do. If you have to do that over and
over, it can become time consuming. That's where presets
come into play.

A preset is simply a collection of saved settings that you can
easily reload to make a tool behave the exact same way each
time it uses the preset. Presets are organized into sets that you
can load for each tool or panel and then easily select. You
will work with presets throughout this book, but this section
is designed to familiarize you with what presets are and the
tools that you use to select and manage them.

Selecting tool presets
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The simplest way to select tool presets is from the Tool Preset
menu option found in every tool options bar, as shown in
Figure 2.26. For the Crop tool, you see presets for each of the
standard photo sizes. Selecting one of the presets configures
the Crop tool to crop the image to the specific size without
your having to change the settings manually.

Figure 2.26

The Presets option in the Options bar allows you to quickly
configure settings for the tool by selecting a preset from a list
of tool configurations.
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From the Tool Preset menu shown in Figure 2.26, you have
the following options:

• Preset list. Displays a list of presets. When you select an
item from the list, the options in the tool are set to the values
that are stored in the preset.

• Current Tool Only. Displays only presets that pertain to
the current tool when you check this box.
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• New Tool Preset button. Enables you to store the current
tool settings as a preset when you click this button. The new
preset appears in the preset list.

• Rename Tool Preset. Allows you to change the display
name of a tool preset so that you can refer to it more easily.
You may end up adding several new presets, so you should
keep the names specific.

• Delete Tool Preset. Removes the selected tool preset from
the list.

• Sort by Tool. Sorts the preset list by tool rather than
alphabetically when you select this option.

• Show All Tool Presets. Displays all available tool presets in
the Preset list when you select this option. This is useful to
switch between tools without selecting them from the
Toolbox.

• Show Current Tool Presets. Displays the tool presets for
only the currently active tool when you select this option. If
you have a lot of tool presets, then you may want to check
this item so that they are easier to find.

• Display options. Allow you to display the list as text only,
or to include small or large tool icons in a list.

• Reset Tool. Resets the settings of the current tool to the
default Photoshop values.

• Reset All Tools. Resets all tools to the default Photoshop
values.
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• Preset Manager. Launches the Preset Manager, which we
discuss in the next section.

• Reset Tool Presets. Resets the current list of tool presets to
the stored values. This allows you to discard any changes you
have made and go back to the last time you saved them.

• Load Tool Presets. Loads a set of tool presets that you have
previously saved.

• Save Tool Presets. Saves the current tool presets to disk for
later retrieval.

• Replace Tool Presets. Replaces the current tool presets
with one that you have stored on disk.

• Preconfigured Presets list. Lists preconfigured presets. For
example, the Airbrushes presets contain several brush tip
presets for airbrushing, and the Crop and Marquee presets
contain several presets for the Crop tool.

Note

You can select presets from the Tool Presets panel. If you
deselect the Current Tool Only option, the list in the tool
options bar and in the Tool Presets panel displays all
currently loaded presets instead of just those for the current
tool. Selecting a preset switches to that tool with the
appropriate settings.

Managing presets
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Presets are organized into sets, and each set is saved as a
separate file on the file system. The Preset Manager allows
you to create, load, and manage sets of tool presets. To access
the Preset Manager, choose Edit⇒Preset Manager, or click
the menu icon of the Preset list shown in Figure 2.27 and
click on the Preset Manager Menu button.

The Preset Manager provides the Preset Type option, which
allows you to select the preset types. In addition to tool
presets, it contains presets for paintbrushes, color swatches,
styles, and other features. When you select a different type,
the list of presets changes to reflect the presets for that type.

You can use the mouse to select presets from the list,
including any new ones you have created, and then use the
Save Set button to save the selected presets as a new set. To
load additional presets, click the Load button. When you try
to load a new set, you are prompted to add the set to the
current list or to append the loaded set to the existing list.

Figure 2.27

The Preset Manager allows you to load, save, and manage
presets for Photoshop tools as well as other types of settings
such as brushes, text, and colors.
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Clicking the Preset Manager Menu button loads a menu
similar to the one in Figure 2.27. The menu is different for
each preset type, but they are all organized into the following
sections:

• List options. This option defines how to display the presets.
You can select text only, lists with icons, and different sizes
of icons, depending on the preset type.

• Reset/Replace options. The Reset Tool Presets option
resets the preset list for the selected preset type to the
Photoshop default. This is a must when you begin tweaking
lists and appending sets. The Replace Tool Presets option
allows you to load a preset list from a file on disk and replace
the current preset list.

• Preconfigured presets. Photoshop provides several
preconfigured presets that you can apply to the current set.
The list of preconfigured presets is different for each preset
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type. When you select one of these sets, you are prompted to
either replace the current list or append the new list to the
current list.

Creating presets

When you change a tool's settings in the Options bar,
Photoshop remembers those settings the next time you select
the tool. At times, you will want to quickly toggle between
different customized settings. The best way to do this is to
create presets for each of the custom settings. Creating your
own custom presets saves you valuable time adjusting settings
that you use frequently.

Presets are created differently, depending on what type of
preset you are creating.

Follow these steps to create a new tool preset:

1. Select a tool from the Toolbox.

2. Adjust the settings in the Options bar.

3. Open the Preset list for the tool (refer to Figure 2.26).

4. Click the New Preset button.

5. Enter the name that you want to use for the preset, and
click OK.

This permanently saves the preset in the Preset Manager until
you delete it.

146



Follow these steps to create a custom style preset:

1. Select a layer that is not locked.

2. Click the Add a Layer Style button at the bottom of the
Layers panel and select an option to launch the Layer
Style dialog box.

3. Adjust the options for each effect you want to include in
the preset.

4. Click the New Style button in the Layer Style dialog
box, and name the preset.

Follow these steps to create a custom brush or pattern preset:

1. Select the pixels you want to use to create the brush or
pattern.

We discuss area selections in Chapter 9.

2. Choose Edit⇒Define Brush Preset or Edit⇒Define
Pattern from the Photoshop menu bar.

3. Name the brush or pattern and click OK.

4. Select the Brush tool if you are creating a custom brush
preset.

5. Refine the brush or pattern by adjusting the settings in
the Brushes panel.

Follow these steps to create a custom shape preset:
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1. Create a path.

2. Select the path in the Paths panel.

3. Choose Edit⇒Define Custom Shape from the
Photoshop menu bar.

4. Name the shape preset.

Follow these steps to create a custom color swatch preset:

1. Click the Foreground Color icon in the Toolbox to
launch a Color Picker.

2. Define the custom color.

3. Hover the mouse cursor over a blank area in the
Swatches panel until the cursor changes to a paint bucket.

4. Click to add the color to the swatches.

Note

When you save preset lists, the filename must be saved with
the appropriate file extension. This actually makes the preset
files easy to locate later when Photoshop searches the file
system if you forget where you saved them. Photoshop uses
default extensions for brushes (.abr), color swatches (.aco),
contours (.sch), custom shapes (.csh), gradients (.grd),
patterns (.pat), styles (.asl), and tools (.tpl).

Setting Preferences
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Setting the preferences allows you to work in a customized
environment that feels comfortable to you. Whether you like
to have cursors that are more precise or you want your rulers
to show centimeters instead of inches, you can make a variety
of changes using the Preferences dialog box.

In Windows, the preferences are located under the Edit menu,
so you choose Edit ? Preferences⇒General to open the
Preferences dialog box in the General pane, as shown in
Figure 2.28. (On Macs, they are under the Photoshop CC
menu, so you choose Photoshop⇒Preferences⇒General.) All
the options available in the Preferences menu are also
available in the left pane of the Preferences dialog box, with
the exception of the Camera Raw preferences. Simply click
an option to display the pane you want.

Before you start setting preferences, though, you'll probably
want to know how to restore the Adobe presets, just in case.
To restore all the settings to the Adobe Photoshop defaults,
press and hold the Ctrl+Alt+Shift/ +Option+Shift keys while
you open Photoshop. You are asked if you want to delete the
current settings. You have a second option if you are running
Mac OS: Open the Preferences folder inside the Library
folder, and drag the CS settings to the trash. The folder is
automatically re-created the next time Photoshop starts.

Note

The Library folder in the user's home directory is hidden on
the Mac, so you need to hold down the Option key while
selecting the Go menu to have it appear in the menu.
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Figure 2.28

The Preferences dialog box allows you to customize many of
the settings in Photoshop.

Updating General preferences

The General preferences panel enables you to control
different aspects of the Photoshop environment. This panel
has several basic options that either apply to Photoshop as a
whole or just don't fit well into any other menu. This is the
place to start looking if you need to find a setting that doesn't
directly apply to any of the other preferences panels. From the
General preferences panel, you can set the following options:
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• Color Picker. This drop-down menu allows you to choose a
color picker. When Photoshop operations require you to
choose a color, you choose a new background or foreground
color using the color picker displayed in the Toolbox. A color
picker usually takes the form of a color wheel or a color
palette. The Adobe color picker appears by default, and in
many cases it's the best choice; it was custom designed for
Photoshop, after all. You also have the option to use the
standard color picker for your operating system — OS X or
Windows. For Macs, you can choose from a variety of color
pickers, such as a wheel or a spectrum. At some point, you
may install plug-ins that give you additional color picker
options. They also appear in the Color Picker drop-down
menu.

• HUD Color Picker. This drop-down menu allows you to
define the style of color picker that is used by the HUD
(Heads Up Display).

• Image Interpolation. This drop-down menu allows you to
choose the type of image interpolation you want Photoshop to
use. When you resize, transform, or otherwise manipulate
images, Photoshop adds or removes pixels to make up the
difference. This is called interpolation, and the method of
interpolation determines not only the quality of the resulting
image, but also the speed with which Photoshop processes the
image. Figure 2.29 shows examples of an image of a rose
enlarged five times using each method of interpolation. We
zoomed in so the difference would be much more obvious.

Note
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You can change the image interpolation in the Image Size
dialog box by using a menu that includes all the available
options. The option you set in the preferences becomes the
default option in the Image Size dialog box.

• Nearest Neighbor (preserves hard edges). This option
simply copies the pixels and creates identical pixels next to
them. This is a much faster process, but for obvious reasons,
it creates an image with jagged edges.

• Bi-linear. This option takes the four surrounding pixels and
averages them to create a new pixel. This creates a softer look
than the Nearest Neighbor option, resulting in a smoother
image but at the sacrifice of sharpness.

• Bicubic (best for smooth gradients). This option goes one
better than the Bi-linear option by using the eight surrounding
pixels to create an average. It also creates more contrast
between the pixels, restoring some sharpness to the image.

• Bicubic Smoother (best for enlargement). This option is
designed to create the smoothest possible transition when
enlarging an image. It reduces the jagged edges and overall
“filled-in” look you get when pixels are created to fill in the
gaps of an image.

• Bicubic Sharper (best for reduction). This option uses the
Bicubic method of interpolation and adds a sharpening filter
to further increase the sharpness of the pixels. This option is
best for reducing the image size.
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Note

It should be obvious from reading about image interpolation
that the more you manipulate an image, the more that image
deteriorates. Although some changes are usually necessary
to get the results you desire, be careful how many steps you
take to create those changes. If you want to make an image
smaller, for example, and you reduce it more than you
anticipated, don't just make the reduced image larger. Step
backward and undo the first resize and then try reducing
again. You may also want to check out some of the
third-party plug-ins available on the Adobe Marketplace
website for enlarging images.

Figure 2.29

The image interpolation option affects the quality and look of
the final image.
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• Auto-Update Open Documents. This option tells
Photoshop to automatically check the hard disk for changes
made to any open file, and to update the file to reflect the
saved changes. The best time to use this option is when two
or more collaborators are working on the same file and you
want them to keep up with each other's changes.

• Beep When Done. This option causes Photoshop to beep
whenever it finishes an operation. This is useful if you are
making less obvious changes and want to be sure the
operation is finished, or you're performing more
time-consuming operations and you want to walk away from
your computer while they proceed.

• Dynamic Color Sliders. When you open the Adobe color
picker, you use a color slider to change the range of colors
visible in the color selection box. With Dynamic Color
Sliders turned on, as you move the slider, the box changes
color in real time. The only reason to turn off this option is if
you are using a computer that was built sometime in the last
millennium and it just can't handle the real-time change
without slowing you down.

• Export Clipboard. This option allows you to copy or cut
content from Photoshop and paste it into other applications by
copying the Photoshop clipboard to the operating system's
Clipboard.

• Use Shift Key for Tool Switch. This option allows you to
switch tools by pressing the Shift key and the hotkey. If you
turn this option off, pressing the hotkey more than once
cycles through the available tools. The Toolbox includes “tool
drawers,” where one or more tools hide behind the visible
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icons in the Toolbox. Hotkeys also provide access to these
tools.

• Resize Image During Place. This option resizes a placed
image to fit the destination document into which you are
pasting it. For example, if you are placing a very large file
into an open image that is much smaller, the document resizes
to fit into the smaller canvas area. If you turn this option off,
the larger document may overlap the canvas area, hiding the
entire image. Keep in mind that any resizing compromises the
image quality and should be kept to a minimum if possible.

• Animated Zoom. This option allows you to continuously
zoom with the Zoom tool by pressing and holding the left
mouse button. It's a great way to control how far you want to
zoom in (or out), but be warned: it can be a little slow with
larger files.

• Zoom Resizes Windows. This option works only if you are
using floating windows for each of your documents. These
windows are resized as your images are resized. This
eliminates the white space around images that you have
reduced and keeps the images that you've zoomed into in
view, instead of overlapping the edges of your window. If you
use floating windows a lot, we suggest turning this option on.

• Zoom with Scroll Wheel. This is our personal favorite
zoom preference. With this option activated, you can use the
scroll wheel of your mouse, if it has one, to zoom in and out
of the selected image. No looking around for the Zoom tool or
trying to remember its hotkey; just use the scroll wheel, and
you can take a closer look at that area of your image you are
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trying to get just right and then zoom right back out to fit it in
the screen.

• Zoom Clicked Point to Center. This option extends the
function of the Zoom tool. When you click an area of your
image with the Zoom tool, it zooms into that area generally,
but with the Zoom Point Clicked to Center option turned on,
the area you click becomes the center of the zoomed image.

• Enable Flick Panning. This option enables you to pan
smoothly around an image. You can use the Hand tool to
click the document, drag quickly, and then release the mouse
button, and the document continues to pan just as if you had
flicked it.

• Vary Round Brush Hardness Based on HUD Vertical
Movement. This option affects the Heads Up Display (HUD).
When you select it, vertical movements in the HUD adjust the
hardness of the Round Brush tip instead of the opacity.

• Place or Drag Raster Images as Smart Objects. This
option allows you to drag and place raster images in layers.
Photoshop does this by temporarily converting them to Smart
Objects and then back to raster images. This option can use a
lot of processing power, so you should enable it only if you
are willing to sacrifice some computer speed.

• Snap Vector Tools and Transforms to Pixel Grid. This
option automatically snaps edits done by vector tools and
transforms to the pixel grid.

• History Log. This option lets you keep a log of what editing
you have done to the file using the following settings:
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• Save Log Items To. This option lets you store the history as
metadata inside the actual image file, as a separate text file, or
both. Keeping a log as metadata makes the history data easy
to transfer between systems, but it increases the size of the
file, and you need to remove the history before distributing it
to others.

• Edit Log Items. This option allows you to specify how
detailed the history is. The Sessions Only option records only
the date and time you edit the file in Photoshop. The Concise
option also records the text that appears in the History panel.
The Detailed option also records the commands you used to
edit the file. Obviously, the more detailed the history, the
more the file size grows.

• Reset All Warning Dialogs. This option enables any
warning dialog boxes that have been disabled when you
selected a warning dialog box's “Don't Show Again” option.

Arranging Interface preferences

The Interface preferences pane provides options for you to
configure how the Photoshop workspace looks and performs.
For example, you can specify colors and how panels behave.
The Interface pane, shown in Figure 2.30, allows you to
define the general look of the Photoshop interface, including
windows, panels, and documents, using the following
settings:

Figure 2.30
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The Interface settings in the Preferences dialog box allow you
to define the look and feel of the windows, documents, and
panels in Photoshop.

• Appearance. This section defines the general appearance of
the Photoshop interface by setting the following options:

• Color Theme. This option allows you to select from four
different user interface tonal themes. Each of these themes
sets the menu, Options bar, panel, and document window
background to different levels of gray. This is a great feature
for quickly changing the appearance of the interface, for
example, if you prefer it to be darker.
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• Standard Screen Mode. This option allows you to define
the background color and border of windows when working
in the standard screen mode.

• Full Screen with Menus. This option allows you to define
the background color and border of windows when working
in the full screen with windows mode.

• Full Screen. This option allows you to define the
background color and border of windows when working in
the full screen mode.

• Options. This section defines the behavior of panels and
document windows using the following options:

• Auto-Collapse Iconic Panels. This option controls how
panels behave when you switch between them. When
enabled, panels that you open by clicking the panel icon close
automatically when you click another panel or tool in the
workspace.

• Auto-Show Hidden Panels. This option allows hidden
panels to be displayed when the mouse rolls over them.

• Open Documents as Tabs. This option forces files to open
in tabbed document windows that are docked to the document
workspace. When disabled, files open in a floating document
window.

• Enable Floating Document Window Docking. This option
allows you to dock floating document windows with each
other to make floating document groups that can be controlled
together.
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• Show Channels in Color. This option allows channels to be
displayed in color. By default, channels appear in grayscale
when you view them individually. Displaying the channels in
color can give you a better perspective on the color, but it's
not the best option when trying to determine tonal
adjustments that you need to make to an individual channel.
See Chapter 11 for more information on channels.

• Show Transformation Values. This option allows you to
specify where to display the contextual transformation value
next to the cursor. You can specify never to turn them off or
to display them at the top right, top left, bottom right, or
bottom left of the cursor.

• Restore Default Workspaces. This button resets the
workspace to the default settings. Photoshop keeps track of
the panels that you open and layout changes that you make to
the current workspace. When you open the workspace again,
the panels return to the way you left them.

• Show Menu Colors. This option specifies whether the
colors that you define by choosing Edit⇒Menus or
Window⇒Workspace⇒Keyboard Shortcuts &
Menus⇒Menus are displayed in the menus. The ability to
toggle this option on and off can be useful if the menu colors
are distracting for some of your workflows.

• Show Tool Tips. This option enables a text description of
tools, settings, windows, and panels to appear when you
hover the mouse over these items.
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• Enable Text Drop Shadows. This option enables text on
panels to have a drop shadow. This can make the interface
look cool, but the drop shadow can also be distracting.

• Text. This section allows you to set the language and font
size used for the text in the Photoshop user interface, such as
menus, tools, panels, and so on. You need to restart
Photoshop after changing these settings.

Configuring Sync Settings preferences

The Adobe Creative Cloud enables you to synchronize
settings for Adobe products between the computer systems on
which you are working. The Sync feature enables you to keep
your preferences and tool presets when you are using
Photoshop on different computers or sharing a single
computer with others.

Adobe uses your Creative Cloud account to keep track of the
settings as you change them. When you log into the Creative
Cloud from Photoshop, those settings are applied to the
version of Photoshop you are running. For example, if you
have both a computer at work and a computer at home on
which you use Photoshop, you can synchronize the Photoshop
settings that you create at work to your home computer, and
vice versa. Creative Cloud synchronization is also very useful
if you are sharing your computer with others. You don't have
to share the same settings because each of you can log into
your own Creative Cloud account and synchronize your own
settings. The Sync Settings preferences panel, shown in
Figure 2.31, allows you to configure the following options for
synchronizing your Creative Cloud settings:
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Figure 2.31

The Sync Settings options in the Preferences dialog box allow
you to see the last time the account was synced and define
what settings you want to synchronize through your Creative
Cloud account.

• Signed in as. This section shows which Adobe account you
are logged in from.

• Last Sync. This field shows the last time the account was
synced, so that you can see if your settings are current.

• Sync Settings. This option allows you to disable and enable
syncing of settings through the Creative Cloud, including
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Preferences, Swatches, Custom Shapes, Tool Presets,
Actions, Styles, Patterns, Brushes, Gradients, and Contours.

• When Conflicts Occur. This option allows you to specify
how Photoshop resolves conflicts. It is possible for conflicts
to occur when synchronizing. For example, you may change
the same tool preset on your work and home computer before
the changes have been synced together. When Photoshop runs
into a conflict, it has to choose to keep the setting on the local
computer or the remote computer. You can choose from the
following conflict resolutions:

• Always Ask. Photoshop prompts you to keep the local
setting or the remote setting.

• Keep Local Settings. Photoshop always keeps the local
settings. I use this option on my main machine to ensure that
the changes I make there are not overwritten.

• Keep Remote Settings. Photoshop applies the settings
coming in from the cloud rather than the current settings on
the local computer.

Setting File Handling preferences

You can use the File Handling preferences to configure
options for saving files, such as background saves, auto
recovery, and file compatibility. The File Handling
preferences pane, shown in Figure 2.32, provides the
following settings to define how Photoshop saves files:

Figure 2.32
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The File Handling settings in the Preferences dialog box
allow you to configure options such as compatibility settings
for when you save files.

• File Saving Options. These options control the following
behavior when saving files:

• Image Previews. This option controls whether to save the
preview thumbnail data to a file when you save the image.
Options are Never Save, Always Save, or Ask When Saving.

• File Extension. This option allows you to specify whether
to save the extension in uppercase or lowercase format.
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• Save As to Original Folder. This option causes Photoshop
to default to the original folder the file was opened from when
you choose File⇒Save As.

• Save in Background. This option saves images in the
background rather than asking you to wait. This can be
extremely useful when you are trying to work with large
images. You can save them and go back to working on them
while Photoshop saves them to disk.

• Automatically Save Recovery Information Every. This
option saves recovery information necessary to restore files in
case a serious computer problem forces Photoshop to shut
down. This is a great feature, but it also affects performance
while the current file recovery data is being saved, especially
if you have several files open. If Photoshop or your computer
does crash, the files that were open are opened again with
‘recovery' in the filename, and you have the option of saving
any work that you lost before the last recovery save. The
default interval is 10 minutes; however, you can change this
value to suit your needs.

• File Compatibility. These options provide the following
settings for file compatibility when saving files:

• Camera Raw Preferences. This button launches a dialog
box where you can set Camera Raw preferences. See Chapter
7 for more information about Camera Raw settings.

• Prefer Adobe Camera Raw for Supported Raw Files.
This option causes Camera Raw files to be opened by Adobe
Camera Raw instead of other applications, including
Photoshop.

166



• Use Adobe Camera Raw to Convert Documents from 32
Bit to 16/8 Bit. This option tells Photoshop to use Camera
Raw when converting a document from 32 bits to 16 or 8 bits.
This will take more time but will usually provide a better
overall result.

• Ignore EXIF Profile Tag. This option can help you to
determine whether your camera has faulty color data. EXIF
information is data about a photo that your digital camera
embeds when you take the photo. Cameras typically embed
color profile data with the image to help ensure color
correctness. However, if the camera has faulty color data, the
image may not look as good as it should.

If your photos from a particular camera aren't
looking quite right, select this option and see if they look
better. If not, you may need to deselect this option for images
taken with that camera. You may also try assigning a different
color profile to the image, as we talk about in Chapter 29.

• Ignore Rotation Metadata. This option controls whether
rotational metadata from the file will be imported into
Photoshop and used to render the document.

• Ask Before Saving Layered TIFF Files. This option
prompts you, before layers are saved in a TIFF file, to
confirm that you don't want to flatten the file. We recommend
keeping the TIFF layers because it is the best way to keep the
file in an editable state with the full range of data. However,
saving layers in the TIFF file may result in a much larger file
size, and some applications that support TIFFs do not support
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layers. Keep this setting on, just as a reminder when saving
TIFF files.

• Disable Compression of PSD and PSB Files. This option
disables Photoshop from compressing PSD or PSB files. This
increases the compatibility and slightly improves quality in
certain settings; however, it also increases the size of the file
on disk.

• Maximize PSD and PSB File Compatibility. This option
controls whether Photoshop tries to maximize the PSD
compatibility between older versions of Photoshop when you
save an image. Options are Never, Always, or Ask.
Maximizing compatibility is good, but it comes at the cost of
greater file size. This preference defaults to Ask, but if you
know that you will never use an older version of Photoshop,
disabling it saves you an extra mouse click.

• Enable Adobe Drive. This option enables Adobe Version
Cue through Adobe Drive, which manages file versions when
multiple people need to work on the same files. Version Cue
can track changes to a file as different people work on it. You
should only enable this option if you are using Version Cue.

• Recent File List Contains. This option specifies the
number of files to show in the File⇒Open Recent File list.
You may want to change the number of files based on the
type of project that you are working on.

Adjusting Performance preferences

The Performance preferences pane in Photoshop provides
options that allow you to configure settings that can help it
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perform better. Photoshop is a very memory- and
disk-intensive application and as such, the better you adjust
the performance, the faster it can perform complex operations
such as Puppet Warp and Liquify. You can adjust several
settings in Photoshop, such as scratch disks, memory usage,
and graphics processing, to improve its performance. The
Performance preferences pane, shown in Figure 2.33,
provides the following settings to improve some of the
performance-intensive features in Photoshop:

Figure 2.33

The Performance settings in the Preferences dialog box allow
you to limit Photoshop so it does not consume resources on
your system.

• Memory Usage. This section defines how much system
memory Photoshop is allowed to consume. It displays the
current system memory and gives a suggested range. The
slider and text box define the maximum amount of RAM
Photoshop is allowed to use. Processing images is very CPU-
and RAM-intensive. The more RAM you allow Photoshop to
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consume, the faster it performs; however, less memory is
available for other applications.

Caution

Allowing Photoshop to consume too much memory can lead
to extremely poor system performance that affects all
applications, even Photoshop. This is one case where more
is not necessarily better.

• Scratch Disks. This section displays a list of devices that
you can select for scratch disks. Photoshop uses scratch disks
to cache data not currently being used when it is processing
data that requires more memory than the system has available.

Tip

You get the best performance when working with Photoshop
if you use three separate disk drives to store the Photoshop
application, scratch data, and image files. This is because
the disks can be seeking the three types of data at the same
time. Keep in mind that putting three USB disks on the same
hub will create a bottleneck that actually degrades
performance in some cases.

• History & Cache. This section defines settings for
document caching and history retention that can improve how
Photoshop performs. You have the following choices:
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• Optimize buttons. These three buttons optimize the cache
for documents that are Tall and Thin, the Default size, or Big
and Flat. These options take into account your computer
hardware and current system settings.

• History States. This option specifies the number of history
states to cache. You can access these history states from the
History panel, as described in Chapter 5. A higher number
gives you more states that you can use to backtrack changes
but consumes more memory.

• Cache Levels. This option allows you to define the behavior
of the cache. Caching improves performance by storing
lower-resolution versions of the image to display in the
document window. This allows for much faster rendering by
Photoshop. A setting of 1 essentially disables caching because
the full image size is stored in the cache. This gives you a
more accurate view of the image but results in slower
rendering times. Increasing the cache number stores more
low-resolution versions of the image, which improves
performance while sacrificing rendering quality in Photoshop.
You need to restart Photoshop for changes to the cache to
take effect.

• Cache Tile Size. This option specifies the number of bytes
that Photoshop stores or processes at once. Typically, the rule
is to use a larger tile size when working with larger images
and a smaller tile size when working with smaller images or
images with a lot of layers. You need to restart Photoshop for
changes to the Cache Tile Size to take effect.

• Graphics Processor Settings. This section contains the Use
Graphics Processor option, which allows you to enable or
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disable OpenCL drawing by your video adapter. OpenCL
drawing uses the processor on your graphics adapter to render
images. Using the video adapter to draw can significantly
improve performance in many of the Photoshop features, such
as the Zoom, 3D, and Paint tools. Enabling OpenCL also
enables several advanced features in Photoshop, such as the
rotate view, bird's-eye zooming, pixel grid, and flick to scroll.

Clicking the Advanced Settings button loads the Advanced
Graphics Processor Settings dialog box, shown in Figure
2.33, that allows you to choose from the following drawing
modes for OpenCL:

• Basic mode. This mode uses the smallest amount of GPU
memory and has the least impact on other applications
running OpenCL features on the system. However, it can
result in slowness in some areas of Photoshop that are
GPU-intensive, such as 3D.

• Normal mode. This mode uses the greatest amount of GPU
memory and enables additional OpenCL features, but may
cause visual defects on some GPUs.

• Advanced mode. This mode uses the same amount of
memory as Normal mode but enables even more OpenCL
features that can improve performance and enhance some of
the Photoshop rendering features such as zoom animation.
This mode may also cause visual defects on some GPUs and
interfere with other applications using the GPU.

• Use Graphics Processor to Accelerate Computation. This
option improves the performance-heavy processing
operations such as the Puppet Warp preview.
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• Use OpenCL. This option turns on OpenCL processing to
improve performance if it is supported by the graphics
adapter. OpenCL is framework that is different that OpenGL
and provides better graphics performance in most
circumstances by allowing parallel processing of the complex
operations Photoshop performs when processing images.

• Anti-alias Guides and Paths. This option causes Photoshop
to anti-alias guides and paths, which makes them render more
cleanly on screen. However, this also slightly impacts
performance.

• 30 Bit Display. This option increases the color fidelity on
the monitor to 30 bits if it is supported.

Configuring Cursors preferences

One of the most important tools in Photoshop is the cursor.
The cursor tells you where you are in the document, which in
turn allows you to make precise edits and selections. The
Cursor preferences allow you to configure the cursors to best
fit your needs. The Cursors preferences pane, shown in Figure
2.34, provides the following settings to define the appearance
and size of mouse or stylus cursors:

Figure 2.34

The Cursors settings in the Preferences dialog box allow you
to set the size and appearance of cursors when working with
the Photoshop tools.
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• Painting Cursors. This section defines the appearance and
size of the cursor used with painting tools such as the brush.
You can choose from these options:

• Standard. This looks like the painting tool icon.

• Precise. This displays a crosshair, which is much better for
seeing the exact center of the brush stroke.

• Normal Brush Tip. This creates a circle the size of the
paint stroke, not taking into account any feathering caused by
brush settings. This option is better for seeing the immediate
area that will be affected by the brush stroke.

• Full Size Brush Tip. This creates a circle that is the full
pixel size of the paint stroke, including any feathered edges.
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This option is better for seeing the full area that will be
affected by the brush stroke.

• Show Crosshair in Brush Tip. This displays a crosshair in
the center of the Normal and Full Size Brush Tips.

• Show Only Crosshair While Painting. This changes from
the Normal Brush Tip or Full Size Brush Tip to the Crosshair
Tip when you are dragging the mouse. This allows you to see
the size of the brush better before using the precision tip.

• Other Cursors. This section defines the brush tip cursor
used for tools other than the painting tool.

• Brush Preview. This section allows you to use a color
chooser to define the color that is used for the brush editing
preview.

Setting Transparency and Gamut preferences

You can use the Transparency & Gamut preferences pane to
configure how transparent pixels appear in the document
workspace. This allows you to distinguish transparent pixels
from the background color. This pane, shown in Figure 2.35,
provides the following settings to define the appearance of the
transparency grid and gamut warning:

• Transparency Settings. This section allows you to set the
size and colors of the grid used to denote transparent pixels in
an image. The Grid Size options are None, Small, Medium,
and Large. The Grid Colors setting provides several
predefined color sets, or you can select Custom to choose
your own set of colors for the grid. Typically, you have no

175



reason to adjust the transparency colors unless you have a
pattern that is similar in the image you are editing.

• Gamut Warning. This section allows you to specify the
color used to warn you when a color is out of range for a
specified color profile — for example, when you choose
View⇒Gamut Warning or are previewing inside the Print
dialog box (File⇒Print). The Opacity setting defines how
transparent or opaque the gamut warning is when it displays.
Reducing the opacity allows you to more easily see the image
behind the gamut warning.

Figure 2.35

The Transparency & Gamut settings in the Preferences dialog
box allow you to define the appearance of the transparency
grid and gamut warning.
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Using Units and Rulers preferences

The Units & Rulers preferences pane enables Photoshop to be
versatile in representing measurements of rulers, text, and
images. For example, you may want to use inches when
editing one image and centimeters in another, or you may
want to measure your text in millimeters instead of points.
The Units & Rulers preferences pane, shown in Figure 2.36,
provides the following settings to define the units, column
sizes, document resolution, and point size to use in
Photoshop:

• Units. This section allows you to control the units used by
the rulers and with type. The Rulers option specifies the units
used for rulers and measurements in Photoshop. The Type
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option specifies the units for all the settings used by the Type
tools as well as the Character and Paragraph panels.

The options are pixels, inches, centimeters, millimeters,
points, picas, and percent (where percent is in relation to the
size of the image). When working in a print workflow, using
inches or picas is best. When working in a web workflow,
using pixels is typically best.

• Column Size. This section is useful if you are preparing an
image or multiple images that can be broken into columns.
Several Photoshop dialog boxes use column width as a unit of
measurement, including the New, Image Size, and Canvas
Size dialog boxes. The columns in those dialog boxes are
based on the Column Size settings.

• New Document Preset Resolutions. This section allows
you to specify the default print and screen resolutions used
when creating a new document with the File ? New command
from the Photoshop menu bar. Keep in mind that the screen
resolution is important for images that are viewed on a
computer, such as web images, but print resolution
determines the print quality and size of the printed image.

• Point/Pica Size. This section allows you to set the number
of points and picas in an inch. The PostScript method defines
a pica as about 1/6 inch and a point as about 1/72 inch.
Applications from years ago used a different system where
there were 6.06 picas per inch and 72.27 points per inch. You
should choose the Postscript setting unless you have a
specific reason for using the traditional method.

Figure 2.36
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The Units & Rulers settings in the Preferences dialog box
allow you to define the units, column sizes, document
resolution, and point size in your images.

Adjusting Guides, Grid, and Slices preferences

The Guides, Grid & Slices preferences pane allows you to
configure the color and look of guides, grids, and slices.
Depending on the colors in the document you are working on,
you may want to change the color of these lines to be more
visible. Also, depending on how precise you would like to be
in your image, you may want to make the grid spacing larger
or smaller, especially if you are using the Snap to Grid
feature. The Guides, Grid & Slices preferences pane, shown
in Figure 2.37, provides the following settings to define the
color, line style, and arrangement used when displaying
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guides, grids, and slice bounding boxes in the document
window:

Figure 2.37

The Guides, Grid & Slices settings in the Preferences dialog
box allow you to define the color, line style, and arrangement
used to display guides, gridlines, and slice bounding boxes in
document windows.

• Guides. This section allows you to set the color and line
style for guides. You can choose any color from the menu or
select Custom to launch a color chooser that lets you select
any color Photoshop can display. You typically want to set
the guide color to something that has a high contrast with the
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colors in the image so that you can see it better. You can also
choose to make the guide a dashed or solid line.

• Smart Guides. This section allows you to set the color of
the smart guides only. Smart guides are the lines that
temporarily appear around the pixels on a layer when you
move items. Smart guides are great at helping you align the
content of one layer with the content of another layer.

• Grid. This section allows you to set the color and line style
used when displaying the grid. You want to select a color that
contrasts well with the image and also contrasts with the color
of the guides so you can easily distinguish the lines from each
other. You can also set the spacing between grid lines and the
number of subdivisions to include between grid lines.
Subdivisions show up as less apparent lines.

• Slices. This section allows you to specify the color of slice
bounding boxes and whether to display the slice number
when displaying the slice.

For more information about slices, see Chapter
30.

Configuring Plug-Ins preferences

Plug-ins are a very useful feature of Photoshop, allowing you
to extend the product beyond its original programming. The
Plug-Ins preferences pane allows you to configure options
that control the behavior of these plug-ins. We discuss the
plug-ins preferences in Appendix B, along with several of the
plug-ins that are available to add functionality to Photoshop.
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Setting Type preferences

The Type preferences pane provides options to control the
appearance and behavior of the type tools. You can use these
options to do things such as enabling smart quotes that cannot
be enabled in the type tools. The Type preferences pane,
shown in Figure 2.38, provides the following settings to
define behaviors such as using smart quotes and substituting
fonts when adding text to images:

Figure 2.38

The Type settings in the Preferences dialog box allow you to
define behaviors such as using smart quotes and substituting
fonts when adding text to images.
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• Use Smart Quotes. Selecting this option causes Photoshop
to scan through the text, detects the starting and ending
quotation marks, and automatically converts them to quotes
that curve toward the text inside the quotes. You may not
want this option enabled if you are using text that contains a
lot of single quotes — for example, using double quotes to
signify inches and a single quote to signify feet.

For more information about fonts, glyphs, and
adding text to images, see Chapter 18.

• Enable Missing Glyph Protection. Selecting this option
causes Photoshop to automatically make font substitutions for
any missing glyphs that appear in the text, but not in the
selected font. This option can be important if you are keeping
text as a vector layer and transferring the file between
machines. When loaded on the second machine, if the font is
not present, Photoshop automatically makes a font
substitution. If this option is disabled, Photoshop prompts you
first.

• Show Font Names in English. Selecting this option will
show the names of fonts in the font list as English, even if you
are working with different language fonts.

• Choose Text Engine Options. This option allows you to
choose a text engine to process complex character text in your
document. There are two options one for east Asian text and
the other for Middle Eastern and South Asian fonts.

Adjusting 3D preferences
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The 3D preferences pane in Photoshop allows you to
configure several features of the 3D tools. You can use these
preference settings to enhance performance, improve object
rendering, and define the look and feel of many of the 3D
controls. The concepts surrounding 3D preferences are tightly
coupled with the 3D chapters in this book. Therefore, we
included a description of the 3D preferences in Chapter 22.
Refer to that chapter for information about setting 3D
preferences.

Customizing Shortcuts and Menus

Photoshop provides a tremendous amount of power by
including a lot of features. Unfortunately, that means
Photoshop also had to include a lot of menus. With the sheer
number of menus and tools that Photoshop has to offer, you
can quickly find yourself spending more time searching for
tools than using them. The solution to this problem is to
customize your menus and to use keyboard shortcuts.

Tip

You can create and name several customized shortcuts or
menu sets. You may want to create different sets for the type
of editing you are doing and then load the set that best
matches your workflow.

Customizing menus

Photoshop allows you to customize the menus in two ways:
you can hide menu items that you do not intend to use, or you
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can color code menu items to make them easier to find. To
customize the Photoshop menu bar, select Edit⇒Menus from
the Photoshop menu bar to display the Menus tab of the
Keyboard Shortcuts and Menus dialog box, shown in Figure
2.39.

Figure 2.39

The Keyboard Shortcuts and Menus dialog box allows you to
create custom menus that hide unwanted items and display
important items in organized colors.
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From the Menus tab, you can use the following options to
create and manage customized menu sets:

• Set. This option allows you to select the default menu set or
a saved menu set from the drop-down list. The Save Set icon
next to the Set list allows you to save changes to the currently
selected set. The New Set icon allows you to save the current
menu configuration as a new set that appears in the Set list.
The Delete Set icon removes the currently selected set from
the list.

To create a new custom menu, first make all adjustments to
the menus, then click the New Set icon, and name the set.
You can then reload that set whenever you like.

• Menu For. This option allows you to choose whether you
want to edit the application menus or the panel menus. When
you change this option, either the application or panel menus
appear, depending on which option you choose.

• Menu list. This list displays a selection of menus that you
can adjust. You can expand and collapse a menu in the list by
clicking the triangle next to the menu name. When the menu
is expanded, you can customize each menu option by doing
the following:

• Change visibility. This option allows you to use the mouse
to toggle the eye icon to hide or show the menu item in
Photoshop. Figure 2.39 shows that the Background option is
hidden while the others are visible.

• Change color. This option allows you to change the color
used for the background of the menu item. This allows you to
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color code certain menu types or highlight important menu
items so you can more easily find them. To change the color,
select a color from the drop-down menu shown in Figure
2.39.

Customizing shortcuts

One of the best ways to speed up your workflow in Photoshop
is by using keyboard shortcuts. Keyboard shortcuts allow you
to use a key sequence to quickly perform tasks, select tools,
and open panels. Throughout this book, we include the
important keyboard shortcuts when describing various tools.
If you take the time to learn and use these shortcuts, you will
be more efficient at using Photoshop.

Caution

You should be careful not to use system-wide shortcut
combinations or shortcuts that are in use with other
programs that you plan to use while you are using
Photoshop. This can cause conflicts that result in confusion
and mistakes.

Photoshop also allows you to customize the keyboard
shortcuts. To customize keyboard shortcuts in Photoshop,
choose Edit⇒Keyboard Shortcuts from the Photoshop menu
bar to display the Keyboard Shortcuts tab of the Keyboard
Shortcuts and Menus dialog box, shown in Figure 2.40.

Figure 2.40
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The Keyboard Shortcuts and Menus dialog box allows you to
customize the keyboard shortcuts that you use to perform
common tasks in Photoshop.

From the Keyboard Shortcuts tab, you can use the following
options to create customized keyboard shortcut sets:

• Set. This option allows you to select the default shortcut set
or a saved shortcut set from the drop-down list. As with the
customizing menus, the Save Set icon next to the Set list
allows you to save changes to the currently selected set. The
New Set icon allows you to save the current keyboard
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shortcuts as a new set that appears in the Set list. The Delete
Set icon removes the currently selected set from the list.

To create a new custom shortcut set, make all adjustments to
the shortcuts, click the New Set icon, and name the set. You
can then reload that set whenever you like.

• Shortcuts For. This option allows you to select whether to
edit the shortcuts for application menus, panel menus, or
tools. When you change this option, the list below changes to
reflect the option you choose.

• Use Legacy Channel Shortcuts. This option changes the
channel-switching shortcuts back to the pre-CS4 form for
users who are familiar with those options.

• Item list. This list displays a selection of shortcuts for the
type you select in the Shortcuts For option. You can expand
and collapse an item in the list by clicking the triangle next to
the item name.

To change or add a shortcut to an item, click in the Shortcut
column of that item. A text box appears with a cursor. When
you type a key sequence into the text box, that key sequence
is added to the text box. Figure 2.40 shows an example of the
text box and key sequence for the Step Forward menu item.
To apply the key sequence as a shortcut, click the Accept
button. To undo the change you made, click the Undo button.
To revert to the Photoshop default, click the Use Default
button.
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• Add Shortcut. This button adds an additional shortcut to
the item so it has two shortcuts. This may help if you are
accustomed to different shortcuts from other applications.

• Delete Shortcut. This button removes the selected shortcut
from the item.

• Summarize. This button launches a dialog box that allows
you to select a location to store an HTML summary of the
keyboard shortcuts. After you save the file, the summary
automatically appears in your default web browser, as shown
in Figure 2.41. This is a good way to review the settings that
you made.

Appendix A contains tables that provide a quick
reference to the most commonly used keyboard shortcuts.

Figure 2.41

The Summarize option of the Keyboard Shortcuts and Menus
dialog box generates a viewable HTML document that
displays the current keyboard shortcuts.
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Summary

This chapter covered the Photoshop workspace, including the
document windows, menus, panels, tools, and preferences.
Photoshop provides a lot of power, and if you learn how to
configure and use the workspace, you can be more efficient
and have much more fun. Photoshop provides an intuitive
interface in most areas and some powerful features, such as
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grouping document windows and customizing menus, that
enable you to speed up your workflow.

In this chapter, you learned the following:

• How to organize and arrange document windows

• The contents of all those menus

• How to use grids, rulers, and guidelines

• All about the tools in the Toolbox and where we cover them
in this book

• How to organize panels

• How to create keyboard shortcuts to make Photoshop easier
to use

• How to create and save tool presets so that you can easily
configure tools for later use
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Chapter 3: Performing Image Basics

In This Chapter

Understanding the file formats that Photoshop supports for
images, video, and 3-D objects

Opening an image in another format

Understanding the resizing algorithms

Cropping and straightening images

The purpose of Photoshop is to edit image files that have
come from a variety of sources. Photoshop supports a large
number of file formats. The different file formats can be
confusing, so this chapter briefly discusses each of them to
help you understand their benefits and drawbacks.

In this chapter, you learn some important concepts about file
size and resolution. Understanding the relationship between
the size, resolution, and ultimate destination of an image file
helps you to know what size and resolution to use for the
image. You also learn about the different types of algorithms
that Photoshop uses to resample images when changing their
size. Understanding the algorithms helps you to know which
ones to use to get the best results when resizing images.

This chapter also discusses how and why you should crop
images. You learn how to use several tools in Photoshop to
accurately crop, trim, rotate, and straighten images quickly.

Exploring File Types
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If you have worked with images long enough, you have
probably come across a variety of file formats. Although
having just one file format would be great, the fact is that
numerous file formats serve a variety of purposes. You need
to understand the different types of image, video, and 3-D file
formats to make the most of the features in Photoshop.
Understanding the different file formats helps you make
better decisions about how to save and work with files.

The following sections focus on the different types of file
formats, where they came from, and why you should use
them. After you understand these formats, you can make
better decisions when importing and saving files with
Photoshop.

Understanding compressed versus uncompressed file formats

The first concept you need to understand about file formats is
why they store the file in either a compressed or
uncompressed form. Each format has its advantages, which is
why both types exist.

An uncompressed file stores the full image, video, or 3-D data
in the same format in which it exists when you open the file.
As a result, the size of the file on disk is the same as the size
of the file in memory. A compressed file stores the data by
using complex algorithms that allow you to store the file
using less space on your disk. When you reopen the file, the
data on disk is uncompressed using an inverse algorithm and
loaded into the application in a viewable and editable form.

One advantage of using uncompressed file formats is that you
always retain the data. Also, uncompressed formats are faster
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to load and save because the computer does not need to
compress or uncompress them. The advantage of using
compressed file formats is that they take up much less room
on disk. With a lot of large images and especially with video,
this can become a major concern.

The two types of compression algorithms are lossless
compression and lossy compression. The lossless
compression algorithm loads the image back into memory in
exactly the same state that it was before compression, while
the lossy compression algorithms “cheat” and throw away
data that is least likely to be relevant when displaying the
image or video.

Tip

Lossy compression offers a major advantage in that you can
store large images and video in a much smaller space.
However, the major disadvantage is that every time you
save an image using a lossy compression algorithm, you
lose some more data. The first time you save the image, the
loss of detail may not be noticeable. However, after several
saves, you will start seeing some artifacts in the image or
video. To avoid this, use a lossless or uncompressed file
type when you are editing the file; when you are finished
editing it, save it in the lossy format for final usage. You
may also want to keep a copy of the uncompressed version
around in case you need to edit the file again.

Using raster versus vector
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Another file format concept that you need to understand is the
difference between raster (or bitmap) and vector images. The
data for an image is stored completely differently in these two
file types. A raster image stores the data as a set of pixels.
Each pixel represents one point of light in the image. The
image is constructed onscreen by simply applying the pixel
data in the image to pixels on the screen.

A vector image stores the data as a series of path information
instead of individual pixels. Each path data item contains the
points, lines, and curves as well as stroke and fill color
information for the path. These paths make up the vector
image. The image is constructed onscreen by using the path
data to draw a series of paths.

A major advantage of using vector images is that no matter
how much you increase the size of the image, the lines are
always crisp because they can be redrawn each time. Another
advantage is that you can perform extremely accurate and
clean adjustments to curves in a way that is not possible in
raster images. The disadvantage is that you cannot make
pixel-by-pixel adjustments, paint, and morph the images in
the same way that you can raster images.

An advantage of using raster images is that for photos and
other complex images, generating enough vector lines to
create enough detail can be difficult, if not impossible. Pixels
offer a much closer representation of how monitors, printers,
and even the human eye work.

When working with multiple layers in Photoshop, some
layers can be raster and others vector. Examples of vector
layers are text, 3-D objects, and shapes. Vector layers can be
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resized without losing the sharpness of the content. Examples
of raster layers are images and painting. Raster layers can be
adjusted using pixel blending tools such as adjusting the hue
and saturation.

Note

You will find out that to perform some operations on a layer
or image in Photoshop you will need to convert it from
vector to raster or “rasterize” it. This is because the layer
works on adjusting the pixels instead of operating on the
vector data. Once the layer or image data has been
rasterized, you cannot convert it back to vector.

Introducing HDR images

High Dynamic Range (HDR) images are comprised of a set of
photographs taken at different exposures in a technique
known as exposure bracketing. You take the exact same
photo multiple times using different ISO settings and f-stops
to create a wide range of exposures for the same image. You
can then combine these photos to create an HDR image with a
much greater tonal range than is possible in a single photo.

Photoshop provides some tools to create and adjust HDR
images. Chapter 6 discusses using the Bridge tools to create
an HDR image. Chapter 13 discusses some of the tools used
to adjust HDR images.

Understanding image files
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Photoshop supports a variety of image file types. Most people
tend to work with one or two types and leave the others alone.
However, having a basic understanding of all file types helps
you make better choices when you have to work with them.
The following sections describe some image file types as well
as their advantages and disadvantages.

Photoshop (*.PSD; *.PDD)

Photoshop natively uses its own Photoshop PSD file format.
This file format contains all the information relevant to
working with the image in Photoshop. For example, all the
layer data you have created when working with the image is
stored in the PSD file.

You should use the PSD file format when working with an
image in Photoshop. The work that you do in Photoshop to
create adjustment layers and other changes usually represents
a lot of effort. The PSD file is the only format that stores all
your work so you can fine-tune your adjustments later.

The Photoshop file format retains all of the image data, so
you need not worry about saving it multiple times. Photoshop
PSD files can store image data in 8 bits per channel, 16 bits
per channel, and 32 bits per channel. One disadvantage of the
Photoshop file format is that it takes up a large amount of disk
space compared with some of the other file formats.

Tagged Image File Format (*.TIF; *.TIFF)

To be consistent with the following sections, Tagged Image
File Format (TIFF) is the next best format after PSD for
saving your files. You can store TIFF images in 8 bits per
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channel, 16 bits per channel, and 32 bits per channel.
Advantages of the TIFF file format are that it stores the layers
that you create in Photoshop and can store transparency in the
form of an alpha channel (discussed later in this book).
Another advantage of the TIFF format is that it is not
compressed so it is a lossless file format.

Unfortunately, TIFF images are also relatively large, so you
may not want to use this file format for most images you will
be working with. Another disadvantage is that TIFF images
are typically not supported in web browsers, so you can't add
them to web pages.

Joint Photographic Experts Group (*.JPG; *.JPEG; *.JPE)

JPEG, named after the Joint Photographic Experts Group, has
become the most commonly used image format. The JPEG
format provides very good image quality, supporting over
16.7 million colors, combined with one of the best
compression algorithms. This makes JPEG images the best
quality for the file size that you can get. Consequently, most
digital point-and-shoot cameras use the JPEG image format
by default.

Almost every computer program can read JPEG images, and
you can easily incorporate them into web pages. They also
take up much less disk space than PSD and TIFF files
because they are compressed.

JPEG 2000 (*.JP2; *.JPX)

The JPEG 2000 file format allows you to use either a lossless
or lossy encoding and compression algorithm. The default
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compression format is lossy. In addition, the JPEG 2000 file
format supports 16-bit color for a greater range of colors,
grayscale images, and 8-bit transparency.

Although JPEG 2000 files provide a number of advancements
over JPEG, they are not as widely supported and so they are
still not as widely used. Adobe provides a plug-in for
Photoshop that allows you to read and save files in the JPEG
2000 format.

Caution

JPEG images use a lossy compression algorithm, which
means the more you change and save an image, the worse its
quality becomes. You should convert your JPEG images to
PSD, TIFF, or PNG-24 format to edit them, and then back to
JPEG format when you are finished making the changes.

CompuServe GIF (*.GIF)

The CompuServe Graphics Interchange Format (GIF) file has
been used to develop web pages since the inception of the
World Wide Web. The GIF format uses an 8-bit palette that is
limited to 256 colors. This makes the GIF images very small
and easy to transfer across the Internet. It also makes the GIF
file format perfect for creating images such as buttons, links,
and icons that appear on web pages.

A cool advantage of the GIF file format is that it supports
animation effects within the image. This allows you to create
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animated controls and icons for web pages. The GIF file
format is lossless, so there is no data loss when saving files.

Portable Network Graphics (*.PNG)

The Portable Network Graphics (PNG) file format was
designed to replace the GIF file format for use on the Internet.
The PNG file format has an advantage over GIF in that it
supports over 16.7 million colors as opposed to GIF, which
supports 256 colors. The three different versions of the PNG
format are PNG-8, PGN-24, and PNG-48. The PNG-8 format
is an 8-bit alternative to GIF images. PNG-24 is a 24-bit
lossless alternative to JPEG images. PNG-48 is a 48-bit true
color format that supports an additional alpha channel for
transparency data. As browsers become more adept at
handling the PNG format, it will likely replace the GIF
format, but for now you should consider working with the
GIF format for web images unless you need the additional
colors available in PNG.

Bitmap (*.BMP; *.RLE; *.DIB)

The Bitmap (BMP) file format was developed for graphics
used in the Windows operating system. It is a simple format
that is widely accepted by Windows applications. BMP files
are not compressed, which makes their file size large.
Another disadvantage is that there is not as much support
outside of Windows — on Mac or Linux operating systems,
for example.

RAW (*.RAW; *.CR; *.CR2; *.DNG; and several others)
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The RAW image format was designed to capture the basic
information collected by the CMOS sensors in digital
cameras. Collecting the information directly without
converting it to another file format makes the cameras work
faster and results in less data loss.

Note

The Open File dialog box in Photoshop provides options for
Photoshop Raw and Camera Raw. As their name indicates,
Photoshop Raw images are saved in the RAW file format
from Photoshop. The Camera Raw option is for files that the
camera saves in a RAW file format. You will find many
different file extensions for the Camera Raw option, because
most camera vendors have their own proprietary formats.

The biggest advantage to using the RAW file format is that
you can work with the image as close as possible to the state
that existed when you took the photo. Adobe has designed a
special tool, Adobe Camera Raw (discussed in Chapter 7),
specifically for editing photos in the RAW file format
because the results tend to be much better than in other file
formats.

Tip

If you are taking photographs that you really want to look
good, you should set your camera to the RAW setting and
use the Adobe Camera Raw tools to adjust them.
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Afterwards, you can save them in another format, but if you
think you will want to adjust them again, keep the Camera
Raw files around.

One downside to the RAW file format is that it has little
support outside of image viewers and image editors such as
Photoshop. Another downside is that RAW is not one single
format. In addition to the original RAW file format, other
vendors have added their own file formats. For example,
Canon has .CR and .CR2. To address this problem, Adobe has
introduced the .DNG (Digital Negative) format in order to
create an industry-standard format. So far, the DNG format
seems to be getting a lot of attention and support from
hardware and software manufacturers.

Portable Bitmap (*.PBM; *.PGM; *.PPM; *.PNM; *.PFM;
*.PAM)

Portable Bitmap (PBM), Portable Gray Map (PGM), and
Portable Pixmap (PPM) are standard file formats. They are so
basic that they serve as one of the best common denominators
for transferring files between different platforms, such as
going from Windows to Linux.

The other file formats such as TIFF and JPG tend to change
pixel data slightly when they are transferred between two
different operating systems, due to differences in how the
operating systems process information. Using these portable
formats, you can overcome those problems more easily.
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Another advantage of PBM files is that they are one of the
few file types that can store image data in 8-bit-per-channel,
16-bit-per-channel, and 32-bit-per-channel formats. This is
another major advantage when trying to make an image
portable from one system to another.

Wireless Bitmap (*.WBM; *.WBMPI)

The Wireless Bitmap (WBM) file format is designed for
images used on wireless devices. Wireless devices limit the
size and number of colors that an image can contain. Using
the Wireless Bitmap format allows you to create images that
most portable devices can display.

Encapsulated PostScript (*.EPS; *.AI3; *.AI8; *.PS; *.EPSP;
*.EPSF)

The Encapsulated PostScript (EPS) file format was developed
by Adobe as a means to store images in a format that
PostScript printers could understand. That way, a person
could send a file directly to the printer without the file
needing to interact with any applications.

Later, Adobe realized that this was an excellent means to
transfer documents between different programs. Because all
Adobe programs were able to generate and read the EPS files,
it was easy for one application to read an EPS file that was
generated by another application.

The greatest strength of the EPS file format is that it can
contain both raster and vector images. This gives you the
ability to generate a vector image in another program, such as
Adobe Illustrator, and then import it into Photoshop.
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Photoshop can then use the vector image, for example, as a
vector path. Another major advantage of the EPS format is
that almost every desktop layout program in use can read its
files.

One disadvantage of the EPS format is that it is not truly a
graphic format. EPS is definitely not the best format in which
to store photos for later editing. Another disadvantage is that
the EPS format may result in a very large file size because the
storage format is not efficient.

Photoshop PDF (*.PDF; *.PDP)

The Portable Document Format (PDF) was developed by
Adobe to be a standard format for files that contained both
vector and raster images. It has been widely accepted as a
standard file format across all operating systems.

Many applications, including Photoshop, can read PDF files.
When Photoshop opens a PDF file, it allows you to import the
pages and images separately, as shown in Figure 3.1.

Figure 3.1

Choosing to import pages and images when opening a PDF
file in Photoshop
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Personal Computer eXchange (*.PCX)

The Personal Computer eXchange (PCX) format was
developed for use with the PC Paintbrush utility for DOS. If
you don't know what DOS is, don't worry; it's best forgotten.
The PCX format was widely used several years ago, but it has
been replaced with the GIF, JPEG, and PNG file formats.

You probably don't need to use the PCX file format unless
you are working with an image that was created several years
ago. Keep in mind that PCX files originally had a maximum
of 256 colors, so you should not expect PCX files to contain
much detail.

PICT (*.PCT; *.PICT)

PICT files are like the Apple version of PCX files. The PICT
file format was originally developed for use with the
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QuickDraw APIs used by many graphics applications. At that
time, this format was one of the few that allowed a file to
contain both vector and raster images. However, that
functionality has been replaced by the EPS and PDF file
formats.

Pixar (*.PXR)

The Pixar file format was developed in-house by the Pixar
animation company. The requirements of digital animation
put such a huge strain on the available applications that the
company had to create a custom system that included their
own file format. Photoshop allows you to read images that
were created using the Pixar system and to write your images
out to the Pixar file format.

Flash XML Graphics (*.FXG)

Flash XML Graphics (FXG) is an XML graphics file format
developed by Adobe. The specific purpose of FXG is to
provide a common file format for all Adobe products. The
FXG format is based on the XML language and defines a
standard for raster graphics.

Google Earth 4 (*.KMZ)

A KMZ file is a zipped archive used by the Google Earth
application to display geographic data and images. A KMZ
file contains one or more KML files and the supporting
images. Google Earth uses KML files similarly to how a web
browser uses HTML files. Google Earth reads the KML file
and interprets how to display the information and images.
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Photoshop allows you to read a KMZ file and open the
images it contains to edit and view. Currently, Photoshop
supports KMZ files using the Google Earth 4 standard only.

Photoshop Big (*.PSB)

Many applications have a limit of 2GB for a file size due to
the nature of the 32-bit operating system. This presents a
problem for many file formats. Adobe has overcome this
problem by creating a special file format called Photoshop
Big (PSB).

Using the PSB file format, Photoshop can open and create
files that are larger than 2GB. An advantage of PSB files is
that they support the 8-bit-per-channel, 16-bit-per-channel,
and 32-bit-per-channel formats. However, unless you really
need a file larger than 2GB, you should avoid using the PSB
format. Only a few applications support it, so it is not very
portable. Another disadvantage of the PSB file format is that
it supports only the grayscale and RGB color models, which
are discussed in Chapter 4.

OpenEXR (*.EXR)

The OpenEXR (EXR) format was developed by Industrial
Light and Magic to provide a multi-resolution and arbitrary
channel format for images. This format can offer a major
advantage if you are working with complex compositing of
images where you may need several different channels that do
not conform to a single color mode.

Although Photoshop gives you the ability to read and even
write an OpenEXR file, it does not allow you to create the
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additional channels. However, if you have an OpenEXR file,
you can use the powerful tools in Photoshop to adjust the
channels.

Cineon (*.CIN)

The Cineon (CIN) file format was developed by Kodak to
contain data from images scanned in from film. The Cineon
format is different from the standard formats such as JPEG
and TIFF. Instead of RGB channels representing intensity of
color, the pixel data in the Cineon format represents the
printing density as determined by the print film. The purpose
of using the printing density is to retain the values that
originally existed on the print film.

Interchange File Format (*.IFF; *.TDI)

The Interchange File Format (IFF) was developed by
Electronic Arts as a method to transfer graphic data between
software. You will probably never need to use an IFF file, but
if you do, Photoshop can open it.

Scitex CT (*.SCT)

The Scitex CT (SCT) file format is used by graphics
processing equipment developed by Scitex Corporation Ltd.
(now Scailex Corporation Ltd.). You will only use this file
format if you are sending print jobs to a Scitex digital printer.

Targa (*.TGA; *.VDA; *.ICB; *.VST)

The Truevision Advanced Raster Graphics Adapter (Targa)
file format has been around since computers first used color
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displays. Targa files support 8-, 16-, 24-, and 32-bit colors per
pixel. Targa files support alpha channel data and are
transportable between many systems. A common use of Targa
files is to store textures used in 3-D imaging such as video
games or animation.

Radiance (*.HDR; *.RGBE; *.XYZE)

The Radiance format stores four bytes per pixel (red, green,
blue, and an exponent byte). This allows pixels to have the
extended range and precision similar to floating point values,
allowing the HDR and RGBE formats to handle very bright
pixels without loss of precision for darker ones. A variant of
the Radiance format, XYZE, uses the XYZ color model
(discussed in Chapter 29) instead of RGB.

Understanding video files

Photoshop supports a wide variety of video file formats. Each
video file format is based on a digital container format. The
digital container format defines how the audio and video data
elements as well as metadata co-exist in the video file. The
different container definitions result in different file formats.

Each of the different video file formats can be compressed
using codecs, which are computer programs that encode and
decode the audio/video data stream. Several different codecs
are available and provide different levels of compression and
quality in the file.

With the addition of the Timeline panel, Photoshop adds
several video file formats to the huge list of supported file
formats. Not only can you import movies with the following
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extensions, but you can also import image sequences with the
image extensions that Photoshop already supports.

Photoshop allows you to import the following video file
formats:

• MOV. The MOV file format is the native file format of
QuickTime. A MOV file can contain several types of tracks,
including video, audio, effects, and text. This makes MOV
files easily editable and portable because you can use a MOV
file on both the Mac and Windows platforms.

• AVI. AVI is one of the most popular high-quality formats.
AVI files usually are not compressed, although some AVI
codecs do compress the file. This means that an AVI file
takes up much more disk space and is difficult to share over
the Internet, but keeps the full quality. Other video formats
such as divx and xvid use lossy compression to make the files
smaller. AVI has the same capability to store tracks as the
MOV file format. It is the most commonly used file format in
video-editing software in Windows.

• MPG/MPEG. MPEG (Moving Picture Experts Groups)
files are based on a set of standards that define audio and
video compression. Several file formats are based on these
standards. The following are the most common standard
formats:

• MPEG-2. MPEG-2 is the standard format used for
broadcast-quality television as well as DVDs. MPEG-2 files
are compressed enough to be transmitted for cable and
satellite television, and fit onto DVD discs while retaining
most of their quality. The MPEG-1 format is based on the
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MPEG-1 format that is still used widely throughout parts
Asia.

• MPEG-4. MPEG-4 utilizes additional coding complexity to
achieve higher compression rates than MPEG-2. This is a
much better format to be rendered on computers, and the
smaller file size makes it the most popular standard for use on
the Internet.

• MP4. Based on the MPEG-4 Part 14 standard, this format
has overtaken MPG files in popularity on the web. MP4 is
very portable and provides great compression while still
maintaining high video quality.

Note

To play video in Photoshop, you must have QuickTime 7
installed on your computer. You can download QuickTime
for free from www.apple.com/quicktime.

Supporting 3-D file formats

By adding 3-D extensions, Photoshop has expanded the file
formats that it supports for 3-D editing. Photoshop supports
these 3-D file formats:

• 3ds. The 3ds file format is used by 3D Studio Max, the most
widely used 3-D application. It has become such an industry
standard that most 3-D modeling programs export their files
in this format.
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• OBJ. The OBJ file format is also a widely used industry
standard. The 3-D models that come with the Photoshop
bonus content are OBJ files.

• COLLADA. This is the file format used by the video
gaming industry. It was originally developed to facilitate
transporting digital content from one creation tool to another.
COLLADA is also a widely supported file format with an
.xml file extension.

• U3D. The Universal 3D file format allows users to share
3-D graphics with other users who don't have the 3-D
modeling program that was used to design the image. Like
JPEG or TIFF files, U3D files are becoming available to most
image viewers.

• KMZ. The KMZ format was discussed earlier as an image
file format; however, it also provides information about the
3-D geography that you see when you explore Google Earth.

Supporting the DICOM file format

A Digital Imaging and Communications in Medicine
(DICOM) file is a medical image or series of images created
when you have a sonogram, CT scan, MRI, or any number of
procedures that take an image of the inside of your body.
DICOM files are used to visually analyze and diagnose
problems inside the body without doing exploratory surgery.

Photoshop gives you the ability to open and work with
DICOM files. Using the powerful level and tone adjustments
available in Photoshop, a trained technician can adjust images
so he can see problems more easily. Photoshop also has the
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ability to animate a series of DICOM files by sequencing
them. For example, if you have several images at timed
intervals of a heart beating, Photoshop can turn the images
into an animated movie.

Creating and Opening Images

Before you can work with images in Photoshop, you need to
know how to use the application to open image files and
create new ones. Creating a new image involves defining the
resolution and size of a blank document and opening it in
Photoshop. This section offers you a quick overview of how
to create and open images in Photoshop. The following
sections give a brief overview of creating new images,
opening existing images, and saving images in Photoshop.

Creating a new image

Many people only see Photoshop as a photo-editing
application. However, Photoshop also allows you to create a
blank image with a wide variety of dimensions and
resolutions. In fact, Photoshop was originally developed as a
painting tool and many applications for Photoshop still
revolve around using it to create some fantastic digital art
from scratch.

To create a new image in Photoshop, choose File⇒New to
open the New dialog box, shown in Figure 3.2. When creating
a new image, you need to tell Photoshop how big the image
should be, how much resolution the image should have, and
what color mode to use.

Figure 3.2
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Setting the options while creating a new image in Photoshop

You can configure the following settings in the New dialog
box when you are creating a new image in Photoshop:

• Name. This setting lets you specify a name for the
document. Typically, you want to use a descriptive name so
that later you can easily locate the document in the file
system.

Tip

When you are copying from another document or
application into a new file in Photoshop, copy the data to the
clipboard first and then create the new document in
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Photoshop using the Clipboard preset. This creates the new
document automatically to the exact size of the contents of
the clipboard, avoiding the need to crop the data later.

• Preset. This setting provides a drop-down list of preset sizes
for the image. The default is Clipboard, which creates a new
image that is the same size as any image data contained inside
the clipboard. You can also choose the default Photoshop size
(5 × 7 inches), U.S. and international paper sizes, standard
photo sizes, film and video sizes, standard web sizes, and
mobile device sizes. You can also select other open images to
create a new image that is the same size, which is helpful if
you are using the new image to work as a composite with an
existing image.

• Size. This setting allows you to select a size from the
drop-down list based on the preset that you selected. For
example, if you selected Photo in the Preset drop-down list,
the Size list contains standard photo sizes such as 5 × 7 and 8
× 10. If you select the Clipboard, default Photoshop, or
Custom preset, the Size option is not active.

• Width. This setting lets you specify the width of the new
image. You can also select the units, which include pixels,
inches, centimeters, millimeters, points, picas, and columns.

• Height. This setting lets you specify the height of the new
image. You can also select the units, which include pixels,
inches, centimeters, millimeters, points, and picas.

216



• Resolution. This setting lets you specify the resolution of
the image. The available units are pixels per inch and pixels
per centimeter.

• Color Mode. This setting lets you specify the color mode
and number of channels to use when creating the image.
Color mode and bit level are discussed in more detail in
Chapter 4.

• Background Contents. This setting specifies the contents
of the background of the new image. The options are White,
Background Color, and Transparent. If you select
Background Color, the color of the background in the
Photoshop Toolbox is used as the background for the image.
If you select Transparent, the file is created with a normal
layer and no background layer.

Opening an existing image

The first thing you typically want to do in Photoshop is open
a file for editing, because Photoshop isn't worth much without
an image file loaded. To open a file in Photoshop, choose
File⇒Open.

Then use the Open dialog box, shown in Figure 3.3, to
navigate to where the file is located.

If you have a lot of files in the location where you are trying
to open the file, it may be difficult to find. You can narrow
the view by selecting the file type of the image you want to
open using the Files of type drop-down list. When you select
a specific file type, Photoshop only displays files of that type.
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Tip

In Figure 3.3, the thumbnails of the images are displayed to
make selecting the desired file easier. You can view the
thumbnails in Windows Explorer by pressing Alt+V and
selecting Medium icons, Large icons, or Extra Large icons
from the drop-down list.

You can also narrow the search by typing in the File name
field. A drop-down list of files appears based on the name you
are typing. As you type more characters, the list becomes
smaller until you can easily select the file you want. When
you click the Open button, the image opens in Photoshop,
ready to edit.

Figure 3.3

Opening an existing image in Photoshop
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Opening an existing image as a specific file type

The first section of this chapter discussed the different types
of files you can work with in Photoshop. Some are better than
others, and you probably have a preference. Photoshop has a
useful feature if you are opening a file in a different format
that you want to use when editing. The Open As feature lets
you open a file in a different format than it currently exists in
on disk. This saves you the trouble of opening the file and
then saving it in the format that you really want to use.

To open a file in a different format, choose File⇒Open As
from the Photoshop menu bar to display the Open dialog box,
shown in Figure 3.4. Navigate the file system to find the
image, and use the Open As drop-down list to select the file
format you want to use when editing the image. You cannot
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filter the list based on file type in the Open dialog box;
however, you can still filter based on filename. When you
click the Open button, the image opens in the format you
specified, ready to edit.

When modifying an image in Photoshop, any work you have
done is lost if you do not save the changes to the file.
Photoshop provides two options to save work you have done
on a file: Save and Save As. The Save option simply saves the
changes you have made to the file back to the original file
format and filename. The Save As option allows you to save
the changes to a new file format and filename.

Tip

If you are planning to use an image more than once, you
should always save a copy of the original first and then
work on that copy. Each time you edit and save the image,
some of the original data is changed or lost. Working on
copies instead of the original ensures that each time you
start again, you have the best source data in the image to
work from.

Figure 3.4

Opening an existing image in a specific file format in
Photoshop
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You generally use the Save option to save permanent changes
while you are editing a document. You use the Save As
option if you want to save a copy of the file to keep the
original image contents, change the file format of the image,
or specify additional data to preserve.

To save the changes made to an existing document in
Photoshop, choose File⇒Save. Some file formats launch a
dialog box with options for that file format; however, most
often, the file is saved immediately and you can continue
working.

To save a copy of the file, change the file format, change the
filename, or specify other options, choose File⇒Save As to
launch the Save As dialog box, shown in Figure 3.5.

From the Save As dialog box, you can specify the following
options when saving a file:
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• File name. This option lets you specify the name under
which the file is stored on disk. Typically, you want to
specify a descriptive name that identifies the file easily.

• Save as type. This option lets you specify the file format to
use when saving the file to disk. This option defaults to the
current format of the existing file.

• As a Copy. This option adds the word copy at the end of the
filename.

Note

Normally, when you use the Save As option, Photoshop
closes the old file and the newly saved file becomes the
working document. However, when you select the As a
Copy option, Photoshop saves the copy, but the current
working document is still the original instead of the copy.

Figure 3.5

Using the Save As dialog box to save changes made to an
image in Photoshop
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• Notes. This option saves the notes data in the image. This
option is only available if you have added notes to the image
and the selected file format supports notes data.

• Alpha Channels. This option saves the alpha channel data
in the image. This option is available only if the image
contains alpha channel data and the selected file format
supports alpha channel data — for example, PSD, TIFF, PDF,
and GIF.

• Spot Colors. This option saves the spot color data in the
image. This option is available only if the image contains spot
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colors and the selected file format supports spot color data —
for example, PSD, TIFF, PDF, and EPS (DCS 2.0).

• Layers. This option saves the layers data in the image. This
option is available if the image contains layer data and the
selected file format supports layer data — for example, PSD,
TIFF, and PDF.

• Use Proof Setup. This option is available if you configure
the current view's proof setup by choosing View⇒Proof
Setup, the View⇒Proof Colors option has been selected, and
the selected file format supports converting to proof colors —
for example, EPS files.

• ICC Profile. This option embeds the configured ICC profile
data in the image. This option is available only if the selected
file format supports embedding ICC data.

• Thumbnail. This option specifies whether a thumbnail
version of the image is embedded in the file's metadata. This
option is available only for files that can have a thumbnail
embedded.

Resizing Files and Adjusting Resolution

A common operation that you will perform on Photoshop
files is resizing and adjusting resolution. When you resize an
image, you reduce the number of overall pixels, which
reduces the file size. When adjusting the resolution, you
adjust the number of pixels per inch; for example, increasing
the print quality decreases the print size. After you open a file
in Photoshop, you are ready to begin editing it. Some of the
first edits you typically perform are resizing and resolution
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adjustments to make the image the size you want. This
section discusses resolution and how it applies when you are
resizing images.

Understanding resolution

Resolution is the ability to discern details in an image. In
Photoshop, resolution is measured in terms of pixels per inch
or pixels per centimeter. An image with more pixels per inch
has more detail.

The biggest limitation of resolution is the medium on which
the image is presented. For example, a typical computer
monitor has a maximum resolution between 72 and 96 pixels
per inch, which means that even if you have an image with a
resolution of 1000 pixels per inch, the detail cannot appear
better than at 96 pixels per inch.

Therefore, when setting the resolution of an image, you
should understand the resolution capabilities of the medium
from which you will output the image. For example, an inkjet
printer may be able to print 300 to 1200 dots per inch (dpi), so
an image with a resolution of 1000 dpi prints more detail than
an image with a resolution of only 96 dpi.

So why not just keep the resolution at the maximum? First,
the higher the resolution in the image, the larger the file is. If
you are concerned about disk space or transmission load time
on the web, then reducing the resolution helps. Second, if you
are using the image in an application or function that requires
a specific resolution range such as a web image, then you
need to change the resolution to match those requirements.
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Tip

It is a good practice to always maximize the resolution when
editing an image until you are ready to output it. That way,
all the editing is done with the maximum amount of detail.
Also, if you plan to edit the image again, you should
consider keeping a copy at the higher resolution.

Changing the image size and resolution

One of the most common editing functions applied to images
is to change the size and resolution based on the destination
of the image. For example, if you place an image on a
website, the size and resolution need to be less than for an
image being sent to a high-resolution printer.

This section discusses the relationship between size and
resolution, how Photoshop creates the resized pixels, and how
to make these adjustments in Photoshop.

Understanding the resolution and size relationship

Ultimately, the digital size of an image is simply the number
of pixels that it contains, and the dimensions are simply the
number of pixels wide by the number of pixels high.
However, when you are outputting the image, size is tied
directly to the resolution capability of the output device.

For example, when you are viewing an image on a computer
screen, the output dimensions of the image in inches are (the
number of pixels high/72 dpi) × (the number of pixels wide/
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72 dpi). However, when you are printing the image to a 1200
dpi printer, the document's output dimensions are (the number
of pixels high/1200 dpi) × (the number of pixels wide/1200
dpi), which is a much smaller image.

Therefore, you need to know the intended output resolution
and the desired dimensions of that medium to determine the
output resolution and size to set in the image. Otherwise, you
may end up with an image that is too large to view on a web
page or that has inadequate resolution for a printed image.

Tip

You should leave the image as large as possible when you
are editing until you are ready to finally output it. The more
pixels Photoshop has to deal with, the better the results you
see when editing. If you need to downsize the image, wait
until you have finished editing it. However, if you are
upsizing the image, you should change the size before you
edit it.

Understanding resizing algorithms in Photoshop

An important concept that you need to understand when
resizing images is what is happening with the pixels during
resizing. When you reduce the size of an image by one-third,
Photoshop has to take a block of 9 × 9 pixels and turn them
into a block of 6 × 6 pixels while displaying the same content.
When you increase the size of an image by one-half,
Photoshop has to take a block of 6 × 6 pixels and turn them
into a block of 9 × 9 pixels to display the same content.
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The point is that when resizing an image, Photoshop has to
make an intelligent determination of how to combine pixels
when reducing the image and how to fill in the missing holes
when increasing the size of the image. To do this, Photoshop
uses complex algorithms to calculate what the resulting pixels
in the new image should be. These algorithms are known as
resample methods.

Note

The algorithms that Photoshop uses to resize images are
available as an option at the bottom of the Image Size dialog
box, which you open by choosing Image⇒Image Size.

Photoshop provides five algorithms to resample images. Each
algorithm has advantages over the others, and they all
produce slightly different results. The following list describes
these algorithms and when to use them:

• Nearest Neighbor. This method is the simplest and fastest
for resizing an image. This option works by simply looking at
the pixels surrounding the selection and averaging them to
create the pixel in the new image. It's fast, but it produces the
worst overall results, especially in images that have highly
contrasting tones next to each other.

• Bilinear. This method uses a weighted average of the
nearest pixels in the old image to determine the value of the
pixel in the new image. This option is still fairly fast, but
typically provides much better results than the nearest
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neighbor method for both upsizing and downsizing images.
The bilinear method is the best overall method to use.

• Bicubic. This method applies a convolution algorithm that
uses a weighted set of numbers that are applied to the pixels
in the old image to determine the value of the pixel in the new
image. This option is not as fast as the nearest neighbor or
bilinear methods. However, the bicubic method typically
preserves finer detail. A downside of the bicubic method is
that it often results in ringing artifacts (a repeating pattern
around edges where there is high contrast in the image — for
example, white next to black).

• Bicubic Smoother. This is the same as the bicubic method,
except that it applies a smoothing filter to the set of pixels at
the same time to help smooth abrupt edges when enlarging an
image. The bicubic smoother algorithm provides the best
overall results when enlarging an image.

Note

Additional third-party Photoshop plug-ins are available on
the Photoshop Marketplace that provide better results than
even the Bicubic Smoother option.

• Bicubic Sharper. This is the same as the bicubic method,
except that it applies a sharpening filter to the set of pixels at
the same time to help keep detail when shrinking an image.
The bicubic sharper algorithm provides the best overall
results when shrinking an image.
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Adjusting the image size and resolution

To adjust the image size and resolution in Photoshop, choose
Image⇒Image Size to open the Image Size dialog box,
shown in Figure 3.6.

Figure 3.6

Setting options to change the image size and resolution of an
image

From the Image Size dialog box, you can set the following
options:

• Dimensions. Displays the new size of the image. The
drop-down list allows you to select how to display the new
dimensions of the image. Available options are Percent,
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Pixels, Inches, Centimeters, Millimeters, Points and Picas.
For example, if you select Percent, then you can see the
percentage of dimension change as you alter the height and
width of the image.

• Fit To. Allows you to force the resized image to conform to
specific predefined dimensions. When you select Custom,
you can manually set the height and width. You can also
select preset sizes such as A4, Legal, Letter, 4x6, 8x10, and
so on. You can also use the Save and Load options in the
drop-down list to save and load your own preset dimensions.

• Width. Allows you to change the actual width of the image
in terms of percent, inches, centimeters, millimeters, points,
picas, and columns. You can use the drop-down list to set the
units used to define the new size. If you select the Constrain
Aspect Ratio option, when you change this value, the
document height value also changes so that the image
maintains the original proportions.

• Height. Changes the actual height of the image in terms of
percent, inches, centimeters, millimeters, points, and picas.
You can use the drop-down list to set the units used to define
the new size. If you select the Constrain Aspect Ratio option,
when you change this value, the document width value also
changes so that the image maintains the original proportions.

• Resolution. Allows you to change the resolution of the
image in terms of pixels per inch or pixels per centimeter. If
you select the Resample option, the pixel dimensions change
when you adjust this value. Otherwise, the document size
changes when you adjust this value.
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• Scale Styles. When selected, scales any style effects that
you have added to the image. This is extremely useful if you
want to apply effects before scaling an image.

• Constrain Aspect Ratio. When selected, changes both the
height and width values when you change either of them to
maintain the document's original proportions. This option
applies to both the pixel dimension and document size values.
When you deselect this option, you can change the height of
the image without changing the width to apply distortion and
elongation effects.

• Resample. Selecting this option, changes the actual pixels
in the image to change the total image size in pixels. When
you deselect this option, you are changing only the document
size and resolution settings that are used when outputting the
image. Next to the Resample option is a drop-down list of
resample methods to use when changing the number of pixels
in the image. These options are available only when you
select the Resample option. You can select from the
Automatic, Preserve Details, Bicubic Smoother, Bicubic
Sharper, Bicubic, Nearest Neighbor, and Bilinear methods.
When you select Automatic, Photoshop uses a computer
algorithm to calculate the best method for resampling the
image, and then uses that option. Although this is usually
sufficient, there are times when Photoshop doesn't pick the
option that gives you the results for which you are looking.

Caution
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The bicubic methods are not available if you are working
with a grayscale image. If you are planning to convert the
final image to grayscale, you should change the size of the
image first to use these options before converting the image
to grayscale.

Changing the canvas size

The previous section discussed how to change the size of an
image. Photoshop also allows you to change the size of the
canvas that contains the image. Changing the canvas size is
different than changing the image size.

Typically, the canvas size is exactly the same as the image
size, so most people do not distinguish the two. Changing the
canvas size allows you to either add pixels to an image or take
pixels away from an image. Taking pixels away is basically
the same as cropping, which you learn about in the next
section.

You generally add pixels to an image file for a variety of
purposes. The most common reason is to add a border to the
image. Increasing the size of the canvas naturally creates a
border of pixels around the image.

Another common reason for increasing the canvas size is to
add crop marks for printing. Some printers require crop marks
to crop your image precisely. Increasing the canvas size gives
you the space to add crop marks to the image file.
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Increasing the size of the canvas does not alter the pixels of
the existing image at all. Instead, it simply adds pixels to the
image file. To change the canvas size, choose Image ? Canvas
Size from the Photoshop menu bar to open the Canvas Size
dialog box, shown in Figure 3.7.

Figure 3.7

Setting options to change the canvas size of an image

The Canvas Size dialog box allows you to set the following
options when resizing the canvas:

• Width. This option lets you specify the width in percent,
pixels, inches, centimeters, millimeters, points, picas, and
columns. If you select the Relative option, the width is the
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actual border size; if you deselect the Relative option, the
width is the total width of the canvas.

• Height. This option lets you specify the height in percent,
pixels, inches, centimeters, millimeters, points, picas, and
columns. If you select the Relative option, the height is the
actual border size; if you deselect the Relative option, the
height is the total height of the canvas.

• Relative. This option lets you specify whether to set the
width and height based on the total canvas or relative to the
image.

• Anchor. This option lets you specify where to anchor the
original image in the new canvas. You can select the center,
top, bottom, one of the sides, or one of the corners. Typically,
you want the image anchored in the center when adding a
border to the document.

• Canvas extension color. This option lets you choose the
color of the new pixels that you add to the canvas. This
defaults to the background color; however, it has presets for
foreground, white, black, and gray. You can also select
Custom to open a Color Picker to specify a different color.

Cropping and Straightening Images

In addition to resizing images, you may want to use only a
part of an image and discard or crop the rest. Photoshop
provides a great tool that allows you to quickly crop out the
unwanted parts of your image. Using the same tool, you can
straighten the cropping to fix problems such as a tilted
camera.
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This section offers some general guidelines for cropping your
images. You also learn how to use the Crop tool and the Trim
utility, included with Photoshop, to crop and straighten
images.

Using general guidelines for cropping a photo

Photography is really an art form. A photo that is well
composed is interesting to look at, leads the eye of the viewer
to the subject, and doesn't include any distracting elements.
You can improve all of these elements with the right crop.
Getting closer to your subject and cutting out background
clutter are vital to a good crop, but knowing a few basic
photography rules, such as the rule of thirds, helps you to
crop your photo to the best advantage.

Getting rid of background clutter

A good reason to crop your photo is to get rid of distracting
elements in the background. The subject should be the main
focus of any image, and anything else in the image should
complement the subject, lead your eye to the subject, and
contribute to the “story” being told about the subject. Too
many objects, distracting colors, or any other background
elements that draw the eye away from the subject should be
cropped out of your photo if possible.

Note

Cropping is an obvious fix for a busy background, but you
have other ways to reduce the impact of a background that
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you can't cut out of a photo with the Crop tool. You can cut
out your entire background using a Selection tool, you can
blur the background, or you can convert the background to
grayscale.

Preserving aspect ratio

Before you pull out your Crop tool and start trimming away,
you need to know what you are planning to do with your
photo. If you want to print your photo in more than one size,
leave yourself plenty of workable area around the edges of
your photo. Don't create a custom crop size that's so tight
around your subject that you'll go in later to create a 5 × 7
print and find that you can't do it without cropping out part of
your subject.

Also be aware that standard print sizes such as 5 × 7 and 8 ×
10 are different aspect ratios, so if you crop your photo to an
8 × 10 size, you'll have to trim the edges to make the same
photo a 5 × 7 size. If you are printing the same photo in
multiple sizes, save the original photo, using it to crop each
size, and then save each cropped photo individually.

Applying the rule of thirds

The “rule of thirds” is a tried-and-true rule for making your
photos visually pleasing, and it's very easy to follow. The
essence of the rule of thirds is that the subject and the horizon
in your photo should never divide your photo in half. Instead,
they should divide the photo into thirds. Mentally divide your
photo into thirds both horizontally and vertically. Ideally, the
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subject should be off-center in your photograph, directly in
one of the intersections of your imaginary lines (power
points), if possible. The horizon in your photo should run
along the top or bottom line, rather than through the center.

For example, in Figure 3.8, you can see that the boy is almost
exactly centered in the photo. To improve the composition,
you can make a crop that places his vertical axis on the left
one-third line to add space in front of him, and the knee on
the bottom one-third line to provide a solid platform, as you
can see in Figure 3.8.

Figure 3.8

Cropping an image using the rule of thirds to improve the
look
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Of course, just like any good rule, this one is made to be
broken. If your sky is the subject of your photo and much
more interesting than the ground, go ahead and place the
horizon line one-sixth of the way up. You are the ultimate
judge of how your photos should be composed. If you like the
way a photo looks, chances are good that others will, too.

Giving your subject somewhere to go

If your subject is in motion or looking off the frame of the
photo, make sure to leave room in your photo for him to
move (or look) into. If the viewer of your photo feels like the
subject may move out of view at any moment, it leaves her
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with a sense of unease. Everyone wants to feel like they are in
on what happens next.

The photo in Figure 3.9 is cropped according to the rule of
thirds, so it should look great, right? Not at all. In fact, aren't
you just a little worried looking at the boy that he is about to
lose his balance and fall down?

Figure 3.9

A cropped image that doesn't give the subject somewhere to
go

Closing in on your subject

If you are taking portraits, a good rule of thumb is to close in
as much as possible, even to the extent of trimming off the
top of the head or the ears. If you want to follow the rule of
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thirds, use the eyes as the main subject. You can achieve a
more engaging and personal photo, as shown in Figure 3.10.

Figure 3.10

Cropping an image to close in on the subject

Telling a story with a photo

A picture is worth a thousand words, so when you start
cropping, make sure you aren't taking out an important part of
the story you want to tell. Close-ups are great, but not at the
expense of an interesting environment. The cropped photo on
the left in Figure 3.11 leaves the viewer wondering what
exactly is happening. The wider view on the right in Figure
3.11 lets you in on the full story.

241



Figure 3.11

Cropping an image too much takes the story element out of
the photo

Cropping an image

Now that you have a good understanding about how and why
to crop images, you are ready to do some cropping in
Photoshop. You can crop images in Photoshop in a couple of
different ways. The most common method is to use the Crop
tool in the Toolbox. However, you can also crop a selection,
have Photoshop detect multiple scanned images, and crop
them automatically.
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The following sections discuss using the Crop tool to crop
your images as well as cropping using the Selection tools.
Automatically cropping scanned images is covered in
subsequent sections.

Using the Crop tool

The Crop tool in Photoshop makes cropping your images both
easy and quick. To crop an image, simply select the Crop tool
from the Toolbox and drag the mouse across the area of the
image that you want to keep to create a crop box, as shown in
Figure 3.12. When you are finished selecting the area,
double-click the mouse on the crop box or click the Commit
button in the Options bar to crop the image.

Figure 3.12

Cropping an image using the Crop tool in Photoshop
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The Crop tool is simple and quick to use, and the crop box
also makes it very versatile. You have these options after
creating the crop box:

• Move the crop box. You can use the mouse to adjust the
position of the crop box in the image after you have created
the crop box.

• Resize the crop box. You can adjust the size of the crop
box by using the mouse to drag the corners and sides of the
crop box.

• Change the center point. You can drag the center point
icon in the middle of the crop box in Figure 3.12 to set the
center position in the cropped image. However, the cropped
image won't be the same size as the crop box if the center
position is moved, because Photoshop must adjust the size to
add enough pixels to adjust for the offset center.

Tip

When changing the position of the crop box, you can use the
Shift+arrow keys to move the box one pixel at a time. This
allows you to make very small adjustments that are difficult
to do with a mouse.

While working with the crop box, the following options are
also provided in the options menu of the Crop tool (see Figure
3.13).

Figure 3.13
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The options menu of the Crop tool in Photoshop

• Aspect Ratio. This option allows you to set the aspect ratio
of the crop box based on one of the following settings:

• Custom. This option enables you to type in specific height
and width values in the two text fields provided in the
Options bar.

• Unconstrained. This option indicates you do not have a
specific aspect ratio in mind. You can then drag the corners
and sides freely to adjust the crop box.

• Original Ratio. This option enables you to drag the corners
and sides, while the image remains in the aspect ratio of the
original image.

• Predefined values: 1x1, 4x5, 8x10, 8.5x11, 4x3, 5x7, 2x3,
4x6, 16x9. This option is extremely useful when cropping
images for standard print sizes. These values maintain the
aspect ratio of the crop box to match the predefined values.
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• Size and Resolution. This option opens a dialog box that
allows you to set a specific height, width, and resolution. This
allows you to specify a crop box size based on a resolution
other than that of the existing document. This is very useful
when cropping images to be placed in other documents.

• Rotate Crop Box. This option allows you to set the size of
the crop box to match the available pixels as you rotate the
image. When you select this option, the Rotate tool is
enabled; as you drag the tool, the image rotates and the crop
box is automatically adjusted to the smallest rectangle
possible without overlapping the border of the image.

• Switch Orientation. This option allows you to switch the
orientation of the crop box between landscape and portrait.

• Straighten. This option enables a ruler tool. You can use
the ruler tool to drag a horizontal or vertical line that matches
what should be horizontal or vertical in the image. The image
is automatically rotated so that the line you have drawn is true
horizontal or vertical, thus straightening the image.

• Overlay View. This option is a very useful feature of the
Crop tool, which allows you to have grid lines that help you
see the balance of the photo area that you are keeping. The
Overlay View option in the Crop tool options menu, shown in
Figure 3.13, allows you to select a Rule of Thirds, Grid,
Diagonal, Triangle, Golden Ratio, Golden Spiral, or no
overlay. The Grid overlay is useful for previewing how the
uncropped area of the photo will be spaced after cropping.
The Rule of Thirds overlay helps you more easily crop to
match the rule of thirds guideline. The Cycle Overlay option
in this menu changes between the different overlay grids,
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although I prefer to use the O shortcut key to cycle through
the grids.

• Crop Options. This option brings up a menu that allows
you to set additional options that affect the behavior and look
of the Crop tool. The following list describes some of the
Crop options:

• Use Classic Mode. When you select this option, the crop
box reverts to the classic Photoshop crop box that many users
prefer. However, I think that the new features are well worth
learning.

• Show Cropped Area. When you select this option, the
cropped area remains visible outside the crop box, allowing
you to see what is being removed.

• Auto Center Preview. When you select this option,
Photoshop adjusts the view to center the uncropped part of the
image.

• Enable Crop Shield. This option is another useful feature
in the Overlay View drop-down menu of the Crop tool
options in the Shield Options setting. When you select Shield
Options from the Overlay View drop-down menu, a dialog
box appears, allowing you to change the shield color and
transparency. The crop shield covers the area of the image
that is going to be cropped with a partially transparent color.
This helps you visualize what is being clipped out and what is
being kept. You can set the overlay color and adjust the
opacity to give you the best overall view. Typically, you want
enough of the background to show through so you can see
what is being removed; however, the less of the background

247



that shows through, the easier it is to see what the results of
the crop will be.

• Delete Cropped Pixels. This option destroys the pixels
when you apply the crop. Use this option if you know you are
not going to need the pixels outside the crop and want to free
up memory so that Photoshop can work faster.

• Revert Crop. This option reverts the crop to the original
settings.

• Cancel Crop. This option cancels the current crop
operation.

• Commit Crop. This option commits the current crop
operation.

Cropping an image to a different perspective

A great feature of Photoshop cropping is the ability to
actually crop an image to a different perspective. The
perspective crop box is not resized in a uniform manner; each
of the corners moves independently, resulting in a skewed
box. Keep in mind that the crop still results in a rectangular
image. Photoshop calculates the adjusted positioning and
changes the perspective of the pixels. I discuss the perspective
transform in Chapter 19.

To crop an image to a different perspective, select the
Perspective Crop tool from the Toolbox. Then draw a crop
box and drag the corners to create a perspective crop box as
shown in Figure 3.14. When you commit the crop, Photoshop
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crops the image to the new perspective, as shown in Figure
3.14.

Figure 3.14

When you crop an image using the Perspective Crop tool, you
can completely alter the perspective of the image.

Cropping using the Selection tools

Another method of cropping images in Photoshop is to create
a selection using the Selection tools and then choosing
Image⇒Crop. This crops everything outside a rectangle
around the selected area.

Cropping an image using a selection has some advantages
over using the Crop tool. The Crop tool is limited in shape to
a simple rectangle, whereas the Selection tools can quickly
select objects of any shape. You can then crop the image to fit
only the selected object. Another advantage is that you can do
several different operations while a selection is highlighted
that you cannot do while a crop is highlighted.
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Cropping from a selection is often convenient, but it does
have some drawbacks. It does not provide as many options as
using the Crop tool. Also, even though the selection is not
rectangular, the crop is. Typically, the Crop tool is the best
option when you are planning to crop an area of an image.
The ability to crop around a selection provides an alternative
option for times when you already have an area selected that
fits the area that you would like to crop.

Straightening an image

One of the most common editing tasks is straightening an
image. For example, when you take a photo with the camera
slightly angled, or even on its side, the result does not look
right.

Note

The Perspective Crop tool can also be used to straighten
images. Especially if lighting, positioning, or other factors
required the shot to be taken at an odd perspective.

Photoshop provides three basic methods for straightening
images. One is to simply rotate the image by a specific angle,
another is to rotate the image while you are cropping it, and
another is to use the Crop and Straighten utility to
batch-straighten scanned photos.

Rotating and flipping images
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The easiest way to rotate an image in Photoshop is to choose
Image⇒Image Rotation and then select one of the following
options from the drop-down menu shown in Figure 3.15:

Figure 3.15

Using the Image Rotation menu to rotate images in Photoshop

• 180 degrees. This option rotates the image around the center
axis 180 degrees.

• 90 degrees CW. This option rotates the image around the
center axis 90 degrees clockwise.

• 90 degrees CCW. This option rotates the image around the
center axis 90 degrees counterclockwise.

• Arbitrary. This option launches the Rotate Canvas dialog
box, which allows you to select an angle to rotate the image
as well as whether to rotate the image clockwise or
counterclockwise. Photoshop increases the image size to keep
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the full original pixels in the rotated version, and adds any
new space that is created as the background color.

Note

When you rotate an image 180 degrees, the dimensions and
pixels do not change. When you rotate an image 90 degrees,
the dimensions swap places but the pixels do not change.
However, when you rotate an image at an arbitrary angle,
the dimensions of the image increase to retain the corners of
the rotated image within the full image canvas. More
importantly, Photoshop alters the actual pixels of the
original photo slightly because they are no longer aligned in
the same direction as they were. Therefore, some data is lost
and you may end up with some residual artifacts. You
should avoid rotating images several times, because each
time leads to more distortion.

• Flip Canvas Horizontal. This option flips the entire canvas
on its back in the horizontal direction, resulting in a mirrored
image of the original. This is similar to taking a transparent
sheet and flipping it over from left to right.

• Flip Canvas Vertical. This option flips the entire canvas on
its back in the vertical direction. This is similar to taking a
transparent sheet and flipping it over from top to bottom.

Rotating while cropping

Another option is to rotate the image at the same time you are
cropping it using the Crop tool. This has the advantage of not
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creating any additional background pixels to accommodate
space that was not in the original image because the cropping
will be rectangular.

As discussed earlier, you can crop an image by selecting the
Crop tool from the Toolbox and then selecting an area in the
image to crop. In addition to the other options that I
discussed, you can rotate the crop box by moving the mouse
over the crop box until the rotation cursor appears, as shown
in Figure 3.16. Then click the left mouse button and drag to
rotate and straighten the image.

When you rotate the crop box, it rotates around the center
point icon. You can adjust the center point to get a better
angle when rotating the crop.

Tip

When using the Crop tool to straighten an image, you
should turn on the grid lines in the Crop Guide Overlay and
use them to align the rotated crop box with an element of the
image that should be either horizontal or vertical, such as a
water line or a building.

Using the Crop and Straighten tool

One of the most common tasks people use Photoshop for is
retouching old photos. Often these photos are scanned in
batches on a flatbed scanner. One of the biggest problems is
that the photos can move around and so are not aligned very
well in the final scan. Another problem is that each scanned
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image may contain several photos when you only want
individual photos.

Figure 3.16

Selecting the rotation cursor around a crop box to rotate an
image in Photoshop

Photoshop provides the Crop and Straighten tool to solve both
of these problems. The Crop and Straighten tool analyzes the
scan and looks for white space around the images. Then it
copies the individual photos in the original image into new
documents. The results are a set of new files, each containing
only a single photo that is correctly rotated.
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To use the Crop and Straighten tool, open the image that
contains the scan of multiple photos, similar to the one in
Figure 3.17. Then choose File⇒Automate⇒Crop and
Straighten Photos from the Photoshop menu bar. You see a
progress bar while Photoshop analyzes the data in the image,
and then separate documents open containing the individual
cropped and straightened photos from the original scan, as
shown in Figure 3.17.

Tip

The Crop and Straighten tool can also be used even if there
is only one photo in an image, as long as there is enough of
a border around the photo that Photoshop can detect the
edges.

Figure 3.17

Using the Crop and Straighten tool to automatically detect,
crop, and straighten a series of photos contained in a single
scan
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Using the Ruler tool

An excellent tool for straightening images is the Ruler tool.
You can use the Ruler tool to draw a line on an image and
then click the Straighten button in the options menu, shown in
Figure 3.18, to straighten the image based on the angle of the
ruler line. The image is straightened vertically or horizontally
to match the angle of the line. If the line drawn with the Ruler
tool is exactly vertical or horizontal, then no change is made.

The Straighten option of the Ruler tool works best on images
that have a reference plane such as the side of a building or a
horizon that should be exactly vertical or horizontal. Figure
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3.18 shows an example of using the ruler to straighten a
sunset image. Notice that the horizon in the original is
crooked, making the image look odd. A line is drawn with the
Ruler tool and then when the Straighten button is clicked, the
horizon matches the horizontal plane of the image.

Figure 3.18

Using the Straighten Layer button in the Ruler tool options,
you can quickly straighten an image based on the line you
have drawn with the Ruler tool.

On the Web

You can find the image shown in Figure 3.18 on this book's
website, as Figure 3.18.jpg. You can open it in Photoshop
and use the Ruler tool to straighten the horizon.

Trimming a border
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The Trim utility provided with Photoshop allows you to
quickly trim off the border around an image. This can be a
useful tool when you are working with scans of older photos
that contain borders, a screen shot of an image that contains a
border, or a document that has empty space around the
outside.

The Trim utility detects the border based on a specific color
or blank pixels and then trims the edges of the document
based on that color. The Trim utility allows you to specify
whether to use transparent pixels, the color of the pixel in the
top-left corner, or the color of the pixel in the bottom-right
corner of the image to trim the edges. You can also specify
which of the top, bottom, left, and right edges of the border
you want Photoshop to remove.

To trim the border around an image, choose Image⇒Trim to
launch the Trim dialog box, shown in Figure 3.19. Then
specify the options you want and click the OK button to trim
the image.

Figure 3.19

Using the Trim utility to trim the border of an image
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Summary

This chapter discussed the basics of images and viewing files.
Some file formats offer advantages over others, depending on
the purpose for which you are using them. Although you will
likely use the Photoshop format for most of your editing, you
will probably gravitate to one of the main file types such as
TIFF or JPEG for saving the edited images.

Resolution and size have a relationship based on the desired
output medium of the images. Using the Canvas Size tool,
you can add additional space to an image without changing
any of the existing pixels in the image.

This chapter also discussed how to crop, straighten, rotate,
and trim images. You can use the Crop tool to crop and
straighten images. You can also straighten and rotate images
using the options in the Rotate Image menu.

In this chapter, you learned the following:
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• The different file formats for images, video, and 3-D objects
that Photoshop is capable of supporting, what they are for,
and when to use them

• Opening images, and resizing and adjusting their resolution

• Using the Image Size tool to set the size and resolution of an
image to match the destination

• Using guidelines when cropping images

• Using the Crop and Straighten utility to detect borders, crop
them, and straighten photos, all at the same time

260



Chapter 4: Understanding Colors, Histograms, Levels, and
Curves

In This Chapter

Understanding color and how Photoshop uses it

Understanding how to use histograms to analyze colors

Using the Curves tool to adjust tones

Selecting a color mode for an image

Selecting colors in Photoshop

Color is the basic element for everything that you do with
images. The purpose of this chapter is to help you understand
how Photoshop perceives color so you can use the tools in
subsequent chapters more effectively.

Photoshop provides some very powerful tools to analyze,
adjust, and select colors in your images. This chapter
discusses using the histogram to understand the color
composition in an image. You need to understand the
histogram to make the most out of tools such as Levels and
Curves.

This chapter also discusses the color modes supported in
Photoshop and how to select colors based on those color
modes. Understanding the color modes gives you an insight
into how Photoshop perceives color and consequently how to
make the most out of the editing tools that it provides.
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Knowing Color Basics

Color is the basic element of all images. Understanding color
helps you make better adjustments and corrections to your
images. Photoshop allows you to work in several different
color models, and understanding color helps you choose the
best color model to use.

Understanding color

The human eye can detect millions of different colors, but
really, what are those colors made of? Put simply, color is
made of light. Light travels in a series of waves. Visible light
is made of waves traveling between a specific set of
wavelengths. White light is light that contains waves of all
frequencies and therefore contains all colors.

The human eye can distinguish the different wavelengths of
the light waves. The wavelength of each light wave
determines the color that the eye detects. For example, light
waves with frequencies on the low end of the visible light
spectrum are interpreted as blue, and light waves with
frequencies on the high end of that spectrum are interpreted as
red.

When the eye looks at an object, it is detecting the light that is
reflecting off the object. Depending on the nature of the
object's surface, some of the frequencies are absorbed by the
surface and some are reflected into the eye, producing the
colors we see.

Looking at color, intensity, and the human eye
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The eye detects color in light waves through tiny receptor
cells in the retina called cones. Light stimulates these receptor
cells, and they transfer the data to the brain. There are three
types of cone cells. The first type, S (short), are sensitive to
the higher frequencies or shorter wavelengths of bluish light.
The second type, L (long), are sensitive to the lower
frequencies or long wavelengths of yellowish light. The third
type, M (medium), are most sensitive to the middle
frequencies or middle wavelengths of greenish light.
Therefore, the color is broken down into three basic
components by the eye, regardless of the complexity of the
wavelength composition in the light it is receiving. This
concept is important as you look at topics such as channels,
histograms, and color management throughout this book.

Another attribute of light that affects the colors you see is the
intensity. Intensity is the strength of the light reaching the eye.
Basically, brighter light carries more intensity than dimmer
light. Because the cones in the eye are stimulated by the light
waves, less intense waves stimulate them less, resulting in a
limited amount of data being collected. This limits the
number of shades of a color that the eye can discern.
Understanding this concept helps you when you are making
adjustments and correcting photos.

The eye overcomes dim lighting by using additional receptor
cells called rods. In bright light, the rods perform almost no
function; however, in dim light, the rods transfer additional
data to the brain. The data from the rods is colorless,
however, which is why we don't see much color in very low
lighting. This is also why indoor photos taken with a flash
typically appear much better than those taken without a flash.
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Note

The cones in the eye are most sensitive to colors on the
upper end of the visible light spectrum. Therefore, colors
such as red, green, and yellow are affected less by reducing
the intensity than colors such as blue and purple. For this
reason, in low lighting conditions you lose more contrast in
the purple-to-blue range than in the red-to-yellow range.

Understanding Channels and Levels

Photoshop applies the concepts of digital color in a way
similar to how our eyes work. Digital color is divided into
channels and levels. A channel represents a specific color,
and a level represents the intensity of that color. Using
combinations of different levels of channels, Photoshop can
represent millions of colors.

To better illustrate this concept, you can look at how some
colors are represented in Photoshop using the RGB color
mode (discussed later in this chapter). Using the RGB color
mode, all colors are divided into three channels: red, green,
and blue, hence RGB. Each channel has an intensity level
range of 0 to 255, where 0 is none of the color and 255 is the
full intensity of the color.

Using the RGB color model, the color red is represented as
255 in the red channel, 0 in the blue channel, and 0 in the
green channel. Similarly, green is represented as 255 in the
green channel and 0 in the other two channels. Yellow is
represented as a combination of the red and green channels at
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255 and the blue channel at 0. To get black, you set all
channels to 0; to get white, you set all channels to 255. In this
way, all colors can be represented as a combination of
different levels of the red, green, and blue channels.

Tip

Often, when working with multiple images, images on
multiple computers, or in different applications, you need to
keep the color consistent. If you note the level value in each
channel, you can easily reproduce the exact same color later.
For example, you may be working in RGB mode and need
to create a specific color of blue where the red channel has a
level of 26, the green channel has a level of 74, and the blue
channel has a level of 158.

Each of the different color modes uses different color
channels. However, all color modes vary the levels of each
channel to represent different colors or tones. Photoshop
provides several tools that use the concept of channels and
levels to adjust images and apply special effects.
Understanding how channels and levels represent color helps
you use those tools in a much broader scope.

Adjusting with Histograms

One of the most useful tools Photoshop provides when
adjusting colors and tones in your images is the histogram.
Using histograms, you can see the composition levels in one
or more channels. At first, histograms may seem daunting;
however, after you understand what they represent, your
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Photoshop life will never be the same. This section discusses
what histograms are and how to use the histogram tools
provided in several areas of Photoshop to quickly adjust the
levels of channels.

Understanding histograms

The first step in adjusting images with histograms is to
understand what they are. Under-standing what Photoshop
uses to build a histogram and what the histogram represents
will help you make better adjustments.

At first glance, a histogram looks like the silhouette of a
mountain range, as shown in Figure 4.1. A histogram is really
just a vertical bar chart. Photoshop constructs the chart by
looking at each pixel in the image and counting the number of
pixels that contain a value of 0 for that channel, then the value
of 1, and so forth up to the value of 255.

Figure 4.1

A histogram of the RGB levels of an image in Photoshop

Using the bar chart, histograms show how the levels of each
channel are distributed in the image. So what does this mean?
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It means that you have a visual representation of the color and
intensity distribution in your image.

You can interpret the visual data in the histograms in many
ways to understand the composition of colors and light in an
image to help you make the most out of the Photoshop
adjustment tools. To illustrate this, the following sections
cover how to use histograms to determine the exposure and
color balance in an image.

Determining overexposure and underexposure in an image

One of the most useful features of a histogram is the ability to
quickly determine how overexposed or underexposed an
image is. While some photos are obviously overexposed or
underexposed, the exposure of others may be difficult to
determine by just looking at them. Using histograms helps
you quickly tell whether an image is overexposed or
underexposed.

Tip

When adjusting color, contrast, levels, and tone of an image,
first check to see if the image is overexposed or
underexposed. You want to adjust the exposure first as
discussed in Chapter 13.

An image that is overexposed has mostly higher levels for all
channels and almost no lower levels because more light was
recorded in the image. Therefore, the histogram is skewed to
the right. Figure 4.2 shows an example of an overexposed
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image. Notice that most of the data in the image falls in the
right end of the histogram.

Figure 4.2

A histogram of the RGB levels of an overexposed image in
Photoshop

Images that are underexposed have mostly lower levels for all
channels and almost no higher levels because not enough
light reached the image. Therefore, the histogram is skewed
to the left side instead of the right. Figure 4.3 shows an
example of an underexposed image. Notice that most of the
data in the image falls in the left end of the histogram.

Figure 4.3

A histogram of the RGB levels of an underexposed image in
Photoshop
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Determining color balance in an image

Histograms allow you to ascertain the color balance in
images. Understanding the color balance helps when you are
trying to correct color and tonal issues in images. For
example, if you look at the histograms of an image that
should be balanced and see that the image has a
disproportionate amount of red, you can easily adjust this.

The best way to determine color balance in an image is to
look at the histograms of each color channel individually.
Viewing the histograms of each channel shows how much of
that color is present in the image compared to the other color
channels, as well as a distribution of the levels of each
channel.

Note

When viewing the color channel histograms of an image,
keep in mind what colors should be present. For example, if
you are working with an RGB image of a boat on the ocean
with a blue-sky background, you should see a lot of blue,
but not much green, and almost no red. However, if the
image contains people, with green trees in the background
and a blue sky, then there should be a fairly even
distribution of red, green, and blue.

Figure 4.4 shows the channel histograms of an RGB image.
Notice that the red channel contains low amount of data that
is evenly distributed in the lower levels and a bulge in the
upper levels. The green channel has a heavy amount of data
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throughout although it is more heavily weighted to the upper
levels. The blue channel contains a moderate amount of data
that is evenly distributed throughout.

Obviously, the color levels in this image are not balanced, but
what does that mean? Well, if the image is of a green plant as
this image was, then it just means that the image contains
much more green than any other color. However, if the image
is a snapshot of a person's face, then it means that their skin
tone has a severe green colorcast, and you will need to add
red to get the pink back in the cheeks. Higher amounts of data
in the low levels means that there are more darker levels of
that color in the image and conversely for the upper levels.

Figure 4.4

The color level histograms of an RGB image in Photoshop
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Using the Histogram panel

The previous sections discussed the importance of using
histograms in understanding the composition of light and
color in an image. Photoshop provides a Histogram panel that
helps you quickly view the important histograms of an image.

Using the Histogram panel, you can view the histograms of
individual channels, all channels together, colors, and
luminosity. You can also use the histogram tool to view
histograms of specific layers. In addition to the histograms,
the Histogram panel can show you numerical statistics about
the level composition of each histogram.

Tip

When you are adjusting or correcting color, hue, tone,
contrast, and so on, you should display the Histogram panel
for the image. Look at the overall histogram to check for
over- and underexposure. Also, look at the individual
channels to verify that the color balance is what you would
expect for that image.

You can display the Histogram panel, shown in Figure 4.5, by
choosing Window ? Histogram from the Photoshop menu bar.
The following sections describe how to configure and use the
Histogram panel to view histograms and statistics.

Figure 4.5

The Histogram panel in Photoshop
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Setting Histogram panel options

The Histogram panel provides several views that you can set
by selecting the menu icon shown in Figure 4.5. The
following settings in the Histogram panel menu allow you to
configure what information appears in the Histogram panel:

• Compact View. The compact view, shown on the left in
Figure 4.6, displays only the histogram image of the current
channel. This view is handy if you just want to dock the
histogram with several other panels to view changes as you
adjust the image.

• Expanded View. The expanded view, shown in the center
in Figure 4.6, displays the histogram image of the current
channel but also provides the option to select different
channels and sources for the histogram. It also displays the
statistics if you have selected the Show Statistics option.

• All Channels View. The all channels view, shown on the
right in Figure 4.6, displays the histograms of all channels in
addition to everything that the expanded view shows.
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• Show Statistics. The Show Statistics setting toggles the
statistics on and off in the expanded and all channels views.

• Show Channels in Color. The Show Channels in Color
option toggles the color view of channels on and off. When
you select this option, the histograms of individual channels
appear in the channel color. This is useful if you are viewing
a specific channel, because it is easy to distinguish which
channel it is.

Selecting channels

The Channel menu, shown in Figure 4.7, allows you to select
a specific channel to view. The channel that you select
appears in the compact and expanded views and at the top of
the all channels view. The statistics are based on the channel
that you select.

Figure 4.6

The compact, expanded, and all channels views of the
Histogram panel in Photoshop
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Note

The channels that are available in the Channel drop-down
list depend on the color mode of the current image. For
example, if the color mode is RGB, then the channels
available are Red, Green, and Blue; if the color mode is
CMYK, then the channels are Cyan, Magenta, Yellow, and
Black.

Figure 4.7

The Channel drop-down list in the Histogram panel of
Photoshop
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The following channels are available in the Histogram panel:

• All Channels. This option selects all the channels for the
color mode, and is located at the top of the Channel
drop-down list. For example, if you are using RGB, the top
item is RGB and it selects all channels to use for the
histogram views and statistics.

• Single Channel. These options allow you to select an
individual channel from the Channel drop-down list, such as
Red, Green, or Blue.

• Luminosity. This option calculates the histogram and
statistics based on how much general light, or luminosity, is
coming from a composite of all channels. This is useful in
determining the over- and underexposure in an image.
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• Colors. This option displays a histogram that is a composite
of all color channels as well as the overlapping colors they
generate. This is useful for seeing the general color
composition in the image.

Selecting a source

The Histogram panel allows you to select different sources
from which you can calculate the histograms. Selecting one of
the following options from the Source drop-down list enables
you to view a histogram from any layer or adjustment layer or
for the entire image:

Note

The image must have more than one layer or adjustment
layer to use the Source menu to select alternate sources.

• Entire Image. This option calculates the histogram based
on a composite of all layers. Basically, this is the histogram of
the image if you flatten out all your layers.

• Selected Layer. This option calculates the histogram based
on the selected layer in the Layers panel. You use this option
to calculate histograms on only a single layer.

• Adjustment Composite. This option calculates the
histogram based on the adjustments made in the selected
adjustment layer and all layers below it. This displays the
adjustments you have made to an image in graphical form.

277



Tip

When combining elements from multiple images, add the
selection from one image as a layer in the second image.
Then you can use the Selected Layer option in the Source
drop-down list of the Histogram panel to compare the
histograms of each layer to see how well the colors match
up. Making the histograms match more closely helps the
composite image look better.

Understanding statistics

The statistics data in the Histogram panel, shown in Figure
4.8, displays the numerical values that are represented in the
histogram image as well as some additional items. Most
people would never need to use these statistics because image
editing is really more of an art than a science. However,
having specific numerical data about the histograms can be
useful if you are closely comparing images.

Tip

Many of the statistics change to match the level of the pixel
under the mouse cursor as you move the mouse over the
image.

Figure 4.8

The statistics data in the Histogram panel

278



The following statistics are available from the statistics view
in the Histogram panel:

• Mean. This represents the average level for the selected
channel.

• Standard Deviation. This represents the variability of the
selected channel — in other words, how varied in intensity
levels the color in the selected channel is.

• Median. This shows the exact middle value of the intensity
levels for the channel. In other words, if you placed the pixels
that are more intense on one side of a scale and the pixels that
are less intense on the other side of the scale, they would be
evenly balanced.

• Pixels. This shows the number of pixels in the selected
channel. This can be useful to see how much data a specific
layer contains — for example, if you create a selection mask
as a layer (as discussed in Chapter 10).

279



• Level. This shows the intensity level value directly under
the mouse pointer when the mouse is over the histogram.

• Count. This shows the total number of pixels in the image
that contain a level of intensity equal to the level under the
mouse cursor in the histogram.

• Percentile. This displays the percentage of pixels in the
image with intensity levels that are at or below the level under
the mouse cursor in the histogram. The percentage is
calculated based on a percentage of all pixels in the image, so
the level to the farthest left is 0 percent and the level to the
farthest right is 100 percent.

• Cache Level. This displays the setting for the current cache
level if you select the Use Cache for Histograms option in the
Preferences dialog box.

Adjusting images with the histogram tools

Some Photoshop features provide histogram tools to help you
adjust and correct images. Although we cover using the tools,
such as the levels adjustments, in subsequent chapters, you
need to have a general knowledge of how they work.

The tools that Photoshop provides all have the same basic
components. As an example, look at the Levels tool in Figure
4.9. The input levels are represented as a histogram. Below
the histogram view are three triangular control handles that
allow you to easily adjust the input levels of the channel in
the image. To the right of the histogram are three eyedropper
tools that allow you to select dark, light, and midtone points
in the image to quickly adjust the input levels of the channel.
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The following sections briefly discuss how to use these tools.
We discuss the tools in more detail in subsequent chapters as
we show you how to correct and adjust images.

Figure 4.9

The Levels dialog box showing the histogram utility that
Photoshop provides in several different tools

Using the handles to adjust the histogram

The dark handle on the left controls the minimum level for
the channel, the white handle on the right controls the
maximum level for the channel, and the middle gray handle
controls the balance of middle tones between the high and
low levels.
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So what do the histogram controls really do? To help clarify
this, notice that most of the level values in the histogram
shown in Figure 4.10 are located to the right of the center
levels. That means a relatively small number of tones are
represented in the image, about 100 out of 255. The result is
typically a washed-out image with very little detail.

Now move the left control over to the right until it is on the
left side of the histogram mountain, and move the right
control to the left until it is on the right side of the histogram
mountain, as shown in Figure 4.10.

On the Web

You can find a file with a histogram similar to the one in
Figure 4.10 on this book's website as Figure 4.10.tif. You
can open it in Photoshop. Try adjusting the levels and see
how changing the histogram affects the image.

Notice that the values of the Histogram panel are now
distributed more evenly between 0 and 255. This means a
greater range of tones is represented in the image because it
includes values ranging between 0 and 255 instead of just a
range between about 123 and 177. The tonal range of the
entire image has been extended, providing much more detail
with the simple adjustment of the two sliders.

Figure 4.10

Adjusting the minimum and maximum levels on the Levels
tool expose more detail to the image
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The middle handle simply adjusts the balance of the midtone
levels in the histogram. When the histogram is weighted
heavily to one side or the other, you can move the middle
adjustment handle toward that side to balance midtones
represented in the image.

For example, the Levels tool shown in Figure 4.11 is
weighted heavily to the left, which means that all the data for
the image is in the darker end of the levels. If you move the
midtone handle to the left toward the middle of the histogram
mountain, the histogram mountain moves to the right to
balance on the new location of the midtone slider.

On the Web

You can find a file with a histogram similar to the one in
Figure 4.11 on this book's website as Figure 4.11.tif. You
can open it in Photoshop. Try adjusting the levels and see
how changing the histogram affects the image.

Figure 4.11
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Adjusting the middle handle in the Levels tool to change the
midtone levels balance in an image

Using the eyedroppers to adjust the histogram

The Eyedropper tools allow you to adjust the levels of a
channel by selecting three points in the image. The
eyedropper on the left sets the minimum level for the channel,
the eyedropper on the right sets the maximum level for the
channel, and the middle eyedropper controls the balance of
middle tones for the channel between the high and low levels.

The eyedroppers work similarly to the control handles, except
that instead of selecting a specific level for the dark, light, and
midtones, you can select pixels directly in the image. To use
the eyedroppers, simply click the left Eyedropper tool and
select a pixel that should appear black in the image. Then
click the right Eyedropper tool, and select a pixel that should
appear white in the image. Finally click the middle
Eyedropper tool, and select a pixel that should match the
midtone for the selected color channel. In the case of all
channels, select a pixel that should appear gray in the image.
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Tip

The eyedroppers are fast and extremely accurate if items in
the image should appear black, white, and gray. If you are
not certain of the colors of the pixels, use the control
handles instead of the eyedroppers.

Adjusting levels with the Curves tool

Another tool that Photoshop provides to help you adjust and
correct images is the Curves tool, which you access by
choosing Image⇒Adjustments⇒Curves from the Photoshop
menu bar. The Curves tool is one of the most difficult tools to
understand, and so many Photoshop users avoid it. However,
after you learn how to use it, a whole new world of color
correction opens up.

While the Histogram tool allows you to change the light,
dark, and midtone values for the histogram, the Curves tool
allows you to apply a complex curve equation to the
histogram, giving you unlimited control over the range of
levels in the image. Using the Curves tool, you can
completely control the tonal properties of an image.

In this section, we discuss what the curve is and how to use
the Curves tool to adjust the levels in an image. We cover
using the different Curves tools in Photoshop for specific
purposes in later chapters.

Understanding curves
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To understand how the Curves tool works, you need to
understand the curve. The curve starts as a diagonal line with
a value of 0 on the left and 255 on the right, as shown in
Figure 4.12. This means that the pixels that currently have an
intensity level of 0 for that channel have a value of 0 in the
histogram, the pixels at level 1 have a value of 1, and so on up
to 255.

Note

The grid lines in the curve window allow you to more easily
tell what the values are for points on the line. The
bottom-left point on the line has a value of 0, the middle
point on the line has a value of 127, and the top-right point
on the line has a value of 255. The point midway between
the bottom-left and middle point of the line has a value of
64, and the point midway between the middle point and the
top-right point has a value of 192.

Figure 4.12

A simple linear curve in Photoshop
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The Curves tool works by applying new level values in the
histogram for each of the current levels. Think of the Curves
tool as a graph with the existing level values specified along
the bottom axis from 0 to 255. The new values are equal to
the values of the points on the line corresponding to each of
the old values.

To help you understand the curve better, look at the following
example. Figure 4.13 shows a modified curve. Notice that the
points on the left (0), right (255), and middle (127) are all on
the original line, which means that pixels with those level
values do not change. However, the curve goes above the
original line before level 127, so the pixels for each of those
levels increase to match the value of the line.

Using only two points may create a problem with the tonal
correction. Notice that the levels close to 0, 127, and 255 do
not change as much as the levels around 64 and 192. To
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overcome this problem, Photoshop allows you to apply
additional points to the line to further adjust the curve.

Figure 4.13

A curve that maps pixels with levels between 0 and 127 to
higher levels, and pixels with levels between 127 and 255 to
lower levels

Using the Curves tool

Now that you understand how the curve works, we discuss
the features of the Curves tool that enable you to create
dynamic curves that can really affect the tones of your
images. You can access these tools whether you are adjusting
images using the Curves tool, with an adjustment layer, or in
Camera Raw.

Selecting the channel

288



The first thing to do is select the channel you want to adjust.
The Channel list, shown in Figure 4.14, allows you to select
any channel or all of the channels.

Adding points

You can add points to the curve by clicking the Points Curve
button and then clicking the curve in the curve panel. When
you select the Points Curve button, you can use the mouse to
add points by clicking the curve. You can add up to 14 points
to the curve, for a total of 16 points including the ends,
because the end points are also adjustable. You can remove
points from the line by dragging them with the mouse to the
bottom-left corner or to the top-right corner of the curve
panel.

Tip

The more points you add to the line, the finer your
adjustments to the tonal correction are. However, adding
more points makes it more difficult to make adjustments
because you may need to adjust multiple points when you
adjust one. To speed things up, make the bigger adjustments
first, and then add more points as needed.

Figure 4.14

The Curves tool in Photoshop
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Adjusting the input levels

You can adjust the input levels using the control handles
along the bottom axis of the Curves panel. This is the same
thing as adjusting the minimum (darkest) and maximum
(lightest) levels in the histogram, and it limits the curved line
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to operate between those ranges. To adjust the input levels,
you simply grab one of the control handles with the mouse
and drag it to the appropriate value.

Tip

You should adjust the input levels before you create your
curve because adjusting the input levels afterward results in
changes to the curve.

Adjusting specific levels from the image

A useful feature of the Curves tool is the ability to select a
level directly from the image. This allows you to select a
particular area of the image based on what colors or tones you
see.

To adjust the levels from the image, click the Click and Drag
button in the Curves panel (refer to Figure 4.14). Then use the
mouse to select a pixel in the image containing the tone you
want to adjust. Photoshop creates a new point on the curve.
While pressing and holding down the mouse button, you can
move the mouse up and down to adjust the level of that point.

Creating a freehand line

If 16 points on the curve line are not enough, you can create
your own line by clicking the Freehand Curve button (refer to
Figure 4.14). The Freehand Curve tool allows you to create
the curve by drawing a freehand line in the curve window
instead of using points.
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You can also use the Freehand Curve tool to make slight,
non-smooth adjustments to the curve after you have created it
with points. Photoshop corrects only the areas of the curve
that you draw with the Freehand tool.

Tip

You can convert a freehand line into a points curve by
clicking the Points Curve button. This is helpful if you need
to make some additional adjustments to the points curve
after you change it using the Freehand Curve tool.

Using the eyedroppers

The eyedroppers work the same way for the Curves tool as
discussed earlier in the Histogram section. Adjusting the
image first with the eyedroppers sometimes gives you a better
base to start from when making tonal corrections with the
curve.

Working in Different Color Modes

Photoshop provides several color modes that help you work
with images. Color consists of different intensities of light at
different frequencies. However, that data needs to be
translated into a quantifiable form that Photoshop, the
monitor, printers, and ultimately you can understand. This
section gives you an overview of the different color modes
available for use in Photoshop and why you would use them.
It also helps you understand the Bits/Channel settings for the
image modes.
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Understanding the different color modes

A color model is simply a method to translate the light
captured in an image into a digital form that the computer and
other devices can understand. Each color model divides the
light into one or more channels and then assigns an intensity
level to each channel for each pixel in the image. Photoshop
provides several color modes that match the most common
color models.

Depending on what you are doing with an image, you want to
use a specific color mode that provides the best management
of the color. To set the color mode of an image, you choose
Image⇒Mode and then select the mode you want to use from
the Photoshop menu bar. The following sections discuss each
of the color modes and what they are for.

Bitmap

The Bitmap color mode contains only one channel with only
two possible levels, 0 and 255. As a result, a bitmap is a
black-and-white image without color or even shades of gray.
In essence, the image becomes a series of black dots on a
white background. This may not sound very useful; however,
there are several good uses for these types of images.

The most common use of the Bitmap mode is outputting an
image to a black-and-white laser printer. Laser printers create
images as a series of black dots on the page. So working with
the image as a bitmap lets you make changes to a version that
appears exactly how it will when it is printed by the laser
printer.
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Tip

Bitmap images that are printed on low-resolution laser
printers often end up darker than you would expect. Be sure
to lighten the image before printing it to a low-resolution
laser printer.

The Bitmap dialog box shown in Figure 4.15 lets you set the
resolution and method to use when creating the bitmap from
the image. You should set the resolution to the same
resolution that you will be using to output the image to the
printer.

Figure 4.15

The options for the Bitmap mode in Photoshop

You can select the following methods from the Method
drop-down list in the Bitmap dialog box:
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• 50% Threshold. This sets every pixel in the image that is
more than 50-percent gray to black, and every pixel that is
50-percent gray or lighter to white. This is by far the simplest
pattern; however, the result is very choppy, and the image
typically doesn't look very good unless you are trying for a
special effect, in which case it would be better to use the
Threshold tool in the Image⇒Adjustment menu.

• Pattern Dither. This uses a pattern to mix black and white
pixels together, which results in the appearance of different
shades of gray. The problem with this method is that the
pattern shows up in the image, so the effect is not very
smooth.

• Diffusion Dither. This uses an error-diffusion method of
converting an image into a series of dithered pixels that are
less structured than the pattern dither. The diffusion dither
method produces an image similar to a mezzotint, which often
is the best option for printing on low-resolution laser printers.

• Halftone Screen. This uses a series of dots of varying sizes
and spacing that trick the eye into believing it is seeing a
continuous tone. When you select the halftone screen option,
an additional dialog box pops up that enables you to select the
frequency, angle, and shape of the halftone dots. Typically,
the best shape to use is the round shape because it is closest to
what the printer generates. The frequency depends on the
resolution of the printer. The higher the frequency, the better
resolution you get in the image; however, if you set the
frequency too high, the patterns overlap when printed and the
results do not look good.

295



• Custom Pattern. This allows you to select a custom pattern,
either one of those included with Photoshop or one of your
own. The custom pattern creates similar results to the pattern
dither. Typically, you would only use this option if you had a
specific pattern that you wanted to show up in the image.

Grayscale

The Grayscale mode contains only one channel, but unlike the
Bitmap mode, it can have intensity levels from 0 to 255. The
Grayscale mode is useful if you are outputting the image to a
black-and-white printer.

Tip

You can create a grayscale image from a single RGB
channel by selecting that channel in the Channels panel and
converting the image to grayscale. Only the selected channel
is converted to grayscale. This can be useful for special
effects as well as using the detail in a specific channel.

Another advantage of grayscale is that viewing and adjusting
the image in grayscale reduces the overhead of dealing with
three color channels. Photoshop is much faster at performing
complex operations on grayscale images than on multichannel
images. Having a single channel also makes it easier to make
adjustments to an image because you only need to worry
about adjusting that channel.
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Caution

To change an image from color to grayscale, Photoshop
takes a composite intensity for all three channels and
reduces it to the single grayscale channel. This results in a
loss of the original color channels. Therefore, make sure you
have a backup copy of the file before you save it again.
Also, you can often create a good grayscale effect using
other methods, such as desaturation, without losing the data
in the color channels.

Duotone

The Duotone mode uses one contrasting color of ink over
another to produce highlights and middle tones in a
black-and-white image. Duotones typically are used to
prepare images for printing. Using the Duotone Options
dialog box, you can add one, two, three, or four inks to create
a monotone, duotone, tritone, or quadtone image in
Photoshop.

Use the following steps to configure the monotone, duotone,
tritone, or quadtone options from the Duotone Options dialog
box shown in Figure 4.16:

Note
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The Duotone color mode option is available only for
grayscale images. If you are using a color image, you need
to convert it to grayscale before changing it to a duotone.

1. Select the type of tone from the Type drop-down list.

2. Click the blank swatch for each ink you need to specify.

3. Select the color you want to use for that tone.

Typically, you should use black for the first ink in the list.

4. Click the curve for each ink you need to configure to
launch the Duotone Curve tool.

5. Use the Duotone Curve tool to adjust the tone curve for
that color of ink.

Typically, you do not need to adjust the curve uNL1ess you
want a specific effect from that color of ink.

6. Click the Overprint Colors button, shown in Figure
4.16, to open the Overprint Colors dialog box.

7. Adjust the colors used when one ink is printed over
another ink by selecting the colors for each of the
overlapping options.

Figure 4.16

The options for the Duotone color mode and the Overprint
Colors dialog box in Photoshop
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Indexed color

The Indexed Color mode contains a single channel with a
single set of indexed colors. Converting an image to indexed
color reduces the image to a set of the most important colors.
The remaining colors are given an index between 3 and 256
in a color lookup table. Instead of using the level value of the
pixel to define the intensity of the channel, it points to an
index value in the lookup table for the indexed image.

To change the color mode of an image to indexed color,
choose Image⇒Mode⇒Indexed Color. To view the table of
indexed colors, choose Image⇒Mode⇒Color Table to open
the Color Table dialog box shown in Figure 4.17. The
following are settings that you can modify in the Indexed
Color dialog box:

• Palette. This lets you select which palette to use when
choosing the color to be placed in the index. You can choose
a palette based on Exact, System, Web, Uniform, Local,
Master, or Custom colors. The Local option selects colors
local to the image. If you are working with multiple images,
the Master option selects colors from a master of all of the
images. When selecting local or master palettes, you can use a
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Selective, Adaptive, or Perceptual method of choosing the
colors. The Selective method tries to preserve the key colors
in the image. The Adaptive method simply preserves the most
common colors. The Perceptual method intelligently selects
colors that will provide the best transitions, rather than just
the most common colors. You also have the option to select
System colors for images that will be viewed only on a
computer. The Web option selects only web-safe colors for
images that will be used on web pages.

• Colors. This specifies the number of colors to use in the
color lookup table. The minimum is three colors and the
maximum is 256.

Tip

When creating web images with file formats such as GIF
and PNG-8, using fewer colors results in smaller file sizes.

• Forced. This lets you force the conversion to keep certain
colors in the image. The default option is to force only black
and white to be kept. The Primaries option protects eight
colors: white, black, red, green, blue, cyan, yellow, and
magenta. The Web option protects the 216 colors in the
web-safe colors palette. The Custom option allows you to
preserve a specific palette of colors that you create. When you
select the Custom option, a dialog box launches that allows
you to specify the colors that you want to preserve.

• Transparency. This specifies whether to preserve the
transparency in the image.
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• Matte. This allows you to specify a matte to use when
working with transparency in the image. If there is no
transparency in the image, this option is inactive. If you select
the Transparency option, the translucent areas in the image
are filled with the matte color. If you deselect the
Transparency option, the translucent and transparent areas are
filled with the matte color.

• Dither. This specifies the method Photoshop uses to
calculate replacement colors for colors being discarded from
the image. The None option simply selects the closest color in
the lookup table, which can sometimes result in harder edges
but is typically the best option to use. The Diffusion option
dithers the color randomly, creating a more natural effect. The
Pattern option dithers in geometric patterns, which is usually
the least desirable option because the patterns show up in the
image. The Noise option mixes pixels throughout the image
instead of in just the areas of transition.

• Amount. This specifies the percentage of diffusion to use
when dithering. This option is available only when you select
the Diffusion dithering option. Lower values decrease the size
of the file but result in harsher color transitions.

• Preserve Exact Colors. This turns dithering off for areas of
solid color when you select the Diffusion dithering option.
This option is not available unless you select the Diffusion
dithering option. Using this option helps your images look
better even if you have to use dithering.

Figure 4.17
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The Indexed Color dialog box and the Color Table dialog box
in Photoshop

RGB color

You will likely use the RGB color model most often, as it is
used by computer monitors and the human eye. Photoshop
quickly processes its wide range of vivid colors.

RGB is the model that most closely matches the human eye
for two reasons. First, RGB uses three colors similar to the
receptors in the human eye. Second, RGB is additive,
meaning that as you add higher levels of the color channels,
you get more closer to white, in the same way that more
colors included in visual light reflected by objects results in
the eye seeing white.

In the RGB model, colors are divided into three channels of
red, green, and blue. Each channel has an intensity level range
between 0 and 255. Each color is made up of a combination
of intensity levels from these three channels, resulting in the
possibility of over 16.7 million different colors.
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RGB provides the most vibrant use of colors of all the color
models and is supported by most file formats. The one
downside to RGB is that it contains more colors than can be
printed, especially the brighter colors. This can result in loss
of detail in some areas of your images when you print them.
The solution is to use the CMYK color model if you are going
to have your images professionally printed.

CMYK color

The CMYK color model is completely different from the
RGB model in that it uses a subtractive method, meaning that
the more color you add, the less light you see. This is one of
the reasons the CMYK model works so well for printing.
Think about adding ink to a page; if you add all the colors,
you get black, or rather a really deep brown.

Another difference between the CMYK model and the RGB
model is that CMYK is made up of four channels: cyan,
magenta, yellow, and black. The black channel is necessary
because adding the cyan, magenta, and yellow ink all together
makes a dark brown, not black, so if you want the printer to
print true black, you must have a separate channel to specify
black.

So which of these two models should you use for general
color image editing? The answer is RGB. The RGB model
provides the widest range of colors for tonal adjustment and
correction. The scanner, monitor, and most other devices
work in the RGB model, although the software for most
printers converts the RGB input to CMYK when sending the
image to the device to be printed. Also, editing images in
Photoshop in the RGB mode is much faster than in CMYK.
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Tip

Even if you are using the RGB model, you can choose
View⇒Proof Colors to toggle the view to a simulated
CMYK model. This way you can periodically check to see
how the image will look when printed. Just remember to
turn it off.

Lab color

The Lab color model is very different from RGB and CMYK.
The Lab model does have three channels, but instead of all
three being dedicated to colors, only two — a and b — are
dedicated to color; the third — Lightness — is dedicated to
luminosity.

The a channel maps colors ranging from deep green at level 0
to gray at level 127 to a rich pink at 255. The b channel maps
colors ranging from bright blue at level 0 to gray at level 127
to a dim yellow at 255. The Luminosity channel maps the
brightness of each pixel from dark at 0 to white at 255.

The Lab channel is additive like the RGB model, but it has
only two channels of color mixing, and the levels of those
channels are not mapping to intensity but rather tones of
color. The tones combine to form brighter colors, and only the
Luminosity channel provides data to darken the tone that is
created by the other two channels.

You can edit images in Lab color at about the same speed as
in RGB and much faster than in CMYK, so it is a fun
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alternative if you want to expand the way you think about
mixing colors.

Multichannel

The Multichannel mode separates out the channels in the
current color model into spot channels. You can use spot
channels to store parts of an image that you want to print in
specific inks or spot colors. For example, you can print
specific inks from a Pantone library.

When you convert an image to the Multichannel model, the
current channels are changed to spot channels. The channels
created in Multichannel mode depend on the original color
mode of the image. For example, the RGB model is converted
to cyan, magenta, and yellow spot channels, the CMYK
model is converted to cyan, magenta, yellow, and black spot
channels, and the Lab model is converted to three alpha
channels.

Note

The spot channels overlap, so if you do not want ink from
one channel to be printed onto ink from another channel,
don't allow the data in those areas of the channel to overlap.

Learning about bits per channel

How many bits should you use per channel? The quick
answer is 8 bits per channel, but let's take a closer look. What
does bits per channel mean? A bit is a single item of
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information for a computer with a value of 0 or 1. That
doesn't mean much in terms of an image, but if you string
millions of bits together, it can mean a lot.

Using 8 bits of information, we can define an intensity level
of 0 to 255. For three channels, we can define over 16.7
million different colors for each channel. If we use 16 bits per
channel, that goes up to over 281.4 trillion colors; if we go to
32 bits per channel, well, you get the idea.

So why not just use 32 bits per channel and maximize our
information? The answer is disk space and speed. An image
with 32 bits per channel takes up much more disk space and
much more computer power to edit in Photoshop. Plus, the
human eye can't even detect all the colors in images
containing 8 bits per channel.

And that leads to the question of why we shouldn't just use 8
bits per channel, as it is more than enough for the human eye.
The answer lies in what happens during adjustments,
corrections, and conversions. Each time you make a
correction to an image, change the levels, add a filter, and so
on, you lose some of the distinguishing detail. If you perform
enough corrections on an image with 8 bits per channel, you
may lose noticeable detail in the image. However, if you are
using an image with 16 bits per channel, the data lost is in
levels that the human eye cannot detect, so when you convert
the image back to 8 bits per channel, there is no apparent data
loss.

An image must be in the RGB or Lab color modes if you
want to convert it to 16 bits per channel. To change your
image to 16 bits per channel, choose Image⇒Mode⇒16 Bits/
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Channel. After you have changed your image to 16 bits per
channel, you can change it to 32 bits per channel by choosing
Image⇒Mode⇒32 Bits/Channel.

Note

An image with 32 bits per channel is considered an HDR
(High Dynamic Range) image. Typically, these images are
used in 3-D rendering and advanced CGI animation effects.

Choosing Colors

Color is one of the most important aspects of most photos.
Color changes can greatly alter the overall visual effect. You
will be working with many different tools in Photoshop that
require you to select colors, so you need to know how to
select colors accurately in order to use these tools.

Remember that even when working with 8 bits per channel,
you can choose from more than 16 million colors. The
following sections discuss the most common methods that
you will use to select colors.

Choosing colors with the Color Picker tool

The most common method of choosing a color is by using the
Color Picker tool. You launch the Color Picker by clicking
the foreground or background tool in the Photoshop Toolbox.

The Color Picker tool, shown in Figure 4.18, allows you to
select any available color in Photoshop and gives you a
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wealth of information. The main areas of the Color Picker
tool are the color chooser pane, the range slider, the new/
current color view, and the color settings.

The Color Picker lets you use the mouse to select the color of
any pixel displayed in the pane. The range slider lets you use
the mouse to adjust the range of colors displayed in the color
chooser pane. The new/current color view simply shows the
current color on the bottom and the newly selected color on
top for comparison purposes.

Figure 4.18

Selecting colors using the Color Picker tool

Photoshop provides these color settings so that you can
change each individual aspect of a color to define it. Selecting
one of the color settings changes the types of color that the
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color chooser pane can display. Changing the value of one of
the settings changes the selected color. This list describes the
available settings in the Color Picker tool:

• H. Changes the hue of the color. The hue values are based
on a range from 0 degrees to 360 degrees. Think of a color
wheel where red is at 0/360 degrees, green is at 120 degrees,
and blue is at 240 degrees. The hue setting is one of the best
to use when selecting colors because it allows you to quickly
move to a specific color using the range slider.

• S. Changes the saturation of the color. The values range
from 0 to 100 percent. A higher saturation value means more
of the color, and a lower saturation value brings the color
closer to gray. If you have chosen a color but you want a
slightly different saturation, this is the best option to select for
the range view.

• B. Changes the brightness of the color. The values range
from 0 to 100 percent. Higher values mean the colors are
brighter, and lower values mean they are darker. This is also
useful when you have chosen a color but you want to slightly
adjust the brightness.

• R. Changes the intensity of the red channel in the color. The
values are based on intensity levels of 0 to 255. Lower values
mean less red, and higher values mean more intense red.

• G. Changes the intensity of the green channel in the color.
The values are based on intensity levels of 0 to 255. Lower
values mean less green, and higher values mean more intense
green.
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• B. Changes the intensity of the blue channel in the color.
The values are based on intensity levels of 0 to 255. Lower
values mean less blue, and higher values mean more intense
blue.

• #. Specifies the hexadecimal code associated with the color.
This is useful for colors that are specified in web pages and
for specifying a particular color without having to memorize
multiple values. The format of the hexadecimal code
represents the level (amount) of red, green, and blue in the
color. The first two digits represent red from 00 to FF, the
middle two digits present green from 00 to FF, and the last
two digits represent blue from 00 to FF.

• L. Changes the lightness of the color. The values are based
on a luminosity of 0 to 100. Higher values approach white,
lower values approach black, and middle values specify the
tone of the color. This is useful when you have the color you
want but want to adjust the luminosity.

• a. Changes the value of the a channel in the Lab color mode.
The values are based on tones between −128 and 127, where
−128 is green, 127 is pink, and 0 is gray.

• b. Changes the value of the b channel in the Lab color
mode. The values are based on tones between −128 and 127,
where −128 is blue, 127 is yellow, and 0 is gray.

• C. Specifies the percentage of cyan in the color. The values
are based on a range from 0 to 100 percent, where 0 percent is
no cyan and 100 percent is full-intensity cyan.
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• M. Specifies the percentage of magenta in the color. The
values are based on a range from 0 to 100 percent, where 0
percent is no magenta and 100 percent is full-intensity
magenta.

• Y. Specifies the percentage of yellow in the color. The
values are based on a range from 0 to 100 percent, where 0
percent is no yellow and 100 percent is full-intensity yellow.

• K. Specifies the percentage of black in the color. The values
are based on a range from 0 to 100 percent, where 0 percent is
no black and 100 percent is full-intensity black.

Another nice feature of the Color Picker tool is the ability to
add the color you have chosen to the Swatches panel. This is
especially nice if you have taken a long time to find just the
right color. To add the color to the swatch, click the Add to
Swatches button and specify the swatch name to add the color
to.

The Color Picker tool also allows you to select colors from a
color library such as a Pantone color. To select a color from a
color library, click the Color Libraries button to open the
Color Libraries dialog box shown in Figure 4.19. Select the
library book from the drop-down menu, and choose the color.
To change back to the Color Picker, click the Picker button.

Figure 4.19

Selecting a color from the Color Libraries tool in Photoshop
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Using the Color panel

Another method of choosing a color is by using the Color
panel. The Color panel provides the option of quickly
selecting a color based on one of the color models or using
sliders to adjust the levels of the color channels. To launch the
Color panel, choose Window⇒Color from the Photoshop
menu bar.

The working components of the Color panel, shown in Figure
4.20, are the before/after view, the Slider tools, the color
ramp, and the menu. The before/after view allows you to see
the original color as well as the newly selected color. The
color ramp at the bottom allows you to select a color from the
ramp using the Eyedropper tool that becomes visible when
the mouse is over it. The Slider tools allow you to use the
mouse to drag handles to quickly select the level for each
available channel or to type in a specific value.
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Figure 4.20

Selecting colors from the Color panel tool in Photoshop

The menu of the Color panel provides the following color
mode options for adjusting images:

• Grayscale Slider. This sets the slider control to a single
slider that adjusts the level of grayscale tones. This tool is
useful if you need to add gray without any other tone to the
image.

• RGB Sliders. This sets the slider control to three sliders that
allow you to adjust the intensity levels of the red, green, and
blue channels.

• HSB Sliders. This sets the slider control to three sliders that
allow you to adjust the hue, saturation, and brightness of the
color.
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• CMYK Sliders. This sets the slider control to four sliders
that allow you to adjust the intensity levels of the cyan,
magenta, yellow, and black channels.

• Lab Sliders. This sets the slider control to three sliders that
allow you to adjust the values of the a, b, and luminosity
levels in the Lab channels.

• Web Color Sliders. This sets the slider control to three
sliders that allow you to adjust the hexadecimal code values
of the red, green, and blue channels for web images.

• Copy Color as HTML. This copies the current color as the
HTML code that is inserted into an HTML tag when building
web pages — for example, color=”#9999cc”.

• Copy Color's Hex Code. This copies the current color as
the hexadecimal code that represents the red, green, and blue
values — for example, #9999cc.

• RGB Spectrum. This changes the color ramp to use the
RGB spectrum for selecting colors using the eyedropper.

• CMYK Spectrum. This changes the color ramp to use the
CMYK spectrum for selecting colors using the eyedropper.

• Grayscale Ramp. This changes the color ramp to use the
grayscale ramp for selecting a shade of gray using the
eyedropper.

• Current Colors. This changes the color ramp to use only
the tonal values of the current color when selecting a color
using the eyedropper.
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Tip

The Current Colors ramp is useful when you have selected a
color, but you want to change the tone or when you want to
use multiple tones of the same color in the image.

• Make Ramp Web Safe. This changes the color ramp to
provide only the web-safe palette for selecting colors using
the eyedropper. This option is a hangover from the days when
web browsers only supported a limited number of colors in
images. When selected, the color ramp changes to provide
colors only within the limited color range.

Using the Swatches panel

One of the simplest ways to choose a color is by using the
Swatches panel. A swatch is just a set of combined colors.
The Swatches panel displays the available colors in the
swatch as either thumbnails or a list. To choose a color,
simply click the one you want. To launch the Swatches panel,
choose Window⇒Swatches from the Photoshop menu bar.

Using the Swatches panel menu shown in Figure 4.21, you
can select one of the following views to display the colors
available in the swatch:

• Small Thumbnail. This displays the colors as tiny squares
in the Swatches panel. This is the most commonly used view
because the colors are generally big enough to see and yet the
panel doesn't take up a lot of space.
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• Large Thumbnail. This displays the colors as larger
squares in the Swatches panel. This view is useful if you have
colors that are very close to each other in the swatch. Viewing
larger squares makes it easier to distinguish between the
colors.

• Small List. This displays the colors as a list with tiny
squares next to the color names in the Swatches panel. You
typically use this view if you want to know the name of the
color when selecting it; however, it can be difficult to
navigate a large swatch when in this view.

• Large List. This displays the colors as a list with large
squares next to the color names in the Swatches panel. This
view is almost never used because it is difficult to scroll
through to find a color.

Using the menu in the Swatches panel, you can also save the
colors in the current swatch as a custom swatch as well as
load and replace swatches. You can also select from a list of
swatches that are built into Photoshop.

Figure 4.21

Selecting colors from the Swatches panel in Photoshop
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Tip

When you open a new swatch, Photoshop allows you to
append it to the existing swatch. This enables you to
combine swatches that you commonly use into a single
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custom swatch that you can load later, allowing you to avoid
constantly switching between swatches.

Selecting color from an image with the Eyedropper tool

Another way to select a color is to use the Eyedropper tool in
the Toolbox. This is by far the simplest method of selecting a
color. The Eyedropper tool works by selecting the color that
the mouse is currently over in the image when you click the
left mouse button.

The downside to using the Eyedropper tool is that the color
must appear in the image. The upside to using the Eyedropper
tool is that the color appears in the image. These two
statements may appear to conflict; however, it depends on
what you are trying to do. If the colors in the image are
limited or you want to add a color that doesn't exist in the
image, the Eyedropper tool will not work for you. However,
if you are trying to use a color that matches the surrounding
image, selecting a color from the image guarantees that it
matches somewhere in the image.

When using the Eyedropper tool, the options menu shown in
Figure 4.22 allows you to set the following options:

• Sample Size. This allows you to specify the size of the area
of pixels beneath the Eyedropper tool that are sampled to
determine a color when you click the mouse button. The
default is 11 by 11 pixels, but you can specify ranges from a
single pixel to 101 by 101 pixels. The total area of pixels is
sampled and the average color is selected. For images with a
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lot of variance, you will likely want to use a smaller sample
size.

• Sample. This allows you to specify whether to sample
pixels from all layers or only the current layer.

• Show Sampling Ring. When you select this option, a large
ring, shown in Figure 4.22, appears as long as you press and
hold down the mouse button. The ring shows the current color
on the bottom and the sampled color on top as you drag the
mouse around the image. Notice that the current color here is
black and the sample color is from the small patch of blue in
the image.

Note

The Show Sampling Ring option is available only if you
select Use Graphics Processor in the Performance
preferences as described in Chapter 2.

Figure 4.22

The Sampling Ring allows you to see the previous color on
top as well as the current color under the cursor on the
bottom.
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Understanding the Color Sampler tool

A subtool of the Eyedropper tool in the Photoshop Toolbox is
the Color Sampler. It looks like the Eyedropper tool, but it
has a crosshair in the icon. The Color Sampler tool allows you
to view channel settings for up to four channels. The Color
Sampler tool launches when you select a pixel.

To use the Color Sampler tool, you select it from the Toolbox
and use the mouse to select pixels in the image. After you
select a pixel by left-clicking in the image, the Info panel
appears. As the mouse moves, the data at the top of the Info
panel changes, telling you the values of the RGB and CMYK
channels of the pixel that the mouse is hovering over.

You can add up to four samples to the Info panel using the
Color Sampler tool, shown in Figure 4.23. To delete a sample,
right-click the sample using the Color Sampler tool and select
Delete from the shortcut menu. To change the color mode
information listed in the Info panel, right-click the sample and
select the color mode.
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Figure 4.23

Viewing color channel data in the Info panel in Photoshop

Using the HUD Color Picker

One of the best ways to quickly select a color while using
another tool such as a brush is to use the HUD Color Picker.
The HUD Color Picker provides a hue strip or wheel that sets
the base tone for a color block. An Eyedropper cursor in the
color block allows you to select a specific color from the
color block or a hue from the hue strip or wheel.

Note
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HUD stands for Heads Up Display, a term used in
technology that presents controls and information to the
operator without the need to look down at a control panel,
such as in military weapons systems, advanced jets, and
even some games.

You launch the HUD Color Picker by pressing Alt+Shift/
Option+Shift while right-clicking with the mouse. Figure 4.24
shows both the wheel and strip versions of the HUD Color
Picker. You can specify which version appears in the General
settings of the Preferences dialog box, as discussed in Chapter
2.

Figure 4.24

The HUD Color Picker is a very useful feature that allows
you to change the color while using other tools.

322



Note

The HUD Color Picker is available only if you select Use
Graphics Processor in the Performance preferences (as
described in Chapter 2) and in 8-bit and 16-bit images.

Summary

This chapter covered everything you need to know about
color to get the most out of the tools in Photoshop, from how
the human eye perceives it to how to select a color in
Photoshop. The histogram shows you the basic composition
of one or more color channels, and modifying the histogram
modifies the color composition in the image.

323



The purpose of this chapter was to familiarize you with the
relationship between light, color, the human eye, digital files,
and Photoshop. You have learned the following:

• That color is simply light reflected off surfaces at different
frequencies and intensities

• How Photoshop sees colors in terms of channels and levels

• How to understand the information contained in a histogram
and how it applies to the level and channels contained in the
different color modes of Photoshop

• The purpose and how to best use each of the color modes,
including RGB, CMYK, and grayscale

• How to use the color tools in Photoshop to give you the
maximum information when editing your images

324



Chapter 5: Applying History and Actions

In This Chapter

Experimenting with the non-destructive nature of Photoshop

Using the History panel to manipulate past adjustments

Creating custom actions to save time

You edit an image in Photoshop by applying a series of
adjustments to modify the original pixels in the image. Each
adjustment builds on the others until you achieve the desired
results. Photoshop provides two powerful features that allow
you to be more productive by using and manipulating the sets
of adjustments that you make to your images.

The History feature tracks each change you make to the
individual image. This allows you to have a record of each
state of the image during editing. Photoshop provides several
highly useful tools that allow you to make dynamic
adjustments to the image by manipulating the history states.
These tools also allow you to experiment with different
techniques because you can revert quickly to previous states
or remove adjustments that do not work well.

The Actions feature allows you to bundle a set of adjustments
as an individual action. You can save actions to a file and
then use them in other images. This feature saves a lot of time
when you are performing similar adjustments to images.

Understanding the Non-Destructive Features in Photoshop
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One of the most powerful features of Photoshop is the ability
to make numerous edits to images and see the effects of those
edits without destroying the underlying pixel data or previous
edits. Many of the edits you will apply to images in
Photoshop will be the result of a series of adjustments using a
variety of tools. Each adjustment builds on preceding ones
until you reach the result you want. Unfortunately, it is not an
exact science, and you may have to try different adjustments
until you find a combination that culminates in the desired
outcome.

The non-destructive features of Photoshop allow you to freely
play around with the edits, tweaking them until they are just
right without the fear of ruining previous edits or the original
pixels in the image. In fact, you can even remove a single
adjustment that you made early on without affecting the
original pixels or the subsequent adjustments.

To help you understand the value of non-destructive editing,
think about editing an image for hours and realizing that one
of the first edits you made was a bad decision. If you could
not undo that edit, the hours of work would be wasted.

The following is a list of the major non-destructive features
and tools that are available in Photoshop:

• History. The History panel, discussed later in this chapter,
provides a means of quickly viewing each of the adjustments
that you have made to the image. The History panel also
provides a way to create snapshots that you can easily revert
to, and to remove individual edits from the history.
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• Dialog boxes. The Ctrl+Z/ +Z key sequence available in
most Photoshop's dialog boxes will allow you to undo the last
adjustment you made to a field. This feature is very useful if
you make a change to a value that you do not like but you
cannot remember what the original value was. This feature
undoes only the last change you made. To undo other
changes, press and hold down the Alt/Option key, and the
Cancel button turns into a Reset button. When you click the
Reset button, the values in all the fields in the dialog box
revert to the original values from when you last opened it.

• Layers. Adjustment layers, allow you to make adjustments
to the image without affecting the actual image pixels. The
adjustment layers contain adjustment data that affects how the
image looks when you apply them. Layers are very useful
because you can remove, reorder, and even move them from
one document to another in Photoshop. For more information
about adjustment layers, see Chapter 10.

• Layer Comps. The Layer Comps panel is similar to the
History panel, but it contains the changes made to each layer.
Using the Layer Comps panel, you can easily create multiple
versions of the edited image, each with its own set of
changes. This makes it easy to track multiple changes to the
image.

Tip

You can use the Layer Comps feature to create several
versions of an image for comparison. This can be very
useful if you are creating multiple versions to get approval
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from a client, if you are not sure what you want and want to
maintain multiple “what-if” versions, or if you need
different types of edits on the same image for different
purposes.

• Masks. Masks allow you to create a shield over an area in a
document that protects that area from any adjustments you
have made. One of the major advantages of masks is that you
can alter them at any time, and the alterations are
automatically updated in the results because they actually sit
between the adjustment layer and the layers below. For more
information about masks, see Chapter 10.

• Alpha channel. The alpha channel allows you to add
information that you can apply to areas of the image without
actually affecting the other channels. For example, you can
add transparency information to an RGB image without
affecting the normal pixels in the image. For more
information about alpha channels, see Chapter 11.

• Smart objects. Smart objects are a useful feature of
Photoshop that provide powerful, yet non-destructive
adjustments to images. Using smart objects, you can combine
a series of one or more layers, documents, and other
components into a single combined object. Then you can
apply filters and make other adjustments to the object without
actually changing the contents. You can change the contents
of the original object at any time, and the adjustments apply
only to the updated object. This allows you to create a base
source image and quickly try different edits without worrying
about damaging the source image or the original pixels.
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• Smart filters. Smart filters work hand-in-hand with to smart
objects to provide the same non-destructive behavior when
applying filters to smart object layers. The Smart filter acts as
metadata to the layer and can be enabled, disabled and edited
without affecting the pixel data permanently.

• Crops. Photoshop allows you to crop images in a
non-destructive manner. When you start to crop an image, as
discussed in Chapter 3, the Options menu displays two
choices: Delete and Hide. If you select Delete, the pixels
outside the crop box are thrown away and you work only with
the remaining pixels. If you select Hide, the pixels outside the
crop box are masked, and although you only see the pixels
inside the crop box, the pixels outside the crop box are still
present in the image. To restore the cropped pixels, choose
Image⇒Reveal All. The canvas reverts to the original size,
and any of the layer adjustments you have applied to the
image are applied to the restored pixels.

Note

The Hide and Delete options in the Crop tool menu are
available only if you are cropping a layer whose pixels are
not locked. For more information about layers and layer
locking, see Chapter 10.

• Revert. At any point while you are editing an image, you
can revert to the original state of the file when it was opened
or last saved by choosing File⇒Revert or pressing the F12
key (Fn+F12 on Apple keyboards). You should only use this
option as a last resort, as all the changes you have made to the
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image are lost. However, this option saves you the time of
closing the image without saving the changes and reopening
it.

Using the History Panel

The History panel can be one of your best friends in
Photoshop because it can save you from losing hours of work.
When you are editing images in Photoshop, you are really
working from one change to another. These changes are tied
together and build on one another.

The purpose of the History panel is to track and manage each
adjustment you make to the image. The History panel is
designed to give you much more flexibility and control than
the traditional undo/redo functionality. Using the History
panel, you can undo and even modify one, some, or all of the
changes you have made to an image.

Note

Photoshop allows you to log some of the history information
either as metadata in the file or as a separate file. You can
set the history logging feature from the General panel in the
Preferences dialog box, as discussed in Chapter 2.

The following sections discuss the History panel and how to
get the most out of it. They also cover using the Eraser,
History Brush, Art History Brush, and selections to roll back
and modify individual edits.
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Understanding the History panel

The History panel stores a list of the actions that you have
performed on a document. This list provides three very useful
features. First, you can see what changes you have made to
the document. Second, you can undo changes that you have
made to the document. And third, as we discuss later in this
section, you can creatively combine items in the history to
enhance your images.

You load the History panel by choosing Window⇒History
from the Photoshop menu bar. The History panel, shown in
Figure 5.1, keeps track of a list of the states of the image after
you apply each edit. This allows you to go back quickly in
time to the state of your document after any of the edits were
made. The following sections discuss configuring and using
the History panel to adjust your images.

Figure 5.1

The History panel keeps track of the state of the image after
you make each change.

331



Configuring the History panel

You can configure the History panel by setting the options in
the History panel menu and by setting the preferences for
history in the general Photoshop Preferences. To configure
options from the History panel, select History Options from
the History panel menu (refer to Figure 5.1) to open the
History Options dialog box, shown in Figure 5.2.

Using the History Options dialog box, you can configure the
following options:

Figure 5.2

Setting options for the History panel
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• Automatically Create First Snapshot. This automatically
creates a snapshot of the original document when it is loaded
into Photoshop. This is a useful feature that allows you to
always have an original snapshot to use with the history tools;
however, if you know that you will not need to use the
history, then turning off this option reduces some processing
overhead and memory usage.

• Automatically Create New Snapshot When Saving. This
automatically creates a snapshot every time you save the file
in Photoshop. Although this can be a useful feature, it can
also be a problem; if you tend to save after every little change
you make, you may end up with a huge list that really isn't
meaningful. If you use this feature, make sure you are careful
about when you save.

• Allow Non-Linear History. The edits to a document are
built on top of each other in a linear fashion. The problem
with the linear method is that if you delete one state in the
history list, then Photoshop deletes all the subsequent states.
When you select the Allow Non-Linear History option, the
history states become disconnected and you can delete one of
the states in the middle without deleting the subsequent
changes.
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Caution

Some of the changes you make to a document are very
tightly connected. You should be very careful when using
the Allow Non-Linear History option so you do not delete a
state on which another state is depending.

• Show New Snapshot Dialog by Default. This specifies
whether to show the New Snapshot dialog box when creating
snapshots. If you disable this option, the New Snapshot dialog
box does not appear unless you select New Snapshot from the
History panel menu. Disabling this option can speed up
creating snapshots using the button on the History panel if
you do not need to specify a name or source.

• Make Layer Visibility Changes Undoable. This is the
default option. If you do not select this option, then turning
layer visibility on and off is not recorded in the history. When
you select this option, turning layer visibility on or off is
recorded in the history and you can undo it using the history
tools.

By default, Photoshop keeps a record of, at most, 20 history
states. Each history state takes up memory and requires extra
computer processing by Photoshop. Generally, 20 history
states are enough to work from. However, if you are working
on an image that requires a single or many different edits with
a tool such as a paintbrush, which results in a separate action
for each brush stroke, you may need to increase the recorded
history states number, so you can revert or adjust some
corrections that you are performing.
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You can specify the maximum number of history states in the
general preferences of Photoshop. To increase the number of
history states that Photoshop keeps available, choose
Edit⇒Preferences⇒General from the Photoshop menu bar
(or use the Ctrl+K/ +K shortcut) to open Preferences. Then
select the Performance option and change the value of the
History States field in the History & Cache pane.

Navigating through history states

You can navigate through the different history states either
directly using the History panel or by using keyboard
shortcuts. The most common method is to open the History
panel, scroll through the history, and select the history state
you want to view. When you select a history state, the image
window changes back to that state.

A sometimes faster option is to use the Ctrl+Alt+Z/
+Option+Z keyboard shortcut to navigate backward through
history and Ctrl+Shift+Z/ +Shift+Z keyboard shortcut to
navigate forward through history. If you need to go back only
a few adjustments to see how the image looked, then this
option is the fastest and easiest; however, you cannot undo
any of the history edits.

Tip

If you select a snapshot in the History pane, then you can
use the Ctrl+Alt+Z/ +Option+Z keyboard shortcut to
navigate backward through the snapshots and the
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Ctrl+Shift+Z/ +Shift+Z keyboard shortcut to navigate
forward through the snapshots.

Using snapshots

A very useful feature of the History panel is the ability to
create snapshots of the image based on a specific state. The
snapshot data remains, even if you delete the history data.
This feature provides a very versatile way to make different
adjustments to an image and quickly compare the
adjustments. This is similar to and in most cases replaces the
need to save multiple versions of the full document.

To create a snapshot, click the Create Snapshot button at the
bottom of the History panel or select New Snapshot from the
History panel menu to open the New Snapshot dialog box, as
shown in Figure 5.3. Name the snapshot, and select the
snapshot source. The snapshot can be taken from the full
document, the current layer, or all layers merged. When you
click OK, the snapshot appears in the snapshots list at the top
of the History panel.

You can treat the snapshots like the history states. You can
delete them and even apply the History Brush tool to them.

Creating documents

Another useful feature of the History panel is the ability to
quickly turn a history state into a separate document. This
feature is useful if you are editing an image and want to send
someone multiple versions for her approval. You can make
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the full edit of the document and then use the History panel to
create documents based on the states that you think might
work.

Figure 5.3

Creating a snapshot of a history state adds a state that you can
go back to at any time.

To create a document using the History panel, select the state
or snapshot to create a document from and then click the
Create New Document from Current State button or select
New Document from the History panel menu. A new
document with the image data from the selected state or
snapshot is loaded in Photoshop. The name of the new
document is the name of the state or snapshot.

Deleting history

You can clear the history in a couple of ways. For example,
you can select a history state and click the trash icon in the
History panel or select Delete from the History panel menu.
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Caution

If you select the Allow Non-Linear History option for the
History panel, Photoshop only deletes the state that you
selected. However, if you do not select the Allow
Non-Linear History option (the default), then Photoshop
deletes all subsequent history states as well. Make sure you
know whether this option is selected before you delete a
large amount of history that you need. You can also save a
snapshot of the current state with the full history of changes
before making changes to the history.

You can also clear out all the history in the History panel by
selecting Clear History from the History panel menu. This
removes all history states. The Clear History option works
only on history states; snapshots remain after you clear the
history.

Painting from history

A powerful feature of the History panel is the ability to select
a history state and paint or erase directly from that history
state or snapshot. This allows you to paint through the
changes that have been made until you get down to the
selected history state. If you consider the number of brush
styles and transparency options available when painting, then
you will see that painting from history opens a variety of
possibilities.

To enable painting from the History feature, you need to click
the box beside the desired state or snapshot in the History
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panel. The box changes to the History Brush icon, as shown
in Figure 5.4. Photoshop uses that state as the base level when
painting from history.

Figure 5.4

Selecting the History Brush option for a history state enables
the History Brush, the Art History Brush, and the Eraser to
use the history data.

Using the Eraser tool in the History panel
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One of the best features of the History panel is that it allows
you to erase part of the history without having to remove all
of the history. To help you understand how this works,
consider the following example.

We start with the image shown on the left in Figure 5.5. After
applying a Brightness/Contrast adjustment on the image, the
sunset is extremely dark. Now you can use the Eraser tool as
a paintbrush to bring back lighting from the original in
specific locations using the following steps:

1. Choose Image⇒Adjustments⇒Brightness/Contrast.

2. Adjust the brightness and contrast down until you have
reduced the brightness of the overall image, as shown in
the middle photo in Figure 5.5.

3. Open the History panel by choosing Window⇒History.

4. Click the Enable History Brush icon for the Open
history state, as shown in Figure 5.6.

5. Select the Brightness/Contrast history state, as shown in
Figure 5.6.

6. Select the Eraser tool from the Toolbox.

7. Change the mode to Brush in the Eraser Options bar,
as shown in Figure 5.6.

8. Change the brush style to a dissipating brush with a
very large size, as shown in Figure 5.6.
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Figure 5.5

Using the Erase to History option on the Eraser tool allows
you to make an adjustment to an entire image and then erase a
part of that change.

Figure 5.6

Using the History Brush settings and configuring the Eraser
tool to erase part of the history from an image
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9. Set the opacity of the brush to about 75% to allow the
adjustment to be more gradual.

10. Select the Erase to History option, as shown in Figure
5.6.

11. Click the image in specific locations to return the
original brightness using a brush effect.

The end result is shown on the right in Figure 5.5; parts of the
sunset stand out more than in the original.

Tip
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Even if you have not selected the Erase to History option,
you can still erase the history by pressing and holding down
the Alt/Option key while using the Eraser tool.

Using the History Brush

The History Brush tool actually works in the opposite
direction of the Eraser tool with the Erase to History option
checked. Instead of erasing the changes made since the
history state was set in the History panel, you use that older
history state as the source to paint on the currently selected
history state.

Using the History Brush tool gives you a major
advantage over using the Eraser tool in that you can use the
brush modes to provide more effects when painting on the
history. For more information about using the brush tools and
brush modes, see Chapter 16.

Working with the Art History Brush

You can use the Art History Brush tool to erase part of the
history of changes. It functions similarly to the Eraser tool
with the Erase to History option checked; however, you have
to think about it in reverse terms. Instead of erasing the
changes made since the history state that was set in the
History panel, you are using that older history state as the
source to paint on the currently selected history state.
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Tip

Using the Art History Brush tool offers a major advantage
over using the History Brush tool: in addition to using the
brush modes, you can also choose a style to apply to the
brush, giving an impressionistic appearance. For more
information about using the brush and brush modes, see
Chapter 16.

Using selections when painting history

Sometimes, you want to limit the area of an image on which
you are painting history. You can use selections to limit the
area of the image that will be affected by the Eraser, History
Brush, and Art History Brush tools. We discuss selections in
detail in Chapter 9.

Follow these steps to use a selection to limit the area you are
painting on while using the history painting options:

1. Click the Enable History Brush icon for the history
state you want to paint from.

2. Select the history state you want to change.

3. Use the selection tools to select the area of the image
you want to paint history into.

4. Use the Eraser, Art History Brush, or History Brush
tool to paint into the image.

You only paint the area inside the selection.
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Creating and Using Automated Actions

Photoshop does an excellent job of providing simple
keyboard shortcuts (hotkeys) for most common tasks. The
more you use Photoshop, the more you will rely on these
shortcuts. They save a lot of time, allowing you to work at a
much faster rate. However, even invoking shortcuts over and
over can become tedious. That is where actions come into
play.

Actions are a list of operations that Photoshop performs from
the current window. Actions can include most of the tasks
that you can perform using the shortcuts, menus, and panels
in Photoshop. Actions can range from something as simple as
adding a special effect to the active document to a long series
of operations that include creating several new documents and
layers with numerous effects, filters, and masks. There really
is no limit to what you can do with custom actions.

Actions save so much time because you can perform an
action, whether it involves two steps or 50 steps, with just the
click of a button or the press of a hotkey. Photoshop comes
with several predefined action sets for various common tasks.

The predefined Photoshop action sets do everything from
creating frames to applying a sepia-tone effect to an image.
As you work more with Photoshop, you will likely find tasks
that you repeat over and over that become tedious. In these
situations, you will want to create custom actions. Recording
a custom action is as simple as recording the steps you take as
you perform those tedious tasks.
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Note

After you play an action, you can click the History tab to
view the History panel and see each step that was taken by
the action.

Understanding the Actions panel

The Actions panel provides a way to store and apply sets of
operations to your images. One of the biggest benefits of
using the Actions panel is that it enables you to store some of
the tedious workflow that you consistently perform on images
and apply these actions with a single click of the mouse.

In order to implement actions to speed up your work, you
need to understand the organization of the Actions panel. You
can access the Actions panel by choosing Window⇒Actions.
By default, the Actions panel is shown with the History panel.

The Actions panel is made up of four main sections, as shown
in Figure 5.7: the action list, the Actions panel menu, the
toggle boxes, and the quick buttons.

Figure 5.7

Using the Actions panel to manage a set of actions to perform
on an image
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• Action list. Located in the main part of the panel, the action
list is made up of three components: action sets, actions, and
recorded commands.

• Action sets. An action set is simply a way to file a list of
actions into a category. An action set is designated by the
folder shown next to the name of any given set. You can see
two sets in Figure 5.7: Default Actions and Video Actions.
You can load any one of seven predefined action sets from
the Actions panel menu, or you can create your own. Click
the triangle next to the action set name to see a list of actions
contained in the set.

• Actions. An action is a preset list of operations that you can
perform quickly and automatically by selecting an action and
clicking the Play button in the Actions panel. Click the
triangle next to the action name to see a list of recorded
commands contained in the action.

• Recorded commands. Recorded commands are a list of
commands that have been recorded in a set order to perform
the same series of operations every time you play the action.
These commands may also contain submenus. For example,
clicking the triangle next to the Stop command in Figure 5.7
shows the message displayed by the command.

• Actions panel menu. Available by clicking the menu button
located in the upper-right corner of the panel, the Actions
panel menu contains menu items that allow you to set the
panel mode, add new actions, load action sets, save action
sets, and set other options for the Actions panel.
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• Toggle boxes. Located along the left side of the panel are
two toggle boxes, which are available for each action set,
action, and operation in the action list. The left toggle box
enables or disables the set, action, or operation. If you do not
select the toggle box, the operation is not applied when you
run the action. The right toggle box enables or disables any
dialog boxes contained in the set, action, or operation.

If a dialog box is displayed in the toggle box, Photoshop
displays the dialog box associated with the operation when
running the action. For example, if an operation adjusts the
levels of an image, having the dialog box toggled on displays
the Levels dialog box, and Photoshop waits for you to adjust
the levels manually every time you run the action.

• Quick buttons. Located on the bottom of the panel, the
quick buttons are icons that provide quick access to the Stop,
Record, Play, Create New Action Set, Create New Action,
and Delete tasks for actions. These options are available in
the panel menu as well.

• Button mode. Located in the Actions panel menu. When
enabled, this option dramatically changes the way the Actions
panel looks. Figure 5.8 shows the actions list converted to
buttons. This allows you to simply click the action you want
to perform without the dual steps of highlighting it and
clicking Play. You can see that the action sets are delineated
by color.

Figure 5.8

Using the Button mode of the Actions panel
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Loading existing action sets

When you initially open the Actions panel, it is populated
with the default action set. At this point, you can use one of
the available default actions, load an existing action set, or
create a custom action set.

You can load an existing action set in one of two ways. The
predefined action sets are listed at the bottom of the panel
menu. These action sets are for specific purposes such as
frames, image effects, and textures. You can load them
simply by clicking them. You can also load action sets that
you have created previously or downloaded by clicking the
Load Actions option in the panel menu and then navigating to
the location of the action set.
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Note

Action sets have an .atn file extension.

When you load an action set, Photoshop adds it to the action
list. Photoshop automatically expands the action set to show
all actions contained inside.

Creating custom actions

You can create a custom action by recording operations you
want to add to the action as you apply them. After you begin
recording the action, all steps that affect the current document
are recorded, including creating new documents. Be prepared
to perform the steps in order without any extra steps.

Follow these steps to create a custom action:

1. Select New Set from the Actions panel menu.

If you want to add the action to an existing set, skip to Step 3.

2. Type the name of the new action set, and click OK.

3. Select the action set you want to add a new action to, or
go to Step 4 to create a new action.

4. Create a new action by selecting New Action from the
Actions panel menu to open the New Action dialog box, as
shown in Figure 5.9.

Figure 5.9
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Using the New Action dialog box

5. Type the name of the new action.

You can also select a function key that automatically runs the
action after you record it. You can select a color for use when
displaying the action in Button mode.

Caution

Be careful when selecting the function key that will start the
action. The key needs to be unique against other action and
also not already used by Photoshop or the computer
operating system.

Note

You will want to group similar actions with similar colors to
make the Button mode easier to use.
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6. Start recording the action by clicking the Record button
in the New Action dialog box.

As soon as you click Record, Photoshop begins recording
operations, so be ready.

7. Perform the desired operations in order.

Perform the operations as you normally would, including
modifying settings in dialog boxes and so forth.

Note

Don't worry if you make a mistake when performing the
operations. You can go back and insert forgotten operations,
delete unwanted operations, and even modify operations that
you didn't perform correctly.

8. Stop recording and save the action by clicking the Stop
button in the Actions panel, shown in Figure 5.7.

The new action appears in the action list.

Editing actions

You can edit an existing action in several different ways. For
example, you may realize after recording an action that you
need to add additional steps. You may also realize that you
need to add menu items, stops, or paths to fine-tune the
action's behavior. The following sections discuss the different
ways that you can fine-tune your actions.
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Applying a stop

A stop is an operation that pauses the running action and
displays a message. The user can read the message and decide
whether to continue running the action. You may want to
insert a stop into actions prior to performing complex or
data-changing actions. For example, if your action makes
changes and then saves the document, you may want to
display a message to that effect so the user can decide
whether he really wants the file changed on disk.

To insert a stop into an action, select the operation that you
want the stop to be inserted above and select Insert Stop from
the panel menu. This opens the Record Stop dialog box, as
shown in Figure 5.10. Create a warning message, and check
the Allow Continue check box if you want the user to be able
to continue after the stop. After you click OK, Photoshop
inserts the stop before the highlighted command.

Figure 5.10

Using the Record Stop dialog box to insert a stop into an
action
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Adding conditional actions

In addition to stops, you can add automatic conditionals that
will allow the action to continue, stop the action, or even
perform a different action. For example, you can cause a
rotate action to apply only if the document is in landscape
format. To add a conditional action, select an existing action
in the Actions panel and then choose Insert Conditional from
the panel menu. Then select from one of the conditions shown
in Figure 5.11 and select actions to perform if the condition is
true or false.

Figure 5.11

Adding a conditional action that applies only if the document
is in landscape format
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Inserting operations

You may decide to add more operations to an existing action.
This can be useful for a couple of purposes. For example, you
may have forgotten a step when you recorded the action, or
you may want to create a variation of an existing action.

To insert additional operations into an action, highlight the
operation below which you want to add additional operations
and click the Record button. Then perform the operations that
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you want to add. When you are finished recording operations,
click the Stop button, and Photoshop adds them to the action.

Moving operations

You can move operations from one location in the action list
to another by simply dragging and dropping them in the new
location. You can even move operations from one action set
to an entirely different action set. You can select multiple
operations in the same action by pressing and holding down
the Ctrl/ key and clicking each operation. Then you can
move the selected group together.

Duplicating actions and operations

You can duplicate actions or operations by pressing and
holding down the Alt/Option key while dragging and
dropping them into their new location. Pressing and holding
down the Alt/Option key leaves the original operation or
action in place and creates a copy of it in the new location. If
you duplicate an action inside the same action set, “copy” is
added to the name.

Modifying operations

You can also modify some operations after you record the
action. This can be extremely useful if, for example, you
made a mistake or you decide later that you want the
operation to use different settings. Instead of having to delete
the operation and re-record it, you can just double-click the
operation, and the dialog box used to create it appears.
Change the settings that you want to modify, and click OK in
the dialog box to update the action.
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Inserting a menu item

To manually insert an operation into an existing action,
highlight the operation right before the operation you want to
insert. Then select Insert Menu Item from the Actions panel
menu to open the Insert Menu Item dialog box shown in
Figure 5.12. You can now add an operation by clicking
through the menu path of the operation. For example, if you
want to zoom into your image, choose View⇒Zoom In.
When the operation you want to insert is in the dialog box,
click OK to insert the operation into the action.

Figure 5.12

Using the Insert Menu Item dialog box to insert an operation
into an existing action

Inserting a path

You can create a complex path as part of an action, but if you
try to record several complex paths, each new path replaces
the last one. You can create a path with a pen tool, use a path
found in the Paths panel, or import a path from Illustrator.
You can insert a new path into an action using the following
steps:
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1. Start recording an action by clicking the Record button
shown in Figure 5.9.

2. Select an action's name to record a path at the end of
the action, select a command to record a path after the
command, or select an existing path from the Paths panel.

3. Choose Insert Path from the Actions panel menu to add
the path to the action.

Paths are a set of points connected by lines that
make up vector shapes. We will cover paths in much more
detail in Chapter 17.

Deleting an operation

You may also want to remove operations from an existing
action. To do this, you select the operations, and drag and
drop them onto the trash icon at the bottom of the Actions
panel to delete them. You can select multiple actions and
delete them at the same time using the Ctrl/ key.

Modifying the action name and function key

You can modify the options of an existing action, including
the name, function key, and color. To open the Action
Options dialog box, press and hold down the Alt/Option key
and double-click the action. You can also choose Action
Options from the Actions panel menu. You can then use the
Action Options dialog box to modify the name, function key,
and color of the action.
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Saving actions

After you have created a new action or modified an existing
one, you need to save the action. You do this by saving the
action set, which is a document. Select the name of the action
set and choose Save Actions from the Actions panel menu.
You can use the default location or browse to a location that
suits you better.

Adjusting action settings temporarily by using the toggle
boxes

You can temporarily adjust actions by selectively toggling the
operations in them off or on. If you click the left toggle box
for an operation and deselect it, running the action skips the
deselected operation. You can save a lot of time when
creating new actions if you use this feature judiciously. Create
an action with all the possible steps that you might want to
take, and then deselect the steps that aren't necessary
depending on the circumstance.

Playing actions

Now that you've learned how to create and modify actions,
you can get to the fun part — using them. Playing an action is
an incredibly simple process. If you are in Button mode in the
Actions panel, you can simply click the button and Photoshop
performs the action. If you are in List mode, select the action
and click the Play button at the bottom of the Actions panel.
If you've set up a hotkey for a particular action, you can use
that, too.
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You can also play an action starting at a particular operation
in the action list by selecting that operation and then clicking
the Play button.

Managing the action list

By default, there are seven predefined action sets available in
the Actions panel menu, and you can also create or download
more. As a result, you can imagine how cluttered the Actions
panel can become if it's not managed well. The following
Actions panel menu options can help you keep your actions
organized:

• Clear All Actions. The Clear All Actions option wipes the
Actions panel clean of any action sets. It doesn't get much
cleaner than that!

• Reset Actions. The Reset Actions option replaces all the
action sets in the Actions panel with the default set. You can
also choose Append to add the default set to the actions on the
panel rather than replacing them.

• Replace Actions. The Replace Actions options replace the
actions in the Actions panel with an action of your choice
from the Actions panel menu. You can browse for the action
you want to add to the panel.

Summary

This chapter discussed the non-destructive features of
Photoshop and how to use the history and actions features to
save time and effort when editing images. Photoshop does a
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good job of tracking the changes that you make to images and
providing tools to manipulate them.

The history tools allow you to view the set of changes you
have made to an image and to manipulate them to modify the
outcome of the edit. The action tools allow you to create,
modify, and use actions to combine a series of changes into
packages that you can quickly and easily apply to one or more
images.

In this chapter, you learned the following:

• How to configure the History panel

• That creating a snapshot preserves the current state of the
image to be used later

• How to use the History Brush and Eraser tools to paint a
previous history state onto a later state

• How to use the Actions panel to save a lot of time when
editing images

• That Photoshop provides several built-in actions

• How to create and organize custom actions
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Chapter 6: Using Bridge to Organize and Process Files

In This Chapter

Creating workspaces for navigating, organizing, and
processing your images

Organizing files using the Bridge application

Batch processing images using Bridge and Photoshop

Using Mini Bridge to find and select files in Photoshop

One of the most important yet least popular tasks when
working with images is organizing and managing the image
files. It is difficult to keep files organized in an effective
manner, especially with the number of images that are
generated by digital cameras.

Adobe has tried to solve the problem of organizing files by
providing the Bridge application. Bridge is designed to
simplify the process of importing, organizing, and finding
files. Bridge also provides a direct interface to Photoshop, and
other applications in the Creative Cloud, that allows you to
take advantage of their image-processing capabilities. The
following sections discuss the Bridge application, how to
configure it, and how to use it to quickly organize and
manage your image files.

Working in the Bridge Workspaces

Bridge is a versatile application that allows you to create
workspaces where you can easily navigate, organize, and
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process your images. Using Bridge will help your
productivity by allowing you to organize your images and
quickly find them when working in Photoshop. The purpose
of this section is to help you understand how the Bridge
workspace is organized and how to customize it to best fit
your needs.

Examining the Bridge interface

The Bridge interface, shown in Figure 6.1, is divided into four
main areas: the main menu bar, toolbar, window panes, and
content view controls. The following sections discuss each of
these parts of the Bridge interface.

Figure 6.1

The main areas of the Bridge interface are the main menu bar,
the toolbar, the window panes, and the content view controls.
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Main menu

The Bridge main menu bar provides access to Bridge
functions that you cannot reach easily through the toolbar or
the windows in the window panes area. The following is a list
of the main menu headings with descriptions of the types of
commands that they contain. We discuss many of these
commands later in this chapter.

• File. This allows you to work with the file system to create
folders, move files, import files, view file information, and
interact with Photoshop and other Adobe CC applications.

365



• Edit. This provides options that allow you to select and
copy files, duplicate files, rotate files, and, in Windows, set
preferences for the Bridge application. The Preferences menu
is under the Bridge main menu on Macs.

• View. This provides settings to configure how you view
files in Bridge. You can also sort files, change to full-screen
preview mode, and start a slide show from this menu.

• Stacks. This provides options to create and configure stacks.
We discuss stacks later in this chapter.

• Label. This allows you to add, remove, and change labels
and ratings of files. You can then use these labels and ratings
to filter your files.

• Tools. This provides options to interact with Photoshop,
batch process files, manage metadata templates, and manage
caches of files.

• Window. This allows you to control which windows appear
in the window panes. You can also use this menu to quickly
switch between workspaces in Bridge. Another option
available in the Window menu is New Synchronized
Window, which launches a second instance of the Bridge
application that is completely synchronized with the first, so
that if you change images or windows in one, the other
changes as well.

• Help. This provides access to the Bridge help feature and
the online support for Bridge at Adobe. You can also update
Bridge, launch the Adobe Extension Manager, and get
information about the version of Bridge from this menu.
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Toolbar

The Bridge toolbar, shown in Figure 6.2, provides quick
access to many of the features in Bridge without having to
navigate the menus. The following list describes each of the
major areas of the toolbar and what tools you can find there:

Figure 6.2

The Bridge toolbar provides quick access to most of the
features without having to navigate the menus.

• Navigation tools. The navigation tools provide some
shortcuts to navigating through the file system to find files.
The left and right arrows allow you to navigate forward and
backward through previous navigations. You can also click
the down arrow to select any of the favorite locations or one
of the subfolders in the current path. The Reveal Recent File
or Go to Recent Folder button provides several options to
navigate back to recent locations and files. The navigation
bar, below the others, shows you each folder in the current
path; you can select any folder to go back to that level.
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Tip

If you click just to the right of the navigation path, a text
box replaces the path display and is initially populated by
the current path, where you can type in a file system path.
This can be much faster than navigating by clicking folder
icons if you know the name of the path that you want to
select.

• Import/export tools. The import/export tools provide
options to import a file from a camera, open a file in Camera
Raw format, and batch rename and output files to PDF or for
the web.

• Workspace selection tools. The workspace selection area
allows you to quickly select the workspace option that Bridge
is using. This is useful when you want to switch between
options when you change from navigating the images to
working with them.

• Search tool. The search tool allows you to limit the files
displayed by restricting them based on the text you type in the
search field. Bridge matches the text against the filename and
keywords, and only displays the files that contain the
specified text in the filename or keywords. This is extremely
useful if you are searching for a specific set of files.

• Thumbnail options. The thumbnail options allow you to
quickly configure how Bridge builds thumbnails to display in
the Content pane. Bridge can use the thumbnails embedded in
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the image for a faster preview; however, these thumbnails are
not as high in quality as the ones that Bridge generates.

• Sort and Filter tools. The sort and filter tools provide
buttons to filter files by rating, and labels and to sort files by
name or different items in the file metadata.

• Rotation tools. The rotation tools allow you to quickly
rotate images 90 degrees to the left or right. This is useful if
you are processing images taken with a camera that was tilted
on its side.

• File and Folder tools. The file and folder tools allow you to
quickly create folders and delete folders and files. You can
also open files from the Adobe Photoshop Recent File list.

Window panes

The window panes area of the Bridge interface provides a
location for window panels to dock. This area actually
contains five different window panes (refer to Figure 6.1).
Each window pane can contain one or more window panels.
You can access different window panels in a pane by clicking
their tabs at the top of the window pane.

You can drag a window panel between panes by clicking the
window panel tab and pressing and holding the mouse button
down while moving the window panel to the new pane. Also,
you can resize window panes by using the control handle in
the middle of the pane bars that separate the panes.

You add and remove window panels from the window panes
by selecting or deselecting them in the Window menu. The
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following is a list of the window panels that you can choose
to view in the window panes:

• Folders. This displays a folder tree view in Windows and a
Finder list hierarchy on Macs. Use this panel to navigate and
find files in the file system.

• Favorites. This displays a list of favorite folders. You can
drag folders from the Content panel to this panel to add them
to the list. This allows you to configure a set of folders that
you use often to speed up navigation.

• Content. This displays a list of contents of the selected
folder in the Folders or Favorites panels. You can
double-click folders in this panel to navigate into them to find
files.

• Preview. This displays a preview of selected images in the
Content panel. You can use the pane controls to change the
size of the preview pane, which changes the size of the image
displayed.

• Metadata. This displays the metadata information contained
in the image selected in the Content panel. Each of the main
metadata sections is divided into areas that you can expand
and collapse. To collapse an area, click the disclosure triangle
next to the area title. To expand an area, click the expansion
triangle next to the area title.

• Keywords. This allows you to create new keywords and add
keywords to the files that are currently selected in the Content
panel.
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• Filter. This allows you to quickly limit the files that are
displayed in the Content panel based on ratings, keywords,
creation date, and last modified date.

• Collections. This allows you to create and manage
collections of files. A big advantage of using collections is
that the files in a single collection do not need to be in the
same folder on the file system.

• Export. This allows you to add and manage modules that
allow you to export files from Bridge to other locations such
as Facebook and Photoshop.

Content view controls

The content view controls shown in Figure 6.3 allow you to
change the view of the Content pane. These tools are useful
when you need to switch between viewing a lot of images in a
folder and viewing more detailed information about a specific
set of files.

Figure 6.3

The content view controls in Bridge allow you to quickly
change how files appear in the Content pane.
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The following list describes the different view controls for the
Content pane:

• Thumbnail size slider. This allows you to quickly change
the size of the thumbnails displayed in each of the content
views using a slider or the smaller/larger button on the left or
right side of the slider.

Tip

When working with a large number of files, use the
thumbnail size slider to shrink the thumbnails so that more
images appear in the Content pane. Then scroll down to the
area where the files you want to work with are located and
use the slider to increase the size of the thumbnails to more
accurately select images.

• View as thumbnails. This shows only a thumbnail of the
image and the filename.

• Lock thumbnail in grid. This is similar to the View as
thumbnails option; however, the images are locked into an
evenly spaced grid. This feature is useful if you are working
with images that are not the same shape.

• View as details. This displays the thumbnail, filename,
creation date, modification date, file size, document type, and
some of the metadata such as ISO, focal length, and color
profile.
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• View as list. This displays the files in a more traditional list
form with columns for each of the metadata items. This view
is useful because you can click the top of any column to sort
the images by the values of that column.

Using the Bridge workspaces

Bridge provides several different workspaces that give you a
different view of the files you are working with. Each
workspace automatically sets the number, size, and shape of
the window panes and the window panels that are available in
each pane. The different workspaces completely change the
look and functionality of the Bridge interface.

Note

Changes you make to a workspace by adjusting window
panes and window panels are persistent. The same settings
are in effect the next time you switch to that workspace and
when you close and reopen Bridge.

Each of these views has advantages over the others, and you
will likely find yourself switching between the different
workspaces to accommodate your current workflow. Bridge
defines the following workspaces:

• Essentials. The Essentials workspace is the best overall
workspace to navigate, find, and organize your files. It
provides a large Content panel in the middle from which to
select files.
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• Filmstrip. The Filmstrip workspace is great for previewing
files. It provides a large Preview panel to view the images.

• Metadata. The Metadata workspace is great for viewing the
metadata of images. A large Content panel allows you to
quickly select different files, and a Metadata panel allows you
to view the metadata.

• Keywords. The Keywords workspace is designed to help
you quickly add and manage keywords for images.

• Preview. The Preview workspace provides the largest area
for previewing images. The Content panel is narrow and
vertical, which can make it difficult to use.

• Light Table. The Light Table workspace displays only the
Content panel. This is excellent for selecting files after you
have already navigated to the files you need.

• Folders. The Folders workspace is designed to help you
navigate the file system to find the folders and files that you
need to work with.

Organizing Files in Bridge

The true value of the Bridge application is in its ability to
quickly find and organize images. Bridge provides direct
access to all metadata contained in an image's file and allows
you to add additional metadata in the form of keywords,
labels, and ratings. Bridge also allows you to organize photos
in a more usable fashion than a traditional file system by
arranging them in collections and stacks. Keeping your files
organized will save you time when looking for images.
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Importing images from cameras and card readers

An extremely useful feature of Bridge is its ability to import
files from a camera or card reader directly to your computer
file system. Most cameras and card readers allow you to
easily copy files to your computer, but Bridge offers many
more options than just copying.

To import images from your camera or card reader to Bridge,
choose File⇒Get Photos from Camera from the main menu
bar, or click the Get Photos from Camera button in the
toolbar. The Photo Downloader dialog box appears, as shown
in Figure 6.4. You can click the Advanced Dialog button to
also display the images on the device, as shown in Figure 6.4.
This allows you to select which images to download from the
device.

Get Photos From

The Get Photos From option provides a drop-down list of
available devices. If you can plug the camera directly into the
computer, it shows up in the list. Mounted memory card
readers also appear in the list.

Location

You can click the Browse button in the Location area to open
a dialog box that you can use to select a destination folder for
the new files. This is the location on your file system where
the new image files are downloaded.

Using Photo Downloader, you can specify where to download
the images, what to name them, and several other options.
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The following sections discuss each of the options available
when downloading images.

Figure 6.4

The content view controls in Bridge allow you to quickly
change how files appear in the Content pane.
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Create Subfolder(s)

You can tell Photo Downloader to create subfolders on the
file system for the new files that you are importing. From the
Create Subfolder(s) drop-down list, you can select None,
Custom Name, Today's Date, or a variety of combinations of
the shoot date with custom data, as shown in Figure 6.5. The
sequence of month, day, and year used when naming the
folders is noted next to each option — for example, mm, dd,
and yyyy.

Figure 6.5

Selecting a subfolder creation option for a destination folder
when downloading images from a camera or card reader

The Create Subfolders option can be extremely valuable if
you are importing files that were taken on different dates and
you want to keep them separate. Photo Downloader can
automatically separate them based on the dates they were
taken.

Rename Files

Another useful feature of Photo Downloader is the ability to
rename files. Most cameras use a simple sequence name that
has no meaning except to the camera. Using the Rename Files
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option in Photo Downloader, you can choose to rename files
based on the current date, shoot date, parent folder name, or a
customized name.

Tip

Using the parent folder name can be helpful if you are using
descriptive filenames because when working with
collections, you cannot easily see which folder the image
resides in.

When you select the Advanced Rename option, a dialog box
similar to the one in Figure 6.6 appears. The Advanced
Rename option allows you to create custom filenames based
on up to ten different components, including text, new
extension, current filename, preserved filename, sequence
number, sequence letter, date/time, and metadata.

The Advanced Rename option is useful for organizing
filenames based on many aspects of the image. For example,
you could organize photos based on lens attribute in the
metadata. Then you could easily find all the images that you
took with a specific lens.

Open Adobe Bridge

The Open Adobe Bridge option is used to automatically open
Bridge if it is not already open when using Photo
Downloader. Because we are discussing using Photo
Downloader from within Bridge, you don't need to worry
about this setting.
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Figure 6.6

Configuring custom filename options when downloading
images from a camera or card reader allows you to organize
files the way you want them.

Convert to DNG

When you select the Convert to DNG option, Photo
Downloader converts the images to the DNG file format
before saving them to your file system. When you enable this
option, the Settings button next to it is enabled. When you
click the Settings button, the DNG Conversion Settings dialog
box appears, as shown in Figure 6.7.

Tip

380



You shouldn't convert files that are not in Camera Raw
format (such as JPEG files) to DNG when importing them.
Because they have already been converted to another
format, the Camera Raw data has already been lost. Editing
them will be faster by just using the current format; there is
no advantage to converting them to DNG even if you plan
on editing them using Camera Raw.

Using the DNG Conversion Settings dialog box, you can
configure the following settings to be used during the
conversion:

• Preview. This allows you to set the size of the JPEG
thumbnail embedded in the DNG file to large, medium, or
none. Using thumbnails can make Bridge run faster; however,
they make the file size larger. If you are not sure, use the
medium setting.

• Compression. This allows you to specify the file
compression. When you check the Compressed option, the
data compression used to store the DNG data is completely
lossless. Unless you have a really good reason to turn this
option off, you should leave it on to keep your image data
intact.

• Preserve Raw Image. This allows you to specify whether
raw data is preserved in the image. When you select Preserve
Raw Image, the image data is stored in the original format if
the DNG converter can read the raw data. This is the best
option because you can always convert the raw data over to a
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linear form, processed into readable pixel data, but you
cannot convert it back.

• Convert to Linear Image. This converts the image to a
linear form, which stores the data more efficiently but is
different from the original RAW format.

• Embed Original Raw File. This embeds the original raw
file inside the newly created DNG file. This option is useful
for full preservation of data; however, it more than doubles
the size of most files on disk.

Figure 6.7

Configuring the DNG conversion settings when converting an
image to DNG while downloading it
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Delete Original Files

When you select the Delete Original Files option, Photo
Downloader removes the file from the camera or memory
card after it has been downloaded. This option is useful in
managing photos. At some point, most people end up with a
memory card containing files that they are not certain have
been downloaded to their computer. Using this option
eliminates that problem.

Save Copies To

When you select the Save Copies To option, Photo
Downloader saves an additional copy of the image file to a
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location that you specify using the Browse button. This option
is useful to help you keep an automatic archive of your
images.

Apply Metadata

The Apply Metadata feature allows you to automatically add
metadata items to images as they are downloaded to the
computer. This can save a lot of time later as you don't need
to add metadata to individual files. You can select one of the
custom defined metadata templates (discussed later in this
chapter) using the Template to Use drop-down list. Bridge
applies the selected custom template to each image as it is
downloaded to the file system. You can also add the creator
and copyright metadata to the file by typing this information
into the appropriate text boxes.

Working with image metadata

The metadata of an image is often as valuable as the pixels in
the image. In fact, some files simply are not useful without
their metadata. Bridge displays metadata about files in
various views and even allows you to filter a list of files based
on the metadata.

The metadata contained in each file can provide a lot of useful
functionality. For example, the metadata of a photo typically
contains information about the time and date that the photo
was taken, which you can use later to accurately label and
organize the file. Photo files also typically contain
information about the camera, lens, and settings that were
used for each photo. Many cameras also have GPS
functionality that includes the GPS coordinates where the

384



photo was taken. For serious photographers, this saves a lot of
time recording the settings that were used for each shot.
Photographers can use the settings to compare results in
multiple images to get a better feel for what camera settings
and lenses to use.

This section discusses the two major features of Bridge that
you use when viewing and changing metadata: the Metadata
panel and the File Info utility. The Metadata panel, shown in
Figure 6.8, allows you to quickly view all available metadata
for the image selected in the Content panel. You can access
the Metadata panel by choosing Window ? Metadata Panel
from the main menu bar.

The data in the Metadata panel is organized into the following
major sections (you can expand or collapse these sections by
clicking the triangle next to the section title):

• File properties. This displays information about the image
file, such as the filename, size, type, dimensions, and color
mode.

• IPTC Core and IPTC Extension. These display the IPTC
(International Press Telecommunications Council) data,
including creator information, copyright description,
keywords and much more.

• Camera Data (Exif). This displays information about the
camera used to take the photo, including the lens, ISO setting,
aperture, and so on.

• Audio. This displays information about audio files,
including the artist, album, song, genre, and so on.
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• Video. This displays information about video files, such as
the tape name, scene, shoot, and date.

• DICOM. This displays the DICOM information associated
with the image, including patient name, date of birth, study
information, physician, and so on.

• Mobile SWF. This displays information about SWF (Small
Web Format) files, such as content type, persistent storage,
and background alpha.

Figure 6.8

Viewing the metadata for an image file in Bridge
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Bridge also allows you to edit the metadata associated with a
file using the File Info utility shown in Figure 6.9. You can
use the File Info utility to add keywords, copyright data,
descriptions, and much more.
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To use the File Info utility, select one or more images and
then choose File⇒File Info from the Bridge main menu bar.
After you have launched the File Info utility, select the tabs at
the top to select areas of the metadata you want to alter. After
you select each tab, you can add or alter certain parts of the
metadata. These saved metadata changes become a permanent
part of the image file so it's available later, and you can filter
and search on those metadata items from within Bridge.

Figure 6.9

Modifying the metadata for files using the File Info utility in
Bridge

Tip

388



The File Info utility allows you to set the metadata on
multiple images at the same time. When setting metadata for
multiple files, select all files that have the same metadata
settings and then make the changes.

Assigning ratings and labels to files

Bridge allows you to assign ratings and labels to files. Adding
ratings to files helps you organize files that you like better
than others. Ratings are based on values of one to five stars.
This helps when you are finding files because you can filter
out the ones with fewer stars.

Bridge also allows you to add labels to files to help you
organize them to use later. You can label files with the Select,
Second, Approved, Review, and To Do labels. To add a rating
or a label to a file, choose Label from the Bridge main menu
bar and then select one of the options shown in Figure 6.10.

Figure 6.10

Adding ratings and labels to files helps you organize,
prioritize, and find these files more easily.
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Assigning keywords to files

An extremely useful feature of file metadata is the ability to
add keywords that identify or link the file with a person,
event, place, or some other piece of data. Bridge makes good
use of the keyword feature by allowing you to create new
keywords and keyword groups, and then add them
permanently to files.
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You can define, group, and assign keywords using the
Keywords panel, shown in Figure 6.11. After assigning the
keywords to files, you can use them to more easily find the
files later.

Adding an existing keyword to a file

To add an existing keyword to one or more files in Bridge,
open the Keywords panel. Then select the files in the Content
panel. Finally, select the keyword you want to add to the files;
Bridge writes the keyword to the metadata of the files.

Adding a new keyword

The Keywords tab displays only the basic keywords as well
as keywords that exist in the selected files. If you want to add
a new keyword that doesn't exist already to a file, click the
New Keyword button in the Keywords panel or right-click in
the Keywords panel and select New Keyword from the popup
menu. A new keyword is added to the list, and you can type
the name in the provided text box.

Figure 6.11

Adding and managing keywords associated with files helps
you organize and find the files more easily.
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Finding a keyword in the list

Sometimes even having keywords divided into subgroups
doesn't make it easy enough to find the keywords. You can
use the search field in the Keywords panel to search for
keywords. As you type into the search box, the keywords
matching the search appear in the list. The search is not case
sensitive and searches for text anywhere in the keyword
name.

Renaming and deleting keywords

Bridge allows you to quickly rename and delete keywords to
keep your list organized. To rename a keyword, right-click it
in the list and select Rename from the popup menu. Then type
the new name of the keyword. Bridge modifies the metadata
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in all the files containing that keyword to update the keyword
name.

Caution

When renaming keywords, you should make sure that they
mean the same thing in all images or you could have
unexpected results. For example, if you wanted to
consolidate your entire family into one keyword and
replaced all the occurrences of the keyword “William” for
your cousin William, and at the same time you had an image
of Prince William and Kate Middleton that was tagged with
the keywords “William” and “Kate,” you would accidently
add the royal couple to your family.

Renaming files

As discussed earlier, you can rename files as you import them
from a camera or a memory card. Bridge also provides the
Batch Rename utility to rename files that already exist on the
file system. To rename files in Bridge, select them in the
Content panel and then open the Batch Rename utility, shown
in Figure 6.12, by choosing Tools⇒Batch Rename from the
Bridge main menu bar.

Figure 6.12

Configuring custom filename options when renaming files in
Bridge
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These options are available when renaming files using the
Batch Rename utility:

• Preset. This allows you to select a default renaming
configuration or a configuration based on string substitution,
or to use one of your previous renaming configurations.

• Destination Folder. This allows you to specify whether you
want Bridge to place the renamed files in the same folder,
move them to another folder, or make copies in another folder
while keeping the originals.

• New Filenames. This section allows you to specify custom
filenames based on up to ten different components, including
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text, new extension, current filename, preserved filename,
sequence number, sequence letter, date/time, metadata, folder
name, and string substitution.

• Options. This lets you specify whether to preserve the
current file in the XMP metadata of the file. XMP (Extensible
Metadata Platform) is a standard developed by Adobe for
processing and storing metadata. You can also specify
whether to force the new filename to be compatible with
filename requirements on Windows, Mac, or Unix.

• Preview. This displays a preview of how the renamed
filenames will appear.

Finding files

One of the biggest strengths of Bridge is that it can quickly
find files you are looking for. Bridge provides several tools to
help you do this. The following sections discuss using the
Filter panel, the Find tool, and the Review mode to find files
using Bridge.

Locating files using the Filter panel

Bridge enables you to quickly find files based on keywords,
labels, file ratings, and other values. To use metadata
information to find files in Bridge, open the Filter panel,
shown in Figure 6.13. The Filter panel keeps a list of
categories of metadata that you can use to filter the list of files
displayed in the Content pane. You can expand and collapse
these categories using the triangle button next to the category
title.
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To filter on a specific item, expand the category and select the
item. A check mark appears next to the selected item, as
shown in Figure 6.13. You can select as many items as you
like. Bridge displays only the items that match the criteria of
the selected metadata items.

Figure 6.13

Filtering the list of files in the Filter panel using metadata
contained in the files
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Tip

If you need to browse several folders when searching for
files, you can click the Pin button in the bottom-left corner
of the Filter panel to keep the filter in effect when browsing
through folders and collections.

Tracking files using the Find tool

Another extremely effective way to find files in Bridge is
with the Find tool, which you can access by choosing
Edit⇒Find from the Bridge main menu bar. The Find tool,
shown in Figure 6.14, allows you to quickly specify a source
location and search criteria to find files. The resulting files
match the specified criteria then appear in the Content pane.

Figure 6.14

Using the Find tool, you can specify a set of criteria to match
in the metadata of files while searching the file system.
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The Look in field of the Find tool allows you to specify a
folder or collection to search from. You can also launch the
Find tool by selecting a collection or folder in the Collections,
Favorites, Folders, or Content panels and pressing Ctrl+F/
+F.

You can specify the search criteria on a specific metadata
item or on all metadata by selecting the option from the
drop-down list. You then specify the criteria-matching option
and a value. To add more criteria, click the plus button. To
remove criteria, click the minus button next to the criteria.
You can also specify whether to add the file if any of the
criteria are met, or only if all the criteria are met. You can
also tell the Find tool to include the subfolders of the selected
location and non-indexed files in the search.

Tip
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When you are creating collections, a good place to start is
by using the Find tool to get a list of the files that you want
to place in the collection. Then select all the files in the
Content panel and add them to the collection.

Viewing files using the Review Mode utility

After you have a list of files in the Content panel, one
additional feature in Bridge can help you find the files you
want. Typically, you view the files as thumbnails and look for
specific files. Bridge provides the Review Mode utility,
shown in Figure 6.15, to quickly view and locate images.

Figure 6.15

Using the Review Mode utility lets you scroll through a list of
images in the Preview panel.

400



The Review Mode utility, which you access by choosing
View⇒Review Mode from the main menu bar, displays a
rotating carousel view of the images in the Preview panel.
This is similar to the Cover Flow view on Macs, iTunes,
iPads, and iPhones. Selecting an image with the mouse brings
that image to the front of the view. You can also click the left
and right arrows to rotate the image to the left or to the right.
Clicking the down arrow or dragging an image off the screen
removes the front image from the list.

Using collections

A collection is a set of files that are grouped together in
Bridge. The collection concept does not exist outside of
Bridge, which offers some advantages and disadvantages. An
advantage is that you can create and delete collections in
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Bridge without affecting the actual files on disk. You can also
add files to collections, regardless of where they exist in the
file system. The disadvantage is that, although you can view
collections of files quickly in Bridge, you cannot view them
in other applications (except Photoshop and InDesign using
the Mini Bridge panel).

Using Bridge collections is useful for keeping track of files
that belong together. The following sections describe how to
create collections of files in Bridge using the Collections
panel, shown in Figure 6.16.

Figure 6.16

Using the Collections panel to create collections of files in
Bridge

Creating collections
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You create a new collection in Bridge by clicking the New
Collection button in the Collections panel. A new collection
appears, and you can type its name. You can rename the
collection at any time by right-clicking it and selecting
Rename from the popup menu. To delete a collection,
right-click it and select Delete from the popup menu.

After you have created a collection, you can drag files from
the Content panel onto the collection in the Collections panel.
When you select a collection, all files that you have added to
the collection appear in the Content panel.

Creating smart collections

Collections are great for creating one-time sets of files. A
much more dynamic option is to use the smart collection
feature that is built into Bridge. Smart collections are dynamic
collections that update continually. You point them to a
location, and they update every time new images are placed
into that location.

A major advantage of smart collections is that they update
based on a configurable filter set. The filter set is the same set
that is available in the Find tool. You can specify the search
criteria on a specific metadata item or on all metadata by
selecting the option from the drop-down list. For example,
this allows you to add files to a smart collection only if they
are taken with a certain lens or ISO setting or if they contain a
specific keyword or rating.

To create a smart collection, click the New Smart Collection
icon in the Collections panel to open the Smart Collection
dialog box, shown in Figure 6.17. Then select the source
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folder to search when looking for new files. Next, set up the
criteria on which to filter when adding files to the collection.
You can edit the criteria at any time by clicking the Edit
Smart Filter button in the Collections panel or in the Content
panel when a smart collection is selected.

Figure 6.17

Configuring a smart collection to dynamically update the
collection based on a set of criteria

Creating stacks

The proliferation of the digital camera has resulted in one
serious side effect: instead of just a single photograph, people
tend to take several. This can present a problem when
organizing files in Bridge. Instead of a simple list of the
photos to choose from, you end up with an extended list
containing sections of nearly identical photographs that are
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difficult to scroll through. Bridge solves this problem with the
stack feature.

The stack feature allows you to take a group of duplicate
photos and place them in a stack, just as you would on a
desktop. You place the best image on top, and that is the only
image you have to view when browsing in Bridge. The other
images are still there and you can access them; however, they
are hidden from the general view.

Note

When you open a stack from Bridge by double-clicking it,
the images open as separate files. You can also choose
Tools⇒Photoshop⇒Load Files into Photoshop Layers to
load the stack into layers in the same document. This can be
useful if you want to convert the layers to a smart object and
then use the Layers⇒Smart Objects⇒Stack Mode options
to reduce noise and enhance the images.

To create a stack from a group of images, select the images in
the Content panel. Then choose Stacks⇒Group as Stack or
press Ctrl+G/ +G to create the group, as shown in Figure
6.18. Instead of all the images appearing, only the top one is
visible in the stack icon with a count in the top-left corner.

Figure 6.18

Grouping images as stacks allows you to hide duplicate
images while browsing through images in Bridge.
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You can expand or collapse the stack by clicking the count
icon in the top-left corner. To promote an image to the top of
the stack, simply drag it to the left so it is in the top-left
position in the stack.

To remove an image from a stack, select it and then choose
Stack⇒Ungroup from Stack. To add another image or images
to an existing stack, select the stack and the images and then
choose Stack⇒Group as Stack.

All metadata operations apply to the stack, so if you add a
rating, label, or keyword, Bridge applies it to all images in the
stack.

Deleting versus rejecting files

Bridge allows you to prevent files from being viewed in two
ways: deleting and rejecting. Deleting a file also removes it
from the file system. Rejecting a file tags it so that Bridge no
longer displays it normally. These options are
straightforward, but you should know for sure that you want
to permanently remove the file before deleting it.

To delete or reject a file in Bridge, select the file and press the
Delete key. A dialog box appears that enables you to either
delete or reject the file.
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Note

Even if you have rejected a file in Bridge, you can still view
it in the Content panel by choosing View⇒Show Rejected
Files from the main menu bar.

Processing Images Using Bridge and Photoshop

Bridge is a powerful tool that allows you to organize and
manage image files. In addition to organizing image files,
Bridge uses an interface with Photoshop to help you process
the images directly while you are organizing them. Bridge
also provides a menu that directly links to Photoshop utilities,
allowing you to perform Photoshop image processing from
the Bridge menu. The following sections discuss some of the
main image-processing operations that you can perform from
within Bridge.

Opening images in Photoshop

One of the most common processing tasks done in Bridge is
opening images in Photoshop. Photoshop is where you edit
the images. Rather than having to open Photoshop and use the
standard File⇒Open dialog box, you can open images in
Photoshop directly from Bridge, where you have great tools
for organizing and finding them.

Bridge makes it fast and easy to open an image as its own
document in Photoshop. Simply select the image (or images)
that you want to open in the Content panel, and then choose
File⇒Open with⇒Adobe Photoshop CC (default) from the
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Bridge main menu bar. If Photoshop is not already loaded, it
loads and then the selected images are opened as separate
documents in Photoshop. You can then edit them.

Placing images in Photoshop

Bridge also makes it possible to place images into other
images in Photoshop. To place an image into another image
in Photoshop, make sure the original image is active in
Photoshop. Then select the image in the Content panel and
choose File⇒Place⇒In Photoshop from the Bridge main
menu bar. Photoshop places the image into the original
document as a smart object layer, exactly as if you had
selected File⇒Place from inside Photoshop. Smart object
layers are discussed in Chapter 10.

Note

When placing images from Bridge into Photoshop, you can
only place a single image at a time.

Loading files as Photoshop layers

Another useful way of opening images in Photoshop from
Bridge is to open them as layers in a single document. This is
useful when you are working with a series of images that you
need to combine into a single composition.

To open a series of images in Photoshop using the Bridge
utility, select the files in the Content panel of Bridge that you
want to open as layers in Photoshop. Next, choose Tools ?
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Photoshop⇒Load Files into Photoshop Layers from the
Bridge main menu bar. Photoshop loads the selected images
into a single, new document as individual layers, as shown in
Figure 6.19.

Figure 6.19

Using the Photoshop interface with Bridge, you can open a
series of images as individual layers in a single document in
Photoshop from the Bridge interface.

Opening in Camera Raw

When you are working with Camera Raw images, you will
likely want to first open them in the Camera Raw editor
(which is discussed in Chapter 7) before opening them in
Photoshop. This allows you to make adjustments directly to
the unprocessed Camera Raw pixel data.

Bridge allows you to open images directly into the Camera
Raw editor using an underlying interface. To open images in
the Camera Raw editor from Bridge, select the images in the
Content panel and then choose File⇒Open in Camera Raw.
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The Camera Raw editor is launched if it is not already open,
and the images are opened as individual documents.

Processing Multiple Files Using the Batch Interface

One of the strengths of Photoshop is its ability to automate
the processing of images. One of the utilities that Photoshop
provides to automatically process images is the Batch tool.
Bridge uses the Photoshop Batch tool by providing a direct
link to it from the Bridge interface. This allows you to
combine the strength of Bridge in organizing and finding
images with the automated processing engine of Photoshop.
The result is that you are more efficient in collecting files and
then quickly processing them.

To use Bridge to invoke batch processing of files, select the
files you want to process in the Content panel and then
choose Tools⇒Photoshop⇒Batch from the Bridge main
menu bar. Photoshop is launched if it is not already open, and
the Batch dialog box appears, as shown in Figure 6.20.

Using the Batch utility, you can select the action set and
specific action to apply to the files. Do not change the source
from Bridge because it is using Bridge to get the list of files
to process. However, you can modify the Destination and
Errors settings. We discuss the Batch tool in more detail in
Chapter 31.

Figure 6.20

Using Bridge, you can select files to be processed by the
Photoshop Batch process utility.
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Using the Image Processor Interface

Another very useful tool that Photoshop provides when
processing images is the Image Processor utility. This feature
is especially useful for quickly converting a set of files to the
JPEG, PSD, or TIFF formats. Bridge provides a direct
interface with the Photoshop Image Processor utility,
allowing you to quickly find the files using the Bridge
interface and then to convert them using Image Processor.

To use Bridge, launch Image Processor, select the files that
you want to process in the Content panel, and then choose
Tools⇒Photoshop⇒Image Processor from the Bridge main
menu bar. Photoshop is launched if it is not already running,
and the Image Processor dialog box appears, as shown in
Figure 6.21.
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Using Image Processor, you can set the destination of the
modified images, file types to convert the images to, and
actions to be performed on the files as they are converted.
Photoshop provides the best conversion based on the actions
you specify. For more information about batch processing,
see Chapter 31.

Figure 6.21

Using Bridge, you can select files to be processed by the
Photoshop Image Processor utility.

Merging photos
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Merging photos was nearly impossible until the invention of
digital image processing. Computers now make it possible to
analyze the data in images and combine them effectively.

You can apply two types of photo merging techniques to
images. The first type is to combine a set of photos taken
from the same relative position but at different points of the
subject. The result is that single images, each containing part
of the subject, can be combined into a larger image that
contains the entire subject.

The second type of photo merge involves taking a set of
images shot with the camera in the exact same location on the
same subject but with different exposure settings, and then
combining them into an HDR (High Dynamic Range) image.
An HDR image contains much more tonal depth than is
possible in a single image. In fact, there is more tonal data
than you can see on a computer monitor or even when printed
on high-quality photo paper.

The following sections discuss how to use Bridge to select
images and then use the photo merging capabilities of
Photoshop to actually merge the images.

Using Photoshop Photomerge

The Photomerge interface allows you to combine a series of
photos taken at different points of a subject into a single
panoramic image of the entire subject. You can select
multiple images using the Bridge interface, and then launch
Photomerge to combine that set of images together.
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To use Bridge, launch the Photomerge utility, select the files
you want to process in the Content panel, and then choose
Tools⇒Photoshop⇒Photomerge from the Bridge main menu
bar. Photoshop launches if it is not already running, and the
Photomerge dialog box appears. You can then specify the
layout and options to use to merge the images. For more
information about Photomerge, see Chapter 21.

Using Photoshop Merge to HDR

Photoshop provides the Merge to HDR utility to combine a
series of photos taken of the same subject, from the same
position but with different exposure settings, into a single
combined HDR image. You can select multiple images using
the Bridge interface, and then launch Merge to HDR to
combine that set of images.

To use Bridge, launch the Merge to HDR utility, select the
files you want to process in the Content panel, and then
choose Tools⇒Photoshop⇒Merge to HDR from the Bridge
main menu bar. Photoshop launches if it is not already
running, a new document is created with each of the selected
images as different layers, and then the Merge to HDR dialog
box appears, as shown in Figure 6.22. For more information
about the Merge to HDR utility, see Chapter 13.

Figure 6.22

Using Bridge, you can select a series of files and merge them
into a single document using the Merge to HDR utility.
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Auto-merging images into HDR and panoramic images

The interface that connects Bridge with Photoshop also
provides an Auto Collection script that automatically
processes files and combines them into stacks of images that
can be processed into panoramic or HDR images.

Images are collected into stacks based on capture time,
exposure settings, and image alignment. The Auto Collection
script analyzes each stack to determine whether the stack
should be processed into an HDR image or a panorama. If the
content of the images across the stack overlaps by more than
80 percent and the exposure settings vary, then the stack is
interpreted to be an HDR image. However, if the content
overlaps by less than 80 percent and the exposure is constant,
then the stack is interpreted to be a panorama.

Note
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Timestamps must be within 18 seconds for the Auto
Collection script to process the photos.

Use the following steps in Bridge to process photos into
stacks of HDR and panoramic images:

1. Choose Edit⇒Preferences in Windows or Adobe Bridge
CC⇒Preferences on a Mac to launch the Preferences
dialog box.

2. Select the Startup Scripts panel, shown in Figure 6.23.

Figure 6.23

Enable the Auto Collection CC script to automatically process
sets of images into panoramic or HDR images.
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3. In the Startup Scripts panel, make certain that the Auto
Collection CC option is selected and then click OK.

4. Open the Folders panel in Bridge.

5. Navigate to the folder with the HDR or panoramic
shots.

6. Choose Stacks⇒Auto-Stack Panorama/HDR from the
menu bar.

This creates stacks in the folder containing sets of images that
can be combined into a panorama or HDR.
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Tip

Running the Auto-Stack Panorama/HDR setting from
Bridge is very processor-intensive on your computer, as it
analyzes all the files in the selected directory. To reduce the
overhead, move the files you know need to be stacked into
their own directory. This reduces the amount of processing
that is required.

7. Choose Tools⇒Photoshop⇒Process Collections in
Photoshop from the Bridge main menu bar to have
Photoshop automatically merge the images.

The results appear in Bridge.

Using the Mini Bridge Extension in Photoshop

Adobe has added a minimal version of the Bridge application
directly to the Photoshop interface, enabling you to find files
without switching to another application window. This feature
provides some of the useful functionality of Bridge directly
from the same Photoshop interface you are using to edit
images.

To launch Mini Bridge, click the Launch Mini Bridge button.
The Mini Bridge panel appears, as shown in Figure 6.24.

You use the Mini Bridge panel similarly to the Bridge
application. You should recognize most of the features in the
Mini Bridge panel from Bridge. Mini Bridge includes only a
small subset of the functionality of Bridge. However, it is a
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useful tool for quickly finding files from within Photoshop.
This section briefly discusses the options available in Mini
Bridge when browsing for files.

Tip

The Mini Bridge panel does not replace the Bridge
application for most of the things you want to do. Mini
Bridge is useful when selecting files already in collections
or small folders. Use Bridge for organizing your images
first, and then you can use Mini Bridge to find them and
open them in Photoshop. Also, for just one or two files, it is
still much faster to use the standard Open File dialog box.

Figure 6.24

The Mini Bridge panel in Photoshop
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The following sections discuss the panels, buttons, and menu
options available when browsing in Mini Bridge:

• Navigation buttons. These buttons allow you to move
backward and forward using the left and right arrows.

• Bridge button. This button switches you to the Bridge
application. This is a quicker way of getting to Bridge than
navigating the multiple open windows on the system.

• Navigation options. These options allow you to quickly
select a point to begin navigating to images. The options are
Computer, your home folder, Favorites, Recent Folders,
Recent Files, and Collections. When you select an option
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from the Navigation Options drop-down list, the available
containers appear in the Navigation panel.

• Navigation panel. This panel is similar to the Favorites
panels in Bridge. You can select a recent location, favorites,
collections, or even Photoshop albums to browse files.

• Content panel. This panel works the same way as the
Content panel in Bridge. The items in the currently selected
folder or collection appear in the Content panel. You select
items in this panel to use the features in Mini Bridge. You can
drag an image out of the Content panel into Photoshop, and a
new document opens for that file. If you drag an image into
an existing document in Photoshop, that image is placed in
the document as a smart layer.

• View selection. This menu provides a drop-down list with
the option to make selections in the Content pane, start a slide
show, and switch to Full Screen or Review mode. The View
selection menu also allows you to select what information to
display with the thumbnail, such as the filename, size type,
date, and rating.

Tip

When you select recent files or folders from the Content
Option menu, Photoshop provides all integrated CS
components in the Navigation panel. For example, you can
select recent files in Photoshop, Illustrator, Dreamweaver,
and so on.
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• Filter menu. This menu displays a list of ways to filter
items that appear in the Content panel. You can filter by
ratings, labels, rejected files, and hidden files.

• Sort menu. This menu displays a list of fields that you can
select to sort images in the Content panel. When you select
one of the items from the Sort list, the files in the Content
panel are rearranged in order, based on that selection.

• Search. This button launches a simple search tool to search
for files. However, the Search window has a link to the
advanced search feature in Bridge, discussed earlier in this
chapter.

• Thumbnail size slider. This slider changes the size of the
thumbnail that appears in the Content panel.

Summary

This chapter discussed using the Bridge application to quickly
import and organize files. Organizing files is one of the most
tedious and least popular tasks that you must do when
working with image files. Bridge allows you to quickly
organize your files into collections. It also helps you to
quickly find files by using advanced search criteria or
filtering based on metadata stored in the images.

In this chapter, you learned the following:

• Importing images from cameras and memory card readers

• Using Bridge to view and modify image metadata
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• Finding files quickly by searching or filtering on metadata

• Organizing images into smart collections that continually
update

• Renaming multiple files at the same time

• Batch processing images using Photoshop

• Automatically merging sets of files into panoramic or HDR
images

• Using the Mini Bridge panel in Photoshop to quickly find
and select images
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Part II: Working with Camera Raw Images

IN THIS PART

Chapter 7

Exploring Camera Raw Basics

Chapter 8

Processing Photos with Camera Raw
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Chapter 7: Exploring Camera Raw Basics

In This Chapter

Benefitting from Camera Raw

Examining Camera Raw file types

Displaying images in Camera Raw

Looking at the Camera Raw workspace

Manipulating workflow options

Fine-tuning preferences

Exploring the Camera Raw menu

Creating altered versions of your images

Saving settings as presets

Exporting Camera Raw images

While not common in point-and-shoot digital cameras, most
digital single lens reflex (dSLR) cameras support a file format
that is commonly called Camera Raw. If your camera
supports this format and you are serious about creating great
photographs, you probably want to shoot in Camera Raw.

When you capture a picture in the standard JPEG format, the
camera takes the image from the image sensor and processes
it before saving it to your memory card. This reduces the file
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size, but it discards image information that you could have
used to refine your photo.

The Camera Raw format saves the unprocessed file, thereby
preserving all the image data so that you can process it
manually later. It's like being able to process your own
negatives, tweaking them to get the color and lighting just
right.

This chapter introduces you to the Camera Raw format,
explaining why Camera Raw is superior to JPEG and the
advantages and disadvantages of using it. We also explain
what a DNG file is and introduce you to the Camera Raw
workspace, explaining the tools and showing you how to set
preferences.

Looking at Camera Raw Benefits

Camera Raw formats have been around for a few years now,
and many photographers won't shoot in any other format. The
ability to use all the image data captured by the camera's
sensors, which amounts to trillions of colors, is quite
exhilarating. Camera Raw files store the changes made to
them as metadata, preserving all of the original information so
that any editing you do is non-destructive.

Keeping original CMOS information

The sensors in your digital camera that register the light
coming into the camera and convert it into a digital image are
called CMOS (complementary metal-oxide semiconductor)
sensors. Don't worry; we're not planning to remember that
either. The point is that when you set your camera to shoot
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JPEG images, your camera settings (such as the exposure or
white balance) determine how the information is processed,
and everything that is considered extra data is discarded.
After the image is processed, it is compressed, further
reducing the quality and size, to create a JPEG file. When you
download that JPEG file onto your computer and make
changes to it in Photoshop, every recompression performed
when saving the collected changes further reduces the quality.

Perhaps an example will help to illustrate the data that is lost
with a JPEG image. If you have set the white balance on your
camera to capture a photo in fluorescent lighting and you
forget to change that setting to capture photos outside, those
photos will have an unsightly blue-green colorcast. Because
your camera has processed the images with the fluorescent
setting, the information that would correct the white balance
has been discarded, making it next to impossible to
adequately correct the color of those images.

A Camera Raw file, on the other hand, does not discard any
of the information gathered by the CMOS sensors. Instead, it
processes it according to your camera's settings, saves those
settings as the default settings in the metadata, and then saves
all the information gathered by the CMOS sensors as the
image file.

This can happen because cameras can capture as many as 14
bits per color channel, but JPEGs can store only 8 bits per
channel. Camera Raw files, on the other hand, can store up to
16 bits per channel.

With 8 bits per channel, each color channel can have 256
distinct tones. Using 8 bits per channel enables an image file
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to contain over 16 million different colors. With 16 bits per
channel, each color channel can have 65,536 distinct tones.
Using 16 bits per channel enables an image file to contain
trillions of different colors.

You may be asking yourself whether you really need that
many different colors, especially since the human eye can
detect only about 7 million colors at best. But you'd be
surprised at the difference using 16 bits per channel can make
when adjusting levels on problem images. The more tones it
has to work with per channel, the more options Photoshop has
when adjusting the levels in an image. For example, an image
that is almost completely bleached out by overexposure or
completely black from underexposure can be salvaged into a
printable form using 16 bits per channel.

This means that more information is available to draw from
than you can see in your image. For example, consider the
first example shown in Figure 7.1. This photo is seriously
overexposed. At first glance, you might think that the photo
doesn't have enough pixel information to save it. If it were a
JPEG image, you'd be right; those pixels would be gone, or at
least very faded.

Lucky for us, this photo was taken in Camera Raw format.
The pixel information isn't missing; the camera was just set to
a higher exposure than it should have been. With a few
tweaks in Adobe Camera Raw, you can readjust the exposure
settings, in effect reinterpreting the information captured by
the CMOS sensors and recovering most of the color
information, as you can see in the second photo in Figure 7.1.
A definite advantage!
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Figure 7.1

Camera Raw files contain so much information that this
washed-out photo was easily saved.

On the Web

Open Figure 7.1.dng from the book's website. Can you
recover the highlights?

Editing non-destructively

Changes made in the Camera Raw format are saved as
metadata. All photo files have metadata — embedded
information that tags along with the file. Even scanned photo
files have at least the date they were created and their size
embedded as information that your computer can access and
display, even if your photo isn't open in a photo-editing
application. Photos taken with a digital camera have a good
deal more information. You'll find almost everything you
want to know about an individual photo file: the date and time
it was taken; what camera was used; whether the flash was
used, suppressed, or not needed; focal length; white balance
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setting; and the list goes on. Figure 7.2 is just a sample of the
metadata that is available for an image.

Figure 7.2

This is some of the metadata that is available for a Camera
Raw image.
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Bridge displays metadata in its own panel. You
can find more information about metadata in Chapter 6.

In a Camera Raw file, there is even more information; just
like JPGS, Camera Raw files are processed by your camera.
The difference is that the processing information is saved, not
as the actual image file, as it is with a JPEG, but as metadata
that is stored with the file.

When you open a file in a Camera Raw format, it opens in the
Camera Raw application that ships with Photoshop. The
version that will launch with Photoshop CC is Camera Raw 8.
(If you are using Photoshop CC, you will always be using the
most recent version of Camera Raw.) This application enables
you to make changes to your image, but unlike changes made
to a JPEG image, these changes are not permanent, nor do
they erode the quality of the pixels. That's because the
changes you make are also saved as metadata.

If you've used Photoshop or another digital photo-editing
application to change the exposure or color of your JPEG or
TIFF photos in the past, you are going to be impressed by
how clean and easy it is to change a Camera Raw image.
When you change the color or lighting of a JPEG image in a
standard editor, what you see in the photo is what you get. In
other words, the visible pixels are all you have to work with,
and when you change settings such as the brightness or
saturation, you actually alter the existing pixels in the photo
file. If you adjust the exposure a little too high, leaving areas
of your photo completely white (specular highlights), that
color information is irretrievable after you've saved the photo.
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Other changes to your photo can leave “bruises,” eroding the
quality as well as the believability of your photo.

Changing the settings of a Camera Raw image is very
different. You aren't actually changing the pixels in the photo;
you are simply changing the way the pixel information is
interpreted by changing the metadata. Because there is so
much more of that information than there is in a JPEG file,
you have much greater latitude for interpreting the
information. You never lose color information in a Camera
Raw file because if you set the exposure too high, you can
always retrieve the information just by readjusting the
settings.

Note

Non-destructive editing holds true as long as you are
processing your photo in Camera Raw. After you open it in
Photoshop and make changes to it, you are required to save
it in a standard image format. The RAW file isn't
overwritten; you simply create a new JPEG, TIFF, or PSD
file in addition to the RAW file.

So mess with your Camera Raw files as much as you want. If
you go overboard with the settings, no worries; you can just
click the default button and everything goes back to the way it
started. You can do this even after the file has been closed
and reopened, or even if you are in a completely different
Camera Raw editor. You can also save your own settings as
well as the default settings so they are retrievable even after
you've made other changes to them.
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Saving time

Processing your photos in Camera Raw can actually save you
time over processing JPEGs in Photoshop. Consider the
following:

• The Camera Raw files are already processed according to
your camera settings and look just like the same shot taken
with a JPEG setting. If your camera settings were right on,
then great! You don't even need to open your photos in
Camera Raw.

• When you do open your photos in Camera Raw, processing
them is much simpler than using adjustments in Photoshop to
clean your image. With all the extra color information at your
fingertips, finding the right settings is simple.

• Camera Raw handles these files really well. The changes
you make to your photos in Camera Raw happen in real time.
Processing in Camera Raw, especially after you are familiar
with the application, doesn't need to take more than a few
seconds.

• You can batch process your RAW-format images. If you
have taken several photos in the same lighting conditions, for
example, you can adjust the white balance on all of the photos
at the same time.

• If you aren't using your photos in a composite or adding
special effects to them, there's no need to open them in
Photoshop. You can even save a JPEG copy (or one of several
other file formats) right from Camera Raw.
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Understanding Camera Raw File Types

You've probably noticed that we've referred to Camera Raw
formats in the plural sense. That's because it's not a universal
format — there are at least as many Camera Raw formats as
there are brands of cameras that capture it. It seems everyone
wants to implement Camera Raw in their own way. Because
so many formats are constantly being added, it's hard to find
applications that read them. Windows can't even preview or
display Camera Raw files without a plug-in, and eBay
certainly doesn't recognize any of them.

It's conceivable that some of these formats won't stand the test
of time and that 10 or 15 years from now, you won't be able
to open your Camera Raw files. If you own laser discs, you
know that this is reality! The difference is that instead of just
having to spend more money on the same movie, you are
losing your irreplaceable photographs.

However, there is good news. Even as more Camera Raw
formats become available, the Adobe Camera Raw editor
continues to be updated so it can read those formats. At least
for now, you are probably covered.

Some of the more notable Camera Raw file types are the
Canon formats (CR2, CRW), the Nikon formats (NEF,
NRW), and the Sony formats (ARW, SRF, SR2). Your
camera has its own format, and you should get to know that
particular format because no two are exactly alike. If you
have a newer or less common format, make sure you can open
your files in Camera Raw. You could look for supported
formats, but the easiest way is to simply open a photo in
Camera Raw. If it works, you're good to go.
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Creating an XMP sidebar file

When you change a supported file format using Camera Raw,
those changes are saved as metadata so your settings are
permanent unless you want to change them. The caveat is that
even though Adobe can access many Camera Raw file
formats, they are still proprietary, so Adobe can't change
those files. Adobe gets around this by creating a second
sidecar file that contains the new metadata. It is called a
sidecar file because it's connected to the Camera Raw file that
it interprets and moves right along with it if you save it in a
different location. A sidecar file has the extension .xmp
(eXtensible Metadata Platform). When you start to see these
files floating around in your photograph folders, you'll know
what they are.

Converting RAW formats to DNG files

No matter what RAW format your camera supports, if Adobe
supports it, you can convert your files to DNG files. The .dng
file extension stands for Digital Negative, and it is the Adobe
Camera Raw format. Many proponents are fighting for it to
become an industry standard. This would alleviate the fear of
losing your valuable image data in the future as Camera Raw
formats are dropped and support is no longer available for
them in new software applications.

You can convert your Camera Raw files into DNG files by
downloading the DNG converter from the Adobe website
(www.adobe.com). It's free and simple to use. However, it
takes a while to run, so plan on walking away from your
computer while it processes your files.
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Tip

Bridge can also converts your RAW files to DNG files
while they are being imported from your camera or card
reader. Choose Bridge as the method of importing these files
and check the Convert to DNG option in the dialog box.

There are two excellent reasons to convert your Camera Raw
files into DNGs, and we highly recommend that you convert
them even if you save a copy of your files in the original
format.

The first reason is that DNG is becoming a popular and
accepted file format. A few cameras out there even capture in
DNG, including Leica, Samsung, Casio, and Hasselblad. You
can easily convert your Camera Raw files into DNG files
using the converter and open them in several applications that
support this format. The chance of the DNG format becoming
obsolete is small, and its popularity precludes it from doing so
without plenty of warning.

The second reason is getting rid of the XMP files. Because
DNG is the native Camera Raw format from Adobe, Camera
Raw has the power to embed the metadata inside the file,
eliminating the need to add the XMP sidecar file. This means
less clutter and less chance of your settings getting lost in the
shuffle.

Opening Images in Camera Raw
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Opening Camera Raw files isn't any different from opening
any other type of file; you find your file or files in Bridge and
double-click them to open them. Photoshop launches if it's not
already open, but Camera Raw also launches, enabling you to
process your image before opening it in Photoshop for the
more traditional editing process. If you are just cleaning up an
image, Camera Raw can do all the editing required for most
photos.

Note

Although you can open several files in Camera Raw at once,
you need to do this all at the same time. If you try to open an
additional file while Camera Raw is already launched with a
file open, your new file won't open until you've exited the
current instance of Camera Raw.

You can also open JPEG and TIFF files in Camera Raw. This
gives you a quick editor for adjusting color and light in these
file types. To open a file in Camera Raw, right-click the
thumbnail in Bridge and select Open in Camera Raw. You
can also set the preferences in Camera Raw to automatically
open when you open these files in Photoshop. You can learn
more about how to do this in the discussion of preferences
later in this chapter.

New Feature

438



The Camera Raw filter is new in Photoshop CC and is a
quick way to use the Camera Raw tools on any photo.
Although non-camera raw photos, such as the JPEGs
common with most point-and-shoot cameras, lack the depth
and therefore the ability to change as dramatically as their
camera raw counterparts, the adjustment tools in the Camera
Raw dialog box are very powerful and quick to use. You can
access the Camera Raw filter by selecting Filter⇒Camera
Raw Filter from inside Photoshop; this launches the Camera
Raw dialog box. It doesn't contain all of the capability of the
Camera Raw application — for example, it lacks export
features — but you will be able to use the powerful editing
tools to quickly adjust lighting and color in any photo. Be
sure to add it as a Smart Filter so that you can adjust it at
any time.

The Camera Raw dialog box opens by default every time you
open a camera raw file, even if it's a file that you've already
processed. Don't worry; the settings are just as you left them.
You can either readjust them or click Open Image to access
Photoshop. If you've already processed your photo and you
like your settings, or you're just satisfied with the way the
photo looks, press the Shift key as you double-click to open
it; it opens directly into Photoshop, bypassing Camera Raw.

Getting to Know the Camera Raw Workspace

The Camera Raw workspace is very different from working
in Photoshop. You make the different corrections primarily
through the use of a few key tools and sliders, which makes
the workspace efficient and incredibly easy to use. The main
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features of the Camera Raw workspace are shown in Figure
7.3.

Following are the main features of the Camera Raw
workspace:

• Document window. This window displays the document
that is currently selected in the filmstrip. At the bottom, you
see the Zoom Level drop-down menu. From this menu, you
can select a zoom percentage or the fit-to-screen option. Next
to the Zoom Level drop-down menu is the document name. In
the bottom-right corner of the document window are left and
right arrows that let you toggle through the documents in the
filmstrip.

• Filmstrip. This panel shows all the documents that are
currently open in Camera Raw. You can select more than one
by pressing the Shift or Ctrl ( ) keys while you select, or by
clicking the Select All option. Select more than one file to
make the same changes to all of them at once, such as setting
the white balance on several photographs taken at the same
time. You should select all the files you want opened in
Photoshop before you close Camera Raw.

• Camera Raw tools. These tools help you make adjustments
in Camera Raw. They do everything from setting the white
balance to correcting red eye.

• Histogram. This is a very important feature for correctly
setting the levels of color and brightness values in your
image. Understanding the histogram helps you make better
adjustments. If you are unsure what the histogram represents
and how to use it, see Chapter 4.
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• Image adjustment tabs. These tabs enable you to adjust
your images in Camera Raw. You can adjust a Camera Raw
image in several ways, from color settings to lens
adjustments. These adjustments are all represented in the
image adjustment tabs, which you will learn more about in
this and the next chapter.

• Image adjustment panel. This panel changes based on the
image adjustment tab that you have selected. Each panel has
several different adjustment settings that modify the way your
image is interpreted.

Figure 7.3

The Camera Raw workspace is a simple but extremely
powerful utility.
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Changing Your Workflow Options

The Workflow options in Camera Raw enable you to change
the color profile and bit depth of the image you are working
on. Understanding these options and how they affect your
editing will give you the power to make the most of your
RAW files.

At the bottom of the Camera Raw workspace is a blue link
that tells you the workflow options that you are currently
working with. Clicking this link, as shown in Figure 7.4,
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opens the Workflow Options dialog box, as shown in Figure
7.5.

Figure 7.4

This is not only important information, but also a link to the
Workflow Options dialog box.

Setting the color space

Space is the first setting in the workflow options. This option
enables you to set the color space in which you want to work.
You can choose from several color profiles as shown in
Figure 7.6. If you don't see the profile you want, choose
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ProPhoto RGB and convert to your desired color space after
opening your image in Photoshop.

Figure 7.5

The Workflow Options dialog box enables you to reset
important features of your images in Camera Raw.

Figure 7.6

You can choose from several color profiles in the Space
drop-down menu.
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Choosing your intent

Depending on the color space you choose, you may be able to
also select an option from the Intent drop-down menu. You
can choose either relative or perceptual.

A relative color profile is true to the original color and will
only adjust the colors within the gamut of the color profile
chosen. This option can create a skewed image, changing
some colors but not others.

A perceptual color profile will adjust all the colors in the
image to bring them into the color profile. This option can be
unpredictable, returning unexpected results.

Choosing a bit depth
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The Depth setting enables you to choose to work with either 8
bits per channel or 16 bits per channel. Remember that the
bits-per-channel setting determines how many tones your
color channels can contain. At 8 bits per channel, you have
access to over 16 million colors, but 16 bits per channel gives
you trillions of colors. The more colors you have access to,
the easier and better your corrections are in Camera Raw. It
stands to reason that you want to work with 16 bits per
channel as often as possible.

So why is it that when you open Camera Raw for the first
time, it is set at 8 bits per channel? Well, although technology
is getting better all the time, there are still a limited number of
file types and applications that can support 16-bit-per-channel
images. For example, when you change the setting in Camera
Raw to 16 bits per channel and open your image in
Photoshop, a few options — such as the Filter Gallery — are
grayed out because they don't support 16 bits per channel.

Caution

16-bit images are also memory-intensive, so the computer
you are using will be a factor in whether or not you want to
process in 16-bit color. You'll need a current computer with
plenty of RAM.

You probably want to work with images that are set at 16 bits
per channel to make any adjustments necessary in Camera
Raw. If you want to make changes to your image that require
an 8-bit-per-channel setting, you can change your Image
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mode to 8 bits per channel in Photoshop by choosing
Image⇒Mode⇒8 Bits/Channel.

Note

We're pretty sure that Adobe sets your images to 8 bits per
channel in the Camera Raw workspace as a default because
they don't want you to pull your hair out over not having
access to the Filter Gallery in Photoshop later on. When you
set your images to 16 bits per channel, that setting stays set
until you change it, so the next photo you open in Camera
Raw is also set to 16 bits per channel. Remember this small
detail so you won't pull your hair out over options you think
you should have in the Photoshop workspace. Take a deep
breath, and remember to convert your image back to 8 bits
per channel.

Adjusting image size

You can adjust the size of your image in Camera Raw by
resampling it, just as you would in Photoshop. This is one
change in Camera Raw that is destructive. Whenever you
resample an image, you trust an algorithm to selectively add
or destroy pixels to make your image larger or smaller.
Although resizing is often necessary, resizing an image over
and over is unwise.

Click the Resize to Fit option to change the drop-down menu
options shown in Figure 7.7. Choosing any one of these
options enables you to change the settings relative to that
option. For example, if you choose Megapixels from the
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drop-down menu, you can then set the number of megapixels
that you want to resample your image to.

Figure 7.7

You can resize your image using one of several parameters.

Setting the resolution

Setting the resolution of your photo changes the print size and
quality. It takes the available pixels and determines how many
of them to pack into a linear inch. Your computer screen
displays at 72 to 133 ppi (pixels per inch) and many digital
cameras shoot at the smaller resolution of 72 ppi, leaving you
with a photo that has huge dimensions. When you take your
photo in to be printed, the photo processor resizes your photos
to the appropriate size and resolution, starting with the
resolution. As a result, a photo printed at 72 ppi looks
extremely pixelated, giving it a jagged look. Increasing the
resolution to at least 200 ppi gives you a much better result.

448



Increasing the resolution automatically reduces the size of
your image without resampling it. Instead of spreading 72
pixels per inch over 30 inches of photo, you can use the same
pixels to pack 300 pixels per 7 inches of photo, giving you
not only a better print resolution, but also a more reasonable
print size.

Applying output sharpening

The Sharpen For/Amount option enables you to apply output
sharpening for screen, glossy paper, or matte paper. This
option is best for when you are planning to use your image
straight from Camera Raw without opening it in Photoshop.
Sharpening an image is usually the last step you take before
output because sharpening not only loses its effectiveness as
other adjustments and filters are placed over it, but it is also
one of the more destructive edits, making visible changes to
the pixels in your photo.

After you have chosen an output type in Sharpen For
drop-down menu, you can choose to sharpen a high, standard,
or low amount.

Opening images as Smart Objects

Opening your RAW image as a Smart Object makes it a little
more complicated to work with in Photoshop, but it protects it
from the Photoshop edits and enables you to open it back up
in Camera Raw and make additional changes to it. Smart
Objects operate very differently from image files. You can't
make adjustments directly to them, thus limiting changes to
the layer adjustments. The filters added to a Smart Object are
also added as separate sublayers. After you've learned more
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about Smart Objects and how they work, the benefits and
drawbacks of this option will be clearer to you.

You can learn more about Smart Object layers in
Chapter 10.

Now that you've seen the workflow options, the blue readout
at the bottom of the Camera Raw workspace should make
sense to you. You can glance down at any time to check your
workflow option settings and click this link to make changes
if they are not set correctly for the image you are working on.

Note

The workflow options settings stay the same as the last time
you set them, even if you are working on a new image in
Camera Raw. Even if you resize an image, the next image is
set to the same resize option. This is convenient if you want
your color workspace to always be set to ColorMatch RGB,
but it's something to be aware of when working with
different-sized documents that you may or may not want
sharpened.

Setting Preferences

Camera Raw preferences enable you to change the way an
image file is handled in Camera Raw. You can access the
Camera Raw preferences by clicking the Open Preferences
icon in the tool menu, as shown in Figure 7.8. You find
options in the Preferences dialog box that enable you to adjust
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sharpness, create a cache, process various file formats, and
save images.

Saving images

The General preferences enable you to change the way your
images are saved. You can choose to save the changes you
have made as a DNG file or an XMP file, and choose where
to store that XMP file. You can also change your sharpness
settings to apply sharpness to the saved file or just to the
preview.

Figure 7.8

The Camera Raw Preferences dialog box offers a variety of
settings.
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Changing image settings

Changes made to Camera Raw images are not actually stored
in the RAW image file. Instead, these changes are stored in a
separate location. You can store these settings in one of three
ways:

• As a sidecar file with a filename ending in .xmp;

• As a Camera Raw database that Photoshop provides on the
local computer; or

• As part of a Digital Negative (DNG) file.
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The sidecar XMP files have the same name as the Camera
Raw image file, except they end in .xmp. These files have the
advantage of being able to transfer from one computer to
another along with the Camera Raw image.

The Camera Raw database is a simple database that is part of
the Photoshop application on the computer. Using the Camera
Raw database means that you do not need to worry about any
secondary files; however, the database is not available if you
open the image on other computers.

If you choose to save your Camera Raw files in the DNG
format, the settings you make in Camera Raw are embedded
in the file, eliminating the need for a sidecar XMP file and
making the settings portable.

Note

The default preferences you configure are applied only to
Camera Raw images that have not been opened in Camera
Raw. Camera Raw images that have been opened before use
their previous settings. This is an excellent reason to review
and set your preferences long before you open more than
one file in Camera Raw.

Applying sharpening

The Apply Sharpening To setting gives you the option to
sharpen the image preview only, which is the one you're
looking at in the document window, or to sharpen the image
output as well by selecting all images. This setting works with
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the Sharpness slider in the Detail tab. If you choose to
sharpen the preview images only, the Sharpen slider does not
affect the output image. You may or may not want to sharpen
your images at this stage, but you probably want the
Sharpness slider to give you an accurate representation of the
sharpness that Photoshop will apply, so it is best to apply this
setting to all images.

Changing the default image settings

The default image settings enable you to apply auto
adjustments to images that you open in Camera Raw. Auto
adjustments override the settings applied to your image by
your camera, but they are non-destructive and changeable, so
you can tweak your images on a case-by-case basis.

You can also make your preferences specific to the camera or
ISO setting in this area of the Camera Raw preferences. That
means that the preference settings are only applied to the
camera used in the selected image or the ISO setting of the
selected image.

You can change the following default settings:

• Apply auto tone adjustments. When you open an image in
Camera Raw, it reads the settings made by the camera to the
metadata of your image and previews your image with those
settings. If you check the Apply auto tone adjustments option,
Camera Raw reads all the metadata and tries to apply its own
settings for the best image. You can also apply auto settings
by clicking the Auto link in the Basic panel, so we
recommend you leave this option unchecked and try the auto
settings on a photo-by-photo basis.
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• Apply auto grayscale mix when converting to grayscale.
When you create a grayscale image from a RAW image by
selecting the Convert to grayscale option in the HSL/
Grayscale panel, you are presented with a color mixer that
enables you to set the grayscale tones of the various color
information in your image. By default, Camera Raw sets
those tones to an auto balance, hoping for the best mix to
begin with. This is a good place to start, so we recommend
leaving this setting checked.

• Make defaults specific to camera serial number. If you
shoot with multiple cameras that use different initial settings,
then select the Make defaults specific to camera serial number
option. When you are adjusting an image and save the default
settings, the settings are applied only to images taken by the
same camera.

• Make defaults specific to camera ISO setting. If you are
shooting at different ISO settings that require their own auto
adjustments, select the Make defaults specific to camera ISO
setting option.

Modifying the Camera Raw cache

The Camera Raw cache specifies the amount of space allotted
to Camera Raw for processing information. The higher the
memory, the more temporary information Camera Raw can
store on your computer. This memory on your computer is
always allocated to Camera Raw, making it useless for
anything else. The default is set to 1GB. If you increase the
size, it can reduce processing time in Camera Raw. You can
choose to create this cache on any drive connected to your
computer.
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Handling DNG files

The DNG File Handling options enable you to specify how
DNG files are created from other files, including Camera Raw
formats, JPEGs, and TIFFs. You can choose to use the XMP
files or embed a JPEG preview in your DNGs for easier
handling.

When using DNG files, you can choose from these two
options:

• Ignore sidecar “.xmp” files. If you have decided to work
using the DNG file format, selecting the Ignore sidecar
“.xmp” files option stores your settings embedded in your
DNG file, and an XMP file is not created.

• Update embedded JPEG previews. If you are working
with DNG files, you can select the Update embedded JPEG
previews option so other applications can preview the image
without having to read the Camera Raw data. You can choose
to set the preview file size to either medium or full size.

Handling JPEG and TIFF file formats

When you open JPEG or TIFF files in Camera Raw, you can
use the tools found in the workspace, but without the benefit
of the increased color depth found in RAW images. You can
choose to open these files automatically in Camera Raw,
sometimes, or never.

If a few, quick adjustments are all that is needed to improve a
JPEG or TIFF file, opening them in Camera Raw is the fastest
and easiest way. If there is more that you want to do with
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these images, or if you want to make the adjustments
non-destructive, use the Camera Raw filter found inside of
Photoshop.

Choose these options for either JPEG or TIFF files:

• Disable JPEG/TIFF support. This option prevents JPEGs
or TIFFs from being opened in Camera Raw.

• Automatically open JPEGs/TIFFs with settings. This
option enables you to specify whether to open a JPEG or
TIFF in Camera Raw. To open one of these file types in
Camera Raw, right-click the image preview in Bridge and
choose Open in Camera Raw.

• Automatically open all supported JPEGs/TIFFs. This
option automatically opens supported JPEGs and TIFFs in
Camera Raw before opening them in Photoshop. You can
make tonal and color changes more quickly in Camera Raw
than in Photoshop, but you don't have the tonal range that you
do with a RAW image. These changes are permanent and
destructive to a JPEG or TIFF file.

Using the Camera Raw Panel Menu

The Camera Raw panel menu is very useful for creating
different settings in the same image. You can choose to use
the Camera Raw defaults (the settings your camera processed
your image with), use the custom settings, or switch back to
the previous settings. You can save as many different settings
as you like and access them using this menu. You can access
the Camera Raw panel menu by clicking the Panel menu icon
under the image adjustment tabs, as shown in Figure 7.9.
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Figure 7.9

The Camera Raw panel menu gives you many options for
saving and retrieving your settings.

In this menu, you have the following options:

• Image Settings. This option applies to images that you have
previously opened and changed in Camera Raw. A check
mark next to Image Settings indicates previous settings. After
making additional changes, you can select this option to
return to those settings.

• Camera Raw Defaults. This option is selected if your
image is newly opened in Camera Raw. You can click it at
any time to return to the original Camera Raw settings.
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• Previous Conversion. This option applies the settings used
for the last image open in Camera Raw to the current image.
This is handy if you have photos that were taken at the same
time with the same camera in the same lighting conditions.

• Custom Settings. This option is checked after you make
changes to an open image. This enables you to preview the
original image by selecting Camera Raw Defaults or Image
Settings and then returning to the changed image by clicking
Custom Settings.

• Preset Settings. This option displays any presets you have
applied to your image.

• Apply Preset. This option displays a preset menu that
enables you to apply presets to your image. If you apply more
than one preset, it is added to the previous preset(s) unless it
falls into the same category. For example, applying Clarity
+15 to Exposure +25 sets both Clarity and Exposure to those
values. Applying Clarity +15 to Clarity +25 simply reduces
the Clarity setting from +25 to +15.

• Apply Snapshot. This option enables you to load any
snapshots you have taken in the Snapshot panel. We show
you how to do this later in this chapter.

• Clear Imported Settings. This option enables other
applications that use Camera Raw, such as Photoshop
Elements, to clear the settings created using Photoshop.
Because fewer options are available to users of Photoshop
Elements, this clears settings that these users cannot access or
modify.
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• Export Settings to XMP. This option enables you to export
the current settings to the XMP file. This is only a temporary
save, however. When you click Done or Open Image, these
settings are overwritten by the current settings. You can click
Cancel, however, and these settings become the saved default.

• Update DNG Previews. This option enables you to update
the JPEG previews in your DNG file. You can also set the
size of these previews. If you've set your preferences to
update these previews, they are updated when you close or
export your image.

• Load Settings. This option enables you to load a saved
setting.

• Save Settings. This option enables you to save your settings
as a preset. A dialog box opens that gives you the option to
select or deselect each setting individually to save in your
preset. The preset is saved as an XMP file in the location of
your choice. The Preset panel enables you to save and load
your settings easily. You will learn more about presets later in
this chapter.

• Save New Camera Raw Defaults. This option enables you
to save your current settings as the Camera Raw defaults.
This gives you the power to change default settings that you
may not like, such as automatic sharpening.

• Reset Camera Raw Defaults. This option resets the
defaults to the original Camera Raw settings.

Creating Snapshots
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As you make changes to your images in Camera Raw, you
may want to save several versions of those changes. For
example, you may want to save the original image and the
special effect you created with it. Using the Snapshots panel,
you can create and save different versions of your image that
are saved as metadata and are always accessible. To open the
Snapshots panel, click the Snapshots image adjustment tab, as
shown in Figure 7.10. There's not much here, just an empty
panel with a New Snapshot and Delete icon at the bottom.

Figure 7.10

The Snapshots panel isn't much until you add to it.
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To create a snapshot, click the New snapshot icon at the
bottom of the Snapshots panel. A dialog box opens, enabling
you to name the snapshot you've just created. After you name
it and click OK, the dialog box closes and the Snapshot name
appears in the Snapshots panel, as shown in Figure 7.11. As
you adjust your image, you can continue to create as many
snapshots as you need.

Figure 7.11

After you've added one or more snapshots, you can return to
their settings by selecting them in the Snapshots panel.
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On the Web

You can access Figure 7.11 with the saved snapshots on the
book's website as Figure 7.11.jpg.

You can access these snapshots at any time by simply
clicking the name in the Snapshots panel. When you are
finished in Camera Raw, it exports the selected snapshot.

Saving Presets

As you adjust the settings in Camera Raw, keep in mind that
you can use the settings on more than just the image you are
adjusting. You can save them as presets and use Bridge to
apply them to other images. You can also apply them to other
images within Camera Raw.

Open the Preset panel by clicking the Preset tab. Just like the
Snapshots panel, the Preset panel is pretty bare until you add
your own presets to it. Click the Add new preset icon on the
bottom of the Preset panel. The dialog box shown in Figure
7.12 opens, giving you the option to choose which settings
will be saved in the new preset. You can also name your
preset to help you find it more easily.

Figure 7.12

You can choose which settings will be changed to create a
preset.
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After you have created a preset, you can change your settings
to match it by highlighting it in the Preset panel. You can also
access the settings in Bridge by choosing Edit ? Develop
Settings and selecting a preset. The setting is adjusted for all
selected images.

Exporting Camera Raw Files
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When you are finished with your image in Camera Raw, you
have several options for exporting it. You can open your file
in Photoshop, close it out, or save it using a different filename
or format. Using the buttons at the bottom of the workspace,
as shown in Figure 7.13, you can open your image in
Photoshop, cancel your changes, and close your image, or
click Done to close your image with the new settings saved.

Note

If you have selected “Open in Photoshop as Smart Objects”
in your workflow options, the Open button reads “Open
Object(s)” rather than “Open Image(s).”

Figure 7.13

Export your document using one of the three buttons on the
right or the Save Image button.

Camera Raw formats are large, unwieldy, and generally not
accepted for printing or sharing on the web. In order to make
your Camera Raw files share-friendly, you need to save them
in a more accepted file format, generally JPEG. You can also
convert your files to DNGs, TIFFs, or PSDs. To explore your
options, click the Save Image button (refer to Figure 7.13) to
open the Save Options dialog box, as shown in Figure 7.14.

Figure 7.14
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The Save Options dialog box enables you to change the name
or file format of your Camera Raw file.

The options available in the Save Options dialog box are as
follows:

• Destination. This section enables you to choose to save
your files in the same location, or a new location.

• File Naming. This section offers several options for naming
a file or multiple files: the batch saving options and the File
Extension option.

• Batch saving options. If you have several photos open in
Camera Raw, you can change their filenames and save them
in sequence using these options.
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• File Extension. Using the File Extension drop-down menu,
you can save your file as a DNG, JPEG, TIFF, or PSD file.

• Format. This section enables you to control different format
options when you save a file. A format is automatically
chosen when you choose your file extension, or vice versa.
The option you choose in this section changes the dialog box
to display the options for each file format.

After you are finished setting your options, click Save and
your file is saved according to your settings. This does not
replace your original Camera Raw file, of course; it creates a
new file.

Summary

By this time, you should have a good idea of why Camera
Raw formats have become so popular and why it is important
to have a non-proprietary format to save these files in. In
addition, you should know quite a bit about the Camera Raw
workspace including the following:

• Where the tools and menus are found and how to access
them

• How to set your workflow options and preferences

• How to create several different snapshots of your image
settings

• How to open your images in Photoshop or export them as
different file types
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Chapter 8: Processing Photos with Camera Raw

In This Chapter

Exploring Camera Raw tools

Correcting several photos simultaneously

Fine-tuning the white balance

Adjusting light settings

Correcting color

Making targeted adjustments

Creating fun effects

Tweaking camera quirks

Adding the finishing touches

When you are familiar with the Camera Raw workspace and
the preferences and menus, you can jump in and start
adjusting your RAW images. In some cases, you will find the
tools and controls so easy to use that you may start opening
your JPEGs and TIFFs in Camera Raw or using the Camera
Raw filter in order to quickly make basic adjustments. In
other cases, if you are familiar with Photoshop, you will be
frustrated that the tools are so completely foreign and so
limited compared to what is available to you in Photoshop.

Getting to Know the Camera Raw Tools
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Before you can make adjustments in Camera Raw, you need
to become familiar with the tools and how they work. The
tools are found at the top of the Camera Raw interface, as
shown in Figure 8.1. Some of the tools are fairly basic, and
you are probably already familiar with how they work, such
as the Zoom and Hand tools. Other tools have specialized
functions, such as the Targeted Adjustment tool and the
Graduated Filter.

These are the same tools available to you in the Camera Raw
filter found inside of Photoshop. You will always want to use
the Camera Raw application to open and make adjustments to
your images that were shot in a camera raw format, but you
can use these powerful tools to make adjustments to JPEG
(and other format) images as well. To make quick, permanent
adjustments, you can open your JPEGs inside the Camera
Raw application. To make non-destructive edits while using
other Photoshop tools, use the Camera Raw filter by choosing
Filter⇒Camera Raw and apply it to a Smart Layer.

You will learn more about Smart Objects and
how they work with the filters you can add to your images in
Chapter 10.

Figure 8.1

Taking a closer look at the Camera Raw tools
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We cover these tools in depth later in this chapter, but for
now, we'll provide you with a quick reference list.

• Zoom. Use this tool to get a closer look at an area of your
photo. The photo zooms to the point where you click the
Zoom tool. To zoom back out, just press and hold the Alt/
Option key to change the plus sign in the magnifying glass to
a minus sign before you click. You can also use the Zoom
menu at the bottom of the document window to choose a
magnification setting.

• Hand. Use this tool when your image is bigger than the
document window; you can grab the image with the Hand
tool and move it around in your window to look at other areas
of your photo.
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• White Balance. Use this tool to select an area of your photo
that is white or neutral gray and change the white balance of
your photo based on that selection.

• Color Sampler. Use this tool to find the RGB values of
areas in your image. These values change as you correct the
tone and color of your photo, giving you a numerical
representation of the changes taking place in your image.
Simply click a color in your photo to place a marker and
display the RGB settings above the image, as shown in Figure
8.2. You can place up to ten color samples. To clear the color
samples, click Clear Samplers.

Figure 8.2

The RGB values in the color samples correspond to the
numbered color sample areas displayed in the photo.
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• Targeted Adjustment. Use this tool to choose one pixel in
your image and change its value in the histogram, which
changes the values of the other colors in the histogram as
well. Click the area of your photo that you want to adjust and
hold down the left mouse button while you drag side to side
or up and down. This changes the value of the pixel you click,
altering the relative values in the histogram. If you click a
darker pixel, the darker areas of your photo change
dramatically while the lighter areas do not change as much.
This holds true if you click a midtone or a light area of your
photo as well; those areas are affected more than others are.
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Again — and we promise it will happen often
throughout the book — knowing how the histogram works
and how colors relate is important to understanding how the
Color Sampler and the Targeted Adjustment tools work. We
discuss both color and histograms in depth in Chapter 4.

• Crop. Use this tool to crop an image. You start by clicking
and dragging around the area you want to crop. If you want to
straighten the image as well, just use the rotating arrow that
appears when you hover over one of the corners, and rotate
the cropped area. Double-click to finish. One difference you'll
notice about cropping in Camera Raw is that even cropping is
a non-destructive edit. Even after opening and closing the
image and creating numerous other settings, you can click the
Crop tool to display the entire image and reset the crop
boundaries, as shown in Figure 8.3.

Figure 8.3

Even though this image was cropped the last time it was
opened, you can change the crop by clicking the Crop tool
and displaying the entire image.
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• Straighten. Use this tool to straighten a photo. Drag in what
should be a straight horizontal line in your photo, and your
image rotates to compensate. This tool is also
non-destructive; you can correct the results at any time.

Except for being non-destructive, cropping and
straightening in Camera Raw work very similarly to the way
they work in Photoshop. That's why they get just a measly
little bullet point here. If you want to read more about
cropping or straightening, see Chapter 3.
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• Spot Removal. Use this tool to correct areas in your photo
that need touchups. We cover the tool in greater detail later in
this chapter.

• Red-Eye Removal. Use this tool to correct red-eye. We
cover this feature later in this chapter.

• Adjustment Brush. Use this tool to make adjustments to
just one area of your photo in Camera Raw. Although this
sounds straightforward, it is actually more complicated than it
sounds, so we take you through it step by step later in this
chapter.

• Graduated Filter. Use this tool to make gradual changes to
areas of your photo. For example, you may have a darker
foreground coupled with an overexposed sky. Use this tool to
correct one or the other gradually for realistic results. We
cover this tool later in this chapter.

• Radial Filter. Use this tool to apply corrections in a circular
or radial pattern. We cover this tool later in this chapter.

• Open Preferences. Use this icon to open the Preferences
dialog box where you can adjust several of your Camera Raw
preferences. We cover this feature in Chapter 7.

• Rotate. Use these buttons to rotate your image 90 degrees
clockwise or counter-clockwise.

• Toggle Full Screen Mode. Use this button to fill your
screen with the Camera Raw utility or to reduce it to a
floating box within Photoshop.
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Synchronizing Adjustments in Multiple RAW Images

You can correct several photos at once using the Camera Raw
interface. This is a real timesaver if your photos have been
taken in similar lighting conditions. For example, you might
have several outdoor shots of the same wedding. When you
make changes to the photo that is displayed in Camera Raw,
those changes are also applied to any selected photo in the
filmstrip. Using the Synchronize option, you can choose
which changes apply to selected photos and which ones do
not apply to other selected photos in the filmstrip.

If you want to make changes to multiple photos, they must
first be open in Camera Raw. Select multiple images in
Bridge, and double-click to open them in Camera Raw. They
appear in the filmstrip in Camera Raw, as shown in Figure
8.4.

Figure 8.4

When you open multiple photos in Camera Raw, they appear
in the filmstrip.
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You can select more than one image at once by using the
Shift key to select images in sequence or the Ctrl/ key to
select images one at a time. You can also click Select All to
select all the images in the filmstrip.

To synchronize which changes are made to all the selected
images, click Synchronize. This opens the Synchronize dialog
box, shown in Figure 8.5. Use the drop-down list or select
individual check boxes to specify which options change
across all the selected photos in Camera Raw.
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After you are finished making batch changes, you can select
your photos one at a time to preview the changes and tweak
them individually, but the bulk of the adjustments are already
made, saving you a lot of time in processing your files.

Figure 8.5

Use the Synchronize drop-down list to choose which changes
will be made to the selected photos.
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Adjusting the White Balance

Your camera has a White Balance setting that tells it what
lighting is being used when a photo is captured. For example,
a fluorescent light leaves a greenish-yellow cast on your
photos, giving your whites a greenish-yellow tinge. Your
camera can compensate by adjusting the color information to
filter out the colorcast. But just like any automatic process,
the camera compensation is not ideal for all images.

If your photo is a RAW image, you don't have to worry if the
White Balance setting on your camera is correct or if it is
compensating correctly for a particular lighting situation. You
can adjust the white balance using Camera Raw after the
photo has been shot. Not that you want to shoot all your
images in tungsten mode, but you could.

Getting the white balance correct is the single most important
thing you can do to improve the colors in your photo. Even
photos that look good can be improved with a simple white
balance adjustment, and photos taken in horrible lighting
situations can be improved dramatically. The before photo in
Figure 8.6 shows an image taken under indoor lighting
without a flash. It's hard to tell in the grayscale version
printed here, but if you look at the color version in the center
insert, you'll see that it has a very yellow colorcast. The after
photo shows the same image after a simple white balance
adjustment. The colorcast is gone, and the colors look much
better.

Figure 8.6
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With a click of the White Balance tool, this photo goes from
scary yellow to beautiful color.

On the Web

You'll find the before image saved as Figure 8.6 on the
website. Can you fix the colors?

In Camera Raw, you can reset the white balance correctly in
three different ways:

• Using the White Balance tool;

• Changing the lighting settings; and
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• Using the Temperature and Tint sliders.

Using the White Balance tool

The White Balance tool can be an effective way to quickly
correct the colors in your photo, or it can be an exercise in
frustration. It all depends on the photo you are trying to
correct and the area on which you use the tool. The White
Balance tool can be found in the tool menu at the top of the
Camera Raw interface.

To use the White Balance tool, select it and click an area of
your photo that should be white or neutral gray, as shown in
Figure 8.7. Camera Raw automatically adjusts the colors in
your photo to correct the white balance based on your
selection. Picking just the right color in your photo can be
challenging. It's not always easy to determine an area that is
white or neutral gray. If you're not satisfied with the results,
just continue to click different areas and the white balance is
set anew each time.

Figure 8.7

Use the White Balance tool to select a white or neutral gray
area of your photo.
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If you choose an area that is too bright for the White Balance
tool to sample, you hear an alert and no change takes place. If
you do it a second time, a dialog box pops up, letting you
know that the area you are selecting is too bright to be
sampled.

Changing the lighting settings

You can use the White Balance menu shown in Figure 8.8 to
change the lighting settings based on the lighting where your
photo was taken. If you took a photo on a cloudy day and it
turned out too cool, you can choose Cloudy to warm it up. If
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you took a photo under fluorescent lighting and your photo
has that nasty yellow cast, you can choose Fluorescent to
filter it out. You get the idea. Of course, you may find that
selecting a setting from the menu based on the light in which
you took the photo may not always give you the best result.
You should preview and experiment with the different options
before you decide on one.

Figure 8.8

You can use the White Balance menu to choose a lighting
setting similar to the White Balance setting on your camera.

You can also choose the best option from the drop-down list
and then use the Temperature and Tint sliders to tweak the
colors until they are just right.

Note
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It's not hard to change the white balance settings so you like
the colors in your image. If you ever want to start over from
the camera settings, however, choose As Shot from the
lighting settings menu.

Using the Temperature and Tint sliders

If you prefer to “eyeball” the changes to your white balance,
you can adjust the Temperature and Tint sliders in the Basic
panel, as shown in Figure 8.9. The Temperature slider adjusts
the levels of yellow and blue in your photo, and the Tint
slider adjusts the levels of red and green. A good rule of
thumb is to find an object in your photo that you want to be a
certain color (skin tones or whites are fairly easy to
determine) and tweak the sliders until you have just the color
you want.

Figure 8.9

Use the Temperature and Tint sliders to eyeball the white
balance of your image.
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The Temperature and Tint sliders are also ideal for tweaking
your image after you've made a white balance adjustment
using the White Balance tool or the White Balance menu. We
usually try the tool first and then tweak the results using the
sliders.

Tip

Add a neutral color card to your shot, and you can set your
white balance easily by clicking the card in your photo after
bringing it into the Camera Raw interface. A light-gray
piece of paper works really well. After you've used it to set
your white balance, simply crop it out of the photo. If you
are taking several photos in the same lighting conditions,
you can remove the card after the first shot and set the white
balance for all the photos at once.

Correcting Lighting

The next six settings in the Basic panel adjust the exposure
and lighting of your photo in different ways. This is where
you'll really see a difference in the quality of a Camera Raw
image over a JPEG. Look at Figure 8.10, for example. The
before photo is a shot of Zion Canyon, taken in the evening,
creating a dark image where the cliffs are just silhouettes on
the background of the darkening sky. If this image were a
JPEG, making the image lighter would result in a grainy
photo with a lot of color noise. The after image in Figure 8.10
shows that fixing this image in Camera Raw turned out a
better result; some noise was created, but not nearly as much
as if this image had been a JPEG.
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On the Web

You'll find the before image saved as Figure 8.10 on the
website. Can you fix the exposure?

Figure 8.10

Changing the exposure on a dark Camera Raw image created
much less noise than if the image had been a JPEG.

Note
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Two highlighted buttons at the top of the light and color
adjustments found in the Basic panel are labeled Auto and
Default. To see the settings that Camera Raw thinks are best
for your image, click Auto and the settings are adjusted to a
mathematical interpretation of where the colors and tonal
ranges really belong in your image. Because the Auto
setting is formulaic, you will probably want to do some
tweaking. The Default button resets your image to the
settings that it opened with, whether these are the original
Camera Raw settings created by your camera or settings that
you created on a previous occasion when you opened your
image.

As you change the light settings of your image, keep an eye
on your specular highlights and deep shadows. As you
increase and decrease your exposure, you run the risk of
creating areas where the pixel information is lost because they
are too light or too dark. Be sure to keep these areas
manageable. Click the Highlight clipping warning and
Shadow clipping warning icons in the Histogram, shown in
Figure 8.11, to show clipped highlights in red and clipped
shadows in blue.

Figure 8.11

Use the clipping warnings to display areas that have lost all
color information.
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Tip

Holding down the Alt/Option key while adjusting the
Exposure and Recovery settings shows you clipped
highlights in your image. White areas do not have any color
detail, and red and yellow areas are clipped in one or two
channels. Holding down the Alt/Option key while adjusting
the Blacks shows clipped shadows in black.

You also create some noise as you use these sliders. The noise
becomes more visible the more you adjust the sliders. You
can reduce some noise in the Detail tab, but noise reduction is
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never an ideal fix; if possible, try to prevent noise in the first
place.

Change the lighting of your image by using the following
sliders in the Camera Raw interface:

• Exposure. This slider adjusts the lightness or darkness of
your image. The results are similar to changing the aperture
setting on your camera. In fact, the numbers on the Exposure
slider are in increments that correlate to f-stops: 1.0 is similar
to widening your aperture by one f-stop, and so on.

• Contrast. This slider adjusts the contrast between the
midtones in your image, creating (or reducing) contrast
without significantly changing the highlights or the shadows.

• Highlights. This slider attempts to recover detail from
highlights, or brighter areas of your photo. Rather than
targeting the entire image, this slider looks for color detail in
the extreme highlights of your image and makes them darker
in an effort to recover any blown-out areas of your image.
You will often want to use Highlights in conjunction with
other settings, such as Exposure and Shadows, so you can
achieve a good balance of lighting in your photo.

• Shadows. This slider does the opposite of Highlights,
adjusting and targeting the shadows in the photo. The
Shadows slider is a real miracle worker when either the
foreground or the background of your photo is much darker
than the other. Consider Figure 8.12, where the background
has been seriously overexposed. Adjusting the exposure and
highlights until the background is visible and then using the
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Shadows slider to bring the exposure of the boy back to an
optimal setting improves this photo dramatically.

Figure 8.12

Adjusting the highlights and shadows brings the exposure of
the entire photo into balance.

On the Web

You'll find the before image saved as Figure 8.12 on the
website. Can you adjust the exposure so that both the
foreground and background look good?
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• Whites. This slider determines how white your whites will
be in the photo; you can brighten them by moving the slider
to the right, or deepen them by moving the slider to the left.
This increases or reduces contrast in your image.

• Blacks. This slider does the opposite of the Whites slider, of
course. You can brighten or deepen the blacks in your image
by moving this slider one way or the other.

An advantage to using Camera Raw to adjust your exposure is
that you can create two amazing images with the same shot.
Consider Figure 8.13. In the first image, we see a boy playing
on a rock. In the second image, he becomes a silhouette
against the sunset.

Figure 8.13

You can adjust Camera Raw files to create different looks
with the same photo.
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Note

If you are familiar with Camera Raw 6.0 or earlier, you'll
notice that the settings have changed significantly. We love
the changes. With the ability to increase or decrease both
shadows and highlights, we've been able to make some
incredible improvements to our images, getting exposure
settings that look like HDR images (see Chapter 13). If
you've opened a Camera Raw file and adjusted it in a
previous version of Camera Raw, you'll notice that the
adjustment sliders from the previous version appear in
Camera Raw. To use the new and improved sliders, click the
exclamation point that appears at the bottom of the Camera
Raw document window.
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Adjusting Color and Clarity

You can adjust the color of a RAW image in the Basic panel
for a general fix, the Tone Curve panel for a targeted fix, and
the HSL panel for a highly precise adjustment that allows you
to make custom decisions about your color in eight different
color ranges. Don't be overwhelmed with all these options for
changing and adjusting the color of your images. As with
most situations (in life as well as in Photoshop), it's best to
start with the basics and work up, depending on how much
control you want to have over the color.

Working in Photoshop is an art form, not a science — even
when it comes to correcting color. Although the basic tools
are fairly simple and straightforward, adjusting tonal curves
takes a little practice and effort before you can do it well
without thought, and adjusting color levels in the HSL panel
can very quickly get out of hand! The best way to become
proficient is to jump in and work with these tools until you
feel comfortable using them to adjust the photos that really
matter.

Tweaking clarity, vibrance, and saturation

Clarity, vibrance, and saturation can be adjusted in the Basic
panel of Camera Raw. These adjustments are so useful and
popular that the default panel is the best place for them. They
are also the easiest of the color adjustments to use and to get
right.

As well as improving the overall color and clarity of your
images, these settings can compensate for loss of color and
clarity due to the tonal adjustments. This is a great way to
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create stunningly colorful images, similar to taking pictures
with a high-saturation film.

You can adjust the clarity and saturation of your image by
adjusting these sliders:

• Clarity. This adjustment clarifies the edges in the image,
restoring definition and sharpness by increasing the contrast
of the midtone pixels. This works like magic to reduce hazy
or dull images that are a result of poor shooting conditions or
using other settings that reduce contrast, such as the
Highlights and Shadows sliders. On the other end of the
spectrum, reducing the clarity can even skin tones and reduce
the noise introduced by other adjustments.

To illustrate, look at the difference between the before and
after images in Figure 8.14. The first image has the clarity
turned all the way down, giving a soft, ethereal look to the
fountain. In the second, the clarity is turned all the way up,
giving the water a crisp look so you can see each individual
drop.

Figure 8.14

Using just the Clarity adjustment made a big difference in this
image.
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On the Web

Try your hand at playing with the clarity of this image,
which is saved as Figure 8.14 on the website. Which look do
you prefer?

• Vibrance. This adjustment saturates only the areas of the
image that are of a lower saturation without affecting the
areas that are already highly saturated. It also leaves skin
tones unaffected, making it ideal for saturating images with
human subjects.

• Saturation. This adjustment saturates the image uniformly,
giving you the ability to reduce the colors in your image to
grayscale or to increase the color of your image to as much as
double the saturation. Colorful photos, such as flowers or
balloons, are especially fun to oversaturate in order to create a
color statement.

Adjusting the Tone Curve

Discussing the Tone Curve in the section on adjusting color
may seem odd, because it adjusts the lightness of your image

496



as much as the color. The Tone Curve gives you more control
over which areas of your photo are brightened or darkened, as
well as which colors pop and which ones fade. It takes
practice to get a feel for exactly how the curve works,
however, so you might find yourself inadvertently making
drastic and unwanted changes. You can easily restore the
default settings and start over, though, so don't despair.

We'll do our best to demystify the Tone Curve so your
practice has purpose. The Tone Curve panel has two tabs: the
Parametric tab, which allows you to make limited changes to
the Tone Curve using sliders, and the Point tab, which allows
you to make changes to the Tone Curve using points on the
actual curve.

The Parametric tab

It's harder to take your changes too far with the Parametric tab
because it limits the changes you can make to the sliders. It's
quicker, easier, and generally more user-friendly than the
Point tab. However, it doesn't give you nearly as much
latitude for making changes as the Point tab.

The first thing you should notice in the Parametric tab, shown
in Figure 8.15, is the histogram that represents the tonal
layout of your image. In the image, most of the pixels are in
the midtone range or higher, as you can see by the high peaks
in the middle and to the right. As a general rule, you would
look at this histogram and know immediately that the photo it
represents is low in contrast. That isn't a bad thing for some
images, but we want to add a lot of contrast to this one to
liven it up. This is a photo that will definitely benefit from a
tonal curve correction.
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Note

It's important to look at images in conjunction with their
histograms to decide whether the histogram represents areas
that need to be corrected. A picture taken on a snowy day
might resemble the histogram in Figure 8.15 and look bright
and clear. The histogram by itself is not an indicator of
whether an image is a good one or in need of improvement.
Instead, it is a guide to help you make the right changes to
improve your image.

Figure 8.15

In the Parametric Tone Curve, the histogram represents the
tonal layout of this image.
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On the Web

Figure 8.15 can go from a rather bland photo to a
spectacular one. You can improve it dramatically using the
Parametric Tone Curve. Give it a try by downloading Figure
8.15 from the website and following the steps for changing
the tonal curve.

Fix the photo shown in Figure 8.15 by following these steps:

1. Adjust the indicators directly under the histogram so
they represent a more balanced tonal range, as shown in
Figure 8.16.
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This doesn't change your image, but it affects how the tonal
sliders underneath affect your image. The Shadows slider
adjusts the pixels to the left of the first indicator, the Darks
slider adjusts everything between that indicator and the next,
and so on.

2. Adjust the Shadows slider.

You want to start by adding plenty of shadow to this image to
create contrast. Move the slider to the left to darken the
shadow in the image. Click the shadow clipping warning in
the main histogram to preview any shadows that are being
clipped. (You won't find any in this photo, but it's a good
habit to get into.) Notice that the histogram changes
dramatically. Stop when you are satisfied with the result.

3. Adjust the Darks slider.

You won't need to change this slider nearly as much as you
changed the shadows; move it down just a little to darken the
darker midtones.

Figure 8.16

Adjusting the indicators determines how the sliders affect the
image.

500



4. Adjust the Lights slider.

Move this slider to the right, intensifying the midtone
contrast. The more you move it, the more colorful and almost
surreal the image looks.

5. Adjust the Highlights slider.

This slider won't make dramatic changes to the image, but it
will increase the contrast of the white speckles on the rock,
possibly even blowing them out, so keep an eye on them.

6. Adjust the indicators under the histogram again.

Tweak the indicators under the histogram to make sure you've
balanced them correctly for the best result.
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You can continue to tweak the indicators and the sliders to get
a feel for the changes they are making and determine how to
get the best final result. When you are finished, you should
have a result similar to Figure 8.17.

Figure 8.17

With these final settings, you can already see a marked
improvement in the photo.

The Point tab

The Point tab gives you much more latitude for changing your
image, but it is also more difficult to use than the Parametric
tab. In the following steps, we'll show you how to correct the
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same image used in Figure 8.15 by using the Point tab instead
of the Parametric tab:

1. Click the Panel menu, and choose Camera Raw
Defaults to reset the image.

If you used the Parametric tab to change the curves, you want
to start over from the original image settings. You should
have the image and settings shown in Figure 8.18.

Figure 8.18

The Points Tone Curve gives you very precise results.

2. Use the drop-down list to choose an appropriate setting.
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I changed the image in this example to the Strong Contrast
Preset. This improves the image, but not enough. You can
continue to customize the settings to get a better result.

3. Tweak the points on the curve, if necessary.

Adjusting these points on the curve performs a similar
function to the indicators in the Parametric histogram. By
changing their location on the diagonal, you can change
which pixels are affected as you use them to bend and stretch
the curve. Move these points closer to the histogram so more
tones are affected by each point, as shown in Figure 8.19.
Note that as soon as you do this, the name in the Curve
drop-down list changes to Custom.

Tip

You can add points to the curve by clicking the curve where
you want to add them. You can remove a point by dragging
it quickly off the curve.

Figure 8.19

Move the points on the histogram so more tones are affected
by their adjustment later.
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4. Adjust the area where you want the biggest change
first.

In this example, the biggest change you want to make to the
photo is to increase the dark areas for more contrast, so start
with the lower-left point first. Move the point slowly down.
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You can drag it up and down the curve line as you do this to
further customize your adjustment.

Tip

For more controlled adjustments, use the arrow keys to
move the selected point by increments of one. The up and
down arrow keys adjust the curve, and the left and right
arrow keys adjust the point placement on the curve.

5. Click to add another point on the curve, if necessary.

To keep from blowing out the highlights, you can add an
additional point at the top of the histogram for more control.

6. Continue to move the points on the curve, adding more
when necessary.

This is where practice and experience comes in. Each photo
reacts differently, and you've probably noticed that even a
small change can really mess up your image. Just keep
working with it until you get the result you want.

Note

The Input field tells you the actual value of the pixel you are
adjusting; the Output field tells you what value you are
adjusting the pixel to.
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It doesn't take long to adjust the point curve before you can
see that it is indeed more versatile, but also much more
difficult to control. Because we could add points to the curve,
the end result was better than what we achieved with the
Parametric adjustment, as you can see in Figure 8.20.

Figure 8.20

The Points adjustment is more precise, creating a better
contrast.

Adjusting hue, saturation, and luminance

Figure 8.21 shows the HSL/Grayscale panel. HSL stands for
Hue, Saturation, and Luminance. Each setting has a panel,
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and the color sliders in each panel allow you to make changes
to the color in these precise color ranges.

Figure 8.21

The HSL/Grayscale panel allows you to adjust individual
colors in your photo.
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Hue adjustments
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In this tab, you can literally change the color in your images.
Using the Reds slider, you can change the reds in your image
to bright pink or warm orange, for example. Each pixel in
your image is assigned to one of the color ranges represented
by the sliders. The brighter the colors are in your image, the
more visible these changes are.

You can use the hue adjustments to give a photo a warmer or
cooler feel, or just to enhance or change specific colors in
your image. Have fun playing with the colors, but watch your
skin tones; they can be negatively affected.

Tip

Use the Default link found in each panel to reset the sliders
to zero for that panel.

Saturation adjustments

The Saturation tab has the same color sliders as the Hue
panel, and not surprisingly, they allow you to add to or reduce
the saturation of the targeted color. You can use this feature to
make more selective color enhancements than the Vibrance
slider can give you, or you can even create specialized images
where only one or two selected colors are saturated and the
rest are in grayscale.

Luminance adjustments

The Luminance tab sets the tint or shade of the selected color,
adding black or white to it in order to adjust the brightness of
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that color. Use these sliders to get your colors just right or to
add contrast to your image.

Creating a grayscale photo

The color sliders are not just for color fixes; they make great
adjustments to grayscale brightness values as well. Most color
images don't make great grayscale images when they are
simply converted, brightness value for brightness value.
However, using the Grayscale Mix sliders, you can change
the brightness values that the colors in your image are
mapped to in order to create a fantastic grayscale image.

The first thing to do is to click the Convert to Grayscale check
box to map the colors in your image to the corresponding
grayscale values. This brings up the Grayscale Mix tab, with
the same color sliders that are present in each of the HSL/
Grayscale panels, as shown in Figure 8.22.

Figure 8.22

A grayscale photo with the Auto settings applied
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When you convert your image to grayscale, the Auto setting
is applied, which is the Camera Raw interpretation of what's
best. You can click Default to see what the straight
conversion would look like, but it's not usually as good as the
Auto setting. Or you can tweak the color sliders to map the
brightness values of the selected color to different brightness
values in your grayscale image, changing the brightness and
contrast of selected areas of your photo. Figure 8.23 shows
what a big difference changing the grayscale mix can make.

Figure 8.23

After tweaking the grayscale mix, the flower is much more
striking.
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Using Split Toning

The Split Toning panel is used to create a color-mapping
overlay over the shadows and/or highlights of an image. This
can have the same effect as placing a warming or cooling
filter over a color image. Using the Split Toning panel has the
added benefit of applying a different filter to the highlights
than to the shadows. This allows you to cool down highlights
while warming up shadows, for example, to reduce the effect
of heavy shadows.

When you apply the Split Toning effect to a grayscale image,
it adds a color tone (or two) to the image. You can create
sepia tones or other color effects over your black-and-white
photo.
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In the Split Toning panel shown in Figure 8.24, you can see
the separate Hue and Saturation sliders for the highlights and
shadows (thus the name, Split Toning). The middle slider sets
the balance between the highlights and the shadows. As you
move it to the right, more pixels are considered highlights; as
you move it to the left, more pixels are considered shadows.

You can use the Hue sliders to choose a color to add to your
highlights or shadows, move the Saturation sliders to the right
to determine how much color to add, and set the Balance
slider to determine which color to add where.

Tip

To apply a single color tone to any image, set the Balance
slider all the way to the right or left.

Figure 8.24

The Split Toning panel maps color to your image.
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Correcting and Retouching

After you've made general corrections to the light and color of
your photo, it's time to make on-the-spot corrections. You can
remove flaws or red-eye in your photo, use the adjustment
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brush to make color or lighting corrections to selected areas
of your photo, or create a graduated or radial filter to apply a
color or lighting effect gradually. Although all these changes
have the potential to bruise your image or create noise, they
are considered non-destructive edits because you can always
return to the original Camera Raw settings.

Cloning and spot removal

The Spot Removal tool allows you to make localized spot
correction and cloning fixes to anything from lens spots to
blemishes. In Camera Raw, this tool is limited compared to
the tools you find in Photoshop for cloning and healing. For
basic fixes, however, it works just fine.

Tip

If you have a lens or sensor spot that appears in multiple
photos and can be fixed adequately in Camera Raw, be sure
to take advantage of the fact that you can fix multiple photos
at once. You can open them all at once in Camera Raw or
use the batch editing capabilities of Bridge, which you can
read about in Chapter 6.

To use the Spot Removal tool, follow these steps:

On the Web
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You can download Figure 8.25.dng from the website and
follow the steps to learn how to use the Spot Removal tool.

1. Open a file containing a spot or blemish you want to fix.

This example uses Figure 8.25 from the website.

2. Click the Spot Removal tool.

This changes your cursor to a crosshair and opens the Spot
Removal panel, as shown in Figure 8.25.

3. Select an option from the Type drop-down list.

This example uses the Heal option, which takes the texture,
lighting, and shading from the sampled areas and places them
over the blemish. The Clone brush simply makes a copy of
the sampled area and places it over the blemish, feathering the
edges so they blend in.

4. Select the spot you want to fix.

In this example, drag over the first lens spot, and release the
mouse button. A red outline indicating the area to correct is
created over the blemish, and a second, green, outline is also
created, indicating the area that is being used to create the
patch.

5. Move either circle, if needed.

Camera Raw makes a guess at which area is the best to take a
patch from when it places the green circle. This guess is
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frequently wrong. Move either circle by hovering over the
center of it until the arrow and plus sign appear, as shown in
Figure 8.26, and then grabbing and moving it to a better
location.

6. Resize the circles, if needed.

You can also resize both outlines by using the Radius slider
or by hovering over the edge of either circle until the
two-directional arrow appears, and then dragging them to the
right size.

Figure 8.25

There are several lens spots in this photo that need correcting.

Figure 8.26
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Wait until the cursor changes to an arrow and plus sign before
you move one of the circles.

7. Deselect the Show Overlay option to remove the circles
from view and make sure everything looks good.

8. Repeat Steps 3 to 7 to make any additional healing or
cloning changes.

As you click to create new circles, the old red circles turn
black, indicating that they are not active, and the old green
circles disappear.
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Note

To start over, click Clear All to remove all sampled and
fixed areas.

9. Select any other tool to exit the Spot Removal panel.

You can use the Opacity slider to reduce the effect of the spot
removal, either before or after you have created the healing
circles. The Opacity (as well as the Radius) works only on the
active circles.

Removing red-eye

You can make quick red-eye fixes in Camera Raw from the
Red Eye Removal panel, which you access by clicking the
Red Eye Removal tool. Use the tool to drag a marquee around
each red eye, making the marquee a little larger than the
actual eye, as shown in Figure 8.27. Deselect the Show
Overlay check box so you can see how well your fix worked.
Use the Pupil Size and Darken sliders to tweak the fix and get
it perfect.

Figure 8.27

Red-eye removal takes seconds with the Red Eye Removal
tool in Camera Raw.
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Using the Adjustment Brush

The Adjustment Brush provides the ability to make targeted
adjustments to only the areas in your image that need them.
Camera Raw does this by creating a mask over everything but
the selected areas and making adjustments over that mask,
similar to the way adjustment layers work in Photoshop.

Selecting the Adjustment Brush opens the Adjustment Brush
panel and sets the Mask option to New, as shown in Figure
8.28. The Adjustment Brush works differently from any other
tool in Photoshop, using pins instead of layers to mark each
adjustment. The number of adjustments made depends
entirely on how you use the Mask options.

Figure 8.28
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The Adjustment Brush panel provides a limited number of
adjustments that you can make to targeted areas of your
image.

Setting the Mask options
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The Mask options include New, Add, and Erase. Whenever
you select New, a brush stroke over your image creates a new
mask with new settings, and places a new pin. After the first
brush stroke, the Mask option automatically changes to Add.
When you select Add, the brush strokes you make are added
to the currently selected mask. You can also select Erase,
which allows you to use the brush to erase areas in the
currently selected mask.

Note

Don't be confused by all this talk of brushing on a mask.
You are probably wondering how an adjustment can be
applied through a mask. Actually, each new mask is applied
to the entire image and the Adjustment Brush erases
portions of it so the adjustment can filter through.

Using the pins

The pins that are placed every time you create a mask with
the adjustment brush are only general indicators of the area
where the adjustment is taking place. A pin is placed at the
beginning of the first stroke you make when creating a new
mask. To see the areas that are being affected by your
adjustment, hover over the center of a placed pin, and the
mask temporarily appears over the adjusted areas. Figure 8.29
shows an image with two pins placed. The pin placed over the
cliff is outlined in green (as you can see by the black circle
inside of it), indicating that it is selected. Adding or erasing
affects the mask this pin is associated with.
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Figure 8.29

Create a new mask that places a new pin whenever you want
to make a separate adjustment.

The second pin is placed towards the bottom of the photo.
The cursor is hovering over it, and the mask appears green,
indicating that the waterfall is being affected by the
adjustment. We have purposely changed the color of the
mask, which would normally appear white, to contrast with
the already white water. You can toggle off the visibility of
the pins by clicking the Show Pins check box or pressing the
V key.

Setting the Brush options

The Brush options are similar to brush options that you find
throughout Photoshop. They determine what each of your
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brush strokes looks like. You can change the following
options to customize your brush:

• Size. This option sets the size of the brush. The brush
appears over your image as a solid circle surrounded by a
dotted circle with a crosshair in the center. You can change
the brush size by moving the slider or pressing the bracket
keys.

• Feather. This option makes the edges of your Adjustment
Brush gradually transparent so that the adjustments blend
better with your image. The solid circle inside the brush
indicates where the feathering begins, and the dotted circle
around the outside of the brush indicates the amount of
feathering being applied.

• Flow. This option changes the flow amount to control how
quickly the adjustment is applied.

• Density. This option, similar to opacity, determines how
translucent the adjustment is.

• Auto Mask. This option confines the edges of your brush
strokes to areas that are a similar color to the center of your
brush strokes.

• Show Mask. This option enables you to keep the mask on
while you work. You can change the color of the mask by
double-clicking the mask color and selecting any color you
like.

Setting the Adjustment options
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You can set the Adjustment options either before or after you
create a mask. As you brush to create the mask on your
image, the adjustments are applied as you set them. After you
have finished applying the mask, you can make changes to
the adjustments as long as the pin for that mask is selected.
The adjustments you can make should be familiar to you by
now:

• Temperature. This slider adds a warmer or cooler colorcast
to the selected areas of your photo.

• Tint. This slider corrects the color for greens and reds.

• Exposure. This slider adjusts the amount of light in the area
you have selected. This is a uniform adjustment and can
create clipped highlights and shadows, so be aware of these
areas as you tweak your exposure.

• Contrast. This slider adjusts contrast mostly in the midtone
ranges of the selected area.

• Highlights. This slider brightens or deepens the appearance
of the highlights in the selected area.

• Shadows. This slider brightens or deepens the appearance of
the shadows in the selected area.

• Clarity. This slider adjusts local contrast to add depth to the
selected area.

• Saturation. This slider adjusts the amount of color in the
selected area.
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• Sharpness. This slider adjusts the contrast between edges in
the selected area.

• Noise Reduction. This slider reduces the graininess of the
selected area.

• Moiré Reduction. This slider reduces the random patterns
that can appear when two grids overlap. A pixelated photo of
a striped shirt will sometimes create a moiré pattern, for
example.

• Color. This slider adds a color to the selected area.

Now that we have introduced you to the options in the
Adjustment Brush panel, we will show you how to make
targeted adjustments step by step, so you can see how it is
done. Figure 8.30 is a photo of a waterfall. We would like to
make targeted adjustments to the water so that it appears crisp
in this photo without creating the hard, contrasty effect that
excessive sharpening would create on the surrounding cliff
and bushes. We can also make targeted adjustments to the
cliff face, increasing the saturation and clarity.

Figure 8.30

You can use the Adjustment Brush to enhance the detail of
this image.
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Make targeted adjustments to the photo of the waterfall by
following these steps:

On the Web

You can download Figure 8.30 from the website and follow
the steps to learn how to use the Adjustment Brush.

1. Open the image you want to adjust.

In this example, we opened Figure 8.30 in Camera Raw.

2. Click the Adjustment Brush tool to open the
Adjustment Brush panel, as shown in Figure 8.30.
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3. Click the Show Mask option to display your brush
strokes.

4. Set your Brush options.

Resize the brush so the solid inner circle is a reasonable size
to quickly and accurately select the waterfall. Set the Feather
option low so that the selection you make will be precise,
about 20. Set the Flow to 50 and the Density to 100.
Double-click the mask overlay color to set it to any bright
color, except white.

5. Specify a type and amount for the adjustment you want
to make.

Increase the Sharpness level to 100. The adjustment brush
won't work until you are brushing on at least one change. You
can make further changes after you have created your mask.

6. Brush a mask over the area you want to affect.

This example is changing the waterfall. Pay particular
attention to the areas where the waterfall meets the cliff so
that you can get a precise selection.

7. Deselect the Show Mask check box so you can view the
changes you make with the Adjustment options.

8. Set your Adjustment options.

Raise the Clarity all the way to 100. This, along with the
adjustment you made to the sharpness, gives the waterfall a
crisp, frozen look. You should also reduce the highlights and
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exposure and increase the contrast, so that the water appears
green with white caps, rather than just white.

Note

Alternately, you can make the water look softer and
smoother by reducing the Sharpness and Clarity to –100.

9. Select New to create a new adjustment mask.

Click the Show Mask check box again.

10. Drag your brush across the areas you want to affect to
create a mask over them.

Brush over the cliff and bushes.

11. Deselect the Show Mask check box.

12. Reset your adjustment options.

The cliff face doesn't need as much adjustment as the water.
Warm it up, brighten it, and give it a little more saturation.

Your final image should look similar to Figure 8.31. Despite
the number of steps in this exercise, the adjustments to this
image were made in a relatively short amount of time.

Figure 8.31

With targeted adjustments, you can make the water look crisp
and colorful.
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Creating a Graduated Filter

Another way to create an adjustment over just part of your
image is to use the Graduated Filter. The Graduated Filter
does just what you might think it does: it creates a gradual
adjustment over a targeted area of your image. Except for the
selection process, it works similarly to the Adjustment Brush.

The image in Figure 8.32 has good color and exposure —
except for the sky, which is overexposed. Using the
Graduated Filter, the overexposure can be improved.

Figure 8.32

The sky in this image is washed out and overexposed, but the
Graduated Filter can improve that.
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On the Web

You can download Figure 8.32 from the website and follow
the steps to learn how to use the Graduated Filter.

Follow these steps to learn how to use the Graduated Filter:

1. Select the Graduated Filter to open the Graduated
Filter panel, as shown in Figure 8.32.

The options are identical to those used in the Adjustment
Brush panel.

2. Set the adjustment option that you want to apply to the
image.
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You need to decrease the exposure of this image, so set this
option first by moving the Exposure slider to the left. You can
oNL1y select an area with the Graduated Filter after at least
one option has been changed.

3. Add the Graduated Filter by dragging to select the area
you want to affect.

Starting in the center of the sky, drag the filter straight down
until you can see the detail in the clouds all the way down to
the tops of the cliffs, as shown in Figure 8.33. The green line
(which is the top line in this figure) indicates the area where
the Graduated Filter is applied most heavily. It is applied on
both sides of the green line. The red line (the bottom line)
indicates the outermost edge of the feathering that makes up
the Graduated Filter. No adjustments are made to the outside
of the red line.

Figure 8.33

The Graduated Filter indicators show you where the filter is
being applied.
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4. Adjust your selection, if necessary.

You can expand, rotate, or move the Graduated Filter
indicator using the icons that appear as you hover over it.
Tweak it until you think you've got the best results.

5. Edit the Adjustment settings.

Tweak the adjustments until you get the best results. You may
want to try Steps 4 and 5 interchangeably a few times until
you get the hang of how the Graduated Filter works.
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When you are finished, the exposure in your image should be
greatly improved, as shown in Figure 8.34.

Figure 8.34

We added color and depth to the sky by using the Graduated
Filter.
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Creating a Radial Filter

The Radial Filter allows you to apply a filter over areas of
your image and have the filter gradually change over an
elliptical area. When you create a Radial Filter, you can
choose to apply the change to the inside or the outside of the
ellipse that you draw on your image. This enables you to
create targeted areas of sharpness or blur, intensifying or
changing the color, or changing the exposure.

New Feature

The Radial Filter is a new feature with Camera Raw 8. It
gives you the ability to apply several adjustments in a radius
of your choosing. You can highlight faces, blur outlines, or
make changes in exposure to targeted areas.

To use the Radial Filter, click the Radial Filter icon in the
Camera Raw tool menu. This opens the Radial Filter panel, as
shown in Figure 8.35. Draw an elliptical area to target by
clicking in the center of the area you want to affect, and
dragging out. If you want the area to be a perfect circle, hold
the Shift key as you drag. Once you have created your ellipse,
you can modify it by using the handles to make it larger or
smaller. You can also rotate it by hovering just outside the
outline until a double-headed arrow appears. Click and rotate
the ellipse until you have it placed appropriately.

Figure 8.35
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The Radial Filter allows you make changes to your image that
radiate in an elliptical pattern.

Once you have placed your ellipse where you want it, choose
whether the changes you make will affect the inside or the
outside of the ellipse by selecting the appropriate option at the
bottom of the Radial Filter panel.

Now, use the adjustment sliders to make changes to your
image. In Figure 8.35, I highlighted the boy and made
changes to the outside of the ellipse, decreasing the clarity
and saturation so that the focus of the image is more clearly
the boy. You may want to hide the overlay so that the changes
are easier to see.
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Once you have made changes, use the Feather slider to
increase or decrease the abruptness with which the changes
take place. You can add as many Radial Filters to your
document as you want. Select New from the top of the Radial
Filter panel and draw a new ellipse in your image. When you
are finished making changes, click the icon of any other tool
to exit the Radial Filter panel.

Creating Artistic Effects

You can't create many artistic effects in Camera Raw just yet,
but you can add grain or a vignette to your image using the
Effects panel. Both effects can add depth and interest to a
photo, and as always in Camera Raw, these edits are
completely reversible.

Open the Effects panel by clicking the Effects tab in the
Adjustment tabs, as shown in Figure 8.36. This panel
provides sliders to add and customize grain or a vignette to
your image.

Figure 8.36

The Effects panel allows you to add grain or a vignette to
your image.
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Adding grain to your image

When you add grain to your image in Camera Raw, it is
added to areas that are out of focus more heavily than it is
added to areas that are in focus. This adds depth and interest
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to the softness created by a short focal length. Use the
following sliders to add and fine-tune grain in your image:

• Amount. This slider adds grain to your image when you
adjust it to the right.

• Size. This slider determines the size of the grain added to
your image.

• Roughness. This slider adds contrast between the grains to
enhance the roughness of the texture.

You can see the effect of adding grain or a vignette to an
image in Figure 8.37.

Adding a vignette

A vignette is a soft, circular border around an image that
highlights an area of the image, as shown in Figure 8.37. In
Camera Raw, a vignette is created uniformly around the edges
of your image, targeting the center by default. When cropping
an image, take care that the focal point of your photo is close
to the center.

To create a vignette, change the following options:

• Style. This drop-down list enables you to choose whether
the vignette is a lighter or darker color than the image.
Choose Highlight or Color Priority from the Style drop-down
list. The Highlight Priority option adds black or white pixels
to create the vignette. Color Priority either lightens or darkens
the existing colors in the image to create the vignette.
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• Amount. This slider adjusts the opacity of the vignette.
Adjusting this slider above 0 creates a lighter vignette; the
higher the value, the more opaque the vignette is. Going
lower creates a darker vignette.

• Midpoint. This slider adjusts the size of the vignette.

• Roundness. This slider adjusts the shape of the vignette.
Moving this slider to the right creates a rounder vignette,
while moving it to the left causes it to conform to the shape of
the image.

• Feather. This slider sets the softness of the vignette edges.

• Highlights. This slider pulls highlights out of the image in
the darker areas to create depth. It is available only if you
have created a dark vignette.

Figure 8.37

Adding grain to this photo gave the soft background a grittier,
more interesting texture while adding a vignette highlights the
focal point of an image.

Correcting Camera Quirks

542



The lens of your camera can introduce distortion and color
abnormalities to your image. Sometimes a vignette is created.
These distortions prevent your photo from looking its best.
The Lens Corrections and Camera Calibration tabs have
options that can help you correct these anomalies.

Making lens corrections

The lens of your camera can introduce flaws to your photo
such as distortion, chromatic aberration, and vignetting.
Camera Raw can work to fix these flaws with the adjustments
available in the Lens Corrections tab in the Image Adjustment
panel. In order to make these adjustments, you need to know
what these flaws are and how they are created.

Lens distortions are introduced when you stand too close to a
subject or when you use a special lens such as a wide-angle or
fish-eye lens. These lenses bubble or pinch the center of your
image so that it appears distorted. You can correct these
distortions by using the Distortion sliders in the Profile and
Manual tabs of the Lens Corrections panel.

If you zoom in to an image until you can distinguish the
pixels, you'll probably notice a color fringe around some of
them, especially highlights. This is called chromatic
aberration, and it's caused either by the inability of the
camera lens to focus all the colors onto the sensor at once or
by those colors being focused but slightly different sizes,
producing color fringes. Camera Raw can correct the second
type of chromatic aberration by defringing the pixels.

The previous section covered how to create a vignette as an
artistic effect, but what if your lens has created the vignette
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and you don't want it? You can remove it by using the Lens
Vignetting sliders to adjust for it, almost the exact opposite of
creating one in the Effects tab.

The Lens Corrections panel has three tabs — Profile, Color,
and Manual — as shown in Figure 8.38. The Profile tab
creates an automatic adjustment based on the lens stored in
your metadata, the Color tab helps you remove chromatic
aberrations, and the Manual tab allows you to make custom
changes.

Camera Raw has several built-in lens profiles. If you used a
digital SLR camera to capture your image, chances are
Camera Raw can make adjustments specific to the lens that
you used to create your photo. In the Profile tab, click Enable
Lens Profile Corrections to see if your lens is recognized. If it
is, corrections are automatically made based on the profile of
your lens. You can then make custom adjustments using the
sliders at the bottom of the panel. If your lens is not
recognized, you can use the Manual tab.

The Manual tab gives you more latitude in making the
correctional adjustments, but you need to know which
adjustments are necessary. It's helpful if you know which lens
was used, even if Camera Raw doesn't recognize it; then you
know which Distortion slider to use.

To correct chromatic aberration, Click the Color tab and
select Remove Chromatic Aberration. You want to zoom in
tightly to your image for this adjustment so that you can see
individual pixels. Use the sliders to reduce the color fringes
on your pixels.
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Figure 8.38

The Lens Corrections panel has options for fixing distortion
and color fringes introduced by your camera's lens.

Setting camera calibration

Cameras all have their own way of defining and interpreting
color, and these color profiles are part of what is saved to the
metadata of your image files. When you bring an image into
Camera Raw, it has its own methods of interpreting color and
chooses profiles that are the best for your particular camera
make and model.
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After you click the Camera Calibration tab to open the
Camera Calibration panel, you can choose which profile to
use from the Name drop-down list in the Camera Profile
section, as shown in Figure 8.39. You can see a significant
difference in the color of your image by clicking through
these profiles. After choosing a profile for your image, you
can tweak it by using the color sliders to adjust individual
colors and saturation.

Figure 8.39

The camera profiles in your Camera Calibration panel may be
different from the ones shown here.
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Reducing Noise and Adjusting Sharpness

When you have completed all the other changes to your
image in Camera Raw, you are ready to open the Detail tab
shown in Figure 8.40, where you can adjust the sharpness and
reduce the noise in your image. The “noise” in a photo is
caused by random speckles that detract from its uniformity;
reducing the noise makes your image cleaner. It can also add
a blurred look to your image, so it is best to reduce noise
before sharpening your image. Adding sharpness to your
image can add crispness and clarity to it, reducing blurriness
and enhancing edges. You make these adjustments last
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because their effectiveness is reduced when other adjustments
are added to them.

Figure 8.40

The Detail panel allows you to make the final adjustments to
your image.
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Reducing noise

Noise is defined as random pixels throughout your image that
give it a messy look. Noise is introduced in several ways. For
example, the higher the ISO setting on your camera, the more
noise it creates in your image. Lightening, as well as some
other adjustments, also creates noise.

You can reduce the noise in your image by adjusting the
following settings:

• Luminance. This slider reduces the amount of grayscale
noise.

• Luminance Detail. This slider preserves the detail of the
edges, counteracting the blurring effect created by increasing
the luminance.

• Luminance Contrast. This slider counteracts the blurring
created by increasing the luminance, but to a smaller degree
than the Luminance Detail slider. It increases the contrast
between the bits of grayscale noise.

• Color. This slider reduces the amount of color noise.

• Color Detail. This slider allows you to preserve the detail in
the edges of your photo, counteracting the blurring effect
created when the color noise is reduced.

Note
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Keep in mind that Photoshop reduces noise by blurring your
image and decreasing contrast of individual pixels.
Sharpening also affects your image at the single-pixel level.
It is important to preview your image zoomed in at least 100
percent in order to see and fine-tune the effects of both noise
and sharpening on your image.

Sharpening

Sharpening works by increasing the contrast around the edges
of your image to bring it more into focus, adding detail to
your image. Camera Raw sets the default sharpening at 25 for
RAW images. This is not a huge amount; in fact, it is
comparable to the sharpness your camera automatically
applies to a processed image. A lot of experts will tell you,
though, that adding any sharpening by default is a bad idea,
so if you want to change the default setting to 0, reset the
slider and choose Set New Camera Raw Defaults from the
Adjustment Tabs menu.

Sharpen your photo by using the following adjustments:

• Amount. This slider sets the amount of sharpening applied
to your image. The amount you choose is directly tied to your
Radius and Detail settings.

• Radius. This slider enables you to choose your radius based
on the size of the detail in your image. An image with very
fine detail should have a small Radius setting. Images with
larger details can get away with a larger Radius setting, but
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keep an eye on that preview; a large Radius setting can
introduce an unnatural amount of contrast in your image.

• Detail. This slider heightens the detail of your image as you
raise it by applying the sharpness to higher-frequency areas of
your photo. A very high detail setting gives your image an
almost textured look.

• Masking. This slider, if raised, applies more of the
sharpening effect to the edges of your image and less to the
overall image.

Tip

If you hold down the Alt/Option key while you adjust the
Sharpening sliders, you see a preview of what the control is
doing to your image. This is a great way to become more
familiar with the Sharpening controls and to find the optimal
setting for your image.

Summary

This chapter covered the fundamentals of using Camera Raw.
You learned about color and light and how they can be
adjusted using the tools and panels in Camera Raw.
Specifically, you learned how to do the following:

• Change the light settings to improve the exposure and
contrast in an image
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• Make color corrections to an image or individual colors in
the image

• Make targeted adjustments to only selected portions of an
image

• Create artistic effects with images

• Apply the finishing touches by correcting camera
aberrations, sharpening, and reducing noise in an image
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Part III: Working with Selections, Layers, and Channels

IN THIS PART

Chapter 9

Creating Selections

Chapter 10

Learning All About Layers

Chapter 11

Exploring Channels
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Chapter 9: Creating Selections

In This Chapter

Using the Select menu

Working with the selection tools

Making your selection perfect

Choosing selections based on color

Eventually, you'll want to make changes to just a part of your
photo. Whitening teeth, swapping backgrounds, or targeting
areas of a photo to leave in color even as you turn the rest to
black and white are just a few examples of things you can do
when specific areas of a photo are selected. Knowing the
different selection tools that are available to you in Photoshop
and how and when to use each one is integral to effectively
making these types of changes.

When you create a selection in a photo, you can change the
area inside the selection without affecting any other part of
the photo. You'll sometimes hear selections called selection
masks, because they effectively mask the unselected parts of a
photo from the changes being made. You can also use
selections to create masks and paths, enhancing your selective
creativity even more.

When you have created a selection, you can select any layer
in your Layers panel and have the selection apply to that
layer. This is handy when you are creating masks or cutouts,
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because you can create a selection from one image layer and
apply it to another.

Before we show you how each selection tool works, we cover
the basics, including the Select menu and the options that are
available. After we show you the ins and outs of all the
selection tools, we show you how to put the finishing touches
on your selection and finally how to output your selection as a
mask.

Getting Familiar with the Select Menu

The Select menu, shown in Figure 9.1, has options that help
you to create and use a selection. Some of these options are
holdovers from before the powerful selection tools such as the
Quick Selection tool and the Refine Edge dialog box were
available. Some options you will use occasionally, and other
options you will find indispensable. Being familiar with these
options can empower you in the way you create selections.

Figure 9.1

The Select menu provides you with options to customize your
selection process.
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The following options appear in the Select menu:

• All. This option enables you to select your entire image, or
select around everything in an active layer.

• Deselect. This option deselects everything.
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• Reselect. This option re-selects your selection. Although
you can use the Undo option to immediately bring your
selection back, you can use the Reselect option even after
you've made other changes to your image in the interim.

• Inverse. This option reverses the areas that are selected in
your image.

• All Layers. This option enables you to select all layers
simultaneously when you have two or more layers in the
Layers panel.

• Deselect Layers. This option deselects any layers that are
selected.

• Find Layers. This option changes the Layer filtering mode
in the Layers panel to Name, so you can enter search criteria
and find a particular layer. For more information on layer
filtering, see Chapter 10.

• Isolate Layers. This option, when clicked, will hide all
layers in the Layers panel that are not selected.

• Color Range. This option allows you to create a selection in
your image based on one or more colors.

• Refine Edge/Refine Mask. This option toggles depending
on what is selected and allows you to refine the edges of a
selection or mask.

• Modify. This option pre-dates the Refine Edge dialog box,
and therefore contains many of the same options that allow
you to refine the edge of your selection or mask:
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• Border. This is the only Modify option that isn't found in
the Refine Edge dialog box. It allows you to select just the
border of an object, as opposed to the entire object. After
making a selection, choose Select⇒Modify⇒Border, and the
Border Selection dialog box appears, as shown in Figure 9.2.
You can type the width of the border in pixels, ranging from 1
to 200, and Photoshop creates a border that is centered on the
original selection. The border selection is soft-edged,
feathering out from the original selection, as you can see in
the effect created using the Border Selection tool in Figure
9.2.

Figure 9.2

You can use a border selection to create special effects.

On the Web
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You can access the JPEG of the flamingos as well as the
final PSD file used in Figure 9.2 by downloading both
versions from the website.

• Smooth. This option reduces the “hills and valleys” in your
selection by smoothing the edges of the selection based on the
pixel value you enter.

• Expand. This option increases the overall size of the
selection by expanding it by the number of pixels you
indicate.

• Contract. This option decreases the overall size of the
selection by contracting it by the number of pixels you
indicate.

• Feather. This option makes the specified pixels on both the
inside and outside edges of the selection gradually
transparent. This allows changes you make to the selection to
blend with the surrounding areas, whether you apply an
adjustment to the selection or create a mask with the
selection.

• Grow. This option expands your selection based on color.
The areas that are adjacent to the selection that fall within the
tolerance range specified in the Magic Wand tool (covered
later in this chapter) are also selected.

• Similar. This option expands your selection based on color,
but using the entire image rather than just the adjacent areas.
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• Transform Selection. This option allows you to scale and
rotate your selection.

• Edit in Quick Mask Mode. This option creates an overlay
or mask over the areas of your image that are not selected.
You can change this mask using the Paintbrush or Eraser
tools to make precise refinements to your selection. If you
prefer, you can access it more quickly from the Toolbox. We
cover the Quick Mask feature in greater detail later in this
chapter.

• Load Selection. This option allows you to reload any saved
selections.

• Save Selection. This option allows you to save the current
selection with a .psd extension and retrieve it at any time,
even after you close and reopen the file.

• New 3D Extrusion. This option creates a 3D object from
your selection by adding a third dimension and giving it depth
that you can manipulate with the 3D tools in Photoshop.

Using the Selection Tools

In Photoshop, there are many shapes and sizes of potential
selections. To make the process of selecting as simple and
efficient as possible, Photoshop provides tools that you can
use to make specific types of selections, as shown in Figure
9.3. You can use these tools in conjunction with each other
for more versatility. With the advancements made to the
tools, options, and refinements over the last few versions of
Photoshop, selection has gone from a tedious process to an
enjoyable one.
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Some selections are easier to make using a
specific color channel rather than the full image. For more
information on color channels, see Chapter 11.

Exploring the Marquee tools

The Rectangular and Elliptical Marquee tools allow you to
select areas in your photo that are roughly rectangular or
elliptical shapes. For example, you can select a building with
the Rectangular Marquee and a ball with the Elliptical
Marquee. The Row and Column Marquee tools select a
one-pixel row the width or height of your image. Because
these tools are simple and precise, they make these selections
very quickly.

Figure 9.3

The Toolbox contains many tools that enable you to create
selections.
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You can find the Marquee tools in the drawer of the Toolbox,
as shown in Figure 9.4. Click and hold the triangle at the
bottom of the Rectangular Marquee tool to choose between
the tools, or press Shift+M to toggle between them.

Figure 9.4

The Marquee tools are grouped together in the Toolbox.
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When you select a tool from the Toolbox, the Options bar
enables you to change the way each tool functions through a
wide range of selections. Located under the Menu bar, the
Options bar changes as you select different tool sets. To show
or hide the Options bar, choose Windows ⇒ Options from the
main menu bar.

The Marquee tool options, shown in Figure 9.4, are as
follows:

• Tool presets. This option enables you to save and retrieve
your favorite tool settings using the Tool presets drop-down
list. Click the little arrow to see a menu of available options.

• New Selection. This option creates a new selection, every
time you drag the selection brush, while erasing the old
selection.

• Add to Selection. This option adds every new selection you
make to the current selection. This makes it easy to do the
detail work after you make the initial selection.

• Subtract from Selection. This option can subtract areas
from the current selection.
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• Intersect with Selection. This option selects only those
areas that were in the first selection you made as well as the
second, and deselects anything that was selected only once.

Note

When adding to a selection, subtracting from a selection, or
creating an intersection, you can use the tools
interchangeably. For example, you can add an ellipse to a
rectangle or add a rectangle to a selection made with the
Quick Selection tool.

• Feather. This option makes the specified pixels on both
sides of the edges of the selection gradually transparent. This
allows changes you make to the selection to blend with the
surrounding areas, whether you apply an adjustment to the
selection or create a mask with the selection. This option is
not available with the Row and Column Marquee tools
because you can't feather a single pixel line.

• Anti-alias. This option creates a smoother-edged selection.
It is available only for the Elliptical Marquee tool because the
other tools have straight-lined selection borders and don't
require smoothing.

• Style. This drop-down list allows you to choose a selection
style: Normal to create a freehand selection, Fixed Ratio to
create a freehand selection that is constrained to a certain
ratio, or Fixed Size to type in exact values for your selection.
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• Width and Height. These fields allow you to specify a
width and height for a selection; you can set a ratio or an
actual dimension. You don't have to use pixels (px); you can
also type in inches (in) or centimeters (cm).

• Refine Edge. This option enables you to perfect and finish
your work by refining the edge of a selection. We cover the
Refine Edge feature later in this chapter.

Using the Rectangular Marquee tool

You can use the Rectangular Marquee tool to easily select
rectangular objects in your image. Of course, you will rarely
want to select something that's a perfect rectangle in a
two-dimensional image; even buildings usually have a
skewed shape due to perspective. A more realistic use for the
tool is to create a new document from a selected part of your
photo without overwriting the original photo, or to select an
area of your photo that you want framed.

To create a rectangular selection, check your options on the
Options bar. Do you want the edges of your selection
feathered? Perhaps you are creating different print sizes of the
same document, so you need to set the width and height for a
5 × 7 or 8 × 10 ratio setting. After you have double-checked
all your options, click the Rectangular Marquee tool in the
Toolbox and drag diagonally across the area of your image
that you want to select. Figure 9.5 shows a rectangular
selection that was created with a 90-pixel feather. The edges
are rounded because of the feather. The Quick Mask is turned
on, so you can see the effects of the feathered edges.

Figure 9.5
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Using the Quick Mask feature makes it easy to see how
feathering the edges of a selection softens it.

Using the Elliptical Marquee tool

You can use the Elliptical Marquee tool to select round or
elliptical objects in your image, to copy rounded areas of your
image into new layers or documents, or to create a vignette.
We often use it when correcting a tough case of red-eye. It's a
little trickier to use than the Rectangular Marquee tool,
because you have to imagine a box around the oval you want
to draw and start at the top corner of that box to place the
selection accurately. It's mostly a matter of trial and error. The
good news is that if you get the right size, you can always
pick the selection up and move it to the right position.
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Tip

You can also press and hold the Alt/Opt key as you drag
with the Elliptical Marquee tool to start the selection from
the center.

Tip

Holding down the Shift key while you use either the
Rectangular or the Elliptical Marquee tool results in a
perfect square or a perfect circle, depending on the tool, of
course.

Looking at the Lasso tools

The Lasso Selection tools have been in Photoshop for much
longer than the Quick Selection tools and in many ways have
been superseded by them. Before the Quick Selection tools,
the Magnetic Lasso was the best tool in the arsenal for
selecting irregular edges that blended into the background;
now ours is a bit dusty. However, the Lasso and the
Polygonal Lasso tools can still be very useful.

The options for the Lasso and the Polygonal Lasso tools are
identical. They are also very similar to the Marquee tool
options. The Magnetic Lasso tool has the most involved
option menu of all the selections tools, so we will cover these
additional options in the Magnetic Lasso tool section.
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You can find the Lasso tools in the drawer of the Toolbox, as
shown in Figure 9.6. Click and hold the triangle at the bottom
of the Lasso tool to choose between the tools, or press
Shift+L to toggle between the tools.

Figure 9.6

The Lasso and Polygonal tools Options bar is very basic.

When you select a tool from the Toolbox, the Options bar
enables you to change the way each tool functions through a
wide range of selections. The Options bar, located under the
Menu bar, changes as you select different tool sets. To show
or hide the Options bar, choose Windows ⇒ Options from the
main menu bar.

The Lasso and Polygonal tool options, shown in Figure 9.6,
are as follows:

• Tool presets. This option enables you to save and retrieve
your favorite tool settings using this drop-down list. Click the
little arrow to see a menu of available options.

• New Selection. This option enables you to create a new
selection every time you use the Lasso tool, while erasing the
old selection.
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• Add to Selection. This option enables Photoshop to add
every new selection you make to the current selection. This
makes it easy to do the detail work after you make the initial
selection.

• Subtract from Selection. This option enables you to
subtract areas from the current selection.

• Intersect with Selection. This option selects only those
areas that were in the first selection you made as well as the
second, and deselects anything that was selected only once.

• Feather. This option makes the specified pixels on both the
inside and outside edges of the selection gradually
transparent. This allows changes you make to the selection to
blend with the surrounding areas, whether you apply an
adjustment to the selection or create a mask with the
selection.

• Anti-alias. This option creates a smoother-edged selection.

• Refine Edge. This option enables you to perfect and finish
your work by refining the edge of a selection. We cover the
Refine Edge option later in this chapter.

Using the Lasso tool

The Lasso is a selection tool that is easy to understand. You
use it to create a selection by drawing a freehand border
around the area you want to select, as shown in Figure 9.7. It
can be useful for selecting areas that are easy to draw
freehand or selecting a general area to start from before using
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more precise selection tools, such as the Color Range dialog
box. You can also use it to touch up other selections.

Figure 9.7

The Lasso tool creates versatile selections by simply
following wherever you draw.
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Caution
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As you use the Lasso Selection tool, be sure to close your
selection by finishing relatively close to where you started.
Photoshop automatically draws a straight line between the
beginning point and the end point, and if that line intersects
other areas of the selection, you may end up with quite a
different selection than you were envisioning.

Working with the Polygonal Lasso tool

The Polygonal Lasso tool is very useful for selecting two
types of areas in your photo: those that are angular but not
rectangular, and those that are hard to select with the Quick
Selection tool because the colors and textures in the photo are
very similar. Even rectangular objects are usually skewed in
photographs, making the Polygonal Lasso tool a better choice
than the Rectangular Marquee tool for selecting them.

The pyramid pictured in Figure 9.8 has simple angles, but
they are not easy to select with the Rectangular Marquee. The
Quick Selection tool would be tricky to use, because of the
similarities in color and texture throughout the photo, making
the Polygonal Lasso tool the best choice.

Use the Polygonal Lasso tool to make a selection by
following these steps:

1. Choose the Polygonal Lasso tool by clicking and holding
the triangle on the Lasso tool icon in the Toolbox and
selecting the Polygonal Lasso tool.

You can access the current Lasso tool by pressing the L key.
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2. Click the corners of the object you want to select.

The Polygonal Lasso tool locks the selection to each corner
you click and selects a straight line between each one, as
shown in Figure 9.8.

Figure 9.8

Click each corner of your selection to anchor the Polygonal
Lasso tool.
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3. Close the selection by clicking the corner where you
started or by double-clicking to release the Polygonal
Lasso tool.

Photoshop creates your selection, as shown in Figure 9.9.

Figure 9.9

The Polygonal Lasso tool helps you make border selections
with a lot of straight lines.
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Using the Magnetic Lasso tool

The Magnetic Lasso tool is a precursor to the Quick Selection
tool, and it works similarly by looking for edges close to the
area where you are dragging the cursor and sticking to them.
This makes your selection more precise than a freehand
selection, but using the Magnetic Lasso tool is not as efficient
as using the Quick Selection tool.

In addition to the standard Lasso tool options, the Magnetic
Lasso tool has additional options, as shown in Figure 9.10:

Figure 9.10

The Magnetic Lasso tool has additional options that allow
you to customize it for the best selection.

• Width. This field specifies how many pixels from the
pointer the Magnetic Lasso tool searches for edges. This
offers a benefit over the Quick Selection tool because the
Quick Selection tool samples the entire document looking for
similarities in what you are selecting and can sometimes
select more than you were anticipating.

• Contrast. This field allows you to adjust the level of
contrast needed for the Magnetic Lasso tool to determine an
edge. If the area you are selecting blends into the background,
you want to set your contrast low.
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• Frequency. This field sets the frequency of the anchor
points that are used.

• Tablet Pressure. This option is used with a stylus tablet.
When you select this option, you can increase the width of
your pen by increasing the pressure on your tablet.

You can use the Magnetic Lasso tool by clicking and
dragging your beginning point as close as possible to the
border of the area you want to select. The Magnetic Lasso
tool looks within a certain radius (set by the Width option) for
edges or contrasting pixels, and places anchor points along
your selection. As you move your cursor, Photoshop sets
down anchor points to show where the edges of your selection
will appear, as shown in Figure 9.11.

As long as you are making your selection, you can change the
anchor points in one of two ways. If an anchor point isn't set
automatically in a place where you need one, click to add an
anchor point. If anchor points are set in areas where you don't
want them, you can use the Delete key to back up your anchor
line one point at a time.

Figure 9.11

You see a line of anchors following your selection with the
Magnetic Lasso tool.
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Caution

As you work with the anchors in the Magnetic Lasso tool,
remember that the tool is still carrying a selection line that
leaves a wake of anchors no matter where you take it. If you
are not careful, you'll create a selection mess reminiscent of
trying to work with hot glue.

Your selection is open and changeable until you close it by
either returning to the beginning and clicking the first anchor
point or double-clicking to release the selection. After you've
done that, the anchor points disappear and Photoshop creates
your selection.

Examining the Quick Selection tools
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The Quick Selection and Magic Wand tools work by using
the colors in your image to define a selection. The Magic
Wand tool allows you to pinpoint a color and select areas in
the document that are the same color. The Quick Selection
tool takes you one step further by using color as well as edges
in your photo to aid you in dragging a precise selection
around different kinds of elements in your image.

You can find the Quick Selection and Magic Wand tools in
the drawer of the Toolbox. Click and hold the triangle at the
bottom of the Quick Selection tool to choose between the
tools, or press Shift+W to toggle between them.

When you select a tool from the Toolbox, the Options bar
enables you to change the way each tool functions through a
wide range of selections. Located under the Menu bar, the
Options bar changes as you select different tool sets. To show
or hide the Options bar, choose Windows ⇒ Options from the
main menu bar.

Looking at the Quick Selection tool

The Quick Selection tool is the most advanced selection tool
in the Photoshop Toolbox. The Quick Selection tool works by
selecting adjacent areas that are similar in color and texture to
the area over which you are dragging. It works well for
almost anything, because you drag the selection roughly
around the edges of the area that you want to select. The tool
automatically finds the edges of your selection and creates a
more precise selection than you could make freehand. The
Quick Selection tool fine-tunes selections made by the other
selection tools as well.
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Before using the Quick Selection tool, familiarize yourself
with the following options and their functions in Figure 9.12
to get the most from this tool's capability:

• Tool presets. When you click the Tool presets drop-down
list, you can save and retrieve your favorite tool settings.
Click the little arrow to see a menu of available options.

• New Selection. When you choose this option, every time
you drag the selection brush, you create a new selection. As
you use the Quick Selection tool, it begins with the New
Selection option and automatically changes to the Add to
Selection option after your first selection.

• Add to Selection. When you choose this option, Photoshop
adds every new selection you make to the current selection.
This makes it easy to zoom in and do the detail work after
you make the initial selection.

• Subtract from Selection. When you choose this option, you
can subtract areas from the current selection.

• Brush picker. When you click this drop-down list, it
enables you to set the size and style of your selection brush.
When using the selection tools, size can make a difference in
your selection. For example, a larger brush has a larger
tolerance and is less likely to find the more detailed edges.

• Sample All Layers. When you choose this option, the
Quick Selection tool uses color and textures from all available
layers to determine the edges of your selection.
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• Auto-Enhance. When you choose this option, Photoshop
smoothes out the edges and reduces the blockiness of your
selection, automatically performing some of the refinements
that can be made using the Refine Edge dialog box.
Auto-Enhance is time-consuming and doesn't give you any
control, however, so it isn't usually the best option.

• Refine Edge. When you choose this option, a dialog box
opens that allows you several options for refining the edge of
your selection.

Figure 9.12

The Quick Selection tool is the best selection tool in many
instances.

Working with the Quick Selection tool

The Quick Selection tool enables you to select the
background of a photo and add a little blur to it, so that the
object in the foreground is the clear subject of the photo. In
the following example, the contrast between the subject and
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the background makes this an easy task with the Quick
Selection tool.

You can select an area in your photo by following these steps:

1. Click the Quick Selection tool in the Toolbox, or press
W.

2. Click the Brush picker and then select a size and brush
style from the Quick Selection options menu at the top of
the preview window, as shown in Figure 9.13.

The size and softness of the brush determine the detail of the
edge selection. For large, hard edges, use a large brush for a
faster selection. To fine-tune smaller areas, use a smaller
brush size.

Figure 9.13

The Brush picker option for the Quick Selection tool allows
you to modify the size and hardness of the Quick Selection
tool.
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Tip

Use the bracket keys, [ and ], to quickly reduce and expand
your brush size.

3. Drag a rough outline around the area you want to
select.

As we dragged around the boy in Figure 9.14, the selection
outline adhered to the edges of his body. You don't need to
make this selection continuously; you can add to and subtract
from it as you go.

On the Web
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You can try your hand at creating this selection by
downloading Figure 9.14 from the website.

4. Use the Add to Selection and Subtract from Selection
options to fine-tune your selection.

Zoom in on hard-to-define areas and reduce your brush size to
make the smaller selections. If you select too much, use the
Subtract from Selection tool to take the extra area out.

Figure 9.14

The Quick Selection tool uses color and texture to define a
selection.
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This is a simple example of how to create a selection with the
Quick Selection tool. From beginning to end, it took less than
five minutes to select the boy from the background of the
sample image. Later in this chapter, we will show you how
you can further refine any selection to achieve superior
results.

Looking at the Magic Wand tool
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Nested with the Quick Selection tool is the Magic Wand tool.
The Magic Wand tool enables you to create a selection by
targeting areas that are the same or a similar color. This tool
works best if the areas that you do not want to select are a
contrasting color.

Before using the Magic Wand tool, familiarize yourself with
the following options and their functions, shown in Figure
9.15, to get the most out of this tool:

Figure 9.15

The Magic Wand tool options allow you to customize how
the tool works.

• Tool presets. When you click the Tool presets drop-down
list, you can save and retrieve your favorite tool. Click the
little arrow to see a menu of available options.

• New Selection. When you choose this option, every time
you drag the selection brush, you create a new selection and
the old selection disappears.

• Add to Selection. When you choose this option, Photoshop
adds every new selection you make to the current selection.
This makes it easy to do the detail work after you make the
initial selection.
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• Subtract from Selection. When you choose this option, you
can subtract areas from the current selection.

• Intersect with Selection. When you choose this option,
Photoshop selects only those areas that were in the first
selection you made, as well as the second, and deselects
anything that was selected only once.

• Sample Size. When you choose this drop-down list, it
allows you to determine the size of the color sample taken by
the Magic Wand tool. For example, a point sample only uses
the color of the single pixel chosen by the Magic Wand tool.
If you choose 3 × 3 average, Photoshop averages the color of
a 3 × 3 pixel radius around the pixel that you choose.

• Tolerance. When you choose this field, it allows you to
specify a tolerance level. The tolerance level determines how
many shades of the color you choose are selected with the
Magic Wand tool. A higher tolerance selects more shades; a
lower tolerance selects fewer shades. The level you set
depends entirely on your photo.

• Anti-alias. When you choose this option, Photoshop creates
a smoother-edged selection.

• Contiguous. When you choose this option, only the
appropriate colors that are contiguous in the area where you
click the Magic Wand are selected. If this option is off, all the
colors in the selected layer within the specified tolerance
range are selected.
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• Sample All Layers. When you choose this option, the
Magic Wand tool uses the colors and textures from all
available layers to determine the edges of your selection.

• Refine Edge. When you choose this option, refining the
edge of a selection is the finish work that perfects your
selection. We cover the Refine Edge option later in this
chapter.

Working with the Magic Wand tool

The Magic Wand tool enables you to select adjacent pixels
within a color range in an image by selecting that specific
color range. In the following example, we want to select the
blue of the shirt and the eyes of the little girl to create a
stylistic photo where only those elements of the photo are in
color. (We know, none of it is in color, but work with us
here.)

Using the Magic Wand tool is as easy as following these
steps:

1. Choose the Magic Wand tool from the Toolbox, or press
Shift+W.

The Magic Wand tool is nested behind the Quick Selection
tool.

Tip
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When the Magic Wand tool is hidden behind the Quick
Selection tool, pressing W activates the Quick Selection
tool. Simply press Shift+W to toggle to the Magic Wand
tool. You can also change your preferences so that you don't
need to use the Shift key. Choose
Edit⇒Preferences⇒General
(Photoshop⇒Preferences⇒General on the Mac) and
deselect Use Shift Key for Tool Switch. After you've done
this, you can toggle through every tool using the single hot
key assigned to the tool without having to use the Shift key
at all.

2. Change the tolerance level.

Because we want to select different shades of bright blue in
the photo and the surrounding area contrasts highly, we use a
high tolerance of 80.

3. Click the color in your photo that you want to select.

The Magic Wand tool is different from every other selection
tool in that it doesn't require you to click and drag, just click a
color. If you want to select different shades, choose an area
that is midrange between the lightest and darkest shades you
want to select. Photoshop selects everything in your photo
that is the color you click and uses the tolerance setting to
determine the range of other colors that are selected. By
choosing a midrange pixel to sample and with a high
tolerance on a contrasting background, we got a nearly
complete selection in Figure 9.16.
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Note

As you hover over your image, the RGB and CYMK values
of the color the cursor is touching are displayed in the info
panel. This makes the Info panel very helpful in choosing
what areas of color to click on when using the Magic
Selection tool.

Figure 9.16

The Magic Wand tool easily selected most of the bright blue
shirt.
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On the Web

You can try your hand at creating this selection by
downloading Figure 9.16 from the website.

4. Use the Add to Selection or Subtract from Selection
options to add or subtract areas from your selection.

Choose the Add to Selection option and continue to click in
areas that still need to be selected. With just a few clicks, you
should be able to select the entire shirt. You can also click the
eyes or any other area of the photo that you want to select.
You can choose an entirely different color to add to the
selected area than the color you used for the first selection.

Refining Your Selection

After you have created your selection, you may need to add or
subtract areas to and from your selection that were not correct
the first time, or smooth out edges by taking out fringe colors.
Adding the final changes through adjusting selections and
refining edges will produce professional results.

Adjusting a selection

After you have made your initial selection, there are several
ways that you can add final changes to complete your
selection, such as using the selection tools, transforming a
selection, creating and adjusting a path, or using the Quick
Mask mode to paint areas in or out of your selection. These
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adjustments can help make your selection perfect so that your
changes blend smoothly.

Using the selection tools

All selection tools have the option to either add to or subtract
from the selection. It doesn't matter what tool you used to
create the original selection; you can use any other selection
tool to add to or subtract from that selection. This makes the
selection tools very versatile to work with.

For example, in Figure 9.17, the Magic Wand tool did a great
job of selecting an almost perfect outline of the rose. Of
course, a few spots here and there need to be added to or
subtracted from this selection. Adjusting the tolerance levels
or trying to add or subtract using the Magic Wand tool can be
an effort in frustration — remember that the Magic Wand tool
samples colors every time you use it, and so you could click
to add or subtract areas you don't want and end up with even
more areas that are wrong.

On the Web

You can try your hand at creating this selection by
downloading Figure 9.17 from the website.

Figure 9.17

With one click, the Magic Wand tool can create a nearly
perfect selection, but the best way to clean up the selection is
to use a different selection tool.
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The better option is to use the Quick Selection tool, or even
the Lasso tool, to clean up this selection. Just click the tool of
choice, make sure the Add to or Subtract from option is
selected, and you have more control to clean up your
selection.

Transforming a selection

You can also change a selection by transforming it. This
option is best when you have a selection that is almost the
right shape, but just needs a little nudge here and there so that
it fits.

For example, in Figure 9.18, we use an Elliptical Marquee to
select the iris of the eye, but because of the perspective of the
shot, the eye isn't an exact symmetrical ellipse. This is a good
time for a transformation.

595



To transform a selection, choose Select⇒Transform
Selection, and Photoshop bounds your selection with a
transformation box. Use the handles to nudge the edges of
your selection until it's where you want it to be.

Now that you have the transformation box activated, you can
use the Transform tools in the Edit menu to skew, warp, or
otherwise distort your selection in any way you want to.
Choose Edit⇒Transform, and choose from one of several
options on the Transform submenu.

Caution

Typically when you want to use the Transform option, you
can use the hot-key combination Ctrl+T/ +T to create a
transformation box; however, don't use the hot key here! If
you do, you will be transforming the area that has been
selected rather than the actual selection. Stick with the
Select menu for choosing this option.

Figure 9.18

The Transformation option can change the shape of your
selection.
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You can get a full run-down of the Transform
tools in the Edit menu in Chapter 19.

Using paths

The most frustrating thing to us about the Magnetic Lasso
tool is all those handles, or anchor points, that disappear the
minute you complete the selection. Wouldn't it be much more
convenient if they stuck around so you could go back and
adjust your selection? Fortunately, you can adjust your
selection using handles by turning it into a path.

After you've created a selection, turn it into a path and correct
it by following these steps:

1. Choose Window⇒Paths from the main menu bar.
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This opens the Paths panel, shown in Figure 9.19.

Figure 9.19

The Paths panel is empty until you make a path.

2. Click the Make work path from selection icon at the
bottom of the Paths panel, as shown in Figure 9.19.

This changes your selection into a path.

3. Select the Direct Selection tool from the Toolbox, as
shown in Figure 9.20.

Figure 9.20

The Direct Selection tool allows you to select one anchor
point at a time.
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4. Use the Direct Selection tool to click an area of the path
that needs adjusting.

Anchor points appear, and you can adjust the anchor points as
needed to correct your selection, as shown in Figure 9.21.

Figure 9.21

With the Direct Selection tool, you can drag anchor points
and change the path.

5. (Optional) If you need to add anchor points to your
path, select Add Anchor Point Tool from the Toolbox, as
shown in Figure 9.22, and click the path to add an anchor
point.

Figure 9.22
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To add anchor points to your path, you need the Add Anchor
Point tool.

6. After you complete your adjustments, click the Load
path as a selection icon in the bottom of the Paths panel
(refer to Figure 9.19) to turn your path back into a
selection.

To learn about paths and how and why you
should create them, see Chapter 17.

It was unfair to drop you into this exercise before explaining
paths a little better, but it's good to know at this point that
selections can become paths, and vice versa. You'll probably
use this option to create paths from selections more often than
using a path to create or adjust a selection because this
method of adjusting your selection is time-consuming, and in
most cases it isn't the most efficient option. It can be very
precise, however, and it's good to know that it is a possibility.

Using Quick Mask mode

We are big fans of the Quick Selection tool. Even if we don't
make an initial selection with it, we often use it to make any
needed adjustments afterwards. Sometimes even the Quick
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Selection tool fails us, however, and we need a more precise
method of adjusting our selection.

The Quick Mask feature allows you to apply freehand
adjustments to your selection by painting a mask over the
areas that you don't want selected and erasing the mask out of
areas that you do.

Tip

The Quick Mask feature is not only a good way to touch up
your selection; it's also a good idea to activate it even if you
think your selection is perfect. Many times, you'll see areas
of your selection that you missed with the marching ants but
are much easier to see with the color overlay.

The Quick Mask icon is found at the very bottom of the
Toolbox, as shown in Figure 9.23. It's not really a tool; it's
just a shortcut to enter Quick Mask mode. Click it or press Q
to turn on Quick Mask mode.

Figure 9.23

The Quick Mask icon is at the bottom of the Toolbox.
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When you've activated Quick Mask mode, your image looks
like Figure 9.24, with a red color overlay (called a rubylith)
covering the areas of your image that are unselected. This
indicates that those areas are protected from any changes you
make to the image, much like a stencil. Notice how easy it is
to see the sloppy selection around the arms and head.

Figure 9.24

It's not easy to tell with this grayscale image, but the Quick
Mask overlays the entire background of this image with a
rubylith.

You can make a few changes to the Quick Mask.
Double-click the Quick Mask icon to open the Quick Mask
Options dialog box, as shown in Figure 9.25. From here, you
can double-click the color field to open the Color Picker and
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choose an alternative color, change the opacity of the mask,
or invert the mask so it covers the selected area rather than the
rest of the image.

Figure 9.25

The Quick Mask Options dialog box allows you to change the
color and opacity of the mask or to invert it.

To add to the selected area, you need to erase the Quick
Mask; follow these steps:

1. Click the Eraser tool in the Toolbox, as shown in Figure
9.26.

Figure 9.26

The Eraser tool allows you to erase parts of the masked area.
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2. Set the brush size in the Options bar.

You want your eraser slightly smaller than the area you are
painting. (Press the bracket keys, [ and ], to quickly change
the size of your eraser or brush.)

3. Set Opacity to 100 percent in the Options bar.

You can feather the edges of your selection later.

4. Erase the Quick Mask from areas that you want to be
selected by dragging the Eraser tool over those areas, as
shown in Figure 9.27.

Figure 9.27

By erasing the Quick Mask, we are adding to the selected
area.
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Caution

When you are using the Brush and Eraser tools to change
your mask, it is important to first set your foreground and
background colors to black and white, respectively. If your
background color is anything but white, the Eraser tool does
not erase the mask entirely; instead, it reduces the opacity of
the mask based on the brightness of the background color.

For subtracting areas from the selection, you can use the
Brush tool to paint in the Quick Mask:
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1. Click the Brush tool in the Toolbox, as shown in Figure
9.28.

Figure 9.28

The Brush tool allows you to add to the masked area.

2. Set the brush size in the Options bar.

You want your brush slightly smaller than the area you are
painting.

3. Set Opacity to 100 percent in the Options bar.

4. Apply the Quick Mask to areas that you don't want
selected by dragging the Brush tool over those areas, as
shown in Figure 9.29.

Figure 9.29

By using the Brush tool to add to the Quick Mask, we are
subtracting from the selected area.
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Note

Of course, these two tools would be reversed if you were to
invert your mask; you would erase areas that you didn't
want selected and brush in areas that you did want selected.

Refining the edges

After you've made your selection as perfect as you can, it's
time to put the finishing touches on it by refining the edges.
The Refine Edge dialog box includes features such as the
Edge Detection tool, which ensures your selection is spot-on;
smoothing and feathering options that soften the edges; and
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output settings that allow you to create layers, masks, and a
new document with your selection.

You can access the Refine Edge dialog box, shown in Figure
9.30, by clicking Refine Edge in the Options bar.

Figure 9.30

The Refine Edge dialog box provides options for perfecting a
selection.
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Changing your View Mode
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By using View Mode, you can determine how your selection
is previewed, while working in the Refine Edge dialog box.
The View Mode section includes the following options:

• Zoom tool. This tool works just like the Zoom tool in the
Toolbox; you can use it to zoom into areas that you are
previewing or adjusting. Getting a closer look at the edges as
you make changes to them is never a bad idea.

• Hand tool. This tool works the same here as it does in the
Toolbox; you can use it to move your document around in the
document window so you can see the desired area.

• View. This drop-down menu, shown in Figure 9.31, gives
you different ways to view your selection. You can keep the
marching ants, use a color overlay, or use different ways of
alternating black, white, and transparency. How you decide to
view your selection is determined in part by your personal
preference, but it is mostly a matter of what works best with
your particular image. Take note of the hot keys that allow
you to change views quickly. Changing views as you work
and double-checking your edges helps you finish with a more
accurate result.

Figure 9.31

The Refine Edge dialog box gives you many different options
for viewing your selection.
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• Show Radius. This view option works with the Edge
Detection options to show your chosen radius. Figure 9.32
shows the On Black view with the radius highlighted.
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• Show Original. This view enables you to see the original
document without any selection indicated by checking the
Show Original option. This comes in handy when the
selection borders get in the way of determining where an edge
should be. Simply click Show Original, and you can take a
look without the hindrance of a selection border.

Using the Edge Detection options

The Edge Detection options can help to make those detailed
refinements that are nearly impossible any other way. Wispy
hair, for example, is notoriously hard to select. The Edge
Detection tools allow you to more easily make these types of
selections. They work by searching the edges of a selection in
a specified radius for edges that are more defined and
probably (but not always) more accurate for your selection.

Figure 9.32

A view of the radius set around the edges of our selection. To
make it more visible, we set the radius extremely high at 50.

612



The options for edge detection are as follows:

• Smart Radius. This option automatically sets a radius for
edge detection based on the tonal irregularities around the
edges of the original selection. You can use this option for a
quick, automatic edge-detection solution.

• Radius. This slider allows you to set your own radius for
edge detection. If your selection is accurate to begin with, you
want to use a low setting. Photoshop searches within the
radius you set for a better edge for your selection. If it finds a
better edge, it moves the edge of the selection. You can
preview the area that is being searched by activating the Show
Radius option in the View Mode section (refer to Figure
9.30). Be sure to zoom in on your edges as you make changes
so you can be sure they are accurate.
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• Refine Radius tool. This tool allows you to fine-tune your
selection even further. After you have set your radius to a
good overall setting for your selection, you might discover
spots where the radius is too big or too small to find the
correct edge. You can fix these individual areas one at a time
by using the Refine Radius tool. The Refine Radius tool
works like a paintbrush to brush in a larger radius or erase
areas of a radius. Click the little black triangle in the
lower-right corner of the icon to display both tools, as shown
in Figure 9.33, and choose the tool you need. Display the
radius by clicking the Show Radius option, and use the Refine
Radius tool to make your desired changes.

Figure 9.33

You can manually add to or subtract from the set radius by
using the Refine Radius tool.
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You can give the Edge Detection options a try by following
these steps:
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On the Web

Try using the Edge Detection options on this example by
downloading Figure 9.34 from the website.

1. Open a file that has edges that are difficult or nearly
impossible to select.

This example involves a subject with delicate curls.

2. Using any combination of selection tools, create the best
selection you can.

Don't worry about being too precise in the areas on which you
plan to use the Edge Detection feature. Aim for the best
selection that you can, as shown in Figure 9.34.

3. Click the Refine Selection button in the Options bar.

This button is available, regardless of which selection tool
you have chosen. Click it to open the Refine Edge dialog box
(refer to Figure 9.30).

4. Click the Refine Radius tool.

Because you are selecting a diverse area when detecting hair,
the Refine Radius tool is usually the best option.

Figure 9.34

Making selections around hair is a difficult process; however,
you can leave the areas around the hair loosely selected.

616



5. Brush the areas where you want the edge detection to
occur.

617



The Edge Detection tool looks for contrast in these areas and
tries to determine the best edge for your selection. You will
notice that there are semi-transparent areas. These areas are
feathered edges and will help your selection blend when you
make changes to it.

6. Click Show Radius in the View Mode section of the
Refine Edge dialog box.

This allows you to see the areas that are affected.

7. Click the black triangle next to the Refine Radius Tool
button and choose Erase Refinements Tool.

Use the Erase Refinements tool to erase areas you have
selected.

8. Repeat Steps 5 to 7 as needed.

Every time you make a pass with the Refine Radius tool, the
edges are recalculated, so keep trying if you don't get the
result you want the first time.

9. When you have the best result possible, exit the Refine
Edge dialog box.

You can see the result we got in Figure 9.35. You can output
your selection in different ways. If you didn't get the exact
result for which you were looking, click OK to exit the dialog
box and make your own changes to the selection.

Figure 9.35
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In the photo showing the result, the hair is selected more
precisely by using the Edge Detection tool.
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Adjusting edges

The Adjust Edge section of the Refine Edge dialog box gives
you control over the hardness, smoothness, and placement of
your selection edge and includes these settings:

• Smooth. Increasing the smoothness of your selection
reduces jagged edges and softens corners. If your selection is
mostly rounded edges, increasing the smoothness probably
improves it by reducing areas of pixelation. If your selection
has sharp corners, however, increasing the smoothness rounds
and softens the corners, so go easy and keep an eye on your
corners.

• Feather. Feathering the edges of your selection makes them
gradually transparent, so that the selection blends better with
whatever changes you make to it. It's better to feather your
edges here, in the Refine Edge dialog box, than by using the
Feather option found in many of the selection tools. Here you
can preview the feathered edges in real time if you have any
of the overlay views selected.

• Contrast. Increasing the contrast sharpens the edges of your
selection and reduces the noise around the selection.

• Shift Edge. Moving this slider to the left expands your
selection, and moving it to the right contracts your selection.
The Shift Edge slider works with the radius that you specified
in the Edge Detection settings to determine how far to move
the selection. For example, if you shift your edge by 30
percent, you are shifting it by 30 percent of the radius setting,
which means that if your radius is set at 10 pixels, you are
shifting the selection by 3 pixels. The Shift Edge option has
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replaced the Contract/Expand option found in earlier versions
of Photoshop.

Choosing Output settings

The Output settings determine the outcome of your selection.
Here are the options you have:

• Decontaminate Colors. This option offers you a powerful
tool to reduce or even eliminate halos or color fringes around
your selection. When you cut a selection out of one image to
place into another image or document, the selection often
displays a halo or color fringe that is either a reflection of the
color around the selection or simply a bleeding of that color.
Select the Decontaminate Colors check box, and Photoshop
samples the edges of your selection for color values that are
different from the actual selection and reduces those colors.
When you select this option, your output choices become
limited.

• Amount. This slider allows you to adjust how much color is
reduced by the Decontaminate Colors option.

• Output To. The Refine Edge dialog box allows you to
output your selection in different formats as you exit, saving
you several steps in the process. These are the options for
saving your selection:

• Selection. This option returns you to the marching ants and
lets you decide on your own changes from there.
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• Layer Mask. This option creates a layer mask over the layer
you are currently working with. Your deselected areas
become transparent.

• New Layer. This option pastes your selection into its own
layer and turns off the visibility of the original layer, so the
unselected areas of your image still appear transparent, but
your entire image remains available in the original layer.

• New Layer with Layer Mask. This option creates a new
layer containing the entire image with a layer mask placed
over the deselected areas, and turns off the visibility of the
original layer, as shown in Figure 9.36. This has the same
visual effect on the image as the previous two options.

Figure 9.36

The Layers panel showing a new layer with a layer mask
created from a selection
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• New Document. This option creates a new document and
places the selection in it, leaving the original document
unaltered.

• New Document with Layer Mask. This option creates a
new document with the entire image from the original
document, but places a layer mask over it so only the selected
areas are visible.

Masks are an extension of selections and are
really the same concept taken one step further. To understand
masks, however, it is important that you understand layers.
We cover layers in Chapter 10.

Caution

Photoshop applies your edge refinement when you close the
Refine Edge dialog box. If you decide later to change the
settings, you need to undo the previous edge refinement, or
you will just be adding the new settings to the first edge
refinement.

Using the Color Range Selector

The Color Range selector is not a tool in the Toolbox, but
rather a dialog box that you can launch from the Select menu.
It works similarly to the Magic Wand tool, because it makes
selections primarily based on color. However, it gives you a
little more control over what is selected by allowing you to
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customize the settings and preview the results before making
the selection.

A unique feature of the Color Range dialog box is that it
works within a selection as well as the entire image, so you
can make a general selection around the area that you would
like to ultimately select color from, and only that area is used
in the dialog box, as shown in Figure 9.37. After you make
your selection and click OK in the Color Range dialog box,
the original general selection disappears and the selection
made by the Color Range dialog box takes its place.

When using the Color Range dialog box, don't forget to use
the features shown on the Options bar in Figure 9.37. You can
select the sample size, choosing to take the exact color of the
pixel sampled or averaging several surrounding pixels
together. There are also a variety of options for choosing
which layers you would like to sample from.

Figure 9.37

The Color Range dialog box is versatile when it comes to
selecting color or tonal ranges.
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On the Web

Use the Color Range dialog box to select the pink shirt in
this photo by downloading Figure 9.37 from the website.

The Color Range dialog box has the following options:

• Select. This drop-down list gives you the option to use a
sample from the image as a basis for your selection, or you
can choose to use a specific color, tonal ranges, or
out-of-gamut colors.

• Localized Color Clusters. This option is useful if you are
choosing more than one color and you want to restrict the
selection to the same general area.
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• Fuzziness. This slider works much like the tolerance levels
of the Magic Wand tool. The higher the fuzziness, the more
varied the colors in your selection are. The best thing about
this feature is that you can preview the selected areas as you
move the slider, allowing you to set a precise fuzziness level
before creating your selection.

• Range. This slider works with the Fuzziness slider to
determine how large an area in your image Photoshop selects
from. Again, having the preview is priceless.

• Selection/Image. These options allow you to preview either
the selection or the image. The Selection preview is shown as
a mask where the selected areas are anything in the upper half
of the brightness scale. In Figure 9.37, the shirt is the only
item in the image that is selected when the Color Range
dialog box is closed. The Image preview appears just as you
see it in your document window, with no indication of what
has been selected. This option is handy if you are using the
Selection Preview option described next.

• Selection Preview. This drop-down list changes the image
in your document window to reflect the areas that are
selected. You can choose to display it in several ways:
grayscale (which mimics the selection window), black matte,
white matte, and quick mask. The option that works best
depends on the colors in your image and the colors you are
selecting.

• Load. This option allows you to load saved Color Range
settings.
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• Save. This option allows you to save your Color Range
settings for later use.

• Eyedropper. This tool is used to select a color: you place
the tip over the color that you want to select and click the
mouse. Every time you do, Photoshop makes a new selection.

• Add to Sample. This tool allows you to select additional
areas after creating an initial selection. It adds to your
selection rather than replacing it.

• Subtract from Sample. This tool subtracts areas from your
selection.

• Invert. This option is used to create a selection around
everything in your image except for the colors that you
choose.

• Use Faces. This option becomes available when you select
the Localized Color Clusters option. It allows Photoshop to
detect and select skin tones more precisely.

Note

You can use the Refine Edge dialog box on any selection,
even one made by the Color Range dialog box. Click
Select⇒Refine Edges to open the Refine Edge dialog box.

Summary
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Selections highlight areas of an image that can be modified
while leaving the rest of the image untouched. In this chapter,
you learned that selections come in many different shapes and
sizes, and many selection tools make creating those selections
a fun and simple process. After you make a selection, many
other tools allow you to change and refine those selections so
they can be perfect.

After reading this chapter, you should be able to do the
following:

• Understand the selection menu and use it to optimize your
use of the selection tools

• Use the Quick Selection tool to make fast selections based
on the edges of your image

• Use both the Magic Wand tool and the Color Range dialog
box to make selections based on color

• Use selection marquees to make selections based on shape

• Create different Lasso selections

• Use the Options bar to optimize your selection

• Add to or subtract from a selection

• Refine the edges of your selection based on different
parameters
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Chapter 10: Learning All About Layers

In This Chapter

Presenting layers

Looking at the Layer menus

Exploring the Layers panel

Using non-destructive fill and adjustment layers

Adding layer effects

Working with Smart Objects

Protecting areas with a layer mask

Saving multiple layouts using layer comps

Finalizing your graphics by merging layers

When you open an image in Photoshop for the first time, that
image is one layer, just as if you'd laid a photo out on a table.
When you add elements to that image such as text or another
image, you can think of it as putting a transparency
containing those items over the original image. Rather than
destroying the integrity of the image, you are simply adding
layers to it to change the way it looks. That's exactly how the
Layers panel works. You can keep stacking up the layers to
change the way your image looks. Those layers don't have to
contain objects; they can be composed of a filter or style.
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Meanwhile, your original image is still available to you in its
unaltered state.

That's the basic idea, anyway. Of course, because this is the
digital world of Photoshop, a great idea has become so much
better over time. Everything from changing the settings of
filters that were added months ago to animating is all part of
the Layers panel in Photoshop CC, and having a good, solid
understanding of how it all works is essential to your
Photoshop success.

A basic understanding of the Layers panel, including the
icons and menu options, is a good place to start. Then we
show you the different kinds of layers you can add. We end
the chapter by showing you everything you need to know
about layer masks. After you've been introduced to the Layers
panel, you'll be ready to get into the substance of what
Photoshop is all about: image correction and special effects,
where the Layers panel is used constantly.

Introducing Layers

You'll soon discover that layers are your best friends when
working in Photoshop. They provide you with an easy and
versatile way to make changes to a project, because each
element of your project is self-contained and editable. This
means that as long as you keep layers in your document, your
text can always be moved and changed, your adjustments can
be reset, duplicated, or moved, and if you use the Layers
panel correctly, even changes such as cloning and healing are
easy to edit and change.
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Although we are going to show you the ins and outs of the
Layers panel and how to add special effects and adjustment
layers later in this chapter, we want to start by diving right in
and showing you what your document looks like with
multiple layers and how to work with those layers. This will
provide you with a basic understanding of how layers look
and how they work so that you can move forward with
confidence.

Understanding multiple layers

Figure 10.1 shows a type layer on top of an image layer. This
is about as basic as two layers get. As you can see in the
photo, the type layer is opaque so you can't see the image
through it.

Figure 10.1

Two different layers in the Layers panel
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Look at the Layers panel. Each layer is represented by a
thumbnail and a row in the Layers panel. The layer at the
bottom of the list — the image, in this case — is the layer that
is on the bottom of the stack of “transparencies.” All the
layers placed above it cover it in some way, and the hierarchy
goes from there.

The image in Figure 10.1 is a background layer. When you
open a new image in Photoshop, it automatically becomes the
background layer. A background layer is locked, so you can't
make changes to the layer such as transforming it or adding
effects to it, and you can't move it; it is always the bottom
layer. You can make the background layer into a regular layer
by double-clicking it and giving it a name. You can also
create a background layer from a regular layer by choosing
Layer⇒New⇒Background from Layer in the main menu bar.
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There can never be more than one background layer in a
document.

Tip

Although you can find options for working with layers in
both the Layer menu and the Layers panel menu, we like to
take a shortcut by right-clicking individual layers. A popup
menu appears with more specific options for the particular
layer. For example, a type layer pops up a menu that
includes all the type options and none of the Smart Object
options.

The text is a type layer, as indicated by the T in the layer
thumbnail. In order to make changes to the layer, you must
select it by clicking the thumbnail and highlighting it in the
Layers panel. Then you can use the tools or Layer menu
options to make changes.

Note

Probably the most frustrating aspect of layers for the new
user, and even admittedly for those of us who have been
around the block a time or two, is that you can't make any
changes to a layer unless you have selected it in the Layers
panel. We've done it many times — tried to move or make
changes to a layer and nothing happens or the wrong layer is
affected. Keep this rule in the back of your mind, and it soon
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becomes a habit to check the Layers panel to make sure you
have selected the correct layer before trying any changes.

After you've turned your background layer into a standard
layer, you can swap it with other layers by dragging and
dropping them above or below one another, as shown in
Figure 10.2. Of course, in this example, because the text layer
is on the bottom, it is no longer visible in the image.

Figure 10.2

You can move layers around by dragging and dropping them
in the Layers panel.
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Speaking of visibility, the “eye” icons next to the layers
indicate that they are visible. Click the eye next to either
layer, and the visibility is turned off as if the layer never
existed. You can't see it or change it until you turn the
visibility back on.

Adding new layers

You can create layers in many different ways: for example,
by adding additional images to your document, turning
selections into layers, and adding text or shapes to your
document. As you add each new layer, it is placed above your
currently selected layer. You can, of course, move it from
there.
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We show you how to add layers that modify your image, such
as adjustment layers or layer styles, later in this chapter.
Smart Objects are another type of layer that require their own
section. In this section, we show you the basics of adding new
elements to your document as separate layers. These new
elements can be another image, text or shape layers, or a
selection.

Adding another document as a new layer

If you are combining two or more documents into one image
either by merging them or by creating a photo collage, adding
additional documents as new layers to your original document
couldn't be easier. Here are four ways of doing so:

• Use the Place command. Choose File⇒Place to open the
Place dialog box with the original document open. Browse to
locate the file that you want to add as an additional layer, and
open it. The file appears in your original document as a new
layer. You have the option of resizing or rotating it before
accepting the placement.

• Use Mini Bridge. Use the Mini Bridge panel to find the
image that you want to bring in as a new layer and drag it
from Mini Bridge into your document. The new image is
placed as a new layer into your original document, and you
have the option of resizing or rotating it before accepting the
placement. You can place images in the same way using the
full Bridge application as well.

• Copy and paste. Copy and paste your documents into one
another as additional layers. Open the document with which
you want to make a second layer. Press Ctrl+A/ +A to select
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all. Press Ctrl+C/ +C to copy your selection. Open the
document into which you want to paste the selection. Press
Ctrl+V/ +V to paste the previous document into the new
one. This method has a drawback from the previous two
placement methods because your new layer is imported into
your document at its original size. In order to resize it, you
need to choose Edit⇒Free Transform.

• Move layers between documents. Choose
Window⇒Arrange⇒Float in Window to float your selected
document in a separate window. Click the image layer of the
document you want to move, and drag it to the original
document, as shown in Figure 10.3. The layer is copied from
the first document into the second one. This option is
especially beneficial if you want to move more than one
layer, because you can move all the selected layers at the
same time. These layers are placed at their original size.

Figure 10.3

You can drag and drop a layer, or even multiple layers,
between documents.
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Adding text or shapes as a new layer
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Adding text or shapes as layers in your document is a
no-brainer, because when you use the Text or Shape tools, a
new layer is automatically created with these elements on it.
Photoshop identifies this layer as either a text or a shape
layer, giving it a unique look, as well as its own menu
options. We cover text and shapes in Chapters 17 and 18.

Note

You can add a new shape to an existing shape layer, in
which case a new layer is not created. In the Options bar,
click Path Operations and choose any option except New
Layer to add a shape to a highlighted shape layer in the
Layers panel.

Creating selections to make a new layer

You can make selections in the document you are working
on, or in other documents to be copied and pasted into the
original. In Chapter 9, we show you how to export selections
as new layers using the Refine Edge dialog box. If you have a
layer containing a selection in one document that you want to
place into another document, you can move just that layer
into your destination document by dragging and dropping it.
You can also use the Copy and Paste commands to copy a
selection and paste it as a new layer into the same document
or a different one. You don't need a special Paste command;
using the Paste command automatically creates a new layer.

Using the Layer Menus

639



When it comes to layers, two menus do all the work: the
Layer menu, located in the menu bar at the top of the screen,
and a compact version in the Layers panel menu, located in
the top-right corner of the Layers panel. These menus have
some identical options, but some options are found in one
menu and not the other.

As with any panel, tool, or dialog box in Photoshop, knowing
the menu options that are available while working with layers
is what gives you the power and versatility to make the
Photoshop creations you've envisioned. We've listed the
menus here as a reference; they'll be much easier for you to
understand after you've read this chapter and worked with
layers, but be sure to come back to this list, because we
guarantee you'll find options you forgot about.

We start with the Layer menu, because it has the most
options, and then move on to the options that are found only
on the Layers panel menu.

Getting to know the Layer menu

The Layer menu has many options that help you use the
layers in your Layers panel to their full capacity, as shown in
Figure 10.4. Some of these options are available for all layers
and some of them are only available for certain types of
layers such as vector layers or Smart Layers.

The Layer menu has the following options for working with
layers:

• New. Enables you to create a variety of new layers by using
the following options:
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• Layer. Creates a new blank layer in the Layers panel.

• Background from Layer. Turns the current layer into a
locked background layer and places it at the bottom of the
layer stack. This option is not available if there is an existing
background layer.

• Layer from Background. Turns the current Background
layer in to a regular layer, opening a dialog box so that you
can rename it and set preferences for it. This option is not
available if there isn't an existing background layer.

• Group. Creates a group in the Layers panel. We cover layer
groups later in this chapter.

• Group from Layers. Creates a group in the Layers panel
and adds all selected layers to that group.

• Layer via Copy. Creates a new layer containing a copy of
any selection made within the layer. If nothing is selected, the
entire selected layer is copied.

• Layer via Cut. Creates a new layer by cutting out any
selection made within the layer and placing it on a new layer.

Figure 10.4

The Layer menu gives you many options for working with
layers.
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• Copy CSS. Allows you to copy CSS properties from a text
or shape layer that can be used to style elements in web
pages. We discuss this feature in more detail in Chapter 30.

• Duplicate Layer. Creates an exact copy of the layer that
you have selected.

• Delete. Enables you to delete layers by using the following
options:

• Layer. Deletes the currently selected layer.

• Hidden Layers. Deletes any layers that have the visibility
icon turned off.

• Rename Layer. Highlights the name of the selected layer so
that you can change it.

• Layer Style. Adds a new layer style to the currently selected
layer. Layer styles include several different effects such as
drop shadows and inner glows. We cover them later in this
chapter; we also discuss several of the Photoshop effects
throughout this book.

• Smart Filter. Allows you to make changes to any Smart
Filters attached to the selected layer. We cover Smart Filters
later in this chapter and throughout the book.

• New Fill Layer. Adds a new layer to the Layers panel that
contains a fill. This fill can be a color, gradient, or pattern.

• New Adjustment Layer. Adds an adjustment layer. This is
an image enhancement that Photoshop places as a
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non-destructive layer over your image. These adjustments
range from levels to hue and saturation adjustments. We
cover fill and adjustment layers in more depth later in this
chapter.

• Layer Content Options. Opens the settings of a selected
Smart Filter, fill layer, or adjustment layer so you can change
them.

• Layer Mask. Creates a new pixel mask on the selected
layer.

• Vector Mask. Creates a new vector mask on the selected
layer.

• Create Clipping Mask. Creates a clipping mask using the
layer below the selected one. We cover masks in greater detail
later in this chapter.

• Smart Objects. Provides options for creating and using
Smart Objects. These enable you to perform non-destructive
edits to layers in several ways. We discuss Smart Objects in
detail later in this chapter.

• Video Layers. Provides options for working with video
layers. We cover video layers when we discuss working with
video in Chapter 26.

• Rasterize. Creates a raster image from the vector objects
listed in the Rasterize submenu. As we discuss in Chapter 3, a
vector object is based on a set of values that describe lines,
while a raster image is made up of pixels.
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• New Layer Based Slices. Creates a slice that conforms to
the proportions of the selected layer. You use slices when
creating files for the web. We cover slices in Chapter 30.

• Group Layers. Groups the selected layers.

• Ungroup Layers. Ungroups the selected layers.

• Hide Layers. Turns off the visibility of selected layers.

• Arrange. Changes the position of the selected layer or
layers in the Layers panel relative to the option chosen. For
example, you can bring a selected layer to the front, which
places it at the top of the Layers panel.

• Combine Shapes. Allows you to combine two or more
shape layers in several different ways, including by
combining them, subtracting the overlap, subtracting anything
that doesn't overlap, and cutting one shape out of the other.

• Align. Aligns the objects on the selected layers based on the
parameters found in the Align submenu. For example, you
can center all the selected layers with each other so that they
are symmetrical. We might use this option to center text
inside an image or border.

• Distribute. Moves each of the selected layers the exact
same distance from one another based on the parameters in
the Distribute submenu. To use this option, you must select at
least three layers and none of the layers can be locked.

• Lock Layers. Locks all the layers in the group with the
selected layer.
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• Link Layers. Links two or more selected layers. When
layers are linked, moving, resizing, or otherwise transforming
one layer also affects any linked layers, just as if you had all
the linked layers selected in the Layers panel.

• Select Linked Layers. Selects all the layers that are linked.

• Merge Down. Merges the selected layer or layers with the
layer directly beneath them.

• Merge Visible. Merges all layers with the visibility icon
turned on. (This option also appears as Merge Layers if you
have selected more than one layer.)

• Flatten Image. Merges all the layers into a single
background layer.

• Matting. Enables you to remove halos by using the
following options:

• Color Decontaminate. Reduces a color fringe or halo
around the edges of a selection by reducing the saturation of
any color on the edges that isn't found in other areas of the
selection.

• Defringe. Removes halos from selections by replacing
aberrant color with pixels farther into the selection.

• Remove Black or White Matte. Removes halos around
images whose edges have been anti-aliased and that have
been cut out of a black or white background. The anti-aliasing
caused the edges of these images to blend with the
background, creating a halo.
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Getting to know the Layers panel menu

The Layers panel menu, shown in Figure 10.5, displays the
options that are used most often on the Layer menu. A few of
the options do basically the same thing as options found in the
Layer menu but go under a different name. Some of the
options have to do strictly with the Layers panel, so they are
found only in the Layers panel menu.

Figure 10.5

The Layers panel menu has several options that apply only to
the Layers panel.
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The following additional options are found in the Layers
panel menu:

• Convert to Smart Object. This option converts the selected
layer into a Smart Object for use with Smart Filters. This
option is found in the Layer menu under the Smart Objects
option. We discuss this feature later in this chapter, as well as
in areas of the book where we discuss filters.

• Edit Contents. This option allows you to make changes to
the contents of a Smart Object, which are kept in a different
file to protect them from changes.

• Blending Options. This option opens the Layer Style menu
where you can create a blending option for the selected layer.
This is not as easy or straightforward as simply using the
Blending options menu found on the Layers panel. We cover
blending options later in this chapter.

• Animation Options. These additional options for the
Layers panel deal with animation. These options can be
shown automatically when you are creating an animation, or
they can be turned on or off. We discuss animation options in
Chapter 26.

• Panel Options. This option opens the Layers Panel Options
dialog box shown in Figure 10.6, which allows you to change
how your Layers panel appears and how layers are shown.

Figure 10.6

Use the Layers Panel Options dialog box to change the way
the Layers panel looks and displays layers and effects.
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• Close. This option closes the Layers panel.

• Close Tab Group. This option reduces the entire tab group
containing the Layers panel to an icon.

Looking at the Layers Panel
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The Layers panel is arguably the most used panel in
Photoshop. It is so popular that it appears in every panel
preset. Whether you are using Photoshop to enhance your
photographs or working with 3-D objects, the Layers panel is
a vital part of your workflow.

The panel is found in the lower-right corner of the Photoshop
workspace, but as we mention in Chapter 2, you can move it
to any position you like. It works out well at the bottom,
though, because the Layers panel tends to grow. You'll see
what we mean very soon.

A quick look at the Layers panel, shown in Figure 10.7,
shows several icons, settings, and drop-down lists. We cover
these elements throughout this chapter.

Figure 10.7

The Layers panel is the most used panel in Photoshop.
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Filtering layers

The top area of the Layers panel allows you to filter your
layers based on layer type. When you have a document that is
heavy on layers, as shown in Figure 10.8, it is useful to be
able to sort those layers in several ways so that only the layers
that you specify are visible in the Layers panel. Figure 10.9
shows the filtering menu as well as the icons that you can use
to filter your layers.

Filter your layers by clicking the layer-filtering drop-down
arrow and choosing a filter. Each filter has several options
that appear in icon form, as a menu, or as a text box.

You have the following options for filtering your layers:
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• Kind. Allows you to filter your layers by what type of layer
they are. The icons shown in Figure 10.9 appear in the Layers
panel when you select the Kind option. You can choose from
the following kinds of layers by clicking the appropriate icon:

• Pixel. Pixel layers are generally image layers, or
photographs composed of pixels.

• Adjustment. Adjustment layers are layers placed over other
layers to apply a lighting or color adjustment over them.

• Type. A Type layer is a layer containing text.

• Shape. A Shape layer is any vector layer that is not
considered text, such as created shapes or clipart.

• Smart Objects. A Smart Object layer is really a pointer to
another document that can be composed of an image, vector
art, or even 3D art. The Smart Layer document can be
composed of several layers.

• Name. Allows you to filter your layers by typing a name in
the given field. This is one of many great reasons to give your
layers descriptive names.

• Effect. Enables you to filter your layers by the effect that
you've applied to them. When you select this option, a menu
appears, allowing you to choose from the effects available in
Photoshop.

• Mode. Allows you to filter by the blending modes used on
your layers. Use the menu that appears to choose a blending
mode.
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• Attribute. Enables you to choose from several different
options, such as whether you want locked layers, visible
layers, or layers to which effects have been applied.

• Color. Allows you to assign a color to any layer when it is
created or by right-clicking it and selecting a color from the
popup menu. When you choose the color filter, you can filter
your layers by the colors you have assigned to them.

• Selected. Shows only the selected layers in the Layers
panel.

Figure 10.8

It is useful to filter layers when you are working with a
document that contains a lot of layers.
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Figure 10.9

There are several ways to filter your layers.

To toggle quickly between filtered layers and a view of all
layers, click the Turn layer filtering on/off icon located to the
right of the filter options in the Layers panel.

New Feature

Isolation mode layer filtering is a new feature of CS7 that
allows you to select individual layers that you want to be
visible in the Layers panel. You can do this in several ways.
The easiest way is to select the desired layers and choose
Selected from the Filter menu in the Layers panel. You can
also use the menu option Select⇒Isolate Layers. If you are
working with a vector tool, you can right-click and choose
Isolate from the menu. You can also use the Path selection
tool or the Direct selection tool to double-click an active
path and isolate the selected layer. We cover the last two
options in more detail in Chapter 17.
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Changing the Opacity and Fill settings

The Opacity and Fill settings both allow you to change the
opacity of a selected layer, but in different ways. The Opacity
setting is just that, a representation of the opacity of the
selected layer. The higher the percentage that is displayed, the
more opaque the selected layer is. As the percentage goes
down, the layer becomes more transparent.

The Fill setting also adjusts opacity, but only the opacity of
the fill. A normal image layer disappears just as easily with a
Fill adjustment as an Opacity adjustment, but a shape or text
layer reacts very differently. Adjusting the fill opacity on a
shape layer reduces just the fill, while the outline (or stroke)
remains, along with any styles that you have applied. You can
also add a Layer style to any type of layer and reduce the fill
opacity to reduce the visibility of the layer, leaving only the
Layer style visible. This is a handy way of creating shadows,
glows, and other effects without the original layer showing.

You can adjust both the Opacity and the Fill settings in three
ways:

• Type a new percentage. Highlight the existing percentage
and type a new percentage. If you know exactly what
percentage to use, this is probably the fastest method.

• Use the drop-down slider. Click the down arrow to display
the drop-down slider and use it to adjust the setting.

• Use the scrubber. Click and drag over the setting name
(Opacity or Fill), and a two-sided arrow appears. Drag left to
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decrease the setting and right to increase it. The scrubber is by
far the easiest method.

Changing the lock settings

The Layers panel has four different lock settings, as shown in
Figure 10.10. Locking different aspects of your layers means
that you can't change those aspects. Each lock works on a
different aspect of your layer, giving you a wide range of
versatility. Select the layer you want to lock, and then decide
which lock you want to use.

Figure 10.10

The Layers panel has different types of lock settings that
allow you to protect your layers.

Here are the four different options for locking your layers:
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• Lock Transparent Pixels. This option locks all the
transparent pixels in your image with a single click. You can
add fills, make color corrections, or add styles or filters to the
rest of the image, but the transparent pixels remain pristine.

• Lock Image Pixels. This option protects the image pixels
from the paint tools.

• Lock Position. This option locks the position of the objects
in the layer, so that you can't move them. You can still change
other things about the layer, adjusting the color or adding a
filter, for example. A background layer is automatically
position locked.

• Lock All. This option keeps your layer visible, but protects
it from any accidental changes.

Blending modes

Blending modes create amazing special effects by changing
the way layers affect each other. At the beginning of this
chapter, we asked you to imagine that layers were like
transparencies stacked on top of one another. Using blending
modes is an example of how digital technology has taken this
idea one step further. Imagine that your transparencies are
made of gel rather than plastic, and that rather than sitting on
top of one another, they can blend with each other. Then
imagine that you can determine which areas of the images on
your transparencies blend, and how. Last but not least,
imagine that you finish blending them, and you hate the
result, but you find that you can pull them apart and start all
over with your original images.
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Blending modes do more than blend two images together.
You can use them on any layer that is added to your Layers
panel. You can use them to change the way a layer style is
applied, to blend a pattern into an image, or even to change an
adjustment layer into a special effect.

The menu at the top of the Layers panel shown in Figure
10.11 displays the different blending modes you can use to
choose how the selected layer affects the layers under it. The
blending modes are easier to show than explain. To
differentiate between them, the following explanations are
pretty technical, so we strongly advise that you use a
Photoshop document with two different layers to try them out
as you read about them, giving you a more hands-on tutorial.
When we refer to the layer value, we are speaking of the layer
that is selected when you apply the blend mode. The base
value is the layer that is under the selected layer, or the layer
that is blending with the selected layer. The blending modes
are divided into six general categories, as we explain in the
following sections.

Choosing Normal and Dissolve blending modes

The Normal blending mode is the default setting in the Layers
panel, and when you use it, layers act as you would expect.
When you set the opacity of a layer to 100 percent, any pixels
in that layer completely cover the layers below. As you
reduce the opacity of a Normal layer, it becomes universally
more transparent. If you choose the Dissolve blending mode,
it looks the same at 100-percent opacity as the Normal mode,
but as you reduce the opacity, the selected layer disintegrates
or dissolves, losing pixels rather than opacity.
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The Normal/Dissolve blending modes are as follows:

• Normal. This is the default option. The blend is applied
uniformly by painting each pixel based on the layer value and
opacity setting to create the resulting pixel.

• Dissolve. This blend is applied by randomly replacing the
pixels with either the base value or the layer value, depending
on the pixel location and the opacity setting. Using this option
allows you to dissipate the effect of the layer more than just
changing the opacity.

Figure 10.11

The Blending modes menu allows you to blend your layers
together.
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Using darkening blending modes

The next group within the Blending modes menu contains
darkening effects. Each of these five blending filters leaves
the darker areas of the selected layer opaque and creates
translucency in the lighter areas of the image.

The darkening effects are as follows:
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• Darken. The blend is applied by replacing the pixels with
the darker of the base value or the layer value. In other words,
the layer is applied only to pixels in the underlying image that
are lighter than the value of the layer pixel. This has the effect
of darkening the image and can be extremely useful if
applying filters to overexposed images.

• Multiply. The blend is applied by multiplying the base
value of each pixel by the layer pixel value. Multiplying a
pixel by black always produces black, and multiplying a pixel
by white leaves the pixel value unchanged. This mode has the
overall effect of darkening the image. Multiply is great for
creating shadows or for generally darkening your image.

• Color Burn. The blend is applied by darkening the base
channel based on the blended color by increasing the contrast
between the two colors. This has the effect of darkening the
image as well as increasing color contrasts.

• Linear Burn. The blend is applied by decreasing the
brightness of the bottom layer based on the value of the top
layer pixel, darkening the image.

• Darker Color. The blend is applied by replacing each
channel of a pixel with the darker between the base pixel
channel and the layer pixel channel. This option works better
than using the Darken mode because it uses the darkest values
from each channel to create the resulting color.

Using lightening blending modes

The lightening blending modes work opposite to the
darkening blending modes. Instead of leaving the dark areas
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opaque, the lighter areas of the selected layer remain opaque
and the dark areas are translucent.

The lightening blending effects are as follows:

• Lighten. The blend is applied by replacing the pixels with
the lighter of the base value or the layer value. This has the
effect of lightening the image and can be extremely useful if
applying filters to underexposed images.

• Screen. The blend is applied by multiplying the inverse of
the channel values of the layer and base pixels. This results in
a lighter color than either the layer value or the base value.
This has the same effect as projecting multiple photographic
slides on top of each other.

• Color Dodge. This applies the blend by decreasing the
contrast between the color of the channels in the layer pixel
and the base pixels. This lightens the base pixels using the
layer pixel values.

• Linear Dodge (Add). This applies the blend by increasing
the brightness based on the layer value of each channel,
lightening the image.

• Lighter Color. This applies the blend by replacing each
channel of a pixel with the lighter between the base pixel
channel and the layer pixel channel. This option works better
than using the Lighten mode because it uses the lightest
values from each channel to create the resulting color.

Adding contrast blending modes
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These blending modes create contrast between the selected
layers and the layers under them, making the lighter areas
lighter and the darker areas darker.

The contrast blending modes are as follows:

• Overlay. This applies the blend by mixing the layer values
with the base pixels while preserving the shadows and
highlights. This reduces the effect of extreme layer
adjustments that dramatically reduce the detail in the original
image.

• Soft Light. This applies the blend based on the gray value
of the filtered pixel. If the value of the layer pixel is darker
than 50-percent gray, then the base pixel is darkened using a
multiplying method. If the value of the layer pixel is lighter
than 50-percent gray, then the base pixel is lightened using a
dodging method. This has a similar effect to shining a
diffused spotlight on the image.

• Hard Light. This applies the blend based on the gray value
of the layer pixel. If the value of the layer pixel is darker than
50-percent gray, then the base pixel is darkened using a
multiplying method. If the value of the layer pixel is lighter
than 50-percent gray, then the base pixel is lightened using a
screening method. This has a similar effect to shining a harsh
spotlight on the image. This option is great for adding
shadows while applying the filter.

• Vivid Light. This applies the blend based on the gray value
of the layer pixel. If the value of the layer pixel is darker than
50-percent gray, then the base pixel is darkened by increasing
the contrast. If the value of the filtered pixel is lighter than
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50-percent gray, then the base pixel is lightened by decreasing
the contrast.

• Linear Light. This applies the blend as a combination of
Linear Burn, Linear Dodge, and Vivid Light. The lighter
colors brighten, but not as much as using Linear Dodge; and
the darker colors darken, but not as much as using Linear
Burn.

• Pin Light. This applies the blend based on the gray value of
the layer pixel. If the value of the layer pixel is darker than
50-percent gray, then the darker of the layer pixel and base
pixel is used. If the value of the layer pixel is lighter than
50-percent gray, then the lighter of the layer pixel and base
pixel is used.

• Hard Mix. This applies the blend by adding the value of
each RGB channel in the layer pixel to the corresponding
RGB channel in the base pixel. The values above 255 and
below 0 are clipped, so this can result in a large loss of detail.

Using difference blending modes

These blending modes blend the layers based on the
difference between the two layers. The following blending
modes look for variations in the layers to create special
effects:

• Difference. This applies the blend by setting the resulting
pixel to the value of the difference between the layer pixel
and the base pixel. Blending white inverts the pixel value, and
blending black results in no change.
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• Exclusion. This applies the blend similarly to the Difference
blend mode, but has less contrast.

• Subtract. This applies the blend by subtracting the
brightness value of the pixels in the base value from the
corresponding pixels in the layer value. The result is divided
by a scale factor and then added to the offset value. The
brighter the source, the more the blending mode subtracts.

• Divide. This applies the blend by dividing the brightness
value of the pixels in the base value from the corresponding
pixels in the layer value. This option has a much larger
variance than the Subtract blending mode.

Looking at the color blending modes

The final group of blending modes gives the selected layer a
color influence over the layers under it. The color blending
effects are as follows:

• Hue. This applies the blend by creating the resulting pixel
using the luminance and saturation of the base value but the
hue of the layer value. This reduces the blend to affect only
the hue of the base value.

• Saturation. This applies the blend by creating the resulting
pixel using the luminance and hue of the base value but the
saturation of the layer value. This reduces the blend to affect
only the saturation of the base value.

• Color. This applies the blend by creating the resulting pixel
using the luminance of the base value but the hue and
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saturation of the layer value. This limits the blend so that it
does not affect the brightness of the base value.

• Luminosity. This applies the blend by creating the resulting
pixel using the hue and saturation of the base value but the
luminance of the layer value. This limits the blend so that it
affects only the brightness of the base value.

Blending images using blending modes

As you can see, it's actually hard to describe the effects that
blending modes can have on your image. The layers you are
working with really make a difference in how the blending
modes look, so the best way to get a feel for them is to jump
in and play with them using your own images.

Here is an example of how to blend two images together
using blending modes:

On the Web

You can create this effect yourself or look at the finished
PSD file by downloading Figures 10-12a, 10-12b, and
10-12c from the website.

1. Open an image in Photoshop to be your base image.

We are going to transform the background of a photo to give
it some style, so we'll start with the PSD file composed of two
layers shown in Figure 10.12.

2. Add a second image as a layer on top of the first image.
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We chose an image of music and placed it between the top
layer composed of the couple and the bottom layer, which is
the photo background.

3. From the Blending modes menu, choose the Hard Light
blending mode.

Make sure the layer you want to blend is selected. The Hard
Light blending mode adds contrast, so the notes blend in
nicely with the variegated background, creating a classy effect
as shown in the final image in Figure 10.12. Feel free to try
some of the other blending modes using the files in this
exercise; there are several fun effects that we could have used.

Figure 10.12

Using the Hard Light blending mode to add style to the
background of this photo is the first step in creating a
professional-looking end product.

Here is another example of using blending modes. In this
example, we are going to add a colorcast to a photo. This is a
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good way to create sepia-toned images, but you can use any
color you want. We are going to use a blue colorcast:

On the Web

You can see the final image in color or try adding a
colorcast yourself by downloading Figures 10-13a and
10-13b from the website.

1. Open an image to which you want to add a colorcast.

2. Choose Solid Color from the New Adjustment Layer
menu in the Layers panel.

The Color Picker dialog box opens.

3. Choose a color to tint your photo.

A dark brown creates a beautiful sepia-tone, but you can
choose any color you want. We are going to use a denim blue.
(The dark browns can be found in the orange/reds at the
bottom of the color spectrum.)

4. Click OK.

Photoshop adds the color fill as a new layer, leaving your
image looking like a rectangle of solid color.

5. Choose Color from the Blending modes menu in the
Layers panel.
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Be sure the color layer is selected when you do this. Now the
color fill affects the image by using the brightness values of
the image to map the color fill onto the image, as shown in
Figure 10.13.

Figure 10.13

Although you can't actually see the colorcast, you can see by
the Layers panel that the blending mode has been applied.

This exercise created a solid colorcast. The best thing about
using blending modes is that the effects are only limited by
your creativity. You can change the look of this effect by
reducing the opacity of the color fill layer, or better yet,
changing your image into a black-and-white photo before
doing so.

Tip
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When creating your own colorcasts, create a Levels
adjustment layer over your image after the colorcast has
been created. Adjusting the levels can increase the contrast
of your image and give the colorcast more “pop.”

Linking layers

On the bottom of the Layers panel is a set of icons for
working with layers. The left icon, shown in Figure 10.14, is
the Link layers icon. Layers that are linked move together and
are resized together, and creating a selection on one layer
creates a selection on all of them.

To link layers, select two or more layers by pressing and
holding down the Shift key to select contiguous layers, or
pressing and holding down the Ctrl/ key to select layers that
are not contiguous in the Layers panel. When you have two or
more layers selected, the Link layers icon becomes active.
Click it to link the selected layers. The linked layers display a
link icon, as shown in Figure 10.14.

Figure 10.14

The most powerful tools in the Layers panel have deceivingly
simple icons.
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Creating layer styles, layer masks, and fill and adjustment
layers

The most versatile icons in the Layers panel are the Add layer
style, Add layer mask, and Create fill or adjustment layer
icons, as shown in Figure 10.14. Along with Smart Objects,
these are the most powerful, non-destructive tools in the
layers repertoire. Because the options related to these icons
are extensive, we cover each one later in this chapter under its
own heading.
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Grouping layers

Just as you create folders on your computer's hard drive to
organize your files, you can create groups in the Layers panel
to organize your layers. Click the Create new group icon in
the Layers panel, and a new group appears, as shown in
Figure 10.14. You can rename the group by double-clicking
the name in the Layers panel or by right-clicking it and
selecting Group Properties from the popup menu.

To add layers to a group, simply drag and drop them onto the
group. These layers still behave in the layer hierarchy just as
they are placed, but now you can toggle the group closed by
clicking the little triangle in the group layer, hiding the layers
inside the group. If you are working with many different
layers, this is extremely useful.

Creating a blank layer

In order to take full advantage of layers in Photoshop, you
need to be able to create a blank layer for your own use. This
is handy when you want to make changes to your image that
you want to be able to edit at any time. When painting, for
example, creating a blank layer to paint the changes on leaves
the pixels in the original layer unaffected. To create a blank
layer, click the Create new layer icon on the Layers panel, and
a new transparent layer is created directly above whichever
layer you have selected.

Throwing layers away

At the bottom-right corner of the Layers panel is a trash icon.
You can delete layers by selecting them and clicking this
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icon. If your layer has a mask, you can delete the mask by
selecting just the mask. Do this by clicking directly on the
mask. You see a highlight appear around it, showing that it is
selected. Click the trash icon, and the mask is deleted. If you
have the layer thumbnail selected, the entire layer disappears,
including any masks or filters. You can also delete layer
styles or sublayers added to a Smart Object by dragging them
to the trash icon.

Applying Worry-Free Fill and Adjustment Layers

A fill or adjustment layer can adjust the color, levels, or
brightness and contrast of your image. These changes are
added as a separate layer placed in the layer hierarchy directly
over the selected layer. They are portable and editable, and
you can create layer masks for each one. You can use
blending modes to change the way they affect other layers,
and because they are full layers, you can turn them into Smart
Objects.

The best thing about a fill or adjustment layer is that it does
not change the pixels of your original image; this is the best
part of non-destructive editing. All the options available for
fill or adjustment layers can be applied directly to an image
file when you choose Image⇒Adjustments. These
adjustments are made directly to the image, however, and are
destructive.

Note
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Vector layers, such as text, shapes, or 3-D files, cannot be
adjusted by using the Image⇒Adjustments menu. The only
way you can apply these adjustments to vector layers is by
placing a fill or adjustment layer over them in the Layers
panel.

Choosing a fill or adjustment layer

You can place a fill or adjustment layer into your file by
clicking the Create fill or adjustment layer icon in the bottom
of the Layers panel. This icon looks like a half-black,
half-white circle. Clicking this icon opens the Fill or
Adjustment layer menu, which includes several options, as
shown in Figure 10.15. Clicking the option you want opens a
dialog box on the Adjustments panel, which allows you to
adjust the settings for that option. We cover these options and
settings in the next few sections.

Figure 10.15

Choosing a fill or adjustment layer
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Learning the basics of fill layers

A fill layer is a color fill, gradient, or pattern that is added as
its own layer in the Layers panel. After you have added a fill
layer, it fills the entire canvas. It may seem ridiculous at first
to fill the canvas with a color or pattern, completely covering
your original file, especially because the Fill dialog box
doesn't have many options. Remember that you are working
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with a separate layer, however. After you have added a fill,
you can reduce the opacity or use a blending mode to create a
colorcast, use masks to create a background, or use a clipping
mask to cut custom shapes from the fill layer. In Figure 10.16,
you can see an example of how we used a pattern fill to create
a custom border for a photo.

We cover clipping masks in Chapter 17.

Figure 10.16

Creating a pattern fill was an important step to creating this
custom border.
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On the Web

You can see the layers used to create this effect by
downloading Figure 10.16 from the website.

To create any one of these layers, choose the Create fill or
adjustment layer icon in the Layers panel and select Solid
Color, Gradient, or Pattern from the popup menu. Each option
opens a dialog box.

Although these dialog boxes are fairly
straightforward, we cover them in greater detail in Chapter
16.

Learning the basics of adjustment layers

Adjustment layers change the lightness or color of your
image. When you add an adjustment layer to your image, you
don't see a dialog box; you use the Properties panel, shown in
Figure 10.17, where you can make changes to the adjustment
layer. This is handy, because you can go back to this panel at
any time to edit your adjustment layers.

Figure 10.17

The Properties panel lets you make changes to adjustment
layers in your Layers panel.
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Adding adjustment layers goes beyond using a
non-destructive layer to improve the look of your photo.
Using layers gives you the option to create masks that allow
you to apply adjustments to selected areas of your image,
giving you the ability to change the mask as well as the
adjustment at a later time, if needed.

For example, the Exposure option is meant to correct
exposure problems in your image. This is a handy adjustment
to use in conjunction with a mask that can cover correctly
exposed parts of your photo as you adjust areas that are too
light or too dark. Figure 10.18 is an example of using a
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selection to isolate a portion of the image and lighten the
exposure on it to create a dramatic improvement in the photo.

Figure 10.18

Using the exposure adjustment selectively creates color
instead of shadow in the foreground of this image.

On the Web
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You can try a targeted exposure setting on this image or see
our targeted exposure by downloading Figures 10-18a and
10-18b from the website.

You can also use layers in conjunction with adjustments to
create two different versions of your image. For example, if
you want to create a black-and-white version of a color photo,
but keep the color photo available, you can use a Black and
White adjustment layer and toggle the visibility to see it in
black and white or in color.

Another reason to use the Black and White adjustment layer
is that most color photos do not convert well to
black-and-white images, because the result is usually lacking
in contrast. In Figure 10.19, the first image was converted to
black and white by changing the color mode to grayscale.
You can see that the result is bland and not very engaging.
The second image has a Black and White adjustment layer
placed over it. The ability to adjust the levels of color in the
image gives you the power to make the yellows and greens
brighter (the eyes and lighter fur) and the blues and browns
darker (the mountains and stripes); this increases the contrast
of the image for a much better overall result.

Figure 10.19

Creating a successful black-and-white photo from a color
photo takes more than just removing the color information.
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We cover the actual adjustments in detail in
Chapters 12 and 13, because you need to do much more than
just add another layer to the Layers panel.

Editing the properties of a fill or adjustment layer

After you have created a fill or adjustment layer, you can go
back at any time to edit the properties of the effect created
with the layer. Simply select the layer and the Properties
panel displays the fill or adjustment settings. You can make
any changes you desire.

Creating Layer Style Special Effects

A layer style is any one of several effects including Drop
Shadow and Inner Glow. Each layer style is contained in its
own sublayer and can be edited, turned off, or discarded.
These sublayers can even be turned into their own full layers
and can be moved, filtered, color corrected, and edited just
like any other layer in Photoshop.
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The Layer Style menu icon (fx) is located at the bottom of the
Layers panel. You can add a layer style to your file by
clicking the fx icon to open the Layer Style menu and
choosing a layer style. When you have added a new style, it
appears as a new sublayer under the object layer, as shown in
Figure 10.20.

Figure 10.20

A layer style is added to the Layers panel as a sublayer of the
selected layer rather than an independent layer.

Note

You can also open the Layer Style dialog box by Choosing
Layer⇒Layer Style and choosing a layer style from the
submenu.
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The Layer Style dialog box is very versatile. After you have
opened it, you can choose one or more styles to add to your
object by clicking the box next to the style name to add a
check mark to it. Highlight the style name by clicking it, and
the dialog box changes to give you the settings for that style.
In Figure 10.21, you can see the Layer Style dialog box with
three different layer styles selected.

Choosing a layer style

Several layer styles are available, all with very different
effects. Here is a list of what they are and what they do:

• Bevel & Emboss. This option creates edge effects that give
a 3-D look to images or objects in your file. We applied a
bevel to the frame in Figure 10.16 to make it pop up.

• Stroke. This option creates an outline of your object. You
can change the stroke's color, width, and position.

• Inner Shadow. This option casts a shadow over your image.
You can set options such as the opacity and choke.

• Inner Glow. This option is like the Outer Glow, but it
creates a glow inside your image. You can change options
such as the opacity and technique.

• Satin. This option creates a gradient wave across your
object that mimics the look of satin. You can set options such
as distance and size.
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• Color Overlay. This option adds a color over your object.
You can change the color or the opacity to get a solid color or
a mixture of colors.

• Gradient Overlay. This option changes the shadow and
color of your object. You can choose from several preset
gradients or create one of your own.

• Pattern Overlay. This option sets a pattern over your 3-D
object like the Color and Gradient Overlay. You can set the
opacity to completely cover your object or to mix with the
object's color. You can also set the scale of the pattern to be
larger or smaller.

• Outer Glow. This option allows you to add a glow around
your image. You can set options such as the color of the light
and the size of the glow.

• Drop Shadow. This option creates a shadow behind your
image or selection. You can set options such as the shadow
size and distance.

Figure 10.21

You can add more than one layer style at a time using the
Layer Style dialog box.

685



Adjusting layer style options

As you highlight each style available in the Layer Style dialog
box, the settings for that style appear. Some of these settings
are self-explanatory; others are not. Here is a list of the
settings that you might not be familiar with:

• Use Global Light. This setting makes all the light settings
in the layer styles universal. That means that if you add an
inner glow and a drop shadow, the angle of the light is the
same for both effects. You can set the light angle and height
of the global light in any layer style option that uses lighting,
and the changes are made to all selected lighting styles.

• Contour. This setting controls the shape of the layer style.
The shape of the contour represents the color fade from a set
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opacity to transparent. For example, the default contour is a
diagonal line. When creating a bevel, the diagonal line creates
that bevel on just one side of the selected layer at a 45-degree
angle (based on your light settings). If you were to choose a
stepped contour, all of the edges of the selected layer would
be affected, creating an outline. You can use preset contours
or create one of your own.

• Anti-aliased. This setting gives the contour softer edges.

• Layer Knocks Out Drop Shadow. This setting simply
keeps the drop shadow from being seen through a transparent
layer.

• Jitter. This setting is available when you are creating a
gradient glow. It randomizes the colors used for the glow.

Whether you create one layer style at a time or use the dialog
box to create several at once, each style shows up as its own
sublayer of the selected layer. Notice in Figure 10.20 how the
layer style is grouped under an Effects heading. You can turn
off the layer styles collectively by clicking the eye next to the
Effects heading, or you can do this individually by clicking
the eye next to the style you want to hide.

Tip

You can move a layer style to a different layer by dragging
it from one layer to another. If you want to make a copy of
the layer style, hold the Alt(Opt) key as you drag and drop.
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You can make changes to the layer styles at any time by
opening the Layer Style dialog box. Rather than duplicating a
layer style, the changes you make are reflected in the styles
already shown in the Layers panel.

Tip

You can add styles you've created to the Styles panel by
dragging and dropping them there. You can also use any of
the styles on the Styles panel by clicking them.

Creating a separate layer from a layer style

The way a layer style is created in the Layers panel is neat
and efficient, and it locks the layer style to the object that it
was created for. Occasionally, though, you will want to create
an independent layer from a layer style so you can edit the
layer style separately from the image layer.

For example, you may want to create an outline of an object
and just use the outline in a composite. Also, you may want to
create a shadow and separate it from the object, giving it
greater distance than you can create through the layer style
settings.

You can create a drop shadow and make a separate layer out
of it by following these steps:

On the Web
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You can follow along with this exercise by downloading
Figure 10.22 from the website and looking at the layers.

1. Open or create a document with at least two separate
layers.

At least one layer should be an object that doesn't fill the
entire canvas, such as the photo cutout shown in Figure 10.22,
or a text or shape layer.

2. Select the cutout layer by clicking it.

The layer appears in highlight, indicating that it is selected.

3. Click the icon labeled “Add layer style” at the bottom of
the Layers panel.

This opens the Layer Style dialog box (refer to Figure 10.21).

4. Select the Drop Shadow layer style.

A drop shadow appears on the layer you selected. Do not
worry about changing the settings at this point.

5. Click OK to close the Layer Style dialog box.

6. Right-click the Drop Shadow sublayer and select Create
Layer from the popup menu.

The effect changes to a regular layer on your Layers panel, as
shown in Figure 10.22.
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7. Select the Drop Shadow layer.

Now you can make changes directly to the drop shadow.

8. Choose Filter⇒Distort⇒Wave to create a wave in the
shadow.

Once you've finished creating the wave you want, click OK.

9. Choose Edit⇒Transform from the menu to resize,
skew, and distort your shadow.

Once you're finished transforming the shadow, accept the
transformations.

10. Choose Filter⇒Blur⇒Gaussian Blur to give your
shadow soft edges and an indistinct shape.

11. Change the opacity of the shadow until it blends neatly
with other shadows in the photograph.

Figure 10.22

A layer style can become its own editable layer.
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Creating Smart Objects

You can apply another type of change to your image by using
the Filter menu. The Filter menu has always been the fun
menu in Photoshop, where you could change your photos into
stained-glass windows or liquid metal. Adjustment filters are
available as well, including those that perform noise reduction
and sharpen your images. All of these filters except Vanishing
Point can be added as Smart Filters so that you can change,
rearrange, or delete them at any time. A Smart Filter is added
to your image on a separate sublayer much like the layer
styles. This gives you the capability to edit it, move it, or
discard it at will without having to go back in your step
history or change any of the other filters or effects you may
have added to your object.

Because Smart Filters are sublayers, they are non-destructive
to your image. You can view the image with the filter or turn
off the view of the filter, so you can see the image without the
effect. This is especially helpful when you add more than one
filter because you can see exactly how the filters affect each
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other. You can even swap the filters around, changing the
order in which they are applied to your image.

Because each filter is contained in its own sublayer, you can
also make adjustments to the filter after the fact. By clicking
the icon shown on the right side of the filter sublayer, you can
adjust the blend mode. You can also right-click the filter
sublayer and choose Edit the Filter to adjust the original
settings of the applied filter.

Unlike the fill and adjustment layers or the layer styles, Smart
Filters do not have their own icon on the Layers panel. In fact,
before you can add Smart Filters to any layer, you need to
turn that layer into a Smart Object. Turning a layer into a
Smart Object actually saves that layer as a separate file so it is
protected. We go into more detail about this technique in the
next section.

Converting a layer to a Smart Object

You can convert any pixel or vector layer to a Smart Object.
To convert a layer to a Smart Object and add Smart Filters,
select that layer and choose Filter⇒Convert for Smart Filters.
The following warning appears: “To enable re-editable smart
filters, the selected layer will be converted into a smart
object.” After you've clicked OK to accept this message, the
layer thumbnail changes to a Smart Object thumbnail, as
shown in Figure 10.23.

Figure 10.23

A Smart Object thumbnail includes the Smart Object icon in
the lower-right corner.
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The primary characteristic of a Smart Object in Photoshop is
that the layer is saved as a separate embedded document in
the original file. This allows the layer to maintain its image
quality no matter how many edits or filters are used and
reversed. Double-click the Smart Object and a dialog box
appears letting you know that after any changes are made to
the original layer, you can save those changes and they will
be updated in the Smart Object. Once you click OK, a new
document opens containing the original layer before it was
turned into a Smart Object. Make the changes you want and
then save and close this document to return to your original
document containing the Smart Object.

Note

You can't change any of the pixel data in a Smart Object.
This is because a Smart Object is an aggregate, not
composed of distinct pixels. In order to change pixels, the
file needs to be a raster file. Changing a Smart Object into a
regular layer will rasterize it.
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Adding Smart Filters

Now that you've changed your layer into a Smart Object in
Photoshop, you can click the Filter menu and most of the
options are highlighted for use as Smart Filters.

Note

Certain filters, such as Liquify and Vanishing Point, are not
available as Smart Filters.

From here, you can choose a filter or open the Filter Gallery
to add a filter to your Smart Object. Choose Filter⇒Filter
Gallery from the menu. In the Filter Gallery that appears, you
can apply more than one filter before exiting by adding
subsequent filter layers. You can click each layer to change
the properties of that filter, or you can drag them up and down
to change the order in which they are applied.

The Filter Gallery is a great place to play. You
can learn all about filters and how to use the Filter Gallery in
Chapter 20.

After you exit the Filter Gallery, you can see that the filter
you applied has been added as a Smart Filter sublayer in the
Layers panel. The Smart Layer is labeled “Filter Gallery”
because the Filter Gallery was used to create the filter.

You can also choose individual filters from the Filter menu.
For example, choose Filter ? Oil Paint to apply that particular
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filter. When you choose a filter from the Filter menu without
using the Filter Gallery, the layer is named with the filter you
applied, as shown in Figure 10.24.

The image in Figure 10.24 has two filters applied: To see the
image without the oil paint effect, you can simply click the
eye on the filter layer. When the eye disappears, so do the
effects applied by that filter.

Making changes to Smart Filters

You can adjust the settings of any layer by double-clicking
that layer. The Filter Settings dialog box opens and allows
you to make changes to the original filter settings.

You can also change the look of the filter layer by changing
the blend mode of the layer. Double-click the Filter Blending
Options icon that appears on the right side of the filter layer.
This opens the Blending Options dialog box, where you can
choose from a list of several modes that change the way the
filter is applied, as shown in Figure 10.25.

Figure 10.24

The Smart Filter layers are labeled with the filter you applied.

695



Figure 10.25

You can change the blending options for each filter to change
the way it affects the image.
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You can also rearrange the order in which the filters are
applied to the Smart Object by simply dragging and dropping
them into a different order. This can change the look of your
image because each filter affects the filters that were added
before it but not after it. For example, if you placed the Oil
Paint filter above the Filter Gallery filter in Figure 10.26, you
would get a softer result than if you placed these filters in the
opposite order.

Figure 10.26
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With the Oil Paint filter added first, you get a more contrasty
result than if the Filter Gallery is the bottom filter.

You can also create masks so that filters are applied only to a
selected part of your image. We discuss how to do this in the
next section.

Manipulating Layer Masks

Think of a mask as a stencil. If you place a stencil over an
area that you are painting, it protects the areas that are
covered and creates a painted design at the same time. Masks
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in Photoshop work the same way, but you can do so much
more with an image than just paint over it. By using masks,
you can apply every enhancement or filter available in
Photoshop to just a part of your image, while leaving the rest
of the image untouched.

A layer mask is what most people think of when you mention
masks in Photoshop. Figure 10.27 shows a layer mask. Just
like a stencil, the black parts represent areas of the image that
will be unaffected by any changes made to this layer. The
mask also makes those areas transparent so that any layers
underneath will be visible.

Figure 10.27

Placing a mask in a layer protects parts of it from edits.

The white areas of the mask will be affected by any changes
made to the layer. These areas behave just as if they were all
the image pixels contained in this layer. One of the best
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aspects of using digital “stencils” is that it is incredibly easy
to create semi-permeable areas of a mask with grayscale
tones. The lighter a grayscale area is, the more your changes
to the image affect those areas.

Creating masks

You can create layer masks in several ways. In most cases,
you begin by creating a selection. After you've created a
selection, turning it into a mask is fairly simple. After you've
created a mask, you can move it between layers to facilitate
image composites and special effects.

Using the Add layer mask icon

The fastest way to create a mask is to click the Add layer
mask icon in either the Layers panel (shown in Figure 10.28)
or the Masks panel. If you have an area in your image
selected, Photoshop creates a mask from that selection. You
can also create a mask from a path. If no selection or path is
active, the mask is blank.

Figure 10.28

Click the Add layer mask icon to quickly add a mask to a
selected layer.
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You can create two different types of masks using these
icons: a pixel mask and a vector mask. The type of mask you
create depends on whether you create the mask from a
selection or a path.

• Pixel masks. Pixel masks are rasterized masks and behave
just like raster images, which we cover in Chapter 3. They are
built from pixels and lose quality if you resize them. If you
create a mask from a selection, it is a pixel mask, whether you
use the Add layer mask icon in the Layers panel or the Add
pixel mask icon in the Masks panel. If you click the Add
vector mask icon in the Masks panel, the selection is not used
to create a vector mask on the selected layer.

• Vector masks. Vector masks are built mathematically and
are recomputed as they are resized so they don't lose quality.
You can create a vector mask from a path by either creating a
path or turning a selection into a path. You can only edit these
masks using vector tools, such as the pen tools or the shape
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tools. Just as you can't use a selection to create a vector mask,
you can't use a path to create a pixel mask.

Using the Refine Edge dialog box

We cover the ins and outs of the Refine Edge dialog box in
Chapter 9. You can use this dialog box to export your
selection as a mask over your current layer, a mask over a
new layer, or a mask over a new layer in a new document.
Regardless of which option you choose, your selection is
changed into a mask with properties identical to the mask
shown in Figure 10.27. Using the Feather option in the Refine
Edge dialog box adds an increasingly transparent edge to your
mask, which is indicated by levels of grayscale.

Creating type masks

You can create type masks over your image by using the type
mask tools found in the Toolbox, as shown in Figure 10.29.
These tools work like the type tools, but rather than creating
solid text on a separate layer, the type mask tools create a
selection that surrounds the type on the selected layer. After
you've created a selection using type, you can create a mask
from that selection using the Refine Edge dialog box or the
Add layer mask icons.

Figure 10.29

The type mask tools can create masks in your image using
type.
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Looking at clipping masks

A clipping mask is not created using a selection, nor does it
look like a traditional mask in your Layers panel. A clipping
mask is created by taking the shape of one layer and cutting
that shape out of the layer above it.

You can create a clipping mask by following these steps:

On the Web

Try it yourself by downloading Figures 10-30a and 10-30b
from the website.

1. Open an image you want to clip.

This can be any image. We've chosen the Halloween photo
shown in Figure 10.30.

2. Double-click the background layer to turn it into a
regular layer.
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You can name the layer if you want to.

3. Create a layer with a cut-out to clip from.

This can be a shape layer, a text layer, or a selection from
another image. We chose the shape of a maple leaf that we
copied and pasted into its own layer, as shown in Figure
10.30.

Figure 10.30

We combined these two images with a clipping mask.

4. Place the layer with the cut-out underneath the image
layer.

If you've created a new layer in your document, it was
automatically placed above your image layer. Click and drag
it underneath your image layer.

5. Select the image layer.
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This is the layer that you want to be visible in the end. Our
selected layer is the one with the jack-o'-lanterns.

6. Right-click the image layer, and select Create Clipping
Mask from the popup menu.

This uses the bottom layer as a template to cut the top layer,
as shown in Figure 10.31. The bottom layer becomes a
silhouette for the top layer.

Tip

A quick way to create a clipping mask without using the
menu is to press the alt/option key and hover over the
dividing line between the two layers until the clipping icon
appears. Then click to instantly create a clipping mask. The
clipping icon looks like an empty layer thumbnail with an
arrow pointing down.

On the Web

Check out the final result by downloading Figure 10.31
from the website and looking at the layers.

Figure 10.31

The clipping mask uses the leaf as a template to cut out the
jack-o'-lantern image for a fun fall effect.
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Creating a clipping mask changes the way the layers look in
the Layers panel, but not by placing a mask thumbnail in the
selected layer. Instead, the layer containing the jack-o'-lantern
image has an arrow pointing down to indicate that this layer is
being affected by the layer underneath.

You can release the clipping mask by right-clicking the top
layer again and choosing Release Clipping Mask from the
popup menu.

Editing masks

After you place a mask thumbnail in your Layers panel, you
can edit it using the image, the channels, or the Masks panel.
Making changes to the mask changes what areas in your
photo are protected.

Making changes to a mask by painting on the image

To edit a mask using an image, you must have the mask
selected in the layer. Make sure the mask thumbnail has a
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white highlight around it (as shown in Figure 10.32), rather
than the image thumbnail. This is sometimes hard to see, so
click back and forth a couple of times to see the difference.

After you have selected the mask, you can use the Brush and
Eraser tools to add to or subtract from the masked area. Using
the Brush tool adds to the mask and using the Eraser tool
subtracts from it. Use these tools directly on your image. The
only difference you see is a change in the mask's effects.
Depending on what those changes are, this might not be the
ideal way to edit your mask, because it is hard to be precise if
the effects of the mask aren't obvious.

Figure 10.32

The white outline showing that the mask is selected means we
are making changes to the mask with the brush, rather than
the image.
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Note

Reducing the opacity of either the Brush or Eraser tool
paints levels of grayscale, creating a semi-permeable area of
your mask.

Editing masks using the Channels panel

A better option for editing this mask is to use the Channels
panel. With the mask selected in the Layers panel, open the
Channels panel, as shown in Figure 10.33. The Channels
panel contains the color channels found in your image, but it
also contains any masks placed in your image. When you
open the Channels panel, the mask channels are not visible. If
you turn the visibility icon on, a rubylith appears in your
image, reminiscent of the Quick Mask that we cover in
Chapter 9. Now as you make changes to the mask, you can
see them clearly.

Note

Rubylith is the term used for a transparent color overlay that
indicates the masked area. Because it is transparent, it is
easy to see where changes need to be made. You can change
the color to contrast with the colors in your image.

If you would like to make changes to the mask by itself,
without a view of the image, you can deselect the visibility
icon in the full color channel (RGB in this example) and only

708



the mask is visible in your document window, as shown in
Figure 10.33.

Figure 10.33

You can edit the mask by itself by turning off the visibility of
the color channels in the Channels panel.

Tip

Layers and Channels are usually in the same tab group. If
you are working with both panels simultaneously, however,
it might be easier to undock one or the other and drag it out
so that you can see both panels at the same time.

Editing masks using the Properties panel

The Properties panel offers the most comprehensive way to
edit masks, not only giving you the option to add to or
subtract from them, but also allowing you to refine the edges,
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choose a color range, or invert it. You can also change your
mask into a selection. Figure 10.34 shows the Properties
panel with a mask selected. The following options are
available:

• Mask thumbnail. This thumbnail shows you the currently
selected mask as well as whether the mask is a pixel mask or
a vector mask.

• Add pixel mask. This button adds a pixel mask to the
selected layer. If that layer contains an active selection, it is
converted to the mask.

• Add vector mask. This button adds a vector mask to the
selected layer. If that layer contains an active path, the path is
converted to the mask.

• Density. This slider adjusts the density or translucency of
the mask.

• Feather. This slider adjusts the gradual translucency of the
edges of the mask, creating a feathering effect.

• Refine. This menu item contains the following options:

• Mask Edge. This button opens the Refine Edge dialog box
(covered in Chapter 9) and allows you to make refinements to
the edge of your mask.

• Color Range. This button opens the Color Range dialog
box, allowing you to add specific colors to your mask, similar
to the Color Range dialog box discussed in Chapter 9.
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• Invert. This button inverts the mask, selecting areas that
were not previously selected and deselecting areas that were.
Areas that are semitransparent are also inverted.

• Load selection from mask. This option does not disable the
mask, but allows you to make changes to it as if it were a
selection. The marching ants appear on your image, and you
can use selection tools to add to or subtract from the mask.
You can also use the Quick Mask feature to paint in changes
to the mask.

• Apply mask. This option combines a selected mask with the
image. By clicking it, you turn all masked areas into
transparent pixels and delete the mask.

• Enable/Disable mask. This “eye” icon allows you to see
the image as if no mask were applied. When the eye has a red
line through it, the mask effects are not visible in the image.

• Delete mask. This option deletes the selected mask when
you click the icon.

• The Properties panel menu. This menu has options that
allow you to add or subtract selections to or from your mask.
You can also see the mask properties that allow you to change
the color of the overlay and give names to your masks.

Figure 10.34

When you select a mask, the Properties panel displays the
mask properties.
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Unlinking and moving masks

To unlink a mask from its layer, simply click the link icon
between the layer thumbnail and the mask thumbnail in the
layer. When the mask is unlinked, it is no longer transformed
with the image when you resize or move it. You can also use
the Move tool to move the mask around independently from
the layer it's on.

You can also move a mask from one layer to a different layer.
You would probably do this if you wanted to create a
selection in one layer, but then use the mask in an entirely
different layer. You can also use this method to duplicate a
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mask in more than one layer. Figure 10.35 shows a composite
created by moving a mask from one layer to another.

Figure 10.35

Moving the mask from the layer containing the cat to the
layer containing the boy cuts the shape of the cat out of the
boy.
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Creating Layer Comps
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Layer comps enable you to create, view, and then display
multiple versions of a design within one file by recording
layers. The Layer Comps panel allows you to take pictures of
three different layer arrangements within the same document:
the layer visibility, position, and appearance. For example, if
you were creating a brochure and a flyer that had the same
images and text but different layouts, you could make a layer
comp for each project in the same document.

To create layer comps, follow these steps:

1. Create a layout in Photoshop.

This layout is completely up to you. You can see an example
of a flyer in Figure 10.36.

2. Open the Layer Comps panel.

Choose Window⇒Layer Comps from the main menu bar.
The panel is very simple and has few options.

3. Click the Create new layer comp icon to create a new
layer comp.

You can give it a custom name if you like. Layer properties
such as position, visibility, and appearance are saved in this
layer comp.

4. Make changes to the position, transparency, or
appearance of your layers.
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These are the oNL1y changes that can be preserved in your
layer comp, so resizing or deleting your layers is out of the
question.

5. Click the Create new layer comp icon again, and save
your new layer comp.

You should have two layer comps in the dialog box, as shown
in Figure 10.36. You can toggle back and forth between them
by selecting the icon next to them to make them visible.

Figure 10.36

The Layer Comps panel shows a layer comp for each of our
designs.

716



Merging Layers

When you have made your changes and you are sure that you
no longer need separate layers, you can merge them. Not only
does this clean up your Layers panel, but it also reduces the
size of your file. Each layer you add makes the file bigger, as
shown in Figure 10.37. The two different file sizes listed in
the document window are the document size and the
document size with layers, respectively.

Figure 10.37
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The document window shows the size of the document with
layers followed by the size of the original document.

You can merge your layers in several ways. Choose one of
the following options from the Layers panel menu:

• Merge Down. This option merges the selected layers with
the layer immediately below them.

• Merge Layers. This option merges the selected layers. Use
it when you want to merge some, but not all, of your layers.

• Merge Visible. This option merges the layers that are
visible, leaving any layers that have the Show/Hide layer icon
(the eye) turned off.
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• Flatten Image. This option flattens all the layers, leaving
you with a background layer that contains the visible
information of all the layers. After you've flattened your
image, you can't make changes to the individual elements that
were contained in the layers; they are now part of the
background layer.

Note

You can flatten your image into a single layer and keep all
the original layers as well. This option is only available by
using the finger-tangling keyboard shortcut Ctrl (
)+Alt(Opt)+ Shift+E. The flattened layer is created as a
separate layer above the original layers.

Summary

Knowing how to use layers is an important part of effectively
using Photoshop. This chapter covered everything you need
to know about the Layer menus, the Layers panel, and layers
themselves. Although you may have some questions about the
effects that can be added to the Layers panel, you should be
able to add them, move them, and edit their settings. You now
have the skills to perform the following tasks:

• Adding layers to your document in several different ways

• Moving and editing those layers in your document as well as
the Layers panel

• Using blending modes to effectively combine layers
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• Creating effects layers such as adjustment layers, layer
styles, and Smart Object layers and understanding how they
work

• Creating layer masks to perform several different functions

• Saving multiple layouts using layer comps

• Merging layers to reduce clutter and file size
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Chapter 11: Exploring Channels

In This Chapter

Introducing color channels

Using the Channel Mixer to enhance grayscale

Understanding the Channels panel

Creating, duplicating, splitting, and merging channels

Creating and using alpha channels

Adding spot color channels to images

Color channels are a core component of both color and
grayscale images. A color image is composed of separate
color channels that, when combined, make up the colors in
the image. Understanding the color channels and the tools that
Photoshop provides will help you make better use of the color
data in your images.

Photoshop provides two main tools to help you manipulate
and manage the color channels in images: the Channel Mixer
and the Channels panel. Using these tools, you can see,
manipulate, and even create channels in your image to
increase your options when making selections and
adjustments.

This chapter discusses using the Channel Mixer to mix, swap,
and combine the color data in your images and using the
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Channels panel to manage channels, create and use alpha
channels, and create spot color channels.

Understanding Color Channels

As we discuss in Chapter 4, the images that we see are
composed of light emitted from a computer screen or
reflecting off a photo. The colors we see can be divided into
the levels of three frequency ranges of light-stimulating
receptors in the eye. Photoshop uses this same concept to
represent digital images. Each pixel in a color digital image
contains a series of values that define the actual color of the
pixel. For example, each pixel in an RGB image contains a
value describing the level of red, a value describing the level
of green, and a value describing the level of blue.

A channel contains the series of values for only one color for
the entire image. For the red channel, each pixel contains only
one value describing the level of red. Splitting the image into
individual color channels allows Photoshop to provide some
very powerful tools when editing images and creating special
effects.

Photoshop provides tools to adjust channels based on the
color mode of the image. For example, if the color mode is
RGB, Photoshop provides red, green, and blue tools; if the
color mode is CMYK, Photoshop provides cyan, magenta,
yellow, and black tools.

Photoshop treats individual channels as grayscale images
because color is based on the mix of the channels; with only
one channel, Photoshop cannot determine color. That is why
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when you view a single channel of an image, it appears in
grayscale.

An advantage to breaking color into channels is that each
color channel contains part of the detail of the image. Notice
the three channels shown in Figure 11.1. Each channel
contains different parts of the detail that make up the entire
image. Breaking up the image detail gives you more options
when you work with the image.

Figure 11.1

The red, green, and blue color channels of an image each
contain part of the full detail in the image.
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On the Web

You can find the image shown in Figure 11.1 on this book's
website as Figure 11.1.jpg. You can open it in Photoshop
and view each of the color channels.

Using the Channel Mixer

One of the most powerful, yet least used, tools in Photoshop
is the Channel Mixer. The Channel Mixer allows you to
fine-tune the level of each color channel in the image
separately. To reach the Channel Mixer, shown in Figure
11.2, choose Image⇒Adjustments ? Channel Mixer from the
main menu bar. The Channel Mixer provides a simple
interface to mix values between the different channels in the
image.

You may wonder whether mixing channels is the same thing
as adjusting the colors in the image using one of the other
adjustment tools. The answer is no. When you mix two or
more channels, you are not mixing the colors of the channels
so much as you are mixing the detail provided in the
channels. Mixing the channels allows you to change the detail
levels in each channel, which provides a different result when
you later make other adjustments such as changing the hue or
tone in the image.

Note
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The Channel Mixer is available only when you are using the
RGB and CMYK color modes. If you need to eventually
work in the lab, grayscale, or other color modes, you should
do the channel mixing before changing the color mode from
RGB or CMYK.

FIGURE 11.2

The Channel Mixer allows you to mix the channels to create
new channel data.
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The Channel Mixer provides these options when mixing the
channels in an image:

• Preset. This allows you to select from a previously saved
mix of channels. Photoshop provides several black-and-white
preset settings that apply different color filters, including
infrared. This is useful if you need to apply the same mix to
more than one photo or if you want to save a certain mix and
then try others. To save the current Channel Mixer settings,
select Save Preset using the drop-down menu button to the
right of the Preset drop-down menu.

• Output Channel. This allows you to select the output
channel that receives the mix of data from the set of source
channels.

Caution

The current data in the output channel is overwritten by the
values you specify in the set of source channels.

• Red. This specifies the percent of the red channel levels to
mix into the output channel. You can use the slider or type in
the value directly.

• Green. This specifies the percent of the green channel levels
to mix into the output channel. You can use the slider or type
in the value directly.
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• Blue. This specifies the percent of the blue channel levels to
mix into the output channel. You can use the slider or type in
the value directly.

• Constant. This specifies the grayscale value of the output
channel. When you specify negative values, more black is
added to the output channel. When you specify positive
values, more white is added.

• Monochrome. This option changes the output channel to
gray and the preview of the image is in grayscale. This is the
perfect option to use when you want to adjust a color image
before converting it to grayscale.

I can see three reasons to mix the color channels in an image.
The most common is to selectively control how color
channels are mixed to create a grayscale image. A second
reason is to mix channels containing more detail with
channels containing less detail to enhance the overall image
detail. A third reason is to completely swap channels to create
special effects without altering the other channels.

Mixing colors with the Channel Mixer

Using the Channel Mixer, you can specify the amount of level
data, or detail, from each of the three channels to mix into one
single channel. This allows you to change the actual color
channel composition of the image.

You perform color mixing by selecting an output channel in
the Channel Mixer and then setting the percentages of each
color channel that you will use to form the new channel. For
example, consider a single RGB pixel. If you use the Channel
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Mixer to change the red channel to be a composite of
0-percent red, 50-percent green, and 50-percent blue, then the
red value for each pixel will be changed to 0 percent of the
red value plus 50 percent of the green value plus 50 percent of
the blue value. The percentage values are based on what is
already there; for example, if the pixel contains level values
of 100 for red, 50 for blue, and 200 for green, then the level
of the output channel pixel will contain 0 from red plus 50
from blue plus 100 from green, or 150.

Color mixing is useful when you have a channel in an image
that contains very little detail because it was taken in colored
lighting or some other situation that altered the color tone in
the image. Using a mix of the other two channels, you can
add more detail to channels that are lacking.

The Channel Mixer allows you to enter negative percentage
values. Negative values have the opposite effect of positive
values. They take the percentage of the value of the channel
and subtract that from the overall level in the output channel.

Caution

The Channel Mixer allows you to use any combination
percentage values of –200 percent to 200 percent for each
source channel. That means you can end up with a total
percentage that is not 100 percent. If you change the values
such that the total does not equal 100 percent, the overall
tonal content of the image is altered. This typically is not a
desired result.
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Swapping colors

A great way to apply a special effect in an image is to
completely swap color channels. This has the effect of
changing the look of the entire image without altering the
actual detail in the image. The effect changes, depending on
the color channels that you swap and the content of the
channels in the image.

To swap colors in an image, follow these steps:

1. Choose Image⇒Adjustments⇒Channel Mixer from the
main menu bar to launch the Channel Mixer, shown in
Figure 11.3.

2. Set the Output Channel to Red.

3. Change the value of the Red channel to 0 percent.

4. Change the value of the Blue channel to 100 percent.

FIGURE 11.3

Changing the Red channel to 100-percent blue and the Blue
channel to 100-percent red
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5. Set the Output Channel to Blue.

6. Change the value of the Red channel to 100 percent.

7. Change the value of the Blue channel to 0 percent.

8. Click OK.

The Red and Blue color channels are swapped in the image.
The result is that the red tones are changed to blue, and vice
versa, as shown in Figure 11.4. Although you cannot see the
full effect on the image in Figure 11.4, you can go to this
book's website and follow these steps to see the results.

On the Web

You can find the image shown in Figure 11.4 on this book's
website as Figure 11.4.jpg. You can open it in Photoshop
and use the steps in this section to see the changes when you
swap the blue and red color channels. As another
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experiment, you could try to swap the green and red color
channels.

FIGURE 11.4

Swapping the Red and Blue channels results in a complete
change to the color tones in an image, which can create some
fantastic effects.

Converting color to grayscale

The most common use of the Channel Mixer is to prepare
images to be converted to grayscale. When you convert an
image to grayscale, Photoshop uses 40 percent of the red and
green channels and 20 percent of the blue channel. For
general purposes, those values have produced the best results.
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The Channel Mixer gives you complete control over how
much of each channel it applies to the output when converting
a color image into grayscale. Use these steps to convert an
image to grayscale with the Channel Mixer:

1. Open the image in Photoshop, as shown in Figure 11.5.

2. Choose Image⇒Adjustments⇒Channel Mixer from the
main menu bar to launch the Channel Mixer.

FIGURE 11.5

A color image to be converted to grayscale using the Channel
Mixer
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3. Check the Monochrome check box.

This changes the output channel to Gray. The Red and Green
source channels are set to 40 percent and the Blue channel is
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set to 20 percent, as shown in Figure 11.6. The image will be
converted to a monochrome grayscale. The image results of
the default values are not very appealing, as shown in Figure
11.6.

4. Adjust the Red slider, which has the effect of adjusting
the red levels in the image.

In this example, we changed the value to 0 percent, as shown
in Figure 11.7.

5. Adjust the Green slider, which also has the effect of
adjusting the image, but in this case, it reveals a different
set of detail in the green levels.

In this example, we changed the value to 110 percent, as
shown in Figure 11.7.

6. Adjust the Blue slider, which has the effect of adjusting
the blue levels in the image, bringing back some of the
detail lost from increasing the red and green channels.

In this example, we left the value at 20 percent, as shown in
Figure 11.7.

FIGURE 11.6

The initial results of selecting the Monochrome check box are
somewhat disappointing.
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7. Click OK to apply the Channel Mixer settings to the
image, as shown in Figure 11.7.

The results create much better contrast and tone than with the
default values in Figure 11.6. The values you choose in the
Channel Mixer will vary greatly between different images.
You will want to play with the sliders, trying different values
while previewing the results in the images.

8. After you have applied the Channel Mixer settings,
choose Image⇒Mode ? Grayscale to convert the color
model of the image to Grayscale.

Note
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You can also choose Image⇒Mode⇒Grayscale or
Image⇒Adjustments⇒Black & White from the menu to
convert the image to grayscale. You do not need to use the
Black and White adjustment tool because the channels have
already been adjusted. The Black and White adjustment tool
(which we discuss in Chapter 12) is a bit simpler than using
the Channel Mixer, but you may get better results using the
Channel Mixer method.

FIGURE 11.7

The results of using custom values in the Channel Mixer to
create the Grayscale channel are much better than those with
the default settings.
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On the Web

You can find the image shown in Figure 11.5 on this book's
website as Figure 11.5.jpg. You can open it in Photoshop
and use the steps in this section to see the effects of mixing
the channels to create a better grayscale image.

Using the Channels Panel

The Channels panel provides access to all the channels
contained in an image. It allows you to look at each color
channel in the image separately. Using the Channels panel,
you can also create spot channels as well as split, duplicate,
and merge color channels.

To open the Channels panel, shown in Figure 11.8, choose
Window⇒Channels from the main menu bar or use the F7
shortcut key and select the Channels tab.

Note

When working with RGB and CMYK images, the top entry
in the Channels panel is a composite channel of the RGB or
CMYK channels. When you select the composite channel,
all the component channels are selected.

Using the Channels panel, you can view and select individual
channels, remove channels, and create new channels. The
following sections discuss using the Channels panel to work
with the color channels in an image.
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FIGURE 11.8

The Channels panel allows you to manage individual color
channels in images.

Selecting channels

A useful feature of the Channels panel is the ability to select
one or more of the channels individually. When you only
select one channel, changes that you make by drawing,
erasing, and applying filters are made to just that channel.
This allows you to create special effects on specific channels
or to fine-tune adjustments to a single channel.
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You can select channels in the Channels panel by clicking
them with the mouse or by pressing the Ctrl+#/ +# key
sequence listed next to the channel name. When you select
the composite channel (RGB or CMYK), the image display
shows the results of all three channels. When you select an
individual channel, the image display shows a grayscale
rendition of the levels of the selected channel. To select
multiple channels, use the Ctrl/ or Shift keys. When you
select multiple channels, the image display shows the results
of the combined channels.

You can also specify whether a channel is visible by clicking
the Visibility button next to the channel in the Channels
panel. When the eye icon is displayed in the box, the channel
is visible in the image display. When the eye icon is not
displayed in the box, the channel data is not used to render the
image display.

Deleting channels

You can delete a channel from an image by selecting the
channel in the Channels panel and then clicking the trash icon
(refer to Figure 11.8). When you delete a channel, the level
data contained in that channel is removed from the image.

When you delete one of the component channels from an
RGB or CMYK image, the composite channel is also
removed and the color mode of the image changes to
Multichannel. Typically, you only delete channels that you
add to an image, such as an alpha channel or a spot channel.

Duplicating channels
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A useful feature of the Channels panel is the ability to quickly
duplicate one of the existing channels. This allows a lot of
flexibility when editing channels. After you duplicate the
channel, you can make adjustments to the duplicate channel
and simply change the visibility between the duplicate and the
original to see the different effects. You can also use this
feature to save a channel as another document.

To create a duplicate of an existing channel, right-click the
channel in the Channels panel and select Duplicate Channel
from the drop-down list. A dialog box similar to the one in
Figure 11.9 appears. You can specify the following settings
when duplicating a channel:

• As. This is the name of the channel.

• Document. This selects the document where the duplicate
channel will be added. Document defaults to the current
image file; however, you can select any open document or a
new file.

• Name. This specifies the name of the new file if you set
Document to new.

• Invert. This creates a completely inverted copy of the
original channel. The lighter areas of the copy are dark, and
vice versa.

Figure 11.9

Creating a duplicate channel in Photoshop
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Splitting and merging channels

Photoshop also provides the ability to split the channels
contained in an image into separate document files. This is
useful when you want to apply a lot of adjustments to the
individual channels and then merge them later.

To split the channels of an existing image into multiple
documents, select Split Channels from the Channels panel
menu (refer to Figure 11.8). The current document is replaced
by a set of documents representing each channel in the image,
as shown in Figure 11.10. You can then edit and save each
channel separately.

Figure 11.10

Splitting color channels of an image results in a new set of
grayscale documents being created, each containing the data
from a separate channel. The filenames are the same as the
original, with an additional letter denoting the channel.
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To merge the channels back into a color image, select Merge
Channels from the Channels panel menu. A Merge Channels
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dialog box similar to the one shown in Figure 11.11 appears,
allowing you to specify the color mode and number of
channels to be included in the new color image. Click OK to
open the Merge Mode Channels dialog box (where Mode is
the color mode you are creating), also shown in Figure 11.11.
This dialog box allows you to specify which files to use for
each channel of the specified color mode when creating the
color image.

Figure 11.11

Merging multiple grayscale images back into a color image
using the Merge Channels feature

Note

The images that you want to merge into a color image must
be monotone images. They must also be open in Photoshop
for the Merge Channels option to be active.

Sharing channels between images

Photoshop makes it extremely easy to share channels between
images. This is useful when you need to move channel data
between documents.
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To move a channel between two documents, simply select the
channel in the Channels panel and drag it to another image, as
shown in Figure 11.12. A new alpha channel is created in the
second image. The contents of the alpha channel are the
levels from the selected channel in the original image.

Figure 11.12

You can share channels between documents in Photoshop by
selecting a channel from the Channels panel in one document
and then dragging it into another document.

Making Channel Selections

One of the major advantages of having access to the separate
channels in Photoshop is the enhanced ability to make
selections. Because each channel provides a different aspect
into the detail of the image, each channel has different
contrast in relation to each part of the image.

Because you can select each channel individually, you can
use individual channels to make different selections in the
image. For example, when you want to select a specific item
in the image, you can use the color channel that provides the
greatest contrast around the edges of that item.
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This example illustrates how to use channels to make better
selections:

1. Open the image in Photoshop, as shown in Figure 11.13.

2. Choose Window⇒Channels to open the Channels
panel.

3. After the Channels panel is open, view each channel
individually.

4. Select the channel that provides the best contrast for
the selection you want to make.

In this example, the first selection you want to make is that of
the rock the boys are standing on. Notice from Figure 11.14
that the red channel provides the best contrast between the
rock and the rest of the image.

Figure 11.13

Selecting the rock and the sky in this image will be easy using
the Channels panel.

745



Figure 11.14

Each channel has different contrast levels, allowing some to
be better for selecting certain objects than others.

746



5. Use a selection tool to create the selection.

In this example, we used the Quick selection tool, discussed
in Chapter 9, to draw across the center of the rock, so it is
selected as shown in Figure 11.15.

6. Click the Save Selection as Channel button to save the
selection as an alpha channel, also shown in Figure 11.15.

Figure 11.15

Selecting the rock in the red channel is easy with the Quick
selection tool because of the higher contrast.
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Next you want to select the sky in the background. Notice
from Figure 11.14 that the blue channel provides the best
contrast around the edges of the sky. So you want to select the
blue channel this time.

7. Use the selection tool to create another selection.

In this example, we used the Quick selection tool to draw
across the sky and pick up the edges around the boys to create
the selection shown in Figure 11.16.

8. Again click the Save Selection as Channel button to
save the selection as an alpha channel.

Figure 11.16

Selecting the sky in the blue channel is easy with the Quick
selection tool because of the higher contrast.
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Using the channel method, you create the two selections more
easily than if you were using the composite RGB channel.
The resulting selections are now channels that you can use as
needed for further editing, as shown in the Channels panel in
Figure 11.17.

Figure 11.17

The newly created selections are added as alpha channels in
the Channels panel.
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On the Web

You can find the project file used in this example on this
book's website as Figure 11.17.psd. You can open it in
Photoshop and practice creating selections using different
color channels.

Understanding the Alpha Channel

You can store a selection in an additional channel called an
alpha channel. The alpha channel describes additional
information used when processing the actual pixel data. The
alpha channel does not provide any data about the color
content of a pixel, but rather how to process the data.

The main purpose of the alpha channel is to provide
transparency information that you can apply to an image. As
with the other channels, each pixel in the alpha channel can
have a value from 0 to 255 where 0 represents that the pixel is
100-percent transparent and 255 represents that the pixel is
100-percent opaque.

Another useful feature of alpha channels is that you can use
them to store and retrieve selections for later use. The alpha
channels allow quick access to previous selections, and you
can even share alpha channels between documents by
dragging them from one document to another.

Creating alpha channels
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Alpha channels are created from selections. The simplest way
to create an alpha channel is to make a selection and then save
the selection as an alpha channel using these steps:

1. Open an image in Photoshop.

2. Choose Window⇒Channels from the main menu bar to
open the Channels panel.

3. Select an area of the photo that you want to use for
alpha channel data, as shown in Figure 11.18.

4. Click the Save Selection as Channel button in the
Channels panel, to convert the selection to an alpha
channel.

5. An alpha channel is created containing the current
selection.

Figure 11.18

Selecting the sky in an image and converting it to an alpha
channel
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On the Web

You can find the project file used in this example on this
book's website as Figure 11.17.psd. You can open it in
Photoshop and play around with the alpha channels using
different color channels.

Loading selections from alpha channels

One of the best features of alpha channels is the ability to
retrieve the selection information used to create them. This
allows you to work with several selections in one or multiple
files without having to constantly save and reload them.

You can retrieve selection data from an alpha channel by
selecting the channel in the Channels panel and clicking the
Load Channel as Selection button at the bottom of the panel.
This clears the current selection if there is one and creates a

752



new selection from the selection data in the selected alpha
channel.

Modifying alpha channels

A great thing about alpha channels is that they are actually
channels with real data that you can adjust using filters and
painting tools. This allows you to modify the alpha channel in
a variety of ways. One of the easiest ways is to simply use a
paint tool to paint directly on the channel.

The following example uses the paint tool to quickly modify
the existing alpha channel created in the preceding section:

1. Select the alpha channel in the Channels panel.

The image display shows the alpha channel, as shown in
Figure 11.19.

2. Select the Brush tool from the Toolbox.

3. Change the foreground color to white.

4. Use the Brush tool to paint white over any pixels that
you would like to include in the selection.

In the example in Figure 11.19, we have removed the boy on
the right.

Figure 11.19
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Modifying the content of an alpha channel is as simple as
painting away the areas of the channel that you want to
exclude or painting in the areas that you want to include.

Understanding alpha channels versus layer masks

A layer mask is similar to an alpha channel; in fact, when you
link a layer mask to a layer, the layer mask appears in the
Channels panel. However, a layer mask applies to a specific
layer in an image with multiple layers and not the entire
image. The alpha channel applies as a separate channel to the
entire image.

The difference between alpha channels and layer masks is
most apparent when you are viewing an image in Photoshop.
When you create an alpha channel, the view doesn't change,
as you can see in Figure 11.20. However, when you create a
layer mask using the same selection, the pixels in the layer
mask are masked from the layer and from the image view, as
shown in Figure 11.20.

Note

When you save a file in a format that supports alpha
channels, the alpha channel data is stored as a separate
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channel and does not affect the pixel values in the rest of the
channels. When you save a file with layer masks, the layer
mask is flattened and the pixels in the channels of the image
are altered.

Changing the channel options for alpha channels

You can change what the data contained in the alpha channel
means by setting the channel options. You can name the
channel and specify the display color and opacity, as well as
what the color indicates.

You set the channel options by selecting Channel Options
from the Channels panel menu to display the Channel Options
dialog box, shown in Figure 11.21. From the Channel Options
dialog box, you can set the following channel options:

• Name. This allows you to select a name that appears in the
Channels panel for this channel. It's useful if you are working
with several alpha channels.

• Masked Areas. This option highlights the masked areas
with the overlay color selected in the Color field. This helps
when determining the nature of the selection. Use this option
when you want to see the actual pixels of the data that is not
being affected by the alpha channel.

• Selected Areas. This option highlights the selected areas
with the overlay color selected in the Color field. Use this
option when you want to display a color field over the pixels
of the data that is being affected by the alpha channel.
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• Spot Color. This option converts the alpha channel into a
spot color channel and changes the Opacity option to a
Solidity option. We discuss spot colors in the next section.

• Color. This specifies the color of the channel overlay. The
overlay appears in the document window when the alpha
channel visibility is on in the Channels panel. This allows you
to more easily view the alpha channel selection because either
the selection or the mask is overlaid with the specified color.
When you click the color, a color chooser window appears,
allowing you to specify the color.

• Opacity. This specifies the opacity of the overlay channel.
Turning up the opacity allows you to more clearly see the
pixels behind the overlay. You may need to play around with
this setting to see enough of the background image to
determine the exact selection.

• Solidity. This replaces the Opacity setting when you select
the Spot Color option. It allows you to specify the solidity of
the spot color channel. Turning up the solidity adjusts how
much tint of the spot color is applied to the image or other
channels when merged with the spot color channel.

Figure 11.20

When you add a layer mask to a document, the representation
of the pixels in the layer is altered, but when you add an alpha
channel to a document, the pixels in the other channels are not
altered.
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Figure 11.21
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Setting the alpha channel options allows you to specify the
color of the overlay and whether the selection or the mask is
overlaid with color when the alpha channel is visible.

Using Spot Color Channels

Spot colors are used for offset printing. A spot color is simply
a single color that is impressed on the paper in a single pass
through the printer. Offset printing is the process of printing
in multiple passes using one spot color per pass.

You use spot colors when printing images for two reasons.
First, it is much less expensive to use spot colors when
printing than mixing the standard CMYK inks to create the
colors needed. Second, you may want to add a color to your
image that cannot be created using a mix of the CMYK inks.

Creating a spot color channel
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The process of creating a spot color channel is similar to that
of creating an alpha channel with a few extra steps. The
following steps take you through an example of creating a
spot channel:

1. Open the image in Photoshop as shown in Figure 11.22.

2. Use the Magic Wand tool to select the area of the image
that you want to turn into a spot channel.

In the case of Figure 11.22, you would want to select the dark
parts of the moon.

3. Press Ctrl+C/ +C to copy the contents of the selection
into the clipboard.

4. Choose Window⇒Channels to open the Channels
panel.

Figure 11.22

You can use a selection in an image in Photoshop to create a
spot channel.
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5. Select New Spot Channel from the Channels panel
menu to open the New Spot Channel dialog box, as shown
in Figure 11.23.

6. Click the Color field to open the Select Spot Color
dialog box.

Choose the color you want to use for the spot color. In this
case, we chose Pantone 289 C.

7. Set the Solidity of the spot color.

In this example, we used 50 percent.
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Figure 11.23

When creating a spot channel, you need to specify the color
and solidity to use for the ink tone.

8. Click OK to create the spot color channel.

The new channel appears in the Channels panel, as shown in
Figure 11.24.

Figure 11.24

The spot channel is created from the selection; however, it is
a solid spot channel with no detail.
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9. Select the new spot channel in the Channels panel.

10. Click the Load Channel as Selection button in the
Channels panel to load the selection used to create the
spot channel.

11. Press Ctrl+V/ +V to paste the contents saved to the
clipboard into the spot channel.

The spot channel becomes a tonal spot channel, shown in
Figure 11.25, instead of a solid. When printed, the spot color
selected in Step 6 is used to print the pixels in that area of the
image.

Figure 11.25
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Pasting the contents of the original selection into the spot
channel selection creates a tonal spot channel that can print
the detail in a single ink color.

Merging spot color channels

You can merge a spot channel into the rest of the image. The
solidity value of the spot channel determines how much of the
spot channel ink is applied to the pixels in the image. To
merge the spot channel with the background data in an image,
select Merge Spot Channel from the Channels panel menu.

Caution
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Merging the spot channel flattens the spot channel layer into
the rest of the image. The spot channel no longer exists, so
you cannot get the selection back or alter the color.

Removing ink overlap using spot color channels

When printing spot colors, you need to be careful that ink
from the image content does not overlap the ink from the spot
colors. Overlapping image content and spot colors results in
ink mixing, which typically is not a desired result.

To prevent the colors from overlapping, you need to create a
knockout, a transparent area of artwork revealing the contents
from other layers. You can achieve this by setting the
background color to white and deleting all pixels in the image
content under the spot color so the spot color ink is the only
ink printed on that part of the paper.

Using a knockout can create another problem. Because there
is no ink beneath the knockout, a white border may appear
around the spot color if the ink doesn't print perfectly. To
solve this problem, you can create a trap between the spot
color and the image content, shrinking the selection of the
spot color by 1 pixel. This allows each of the spot colors to
bleed slightly into the image content and eliminate the white
border.

Note

764



Trapping is a prepress technique that involves creating small
overlaps between adjacent colors in an image. Trapping
allows the colors to bleed together to avoid white outlines
that can occur because of misalignment when printing.

Follow these steps to create a knockout and trap to prevent
spot colors from overlapping:

1. Create a spot channel as described earlier in this
chapter.

2. Select the spot channel in the Channels panel.

3. Click the Load Channel as Selection button to create
the selection of the channel.

4. Click the composite channel for the image in the
Channels panel.

The selection is now visible in the composite channel of the
image.

5. Set the background color to white.

White means that no ink will be printed on that part of the
paper.

6. Create the trap by choosing Select⇒Modify⇒Contract
to open the Contract Selection dialog box.

7. Set the Contract By option to 1 pixel.
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This allows the spot channel to overlap onto the image
content so the inks overlap, eliminating the possibility of a
white border between the two.

8. Create the knockout by pressing the Delete key to delete
the image content beneath the spot color.

If the Fill dialog box appears instead of just deleting the
pixels, select white and click OK.

Summary

In this chapter we discussed using the Channel Mixer to have
direct access to mixing, swapping, and combining the color
data in your images. Using the Channel Mixer allows you to
change the color composition without changing the original
detail in the image.

We also discussed how to use the Channels panel to view and
manage channels, including alpha channels and spot color
channels. Alpha channels are not color channels; instead, they
contain information, such as transparency information, about
certain areas of an image. Spot colors are used when printing
specific colors in passes rather than a mix using the standard
CMYK inks.

In this chapter, you learned the following:

• How to mix the color channels to create a better grayscale
conversion

• That swapping two color channels can drastically change the
look of an image without affecting the detail
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• That you can split channels into multiple monotone
documents, edit them, and then merge them back into a single
color image

• How to share channels between multiple images

• That alpha channels can be created from a selection

• How to use alpha channels to store and retrieve selection
data

• How to effectively create spot color channels that can be
used in offset printing
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Part IV: Enhancing, Correcting, and Retouching Images

IN THIS PART

Chapter 12

Optimizing Adjustment Workflow

Chapter 13

Making Lighting and Color Adjustments

Chapter 14

Applying Sharpness, Blur, and Noise Adjustments

Chapter 15

Cleaning Up Digital Images with Cloning and Healing Tools
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Chapter 12: Optimizing Adjustment Workflow

In This Chapter

Optimizing adjustment workflow

Making quick-fixes with auto adjustments

Creating non-destructive and easy-to-edit adjustment layers

Using the Properties panel to make adjustments

Every edit you make to your photo alters the pixels, reducing
the quality and increasing the possibility of bruising —
creating visible areas of pixel distortion. Even if you make
your edits using non-destructive layers, the visible end result
is the same. Some adjustments are more destructive than
others, so creating a workflow that takes you from the least
destructive to the most destructive is a very important step in
achieving the best results possible.

As you add adjustments to your image, the fastest and most
efficient way to do so is by using the Adjustment panel. You
can use icons for a quick-click to add and edit adjustments
without having to open and select adjustments from a menu.
Photoshop adds the adjustments that you apply from the
Adjustment panel as non-destructive adjustment layers.

This chapter explains the importance of workflow and
introduces you to the Adjustment panel.

Understanding Workflow
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Using an organized workflow to edit your images is the best
way to make non-destructive edits. It is a good organizational
habit to get into, so you aren't inadvertently skipping
important steps when correcting your photos.

Not all images need the same amount of editing, but you'll
want to follow the same order for each one, skipping steps
when they aren't required. Here's a good workflow to follow:

1. Correct your photos in Camera Raw.

Whether your photos are RAW images, TIFFs, or JPEGs, you
can open them in Camera Raw, make relatively quick,
non-destructive changes to them, and then save them or open
them in Photoshop. Follow the same workflow in Camera
Raw as in Photoshop to create your edits.

Note

If you open a JPEG in Camera Raw and make changes to it,
you must save it as a TIFF, PSD, or DNG file to preserve
the metadata and keep the edits non-destructive. After you
save your changes to a JPEG file, they become part of the
image and you cannot reverse them.

2. Open your image in Photoshop.

Whether you are coming from Bridge, Camera Raw, or
another program, the following steps require you to edit your
image in Photoshop.
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3. Crop, straighten, and resize your photo.

UNL1ess you want several different aspect ratios (such as 4 ×
6 and 8 × 10), you should crop your photo strictly to the area
you want.

4. Correct overall lighting.

Correcting the lighting in your image is usually instrumental
in correcting the color, so you should always do this first.

5. Correct the overall color.

If you correct the lighting and there is still a colorcast to your
image, now is the time to correct it. This is also the time to
make overall color changes, such as transforming your photo
to black and white or adding a lens filter to warm or cool the
photo. After you've corrected both lighting and color in your
image, it should look pretty good, with lighting and color at
the best settings and eveNL1y distributed across the image.
Now you are ready to make targeted adjustments.

6. Clean the unwanted elements out of your photo using
the Clone Stamp and Healing Brushes.

While your lighting and color are still uniform, you want to
clean up scratches, lens spots, blemishes, or stray elements in
your photo that distract from the subject. These tools in
Photoshop are fantastic and create realistic results, although
they can still cause visible areas of pixel distortion.

7. Combine images.
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If you are combining two or more images to create a collage
or special effect, now is the time to do it. If you are using the
Clone Stamp tool to create head swaps or otherwise add
elements from one photo to another, you want to make sure
the lighting and color are as uniform between the two images
as possible before you begin. This makes the next step much
easier.

8. Make targeted lighting adjustments.

When your image is uniformly correct, you can start to
improve areas in the image that are still not ideal, such as an
overexposed sky. You can make these adjustments by
creating a selection or mask so the adjustments are applied
oNL1y to the targeted area. This is where you need to be
careful with how you apply the adjustments by watching
edges for halos, hardness, or aberrations that prevent your
changes from looking natural.

9. Make targeted color adjustments.

As with lighting, some areas of your image may need a
targeted color correction. You may also want to create a color
effect, such as oversaturating areas of your photo or creating a
black-and-white photo with color accents.

10. Add filters or layer styles to create artistic effects.

Now that your image is put together and the lighting and
color are just right, you can add layer styles and filters to
create amazing images to your heart's content. You can add
these effects to your entire image or to targeted areas. These
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changes dramatically alter the pixels in an image or selected
areas, so again watch your edges.

11. Reduce noise and sharpen your image.

Because each previous change can create noise and distort
sharpness to further decrease image quality, these changes
should be the last you make.

12. Prepare your image for output.

Whether you are preparing your image to be printed or
exported to the web, you want to adjust your color settings
accordingly and save it in the correct format.

Making Auto Adjustments

Before you start making your own adjustments, you should
know that Photoshop can make several adjustments for you.
These adjustments are great for quick fixes on photos that you
don't want to spend a lot of time on. If you are new to
Photoshop, they are a great way to get started on your own
adjustments. Three auto adjustments are available in the
Image menu: Auto Tone, Auto Contrast, and Auto Color.
Auto buttons are also available in the Levels, Curves, and
Black and White dialog boxes.

An auto adjustment is an algorithm that uses the brightness
values in an image to take a best guess at the adjustment you
are applying. Although auto adjustments are frequently better
than the original image, they are rarely the best possible
settings to use.
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You can customize the way that the auto color corrections are
applied to your image for the best results. Choose
Image⇒Adjustments⇒Levels or
Image⇒Adjustments⇒Curves. In either the Levels or Curves
dialog box, click the Options button. This opens the Auto
Color Correction Options dialog box, as shown in Figure
12.1.

Figure 12.1

The Auto Color Correction Options dialog box

Photoshop can use four algorithms when making auto
adjustments. The Levels and Curves adjustments can use any
one of these algorithms, and you specify which one in the
Auto Color Correction Options dialog box. You can choose
from the following options:
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• Enhance Monochromatic Contrast. This is the algorithm
used to set the Auto Contrast. It enhances shadows and
highlights by increasing the contrast in the midtones of an
image, clipping the color channels uniformly. This preserves
the color integrity, but although it doesn't introduce a
colorcast, it doesn't remove one either (an important element
of both the Levels and Curves adjustments).

• Enhance Per Channel Contrast. This algorithm is used by
the Auto Tone adjustment. It finds the lightest and darkest
areas of each color channel and adjusts them individually to
create the most contrast of the three algorithms. Although this
adjustment may introduce colorcasts or even fringing, this is a
good setting in most cases for Levels or Curves because it
adjusts the lighting balance of each color channel.

• Find Dark & Light Colors. This algorithm is used by the
Auto Color adjustment that uses an average of the darkest and
lightest pixels in your image to create contrast with the least
amount of clipping. The Auto Color adjustment uses the Snap
Neutral Midtones option to find colors that are close to
neutral, and changes their values so they are indeed neutral,
shifting the values in the entire image to match.

• Enhance Brightness and Contrast. This option is also the
default setting. This auto adjustment searches a database for a
curve that will create the optimal brightness and contrast
across all channels — a definite improvement to the Levels
and Curves auto adjustments.

Note
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A neutral color is easy to find or create with RGB values;
each of the three values is identical.

You can also set the target colors that determine what colors
are considered highlights, midtones, and shadows. The
defaults here of .1 percent are on the high side if you are
working with images that have been scanned or taken at high
resolution with modern equipment. As a result, you might
want to change these settings to a lower number if you are
working primarily with these types of images and want to use
the Auto adjustments; .05 percent or even lower will give you
less dramatic results.

The bottom line is that you can use the Auto adjustments for a
quick fix that might actually work if you take the time to
figure out which setting is best with each individual image.
Does this sound like too much work for something that was
supposed to be easy? We think so, too. Stick to custom
adjustments; you'll have less to remember, and your images
will look better in the long run.

There are ways to create “custom” Auto
adjustments from the Curves and Levels adjustment panels as
well. You can read more about this in Chapter 13.

Creating Adjustment Layers

In addition to using the Image⇒Adjustments menu to add an
adjustment to your project, you can create adjustment layers
that are non-destructive and easy to edit. These adjustments
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appear as separate layers in the Layers panel and you can
adjust them easily using the Properties panel.

To create a new adjustment layer, click the Create new fill or
adjustment layer icon at the bottom of the Layers panel to
open the fill or adjustment layer popup menu, as shown in
Figure 12.2.

Figure 12.2

Creating an adjustment layer
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Here is a quick list of the adjustment layers that are available
to you:

• Solid Color. This launches the Color Picker dialog and
allows you to select a color. The new color will be added as
the background color of the new adjustment layer.

• Gradient. This launches the Gradient Fill dialog box that
allows you to create a gradient fill for the background in the
adjustment layer. The dialog box allows you to set the
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gradient, style, angle, scale, and other options. As you work
more with the image, you have the option of adjusting the
gradient fill by changing the settings in the adjustment layer.

• Pattern. This launches the Pattern Fill dialog box that
allows you to create a pattern fill for the background in the
adjustment layer. The dialog box allows you to select the
pattern as well as set the scale and other options.

• Brightness/Contrast. This option gives you two basic
sliders. The first slider adjusts the brightness of the image,
unilaterally enhancing or reducing the brightness of the
pixels. The second slider adjusts the contrast, changing the
value of the midtones in the image by making the tones on the
dark side 50-percent darker and the tones on the light side
50-percent lighter.

• Levels. This option allows you to adjust the levels of the
brightness values in your file by adding a Levels layer. As
you choose the Levels option, you see a histogram that
represents the brightness values found in your file. By
adjusting the sliders, you can increase (or decrease) the
darkness of your darkest pixels or increase (or decrease) the
brightness of your brightest pixels. You can do this in all the
color channels together or in each one individually.

• Curves. This option allows you to add up to 14 points along
the tonal range from shadows to highlights. The dialog box
also includes a preset menu to give you a jumping-off point.

• Exposure. This option is meant to correct exposure
problems in your image. Change the Exposure, Offset, and
Gamma Correction settings to give your file highlights or
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dark tones similar to overexposing or underexposing a
picture.

• Vibrance. This option works selectively to saturate areas of
your image that have less color while leaving already
saturated areas alone.

• Hue/Saturation. This option allows you to change the hue,
saturation, or lightness of the individual or all color channels
contained in your file. You can use a drop-down menu to
choose a color range or use the eyedropper to customize the
color you change.

• Color Balance. This option opens the Color Balance panel.
You can change the levels of the color channels in your file
using the Highlights, Midtones, or Shadows settings. This is
the easiest way to affect individual colors directly in your file.

• Black & White. This option gives you the most power in
creating a black-and-white image from a color photo. The
Black & White adjustment includes options that let you set
the levels of the colors in your image so that they are mapped
to the grayscale values that you choose.

• Photo Filter. This option mimics using a photo filter on
your camera. You can use one of 20 preset filters or change
the color of the filter using the Select Filter Color dialog box.

• Channel Mixer. This option lets you adjust the color levels
in each channel separately. A drop-down menu gives you
several preset options. Learn more about the Channel Mixer
in Chapter 11.
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• Color Lookup. This option allows you to create a selection,
turn it into a mask, and modify that mask in different ways by
changing the transparency, feathering the edges, or creating a
color range selection.

• Invert. This option changes all the colors in your file to
their exact opposite, creating a negative image. The Invert
adjustment doesn't have any panel controls; it simply changes
every color to 255 minus its original value.

• Posterize. This option allows you to change the color
brightness range in your image from 2 to the full 255. When
you set the levels at a low range, you reduce the number of
colors used in the image, giving the colors a banded look.

• Threshold. This option changes your file into a true
black-and-white image — not grayscale. The dialog box
contains a slider that allows you to set the Threshold level.
Every color above that brightness level is changed to white,
and every color below that level becomes black. Although it
doesn't make your image look very good, it is ideal for
finding the brightest and darkest values of the image. This
helps you choose settings for many of the other adjustments.

• Gradient Map. This option takes a gradient and uses the
lowest tones of the gradient to replace the darkest tones of
your file, the highest tones of the gradient to replace the
lightest tones, and the mid-tones of the gradient to replace
everything in between.

• Selective Color. This option allows you to change the level
of colors individually. Choose from nine color options in the
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drop-down menu, and change the CMYK sliders to adjust the
selected color.

Note

The Solid Color, Gradient, and Pattern options are fill
layers, not adjustment layers.

When you click any one of these Adjustment menu options,
Photoshop creates an adjustment layer above the selected
layer in your Layers panel, and the Properties panel changes
to display the settings for that adjustment, as shown in Figure
12.3. To edit any one of your adjustment layers, select it in
the Layers panel and the settings reappear in the Properties
panel, allowing you to adjust them.

Figure 12.3

Choosing Levels from the fill and adjustment layer popup
menu creates a Levels adjustment layer and opens the Levels
settings in the Properties panel.
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Making Adjustments Using the Properties Panel

By default, the Properties panel is docked just above the
Layers panel in the Photoshop workspace. When you select a
layer in the Layers panel, the Properties panel changes to
reflect the properties of that layer. For example, when you
select a Levels adjustment layer, the Properties panel displays
the Levels adjustment options.

When the Properties panel displays an adjustment, new icons
appear on the bottom of the panel, as shown in Figure 12.4.
You can reset the adjustment to the default settings, toggle the
visibility, or return the adjustment to the previous state.

Figure 12.4
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New icons appear in the Properties panel when an adjustment
layer is highlighted.

You can also choose to clip the adjustment to the layer below
it. Generally, when you add a layer to the Layers panel, it
affects all the layers below it, but if you want your adjustment
to affect only one layer below, you can click the Clip
adjustment to layer below icon. You know that your
adjustment layers are clipped to the layer below them because
they look like the layers in Figure 12.5, with an arrow added
to the adjustment layer pointing to the layer below. The layer
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that is being affected by the adjustment has an underlined
name.

Figure 12.5

An adjustment layer that has been clipped to the layer below
it does not affect any other layer.

Summary

This chapter introduced you to the workflow you should use
when applying adjustments, corrections, and artistic effects to
your images. It also introduced you to making both auto
adjustments and manual adjustments in the Properties panel,
so you will know how these elements work as you use them
in the following chapters.

In this chapter, you learned about:

• Workflow organization
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• Making auto adjustments

• Using the Properties panel
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Chapter 13: Making Lighting and Color Adjustments

In This Chapter

Adjusting lighting and exposure

Changing color balance

Adjusting levels in images to restore detail

Using the Curves tool

Making specific color and tone adjustments to images

Creating HDR images

The most common edit that you will perform on photos is
correcting the lighting and color. Photoshop provides a
number of tools that adjust the color and lighting in different
ways. As you become more familiar with these tools, you can
adjust problems in images such as overexposure,
underexposure, and colorcasts. You can also make minute
adjustments to images that make a big difference in their
overall appearance.

This chapter discusses most of the tools available in the
Image⇒Adjustments menu and the Adjustments panel. Many
of these tools have overlapping functionality, so you are not
locked into one specific tool to adjust an image. Try all the
tools we discuss in this chapter, and then use the tools that
work best for you.
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Note

Remember that most of the techniques you learn in this
chapter can be applied as an adjustment layer. That means
you can use a selection to create the adjustment layer and
then apply the color adjustments only to that specific area of
the image. This enables you to be much more aggressive
with the changes you make because you aren't modifying
the rest of the image.

Applying Quick Adjustments to Light and Color

Photoshop provides several tools that enable you to make
quick adjustments to the lighting and color in an image. In the
background, these tools are simply adjusting the level values
in the color channels of the image. However, these tools
provide a nice interface where you can adjust them in specific
ways. We like to think of the adjustment tools as “canned”
solutions to simple color and lighting issues.

The following sections discuss using the Photoshop
adjustment tools to fix lighting and color problems, and
making subtle adjustments that enhance the appearance of
photos. These tools work well for most of the problems you
will encounter in images. Later in this chapter, we discuss
using the Levels and Curves tools to make adjustments that
are more complex.

Adjusting brightness and contrast versus exposure
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One of the most common problems you may encounter with
photos is that they are either too dark or too light due to
lighting or exposure problems. Photoshop provides two tools
to fix lighting problems quickly in your images: the
Brightness/Contrast tool and the Exposure tool.

To understand how these tools work, you must first look at
the reason why a photo is too dark or too light. Photos are too
dark because the camera did not receive enough light, which
was a result of either the aperture being too small or the
exposure time being too short. The end result is that too many
pixels are in the low levels of all color channels, making the
image dark with limited details. The opposite is true for
photos that are too light.

You can use both the Brightness/Contrast tool and the
Exposure tool to correct photos that have been overexposed
or underexposed. However, they work a bit differently and
produce different results.

The biggest difference between the two tools is that the
Brightness/Contrast tool works with the color space that
exists in the image and the Exposure tool works with a linear
color space called gamma 1.0. Because the Exposure tool is
not limited to the current color space, it can make more
dramatic lighting corrections. The downside of the Exposure
tool is that when working outside the color space in the
image, some data loss occurs in the form of more abrupt
changes between tones.

Tip
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The Exposure tool was designed to handle HDR images
with much greater tonal ranges, even though it does work
with 8-bit and 16-bit images. A good rule to follow is to use
the Brightness/Contrast tool when working with 8-bit
images and the Exposure tool when working with HDR
images. Then, if you can't get the lighting correction you
need with the Brightness/Contrast tool, you can use the
Exposure tool to get a better result.

Using the Brightness/Contrast tool to adjust lighting

The Brightness/Contrast tool enables you to adjust both the
brightness and contrast levels in an image. The Brightness/
Contrast tool options are as follows:

• Brightness. Adjusting the Brightness slider to the right
increases the level values of all color channels in an image,
making the image lighter. Adjusting the slider to the left
decreases the level values of all color channels in an image,
making the image darker.

• Contrast. Adjusting the Contrast slider to the right spreads
the level values out, which generates more contrast in the
image. Adjusting the slider to the left contracts the level
values more tightly, giving less contrast.

Typically, to correct an image that is underexposed, you need
to increase the brightness first and then increase the contrast
to bring back some of the detail lost by increasing the
brightness. To correct an image that is overexposed, you need
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to decrease the brightness and then increase the contrast to
bring back the detail.

Figure 13.1 shows the effects of adjusting the brightness and
contrast in a photo that was underexposed. Notice that by
increasing the brightness and contrast, you can see more
detail in the photo.

On the Web

You can find the image shown in Figure 13.1 on this book's
website as Figure 13.1.psd. Open it in Photoshop and try
adjusting the brightness and contrast.

Using the Exposure tool to adjust lighting

The Exposure tool enables you to adjust the exposure values
of an image, increasing or decreasing the lighting and
contrast. This tool enables you to set the following values:

• Preset. This menu enables you to select from a list of
predefined Exposure tool settings.

• Exposure. This slider adjusts the highlight end of the tonal
scale. Adjusting the exposure to the right lightens the lighter
pixels. Adjusting the exposure to the left darkens the lighter
pixels. This setting has only a minimal effect on the darkest
pixels of the image.

• Offset. This slider adjusts the darker and middle end of the
tonal scale. Adjusting the offset to the right lightens the
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darker pixels. Adjusting the offset to the left darkens the
midtone and darker pixels. This setting has only a minimal
effect on the lightest pixels of the image.

• Gamma Correction. This slider applies gamma correction
to the image. Adjusting the gamma value to the left (between
0 and 1) darkens the image and adjusting the gamma value to
the right (between 1 and 10) lightens the image.

• Black eyedropper. This option enables you to select a pixel
in the image. Photoshop adjusts the Offset value by setting
the selected pixel to zero.

• White eyedropper. This option enables you to select a pixel
in the image. Photoshop adjusts the Exposure value by setting
the selected pixel to white. White is 1.0 for HDR images and
0.0 for non-HDR images.

• Midtone eyedropper. This option enables you to select a
pixel in the image. Photoshop adjusts the Exposure value by
setting the selected pixel to midtone gray.

Figure 13.1

Increasing the brightness and contrast in an underexposed
image reveals more of the detail.
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Note

You can also select a preset exposure value of –1.0, –2.0,
+1.0, +2.0, or a custom value from the Exposure drop-down
list shown in Figure 13.3. This enables you to create a
custom exposure setting that you can save using the Save
Exposure Preset option in the Adjustments panel menu. You

793



can then apply the custom exposure to several different
images that have the same exposure problems.

Follow these steps to use the Exposure tool to adjust the
lighting and contrast of an image in Photoshop:

1. Choose Window⇒Adjustments from the main menu
bar to load the Adjustments panel shown in Figure 13.2.

2. Click the Exposure button (see Figure 13.2) to add an
Exposure adjustment layer to the image.

Figure 13.2

Click the Exposure button in the Adjustments panel

The Properties dialog box opens, enabling you to adjust the
exposure settings.

3. Try to use the eyedroppers to set a baseline for setting
the exposure.
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Use the black eyedropper to select a pixel in the image that
should be black, the white eyedropper to select a white pixel,
and the midtone eyedropper to select a gray pixel. On many
photos, the eyedroppers simply don't work. If they don't work,
just move to the next step.

4. Adjust the Exposure to get the overall light pixels in the
image to show as much detail as possible.

Don't worry if the image looks faded at this point.

5. Adjust the Offset, typically in the opposite direction
than you adjusted the Exposure, until the image is less
faded.

6. Adjust the Gamma Correction to lighten or darken the
image until you are satisfied with the result.

7. Tweak the Exposure, Offset, and Gamma Correction
settings until you get the best overall lighting and contrast
in the image.

Figure 13.3 shows the effects of adjusting the Exposure,
Offset, and Gamma Correction settings on a photo that was
severely underexposed. Notice that increasing the Exposure
enables you to see more details in the image. However, the
image is now a bit grainy because we adjusted the values
outside the tonal range of the image.

Figure 13.3
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Increasing the Exposure and Offset in an underexposed image
using the Exposure tool reveals much more of the detail in the
image.

796



797



On the Web

You can find the image shown in Figure 13.3 on this book's
website as Figure 13.3.psd. Open it in Photoshop and try
adjusting the exposure.

Changing the color balance

The Color Balance adjustment tool enables you to adjust the
balance between each color in the color channels with its
complementary color. Changing the color balance adjusts the
overall hue of the color channel. This enables you to quickly
fix a single color that is out of balance or adjust all the colors
in the image. The Color Balance Properties are as follows:

Tip

The Color Balance tool is extremely useful when you are
trying to add color to a black-and-white image. You can
select specific areas of the image and adjust the color
balance to those areas to create color tones.

• Tone. This feature of the Color Balance adjustment tool
enables you to specify whether you want to adjust the color
balance for the pixels in the highlights, midtones, or shadows
range. Separating the color balance into tonal ranges enables
you to focus on one specific tonal range, so that you can fix
the color for that range before moving on.
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• Color sliders. This feature enables you to drag the color
sliders to the left or right to adjust the balance between each
color and its complementary color. Adjusting the balance
shifts the hue of the color, for example, from red to cyan or
blue to yellow.

• Preserve Luminosity. This option specifies whether to
preserve the luminosity, which typically is the best choice.
Preserving the luminosity forces the color balance
adjustments to change so that the luminosity stays the same.
This keeps the color balance adjustments from washing out
the image.

The following example demonstrates how to use the Color
Balance adjustment tool to fix the colors in an image that has
been overwhelmed by a single tone:

1. Open the image in Photoshop shown in Figure 13.4.

The leaves of the background have really added a yellow hue
to the entire image, and none of the colors pop.

2. Choose Window⇒Adjustments to load the Adjustments
panel shown in Figure 13.5.

Figure 13.4

This image has such intense yellow in the leaves that it
dominates the other tones in the image.
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3. Click the Color Balance button shown in Figure 13.5 to
add a Color Balance adjustment layer to the image.

Figure 13.5

Adding a Color Balance adjustment layer to an image in
Photoshop

The Properties dialog box opens, enabling you to adjust the
color balance settings.

4. Select the Highlights tone, and adjust the colors until
the bright yellow of the leaves is toned down.

You'll definitely want to adjust the Yellow/Blue slider to the
right, but play with the other sliders as well until you get a
result that looks good to you. Keep in mind that you need to
adjust the midtones and shadows as well, so you may want to
come back to tweak these settings.

Don't worry at this point that the boy takes on a blue
colorcast, as you'll fix that in the following steps.
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5. Select the Midtones tone, and adjust the colors to take
out more of the yellow in the leaves.

Once again, you are reducing the yellow color, so moving the
Yellow/Blue slider to towards the blue is the most effective
adjustment you will make. Don't just look at the leaves,
however, keep an eye on the other colors in your image and
make sure they stay looking true. The skin tones can be
particularly tricky!

6. Select the Shadows tone, and adjust the colors until the
boy has a rosy hue once again.

There are very few yellowshadows, so this is the setting that
will allow us to restore some of the color to the skin tones.
You'll want to move the Yellow/Blue slider to the left toward
the yellow to warm the photo up.

7. View the resulting image as shown in Figure 13.6.

Notice that the colors are more variedpth and the boy really
stands out much better. Although the overall change has been
subtle, the eye is drawn more towards the boy and not
overwhelmed by the color of the leaves.

On the Web

You can find the image shown in Figure 13.6 on this book's
website as Figure 13.6.psd. Open it in Photoshop and see
how the adjustment makes the colors pop.
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Figure 13.6

Adjusting the color balance enables other colors to pop out of
an image that is dominated by a specific tone.

803



Making selective color adjustments
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One advantage and disadvantage of the Color Balance tool is
that it adjusts all the colors for the selected tonal range. This
is an advantage when you want to adjust all the pixels in a
tonal range uniformly. However, this presents a problem if
you want to, say, adjust only the blues in the sky without
adjusting the rest of the image.

The Selective Color adjustment tool enables you to adjust
only the tones of a specific color instead of a tonal range. This
enables you to focus on adjusting the blues, greens, or other
colors individually using the following options:

• Colors. This drop-down list enables you to select the red,
blue, green, cyan, magenta, yellow, white, black, or neutral
color tones to be adjusted. Only the color tones that fall into
the selected color are adjusted.

• Color sliders. These sliders adjust the percentage of cyan,
magenta, yellow, or black used for each color. Drag the slider
or type the percentage in the text box.

• Relative. This option tells Photoshop to use the amount of
cyan, magenta, yellow, or black based on its percentage of the
total. For example, if the total of all sliders is only 50 percent
and cyan is set to 20 percent, the actual value used for cyan is
40 percent.

• Absolute. This option tells Photoshop to use the amount of
cyan, magenta, yellow, or black based on its absolute setting,
regardless of the total. For example, if the total of all sliders is
only 50 percent and cyan is set to 20 percent, the actual value
used for cyan is still 20 percent.
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The following example demonstrates how to use the Selective
Color adjustment tool to enhance specific color tones in a
photo:

1. Open the image in Photoshop shown in Figure 13.7.

The colors in this photo were really toned down due to the
haze and the lack of a good filter on the camera.

Figure 13.7

The colors in this image are really toned down.

2. Choose Window⇒Adjustments to load the Adjustments
panel shown in Figure 13.8.

3. Click the Selective Color button shown in Figure 13.8 to
add a Selective Color adjustment layer to the image.
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The Properties dialog box opens, enabling you to adjust the
individual colors.

4. Select the Relative option shown in Figure 13.8.

This enables you to make more dramatic changes to the
colors.

5. Select Reds in the Colors drop-down list, and adjust the
Cyan slider to the left as much as possible and the
Magenta slider to the right +35 percent to bring out the
red in the rocks.

Notice that the change doesn't affect the colors in the sky.

6. Adjust the Black slider to the right 50 percent to bring
out more detail in the red rocks.

7. Select Blues in the Colors drop-down list, and adjust the
Cyan, Magenta, and Black sliders to the right +100 to give
the sky a deep blue.

Notice that the change doesn't affect the colors in the rocks.

Figure 13.8

The Selective Color adjustments in Photoshop
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8. View the resulting image shown in Figure 13.9.

Notice that the colors have much more depth. The blues and
reds now stand out much more without adding a colorcast to
the other tones.

On the Web

You can find the image shown in Figure 13.9 on this book's
website as Figure 13.9.psd. Because the book is in black and
white, you can't really see the results of the image
adjustments here. Open the file in Photoshop and see how
the Selective Color adjustment restores the reds and blues
without affecting the other colors.

Figure 13.9
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Adding a Selective Color adjustment layer to a washed-out
image and adjusting the reds and blues enables you to restore
color to the image.

Applying Photo Filter to images

Photoshop provides the Photo Filter adjustment tool to
simulate using various color lens filters on photos.
Photographers use color lens filters to correct lighting
problems or to adjust the color temperature of photos. Using
color filters can fix photos that otherwise would have a
colorcast. Using warming and cooling filters can enhance the
tones in a photo.

Using lens filters creates a couple of problems, though. One is
that because the light must pass through another medium,
there is a reduction in the light reaching the camera. The
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second problem is that the data in the photo is permanently
altered by the adjustment made by the lens filter.

The Photo Filter adjustment tool enables you to make image
adjustments that simulate what the image would have looked
like if a color filter had been used when the photo was taken.
The advantage of using Photoshop to apply the color
adjustment is that the original photo data can remain intact in
the original layer. You can also tweak the density of the filter
adjustments and try several different ones until you get it
right. You don't get a second chance using lens filters in the
field. To use the Photo Filter adjustment tool, choose
Image⇒Adjustments⇒Photo Filter to open the Photo Filter
dialog box shown in Figure 13.10.

Figure 13.10

Using the Photo Filter adjustment tool, you can simulate the
effect that using a color lens filter would have had when the
photo was taken. You can also tweak the density and color of
the filter.
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Note

Using the Photo Filter tool gives you many more options
and is easier than using actual lens filters. However, there is
no real substitute for using the appropriate lens filter on your
camera. If you know you really need to use a lens filter to
correct a lighting problem and are confident in the results,
you should use an actual filter to get a better effect than
Photoshop can provide.

Using the Photo Filter dialog box, you can make the
following adjustments:
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• Filter. This menu enables you to select from the predefined
filters, including Warming Filter (85), Warming Filter (LBA),
Warming Filter (81), Cooling Filter (80), Cooling Filter
(LBB), Cooling Filter (82), Red, Orange, Yellow, Green,
Cyan, Blue, Violet, Magenta, Sepia, Deep Red, Deep Blue,
Deep Emerald, Deep Yellow, and Underwater.

• Color. This option enables you to select a specific color
instead of a predefined filter. Clicking the Color box enables
you to use a color selector to select any of the colors that
Photoshop can produce to use as a color filter.

• Density. This slider enables you to set the density of the
color filter. A lower density has less effect on the image, but
if you use too high a density, you begin to lose detail.

• Preserve Luminosity. This option specifies whether to
preserve the luminosity, which typically is the best idea.
Preserving the luminosity forces the filter adjustments to
change such that the luminosity stays the same.

Replacing specific colors

Photoshop enables you to replace an individual color
selectively in an image with another color using the Replace
Color adjustment tool. This enables you to adjust the tone of a
specific color range or even replace it with another set of
colors. For example, you can replace a dull blue with a
brighter blue or even bright yellow without changing the
other colors in the image.

To use the Replace Color adjustment tool, choose
Image⇒Adjustments⇒Replace Color to open the Replace
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Color dialog box, shown in Figure 13.11. This dialog box
enables you to select a specific color and the tones around it
and then select a replacement color. The replacement color is
applied to the image, replacing the original color tones
without affecting any other colors.

Figure 13.11

Using the Replace Color adjustment tool, you can replace
specific colors in an image.
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The Replace Color adjustment tool enables you to adjust the
following settings:

• Localized Color Clusters. This option specifies whether to
select only color clusters that are contiguous to each other.
Using this option makes color selection more accurate when
the color is localized to one area of the image. However, if the
color is spread throughout the image, do not use this option.

• Eyedroppers. This option enables you to select colors from
the image. The plus dropper adds to the selection, while the
minus dropper removes the color from the selection. The
adjusted selection appears in the Selection view below the
eyedroppers.

• Color. This option opens a color chooser dialog box that
enables you to choose any available color in Photoshop to
replace in the image.

• Fuzziness. This slider specifies the range of tones to include
in the selection color. Low fuzziness means that only tones
close to the selected color are chosen. High fuzziness means
that a broader range of tones is included.

• Selection view. This preview window shows the selection as
white with non-selected areas of the image as black, so you
can see what areas of the image will be affected by the color
replacement.

• Selection/Image. These options enable you to toggle the
selection view between the selection and the actual image.
This helps you see how the color selection relates to the
image.
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• Hue. This slider adjusts the hue of the color that will replace
the existing color in the image.

• Saturation. This slider adjusts the saturation of the
replacement color. Adjusting the saturation to the right
deepens the change; adjusting the saturation to the left tones
down the replacement color.

• Lightness. This slider adjusts the lightness of the color that
will replace the existing color in the image.

• Result. This color swatch displays the resulting color from
the Hue, Saturation, and Lightness adjustments. You can also
click the color swatch to launch a color chooser and use it to
specify a color.

The following steps take you through an example of using the
Replace Color adjustment tool to replace a color in an image:

1. Open the image in Photoshop shown in Figure 13.12.

Figure 13.12

The color of these flowers is about to change in the following
steps.
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2. Choose Image⇒Adjustment⇒Replace Color to load the
Replace Color dialog box.

3. Use the eyedropper to select a color in the image.

In this case, select one of the flower petals. Notice how those
color tones have been added to the selection view in Figure
13.13, but that the selection is still incomplete.

4. Drag the Fuzziness slider left or right to adjust the
selection.

In this case, the flowers are the oNL1y violet element in the
image, so we adjust the fuzziness to the right until most of the
flowers are added to the selection, as shown in Figure 13.13.

5. Use the plus and minus eyedroppers to fine-tune the
selection.
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In this example, we used the plus eyedropper to add some of
the missing parts of the selection while leaving oNL1y the
darkest and lightest tones in the flowers, as shown in Figure
13.13. You may also need to make additional adjustments to
the Fuzziness as you adjust with the eyedroppers.

Figure 13.13

Using the eyedropper to select a color creates a small
selection; increasing the fuzziness increases the selection to
include more of the similar tones; finally, using the plus
eyedropper, we selected the rest of the rose.

6. After you have the selection finalized, adjust the hue to
the replacement color.

You can also click the Color box to open a color chooser to
select the color. In this example, we changed the violet
flowers to deep red color, as shown in Figure 13.14.
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7. Adjust the saturation and lightness to get the best effect
in the image.

In this example, we tweaked the Hue, Saturation, and
Lightness sliders to get just the right color of red. The results
are shown in Figure 13.14, where the flowers are now red, but
the green background remains unchanged.

On the Web

You can find the image shown in Figure 13.14 on this
book's website as Figure 13.14.psd. The adjustment was
made to a duplicate layer so you can see both images.

Figure 13.14

Adjusting the hue, saturation, and lightness of the selected
color changes the flowers from violet to red.
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Using the Variations tool

The Variations adjustment tool in Photoshop enables you to
easily make the most of the general color correction changes
that Photoshop has to offer from a single interface. This tool
is extremely useful if you are editing images and you're not
quite sure what color correction needs to be made.

The biggest strength of the Variations adjustment tool is that
you can preview all possible changes as thumbnails in the
same view before you make them. You can also adjust only
the highlights, midtones, shadows, or saturation and specify
the coarseness of the changes.

To use the Variations adjustment tool, choose
Image⇒Adjustments⇒Variations in Photoshop to open the
Variations dialog box, as shown in Figure 13.15. From the
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Variations dialog box, you can view and make the following
adjustments:

Figure 13.15

Using the Variations adjustment tool, you can quickly see
possible color, lighting, and saturation adjustments in
thumbnails and then apply the changes by clicking the
thumbnails.

• Original/Current Pick. This section displays the original
and current images side by side so you can always see the
differences that the change has made.

• Shadows. This option enables you to make adjustments only
to the shadows in the image. Using this option enables you to
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make both color and lighting corrections to the darker areas of
the image.

• Midtones. This option enables you to make adjustments
only to the midtones in the image. Using this option enables
you to make both color and lighting corrections to the
midtones.

• Highlights. This option enables you to make adjustments
only to the highlights in the image. Using this option enables
you to make both color and lighting corrections to the lighter
areas.

• Saturation. This option enables you to make adjustments
only to the saturation of pixels in the image.

• Fine/Coarse. This slider adjusts how coarse the adjustments
should be. Adjusting the slider left to Fine makes subtle
changes, and adjusting it right to Coarse makes much more
dramatic adjustments.

• Show Clipping. This option enables you to show the
clipping that occurs when you adjust pixels in the images
such that their level value goes out of range (below 0 or above
255); the pixel data is lost because the values out of range are
clipped back into range.

• Color adjustments. This section enables you to add more
of any color hue to the image by clicking More color
thumbnails (refer to Figure 13.15). This option is available for
adjusting the shadows, midtones, or highlights in the image.
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Note

Adding colors is not an additive; for example, if you click
More Yellow twice and then More Cyan twice, the pixels in
the Current Pick view return to the original state.

• Lightness adjustments. This section enables you to
increase or decrease the lightness levels to the shadows,
midtones, or highlights in the image.

• Saturation adjustments. These adjustments enable you to
add and remove saturation from the image. In order to use
them, you must first select the Saturation option.

Changing the shadows and highlights in images

Adjusting shadows and highlights is a great way to correct or
enhance photos to give them additional depth and detail.
Many lighting and color adjustments tend to focus on the
entire tonal range, but adjusting shadows and highlights
enables you to add detail that is lost in the upper and lower
ranges without affecting the midrange colors that make up
most of an image.

Photoshop provides the Shadows/Highlights adjustment tool
so that you can work with only the upper or lower tonal
ranges in an image. Using the Shadows/Highlights adjustment
tool, you can focus on specific problems where areas of an
image are too bright or too dark, causing limited detail. You
can also use the Shadows/Highlights adjustment tool to make
subtle corrections to images to increase the detail and
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contrast. To use this tool, choose
Image⇒Adjustments⇒Shadows/Highlights in Photoshop.

Fixing shadows

The Shadows section of the tool enables you to bring back
some of the detail that is lost in areas of the image that are too
dark due to problems such as backlighting issues. To fix the
shadows in an image, use the following adjustments in the
Shadows/Highlights adjustment tool:

• Amount. This slider specifies how much correction to make
to the shadows in the image. Increasing this value results in a
more dramatic correction. However, if you increase the value
too much, the corrected values may cross over and become
brighter than the highlights in the image.

• Tonal Width. This slider sets the range of tones that are
involved in the correction. Increasing this value results in
more of an effect on the midtones and highlights in the image.
Decreasing this value results in only the shadows being
affected. When you are trying to correct only a dark area of
the image, you should decrease the tonal width value to close
to zero.

• Radius. This slider specifies how many surrounding pixels
to use to determine whether an area falls in the Shadows tonal
range. A smaller radius value means that fewer pixels are
used and the shadow correction is more precise. However, if
the radius is too small, some areas of the image may not be
corrected properly. You need to play around with the radius
until the adjustment provides the best outcome.
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Tip

Set the Radius amount to roughly the size of the subjects of
interest in the image. This ensures that those subjects are
most accurately corrected.

Fixing highlights

The Highlights options of the Shadows/Highlights adjustment
tool enable you to focus on areas of the image that are too
bright. For example, you can correct overexposed areas in the
image due to a flash or direct sunlight. To fix the highlights in
an image, use the following adjustments in the Highlights
section:

• Amount. This slider specifies how much correction to make
to the highlights in the image. Increasing this value results in
a more dramatic lighting correction. However, if you increase
the value too much, the corrected values may cross over and
become darker than the shadows in the image.

• Tonal Width. This slider sets the range of tones that are
involved in the correction. Increasing this value results in a
greater effect on the midtones and shadows in the image,
while decreasing this value results in only the highlights
being affected. When you are trying to correct only a dark
area of the image, you should decrease the tonal width value
to close to zero.

• Radius. This slider specifies how many surrounding pixels
to use to determine whether an area falls in the Highlights
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tonal range. A smaller radius value means that fewer pixels
are used and the highlights correction is more precise.

Adjusting after shadows or highlights are corrected

After you have adjusted the shadows or highlights, you may
need to adjust the color and contrast in the entire image to
make it look more natural. To do this, use the following
adjustments in the Shadows/Highlights adjustment tool:

• Color Correction. This slider adjusts the saturation of the
colors in the areas of the image that have been corrected by
the shadows and highlights adjustments. This option is
available only in color images. Increasing this value adds
more color, and decreasing it reduces the amount of color.
Typically, you want to add more color to areas of the image
that were too dark or too light because those areas tend to
have less color detail than the rest of the image and will look
a bit odd.

• Brightness. This slider adjusts the brightness of an entire
grayscale image — in fact, it is only available for grayscale
images. Increasing this value increases the brightness, and
decreasing it reduces the brightness.

• Midtone Contrast. This slider adjusts the contrast in the
midtone pixels of the image. You can use this option to help
the midtones match the adjusted shadows and highlights.
Increasing this value increases the contrast in the midtone
pixels only.

• Black Clip. This field specifies how much the shadows are
clipped to level 0 when you adjust them. Increasing this value
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provides greater contrast; however, too high a value results in
loss of detail.

• White Clip. This field specifies how much the highlights
are clipped to level 255 when you adjust them. Increasing this
value provides greater contrast; however, too high a value
results in loss of detail.

Figure 13.16 illustrates the effects of using the Shadows/
Highlights adjustment tool to enhance an image that has been
negatively affected by lighting conditions. Notice that the
original image is rather dull because, despite the interesting
contours of the rock, it is all the same color. After adjusting
the shadows, highlights, and midtones, there is much more
contrast and color, making the photo much more interesting.

Figure 13.16

Using the Shadows/Highlights adjustment tool, you can
quickly adjust light and dark areas of your photo.
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On the Web

You can find the image shown in Figure 13.16 on this
book's website as Figure 13.16.jpg. Open the file in
Photoshop and make the changes shown in this example to
restore the detail and tone down the brightness.

Creating customized black-and-white photos

When you convert a color image into a black-and-white
photo, you are really combining three channels (red, green,
and blue) of data into only one grayscale channel. Although
this can be done in many ways, we will talk about the three
most common methods.

One way to convert a color image to grayscale is to use only
one of the three channels, for example, only the red channel.
The problem with this method is that it gives you only the red
data in the image, leaving out all of the other data. This works
well for some effects, but you likely want more detail in your
image.

A second way is to use a combination of the three channels.
For example, you could create grayscale data by taking 40
percent of the red value, 40 percent of the green value, and 20
percent of the blue value and adding them together to get the
value for each grayscale pixel. By using the best combination
of the three channels, you can get the most detail from the
image. You can do this with the Channel Mixer adjustment
tool, which we discuss in Chapter 11. This is the default
method that Photoshop uses to convert color images to
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grayscale and is generally the recommended method of
conversion.

A slightly more complex way to generate the grayscale data
from the color channels is to focus on percentages of each
color tone. This enables you to maximize the amount of
detail, create the best contrast, and optimize the overall
appearance of the resulting black-and-white photo. The
drawback to this method is that it requires some guesswork
and a bit of trial and error to get the best effect.

The Black and White adjustment tool enables you to use
combinations of reds, greens, and blues, as well as cyans,
magentas, and yellows, to generate the grayscale data in the
black-and-white image. By specifying percentages of these
color tones, you can customize the resulting levels that go
into the grayscale channel of the black-and-white photo.

To use the Black and White adjustment tool to create a
customized black-and-white photo, choose
Image⇒Adjustments⇒Black & White in Photoshop to open
the Black and White dialog box, as shown in Figure 13.17.
Then use the adjustment sliders to set the amount of each
color to include when creating the grayscale channel.

Tip

When you use the Black & White adjustment tool to create
black-and-white photos, keep in mind that increasing the
percentage of a color lightens those pixels in the resulting
image, while decreasing the percentage of a color darkens
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those pixels. For example, if you want to darken the sky in
the black-and-white photo, you decrease the percentage of
blue that is included in the resulting image.

Figure 13.17

Using the Black & White adjustment tool, you can create
customized black-and-white photos using combinations of the
red, yellow, green, cyan, blue, and magenta colors in a color
image.
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A nice feature of the Black & White adjustment tool is the
ability to add a tint to the resulting image. This is a great way
to create a sepia effect in the image because the tint takes into
account the current color values along with the adjusted
percentages when creating the overlaying tint.

To add a tint to the resulting black-and-white image, select
the Tint option. You can choose the color the tint will take by
double-clicking the color box and selecting a color from the
Color Picker dialog box.
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Fine-Tuning Hue and Saturation

Hue and saturation are by far the most important properties
that define the color in an image. Hue refers to how the actual
color tone of the pixel in the image appears to the eye. Hue is
measured in degrees around the color wheel, where 0 degrees
and 360 degrees are red, 120 degrees is green, and 240
degrees is blue.

Saturation refers to the difference of the color against its own
brightness — in other words, how brilliant the pixel appears
to the eye. Low saturation means almost gray, and high
saturation is the fully brilliant color.

You adjust the hue and saturation of images for two main
reasons. One is to change the color tones that were affected
by adverse lighting, such as a yellow cast caused by
fluorescent lights. The second reason is to bring back the
intensity of colors that is lost due to the use of filters, haze,
and limited lighting, as well as other adjustments made in
Photoshop. This section discusses using the Hue/Saturation
adjustment tool to fix the color tones in images.

Using the Hue/Saturation tool

The most important tool you can use to adjust the color in
images is the Hue/Saturation adjustment tool. Changing the
hue of an image can drastically alter the overall effect of the
image. For example, changing the hue more towards red
warms up the image, and more towards blue cools off the
image. Changing the saturation affects the overall brilliance
of the colors.
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Using the Hue/Saturation adjustment tool, you can change the
hue, saturation, and lightness of all colors in the image, or you
can adjust specific colors. You can access the Hue/Saturation
tool by choosing Image⇒Adjustments⇒Hue and Saturation
or by adding an adjustment layer to the image, as shown in
Figure 13.18.

Figure 13.18

Using the Hue/Saturation adjustment tool, you can make both
specific and general adjustments to the colors in an image.
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From the Hue/Saturation settings, you can set the following
options:

• Presets. This drop-down list enables you to select one of the
predefined Photoshop presets or one of your own saved
presets. You can save the settings you make in the Hue/
Saturation tool as a preset by selecting Save Hue and
Saturation Presets from the Adjustments panel menu.
Photoshop provides the following presets to adjust the hue
and saturation of your images quickly:
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• Default. This option uses the middle values for hue,
saturation, and lightness.

• Cyanotype. This option applies a blue monotone effect to
the entire image.

• Increase Saturation. This option increases the saturation of
all colors by +10, giving a slight saturation boost to make the
colors stand out.

• Increase Saturation More. This option increases the
saturation of all colors by +30, giving a larger saturation
boost to make the colors stand out more.

• Old Style. This option decreases the saturation by −40 to
reduce the amount of color in the image. Lightness is also
increased by +5 to compensate for the lost color.

• Red Boost. This option decreases the hue by −5 and
increases the saturation by +20 to make the reds pop more.

• Sepia. This option makes the image a monotone by
selecting Colorize and adjusting the hue to red and the
saturation down to only 25 to give the image a sepia look.

• Strong Saturation. This option increases the saturation of
all colors by +50 to make the colors really stand out.

• Yellow Boost. This option increases the hue by +5 and
increases the saturation by +20 to make the yellow colors pop
slightly.
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• Custom. This option enables you to make your own
changes to the hue, saturation, and lightness in the image.

• Color channel. This option enables you to select the master
color channel to change all colors or select the red, yellow,
green, cyan, blue, or magenta color tones.

Note

If you move the adjustment color outside of the tonal range
of a color into another color's tonal range, the color channel
name changes to the new color tone. For example, if you
select the red color channel and adjust it to green, the
Adjustment color list displays Green 2 instead of Red for the
color channel.

• Hue. This slider adjusts the hue of the selected color
channel based on the location of the slider or the value in the
text box.

• Saturation. This slider adjusts the saturation of the selected
color channel based on the location of the slider or the value
in the text box. Increasing the saturation makes the colors
brighter, and decreasing the saturation dims the colors toward
gray.

• Lightness. This slider adjusts the lightness of the selected
color channel based on the location of the slider or the value
in the text box.
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• On-image adjustment slider. This tool is a great way to
adjust the hue or saturation of a specific color in the image.
When you select the On-image adjustment tool option, the
mouse cursor changes to an eyedropper. Simply select the
color you want to change in the image, and drag the mouse to
adjust the saturation. The color channel changes to match the
color of the selected pixel. As you drag the mouse to the left,
the saturation decreases, and as you drag the mouse to the
right, the saturation increases. To adjust the hue, press and
hold the Ctrl/ key when you select and drag a color in the
image. The color channel changes to match the color of the
selected pixel. As you drag the mouse to the left, the hue
moves toward the yellow side of red, and as you drag the
mouse to the right, the hue moves toward the magenta side of
red.

• Eyedroppers. These tools enable you to define the hue of
color channels by clicking specific pixels in the image. This
enables you to use real pixels in the image to define colors.
The eyedroppers are not available when the Master color
channel is selected. The regular eyedropper sets the middle of
the color channel to the value of the pixel selected in the
image. When you use the plus eyedropper, the color of the
selected pixel is added to the color channel, increasing the
tonal range. When you use the minus eyedropper, the color of
the selected pixel is removed from the color channel,
decreasing the tonal range.

• Colorize. This option is used either to add color to a
grayscale image or to create a monotone image from a color
image. The color channels are flattened, and the hue,
saturation, and lightness values apply to the entire image. The
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only color in the image is the color range of the current hue
value.

• Adjustment sliders. These sliders are the most powerful
feature of the Hue/Saturation tool. The adjustment sliders
enable you to specifically define the range of the colors being
affected by the hue, saturation, and lighting. You can also
define how the color boundaries are feathered out into other
colors. You can use the mouse to adjust the sliders in the
following areas, as shown in Figure 13.19.

• Left falloff handle. Moving this handle adjusts the area of
the left falloff used to feather the color correction into other
colors. Increasing the falloff area results in more feathering of
the color changes into the adjacent colors. Adjusting this
handle does not affect the hue range at all.

• Left falloff area. Moving the left falloff area doesn't affect
its size; however, the hue range area is increased or
decreased.

• Left range handle. Moving this handle adjusts both the hue
range area and the left falloff area. As the hue range area
increases, the left falloff area decreases, and vice versa.

• Hue range area. Moving this area moves the entire set of
handles without changing their respective sizes. The hue
range area specifies the colors that are directly affected by the
hue, saturation, and lightness changes. Increasing the hue
range area includes more of the adjacent tones in the
correction, just as decreasing the hue range area focuses on a
specific color. You may have to vary this setting for specific
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needs. For example, if you want to correct a specific color,
then you need the range to be as small as possible.

• Right range handle. Moving this handle adjusts both the
hue range area and the right falloff area. As the hue range
increases, the right falloff area decreases, and vice versa.

• Right falloff area. Moving the right falloff area doesn't
affect its size; however, the hue range area is increased or
decreased.

• Right falloff handle. Moving this handle adjusts the area of
the right falloff used to feather the color correction into other
colors. Increasing the falloff area results in more feathering of
the color changes into the adjacent colors. Adjusting this
handle does not affect the hue range at all.

Figure 13.19

Using the adjustment sliders of the Hue/Saturation adjustment
tool, you can specify both the specific color range and the
surrounding falloff ranges that are used to feather
adjustments.
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Adjusting the hue and saturation to make colors pop

The biggest strength of the Hue/Saturation adjustment tool is
its ability to make hue, saturation, and lighting changes to
specific color ranges. This enables you to fix certain colors in
an image without affecting other colors.

The following example demonstrates how to use the Hue/
Saturation adjustment tool to enhance the colors in an image:

1. Open the image in Photoshop shown in Figure 13.20.

The colors in this image are really dulled by the haze and
cloud cover that was present the day the photo was taken.

Figure 13.20
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The colors in this image are very dull and washed out by the
haze present when the photo was taken.

2. Choose Window⇒Adjustments in Photoshop to open
the Adjustments panel shown in Figure 13.21.

3. Select the Hue/Saturation adjustment tool, as shown in
Figure 13.21, to add a Hue/Saturation adjustment layer to
the image and open the Hue/Saturation Properties panel.

Figure 13.21

Selecting the Hue/Saturation option from the Adjustments
panel in Photoshop adds an adjustment layer to the image and
opens the Hue/Saturation Properties panel.
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4. Select the Reds color channel, as shown in Figure 13.22,
and increase the saturation to make the reds deeper and
more vibrant.

This makes the red colors in the cliffs pop.

5. Select the Magenta color channel and increase its
saturation as well.

6. Select other color channels if desired and experiment
with the settings.

The blues in this photo are toned down by the gray sky, and
the yellows in the rock are a little strong.

7. Change the color channel back to Master and make
targeted adjustments to the photo using the On-image
adjustment slider (see Figure 3.18).

Click the On-image adjustment slider icon to highlight it.
Then click and drag directly over your image to target
specific areas to increase or decrease the saturation, as shown
in Figure 13.22.
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Note

You can change the hue with the On-image adjustment
slider by holding the Ctrl/ key while dragging the slider.

Figure 13.22

You can use color channels or the On-image adjustment slider
to change and enhance the colors in your image.

8. View the results shown in Figure 13.23.

Figure 13.23

Using the Hue/Saturation tool, we made the colors pop and
reduced the haze in this photo.
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On the Web

You can find the image shown in Figure 13.23 on this
book's website as Figure 13.23.psd. Because the book is in
black and white, you cannot really see the adjustments in the
image. Open the file in Photoshop and make your own
changes to the Hue/Saturation adjustment layer to see the
effect in action.

Adjusting Levels

The most basic adjustment you can make to the color and
lighting in an image is to change the level composition of the
color channels. Adjusting the level composition can restore
detail to an image and fix a variety of lighting problems.
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The Levels adjustment tool in Photoshop gives you direct
access to the levels of the color channels. You can access the
Levels adjustment tool by choosing Image⇒Adjustments ?
Levels or by selecting a Levels adjustment in the Adjustments
panel.

This section discusses how to configure and use the auto
levels adjustment as well as how to make custom levels
adjustments to your images.

We introduce the concept of color channel levels
in Chapter 4. You should read that chapter before reading this
section because you need to understand how color channel
levels work to get the most out of using the Levels tool.

Using the Levels adjustment tool

The best way to use the Levels adjustment tool is to add a
Levels adjustment layer. The Levels adjustment layer enables
you to adjust the tonal levels in a separate layer, preserving
the original pixels in the image. Adjusting the levels enables
you to brighten and darken tones and colors in the image,
restoring detail that might have been lost due to improper
lighting or exposure.

To add a Levels adjustment layer to the image, select the
Levels icon in the Adjustments panel. This loads the Levels
Adjustment Layer options in the Properties panel, shown in
Figure 13.24.

Figure 13.24
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Using the Levels adjustment tool, you can adjust the levels of
color channels to change the color composition and bring
detail back into an image.

The Levels adjustment tool enables you to adjust the
composite channel or any single color channel using the
following controls:

• Preset. This drop-down list enables you to select a default
Photoshop preset or one of your own saved ones. You can
save the settings you make in the Levels tool as a preset by
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selecting Save Levels Preset from the Adjustments panel
menu. Photoshop provides the following predefined
adjustments to quickly adjust the levels in an image: Default,
Darker, Increase the Contrast 1, Increase the Contrast 2,
Increase the Contrast 3, Lighten Shadows, Lighter, Midtones
Brighter, Midtones Darker, and Custom.

• Channel. This drop-down list enables you to select the
composite channel or one of the individual color channels.
Making levels adjustments to the composite channel changes
the entire image. Making changes to an individual color
channel enables you to fix level problems associated with a
specific color without affecting other colors.

Caution

Adjusting the levels of color channels separately changes
the color composition in the image. If the general color
tones match up well, you should not change the levels of the
color channels separately because you may end up with
some colors that do not match the rest of the colors in the
image.

• Black slider. This slider sets the level value in the image
that equates to the desired lowest level in the color channel
(essentially black). All values lower than the value of the
black slider are clipped to 0. Typically, you want to set the
black slider to the left edge of the histogram mountain and
ignore the few pixels that are scattered to the left.
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• White slider. This slider sets the level value in the image
that equates to the desired highest level in the color channel
(essentially white). All values higher than the value of the
white slider are clipped to 255. Typically, you want to set the
white slider to the right edge of the histogram mountain and
ignore the few pixels that are scattered to the right.

Tip

If you press and hold the Alt/Option key while adjusting the
Black and White sliders, the areas of the image that are
being clipped appear in the document window, as shown in
Figure 13.25. This is extremely useful for helping you to
understand what detail will be lost when the clipping occurs.
You can also turn this feature on permanently by selecting
Show Clipping for Black/White Points in the Adjustments
panel menu.

• Midtone slider. This slider sets the balance point used for
distributing the pixels in the image. The levels of the pixels
between the black and white sliders are distributed to fill the
entire 0-to-255 range. The pixels below the value of the
midtone slider are distributed between 0 and 127, and the
pixels greater than the value of the midtone slider are
distributed between 128 and 255. Typically, you want the
pixels to be evenly distributed, so you want to move the
midtone slider toward the area of the histogram that has the
largest number of pixels.

Figure 13.25
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Pressing and holding down the Alt/Option key while
adjusting the Black and White sliders displays the clipping in
the document window.

Tip

Adjusting the midtone slider really takes some trial and
error. An even distribution doesn't always generate the best
results, so don't be afraid to try different values for the
pixels. A good rule to remember is that as you move the
midtone slider to the right, the overall tone of the channel
gets darker, and as you move the midtone slider to the left,
the overall tone of the channel gets lighter.

• Output Levels. These sliders enable you to set the
minimum and maximum values for the distribution of levels
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in the results from the level adjustments. For example, if you
set the black slider to 50 and the white slider to 200, the
output is distributed between 50 and 200 instead of 0 and 255,
which limits the detail by 100 level values. Typically, you
want to change this option only if you are planning to
combine an image with another image that provides the detail
in the omitted level values.

Tip

You can trade places between the black and white sliders in
the Output Levels option to create a negative effect. This
can be very useful when you want to combine selections
from different color channels.

• Black eyedropper. This tool enables you to sample the
value to be used for black pixels directly from the image.
Using the black eyedropper tool sets the value of the black
slider to the level of the selected pixel. If you press and hold
the Alt/Option key while using the Eyedropper tool,
Photoshop displays the clipped portions of the image, as
shown in Figure 13.25.

• White eyedropper. This tool enables you to sample the
value to be used for white pixels directly from the image.
Using the white eyedropper tool sets the value of the white
slider to the level of the selected pixel. If you press and hold
the Alt/Option key while using the Eyedropper tool,
Photoshop displays the clipped portions of the image, as
shown in Figure 13.25.
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• Gray eyedropper. This tool enables you to sample the
value of a gray pixel directly from the image. The value of the
gray pixel is used to calculate the balance of the color
channels because a gray pixel of any level should have an
equal amount of red, green, and blue.

• Calculate more accurate histogram. This option enables
you to have Photoshop use a computer algorithm to calculate
a more accurate histogram. Occasionally Photoshop detects
that a more accurate histogram can be calculated. When this
occurs, an icon appears in the Levels tool (refer to Figure
13.24). When you click this icon, Photoshop calculates a new
histogram. There are trade-offs, though. To calculate the more
accurate histogram, Photoshop has to make assumptions. If
those assumptions are wrong, you can lose a slight amount of
the detail in the image.

• Auto. This button applies the Auto Levels adjustment to the
image. The next section discusses setting the options for the
Auto Levels adjustment.

Note

Photoshop calculates the histogram based on the frequency
of levels in the image. However, with some images and
layer adjustments, the normal method for calculating
histograms can be inaccurate. For those images, Photoshop
displays an additional option, Calculate a more accurate
histogram button, with a triangle-warning icon that enables
you to use a more accurate, if less consistent, method for
calculating the histogram. Sometimes this option produces
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better results, but not always, especially if the histogram is
evenly distributed.

Configuring the Auto Levels adjustment

For many images, the Auto Levels adjustment in Photoshop is
sufficient to correct problems with levels. To use the Auto
Levels adjustment option, you click the Auto button on the
Levels adjustment tool. Because adjusting levels is complex,
Photoshop enables you to configure the following options by
selecting Auto options from the Adjustments panel menu to
display the Auto Color Correction Options dialog box shown
in Figure 13.26.

Figure 13.26

Using the Auto Color Correction Options dialog box, you can
adjust the algorithms and settings that Photoshop uses when
performing an Auto Levels adjustment.
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The Auto Color Correction Options dialog box contains the
following settings:

• Enhance Monochromatic Contrast. When you select this
option, all channels are clipped identically, which preserves
the overall color relationship while making highlights appear
lighter and shadows appear darker. This option is available by
choosing the Image⇒Auto Contrast command.

• Enhance Per Channel Contrast. When you select this
option, Photoshop tries to maximize the tonal range in each
channel. This results in a much more dramatic correction and
provides the greatest amount of detail. However, you run the
risk of introducing a colorcast. This option is available by
choosing the Image⇒Auto Tone command.

• Find Dark & Light Colors. When you select this option,
Photoshop finds the average lightest and darkest pixel in the
image and uses those pixels to maximize the contrast while
still preserving as much detail as possible through minimal
clipping. This option is available by choosing the
Image⇒Auto Color command.

• Enhance Brightness and Contrast. When you select this
option, Photoshop tries to optimize the color correction based
on enhancing the brightness and contrast in the image. This
option can have a dramatic impact on photos that have
reduced color due to poor lighting conditions.

• Snap Neutral Midtones. When you select this option,
Photoshop finds the most neutral color in the image and
adjusts the midtone values to make that color neutral.
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• Shadows. When you select this option, it enables you to set
the color used for the darkest shadows when performing the
Auto Levels adjustment. You can also specify the amount of
clipping that can occur in the shadows during the Auto Levels
adjustment.

• Midtones. When you select this option, it enables you to set
the color used for the midtone balance when performing the
Auto Levels adjustment.

• Highlights. When you select this option, it enables you to
set the color used for the lightest highlights when performing
the Auto Levels adjustment. You can also specify the amount
of clipping that can occur in the highlights during the Auto
Levels adjustment.

• Save as defaults. When you select this option, the values
you specify are used as the defaults when you use the Auto
Levels adjustment. These values are preserved even if
Photoshop is closed and opened again.

Adjusting levels to increase detail in images

Adjusting the levels in an image can help lighten dark areas,
reduce the brightness of highlighted areas, restore detail to
images, and remove colorcasts. The following example takes
you through the process of using the Levels adjustment tool to
adjust the levels in a photo:

1. Open the image in Photoshop shown in Figure 13.27.

Figure 13.27
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The color in this image is poor because of haze and distance.

2. Choose Window⇒Adjustments in Photoshop to open
the Adjustments panel, shown in Figure 13.28.

3. Select the Levels adjustment to add a Levels adjustment
layer to the image.

The Properties dialog box opens, enabling you to adjust the
levels.

Figure 13.28

Selecting the Levels tool from the Adjustments panel in
Photoshop adds an adjustment layer to the image and
launches the Levels adjustment tool.
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4. Select the Red channel, and adjust the black and white
sliders.

Move the black slider to the left edge of the histogram
mountain and the white slider to the right edge of the
histogram mountain, as shown in Figure 13.29, to drop the
upper and lower levels that are not needed. Don't worry that
this makes the photo look horrible; it will improve.

5. Select the Blue channel, and adjust the black and white
sliders.

Move the black slider to the left edge of the histogram
mountain and the white slider to the right edge of the
histogram mountain, as shown in Figure 13.29, to drop the
upper and lower levels that are not needed.

6. Select the Green channel, and adjust the black and
white sliders.

Move the black slider to the left edge of the histogram
mountain and the white slider to the right edge of the
histogram mountain, as shown in Figure 13.29, to drop the
upper and lower levels that are not needed.
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7. Select the RGB channel and tweak the sliders to make
final adjustments.

Once you've fixed the colors individually, it is a good idea to
return to the RGB channel and play with the sliders one last
time to make sure the overall effect is the best that it can be.

Figure 13.29

Adjusting the black and white sliders in each of the color
channels drops pixel values that are not really needed and
creates room in those levels for additional detail.

8. View the results shown in Figure 13.30.

Figure 13.30

Using the Levels adjustment tool restores a lot of the detail
and contrast in the image.
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On the Web

You can find the image shown in Figure 13.30 on this
book's website as Figure 13.30.psd. Check out the file to see
the resulting color and lighting changes. You can use the
Levels adjustment layer to play around with the level values
and see how different settings affect the image.

Making Adjustments with Curves

The most powerful tool Photoshop has for adjusting color and
lighting is the Curves adjustment tool. The Curves adjustment
tool provides a dynamic and flexible interface that enables
you to make dramatic changes to the lighting and color in
images. Although it takes a bit of practice and patience to
learn the Curves adjustment tool, after you are familiar with
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it, you can make changes in images that you may not have
thought possible.

You can access the Curves adjustment tool by choosing
Image⇒Adjustments⇒Curves or by selecting a Curves
adjustment in the Adjustments panel. This section discusses
how to configure and use the Curves adjustment tool to make
changes to the color, lighting, and contrast in your images, as
well as how to configure and use the Auto Curves adjustment.

We introduce the concept of using curves to
adjust color channel levels in Chapter 4. You should read that
chapter before reading this section because you need to
understand how color channels work to get the most out of
using the Curves tool.

Using the Curves tool

The Curves tool provides a dynamic way to adjust the tone
and color levels in an image. With the Curves tool, you can
use the mouse to alter a line graphically that maps the input
tones to the output tones. This gives you much more control
over the changes to the tonal levels in the image.

The best way to use the Curves tool is to add a Curves layer
to the image by selecting the Curves tool in the Adjustments
panel. This loads the Curves tool shown in Figure 13.31.

Figure 13.31
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Using the Curves tool, you can adjust the levels of color
channels to change the color composition and bring detail
back to an image.

The Curves adjustment tool enables you to adjust the
composite channel or any single color channel using the
following controls:

• Preset. This drop-down list enables you to select one of the
predefined Photoshop presets or one of your own saved
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presets. You can save the settings you make in the Curves
tool as a preset by selecting Save Curves Preset from the
Properties panel menu. Photoshop provides the following
predefined adjustments to adjust the levels of images quickly:
Default, Color Negative, Cross Process, Darker, Increase
Contrast, Lighter, Linear Contrast, Medium Contrast,
Negative, Strong Contrast, and Custom.

• Color channel. This drop-down list enables you to select
the composite channel or one of the individual color channels.
Making curves adjustments to the composite channel changes
the entire image. Making changes to an individual color
channel enables you to fix level problems associated with a
specific color without affecting other colors.

Caution

Adjusting the curves of color channels separately changes
the color composition in the image. If the general color
tones match up well, you should not change the curves of
the color channels separately because you may end up with
a colorcast or some colors that do not match the rest of the
colors in the image.

• Black eyedropper. This tool enables you to sample the
value to be used for black pixels directly from the image.
Using the black eyedropper tool sets the value of the black
slider to the level of the selected pixel.

• Gray eyedropper. This tool enables you to sample the
value of a gray pixel directly from the image. The value of the
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gray pixel is used to calculate the balance of the color
channels because a gray pixel of any level should have an
equal amount of red, green, and blue.

• White eyedropper. This tool enables you to sample the
value to be used for white pixels directly from the image.
Using the white eyedropper tool sets the value of the white
slider to the level of the selected pixel.

• Auto. This button applies the Auto Curves adjustment to the
image. You will learn more about setting the options for the
Auto Curves adjustment later in this chapter.

• Output tonal range. This gradient bar displays the output
levels range used by the vertical values of the curve.

• Input tonal range. This gradient bar displays the input
levels range used by the horizontal values of the curve.

Note

The input and output tonal ranges for CMYK are the
opposite of those for RGB — in other words, light to dark
instead of dark to light. This is because the CMYK color
model is subtractive instead of additive.

• Input range sliders. These sliders enable you to set the
minimum and maximum input values for distribution of
curves in the results from the curves adjustments. Adjusting
the sliders limits the input range of the curve.
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• Points curve option. This option enables you to adjust the
curve using control points. You can add points by clicking the
curve. To change the curve, drag one of the points on the
curve, as shown in Figure 13.32. You can add as many as 14
points to the curve to make very specific tonal adjustments to
the image.

Figure 13.32

Using the Points curve option, you can add points to the
histogram curve by clicking the curve, and then adjust the
curve by dragging the points.

• On-image adjustment tool. This option changes the mouse
cursor to an eyedropper. As you move the mouse over the
image, a circle icon hovers over the curve at the level value of
the pixel under the mouse. When you select a pixel in the
image, a point is added to the curve at the level value of the
selected pixel. You can then change the output value of the
curve at that point by dragging the mouse up and down. This
option is available only when you have selected the Points
curve option.
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• Draw freehand curve option. This option enables you to
change the curve by drawing freehand on the image, as shown
in Figure 13.33. The areas of the curve corresponding to the
line you draw with the Freehand tool are removed from the
curve line, and the Freehand Output values are used. By
drawing freehand, you can more accurately change the output
values of specific input values. This gives the Curves tool a
lot of power, just as the freehand lines in Figure 13.33
specifically alter the output values for the input ranges they
are drawn over.

• Smooth curve option. This option makes the curve
smoother. Each time you click the Smooth curve icon, the
curve is smoothed a bit until it eventually becomes the
original diagonal linear curve. This enables you to reduce the
variation between the levels. This option is extremely useful
in joining areas of the curve that are not connected after you
use the Draw Freehand Curve tool, as shown in Figure 13.34.
This option is available only when you have selected the
Draw freehand curve option.

Figure 13.33

Using the Draw freehand curve option, you can draw directly
on the Curves tool to set the output values for specific input
values.
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• Calculate more accurate histogram. This option enables
you to have Photoshop use a computer algorithm to calculate
a more accurate histogram. Occasionally Photoshop detects
that a more accurate histogram can be calculated. When this
occurs, an icon appears in the Levels tool (refer to Figure
13.24). When you click this icon, Photoshop calculates a new
histogram. There are trade-offs, though. To calculate the more
accurate histogram, Photoshop has to make assumptions. If
those assumptions are wrong, you can lose a slight amount of
the detail in the image.

Figure 13.34

Using the Smooth Curve option connects areas of the curve
that are not connected when you use the Freehand tool. It
smoothes the curve out, reducing the variation in output
levels.
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Configuring the Curves tool

A great feature of the Curves tool is its ability to change its
look and feel to better fit your editing style or project needs.
You can configure several options that change the appearance
of the Curves tool, such as grid size and channel overlays.

To configure the display options for the Curves tool, click the
Properties panel menu and select Curves Display Options to
launch the Curves Display Options dialog box, as shown in
Figure 13.35.

Figure 13.35
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Adjusting the display options for the Curves adjustment tool
in Photoshop

In the Curves Display Options dialog box, you can set the
following options:

• Light. When you select this option, the histogram shown in
the Curves tool is based on the light levels.

• Pigment/Ink %. When you select this option, the histogram
shown in the Curves tool is based on the actual pigment used
to generate the output image.

• Channel Overlays. When you select this option, the curves
for all individual channels are displayed in their respective
colors. This option is very useful if you are making curves
adjustments to more than one color channel.

• Histogram. When you select this option, the histogram of
the selected channel is displayed in the background of the
Curves view. You likely want to keep this option selected so
you can see the distribution of levels as you adjust the curve.
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• Baseline. When you select this option, the baseline curve
(diagonal line) is displayed so you can gauge the size of the
deviation you are making with the Curves adjustment.

• Intersection Line. When you select this option, intersecting
lines are displayed so you can make adjustments that are more
precise.

• Grid size. When you select this option, these two buttons
enable you to switch between large and small grids. Smaller
grids make the view a bit more confusing but enable you to be
more precise.

Configuring the Auto Curves tool

For many images, the Auto Curves tool in Photoshop is
sufficient to correct the levels problems in your images. To
use the Auto Curves tool option, click the Auto button on the
Curves tool. The Auto Curves tool uses the same options as
the Auto Levels adjustment discussed earlier in this chapter.

Adjusting the curve to correct color and contrast in images

Adjusting the curves in an image can help fix severe contrast
problems, restore detail, and remove color problems. The
following example takes you through the process of using the
Curves tool to adjust the color levels in a photo:

1. Open the image in Photoshop shown in Figure 13.36.

The photo is completely washed out because of overexposure.

Figure 13.36
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The detail in this image is extremely limited because it was
overexposed, and the huge shadow on the rock presents a big
problem for contrast.

2. Choose Window⇒Adjustments in Photoshop to open
the Adjustments panel shown in Figure 13.37.

3. Select the Curves adjustment and then open the Curves
tool, as shown in Figure 13.38, to add a Curves
adjustment layer to the image.

Figure 13.37

Selecting the Curves tool from the Adjustments panel in
Photoshop adds an adjustment layer to the image and
launches the Curves tool.
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4. Select the RGB channel, and adjust the sliders.

Move the black slider to the left edge of the histogram
mountain and the white slider to the right edge of the
histogram mountain, as shown in Figure 13.38, to drop the
lower level values that are not contributing to the image
anyway.

Notice how the image immediately reveals additional detail.

Figure 13.38

Adjusting the white slider to the edge of the histogram
immediately gives you additional detail in the image.
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5. Add a point to the curve in the lower levels.

Along the lower half of the curve, click directly on the curve
to add an adjustment point. Adjust it down slightly to bring
back some of the detail in the darker areas of the image.

Notice that the image darkens slightly, and you actually lose
some detail in the upper levels, as shown in Figure 13.39.

Figure 13.39

Adding a point to the curve lets you adjust the levels down
slightly to retrieve some detail in the lower levels, but you
lose detail in the upper levels.

6. Add another point to the curve in the middle levels.

Adjust this point down slightly to get some of the detail back
in the midtones.

This keeps the detail in the lower levels, but it still adds some
detail back in the middle levels, as shown in Figure 13.40.
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Figure 13.40

Adding another point to the curve lets you adjust the middle
levels down a bit to gain some detail, but you still lack detail
in the upper levels.

7. Add another point to the curve in the upper levels.

Adjust this point up slightly to restore some of the detail in
the upper levels.

This keeps most of the detail in the lower and middle levels,
but it restores some detail in the upper levels, especially in the
clouds, as shown in Figure 13.41.

Figure 13.41

Adding another point to the curve lets you lower the upper
levels slightly to gain some detail in the upper levels without
affecting the lower levels.
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8. Adjust the points to achieve the best overall color and
lighting in the image.

Notice that adjusting the three points slightly adds some detail
in certain areas, as shown in Figure 13.42. You may need to
add more points to fix specific level ranges. The more you
play with the points in the curve, the better you'll understand
the curve adjustment. You can always remove points from the
curve by dragging them out of the curve window.

Figure 13.42

Adjusting the points adds even more detail to the image.
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On the Web

You can find the image shown in Figure 13.42 on this
book's website as Figure 13.42.psd. Check out the file to see
the resulting color and lighting changes. You can use the
Curves adjustment layer to play around with the Curves tool
and see the effect of adding and adjusting points.

Using the Match Color Tool to Change Colors

The Match Color tool can use the color composition of one
image to adjust the color composition of another image
automatically. This helps the images match more closely
when placed side by side.

When you need to correct color in several photos from the
same shoot, the Match Color tool is your best option (see
Figure 13.43). For example, when you are color correcting a
set of photos that are slightly washed out from UV
interference, you see a large change when you adjust the hue

873



and saturation to bring back the color. As you work with more
images, your eyes adjust to the color-corrected images and
you tend to overcorrect. The result is that the final images
don't match the initial images.

Figure 13.43

The Match Color tool provides several options to control how
colors are adjusted in a target image by using the colors in a
source image.

Open the Match Color tool by choosing
Image⇒Adjustments⇒Color Match. When applying a color
match to an image, you can use the following options to
control the color matching process:
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• Target. This information shows the image and layer that
will be affected by the color match. It also shows the color
mode of the target image.

Note

The color match only affects the selected layer in the
destination file.

• Ignore Selection when Applying Adjustment. This option
causes the color match to apply to the entire image instead of
just a selection.

Note

A great feature of the Match Color tool is that you can apply
the color matching change to a selection rather than the
entire image. For example, you may want to change the
background colors without changing the subject's skin tones.

• Luminance. This slider adjusts the brightness of the color
match adjustment.

• Color Intensity. This slider adjusts the color saturation
applied by the color match. Increasing this value makes the
colors pop more; decreasing it makes the color change more
subtle.

• Fade. This slider adjusts the percentage of color match
adjustment to apply to the image. A value of 0 means a full
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color match adjustment; a value of 100 means no color match
adjustment.

• Neutralize. This option neutralizes colorcasts in the image,
reducing the effects of the color match adjustment that can
result in a general colorcast. It is a good idea to try this option
when correcting images, as you may not always notice that
the color match has resulted in a colorcast.

• Use Selection in Source to Calculate Colors. This option
specifies to use only the selected area in the source image to
calculate colors for the color match.

Tip

It is usually best to use selected areas of known colors to
apply the color adjustment to images. This can reduce
colorcasts and result in adjustments that are more accurate.
For example, you may want to select a person's face in both
the source and target images to make sure skin tones match.

• Use Selection in Target to Calculate Adjustment. This
option specifies to use only the selection in the target image
to calculate the color match adjustment.

• Source. This drop-down list specifies the source image. All
open documents in Photoshop appear in the list.

• Layer. This drop-down list specifies the layer to use in the
source file.
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• Load Statistics. This option enables you to load a
previously saved set of color statistics and use them instead of
a source image.

• Save Statistics. This option enables you to save the
statistics from the layer of an image specified by the Source
and Layer options. This enables you to store a specific set of
colors that you can use later to adjust other images.

• Source view. This field displays the image specified by the
Source and Layer options so you can verify that you have the
correct image selected.

Figure 13.44 shows an example of using the colors in one
image to adjust the colors in another image. The colors in the
source image have already been adjusted to a desired level.
The Match Color tool takes the color composition from the
source image and applies it to the target image, resulting in a
much better color match.

Figure 13.44

The Match Color tool adjusts the colors in a target image by
using the colors in a different source image.
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On the Web

You can find the image shown in Figure 13.44 on this
book's website as Figure 13.44.psd. This file contains both
the original layer and the color-matched layer so you can see
the results of applying the color match.

Doing It All with the Camera Raw Filter

The Camera Raw filter is the one-stop-shop for all of your
color and lighting needs for any photo. Not only does it do
everything that all the preceding filters do, but in most cases it
also does it better. (A notable exception is the Color
Replacement tool, which would require several steps to use
the Camera Raw filter.) Although using Camera Raw on
images that are actually captured in RAW format is much
more powerful, the improvements that you can make to a
JPEG or TIFF image can also be dramatic.

New Feature

The Camera Raw filter is a new feature in Photoshop CC. It
brings the capability of the Camera Raw application right
into Photoshop so that you can use it in conjunction with
other tools to improve your image. Now you can use it on
any file within Photoshop: image composites, 3-D files, and
video files as well as image files.

Using the Camera Raw filter is quick and easy; follow these
steps:

879



1. Open an image in Photoshop that would benefit from
color or lighting corrections.

2. Right-click the background layer and select Duplicate
Layer from the popup menu.

This creates a second layer to make changes to while
preserving the original. Give this layer a descriptive name
such as “Camera Raw adjustment.”

3. With the duplicate layer selected, choose
Filter⇒Convert for Smart Filters.

This ensures that you can change the filter settings at any
time.

4. With the duplicate layer selected, choose
Filter⇒Camera Raw Filter.

This launches the Camera Raw filter dialog box, as shown in
Figure 13.45.

Figure 13.45

The Camera Raw filter has many features that enable you to
make dramatic improvements to your image.

880



5. Make the required changes with the Camera Raw filter.

You can see that we were able to make a significant
difference in our image, as shown in Figure 13.46. These
changes were fast and simple, and they worked together so
that we were able to make changes that balanced each other
out. For example, we reduced the exposure and highlights so
that the background wasn't as washed out and then increased
the shadows so that the girl wasn't too dark. We explain how
to use the adjustments found in the Camera Raw filter in
Chapter 8.

Figure 13.46

We were able to retrieve a significant amount of detail from
this washed-out photo.
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There are so many adjustments that you can make
with the Camera Raw filter that they take an entire chapter to
describe. Because all of the adjustments found in this filter
can also be found in the Camera Raw application, we cover
them in depth in Chapter 8.

Working with HDR Images

High dynamic range (HDR) images are created from a set of
bracketed photos taken at varying exposures. This enables
you to include more tonal ranges in the images than you can
store in a single digital photo. This results in images that
reflect more of the colors and intensity levels found in the real
world, such as nature scenes. HDR images are either 16-bit or
32-bit images, enabling you to have more detail than the
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original images and lose less detail when making adjustments.
You can import bracketed photos into Photoshop using the
Merge to HDR Pro utility.

Creating HDR images

One of the most difficult challenges in photography is
capturing a large tonal range with the limited capabilities of
the equipment. To solve that problem, you can use a
bracketed set of photographs and the Merge to HDR Pro
utility in Photoshop to create a 32-bit HDR image. Bracketed
photos consist of three or more images where one photo is at
the correct exposure and the rest are either overexposed or
underexposed.

The Merge to HDR Pro utility enables you to select the
bracketed photos and then apply a series of adjustments to
them to collect a full 32-bit tonal range. From the Merge to
HDR Pro utility, you can make the following lighting and
color adjustments:

• Preset. This drop-down list enables you to select one of the
predefined HDR tonal adjustments supplied with Photoshop
or to specify Custom to create your own.

• Remove ghosts. This option removes ghosts that are created
because the bracketed photos are not perfectly aligned.

• Mode. This drop-down list enables you to set the image
output mode to 8 bit, 16 bit, or 32 bit.

883



• Method. This drop-down list enables you to specify one of
the following methods used by the HDR Toning tool to adjust
the lighting and color:

• Exposure and Gamma. This option enables you to
manually adjust the brightness and contrast of the HDR
image. Only those two settings will be available in the HDR
Toning tool.

• Highlight Compression. This option automatically
compresses highlight values in the HDR image so that they
match the range of luminance values that 8-bit-per-channel
images support. None of the following options will be
available.

• Equalize Histogram. This option automatically compresses
the dynamic range of the HDR image while trying to preserve
some contrast. None of the following options will be
available.

• Local Adaptation. This option enables you to adjust the
following options in the HDR image. The HDR Toning tool
uses the values to calculate the amount of correction
necessary for local brightness regions throughout the image.

• Radius. This slider specifies the area size used to define
local brightness.

• Strength. This slider specifies how far apart the level values
for two pixels must be before they are no longer part of the
same brightness region.
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• Edge Smoothness. This option tries to preserve smoothness
around edges while increasing detail.

• Gamma. This slider enables you to make a gamma
correction to the tones in the image.

• Exposure. This slider enables you to adjust the exposure up
or down. Remember that the dynamic range of the HDR
images contains multiple levels of exposure.

• Detail. This slider specifies a percentage amount of detail to
preserve when making the other adjustments.

• Shadow. This slider enables you to adjust only the levels of
the shadow (darker) tones up and down.

• Highlight. This slider enables you to adjust only the levels
of the highlight (lighter) tones up and down.

• Vibrance. This slider adjusts the intensity of colors in the
image.

• Saturation. This slider adjusts the saturation of colors in the
image while trying to minimize the amount of clipping that
results.

• Curve. This tab contains a Curve tool that you can use to
adjust the tones in the image.

The following example takes you through the process of
creating an HDR image from a set of bracketed photos.
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1. To access the Merge to HDR Pro utility, choose
File⇒Automate⇒Merge to HDR Pro in Photoshop.

This launches the Merge to HDR Pro file selector, as shown
in Figure 13.47.

Figure 13.47

The Merge to HDR Pro file selector enables you to select
bracketed images to be merged into an HDR image.

2. Select the bracketed files that you want to merge into an
HDR image.

From the Merge to HDR Pro file selector, you can select Files
or Folder from the Use drop-down list. If you select Files,
then all of the files you select will be combined to form the
HDR image. If you select Folder, then all of the files located
in the folder you select will be combined to form the HDR
image. You can also select files by clicking the Add Open
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Files button, which selects all files currently open in
Photoshop. The Remove button enables you to remove
selected files from the list.

3. Select the Attempt to Automatically Align Source
Images option.

Tip

If you select the Attempt to Automatically Align Source
Images option, then Photoshop tries to align the images.
Photoshop usually gets the alignment right if you select this
option; however, sometimes it gets it wrong. Try creating
the HDR image with this option both on and off, and choose
the one you like best.

4. Click OK to launch the Merge to HDR Pro utility
shown in Figure 13.48.

Figure 13.48

The Merge to HDR Pro utility enables you to quickly adjust
the lighting and color of HDR images.
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5. Select the Remove ghosts option.

You should remove ghost edges before trying to adjust the
rest of the image so that they do not interfere with interpreting
your other changes.

6. Adjust the gamma to get the overall tones in the image
correct.

In this image, we adjusted the gamma up to 0.75.

7. Adjust the exposure to get the optimal detail back in the
image.
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In this case, we decreased the exposure by .35. You may need
to go back and adjust the gamma again after adjusting the
exposure.

8. Adjust the detail to get the look you want for the image.

If you increase the Detail setting, then the image gets sharper;
reducing the Detail setting makes the image a bit softer. In
this case, we reduced the detail to 70 percent to create a
slightly surreal effect in the image.

9. Set the radius and strength of the Edge Glow.

In this case, we set the radius up to 200 pixels and the
strength up to 1.6 to bring out the edges of the mountains
against the clouds and add to the slightly surreal scene.

10. Select the Edge Smoothness option.

11. Adjust the Shadow and Highlight options.

In this case, we decreased the shadows to add more depth to
the clouds and lower areas of the image, and increased the
highlights to brighten the highlights on the cliffs.

12. Adjust the vibrance to increase the color brilliance.

For this HDR image, we increased the vibrance all the way up
to 80 because we were looking for a slightly surreal effect.

13. Adjust the saturation to bring out more color.
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In this image, we increased the saturation by 50 percent to
add more color to the cliffs and the blue sky.

14. Click the Curve tab and use the curve to fine-tune the
image adjustments.

The results are shown in Figure 13.49.

On the Web

You can find the image shown in Figure 13.49 on this
book's website as Figure 13.49.psd. This file contains the
HDR image.

Figure 13.49

Using the Merge to HDR Pro utility, you can combine a set of
bracketed photos into a 32-bit HDR image with much greater
tonal range.
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Converting HDR images to 8 bits per channel

You need to convert an HDR image to 8 bits per channel
before you can use it outside of Photoshop. The HDR Toning
tool provides an incredible amount of control when adjusting
the color and tone of 32-bit-per-channel HDR images to
convert them to 8-bit-per-channel images.

Tip

Although the HDR Toning tool is designed to convert HDR
images to 8-bit-per-channel images, it can also be applied to
non-HDR images. We've found that you can sometimes get
better results using the HDR Toning tool than with a simple
levels adjustment. After applying the adjustment, you still
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get a message saying that the image is converted to an
8-bit-per-channel image, but because it was already an
8-bit-per-channel image, it won't matter.

To access the HDR Toning tool, shown in Figure 13.50,
choose Image⇒Adjustments ? HDR Toning from the main
menu, or choose Image⇒Mode⇒8 Bits/Channel from the
main menu.

Figure 13.50

The HDR Toning tool enables you to quickly adjust the
lighting and color of HDR images.
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From the HDR Toning tool, you can make the following
lighting and color adjustments:

• Preset. This drop-down list enables you to select one of the
predefined HDR tonal adjustments supplied with Photoshop,
or to specify Custom to create your own. The button next to
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the Preset drop-down list enables you to save the current
settings to a file, as well as load previously saved presets.

• Method. This drop-down list enables you to specify one of
the following methods used by the HDR Toning tool to adjust
the lighting and color:

• Exposure and Gamma. This option enables you to
manually adjust the brightness and contrast of the HDR
image. Only those two settings are available in the HDR
Toning tool.

• Highlight Compression. This option automatically
compresses highlight values in the HDR image so they match
the range of luminance values that 8-bit-per-channel images
support. None of the following options is available.

• Equalize Histogram. This option automatically compresses
the dynamic range of the HDR image while trying to preserve
some contrast. None of the following options is available.

• Local Adaptation. This option enables you to adjust the
following options in the HDR image. The HDR Toning tool
uses the values to calculate the amount of correction
necessary for local brightness regions throughout the image.

• Radius. This slider specifies the area size used to define
local brightness.

• Strength. This slider specifies how far apart the level values
for two pixels must be before they are no longer part of the
same brightness region.
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• Smooth Edges. This option attempts to smooth sharp edges
created by other adjustments.

• Gamma. This slider enables you to make a gamma
correction to the tones of the image.

• Exposure. This slider enables you to adjust the exposure up
and down. Remember that the dynamic range of the HDR
images contains multiple levels of exposure.

• Detail. This slider specifies a percentage amount of detail to
preserve when making the other adjustments.

• Shadow. This slider enables you to adjust only the levels of
the shadow (darker) tones up and down.

• Highlight. This slider enables you to adjust only the levels
of the highlight (lighter) tones up and down.

• Vibrance. This slider adjusts the intensity of colors in the
image.

• Saturation. This slider adjusts the saturation of colors in the
image while trying to minimize the amount of clipping that
results.

• Toning Curve and Histogram. This display enables you to
use a curve tool to adjust the tones in the image.

Summary

This chapter discussed most of the tools available in
Photoshop that adjust the color and lighting in images.
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Although color and lighting changes involve adjusting the
values of color channels in the images, several tools make it
easy to focus on specific adjustments in images.

In this chapter, you learned the following:

• How to use the Exposure tool to fix lighting problems in
images

• How to use the Shadows/Highlights tool to adjust the upper
and lower color levels quickly in an image

• How Photoshop can simulate the effect of using a lens filter
on a photo that was taken without one

• How to replace one color with another to change the look of
a photo completely

• How to create black-and-white photos from color images

• How to adjust individual color channels to make some
colors pop while not affecting other colors

• How to use the powerful and flexible Curves tool to restore
detail to images with severe lighting problems

• How to use the Camera Raw filter to make powerful
changes to JPGs and TIFs

• How to use the Merge to HDR Pro and HDR Toning tools to
create HDR images
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Chapter 14: Applying Sharpness, Blur, and Noise
Adjustments

In This Chapter

Using sharpening filters to sharpen an image

Applying blurring filters to soften the background in an image

Reducing noise and removing dust and scratches in an image

Two common problems when working with photos are
blurriness and noise. To overcome these problems, Photoshop
provides three classes of filters: sharpen, blur, and noise. It is
important to remember that when you apply filters to an
image, you are altering the pixels based on computer
algorithms and not optical data. Therefore, the adjustments
that Photoshop can make are limited in their effectiveness.

This chapter discusses using the sharpening filters to enhance
blurry images and make edges stand out, using blur filters to
apply softening effects to images, and using noise reduction
filters to remove noise and unwanted artifacts from images.

We discuss sharpening, blurring, and noise
reduction filters in greater detail in Chapter 20. Before getting
too far in this chapter, you should review the section in
Chapter 20 that discusses creating and using non-destructive
Smart Filters.
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When you apply the sharpening, blurring, and
noise reduction filters in this chapter as Smart Filters, you can
use blend modes to significantly change how the filters are
applied. Before reading this chapter, you should look at the
section in Chapter 10 that discusses blend modes in detail.
This will familiarize you with the additional options that are
available when blending rather than applying filters normally.

Using Sharpening Filters to Sharpen Images

The best way to get a sharp photo is to shoot a sharp photo in
the first place. Nothing can take the place of an optically
sharp image. Unfortunately, you don't always shoot perfectly
sharp photos. And even if you do, you may lose some
sharpness when making adjustments to the photo in
Photoshop.

For these reasons, Photoshop includes some powerful
sharpening filters that make your images look better. To
sharpen a photo, Photoshop uses some algorithms that
analyze the image, find edges of objects, and then adjust the
pixels in the image to maximize the contrast between the
edges with minimal impact on the overall appearance of the
photo.

Tip

The best way to apply sharpening filters is to create a
duplicate layer of the background and then turn that layer
into a Smart Object. Then apply the filter to the Smart
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Object so you can add several filters, turn them on and off,
and try different settings.

Keep in mind that the more sharpening you do in your
images, the more anomalies you introduce, such as false
edges and ringing artifacts. The amount of sharpening you
can do is limited by the amount of detail in your image as
well as the size of the image; when it comes to sharpening,
bigger is better.

Note

Ringing artifacts can appear in images when you sharpen
areas with abrupt transitions. They show up as “echoes”
radiating away from the transition, almost like ripples in a
pond.

The following section discusses the basic sharpening tools in
Photoshop as well as some of the more advanced ones.

Note

The sharpening filters significantly alter the pixels in an
image. You should always apply the sharpening filters after
you have made all other adjustments to avoid spreading
some of the anomalies caused by sharpening the image.

Understanding basic sharpening filters
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The simplest way to sharpen images is to use one of the three
basic filters supplied by Photoshop. These basic filters use
slightly different techniques to sharpen images. They apply a
predefined amount of sharpening to an image and do not
provide an interface to customize the amount of sharpening
that takes place.

The following list describes the basic sharpening filters that
are available when you choose Filter⇒Sharpen in Photoshop:

• Shake Reduction. This filter uses an intelligent algorithm
that detects camera shake, and reduces the effect by applying
a sharpening in the direction of the shake.

• Sharpen. This filter performs a simple sharpening on an
image. The filter scans the pixels in the image, looking for
boundaries denoted by a pixel not matching adjacent pixels in
one direction or another. The filter then changes the value
around the boundaries to increase the contrast and make the
edge more defined.

• Sharpen More. This filter works the same way as the
Sharpen filter except that the Sharpen More filter is more
aggressive about finding edges and how much to increase the
contrast. This increases the sharpness around the edges, but it
can introduce a considerable amount of noise in images.

• Sharpen Edges. This filter works similarly to the Sharpen
and Sharpen More filters except that the Sharpen Edges filter
is more aggressive when it finds areas of higher contrast,
sharpening those areas more than the Sharpen More filter.
This filter is great if you have items in the image that have
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edges that contrast highly against the surrounding
background.

• Smart Sharpen. This filter gives you more control over the
sharpening effect by enabling you to set the sharpening
amount, method, radius, and angle.

• Unsharp Mask. This filter uses a different method of
sharpening by finding pixels that are different from the
surrounding pixels and then increasing the contrast in the
surrounding pixels. We discuss the Unsharp Mask filter in the
next section.

The following example takes you through the process of
using the basic sharpening filters to sharpen an image:

1. Open the image in Photoshop, as shown in Figure 14.1.

Notice that the image is blurry.

Figure 14.1

A very blurry image opened in Photoshop
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2. Right-click the background layer in the Layers panel,
and select Duplicate Layer from the Layers panel menu,
as shown in Figure 14.2.

This displays the Duplicate Layer dialog box.

3. Name the duplicate layer in the Duplicate Layer dialog
box, shown in Figure 14.2, and click OK to create the
layer.

The new layer is added to the Layers panel.
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Figure 14.2

Duplicating the background enables you to create a copy of
the image to work with without damaging the original pixels.

4. Right-click the new layer, and select Convert to Smart
Object from the menu, as shown in Figure 14.3.

5. Choose Filter⇒Sharpen⇒Sharpen to apply the
Sharpen filter to the Smart Object.

6. Choose Filter⇒Sharpen⇒Sharpen More to apply the
Sharpen More filter to the Smart Object.

Figure 14.3
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Making the duplicate layer a Smart Object enables you to
apply the filters as Smart Filters.

7. Choose Filter⇒Sharpen⇒Sharpen Edges to apply the
Sharpen Edges filter to the Smart Object.

The Sharpen, Sharpen More, and Sharpen Edges filters are
applied as Smart Filters to the Smart Object, as shown in
Figure 14.4.

Figure 14.4

Applying the Sharpen, Sharpen More, and Sharpen Edges
filters as Smart Filters to the blurry image
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The results of applying the Sharpen, Sharpen More, and
Sharpen Edges filters are shown in Figure 14.5. Notice that
the Sharpen filter does not have as drastic an effect on the
image as the Sharpen More filter, and that the adding a
Sharpen Edges filter applies additional sharpness to the
image.

Figure 14.5

Notice the results of the Sharpen, Sharpen More, and Sharpen
Edges filters on the image. Sharpen More makes a bigger
difference than Sharpen, and Sharpen Edges applies changes
mostly around the edges of the wing and body.
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On the Web

You can find the file used to create the image shown in
Figure 14.5 on this book's website as Figure 14.5.psd. Open
it in Photoshop and see the effects of the Sharpen, Sharpen
More, and Sharpen Edges filters. The sharpen filters are
applied as a separate layer, so you can delete that layer or
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hide it and try to make your own adjustments as you follow
along with the exercises.

Using the Unsharp Mask filter

The Unsharp Mask filter uses a more advanced method of
sharpening images than the basic sharpening filters. Instead of
detecting the edges in the image, the Unsharp Mask filter
finds pixels that are different from the surrounding pixels by a
specified threshold. Then it increases the contrast in a
specified set of surrounding pixels called a neighborhood. For
example, if a pixel is darker than the surrounding
neighborhood, then the neighborhood is lightened.

Figure 14.6 shows the Unsharp Mask dialog box that appears
when you choose Filter ? Sharpen⇒Unsharp Mask. Using the
Unsharp Mask dialog box, you can set the following values
when sharpening an image:

• Preview size controls. These controls appear as a minus
and plus button, and enable you to adjust the size of the image
in the preview window of the Unsharp Mask dialog box. You
can drag the image inside the preview window to adjust the
position of the preview or simply click the preview image.

• Amount. This slider specifies the amount used to increase
the contrast of the pixels in the neighborhood when
sharpening. A greater value here creates a more dramatic
sharpening effect in the image.
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• Radius. This slider specifies the size of the neighborhood to
use when calculating whether a pixel doesn't match the
surrounding pixels. A greater radius means that a larger area
of the image is affected by the sharpening, so the edge
transitions are more gradual. A smaller radius means that a
smaller number of pixels are affected, so the edge transitions
are more abrupt.

• Threshold. This slider specifies the threshold used to
calculate whether a pixel matches the surrounding
neighborhood. A larger value here means that only significant
differences between a pixel and its neighbors are sharpened.
Typically, you want to use a threshold value between 4 and
20 pixels.

Use the following steps to apply an Unsharp Mask filter to an
image in Photoshop:

1. Open the image in Photoshop.

2. Right-click the background layer and select Duplicate
Layer from the menu to display the Duplicate Layer
dialog box.

3. Name the duplicate layer in the Duplicate Layer dialog
box, and click OK to create the layer.

The new layer is added to the Layers panel.

4. Right-click the new layer, and select Convert to Smart
Object from the menu (refer to Figure 14.3).
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5. Choose Filter⇒Sharpen⇒Unsharp Mask to apply the
Unsharp Mask filter to the Smart Object.

The Unsharp Mask dialog box appears, as shown in Figure
14.6.

Figure 14.6

The Unsharp Mask filter enables you to set the amount of
sharpening, the radius of the neighborhood to sharpen, and
the threshold to use to determine pixels that need sharpening.

6. Adjust the size of the preview by clicking the plus and
minus buttons, and drag the image until you have a
preview area that includes the part of the image you are
most interested in sharpening.

In Figure 14.6, we adjusted the size and dragged the image so
that the turkey's face was visible in the preview area.
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7. Adjust the Amount value to set the amount of
sharpening to take place.

In this example, we set the value to 130 percent to make a
large change.

8. Adjust the Radius value to include enough of the
surrounding pixels to detect the change and provide a
smooth transition along the edges.

In this example, we set the radius to 6 pixels so we could get
enough of the surrounding pixels.

9. Adjust the Threshold value until only the areas you
want sharpened are being sharpened by the filter.

You may need to go back and adjust the Amount and Radius
values if you don't get a threshold setting that you like.

10. Click OK to apply the Unsharp Mask filter as a Smart
Filter to the layer.

The results of applying the Unsharp Mask filter are shown in
Figure 14.7.

Figure 14.7

Notice the results of the Unsharp Mask filter on the image.
The feathers and head of the turkey have been sharpened by
the filter.
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On the Web

The fine adjustments of the Unsharp Mask filter will be
much more apparent in Photoshop than a printed book, so
we strongly suggest that you try it out for yourself. You can
find the file used to create the image shown in Figure 14.7
on this book‘s website as Figure 14.7jpg. Open it in
Photoshop to see the effects of the Unsharp Mask filter and
try making your own adjustments.

Applying Smart Sharpen

The most powerful tool that Photoshop has to sharpen images
is the Smart Sharpen filter. The Smart Sharpen filter uses the
same algorithm as the Unsharp Mask filter. However, the
Smart Sharpen filter also includes the ability to fine-tune the
amount of sharpening that takes place in the highlight and
shadow areas of the image. The Smart Sharpen filter also
enables you to specify the type of blur you want to remove
from the image. Figure 14.8 shows the Smart Sharpen dialog
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box that appears when you choose Filter⇒Sharpen ? Smart
Sharpen.

Figure 14.8

The Smart Sharpen filter enables you to set the amount of
sharpening, the radius of the neighborhood to sharpen, and
the type of blur to be corrected by the sharpening filter.

Using the Smart Sharpen dialog box, you can set the
following values when sharpening an image:

• Preview size. These controls appear as a minus and plus
button, and enable you to adjust the size of the image in the
preview window of the Smart Sharpen dialog box. You can
drag the image inside the preview window to adjust the
position of the preview or simply click the preview image.

• Preset. This drop-down list enables you to save the current
settings as a preset filter and select it later. This enables you
to apply the same filter settings to several images to correct
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similar blurring caused by lens or camera issues. You can also
delete a preset filter by selecting Delete Preset from the list.

• Amount. This slider specifies the amount used to increase
the contrast of the pixels in the neighborhood when
sharpening. A greater value here creates a more dramatic
sharpening effect in the image.

• Radius. This slider specifies the size of the neighborhood to
use when Photoshop calculates whether a pixel matches the
surrounding pixels. This value is also used to determine the
size of the area affected by the Smart Sharpen filter. A greater
radius means that a larger area of the image is affected by the
sharpening, so the edge transitions are more gradual. A
smaller radius means that fewer pixels are affected, so the
edge transitions are more abrupt.

• Reduce Noise. This slider adjusts the amount of image
noise generated by the Smart Sharpen by applying an
algorithm that detects the noise and reduces it by applying a
gentle blend with adjoining pixels.

• Remove. This drop-down list specifies the type of blur you
are trying to remove from the image. You can specify
Gaussian Blur, Lens Blur, or Motion Blur. Gaussian blurs are
introduced into images when you make image adjustments
such as noise reduction or image resizing. Lens blurs are
introduced into the image due to focus problems. Motion
blurs are introduced into images by either camera or subject
motion.

• Angle. This field enables you to select the angle of motion
when you select the Motion option in the Remove drop-down
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list. This gives Photoshop an idea of the motion of the target
in the image and enables the algorithms to be much more
aggressive when fixing motion blur.

• More Accurate. Selecting this option from the Smart
Sharpen panel menu, causes Photoshop to apply more
accurate algorithms that take more time when processing the
Smart Sharpen filter, but give you a much better sharpening
effect.

To fine-tune the sharpening that takes place in the shadows of
the image, expand the Shadows / Highlights option in the
Smart Sharpen dialog box, and then set the following options
in the Shadows section, shown in Figure 14.9:

• Fade Amount. This slider specifies the amount used to
increase the contrast in neighboring pixels when sharpening
pixels in the shadows range.

• Tonal Width. This slider adjusts the range of tones that are
included in the shadows range. Moving the slider to the left
decreases the maximum value that is considered to be in the
shadows.

• Radius. This slider specifies the size of the neighborhood to
use when calculating whether a pixel belongs to the shadows
range.

Figure 14.9

You can fine-tune the Smart Sharpen filter to set the amount
of sharpening that takes place in the shadows range.
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To fine-tune the sharpening that takes place in the highlights
of the image, expand the Shadows / Highlights option in the
Smart Sharpen dialog box, and then set the following options
in the Highlights section, shown in Figure 14.10:

• Fade Amount. This slider specifies the amount used to
increase the contrast in neighboring pixels when sharpening
pixels in the highlights range.

• Tonal Width. This slider adjusts the range of tones that are
included in the highlights range. Moving the slider to the left
decreases the maximum value that is considered to be in the
highlights.
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• Radius. This slider specifies the size of the neighborhood to
use when calculating whether a pixel belongs to the highlights
range.

Figure 14.10

You can fine-tune the Smart Sharpen filter by setting the
amount of sharpening that takes place in the highlights range.

Using Blur Filters to Soften Images

When you apply a blur filter to an image, it has the opposite
effect of a sharpening filter. Instead of finding edges and
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adding contrast, blurring reduces the contrast, making edges
softer. Photoshop has 11 blur filters.

Caution

Photoshop blurs images by smoothing out some of the
details. However, the detail is permanently lost, so you
likely want to apply the blurring filters on a separate
duplicate layer to avoid losing your original data.

Each blur filter reduces the contrast at different levels and in
different ways. If you choose a Gaussian Blur, for example,
each pixel is compared to pixels around it in an even radius,
and pixels that are closer count more when calculating the
blur value than pixels that are farther away. Choosing a blur
filter softens the edges in your image by blurring only those
pixels that are in high-contrast areas. If you choose a Box
Blur, each pixel is compared to pixels around it in a box
shape, giving the end result an edgier appearance. If you
really want an interesting result, choose a Shape Blur, where
you can choose from dozens of shapes to use for the pixel
comparison.

Understanding the automatic blur filters

The first three blur filters on the Filter⇒Blur menu are
automatic blur filters, meaning that they don't require any
input from the user. These filters are Average, Blur, and Blur
More.
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• Average. This filter takes the average color of the frame (or
selected area) and fills the entire frame with that color. It's not
a great photo enhancer, but it can be useful for creating
matching backgrounds when placing odd-sized photos in a
video file.

• Blur. This filter automatically smoothes the color transitions
in an image to soften the edges.

• Blur More. This filter works the same as the Blur filter by
smoothing the color transitions in an image to soften the
edges. The Blur More filter is several times stronger than the
Blur filter, although it is still subtle.

Using the Gaussian, Box, and Shape Blur filters

The Gaussian Blur, Box Blur, and Shape Blur filters blur all
the pixels throughout an image or selection rather than
selected pixels in high-contrast areas, as the Blur and Blur
More filters do. The pixels are blurred by reducing the
contrast between each pixel and the surrounding pixels. The
surrounding pixels are determined by both the filter and the
Radius setting you use.

Gaussian Blur

The Gaussian Blur compares the pixels in an even radius
around each pixel and applies a weighted average to each
pixel to reduce its contrast to the surrounding pixels. This
results in a general softening of the image. You can apply a
Gaussian Blur filter by choosing Filter⇒Blur⇒Gaussian Blur
to open a dialog box that enables you to set the radius of the
blur. The radius, of course, is the number of pixels around
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each pixel that this pixel is compared to. Figure 14.11 shows
the effect of creating a selection around the subject and then
applying a Gaussian Blur filter. Notice that the Gaussian Blur
is very smooth.

Figure 14.11

A Gaussian Blur has been liberally applied to the background
to clearly demonstrate the effect.

Box Blur

A Box Blur compares the pixels in a box shape rather than the
feathering-out comparison of the Gaussian Blur. The result is
a blur with edges. You can apply the Box Blur by choosing
Filter⇒Blur⇒Box Blur. This filter has the same dialog box
as the Gaussian Blur, consisting of a preview window and a
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Radius setting, as shown in Figure 14.12. With the Radius
setting turned up to 20, you can clearly see the difference in
the blur filters. Figure 14.12 also illustrates one of the down
sides to the Box Blur. Notice that the area around the boy, and
in particular between the boy's arm and his body, is not very
blurred. This is because of the radius setting. The larger the
radius setting, the less blurring occurs around the edges of the
selection or mask.

Figure 14.12

The Box Blur gives the background an edgy look.

Shape Blur

As if having a soft blur or an edgy blur weren't enough,
Photoshop gives you the choice of literally dozens of shapes
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to use when comparing pixels. The Shape Blur works in the
same way as the Gaussian Blur and Box Blur, except the
pixels are compared to one another in the shape you choose.
Maybe someone at Adobe had too much time on his hands,
but the result can create some interesting blur effects.

Open the Shape Blur dialog box by choosing
Filter⇒Blur⇒Shape Blur. You can see in Figure 14.13 that
the dialog box is full of all sorts of fun shapes that you can
use in the Blur filter. Click the menu button next to the list of
shapes to add additional sets of shapes to the selectable list.
Of course, the preview window and the Radius setting are
part of the dialog box as well. The higher you set the Radius
setting, the more likely you are to see a real difference in the
effects created by each shape. Figure 14.13 shows an example
of what the star shape does for this blur effect.

Figure 14.13

The Shape Blur has a completely different look than either the
Gaussian Blur or the Box Blur, despite having the same
radius of 200 pixels.
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On the Web

You can find the file used to create the image shown in
Figures 14.11, 14.12, and 14.13 on this book‘s website as
Figure 14.11.psd. Open it in Photoshop to see the effects of
the blur filters. Each of the Gaussian, Box, and Shape filters
is in its own Smart Object layer, so you can turn the blurs on
and off to see the different effects.

Creating a direction blur

The Motion Blur and Radial Blur filters create the illusion of
motion in your image. These filters are very useful in adding
a motion effect to either the entire image or a specific
selection. A Motion Blur adds a directional blur that moves
across the 2-D plane of the image. A Radial Blur adds
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blurring that radiates outward from a central point in the
image.

Adding a Motion Blur to an image

The Motion Blur filter simulates movement in a straight path,
which you determine by setting the angle in the dialog box.
The following example takes you through the process of
adding two types of motion blur to an image. The image is
that of a boy running. The example shows how to emphasize
the movement by adding motion blurring. First you will apply
motion blur to the boy as if the camera were fixed, and then
you will add motion blur to the background as if the camera
were tracking the boy.

1. Open the image in Photoshop.

2. Select the area of the image where you want to add the
Motion Blur effect, and press Ctrl+C/ +C to copy the
selection to the clipboard.

3. Add three new layers to the image using the Layers
menu.

4. Paste the contents of the clipboard into two of the newly
created layers, as shown in Figure 14.14. We will use one
of these layers to apply motion blur to the boy, and the second
layer to sit on top of the blurred background and enable the
boy to maintain clarity.

Figure 14.14

Paste the clipboard contents into the new layer.
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5. Invert the selection and copy the background using
Ctrl+C/ +C.

6. Copy the background into the empty layer as shown in
Figure 14.14.

7. Right-click each of the new layers, one at a time, and
select Convert to Smart Object.

8. Select one of the layers with the boy cutout and choose
Filter⇒Blur⇒Motion Blur to apply a Motion Blur filter
to the Smart Object.

It is important that the boy cutout layer to which you will not
apply a motion blur is above the cutout of the background in
the layers panel.

The Motion Blur dialog box appears, as shown in Figure
14.15.

Figure 14.15
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The Motion Blur filter enables you to set the angle and
direction of the blur that is applied to the image.

9. Adjust the Angle to match the relative direction of the
motion you want in the image.

In the example, we adjusted the angle to 10 degrees to match
the slope of the field.

10. Adjust the Distance to the desired number of pixels
and click OK.

A small number of pixels blurs the image oNL1y slightly.
Increasing the Distance increases the amount of movement in
the subject and makes the image blurrier. In this example, we
increased the distance to 50 to make the runner look like he
was moving faster.

11. Repeat Steps 8 through 10 to apply the same blur to
the background cutout layer.
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12. Hide the sharp boy cutout and background cutout
layers to see an example of only motion blurring the boy,
as shown in Figure 14.16.

13. Hide the blurred boy cutout and show the sharp boy
cutout and blurred background cutout to show the
background motion blur as if the camera were tracking
the boy, as shown in Figure 14.16.

Figure 14.16

Applying the Motion Blur filter to an object helps to
emphasize the speed of movement, whereas applying the
same filter to a background helps to simulate a camera
tracking a moving object in the photo.
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On the Web

You can find the file used to create the image shown in
Figure 14.16 on this book's website as Figure 14.16.psd.
Open it in Photoshop to see the effects of the Motion Blur
filter.

Adding a Radial Blur to an image
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The Radial Blur filter enables you to add blurs that radiate
outward from a central point. To apply a Radial Blur, choose
Filter⇒Blur⇒Radial Blur and set the following options, as
shown in Figure 14.17:

• Amount. This slider specifies the amount of blur to apply to
the layer.

• Spin. This option gives the image the illusion that it is
spinning in a circular motion.

• Zoom. This option blurs the edges of the image more than
the center, creating the illusion that the image is moving
rapidly toward or away from the viewer.

• Quality. This section enables you to specify Draft, Good, or
Best. The better the quality, the better the results look;
however, the Radial Blur filter takes a lot of processing
power, so you should try it out in Draft mode first and then
increase the quality after you get the desired results.

• Blur Center. This pane enables you to drag the center of the
blur to any location in the image. The lines show the amount
of blurring that will take place.

Figure 14.17

The Radial Blur filter offers Spin and Zoom options.
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On the Web

You can find the file used to create the image shown in
Figure 14.17 on this book's website as Figure 14.17.psd.
Open it in Photoshop to see the effects of the Radial Blur
filter and play around with the direction and amount of the
blur.

Adding a Surface Blur

The Surface Blur filter is the opposite of the Blur and Blur
More filters. Rather than softening the edges, the Surface Blur
works by softening the midtones, leaving the edges sharp and
crisp. This is perfect for smoothing out slight imperfections or
noise in an image without losing crisp detail.

Applying a Smart Blur

The Smart Blur enables you to blur with more precision by
using radius and threshold settings that enable you to specify
the number of pixels involved and what the difference in the
pixels should be before you apply the filter to them. The
Smart Blur is a great option if you are not sure exactly what
blur effect you would like to add to an image.
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To apply a Smart Blur, select Filter⇒Blur⇒Smart Blur from
the main menu bar and set the following options, as shown in
Figure 14.18:

• Radius. This slider specifies the area of pixels that are
searched to determine whether a pixel is dissimilar to its
neighbors and should be blurred.

• Threshold. This slider specifies the amount of dissimilarity
a pixel must have with its neighbors before the filter is
applied to it.

• Quality. This drop-down list enables you to specify a Low,
Medium, or High quality. The better the quality, the better the
results look; however, the Smart Blur filter takes a lot of
processing power, so you should try it out in Low mode first
and then increase the quality after you get the desired results.

• Mode. This drop-down list enables you to specify a Normal,
Edge Only, or Overlay Edge blur. The Normal setting gives
you basic blurring results. The Edge Only setting turns the
image entirely black and creates white edges. The Overlay
Edge setting overlays the edges in the image with white.

Figure 14.18

The Smart Blur filter enables you to specify the area of pixels
and threshold to use when blurring the image.
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Faking Lens Blur

The Lens Blur is by far the most advanced blur filter
available. It presents a very involved dialog box that enables
you to change aspects of your image, including the depth of
field and specular highlights. The whole point of the Lens
Blur is to enable you to blur parts of your image while leaving
other areas in sharp focus.

The Lens Blur dialog box shows a full preview of your image
by default. Because the changes you make probably affect
different areas of your image differently, you can see the
effects your changes have on your full image. Because the
precise changes made by the Lens Blur can take time, you
have the option of choosing between a faster or more accurate
preview. The following sections discuss the adjustments that
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you can make in the Lens Blur dialog box, shown in Figure
14.19.

Figure 14.19

The Lens Blur dialog box is loaded with options for creating a
custom blur.

Preview

The preview pane for the lens blur is very big and can be slow
when rendering large images. To let you choose between
speed and accuracy, Photoshop provides the Faster and More
Accurate options. The faster preview renders more quickly
but is less like the actual filter than the more accurate setting.
Which option you use depends on whether you have time to
wait.

Depth Map
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An image or video file in Photoshop is just a pixel map.
Photoshop can't determine which areas of an image should be
in focus and which shouldn't be. Setting the Depth Map tells
Photoshop which pixels to keep sharp and which ones to blur.
You can create a Depth Map in several ways. Selecting None
from the Source drop-down list blurs the pixels in your image
indiscriminately. Choosing Transparency blurs the pixels
based on their Transparency values. If you select Layer Mask,
the blurring is based on the grayscale values in the layer
mask. For example, if you create a gradient layer mask, the
lighter areas of the gradient are less blurry than the darker
areas.

The best way to create a Depth Map is to create and load an
alpha channel. (See Chapter 11 for more information on
creating an alpha channel.) The dark areas of the alpha
channel are treated as the foreground of the image, and the
light areas are treated as the background. Figure 14.20 shows
an alpha channel that matches the shape of the cabin in the
Lens Blur dialog box (refer to Figure 14.19). When you've
created an alpha channel, it appears in the Source drop-down
list, and you can use it to determine which pixels are blurred.
Click anywhere on your image to choose the pixel brightness
that determines which areas of your picture stay in focus.

Figure 14.20

The Channels panel contains an alpha channel created with a
selection.
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If you select a source other than None, you can choose the
focal distance of the blur by adjusting the slider. As the focal
distance changes, the area inside the alpha channel becomes
sharper and the area outside the alpha channel becomes more
blurred. You can also invert the effects on the respective parts
of the alpha channel by selecting the Invert option.

Iris

You can specify the size and shape of the aperture of a
camera using the Iris settings in the Lens Blur dialog box.
These settings enable you to simulate the different types of
irises found in different cameras. The Iris settings enable you
to change the following options:

• Shape. This drop-down list enables you to specify the shape
of the iris in terms of the number of blades, from 3 to 8.

• Radius. This slider determines the number of pixels
sampled to create the blur effect.

• Blade Curvature. This slider specifies the curvature of the
blade in a range between 0 and 100. The curvature of the
blade affects the amount of blurring around the edges in the
image.
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• Rotation. This slider specifies the rotation of the iris in
degrees. This enables you to apply the filter at different
rotations that affect the results of the blur.

Specular Highlights

When you blur a photograph using a mathematical formula,
your whitest whites tend to dissipate and be replaced with
duller tones. This would never happen in a real photo, no
matter how blurry it became. You can readjust the whites in
your image by using the following settings to add specular
highlights:

• Brightness. This slider specifies the value by which you
want to increase the whites to bring back the brilliance.

• Threshold. This slider specifies the levels affected by the
Brightness setting. The default is 255, meaning only pure
white. As you move the slider to the left, darker pixels are
included.

Noise

All photographs contain noise, even blurry ones. To create a
more realistic blur, you can add noise to your image using the
following settings:

• Amount. This slider specifies the amount of noise to add
when blurring.

• Uniform. This option adds noise uniformly to the image in a
linear fashion, so the effect is consistent.
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• Gaussian. This option adds noise based on the amount of
sharpening or blurring that occurs in the pixels. The Gaussian
effect appears more natural but does occasionally create some
artifacts in the image.

• Monochromatic. This option adds noise as gray instead of
based on the color of the surrounding pixels. The result can
appear more natural, but it typically worsens the overall
effect.

Introducing the Blur Gallery

The Blur Gallery is different from other blurring filters in that
it launches multiple components that you can use to make
changes by clicking the OK button and applying the changes
to the image when you are finished. The Blur Gallery consists
of two panels: an Options bar and several on-image controls.
You can access the Blur Gallery by choosing
Filter⇒Blur⇒Field Blur, Iris Blur, or Tilt-Shift Blur in
Photoshop.

Using the Blur Gallery tools enables you to soften your
images with extreme dexterity and flexibility. The Blur
Gallery Options bar provides functionality to control some of
the external factors of the blur operation such as selection
bleeding and focus. The Blur Tools panel contains controls
that enable you to add up to three different types of blur filters
to the image: the Field Blur, Iris Blur, and Tilt-Shift Blur. The
Blur Effects panel provides controls to add lighting and color
effects, such as a bokeh (out of focus points of light caused by
background light and the aperture shape), to the blur filter.
The on-image controls enable you to pinpoint specific areas
of an image to blur and control the blurring behavior.
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Using the Blur Gallery Options bar

The Blur Gallery Options bar enables you to control how the
filters in the Blur Gallery are applied, as well as the output
from the Blur Gallery, as shown in Figure 14.21.

Figure 14.21

The Blur Gallery Options bar enables you to control the
behavior and quality of the Blur Gallery filter.

The following list describes the options that are available in
the Blur Gallery Options bar:

• Selection Bleed. This drop-down list becomes available
when you are adding a blur to a selected area of the image.
This option determines how much the selected areas will
blend and bleed with the unselected areas. This option is very
important to use if you want the blur effect in the selection to
blend well with the surrounding pixels.

• Focus. This drop-down list specifies the amount of the
non-blurred area of a specific pin that will be preserved when
you place multiple pins. You can set a specific focus for each
pin by selecting the pin and adjusting this setting.

• Save Mask to Channels. This is a great option for adding
additional effects to your blur later. Each pin you place
generates a blur field. When you select this option, the blur
fields generated by the pins are merged and the results of the
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intensity of the blur are translated into an alpha channel in the
Channels panel, as shown in Figure 14.22. In Figure 14.22,
we have added several blur pins; for the ones directly on the
flowers, we set the blur to 0, and on the others, we set the blur
to 25 pixels. These blur pins result in the individual flowers
being in focus, and the elements around them being out of
focus. You can apply any of the alpha channel techniques to
the image using the newly created channel.

Figure 14.22

Selecting the Save Mask to Channels option in the Blur
Gallery creates a new alpha channel in the Channels panel
when you apply the blur.

• High Quality. The bokeh highlighting is more accurate
when you select this option. Keep in mind that this option
results in more processing time for complex filters and large
images.
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• Preview. This option enables you to see a preview of the
blur effects in the image when you select it.

• Remove all pins. All blur pins are removed and you can
begin again with a fresh image when you select it.

Using the on-image controls

When you are applying blur tools, each tool provides a set of
on-image controls that you can use to fine-tune the size,
location, and effect of the blur. You will want to become
familiar with these controls, so you can easily adjust the blur
to provide the exact effect for which you are looking.

Field Blur tools

The Field Blur tools enable you to quickly add and position
blurring fields to different areas of your images to obscure
some aspects or enhance the focus of other areas. Figure
14.23 shows the Field Blur panel as well as the on-image
tools for Field Blur. These tools appear when you choose
Filter⇒Blur⇒Field Blur from the main menu bar. The
following list describes each of the available options in the
Field Blur panel and on-image tools:

• Blur. This slider in the Field Blur panel adjusts the blur
amount of the selected pin up and down.

• Blur pin cursor. This mouse cursor appears when you open
up the Blur Gallery. When this cursor is active, Photoshop
places a blur pin on the image when you click the right mouse
button.
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• Blur pins. These pins show the center of the blur fields that
you have placed on the image. The blur field radiates out
from the blur pin. You can move the blur pin by dragging it
around the image with the mouse.

• Active blur pin. Selecting a blur pin activates it. Notice that
the active blur pin has a ring around it and that part of the ring
is white and part is black. The white part of the ring denotes
the amount of blur that is being applied to that field. Using
the mouse you can adjust the amount of blur by dragging the
white further around the ring. Each blur pin can have different
settings for the blur amount.

• Inactive blur pin. This is how a blur pin appears when it is
not active.

Tip

You can drag the blur ring around with the mouse to
increase and decrease the blur amount. You can also drag a
blur pin around with the mouse to reposition it on the image.

Figure 14.23

The on-image controls for the Field Blur enable you to adjust
the blur amount as well as the location of the blur fields.
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Iris Blur on-image tools

The Iris Blur tools enable you to quickly add and position a
graduated blurring field to different areas of your image. The
graduated blurring field gets gradually sharper as you move
toward the center. Figure 14.24 shows the Iris Blur panel as
well as the on-image tools for Iris Blur. These tools appear
when you choose Filter⇒Blur⇒Iris Blur from the main menu
bar. The following list describes each of the available options
in the Iris Blur panel and on-image tools:

• Blur. This slider increases and decreases the blur amount of
the selected pin.

• Blur pins. These pins show the center of the blur fields that
have been placed on the image. The blur fields radiate from
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the blur pins until they run into the edge of the image, or the
blur field from another pin.

• Active blur ring. This ring appears around a blur pin when
you click it with the mouse. This indicates that the blur ring is
active. Notice that part of the ring is white and part is black.
The part that is white denotes the amount of blur that is being
applied to that field. Each blur pin can have different settings
for the blur amount.

• Ellipse. This shape shows the general edge of the blur
effect. The parts of the image that are inside the ellipse are not
blurred, while the parts outside the ellipse are blurred.

• Ellipse handles. These handles enable you to use the mouse
to resize the ellipse. Just drag a handle to change the size.

• Roundness knob. This feature enables you to control the
shape of the ellipse. Dragging the roundness knob with the
mouse enables you to adjust the ellipse to be more or less
rectangular.

• Feather handle. These handles are located in four locations
around the ellipse. As you adjust them, you adjust the amount
of feathering that occurs around the edge of the ellipse. The
closer to the ellipse the handles are, the less feathering takes
place, making the blur edge more distinctive.

Figure 14.24

The on-image controls for the Iris Blur enable you to adjust
the blur amount as well as the location, shape, and feathering
of the blur fields.
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Tilt-Shift Blur on-image tools

The Tilt-Shift Blur tools enable you to quickly add and
position horizontal or vertical blurring effects to an image,
which can give your images better depth. Figure 14.25 shows
the Tilt-Shift Blur panel as well as the on-image tools for the
Tilt-Shift Blur. These tools appear when you choose
Filter⇒Blur⇒Tilt-Shift from the main menu bar. The
following list describes each of the available options in the
Tilt-Shift Blur panel and on-image tools:

• Blur. This slider in the Tilt-Shift panel increases and
decreases the blur amount of the selected pin.

• Distortion. This slider enables you to adjust the amount of
distortion created in the lower blur zone. The distortion
radiates from the blur pin. For example, if you slide the blur
pin to the right, then the lower blur zone is distorted to the
right.
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• Symmetric Distortion. This option enables you to activate
or deactivate symmetrical distortion. When activated, the
distortion created by the tilt-shift blur is symmetrical about
the axis defined by the tilt shift tool.

Tip

No matter how much you rotate the Tilt-Shift focus zone,
Photoshop will remember which blur zone was the original
lower zone and will therefore keep the distortion in that
zone.

The distortion created by this slider radiates from the blur
ring. Move the blur ring parallel to the focus lines within the
focus zone to see the difference.

• Blur pins. These pins show the center of the blur fields that
you have placed on the image. The blur fields radiate from the
blur pins.

• Active blur ring. This ring appears around a blur pin when
you click it with the mouse. This indicates that the blur ring is
active. Notice that part of the ring is white and part is black.
The part that is white denotes the amount of blur that is being
applied to that field. Each blur pin can have different settings
for the blur amount.

• Rotate handle. This handle enables you to rotate or tilt the
direction of the blur. Simply click the handle and drag the
mouse to the left or to the right.
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• Tilt angle. This indicator displays the angle of the rotation.
This is useful if you want to create a blur effect to match a
specific angle in the image.

• Focus lines. These lines appear around the area of the image
that will remain in focus. You can drag each of the focus lines
to change this area.

• Feather lines. These lines indicate a transition zone. The
area between these lines and the focus lines is feathered to
provide a smooth transition to the blur zone.

• Focus zone. This area remains in focus.

• Transition zone. This is the part of the image that is
feathered from focused to blurry, starting at the focus line.

• Blur zone. This part of the image is uniformly blurred.

Figure 14.25

The on-image controls for the Tilt-Shift Blur enable you to
adjust the blur amount as well as the angle, location, and
feathering of the blur fields.
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Applying a Field Blur

The most dynamic of the Blur Gallery tools is the Field Blur.
By changing the amount of the blur and the location of the
blur pins, you can create some fantastic blur effects with the
Field Blur. You can create extremely intricate blur designs by
adding more blur pins.

In the following example, you will add front and rear blur
fields to this image of flowers, giving it a depth of field:

1. Open the image in Photoshop.

2. Choose Filter⇒Blur⇒Field Blur.

This opens the Blur Gallery.

3. Move the blur pin to the area of the image you want to
remain in focus, as shown in Figure 14.26.
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4. Set the blur value of that blur pin to 0.

This creates a field that will protect that part of the image.

5. Add a blur pin above the area that you want to remain
in focus, as shown in Figure 14.26.

6. Set the value of that blur pin to 25.

This blurs everything above the center blur field.

7. Add a blur pin below the area that you want to remain
in focus, as shown in Figure 14.26.

8. Set the value of that blur pin to 20.

This blurs everything below the center blur field.

9. Click the OK button.

Notice that the center of the image remains in focus but the
areas above and below are blurred, giving the image a depth
of field just as if the photo was shot with a wide aperture.

Figure 14.26

Adding three Field Blur pins using the Blur Gallery, you can
quickly add depth of field to a flat image.
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Adding an Iris Blur

The simplest way to accentuate a subject in a photo is to blur
around the edges of the photo. The Iris Blur is perfect for
softening the edges of an image similar to a vignette effect.
By changing the amount of the blur and the shape of the
ellipse, you can create some very professional blur effects
with the Iris Blur.

In the following example, you will add a soft feathering effect
to the edges of a photograph to accentuate the subjects in the
foreground:

1. Open the image in Photoshop.

2. Choose Filter⇒Blur⇒Iris Blur.

This opens the Blur Gallery.
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3. Move the blur pin to the center of the area of the image
that you want to remain in focus, as shown in Figure
14.27.

4. Drag the roundness knob to adjust the ellipse to be
more rectangular, as shown in Figure 14.27.

5. Drag the ellipse handles to resize the ellipse to exclude
only the area that you want to be totally blurry, as shown
in Figure 14.27.

6. Set the value of that blur pin to 25.

This blurs everything outside the ellipse.

7. Adjust the feather handles until you get just the right
amount of feathering around the edges.

8. Make any other minor adjustments to the ellipse,
feather handles, or blur amount until the image looks the
way you want.

9. Click the OK button.

Notice that the center of the image remains in focus, but there
is a nice softening effect around the edges.

Figure 14.27

Adding an Iris Blur using the Blur Gallery, you can quickly
add a soft edging effect to an image.
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Applying a Tilt-Shift Blur
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The Tilt-Shift Blur enables you to apply blurring effects along
straight lines in your images, which is great for landscapes
and perspective views. Changing the amount of the blur, the
angle, and feathering, you can create some very dramatic blur
effects with the Tilt-Shift Blur.

In the following example, you will use the Tilt-Shift Blur tool
to soften the ridgeline and enhance the cloud formations in a
sunset image:

1. Open the image in Photoshop.

2. Choose Filter⇒Blur⇒Tilt-Shift.

This launches the Blur Gallery.

3. Move the blur pin to the center of the area of the image
that you want to remain in focus, as shown in Figure
14.28.

4. Drag the rotate handle to match the tilt in the focus line
to that of the skyline, as shown in Figure 14.28.

In this example, we rotated the focus line more than 180
degrees so that we could distort the clouds in the sky above
the sunset.

5. Adjust the focus lines so that they only include the area
that you want to remain in focus.

6. Adjust the feather lines to exclude only the area that
you want to be totally blurry, as shown in Figure 14.28.
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7. Set the value of the blur pin to 25.

This blurs everything outside the focus lines.

8. Adjust the position of the blur pin to the right or to the
left to add distortion to the lower blur zone.

9. Adjust the distortion setting in the Tilt-Shift pane until
you get the right amount of distortion in the lower blur
zone.

10. Make any other minor adjustments to the tilt,
transition zones, focus zones, blur pin, blur amount, and
distortion settings until the image looks the way you want.

11. Click the OK button.

We now have a nice softness to the skyline, almost making it
look like an evening mist, and the upper clouds are more
dramatic.

Figure 14.28

By applying a Tilt-Shift Blur using the Blur Gallery, you can
add a dramatic effect to a sunset image.

952



Adding blur effects in the Blur Lab

A great feature of the Blur Gallery is the ability to add effects
to the blurred section of an image. These effects can enhance
the overall effect of the blur.

The Blur Effects panel, shown in Figure 14.29, is launched
when you select any of the Blur Gallery filters. A great effect
available in the Blur Gallery is the bokeh. A bokeh effect is a
photograph artifact that is created by an interaction with
points of light in the background as well as the shape and size
of the camera aperture. Bokeh are manifested as blurred
points of light in the photograph. Using the Blur Effects
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panel, you can adjust the following options when adding a
bokeh effect:

• Light Bokeh. This slider enables you to specify the
intensity of the bokeh. The greater the value, the larger the
image enhancement.

• Bokeh Color. This slider specifies the amount of color to
include in the bokeh. A value of 0 percent is neutral, and 100
percent is full color.

• Light Range. This slider enables you to set the upper and
lower brightness values that will be impacted by the Light
Bokeh effect. Typically, you want to keep the difference
between the light and dark at around 5.

Figure 14.29

Applying a bokeh effect can add some nice aesthetic qualities
to the blurred areas of the image.
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Reducing Noise in an Image

Noise results from any pixels that don't belong in an image.
Some types of noise include excessive grain, pixelation, and
half-toning. Excessive grain can be caused by low lighting,
high ISO settings, and even by adjustments in Photoshop.
Pixelation occurs when artifacts are left over after an image is
resampled to a higher resolution, rotated, or transformed in
other ways. Half-toning and moiré patterns are some
examples of artifacts that can be introduced during a scan of a
printed image.

The two types of noise are color (chroma) noise and
luminance noise. Color noise manifests itself as colored
artifacts that don't match the image and become more
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apparent the more you zoom in on the image. Typically, color
noise is more visible in one color channel than the others.
Luminance noise manifests as bright-gray pixels in grainy
images or halos.

Reducing noise and removing dust and scratches can improve
the look of images. This section discusses some of the
methods of reducing noise in images using the noise filters
found in the Filter⇒Noise menu.

Using the Despeckle filter

The Despeckle filter is much like the Surface Blur filter. It
detects the edges in your image by finding high-contrast areas
and blurring the areas in between the edges, reducing the
overall noise in the image. You apply the Despeckle filter to
the image or layer by choosing Filter⇒Noise⇒Despeckle.

The Despeckle filter has no dialog box to control the amount
of blurring that takes place, so it is limited in what it can do.
However, you can apply the Despeckle filter as many times as
you want to the image. Each time you apply the Despeckle
filter, more smoothing occurs.

Applying a Median filter

The Median filter removes noise from an image by searching
each pixel to find pixels that are of similar brightness. If it
finds pixels that are different from their surrounding pixels, it
replaces them with a pixel value that is determined by the
median brightness value of the surrounding pixels. Pixels that
vary too much from their neighboring pixels are ignored
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when calculating the median, so they don't skew the median
value.

The Median filter enables you to specify the radius of the area
to use when calculating the median value. The best value of
the radius varies, depending on the variance of pixels in the
image. You can use a higher radius value for images that
contain little variance.

To apply a Median filter to an image, you choose
Filter⇒Noise⇒Median. Figure 14.30 shows an example of
using the Median filter on an image. Notice that when you
zoom in on the hawk's tail, the sky and even the feathers show
some noise. When you use a Median filter with a radius of 2,
the noise is cleaned up. Some detail is lost due to blurring, but
it is still acceptable. However, when you use a Median filter
with a radius of 5, you lose a great deal of detail. You need to
play around with the filter to figure out the best radius value
to remove the noise while minimizing detail loss.

Figure 14.30

The Median filter enables you to configure a radius setting
that controls the area affected by the filter. Too small a radius
does not clean up the noise, but too large a radius removes too
much detail.
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Reducing dust and scratches

You can reduce the imperfections in your image by choosing
Filter⇒Noise⇒Dust and Scratches. The key to success with
this filter is to find a good balance between the Radius and
Threshold settings.

Turning up the Radius while leaving the Threshold at 0
quickly reduces the dust in your image but also adds a blur to
it. By increasing the Threshold, you can keep most of the
sharpness in the image and still reduce the imperfections, as
shown in Figure 14.31.

Figure 14.31

Getting a good result from the Dust & Scratches filter is a
balancing act between adjusting the Radius and Threshold
settings.
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Using the Clone and Healing tools is usually a
better method of removing dust and scratches from images.
We discuss the Clone and Healing tools in more detail in
Chapter 15.

Reducing noise

The Reduce Noise filter provides the most flexibility of all the
Noise filters. The different settings in the Reduce Noise
dialog box help you customize the Reduce Noise filter to best
match the needs of each specific image.

To use the Reduce Noise filter, you choose
Filter⇒Noise⇒Reduce Noise to open the Reduce Noise
dialog box, shown in Figure 14.32. From this dialog box, you
can adjust the following settings:

• Basic/Advanced. This option toggles between Basic and
Advanced modes. In Basic mode, you change the settings for
all channels at once. In Advanced mode, you adjust settings to
reduce noise in each channel individually.
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• Settings. This drop-down list enables you to select the
default option or one of the previously saved presets. You can
save a preset by clicking the Save button and delete it by
clicking the trash icon.

• Strength. This slider specifies the amount to reduce the
luminance noise in the image when the filter is applied, by
increasing or decreasing the intensity of the overall noise
reduction.

• Preserve Details. This slider specifies the percentage of
detail that must be preserved. To reduce noise, you must
sacrifice some detail. Use this setting to make certain you
maintain at least a minimum amount of detail in the image.
Typically, you should set this option at 60 percent or higher.

• Reduce Color Noise. This slider specifies the percentage of
color noise to remove from the image. If you set this value
too high, Photoshop has difficulty distinguishing between
color noise artifacts and simple variations in the image. This
option is necessary only if color noise exists in the image.

• Sharpen Details. This slider specifies the percentage of
detail to try to gain during the filter process. Noise reduction
is done by blurring and results in lost detail. This option
enables you to specify how much sharpening is applied after
the blurring to regain some of that lost detail. Be careful not
to set this value too high, or you will introduce new noise into
the image.

• Remove JPEG Artifact. This option causes the Reduce
Noise filter to minimize the blocky image artifacts and halos
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that can be created when a JPEG file is resampled and then
saved again.

• Per Channel. This panel enables you to select specific color
channels so you can customize the Strength and Preserve
Details options differently for each color channel.

Figure 14.32

The Reduce Noise dialog box enables you to balance the
strength of the noise reduction with preserving detail. You
can also fine-tune the noise reduction based on individual
color channels.

Tip

Removing noise blurs your picture. Photoshop includes the
Sharpen Details setting with this feature to counteract that
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blurring. You can use this setting or use a more powerful
sharpening filter after you have reduced the noise.

Adding noise

In addition to removing noise, Photoshop also enables you to
introduce noise into an image. Adding noise to an image adds
graininess to it that can simulate film grain, add a texture
effect, or camouflage areas that have been corrected.

To add noise to an image, you choose Filter⇒Noise⇒Add
Noise to open the Add Noise dialog box, shown in Figure
14.33. You can add noise using the Uniform setting, which
randomizes the values used to create the noise pattern, or
using the Gaussian setting, which uses the bell curve to create
the values. When you add noise to an image, it can appear in
varied colors, which can change the color integrity of your
file. To avoid this, choose the Monochromatic option to
create noise as shades of gray.

Figure 14.33

The Add Noise dialog box enables you to introduce noise into
an image to simulate film grain, add a texture effect, or
camouflage areas that have been corrected.
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Removing Camera-Shake Blurring from an Image

One of the most common types of problems with photos,
especially in today's world of smart phone cameras, is camera
shake. Photoshop provides a specialized tool for removing
camera shake from images. If you know the image is blurry
due to camera shake and not just out of focus, you can use
this tool to sharpen your images with much better
effectiveness than other sharpening tools.

To do this, Photoshop analyzes one or more areas of the
photo, determines the direction of the camera shake, and is
then able to apply much more accurate filters to fix the
blurring. You can launch the Shake Reduction filter by
selecting Filter⇒Sharpen⇒Shake Reduction from the main
menu in Photoshop.
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Inside the Shake Reduction window, shown in Figure 14.34,
there are four tools in the top-left corner that provide the
following functionality:

• Blur Estimation tool. Enables you to select a specific
region of the image that Photoshop will use to estimate and
correct blurring. Typically you should try to pick an area that
should be in focus and has high-contrast areas.

• Blur Direction tool. Enables you to draw a line on the
image that matches the length and angle of a straight surface
in the image such as a window edge or side of a building.
This is a bit more accurate than the Blur Estimation tool if
there is a good line to match in the image. The line you draw
needs to match as closely as possible to both the angle and
length of the straight line in the image. You can use the [ and
] keys to nudge the size of the line and Ctrl/ +[ and Ctrl/ +]
to nudge the angle of the line.

• Hand tool. Enables you to move the image inside the Shake
Reduction window.

• Zoom tool. Enables you to zoom in and out on the image.

Figure 14.34

The Shake Reduction filter enables you to use tools to create
Blur Estimation and Blur Direction regions that Photoshop
can analyze in order to remove camera shake from your
digital images.

964



Each of the Blur Trace regions created by the tools can be
adjusted in the Blur Trace Settings section of the Shake
Reduction window shown in Figure 14.34. You can do this by
changing the following settings:

• Blur Trace Bounds. Adjusts the size of the pixel grid that is
used to estimate blur within the image. With high-contrast
regions this setting can be higher, but it should be reduced for
low-contrast regions. This feature is available when you
select a Blur Estimation region.

• Source Noise. Enables you to define the amount of noise
that is actually within the region. Noise is busyness; for
example, a solid tie would be considered low noise and a
paisley tie would be high noise. The available options are
Auto, Low, Medium, and High. Photoshop uses this value to
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determine how to analyze blur. This feature is available when
you select a Blur Estimation region.

• Blur Trace Length. Enables you to set the exact pixel
length of the Blur Direction line for a Blur Direction region.
This feature is available when you select a Blur Direction
region.

• Blur Trace Direction. Enables you to set the specific angle
of the Blur Direction line for a Blur Direction region. This
feature is available when you select a Blur Direction region.

• Smoothing. Adjusts the smoothing applied along with the
shake reduction to remove hard edges. The larger this
amount, the smoother the output edges will be, but some
sharpening will be lost.

• Artifact Suppression. Specifies the amount of artifact
suppression to apply when rendering the sharpening.
Sharpening introduces at least some unwanted artifacts in the
image. Applying artifact suppression removes these artifacts,
but can result in some loss in sharpness.

The Advanced section of the Shake Reduction window shown
in Figure 14.34 provides the following settings and options:

• Show Blur Estimation regions. This option displays the
Blur Trace regions in the Shake Reduction window.

• Blur Trace icons. These icons represent each of the blur
trace regions. The icon shows whether it is a line or an
estimation, as well as the amount of blurring detected (white
on black). You can select the regions by clicking the icons. If
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you select two of them by Ctrl/ -clicking them, you are
shown a comparison of the areas based on each one.

• Enable/Disable Blur Trace region. These check boxes
appear below the Blur Trace icons. You can use them to
enable or disable the regions.

• Add Suggested Blur Trace. This icon enables you to add a
new Blur Estimation Trace region based on the makeup of the
image. If you are not sure where to begin, you can use this
option and then adjust the regions.

• Delete Blur Trace. This icon enables you to delete a
selected Blur Trace region.

The Detail section of the Shake Reduction window enables
you to see a zoomed-in preview so that you can see the
sharpen effect. You can drag the image in the Detail window
to adjust the position, and use the settings at the bottom to
specify the amount of zoom.

Figure 14.35 shows an example of an image with the
camera-shake blurring removed. To perform the sharpening,
you can follow these steps:

1. Open the image in Photoshop.

2. Select Filter⇒Sharpen⇒Shake Reduction.

3. Create two Blur Estimation Trace regions using the
Blur Estimation tool.
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We created a region over each boy's face, as they were the
most important features of this photo.

4. Adjust the Blur Trace Bounds of the regions to provide
the best results for each face. In this image we adjust the
Blur Trace Bounds to 14 pixels to get the crisp edges around
the eyes.

5. Adjust the Smoothing and Artifact Suppression values
to reduce the artifacts in the image. In this image we adjust
the Smoothing up to 22% and Artifact Suppression to 35% to
remove the rough edges and get rid of the noise generated by
sharpening.

Figure 14.35

Using the Shake Reduction filter, you can remove camera
shake from your digital images with amazing results.

Summary

Using the Photoshop filters enables you to correct blurriness
or noise problems in images and make adjustments to soften
harsh areas of a photo. This chapter discussed using the
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sharpening filters to fix blurry images and enhance edges,
blurring filters to apply softening effects, and noise reduction
filters to remove noise and unwanted artifacts from images.

In this chapter, you learned the following:

• The Shake Reduction filter allows you to remove camera
shake from images with a high degree of accuracy

• The Smart Sharpen filter enables you to fine-tune the
sharpening effect to match the type of blurring problems that
occur in a photo

• Using an Unsharp Mask filter can restore missing detail to
an image

• Applying a blurring filter to the background of a photo
softens the overall appearance of the image

• Using the Field, Iris, and Tilt-Shift filters in the Blur Gallery
enables you to quickly add dramatic blurring effects to your
images

• Using Motion Blur can make an object in a photo appear to
be moving

• Applying a noise reduction filter removes unwanted noise
from an image

• You can remove dust and scratches from damaged images

• You can remove JPEG artifacts caused by the compression
algorithm used when saving JPEG images multiple times
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Chapter 15: Cleaning Up Digital Images with Cloning and
Healing Tools

In This Chapter

Removing blemishes with the Healing Brush tools

Reconstructing images using the Clone Stamp

Combining cloning and healing techniques for best results

Even the best photos can have problems that keep them from
being perfect: dust and scratches, unsightly backgrounds, or
just the presence of an ex-boyfriend. Even the most beautiful
photo models can have blemishes, bulges, or cellulite. Family
pictures are only as good as the family member who has her
mouth open or the one with his eyes closed. The Healing
Brush tools and the Clone Stamp are designed to correct these
problems and make bad photos good and good photos great.

You can use these tools to create artistic effects as well,
adding elements to your photos that wouldn't normally be
there and blending images together seamlessly. We'll show
you how these tools work in depth, and before you know it,
your ex will be history.

Using the Healing Brush Tools

We wish we had a Healing Brush that worked in real life.
From acne to carpet stains, our lives would certainly be much
easier. The idea behind the Healing Brushes is to take a flaw
— such as acne, lens spots, or even unknown people — and
remove it by covering it with a patch made by subtly copying
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and blending the surrounding areas of the image. The Healing
Brushes blend the pixel information of the sampled area with
the lighting, texture, and transparency information of the
target area, so the finished product is an area that blends
better than a straight clone. This is especially useful for areas
that are similar but consist of many different tones, such as a
face.

The Spot Healing Brush works automatically, choosing which
areas to blend. The Healing Brush tool allows you to choose
which area it uses to create the overlay, and you can use the
Patch tool to create a selection around the targeted area and
preview the resulting fix. The Remix tool allows you to
expand or contract objects or to move objects from one area
of your photo to another. The Red Eye tool doesn't really fit
with the description of the Healing Brushes, because the patch
it creates is just composed of dark pixels, but it is a fast fix for
a common photographic problem, so it is grouped in the
Toolbox with the Healing Brushes.

You access the Healing Brushes, the Patch tool, the Remix
tool, and the Red Eye tool by clicking and holding the triangle
at the bottom of the Toolbox icon, as shown in Figure 15.1, or
by pressing J (Shift+J to toggle through the tools).

Figure 15.1

You can find the Spot Healing Brush, Healing Brush, Patch,
Remix, and Red Eye tools all together in the Toolbox.
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Using the Spot Healing Brush

Sometimes we wonder if Adobe didn't feel like they acted too
soon when they named the Magic Wand. The Quick Selection
tool is definitely more magical, and the Spot Healing Brush
makes things disappear faster than you can say
“abracadabra!”

The Spot Healing Brush is primarily used for targeting small
blemishes or spots that are surrounded by areas free of defect.
Because it doesn't allow you to manually set a sample area,
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it's a hit-and-miss tool. When it works, it's a
one-click-wonder, and when it doesn't, the results are usually
extremely bruised and smudged pixels. Thank goodness for
the Undo option and the History panel!

You can change options to determine how the Spot Healing
Brush works by selecting a brush type in the Options bar, as
shown in Figure 15.2. The options are Proximity Match,
Create Texture, and Content-Aware.

Figure 15.2

The Options bar for the Spot Healing Brush

Proximity Match

When you set the Spot Healing Brush to its default option of
Proximity Match, it uses the areas in or around the targeted
area to replace the targeted area. If these areas aren't
consistent with what you want your end result to be, you can
end up with a very interesting patch.

To show you what we mean, look at Figure 15.3. Cleaning the
spots off this girl's cheek by just clicking them with the Spot
Healing Brush is easy, and presto — they disappear! Try that
with the spots around her mouth and nose, however, and you
can see in the second photo that she starts to acquire an extra
body part.

Create Texture
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In targeted areas that are surrounded by variance, such as
under the child's nose in Figure 15.3, you can use the pixels
inside the targeted area by choosing the Create Texture
option. This creates the patch with the pixels inside the
targeted area instead of outside the targeted area. The third
photo in Figure 15.3 shows the end result using this option,
and it looks much better.

Figure 15.3

Using the Proximity Match option works great in areas that
are consistent, but the Create Texture option is better in areas
of variance.

Content-Aware

The Content-Aware option actually samples multiple areas to
create a patch that matches a background with distinctly
different areas. Although it doesn't work with body parts very
well, it seems to do a fair job with rough borders, such as the
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one created by the monolith in Figure 15.4. You can see that
the different coloring and the shadows of the rock were not
only cloned to create the new patch, but cloned in such a way
that they lined up with the rest of the photo.

Using the Spot Healing Brush is as simple as using the cursor
to paint over the area you want to remove from your image.
Photoshop then creates a blended patch based on the options
you select to cover the targeted blemish.

On the Web

You can find the photos shown throughout this section
saved as Figures 15.3, 15.4, and 15.5 on the website. Use
Figure 15.5 to follow along with the exercise.

Figure 15.4

The Content-Aware option makes easy work of taking objects
out of a variegated background.
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Follow these steps to use the Spot Healing Brush to correct a
spot or blemish in an image:

1. Open an image that has one or more spots that need
correcting.

Figure 15.5 is a great photo, but the face of the teenage boy is
marred by acne. Zoom closer to the blemishes if you want a
better view.

Figure 15.5

The acne on this boy's face distracts from an otherwise great
photo.
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2. Click the Spot Healing Brush to select it.

3. Change the brush size to slightly larger than the area
you want healed.

Note

If your blemished area is elongated, you can use a smaller
brush size. However, you must cover the blemish in one
stroke by clicking and dragging the left mouse button to
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mark the entire blemish before releasing it. This ensures that
the Healing Brush doesn't use the blemish outside the stroke
to heal the area inside the stroke.

4. Choose a healing mode from the Mode drop-down
menu in the Options bar.

The Normal healing mode creates a blended patch, using both
the source and target area. The Replace mode works like the
Clone Stamp to actually replace the selected area by copying
and pasting the source exactly how it appears, not blending
the pixels at all. This option is rarely a good idea with the
Spot Healing Brush because you don't get to pick the
replacement pixels. The other modes correspond to the
blending modes and create lighter or darker versions of the
patch.

5. Choose a type of correction from the Options bar.

For the photo in Figure 15.5, we selected Proximity Match
because we wanted the color and texture of the surrounding
skin to become the patch.

6. Choose Sample All Layers in the Options bar if you are
using a second, empty layer, as shown in Figure 15.6, to
make the healing changes.

Figure 15.6

Don't forget to choose Sample All Layers if you are making
non-destructive edits to a second, blank layer.
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Tip

Using a second layer on which you will apply changes is
always an excellent idea. It gives you a canvas to work with
and erase changes from, as well as leaving your original
image unchanged.

7. Click the blemish with the Spot Healing Brush, as
shown in Figure 15.7.

You can click and drag if needed to cover the entire blemish.

Photoshop processes the patch and places it. If you used the
Content-Aware option, this might take some time. Your
results may or may not be satisfactory. Continue with the
following steps to see how the Spot Healing Brush works
differently each time you use it.

8. Undo and then use the Spot Healing Brush repeatedly
to see several different results.
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You will probably see a different result every time. In other
words, if at first you don't succeed…

9. Make a second pass, and even more, if necessary.

Sometimes making two or three passes cleans up edges left by
the initial pass. If the Spot Healing Brush works, you should
get results similar to Figure 15.8.

Figure 15.7

When using the Spot Healing Brush, be sure to cover the
entire blemish with one pass.
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Figure 15.8

When the Spot Healing Brush works, it's almost impossible to
tell that your image ever had a blemish.
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If you don't get the results that you want, you can move on to
the more advanced tools.

Using the Healing Brush

The Healing Brush tool works similarly to the Spot Healing
Brush tool, with the added advantage that you get to set the
sample point so that you can choose the area where the fix
comes from. For example, Figure 15.9 is a photo of a wild
turkey that would look much better if there wasn't vegetation
marring the image, particularly the branch in the foreground
that is so out of focus that it is very distracting. Using the
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Spot Healing brush, even multiple times, results in severely
bruised and unnatural pixels due to the large size of the
blemish. The Healing Brush works much better in situations
like this.

Figure 15.9

Because the blurred branch is such a large blemish on a
variegated background, the Healing Brush is the best tool to
fix it.

Follow these steps to use the Healing Brush to correct this
image:
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On the Web

Use Figure 15.9 from the book's website to follow along
with this exercise.

1. Open an image in need of the Healing Brush tool to
correct it.

If necessary, change the background to a layer by
double-clicking and renaming it.

2. Select the Healing Brush from the Toolbox, or press J.

Press Shift+J to toggle to the Healing Brush if it is nested
behind another tool.

3. Select a brush size from the Options bar.

You can also use the bracket keys, [ and ], to quickly change
the brush size.

4. Alt-click/Option-click to set the sample point.

In Figure 15.10, the crosshair shows that we have chosen the
feathers that have not been marred by the blurry branch. You
can reset the sample point as many times as you need to
throughout the healing process by repeating this step. For
example, you will want to select an area of grass to fix the
bottom portion of the branch.

5. Drag over areas that you want to be healed, as shown in
Figure 15.10.
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UNL1ike the Spot Healing Brush, you can make several
passes to completely cover an area if you need to. As you
drag, notice that the sample point moves along with your
cursor, sampling areas in line with what you need to heal. If
you deselect the Aligned option, releasing the mouse returns
the sample point to the original starting point. If you select
Aligned, the sample point remains the exact same distance
from your Healing Brush tool, no matter how many times you
release your mouse.

Figure 15.10

Set the sample point by Alt-clicking/Option-clicking. The
sample point follows your cursor as you drag the Healing
Brush.
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6. Make as many passes as necessary to clean up any
branches or other elements in front of the turkey.

When you are finished, your photo should look like Figure
15.11.

Figure 15.11

Without the branches in front, this photo is more engaging.

Instead of using a sampled area, you can use a pattern with
the Healing Brush tool. This fix takes the texture of the
pattern you choose and adds it to the color of the area you
pass the Healing Brush over. To use a pattern, choose Create
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Texture from the Healing Brush Options bar. In Figure 15.12,
we used the Healing Brush to give the background of this
photo dimension.

Another benefit of the Healing Brush is that you can use the
Clone Source panel to create multiple samples, sample from
different files, and modify the size and rotation of the source.
The Clone Source panel is an important tool for creating the
best fixes with both the Healing Brush and Clone Stamp, but
it is an integral part of the Clone Stamp; we cover it in detail
in the Clone Stamp section of this chapter.

Tip

Both the Spot Healing Brush and the Healing Brush
frequently leave a blurry smudge instead of a clean fix. This
is a good time to try again, because this result rarely
happens every time you try to heal your photos.

Figure 15.12

The Healing Brush can create textures.
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Fixing larger blemishes with the Patch tool

The Patch tool allows you to heal larger areas easily and
preview the target area you are using. It also uses the source
more thoroughly to completely cover the area that needs
fixing, so you don't leave color behind as frequently as with
the Healing and Spot Healing Brushes.

The Patch tool has an option that enables you to use the
Content-Aware engine to match the background as closely as
possible. You can choose the Normal setting or the
Content-Aware setting from the Options bar, as shown in
Figure 15.13. You want to use the Normal setting to blend the
area you are fixing with the area that you are using to create
the patch. For example, skin tones or areas with similar
backgrounds blend much better to create more realistic
shading. The Content-Aware option uses the color and texture
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information from the background areas around your selection,
creating a complete cover-up rather than a blend.

Figure 15.13

The Options bar for the Patch tool allows you to choose either
a Normal or a Content-Aware patch fix.

The boy in Figure 15.14 has a skinned area on his forehead
that needs to be fixed. However, when you apply the Healing
and Spot Healing Brushes to such a big area, they leave
smudges with pink highlights. In this situation, the Patch tool
is ideal.

Figure 15.14

The skinned area on this boy's forehead is easily fixed with
the Patch tool.
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The Patch tool is extremely easy to use; follow these steps to
get the best results:

On the Web

Use Figure 15.14 from the book's website to follow along
with this exercise.

1. Open an image that you want to patch.

992



2. Select the Patch tool from the Healing Brush tools
flyout in the Toolbox.

3. Select a Patch option from the Options bar.

For a normal patch fix, select Normal. If you want to make a
selection around the area that you are correcting, select
Source. If you want to make a selection around the area you
are using to correct the image, select Destination. For this
example, we selected Source.

Note

If you choose Transparent in the Patch options, the patch
has a transparent background and simply creates an overlay
on the patched area.

4. Draw around the area that you want to heal.

The Patch tool creates a selection much like the Lasso
Selection tool. Draw around the area you want to select, and
close the selection. You can use the Selection options in the
Options bar to add to or subtract from the selection, but it
doesn't have to be exact.

Note

The Patch tool uses a selection to replace the targeted area.
It doesn't matter if you've used the Patch tool to create the

993



selection. You can make a selection with any Selection tool
and use the Patch tool to move and replace the selection.

5. Click and drag the selection over the area that you want
to use to fix the patch.

The actual selection doesn't move, as you can see in Figure
15.15, but an identical selection shows the area you are using.
Additionally, the pixels inside your original selection change
so you can preview the fix. This preview is not the final
result; after you release the mouse button, Photoshop blends
the two areas to create a seamless patch.

Figure 15.15

Simply drag the selection to an area that you can use to fix the
blemish, and release the mouse button for a fantastic fix.

6. Press Ctrl+D/ +D to deselect the selected areas and see
your final results.
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You can make a Content-Aware fix using the same steps
outlined for the normal fix; the difference is in how you apply
the patch. In Figure 15.16, for example, the normal patch
blended in a lot of color from the source and left a blotchy
residue. By using the Content-Aware fix, we got a much
better result.

Figure 15.16

The Content-Aware patch fix is very effective.

Using the Content-Aware fill

The Content-Aware fill isn't found with the Healing tools, but
it takes unwanted elements seamlessly out of an image. The
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Content-Aware feature uses an algorithm that quickly and
seamlessly fills in a selected area of a photo. The
Content-Aware fill and the Content-Aware patch work
similarly, but the Content-Aware patch allows you to choose
the area you would like to mimic.

Note

Because the Content-Aware tool works with the Selection
tools, you can make precise selections.

On the Web

You can try using the Content-Aware fill on this image.
Download Figure 15.17 from the website.

Figure 15.17

Using the Selection tools allows you to target precise areas on
which to use the Content-Aware fill.
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After you've made a selection in an image, choose Edit⇒Fill
to open the Fill dialog box, as shown in Figure 15.18. Choose
Content-Aware from the Use drop-down menu. After you
click OK, the Content-Aware algorithm takes over, searching
your photo for appropriate areas to use in replacing the area
that you have selected. This can be a memory-intensive
process, but when it is finished, your image should look close
to realistic, as shown in Figure 15.19. Even if your photo is
not perfect, it usually takes relatively little cleanup to make it
look good.

Note

The Content-Aware algorithm is memory intensive, and
large files can take several minutes and use a considerable
amount of RAM.
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Tip

The Content-Aware tool, much like the Healing Brushes,
doesn't return the same results every time you use it. If
you're not happy with the first results you get, try again.

Figure 15.18

Choosing the Content-Aware option in the Fill dialog box

Figure 15.19

The Content-Aware algorithm makes short work of removing
even large elements from images.
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Using the Remix tool

The Remix tool allows you to make things bigger or smaller,
or to move them around in your photo. It does this by using
the Content-Aware algorithm to copy areas and put them in
the right places in your image. It's much easier to show you
what we mean than to explain it.

You can try out the Remix tool by following these simple
steps:

1. Open an image that you would like to extend.

We chose the building shown in Figure 15.20.

2. Select the area of your image that you want to extend.
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You can use any selection tool you want. The Remix tool
allows you to create a freehand selection, but it is difficult to
be precise. The more precise your selection, the better the
Remix tool works.

3. Select the Remix tool from the Healing Brush tools
flyout in the Toolbox.

4. Set the Remix options in the Options bar.

To expand the object, select Expand from the Remix pop-up
menu. Selecting Very Strict from the Adaptation menu works
best with items that have hard lines, such as the building in
this example. For items that are less precise, choose a less
strict option.

5. Drag the selection in the direction that you want the
object to expand.

We've noticed that smaller movements net better results, so
we made the building in Figure 15.20 incrementally taller, but
not a lot taller.

Figure 15.20

The Remix tool allowed us to make this building taller.
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Another use for the Remix tool is moving objects around in a
variegated background. For example, toys scattered on a
carpet can be moved around almost seamlessly. We'll show
you how it works.

You can move objects around in a photo with the Remix tool
by following these steps:

1. Open an image containing an item or items with a
variegated background.

We chose to move the boy in Figure 15.21.

2. Select the area of your image that you want to move.
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You can use any selection tool you want. The Remix tool
allows you to create a freehand selection, but it is difficult to
be precise. The more precise your selection, the better the
Remix tool works.

3. Select the Remix tool from the Healing Brush tools
flyout in the Toolbox.

4. Set the Remix options in the Options bar.

To move the object, select Move from the Remix pop-up
menu. Because our photo didn't have hard lines, we selected
Very Loose from the Adaptation menu. For items with hard
lines, choose a stricter option from the Adaptation drop-down
menu.

5. Drag the selection to the area of the photo where you
would like to place it.

It didn't matter that we had some overlap in the boy; the
Remix tool was still able to move him with a minimal amount
of bruising, as you can see in Figure 15.21.

Remember that just like any of the healing or content-aware
tools, the Remix tool works differently every time you use it,
so if you don't like the results you get the first time, try again.

Figure 15.21

The Remix tool moved the boy from one part of the photo to
another.
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Fixing red-eye

The Red Eye tool is easy to use. Click and hold the arrow on
the Healing Brush icon in the Toolbox to display the Healing
Brush tools, and click the Red Eye tool; your cursor turns into
a crosshair. You can adjust the pupil size and darken amounts
in the Options bar. Center the cursor on the eye, and click.
Photoshop takes it from there, darkening the red in the
targeted area.

Note

Sometimes a subject's red eyes are so washed out that it is
difficult to get a good fix with the Red Eye tool. When that
happens, the next step is to select the red eye using the
Elliptical Marquee. Using a Hue and Saturation adjustment,
target the red in the eye and desaturate it. If that doesn't
work, the last resort is to actually paint (or clone) new pixels
into the eye area.

Using the Clone Stamp Tool

The Clone Stamp tool is the miracle worker that takes off ten
pounds, performs head swaps, and adds improbable elements
(like giant spiders) to ordinary photos. Knowing how to use
this tool effectively gives you the power to create great
images from photos that were originally so-so.

The Clone Stamp tool looks like a rubber stamp in the
Toolbox, as you can see in Figure 15.22. It is nested with the
Pattern Stamp tool, which allows you to brush patterns into
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your image (see Chapter 16). Clicking the Clone Stamp icon
also opens the Clone Source panel.

Cloning involves copying an area from an image and then
painting it into the same image or a different one. This is
useful for removing unwanted elements from an image or
adding elements to an image. When you use the Healing
Brushes to fix an image, they can leave smudgy-looking areas
due to over-blending. Unless you change the settings, the
Clone Stamp tool doesn't blend at all (except around the
edges, if you choose a soft brush). Because of this, it is more
precise than the Healing Brushes, but it can leave obvious
edges. It is a powerful tool that takes practice and a measure
of creativity to use properly.

In the following section, we show you how to use the Clone
Stamp tool and the Clone Source panel. We also provide
several examples that demonstrate different ways of using the
Clone Stamp, as well as tips and tricks for creating a fantastic
end result.

Figure 15.22

The Clone Stamp tool looks just like a rubber stamp.
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Looking over the Clone Stamp options

The Clone Stamp tool has options that make it very versatile
so that you can use it in any situation. You can create
seamless fixes or create an effect using blending modes or a
change in opacity. You can work with just one layer or you
can sample multiple layers. Just like every tool in the
Toolbox, when you select the Clone Stamp, the Options bar
changes to display the options that are specific to the Clone
Stamp. As you can see in Figure 15.23, they are similar to the
options for the Healing Brushes, with a few options added.
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Figure 15.23

The Clone Stamp Options bar provides several options for
customizing the Clone Stamp tool to fit your needs.

Here are the options and what they do:

• Tool presets. Click to create a tool preset for the Clone
Stamp or to load a preset you have already created.

• Brush presets. Click to display a list of Photoshop presets
for the brush that you will use with the Clone Stamp. You can
use one of these presets or create your own.

• Toggle Brush panel. Click to open or close the Brush
panel.

• Toggle Clone Source panel. Click to open or close the
Clone Source panel.

• Mode. Click this drop-down menu to set the blending mode
for the new pixels that you add to your image. Using a
blending mode other than Normal can create some great
artistic effects.
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• Opacity. Click this drop-down menu to control the opacity
of the pixels that you add to your image.

• Tablet pressure controls opacity. Click to toggle this
setting. If you are using a tablet, you can change the opacity
based on the pressure you exert. This option overrides the
Opacity setting.

• Flow. Click this drop-down menu to control the rate at
which new pixels are applied.

• Enable Airbrush. Click to enable this option; pixels will
continue to appear around the brush as long as you hold down
the left mouse button, creating a pooling effect.

• Aligned. Click to select this option; Photoshop locks the
clone source with your very first brush stroke, and the source
doesn't move even when you release the mouse. This is ideal
when you are cloning specific areas, such as a face or other
object that you don't want to move. If you are cloning a fix,
however, and you want to reset the Clone tool source every
time you release the mouse button, deselect this option.

• Sample. Click this drop-down menu to choose which layers
to sample while cloning.

• Ignore adjustment layers. Click this option if you've
already applied adjustment layers to your image and you don't
want to add them to the cloning mix.

• Tablet pressure controls brush size. Click this option if
you use a tablet, and you want to let the pressure determine
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the brush size. This option overrides the size in your brush
presets.

Learning the basics of cloning

Before we show you the more advanced cloning techniques,
let's start with an exercise that demonstrates the basic use of
the Clone Stamp. We created a special effect image from
Figure 15.24 by cloning out the rappelling gear so that the
boy seems to hover in midair.

On the Web

Can you clone out the ropes? Follow along by downloading
Figure 15.24 from the book's website.

Figure 15.24

Let's have some fun with this image.
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You can use the Clone tool to erase an object from an image
by following these steps:
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1. Open an image with an area that you want to change.

2. Click the Clone Stamp tool in the Toolbox.

3. Select a brush from the Options bar.

A soft brush usually works best for blending in edges.

4. Place the cursor over an area that you want to clone.

It's usually better to choose an area that's as close as possible
to the area you are fixing so that lighting, color, and texture
are as even as possible.

5. Press and hold the Alt/Option key as you click the
image.

This sets the clone source of the image.

6. Drag over the area where you want to apply the clone.

Photoshop copies the clone source to that area. The crosshair
shows the area that is currently being cloned, as you can see
in Figure 15.25.

Figure 15.25

Dragging over your image with the Clone Stamp copies
precisely the area the crosshair is over.
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7. Reset the clone source as needed by pressing and
holding the Alt/Option key and clicking your image.

8. Repeat Steps 4 to 7 until the object is gone from your
image.
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When you get to areas that have hard lines, such as the hard
line created by the shorts on the rock, make sure to clone the
seam just above or below so that you can line up the seam
perfectly. If you take your time and are careful, you will never
know there was more to your image, as shown in Figure
15.26.

Figure 15.26

The Clone Stamp worked well to remove the ropes.
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Note

Although you can use the Clone Stamp by itself to fix the
photo of the boy, you can also use the Healing Brushes,
which can actually be better for some areas, such as the rope
in front of the rock face.

That's it for the basics of using the Clone Stamp tool. Are you
ready to make it a lot more fun? The Clone Source panel
enables you to use a different image, resize your clone source,
or even tilt the clone source.

Utilizing the Clone Source panel

The Clone Source panel expands the use of the Clone Stamp
tool by providing five different clone sources that you can
save and reuse, as well as letting you resize, rotate, and flip
your clone source. Using the options found on this panel, you
can transfer portions of one photo into another, resize it to fit,
and tilt or flip it so that it blends just right.

You can open the Clone Source panel in three ways: by
clicking the toggle button for the Clone Source panel in the
Options bar, clicking the Clone Source icon in the panel, or
choosing Window⇒Clone Source. The Clone Source panel
opens, as shown in Figure 15.27, and with it a whole new
world of possibilities.

Figure 15.27

The Clone Source panel options
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We introduce you to the options in the Clone Source panel
and then show you how they work by taking you through an
exercise that uses many of these options.

You will find the following options in the Clone Source
panel:

• Clone samples. These five icons enable you to set and store
five different clone sources. You can create and use these
sources in any document.

• Offset. These values indicate how far you've moved the
clone source from its original position.

• Flip clone source. This feature allows you to flip the clone
source vertically or horizontally using the rotating arrows
next to the Width and Height percentage fields.
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• Scale clone source. This feature is incredibly useful,
especially when you are cloning specific objects from one file
into another. Often you need to resize the clone source so that
it fits into the new document. Type a percentage or use the
slider that appears when you hover over the W or H icons. If
you want, you can select the link icon to maintain the aspect
ratio.

• Rotate clone source. This feature enables you to type a
rotation degree in the field or use the slider to rotate your
source.

• Reset transform. This button changes the settings of the
Clone Source panel back to the defaults.

• Frame Offset. This field enables you to indicate how many
frames you are from the clone source when you are cloning
from one frame to another frame using a video file.

• Lock Frame. This option locks the clone source in a video
file to the original frame it was created on. When you deselect
this option, as you move from frame to frame cloning a video,
your clone source also moves the same number of frames, so
the frame offset is consistent. If you want to use the original
frame, even while you move through different frames, select
Lock Frame.

• Show Overlay. This option creates an overlay with the
clone source so you can preview the changes you are making
with the Clone Stamp.

• Opacity. This drop-down menu sets the opacity of the
overlay. The default setting of 50 percent allows you to
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clearly see the background at the same time as the clone
source and in most cases determine where to place your first
stroke.

• Overlay blending mode. This drop-down menu enables
you to change the blending mode of the overlay to lighten or
darken it. This makes it easier to distinguish between the
overlay and the original image.

• Clipped. This option allows you to toggle clipping on and
off. By default, the clone source overlay is clipped to the area
indicated by your Brush tool. This is great for fix-ups where
you aren't cloning specific items, but you'll find yourself
frequently toggling this option on and off as you work with
specific objects.

• Auto Hide. This option shows the overlay when you release
your mouse button, and hides the overlay as you paint in
cloned areas.

• Invert. This option inverts the overlay so it is easier to
distinguish from the background image.

Tip

If you are planning to use the Clone Source panel
frequently, or at least for an extended period of time, you
might want to dock it with the main panels to keep it out of
your work area. Drag it into place and drop it when you see
a blue highlight indicating it is linked to the other panels in
the main area.
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Now that you've had an overview of what these options are,
we will show you a real-world example that demonstrates the
usefulness and scope of the Clone Source tools. In this
example, we will use two different files.

Figure 15.28 is a special effect image that we have been
working on. We want to add some flowers to give it a
fairyland feel. The Clone Stamp is just the tool we need.

Figure 15.28

We will use the Clone Source panel to add flowers to this
image.
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On the Web
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The image for this file is available on the website as Figure
15.28. You will find two layers, one containing the fairy and
the other containing the background forest. You will want to
clone flowers both in front of and behind the fairy to create
the final result. You can also find the clone source file saved
as Figure 15.29. In order to make this exercise easier, we
have already cut the background out of the image and
created transparency so that the flowers will work well in
the new composite image you are creating.

Follow these steps to use the options found in the Clone
Source panel:

1. Open the image you are using for a clone source.

The image in this example is shown in Figure 15.29.

Figure 15.29

These flowers will add color and whimsy to the fairy photo.
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2. Select the Clone Stamp tool from the Toolbox.

3. Open the Clone Source panel, and select the first Clone
Source icon.

4. Alt-click/Option-click inside the clone source file to set
your clone source.

5. Open the file you want to clone into.

In this example, we used the image in Figure 15.28.

Note

You should create a new layer for the changes that you will
make with the clone stamp; it makes it much simpler to
make changes later. In our example, we created two new
layers, one in front of the fairy and one behind.

6. Deselect the Clipped option in the Clone Source panel
to reveal the full overlay, as shown in Figure 15.30.

If the opacity of your overlay is too high, reduce it so that you
can see through to the underlying image.

Figure 15.30

With the Clipped option deselected, you can see the cloned
image overlaying the original image.
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7. Resize the clone source so it fits where you want it.
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We wanted our flowers to be oversized, creating the illusion
that the fairy was very small, so we resized the flowers to 120
percent.

8. Rotate the clone source so it lines up where you want it.

We had to make several passes when cloning these flowers
into the image, and we changed angles as needed to get the
look we wanted. We started with an angle of –6 degrees.

9. Clone in the new image.

After you've lined up the images, click to anchor the clone
source and make as many passes as needed to clone in what
you want.

10. Use multiple clone sources to customize your image.

When you are ready to reset your clone source, click a new
Clone Sample icon in the top of the Clone Source panel. As
you continue to clone, you can return to any previous Clone
Sample to fill in areas that you missed.

11. Continue cloning, using the tools as necessary, until
you have the results you want.

We used several passes, placing some flowers in front of the
fairy and some behind. We also angled some flowers and
changed the size of others. You can see our final result in
Figure 15.31.

Figure 15.31
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As you can see, the flowers are not perfect cloned copies of
their original sources, but have been added in several passes
with several different settings to create the new image.
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Using the Clone and Healing Brushes Together for Optimal
Effect

Now that you have a feel for how the Clone Stamp and
Healing Brushes work, we will show you some advanced
techniques that are frequently used to fix photos and create
special effects. We will show you the steps that make up the
process, as well as how using the Clone Stamp and Healing
Brush tools together creates the best end result.

We start with an old photograph that has missing areas and
scratches, and move on to arguably the hardest cloning
technique, head swapping.

Fixing damaged photos

Most of us treasure old photos of long-gone loved ones.
Being able to scan them and preserve them digitally is
wonderful; being able to correct them digitally is even better.
Figure 15.32 shows an old photo with a scratch and a
discolored area that need to be repaired.

Figure 15.32

Old photos are a good test of the power of the Clone Stamp
and Healing Brush tools.
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We wanted to try out the Content-Aware fill and see how well
it fixes the problem areas. We were surprised because it did a
decent job, with the end result looking much better than the
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original. Let's see if we can do a better job with the Clone
Stamp and Healing Brush tools.

On the Web

Can you fix the worn and torn areas of this photo? Follow
along by downloading Figure 15.32 from the book's
website.

Follow these steps to repair this old photo:

1. Open the image from the website.

2. Zoom into the scratch over the window.

It's hard to make precise changes uNL1ess you can see what
you're doing.

3. Click the Clone Stamp tool to select it.

4. Choose a soft brush so the edges of your fix blend well.

Size it so it covers just one seam of the curtain because you
want to maintain control of individual areas.

5. Click the Airbrush in the Options bar to activate it.

This allows you to hold down the mouse button long enough
to fill in the pixels that will start out soft because of the soft
brush.

6. Select the Clipped option in the Clone Source panel.
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Because you are cloning small areas, you should find this
setting adequate to see what you are doing without being
distracted.

7. Alt-click/Option-click one of the seams created by the
curtains.

Because the area has so many seams, cloning will take several
steps. The best areas to clone are either directly over or under
the scratch.

8. Drag slowly over the scratch, being careful to keep the
seams in line, so that the curtain runs continuously.

Pause long enough in each area to fill in the pixels fully, as
shown in Figure 15.33.

Figure 15.33

Cloning in the seams makes the clone look realistic.
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9. Repeat Steps 7 and 8 until you've filled in the area
damaged by the scratch.

Be sure to use a seam whenever possible so the lines stay
consistent. Work until your result looks like Figure 15.34.

Figure 15.34

The window area is repaired.
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10. Zoom back out, and then zoom in on the discolored
area by the boys' legs.

11. Repeat Steps 7 and 8 for this area as well.

It doesn't have as many seams, but making sure they line up
makes your results look much better.

12. When you are finished with these two areas, use the
Spot Healing Brush to target white flecks and other areas
of the photo that need a little cleanup.
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You may need to use the Clone Stamp in one or two areas
that have seams, such as the siding. When you are finished,
you should have a result similar to Figure 15.35.

Swapping faces with multiple images

With four boys, being able to swap faces is the only way we
ever get a decent family picture. These days, we often use
face swapping to get the perfect shot. Some face swaps are
easier than others. If the shots are nearly identical and the
background is just right, it may just be a matter of replacing
the expression on one face with another. But even when the
circumstances seem ideal, as you see in this next exercise, it's
the little things like posture and the tilt of the head that can
make this technique complicated.

Figure 15.35

Although the Content-Aware fill works much faster and does
a fair job, it can't compete with the human touch!
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Figure 15.36 shows two photos that were taken in the same
photo shoot of the same family with the same lighting and
background. In this exercise, we are combining these two
photos by replacing the heads in the background of the first
photo with the same heads in the second photo so that we
have the best of both photos.

Figure 15.36

Ready for a head swap? Let's make one good photo out of
two.
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On the Web

Follow along by opening Figures 15.36a and 15.36b from
the website.

Follow these steps to create the perfect head swap:

1. Open Figure 15.36b from the website.

2. Choose the Clone Stamp from the Toolbox.

3. Choose a soft brush and set it to a size you are
comfortable with.

4. Select the First Clone Source icon in the Clone Source
panel.

5. Alt-click/Option-click directly above the man's nose.

6. Open Figure 15.36a from the website.

7. Create a new layer by clicking the New Layer icon in
the Layers panel.
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Use this layer to clone into.

Tip

We protected the children in front from any changes by
creating a selection around them and creating a mask in the
new layer.

8. Deselect Clipped in the Clone Source panel.

This displays the entire image as an overlay. If the opacity of
your overlay is too high, reduce it so that you can see through
to the underlying image.

9. Center the image so that the photo fits well.

We chose to line up the head of the little girl in front. Click
once to lock the clone in place.

10. Select Clipped in the Clone Source panel.

This allows you to clearly see the areas that have been
changed and the areas that still need work.

11. Drag over the faces in the background to change them.

Be sure there are no soft areas where the pixels aren't filled in
completely. Do the best you can with the edges so the two
photos blend seamlessly wherever possible. Don't worry; your
results right now will be far from perfect, as demonstrated in
Figure 15.37.
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12. Use either the History Brush or the Eraser tool to
change any areas back to the original photo that you
shouldn't have cloned over.

In Figure 15.37, there is an extra arm and the lines in the
background are no longer straight.

Figure 15.37

The first pass with the Clone Stamp leaves several areas that
need to be changed back.

Note
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Just like any brush, the History Brush can be softened so the
changes blend in, or left hard to re-create hard edges. The
Eraser works only if you are using a second layer.

13. Repeat Steps 11 and 12, paying attention to each area
to note any aberrations.

You probably won't end up with a perfect result, as you can
see in Figure 15.38.

14. Click the second Clone Source icon in the Clone
Source panel.

You want to keep the original clone in place so you can use it
for repairs.

Caution

It is very easy to forget to change between the two clone
sources. If you accidentally reset the first clone source, you
can't recover it; you have to reset it as closely as possible to
use it again to make changes, so be cautious.

15. Use the second clone source to make small repairs.

Use all the tricks we've shown you so far to fix lines and
clean up the areas that don't match. Double-check and
triple-check areas you have cloned for seams that are out of
place, smudges, or unnatural areas. When you are finished,
your results should resemble Figure 15.39.
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Figure 15.38

Even finding the right balance between the images leaves
areas that need detail work.
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Figure 15.39

The powerful Clone Stamp worked its magic, and it's hard to
tell that this isn't the original image.

Summary

In this chapter, you learned how to use the Healing Brushes
and Clone Stamp to correct and modify your images. You
also became familiar with the Content-Aware tools. Using the
Clone Source panel, you should be able to make adjustments
that help your clone source fit the image you are working
with.

At this point, you should be familiar with these tools:

1041



• The Spot Healing Brush

• The Healing Brush

• The Patch tool

• The Content-Aware fill

• The Remix tool

• The Red Eye tool

• The Clone Stamp
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Part V: Using Paint, Paths, Shapes, and Text Tools

IN THIS PART

Chapter 16

Editing with Paintbrush Tools

Chapter 17

Working with Paths and Vector Shapes

Chapter 18

Working with Text
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Chapter 16: Editing with Paintbrush Tools

In This Chapter

Using paint-brushing techniques

Using brush-style editing tools to edit photos

Customizing paintbrush settings

Painting with brush and non-brush tools

Applying painting and tracing techniques

Although Photoshop is typically thought of as a photo-editing
package, it also includes an arsenal of tools that makes it one
of the premier painting applications. In fact, painting in
Photoshop means much more than in most other painting
applications.

What makes painting so effective in Photoshop is that Adobe
combined the powerful photo-editing tools with the
paintbrush tools so that you can use paintbrush strokes to
apply localized photo editing and you can apply photo-editing
techniques to your painting.

This chapter discusses the Brush tools available in Photoshop
for both editing and painting purposes. It also covers how to
configure custom brushes to increase the capability of those
tools. Before you begin painting in Photoshop, you may want
to switch to the Painting workspace by choosing
Window⇒Workspaces⇒Painting from the main menu bar.
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This configures the workspace specifically to support the
painting tools.

Painting in Photoshop

Painting in Photoshop means much more than just painting
colors onto a blank document with a brush. Painting means
using brushing techniques to apply effects to fix problem
areas of photographs, retrace history, blend layers, and apply
and mix colors.

In this chapter, we discuss the tools and techniques that you
can use to make some specific changes to images, create
artwork, and apply dramatic artistic effects. Before we start,
though, you should know a few things about painting:

• You apply brushing techniques by selecting the tool, setting
the brush and tool options, and then dragging the cursor in a
specific area of the document using a mouse, trackball,
trackpad, or stylus pen.

• You apply painting to the currently selected layer in the
Layers panel, although some of the tools sample from all the
layers to apply the painting effect.

• When you have a selection active, the painting effect applies
only inside the selection. This enables you to use the powerful
Selection tools to fine-tune your painting.

• Painting is a destructive task that alters pixels. It is a good
idea to paint from a copy of the background layer if you are
altering a photo and then to apply the change only when you
feel that the painting is finished.
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• You can paint on vector layers, but you need to convert
them to Smart Object layers first.

• Painting is not an exact science. You may need to try
different brush styles, sizes, settings, and strokes to achieve
the results you are looking for.

Understanding the Painting Tools

The best way to understand painting in Photoshop is to look
at the brush-based tools that Photoshop provides.
Understanding how these painting tools work can make you
more effective at both editing photos and applying artistic
effects. This section discusses the painting tools and how to
use them.

You use three types of paintbrush tools to paint in Photoshop:
editing, painting, and mixing. Editing tools paint by adjusting
the pixels directly beneath the tool. Painting tools paint by
applying color to the pixels directly beneath the tool. Mixing
tools paint by mixing color with the pixels directly beneath
the tool.

Tip

When you are using any of the painting tools, keep in mind
that pressing and holding the Shift key while dragging the
cursor applies the stroke in a straight horizontal, vertical, or
diagonal line. You can also press and hold the Shift key as
you click the painting tool in two different locations in the
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image to create a straight paint stroke between the two
points.

Many of the painting tools in Photoshop are designed to take
advantage of the benefits of using tablet devices. Tablet
devices provide a stylus and pad that work in tandem to
simulate the experience of drawing with a pencil or other tool.
The tablet is able to sense the direction, speed, pressure, tilt,
and other information from the stylus. This information is
transferred to the Photoshop tools where they are able to
apply it as intelligent brush strokes. The results can be
amazing when compared with simply using a mouse. If you
are planning to use the painting tools, you should seriously
consider purchasing a tablet.

Working with painting tools in blending modes

Many of the painting tools provide blending modes that
define the behavior and look of the effect, and how it blends
to the pixels beneath. Blending modes are computer
algorithms that define methods to combine two pixels into
one pixel. The idea is that instead of using one pixel or the
other, you can define several ways to combine the two pixels
to create a different outcome.

As you begin using the painting tools, you'll notice that many
of the tools offer some kind of blending mode setting. The
painting tools use blending modes for a variety of purposes.
For example, the Brush tool enables you to set a blending
mode that defines how the paint from the brush interacts and
blends with the pixels below. And when adding a texture to a
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brush, you can use a blending mode to define how the pixels
from the pattern blend with the paint in the brush to create the
texture.

The following sections describe the different blending modes
and how they relate to the painting tools. In the descriptions,
we refer to the pixels below the brush as the base pixels.

Choosing a basic blending mode option

In Photoshop, there are four basic blending modes that enable
you to edit or paint a graphic:

• Normal. This is the default option for most of the Brush
tools. No blending is applied; instead, the value of the new
pixels is the value created by the paintbrush. When painting
tools use the Normal mode, the foreground color that you
apply is based on the opacity, flow, and airbrush settings.
When editing tools use the Normal mode, the tool
manipulation is applied using the normal editing algorithm.

• Dissolve. This option applies the blend by randomly
replacing the pixels with either the paintbrush value or the
pixels beneath, depending on the pixel location and the
opacity setting. Using this option enables you to dissipate the
painting effect, more than just changing the opacity.

• Behind. This option applies the painting effect on only the
transparent areas of the layer. This mode works only when
you deselect the Lock Transparency option for the layer.

• Clear. This option applies the painting effect as
transparency. It's similar to the Eraser tool, but it works with

1048



the Shape, Paint Bucket, Brush, and Pencil tools to apply the
transparency. This mode works only when you deselect the
Lock Transparency option for the layer.

Note

The Behind and Clear blending modes are not available if
you lock the selected layer in the Layers panel.

Applying a darkening blending mode

The blending modes menu contains darkening effects. These
five blending filters reduce the painting effect in the darker
areas and apply more paint to the lighter pixels below. The
result is that the effects tend to darken the overall image.

• Darken. This option applies the blend by replacing the
pixels with the darker of the base value or the paintbrush
value. In other words, it only applies the painting effect to the
underlying pixels that are lighter than the value of the brush
pixel. This has the effect of darkening the image.

• Multiply. This option applies the blend by multiplying the
base value of each pixel by the paintbrush pixel value.
Multiplying a pixel by black always produces black, and
multiplying a pixel by white leaves the pixel value
unchanged. This mode has the overall effect of darkening the
image.

• Color Burn. This option applies the blend by darkening the
base channel; based on the brush color, Photoshop increases
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the contrast between the two sources. This has the effect of
darkening the image as well as increasing color contrasts.

• Linear Burn. This option darkens the image as it applies
the blend by decreasing the brightness based on the value of
the paintbrush pixel.

• Darker Color. This option applies the blend by replacing
each of the channels of a pixel with whichever is darker: the
base pixel channel or the paintbrush pixel channel. This
option works a bit better than using the Darken mode because
it uses the darkest values from each of the channels to create
the resulting color. For example, this mode may use red and
green from the base pixel and blue from the paintbrush pixel.

Selecting a lightening blending mode

The lightening blending modes have the opposite effect of the
darkening blending modes. As you apply the painting effect,
the results tend to lighten darker areas of the image while not
significantly impacting the lighter areas of the image.

• Lighten. This option applies the blend by replacing the
pixels with the lighter of the base value or the paintbrush
value. This has the effect of lightening the image and can be
extremely useful if applying filters to underexposed images.

• Screen. This option applies the blend by multiplying the
inverse of the channel values of the paintbrush and base
pixels. This results in a lighter color than either the paintbrush
value or the base value. This has the same effect as projecting
multiple photographic slides on top of each other.
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• Color Dodge. This option applies the blend by decreasing
the contrast between the color of the channels in the
paintbrush pixel and the base pixels. This lightens the base
pixels using the paintbrush pixel values.

• Linear Dodge (Add). This option lightens the image as it
applies the blend by increasing the brightness based on the
paintbrush pixel value of each channel.

• Lighter Color. This option applies the blend by replacing
each channel of a pixel with whichever is lighter: the base
pixel channel or the paintbrush pixel channel. This option
works better than using the Lighten mode because it uses the
lightest values from each channel to create the resulting color.

Adding contrast blending modes

These blending modes create contrast between the paintbrush
effect and the base pixels, making the lighter areas lighter and
the darker areas darker:

• Overlay. This option applies the blend by mixing the
paintbrush values with the base pixels while preserving the
shadows and highlights. This reduces the effect of extreme
layer adjustments that dramatically reduce the detail in the
original image.

• Soft Light. This option applies the blend based on the gray
value of the paintbrush pixel. If the value of the paintbrush
pixel is darker than 50-percent gray, the base pixel is
darkened using a multiplying method. If the value of the
paintbrush pixel is lighter than 50-percent gray, the base pixel
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is lightened using a dodging method. This has a similar effect
to shining a diffused spotlight on the image.

• Hard Light. This option applies the blend based on the gray
value of the paintbrush pixel. If the value of the paintbrush
pixel is darker than 50-percent gray, the base pixel is
darkened using a multiplying method. If the value of the
paintbrush pixel is lighter than 50-percent gray, the base pixel
is lightened using a screening method. This has a similar
effect to shining a harsh spotlight on the image. This option is
great for adding shadows while applying the filter.

• Vivid Light. This option applies the blend based on the gray
value of the paintbrush pixel. If the value of the paintbrush
pixel is darker than 50-percent gray, the base pixel is
darkened by increasing the contrast. If the value of the
paintbrush pixel is lighter than 50-percent gray, the base pixel
is lightened by decreasing the contrast.

• Linear Light. This option acts as a combination of the
linear dodge and linear burn. If a paintbrush pixel is darker
than 50-percent gray, then the pixels in the image are
darkened by the brush stroke. If a paintbrush pixel is lighter
than 50-percent gray, then the pixels in the image are
lightened by the brush stroke.

• Pin Light. This option applies the filter based on the gray
value of the paintbrush pixel. If the value of the paintbrush
pixel is darker than 50-percent gray, the darker of the
paintbrush pixel and base pixel is used. If the value of the
layer pixel is lighter than 50-percent gray, the lighter of the
paintbrush pixel and base pixel is used.
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• Hard Mix. This option adds the value of each RGB channel
in the paintbrush pixel to the corresponding RGB channel in
the base pixel. The values above 255 and below 0 are clipped,
which can result in a large loss of detail.

Blending two layers

The Difference, Exclusion, Subtract, and Divide blending
modes blend two layers based on the difference between the
layers.

• Difference. This option applies the blend by setting the
resulting pixel to the value of the difference between the
paintbrush pixel and the base pixel. Blending white inverts
the pixel value, and blending black does not change the pixel
value.

• Exclusion. This option works similarly to the Difference
blend mode, but generates less contrast.

• Subtract. This option applies the blend by subtracting the
pixel value in the paintbrush from the corresponding pixel in
the image. The resulting pixel value is divided by a scale
factor and then added to an offset to make certain it still falls
in the 0-to-255 range. As a result, the darker the paintbrush
pixel is, the less effect it has on the image pixel.

• Divide. This option works the same way that the Subtract
blend mode does, except the image pixel value is divided by
the paintbrush pixel value. This increases the range of
variance in the degree of change in the image pixels.

Finishing with a color blending mode
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The final group of blending modes gives the selected layer a
color influence over the layers under it.

• Hue. This option applies the blend by creating the resulting
pixel using the luminance and saturation of the base pixel but
the hue of the paintbrush pixel. This reduces the blend to
affect only the hue of the base pixels.

• Saturation. This option applies the blend by creating the
resulting pixel using the luminance and hue of the base pixel
but the saturation of the paintbrush pixel. This reduces the
blend to affect only the saturation of the base pixels.

• Color. This option applies the blend by creating the
resulting pixel using the luminance of the base pixel but the
hue and saturation of the paintbrush pixel. This limits the
blend so it doesn't affect the brightness of the base pixels.

• Luminosity. This option applies the blend by creating the
resulting pixel using the hue and saturation of the base pixel
but the luminance of the paintbrush pixel. This enables you to
apply the blend so it affects only the brightness of the base
pixels.

Applying color with painting tools

Painting tools enable you to work by applying new color to
the pixels in a specific region under the tool. This is a basic
concept that has been around for decades. Photoshop
enhances the paint technique by enabling you to select
specific brush styles, sizes, and settings that control how
pixels are painted in almost unlimited ways. You can find the
painting tools in the Toolbox as shown in Figure 16.1. This
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enables you to quickly switch between painting and other
operations in Photoshop.

Tip

You can select the painting tools using the B hotkey, and
you can toggle through the Brush, Pencil, Color
Replacement, and Mixer Brush tools by using the Shift+B
hotkey sequence.

The following list describes the painting tools that you can
use to add color to your images:

• Brush and Pencil tools. The Brush and Pencil tools work
basically the same way with one distinct difference. Brush
tool strokes have a soft edge that is created by anti-aliasing
the edges of the strokes so they blend slightly with the
surrounding image. Pencil tool strokes have a crisp, hard edge
that does not blend with the surrounding image. Figure 16.2
shows an example of the Brush and Pencil tool strokes
applied with the same brush style.

Figure 16.1

The painting tools enable you to apply color to images using a
variety of brush and pencil strokes.
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Figure 16.2

The Brush tool applies the stroke with soft edges, and the
Pencil tool applies the stroke with hard edges.

Even though the concept is simple, the Brush and Pencil tools
provide an incredible range of results. When using the Brush
and Pencil tools, you can configure the following settings in
the tool menus to control how Photoshop applies your brush
and pencil strokes to the image:
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• Tool Presets. This option, like all presets in Photoshop,
enables you to quickly save the tool settings and then load
and select them later.

• Brush Preset. The Brush Preset panel enables you to select
the style of brush to use for the tool. You can also set the size
and hardness of the brush.

The size of the brush determines the area of pixels that are
affected by the brush stroke, and the hardness of the brush
determines the intensity of the stroke. When painting, harder
brushes mean that you add more color; when editing, harder
brushes mean that you apply a more dramatic effect.

Note

The settings that you apply using the Brush panel add to or
override the settings you specify in the Brush Preset panel
popup menu. You will probably want to select a brush using
a combination of the Brush Preset option, the Brush panel,
and the Brush Presets panel.

Using the Brush Preset panel menu, you can manage the set
of listed brushes. You can rename and remove brushes, load
different sets of brushes, and even manage the appearance of
the lists, as shown in Figure 16.3.

Figure 16.3
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The Brush Preset panel menu enables you to quickly select a
brush and set its size and hardness. You can also manage the
list of brush styles that appear.

• Brush Panel. This option displays the Brush panel, which
enables you to control a variety of options for every aspect of
the brush behavior. We cover the Brush panel in more detail
later in this chapter.

• Mode. This drop-down menu specifies the blending mode
that Photoshop uses to apply the brush stroke to the pixels
below. The blending mode can have a major impact on how
the brush strokes look. Instead of just applying the brush
stroke to the pixels below, Photoshop blends the pixel data in
the brush stroke with the pixel data in the selected layer,
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based on the blend mode algorithm. We cover blend modes in
more detail later in this chapter.

• Opacity. This drop-down menu enables you to specify the
opacity of the painting tool. A higher opacity means that the
underlying pixels are affected more by the painting stroke. A
value of 100 percent means that all pixels are affected; 0
percent means that none of the pixels are affected.

• Tablet pressure controls opacity. This option enables the
pressure on the stylus tip to define the percentage of opacity
involved when painting. This is a great option to fine-tune
your strokes using a more realistic effect, if you have a stylus
pen.

• Flow. This drop-down menu controls the rate at which
Photoshop applies the tool effect to the pixels below. A value
of 100 percent means that the pixels are affected immediately.
Reducing the flow applies the effect more slowly, enabling
you to move the brush before Photoshop applies the full effect
of the tool to the underlying pixels. Using this option, you can
give your stroke effect a more realistic look just as if you
were painting at different speeds with a real brush.

• Enable airbrush style. This option causes the stroke to be
applied in gradual tones to the image. This feature typically
works better when you use it in conjunction with a reduced
flow setting.

• Auto Erase. This option enables you to use the Pencil tool
to paint over areas containing the foreground color using the
selected background color. When you select this option and
the cursor is over the foreground color when you begin
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dragging, Photoshop paints the area with the background
color. When you select this option and the cursor is not over
the foreground color when you begin dragging, Photoshop
paints the area with the foreground color. In other words, this
doesn't erase, but simply replaces any pixels with the
foreground or background color depending on the color
underneath the mouse when you start dragging it.

• Tablet pressure controls size. This option causes the stylus
pressure to override the brush or pencil size when painting.

• Color Replacement Tool. This tool works similarly to the
Brush tool except that it applies the paint, specified by the
foreground color in the Toolbox, only to a specified color.
This is a great way to replace one color in the image with
another color without affecting the surrounding pixels. You
select a sample color, and as you apply the Color
Replacement tool, Photoshop analyzes the pixels below the
tool, determines which pixels match the sample color, and
paints only those pixels. Only the pixels that match the
sampled color are replaced, as shown in Figure 16.4.

Using the Color Replacement tool, you can configure the
following settings in the Options bar, shown in Figure 16.1,
that control how Photoshop applies the Color Replacement
strokes to the image:

• Continuous sampling. This option causes the Color
Replacement tool to continuously sample the pixel directly
beneath it to determine what color pixels to paint. When you
select this option, it behaves similarly to the Brush tool,
depending on the other settings.
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• Once sampling. This option causes the color you are
replacing to be that of the pixel directly below the tool when
you first click and begin to drag the mouse. This feature is
great for quickly selecting a color to replace directly from the
image.

• Background sampling. This option causes the color you are
painting to be the background color in the Toolbox.

• Limits. This drop-down menu enables you to set the limit of
erasing to Discontiguous, Contiguous, or Find Edges.
Discontiguous replaces the pixels wherever they occur.
Contiguous replaces only the pixels that are immediately
adjacent to the changeable pixels. Find Edges replaces pixels
while trying to keep the edges in the image distinct.

• Tolerance. This drop-down menu specifies the tolerance
Photoshop uses when determining whether a pixel matches
the sample color and should be replaced.

• Anti-alias. This option causes Photoshop to use
anti-aliasing to soften the edges around the pixels being
replaced.

• Mixer Brush tool. This tool is different from the painting
tools, and we cover it later in this chapter.

Figure 16.4 shows an example of using the Color
Replacement tool to paint a different color onto a flower.
Notice that only the petals of the flower are affected. We use
the Sampling options to sample a petal, so only the pixels that
are similar to the color of the petals are altered, leaving the
others alone.
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Figure 16.4

The Color Replacement tool enables you to use brush strokes
to paint over a specific color while leaving the other colors
alone.

Painting with editing tools

Editing tools enable you to paint by using different algorithms
to manipulate the pixels in a specific region under the tool
instead of laying down a new color. You can control the
shape and size of the area of pixels affected by the tool. You
manipulate the pixels by dragging the mouse or using a stylus
pen.

The editing tools enable you to fix or enhance problem spots
in images. For example, you can use the Spot Healing Brush
tool to remove blemishes, or the Sharpen tool to enhance the
sharpness of a specific area of a photo. The following sections
discuss the editing tools that you use to paint edits on photos
in Photoshop.
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Making quick fixes with the healing tools

The healing tools shown in Figure 16.5 enable you to quickly
fix problem areas of photos, such as scratches, red-eye, or
even unwanted objects.

For a more detailed explanation of how to use the
healing tools to edit photos, see Chapter 15.

Figure 16.5

The healing tools enable you to use brush strokes to quickly
fix and remove problem areas in photographs.

Choosing a Stamp tool to replace pixels

The Clone Stamp tool shown in Figure 16.6 enables you to
quickly fix problem areas of a photo. For example, you can
fix scratches and remove unwanted objects by using other
areas of the photo as a source to replace pixels using a Stamp
brush.

For a more detailed explanation of how to use the
Clone Stamp tool to edit photos, see Chapter 15.
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The Pattern Stamp tool works similarly to the brush tool
except that it paints a pattern instead of a color. The options
for the Pattern Stamp tool include the following:

• Pattern Picker. This feature displays a drop-down menu
where you can select a pattern to paint.

• Aligned. This option causes the pattern in each new brush
stroke to be aligned with the previous brushstroke. This
enables you to keep the pattern aligned as you paint multiple
strokes.

• Impressionist. This option softens the pattern to give it an
artistic effect rather than a crisp pattern.

Figure 16.6

The Clone Stamp tool enables you to use a stamp effect to
quickly fix or remove problem areas in photographs.

Using history tools

The history tools shown in Figure 16.7 enable you to use
brush effects to paint previous edit states of the document
onto the current state. They do this by using a painting effect
to reveal pixels from previous edit states.
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For a more detailed explanation of how to use the
history tools to reveal effects from previous states, see
Chapter 5.

Figure 16.7

The history tools enable you to use a paintbrush to paint data
from a previous edit state of the document onto the current
state, thus restoring effects to specific areas of the image.

Choosing an eraser tool

The eraser tools, shown in Figure 16.8, are designed to erase
pixels from the image. However, the eraser tools provide
several settings that offer you a lot of flexibility when
removing pixels. Eraser tools only affect the selected layer in
the Layers panel, so you can restrict the erasing to a specific
layer.

Tip

You can select the Eraser tools feature using the E hotkey,
and you can toggle through the eraser tools by using the
Shift+E hotkey sequence.

Figure 16.8
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The eraser tools enable you to remove pixels from a layer in
the image and replace them with transparency or the
background color.

You can use three types of eraser tools, as shown in Figure
16.8:

• Eraser. This tool is designed to remove pixels from the
current layer and replace them with transparency or the
background color using the following options:

• Mode. This drop-down menu enables you to erase in Brush,
Pencil, or Block mode. The Block mode is simply a square
tool that's useful in hard-to-erase corners. The Pencil mode
enables you to select the pencil tip, but the edges are hard for
crisp erasing. The Brush mode enables you to erase using all
the functionality of brush strokes, so you can smooth the
edges of the area being erased.

• Opacity. This drop-down menu enables you to specify the
opacity of the Eraser tool. The higher the opacity, the more
the underlying pixels are removed as you paint on them.
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• Stylus controls opacity. This option enables you to define
the amount of opacity you apply when you use the Eraser tool
by changing the pressure on the stylus tip.

• Flow. This drop-down menu controls the rate at which
Photoshop applies the erase effect to the pixels below. A
value of 100 percent means you erase the pixels immediately.
Reducing the flow amount applies the erasure more slowly,
enabling you to move the brush before fully erasing the
underlying pixels.

• Airbrush Mode. This option causes the erasure to be
applied gradually to the image to soften the edges of the area
you are erasing. This option typically works better when used
in conjunction with a reduced flow setting.

• Erase to History. This option causes the Eraser tool to erase
to a previous history state, instead of erasing to transparent or
background pixels (see Chapter 5).

• Stylus controls size. This option causes the stylus pressure
to override the brush or pencil size when erasing.

• Background Eraser tool. This tool is designed to erase a
specific color from the layer instead of just erasing
everything. This is extremely useful for removing monotone
elements from images or for cleaning up a specific color from
a layer. The Background Eraser tool provides the following
options:

• Continuous sampling. This option causes the Background
Eraser tool to continuously sample the pixel directly beneath
it to determine what color of pixels to erase. When you select
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this option, it behaves similarly to the regular Eraser tool,
depending on the other settings.

• Once sampling. This option causes the color you erase to be
determined by the pixel directly below the tool when you first
click and begin to drag the mouse. This is great for quickly
selecting the color you will erase from the image.

• Background sampling. This option causes the color you
erase to be determined by the background color in the
Toolbox.

• Limits. This drop-down menu enables you to set the limit of
erasing to Discontiguous, Contiguous, or Find Edges.
Discontiguous erases the pixels wherever they occur.
Contiguous erases only the pixels that are immediately
adjacent to the first selected pixel. Find Edges erases pixels
while trying to keep distinct edges in the image.

• Tolerance. This drop-down menu enables you to specify the
tolerance Photoshop uses when determining whether a pixel
matches the sample color and should be erased.

• Protect Foreground Color. This option protects the color
in the foreground of the Toolbox from erasure. You typically
use it to erase everything but one color, as shown in Figure
16.9.

• Magic Eraser tool. This tool offers a fast way to erase
similar pixels throughout your image. Simply click a pixel in
the image, and Photoshop scans the rest of the image and
automatically removes all pixels that are similar using the
following options:
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• Tolerance. This drop-down menu enables you to set the
tolerance that Photoshop uses when determining whether the
pixel matches the selected pixel and should be erased.

• Anti-alias. This option causes Photoshop to use
anti-aliasing to smooth the edges between the pixels being
erased and the pixels remaining.

• Contiguous. This option causes only pixels that are
contiguous to and have a similar color to the selected pixel to
be erased.

• Sample All Layers. This option causes Photoshop to
sample the pixels in all layers to determine the color it will
use when erasing pixels. When you deselect this option, the
Magic Eraser tool samples only from the selected layer. This
can be useful for removing pixels from one layer that match
the pixels in another layer without affecting the other layer.

Figure 16.9 shows an example of how each Eraser tool works.
Notice that the Eraser tool erases all the pixels, but because
we have set the foreground color to the color of the flowers,
the Background Eraser tool does not erase the flowers. Also
notice that the Magic Eraser tool erases most of the color of
the flowers from the image.

Figure 16.9

The Eraser tool erases all pixels, whereas the Background
Eraser tool can be used to erase or preserve specific colors,
and the Magic Eraser tool finds and erases pixels with similar
colors.
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Selecting the right Sharpen, Blur, or Smudge tool

The Sharpen and Blur tools, shown in Figure 16.10, enable
you to use Brush tools to apply sharpening and blurring
effects to specific areas of an image. The Smudge tool
samples the pixels in the image below the cursor and applies
those pixels as you drag the mouse or stylus across the image.
The result is that the pixels in the image combine with the
sampled pixels, producing a smudging effect.

For a more detailed explanation of sharpening
and blurring images, see Chapter 14.
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Figure 16.10

The Sharpen and Blur tools enable you to use brushing
techniques to apply sharpening and blurring to specific areas
of an image. The Smudge tool enables you to use brush
techniques to smudge areas of an image.

The following list describes some of the options that are
available in the Options bar for the Blur, Sharpen, and
Smudge tools:

• Mode. This drop-down menu enables you to set the
blending mode to use when applying the blur, sharpen, or
smudge effect. The options are Normal, Darken, Lighten,
Hue, Saturation, Color, and Luminosity.

• Strength. This drop-down menu enables you to set the
strength of the effect from 0 to 100 percent. Applying a
higher strength makes the blur, sharpen, or smudge effect
more dramatic.

• Sample All Layers. This option causes Photoshop to use all
layers to calculate the effect that it applies to the current layer.
Keep in mind, though, that this only affects the current layer.

• Protect Detail. This option causes the Sharpen filter to try
to protect the detail in the image.
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• Finger Painting. This option causes Photoshop to use the
foreground color, instead of sampling the image, to fill the
Smudge tool. The effect is similar to dipping your finger in
paint and then dragging it across a wet image.

Figure 16.11 shows an example of how the Blur, Sharpen,
and Smudge tools work. Notice that the Blur tool can blur out
the center of the image without affecting the detail in the rest
of the image, just as the Sharpen tool can sharpen just the
center. The Smudge tool has a completely different effect in
that it smudges the pixels in the center just as if they were wet
paint on a canvas.

Choosing a Dodge, Burn, or Sponge tool

The Dodge, Burn, and Sponge tools, shown in Figure 16.12,
enable you to use brush techniques to apply lightening,
darkening, and saturation adjustments to specific areas of an
image. The Dodge tool applies a lightening effect to the
pixels as you drag the mouse or stylus across the image. The
Burn tool applies a darkening effect to the pixels as you drag
the mouse or stylus across the image. The Sponge tool either
saturates or desaturates the pixels as you drag the mouse or
stylus across the image.

Tip

You can select the Dodge, Burn, and Sponge tools using the
O hotkey, and you can toggle through them by using the
Shift+O hotkey sequence.
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We discuss lightening and saturation corrections
in more detail in Chapter 13.

Figure 16.11

The Blur, Sharpen, and Smudge tools apply blurring,
sharpening, and smudging to specific areas of the image using
paint strokes.

Figure 16.12

The Dodge, Burn, and Sponge tools enable you to use brush
techniques to apply lightening, darkening, and saturation
adjustments to specific areas of an image.
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The following list describes some of the options that are
available in the Options bar for the Dodge, Burn, and Sponge
tools:

• Range. This drop-down menu enables you to specify the
tonal range to which you want to apply the Dodge or Burn
effect. The available tonal ranges are Shadows, Midtones, and
Highlights.

• Exposure. This drop-down menu enables you to set the
amount of exposure that Photoshop applies with the Dodge or
Burn tool. A larger percentage in the Exposure setting results
in a more dramatic effect.

• Protect Tones. This option causes Photoshop to limit the
amount of adjustment in the Dodge and Burn tools so that
they have a minimal effect on the color tones.

• Mode. This drop-down menu enables you to specify
whether to apply a color saturation or desaturation effect with
the Sponge tool.

• Flow. This drop-down menu controls the rate at which the
saturation or desaturation effect is applied to the pixels below.
A value of 100 percent means the pixels are affected
immediately. Reducing the flow applies the affect more
slowly.
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• Vibrance. This option limits the effect of the Sponge tool to
retain as much of the vibrance of the tones as possible.

Figure 16.13 shows an example of applying the Dodge and
Burn tools to help the look of a photo that was taken at the
wrong angle during a sunny day. Notice in the original that
the hair shines too brightly and a bad shadow appears on the
other side of the face. Using the Dodge tool, we lightened the
face to restore some of the detail, and using the Burn tool, we
darkened the highlight in the hair.

Figure 16.13

Using the Dodge and Burn tools, you can apply brushing
techniques to darken highlights and brighten shadows.

Painting with mixing tools
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The Mixer Brush tool is designed to mix the paint in the brush
with the pixels below to produce the effect of using real paint.
The Mixer Brush tool is extremely dynamic and versatile in
how it mixes the paint with the pixels below.

The Mixer Brush tool enables you to use the color palette to
mix paint into the image and use a dry brush to mix the paint
on the image. You can also specify how much paint is applied
to the brush, and apply other changes to create an effect
similar to painting with actual wet paint on a physical
medium.

The Mixer Brush tool is available in the painting tools set in
the Toolbox, and you can select it by pressing Shift+B to
toggle through the painting tools. The following list describes
some of the options available in the Options bar, shown in
Figure 16.14, when you select the Mixer Brush tool (for
descriptions of the other options that are not listed, see the
painting tools section earlier in this chapter):

Figure 16.14

Options for the Mixer Brush tool enable you to set the color
and control the paint mix, color, and cleaning of the brush.

1076



• Brush Load/Color. This field displays the current paint
that's loaded in the brush. This feature is critical when you are
painting with wet paint so you can see what colors of paint
the brush strokes will apply. The area in the center is the part
of the brush at the tips, and affects the pixels the most. The
area to the outside corresponds to the part of the bristles
farthest from the tips and does not affect the pixels as much.

When the brush is clean, this field displays a transparent
pattern. When the brush is full of a single color, the field
displays a solid color. When the brush is mixed, the field
displays the mix of colors, as shown in Figure 16.15. When
the outside area is transparent, only the tip of the brush is wet.
When you click the Color field, it launches a color chooser
that enables you to set the color of paint that you apply using
the brush strokes.

Figure 16.15

The Color field displays the paint that is currently loaded in
the brush. An empty brush is transparent, and a mixed brush
shows all of the mixed colors.

• Load Control. This drop-down menu enables you to
quickly load or clean the brush. You can also select the Load
solid colors. This loads the brush with a solid color only. If
you use this option with the Clean Brush After Stroke option,
the brush is loaded with a single color only.
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• Load brush after each stroke. This option reloads the
brush with the foreground color after each stroke. This is a
great way to paint a large area, but it can result in more paint
being added to the canvas than you may expect, because the
paint in the brush is constantly being replenished.

• Clean brush after each stroke. This option cleans the
brush after each stroke. If you use this option with the Load
brush after each stroke option, the brush is always loaded
with the foreground color only.

• Brush mode. This drop-down menu enables you to quickly
set the wetness, load, and mix of the brush stroke to preset
values. Essentially, it's the same thing as defining how thin
the paint is, as well as the heaviness of the mixture of paints
as you apply the stroke to the canvas. You can specify
wetness levels between dry and very wet, where dry means a
solid stroke and very wet means the paint is thinly applied to
the pixels. You can specify mixture levels of light or heavy.
You can also select custom values and set specific values.
Figure 16.16 shows examples of some of these settings.

Figure 16.16

Using different wetness, load, and mixture levels changes the
way that paint is applied to the pixels below.
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• Wet. This drop-down menu specifies the exact percentage to
use for the wetness of the paint on the brush. The wetter the
paint, the thinner the amount of paint that you apply.

• Load. This drop-down menu specifies the percentage of
paint to place into the brush each time the brush is loaded.

• Mix. This drop-down menu specifies the percentage of
mixing that occurs between the paint in the brush and the
pixels below when you apply the brush stroke to the image.

• Flow. This drop-down menu specifies the rate at which
Photoshop applies the paint from the brush to the pixels
below.

• Sample All Layers. This option causes the Mixer Brush
tool to sample all the layers in the document when applying
paint. Keep in mind that Photoshop applies the resulting
painting effect only to the selected layer.

Tip
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Using the Sample All Layers option, you can create a blank
layer to paint on that makes the painting effect
non-destructive. You can even paint on multiple new layers,
so that you can try different techniques until you find one
you like.

Using the Brush Panel

The Brush panel is by far the most complex and capable tool
in defining how painting strokes are applied to an image. This
panel has two purposes: to select the type of brush and to
define the behavior of the brush when applying brush strokes.

Using the options available in the Brush panel, you can define
the shape, bristle length, stiffness, texture, and many more
features of the brush that you use to apply the painting effects
to the image. At any time, you can reset the brush settings by
selecting Reset Brush Controls from the Brush panel menu.

You can open the Brush panel by pressing F5 on the
keyboard, selecting the Brush panel option from one of the
painting tools, or choosing Window⇒Brush from the main
menu bar. The following sections discuss how you can
control the different brush settings.

Selecting the brush tip shape

The shape of the brush tip controls the actual pixels that are
changed during each movement of the brush stroke. Different
brush shapes can result in very different effects. You may
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need to play around with a few of the shapes until you are
familiar with the different shape effects.

You can display and select brush tips by clicking the Brush
Tip Shape button, as shown in Figure 16.17. The available
brush tips are based on the set that you have currently
selected from the Brush Presets panel, which we discuss later
in this chapter. To change the set of brushes that appear in the
Brush Tip Shape list, click the Brush Presets button and select
a different list from the panel.

You can select from two types of brush tips: flat and bristle.
Flat brush shapes are the traditional shapes that Photoshop
has offered for years. Flat brushes define a set of pixels that
are affected. Bristle brushes are simple shapes with bristling
behavior that provide an experience much closer to using a
physical brush. The following sections describe these brush
tips in more detail.

Note

You can save the settings for a brush that you have
configured in the Brush panel by selecting New Brush
Preset from the Brush panel menu or by clicking the Create
New Brush icon at the bottom of the Brush panel. You then
name the brush, and it becomes available in the brush list.

Selecting flat brush shapes

Flat brush shapes are based on rasterized shapes, as you can
see in Figure 16.17. The solid pixels in the shape are used to
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sample and apply the painting effect during each movement
of the mouse. You can apply many different tip shapes to
your images, and the more you play with them, the better you
understand how to apply them.

Figure 16.17

Setting the shape of a flat brush

In addition to selecting the brush tip shape, you can also
configure some additional properties of the brush tip:
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Note

As you change any of the brush settings that apply to how
the stroke will look, the display at the bottom of the Brush
panel changes to reflect the new look. This enables you to
better understand how the changes you make to the settings
affect the actual brush stroke.

• Shape. This scroll box enables you to select one of the
brush shapes from the current list selected in the Brush
Presets panel.

• Size. This slider adjusts the size of the brush.

• Flip X/Flip Y. These check boxes enable you to flip the
brush tip shape along the X or Y axis. This enables you to
create mirror images of the brush either vertically or
horizontally. Using mirrored brush techniques can help if you
are using large brush strokes to create symbols or characters.

• Angle. This field sets the angle of the brush from 0 to 360
degrees. Tilting the angle of the brush affects how the stroke
looks, especially at the beginning and end.

• Roundness. This field sets how round the brush is. Round
brushes paint much more evenly than thin brushes. However,
thin brushes can paint into corners and generate angled effects
that round brushes cannot.

• Hardness. This slider sets the hardness of the brush. Hard
brushes create much more dramatic painting effects than soft
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brushes. When working with wet paint, a high hardness
amount can result in a skipping effect where the bristles skip
instead of smoothly flowing.

• Spacing. This slider specifies the spacing of the brush
stroke from 1 percent to 1000 percent. Using a spacing of 1
percent makes the stroke flow smoothly. Using a high spacing
value results in the stroke being applied at intervals.
Typically, you want to set this option very low unless you are
trying to scatter the effect of the brush stroke.

Choosing bristle brush shapes

Bristle brush shapes are based on computer algorithms that
calculate how to apply the paint based on a set of digital
bristles. Using the Brush Tip Shape settings shown in Figure
16.18, you define the shape and nature of the bristles. When
you use the bristle brush to apply the painting strokes,
Photoshop uses the bristle brush settings to determine how the
painting effect is calculated during each movement of the
mouse.

The available bristle brush shapes are shown at the top of the
list in Figure 16.18. In addition to selecting the brush tip
shape, you can configure some the following settings to
define the nature of the bristle brush:

• Shape. This drop-down menu specifies the shape of the
bristle brush tip. You can select Blunt, Curve, Angle, Fan, or
Point. You can also select round or flat versions of these
brush tips.
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• Bristles. This slider specifies the number of bristles present
in the brush tip. More bristles give you a smoother effect, and
fewer bristles give you more textured strokes.

• Length. This slider specifies the length of the bristles from
1 percent to 500 percent. The longer the bristles, the more
paint the brush holds and the more sweeping the strokes are.

• Thickness. This slider specifies the thickness of the bristles.
A higher thickness value results in a more textured effect
because the bristles show up better, whereas thinner bristles
result in smoother effects.

• Stiffness. This slider specifies how flexible each bristle is.
More flexible bristles allow for more sweeping strokes, a
softer look, and more sensitive effects. Stiffer bristles provide
more dramatic effects and add a greater amount of texture to
the stroke.

• Angle. This slider enables you to set the angle of the brush
as you apply the stroke. Adjusting the angle changes the
shape of the brush stroke, especially at the end.

Figure 16.18

Setting the shape of a bristle brush
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Photoshop provides a Bristle Brush preview that enables you
to see the shape of the bristle brushes. You can toggle the
Bristle Brush preview on and off by clicking the button on the
bottom of the Brush panel (see Figure 16.18). Figure 16.19
shows some of the sizes and shapes that are available using
different settings for the bristle brush.

Note
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You must select the Enable OpenGL Drawing option in the
Performance tab of the Preferences panel for the Bristle
Brush preview to work. To open the Preferences panel,
press Ctrl+K/ +K.

Figure 16.19

Photoshop provides a Bristle Brush preview window that
enables you to see the shape of the bristle brush based on the
settings you apply in the Brush panel.
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One of the most useful features of the Bristle Brush preview
is that it enables you to see the behavior of the painting stroke
through a simple animation. As you paint, the brush comes
down to the bottom of the preview pane. The dashed line
close to the bottom represents the paper, and you can see the
bristles bending as you apply the brush stroke. This feature is
most useful if you are using a stylus pen, because it also
shows you the pressure and angle of the brush, as shown in
Figure 16.20.

Note

The preview window shows two different views of the
brush: the top and side views. To toggle between the two
views, click the preview window.

Figure 16.20

The Bristle Brush preview window animates the movement of
the brush and bristles when you are applying paint strokes.
You can see the curvature of the bristles caused by the
pressure and angle of the stylus pen.

Selecting erodible tip brush shapes
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Erodible tip brush shapes are based on computer algorithms
that calculate how to adjust the shape of the brush tip as it
wears down with use. Using the Brush Tip Shape settings
shown in Figure 16.21, you define the shape and nature of the
erodible tip. When you use the erodible tip brush to apply the
painting strokes, Photoshop uses the brush settings to
determine how the brush tip erodes, thus changing the
painting effect of using the brush.

Figure 16.21

Setting the shape of an erodible tip brush
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You can configure some the following settings to define the
nature of the erodible tip brush:

• Size. This slider specifies the size of the erodible tip. The
larger the tip, the more paint you apply, and the larger the
effect that erosion has on the brush.

• Softness. This slider specifies how fast the erodible tip will
erode. The higher you set the softness, the faster the tip
erodes.

1090



• Shape. This drop-down menu specifies the initial shape of
the erodible tip. You can specify a tip shape of point, flat,
square, round, and triangle. The shape of the tip greatly
affects how erosion changes the flow of paint onto the canvas.
For example, an Erodible Point tip erodes faster and changes
more rapidly than an Erodible Flat tip.

• Sharpen Tip. This button resets the tip to its original state.
You may find yourself sharpening the tip often to maintain
the specific effect that you want from the erodible tip.

• Spacing. This option specifies the spacing between
applications of paint from the erodible brush. A setting of 0
percent means that the brush continually paints onto the
canvas, while a setting of 100 percent means that Photoshop
applies the paint once for each size value of the brush. For
example, if you set your brush to 25 pixels, then Photoshop
applies the paint from the brush once every 25 pixels as you
paint.

Photoshop provides an Erodible Tip Brush preview that
enables you to see the shape of the erodible brushes. You can
toggle the Brush preview on and off by clicking the button on
the bottom of the Brush panel (see Figure 16.21). Figure
16.22 shows some of the sizes and shapes that are available
using different settings for the erodible brush.

Figure 16.22

Photoshop provides an Erodible Brush preview window that
enables you to see the shape of the erodible brush based on
the settings you apply in the Brush panel.
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Photoshop provides the same type of preview as with the
Bristle Brush preview, which enables you to see the behavior
of the painting stroke through a simple animation. As you
paint, the brush comes down to the bottom of the preview
window. The dashed line close to the bottom represents the
paper, and you can see the erodible tip wearing away as you
apply the brush stroke. This feature is most useful if you are
using a stylus pen, because it also shows you the pressure and
angle of the brush.

Selecting airbrush shapes

Airbrush shapes are based on computer algorithms that
calculate how to apply paint to the canvas in a 3-D style as if
the brush tip was a distance away from the canvas and was
spraying paint. Using the Brush Tip Shape settings shown in
Figure 16.23, you define the shape and nature of the airbrush
tip. When you use the airbrush to apply the painting strokes,
Photoshop uses the brush settings to determine how to apply
the airbrush effect on the canvas.

Figure 16.23

Setting the shape of an airbrush
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You can configure some the following settings to define the
nature of the airbrush:

• Size. This slider specifies the size of the erodible tip. The
larger the tip, the more paint you apply, and the larger the
effect that erosion has on the brush.

• Hardness. This slider specifies how cleanly you apply the
paint to the canvas. The higher the setting, the less diffused
the paint becomes as you apply it to the canvas. As a result,

1093



the edges are much crisper. Reducing the hardness setting
results in softer edges around the painted area.

• Distortion. This slider specifies the amount of distortion to
apply to the paint spray. This can help provide a more
realistic look if you are going for a graffiti effect.

• Granularity. This slider specifies the size of each
individual spray particle. Increasing this value enables you to
more readily show the actual spray droplets.

• Splatter Size. This slider specifies the size of the splatter
droplets that are a trademark of spraying paint. This adds an
interesting effect, although for general airbrushing, you want
to set this size to 0 percent.

• Splatter Amount. This slider specifies how many splatter
droplets are painted on to the canvas.

• Spacing. This option specifies the spacing between
applications of paint from the airbrush. A setting of 0 percent
means that the brush continually paints onto the canvas, while
a setting of 100 percent means that you apply the paint once
for each size value of the brush. For example, if you set the
brush to 25 pixels, then you apply paint from the brush once
every 25 pixels as you paint.

Photoshop provides an Airbrush preview that enables you to
see the shape, angle, and splatter effect of the airbrush. You
can toggle the Brush preview on and off by clicking the
button on the bottom of the Brush panel (see Figure 16.23).
Figure 16.24 shows an example of an airbrush preview.
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Figure 16.24

Photoshop provides an Airbrush preview window that enables
you to see the shape of the airbrush based on the settings you
apply in the Brush panel.

Photoshop provides the same type of preview as the Bristle
Brush preview, which enables you to see the behavior of the
painting stroke through a simple animation. As you paint, the
shape of the airbrush stream is rendered in the preview pane.
This feature is most useful if you are using a stylus pen,
because it also shows you the pressure and angle of the brush.

Setting the brush behavior

In addition to setting the brush shape and attributes,
Photoshop provides many additional options that define the
behavior of the brush as you apply painting strokes. You can
select these options in the settings menu below the Brush Tip
Shape setting. You can toggle these settings on and off by
selecting or deselecting the check box next to them.
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You can also lock and unlock the settings by clicking the lock
icon next to their name. Locking a setting keeps the values
static, even as you toggle between other brushes and change
other settings. Settings that are not locked can be reset to the
default values by selecting Reset All Locked Settings from
the Brush panel options menu. This feature is great if you
need to reset the behavior of the brush and start over.

The following is a list of the simple behavior settings in the
Brush panel that do not have additional dialog box options:

• Noise. This option adds noise along with the paint as you
apply the stroke. This has the effect of adding extra texture to
the paint stroke and minimizing harsh changes made by
editing paint tools.

• Wet Edges. This option adds an appearance of wetness to
the edges of the paint strokes, which can help soften the edges
of the strokes. This option is neither needed nor available
when you are using the Mixer Brush tool.

• Build-up. This enables an airbrush style buildup to be added
to paint strokes.

• Smoothing. This option causes the brush stroke to produce
smoother curves. It is most effective when you are using
quick paint strokes with a stylus. This is a nice option, but it
may produce a slight lag time when rendering the stroke.

• Protect Texture. This option causes Photoshop to apply the
same pattern and scale to all brush presets that have a texture
to help simulate a consistent canvas texture when painting
with multiple, textured brush tips.
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The following sections cover the more advanced behavior
settings in the Brush panel that contain extra dialog box
options.

Configuring the Shape Dynamics settings

The Shape Dynamics settings, shown in Figure 16.25, are
designed to help you control the size, angle, and shape of the
brush when you apply the actual painting stroke.

Figure 16.25

Setting the shape dynamics of the brush tip
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Here are the settings you can configure to control the Shape
Dynamics effect:

• Control. This setting defines what input is used in
determining the variance applied by the jitter settings. Setting
Control to Fade allows you to specify the number of steps
over which Photoshop applies the jitter adjustment. The other
settings enable you to use the pen pressure, tilt, and stylus
wheel values to control the variance that's applied. The Size
Jitter, Angle Jitter, and Roundness Jitter settings all have
Control settings that enable you to define how the value of
each is controlled, for example by the stylus tilt or stylus
pressure.

• Size Jitter. These settings control the variation in the brush
tip's size as you create the stroke by dragging the cursor. A
Size Jitter setting of 0 percent means that the brush tip size
doesn't change at all during the stroke. The higher the
percentage, the more the size dynamically changes as you
make the stroke. The Minimum Diameter setting specifies the
minimum size to which the jitter can reduce the brush as you
are applying the stroke.

Using the Pen Tilt setting to control the size jitter gives you
the most control. If you are using the Pen Tilt option in the
Control setting, you can use the Tilt Scale option to define the
amount of variance in the Size Jitter. The larger the Tilt Scale
setting, the more variance you see in the size of the brush.

• Angle Jitter. This setting enables you to vary the angle of
the brush based on different Control options. In addition to
the regular Control options, if you have a stylus tablet that
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Photoshop recognizes attached to your system, you have the
option to use the following:

• Rotation. This varies the angle of the brush based on the
rotation of the stylus pen.

• Initial Direction. This varies the angle based on the initial
direction of the brush stroke. This is similar to holding the
brush at a specific angle throughout the stroke and is a great
option if you are using the brush to add calligraphic text.

• Direction. This varies the angle based on the current
direction of the brush stroke. This reduces the impact that flat
brushes have when changing angles.

• Roundness Jitter. This setting enables you to vary the
roundness of the brush as you are creating the stroke. The
rounder the brush, the more consistent the brush stroke is.
Reducing the roundness allows you to create more dramatic
brush strokes in your image. You can specify a Minimum
Roundness value that keeps the brush from varying too much.

• Flip X Jitter/Flip Y Jitter. The Flip X Jitter option flips the
jitter across the X axis of the painting stroke. The Flip Y Jitter
option flips the jitter across the Y axis of the painting stroke.

Creating a scattering effect

The Scattering settings, shown in Figure 16.26, are designed
to help you apply a scattering effect as you apply the brush
stroke. The Scattering option creates the effect of scattering
the brush tip in a random displacement along the path of the
stroke, as shown in Figure 16.27.
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Figure 16.26

Setting the Scattering options of the brush tip

Here are the settings that you can configure to control the
Scattering effect:

• Control. This setting defines what input is used in
determining the variance of paint splatter size and distribution
applied by the scattering settings. Setting Control to Fade
allows you to specify the number of steps over which
Photoshop applies the scattering adjustment. The other
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settings enable you to use the pen pressure, tilt, rotation, or
stylus wheel values to control the variance that is applied.

• Scatter. These settings control the variation in the scattering
of the brush as you apply the stroke. The variance of the
scattering is controlled by the method that you specify in the
Control setting.

• Both Axes. This option causes the brush tip to scatter both
horizontally and vertically. When you deselect this option, the
brush tip is scattered only horizontally or vertically in a
direction perpendicular to the movement of the stroke.

• Count. This slider specifies the number of brush tips to
include in the scattering.

• Count Jitter. This slider specifies the amount by which the
scattering varies and enables you to control the variance of
the count based on the Control setting.

Figure 16.27

The effect of using the scattering option. One of the lines is
drawn without scattering, and the other with scattering.
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Applying a texture effect

The Texture settings, shown in Figure 16.28, are designed to
help you apply a texture effect to your brush strokes. Adding
texture to your brush tip, you can simulate textures such as an
oil paint canvas or wall that show up in the brush strokes.

Figure 16.28

Setting the texture options of the brush tip
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Here are the settings that you can configure to control the
Texture effect:

• Texture. This drop-down menu enables you to select a
texture from the patterns list that is currently selected in the
Presets Manager. When you display the list, you can click the
triangle button to display a list of presets and options to load
and save presets.

• Invert. This option inverts the pattern used to apply a
texture to the brush stroke.
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• Scale. This slider sets the size of the pattern applied to the
brush stroke. Setting this value too high makes the pattern
very apparent in the brush strokes. Setting it too low makes
the pattern too small to see.

• Brightness. This slider controls the brightness of the
texture.

• Contrast. This slider controls the contrast between
brightness and darkness in the texture.

• Texture Each Tip. This option causes Photoshop to apply
the texture individually to each brush mark in the brush stroke
rather than to the entire stroke when it is finished. Although
invoking this option is very CPU-intensive, it is required for
the depth variance option to have an effect.

• Mode. This drop-down menu specifies the blending mode to
use when applying the texture pattern to the brush stroke
(before it is applied to the pixels below). This setting does not
override the blend mode setting in the Brush tool options.

• Depth. This slider specifies how deeply the paint penetrates
into the texture. A value of 0 percent means that no pattern
shows through.

• Minimum Depth. This slider specifies the minimum
penetration depth that Photoshop applies to a stroke, even if
the variance control reduces penetration below that level.

• Depth Jitter. This slider enables you to vary the depth that
Photoshop applies to the texture as you are creating the brush
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stroke. Increasing this value can give the texture a more
dramatic appearance.

• Control. This drop-down menu defines what input is used
in determining the variance applied by the depth texture
setting. Setting Control to Fade allows you to specify the
number of steps over which Photoshop applies the depth
texture variance. The other settings allow you to use the pen
pressure, tilt, rotation, or stylus wheel values to control the
depth variance that is applied.

Applying dual brush strokes

The Dual Brush option enables you to use two brushes at the
same time to apply each stroke. Using the Dual Brush option
can add a whole new level of dynamics to your brushing
techniques. When you select the Dual Brush option, the Brush
panel dialog box changes to enable you to select the second
brush. You can also select the blending mode used to
combine the two brush strokes before you apply them
together to the image. You can also set the size, spacing,
scatter, and count to use in the second brush.

Painting with multiple colors simultaneously

The Color Dynamics option, shown in Figure 16.29, provides
a dynamic coloring effect by changing the brush stroke from
the foreground to the background color as you apply the
stroke. Using the Color Dynamics option allows you to
essentially paint with two colors at the same time.

The Foreground/Background Jitter slider controls the jitter
between the foreground and background colors. A value of 0
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percent applies only the foreground color. A larger value
results in more jitter between the two colors.

You can adjust the variance between the foreground and
background colors using the Control setting. The Control
setting defines what input is used in determining the variance
between the foreground and background colors. Setting
Control to Fade allows you to specify the number of steps
over which Photoshop applies the color variance. The other
settings enable you to use the pen pressure, tilt, rotation, or
stylus wheel values to control the color variance that is
applied.

You can also vary the hue, saturation, brightness, and purity
in the colors by adjusting the sliders in Figure 16.29.

Figure 16.29

Setting the color dynamics options of the brush tip
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Controlling the brush stroke with the Transfer option

The Transfer option, shown in Figure 16.30, gives you an
additional level of control over how Photoshop applies the
brush stroke to the pixels below by varying settings such as
opacity, flow, and wetness. The Transfer option really has
two modes: one for painting and editing brushes, and one for
the Mixer Brush tool.

When you select a painting or editing brush, you can use the
Transfer option to set an amount of Opacity Jitter and Flow
Jitter that occurs when applying the brush strokes. Increasing
the Opacity Jitter and Flow Jitter varies the intensity of the
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brush stroke and thus varies the effect of the painting tool in a
dynamic way.

You can adjust the variance in all the Transfer controls using
the Control setting. The Control setting defines what input is
used in determining the variance in each transfer setting.
Setting Control to Fade allows you to specify the number of
steps over which Photoshop applies the variance. The other
settings enable you to use the pen pressure, tilt, rotation, or
stylus wheel values to control how the variance is applied.

Figure 16.30

Setting the Transfer options of the brush tip
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Using the Brush Presets panel

The options for configuring the shape and behavior of brushes
are limitless. This makes the ability to save brush settings a
critical part of using the painting features in Photoshop.

The Brush Presets panel, shown in Figure 16.31, displays a
list of the preset brushes with their corresponding brush
stroke preview. The Brush panel menu also enables you to set
the preview mode to text only; small or large thumbnails; and
small or large thumbnail lists. You can also select one of the
many sets of preset brush lists from the panel menu. You can
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add, rename, and remove brush presets from the current list
using the buttons at the bottom of the panel menu.

The panel menu provides the following options to manage the
brushes that are available in the presets list:

• Reset Brushes. This option resets the preview list to the
Photoshop default.

• Load Brushes. This option launches a dialog box to load a
saved set of brushes from a file. The new set is added to the
existing set.

• Save Brushes. This option launches a dialog box to save the
current set of brushes as a new preset file. This is the best way
to permanently organize the brushes you are using.

• Replace Brushes. This option launches a dialog box to load
a saved set of brushes from a file. The new set replaces the
existing set.

Figure 16.31

Managing the preset brush list
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Painting with Non-Brush Painting Tools
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In addition to the brush style painting tools listed earlier,
Photoshop provides the Paint Bucket and Gradient tools,
which enable you to paint large areas of an image with a
color, gradient fill, or pattern. These tools apply paint using a
general filling method rather than individual brush strokes.
Painting with the Paint Bucket and Gradient Fill tools
provides an effective means to quickly add background color
and depth to an image.

The Paint Bucket and Gradient tools can be found in the
Toolbox, as shown in Figure 16.32. This enables you to
switch between these tools and other tools quickly when
you're trying to add color while painting in Photoshop.

Figure 16.32

The Paint Bucket and Gradient tools enable you to add paint
to an image by filling an area rather than using individual
brush strokes.

Applying paint to layers

The Paint Bucket tool applies paint to a layer when you click
a pixel. All pixels that match the pixel directly below the
cursor are replaced by the foreground color or a pattern. The
Paint Bucket tool paints only to the layer that you have
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currently selected in the Layers panel. Also, if a selection
exists, the Paint Bucket tool paints inside that selection only.

You can set the following options when using the Paint
Bucket tool:

• Color Source. This enables you to select either the
foreground layer or pattern.

• Pattern. This option enables you to select a pattern to fill
the image from the drop-down menu shown in Figure 16.33.
You can also select from several pattern sets using the popup
menu next to the pattern list, also shown in Figure 16.33.
Using this menu, you can load and save the preset lists, open
the Preset Manager, and add new patterns.

• Mode. This drop-down menu enables you to select the
blending mode to use when applying the paint to the image.

• Opacity. This field sets the opacity of the filling paint.

• Tolerance. This field sets the tolerance to use in
determining whether a pixel matches the color of the selected
pixel.

• Anti-alias. This option enables you to toggle anti-alias
smoothing around the edges of the paint fill. When you select
this option, the edges blend more with the surrounding pixels.

• Contiguous. This option causes the fill to occur only in
pixels of the same color that are also contiguous to the
selected pixel. When you deselect this option, Photoshop
paints all the pixels in the image that match the selected pixel.
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• All Layers. This option causes Photoshop to use all layers
to sample the selected pixel instead of just the selected layer.
This helps if you want to paint in a layer based on a pixel
color that exists in a different layer.

Figure 16.33

The Paint Bucket tool enables you to fill an area using a
pattern from a list. The popup menu next to the patterns list
enables you to load different sets of patterns, load and save
pattern presets, and even create new patterns.

Figure 16.34 shows some examples of applying paint with the
Paint Bucket tool. The first fill is a solid foreground color.
Notice that only the light blue portion of the image is painted.
The second fill is a pattern fill with the Contiguous option
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selected. Notice that only the light blue pixels contiguous to
the cursor are filled in.

Figure 16.34

Using the Paint Bucket tool, you can quickly paint over a
color in the image with another color or pattern.

Filling a selection with a color or pattern

The Fill tool enables you to fill in the current selection of the
canvas with either a solid color or a pattern. This can
sometimes be easier to use than the Paint Bucket tool. You
can control which pattern is used as well as the blending
mode and opacity to use for the fill.

To fill the current selection, choose Edit⇒Fill from the main
menu bar to open the Fill dialog box shown in Figure 16.35.
Then set the following options:

• Use. This drop-down menu enables you to select one of the
following options to use as a fill source:

• Foreground Color. This option fills the selection with the
currently selected foreground color.
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• Background Color. This option fills the selection with the
currently selected background color.

• Black. This option fills the selection with black.

• White. This option fills the selection with white.

• Gray. This option fills the selection with a gray that is
50-percent white and 50-percent black.

• Content Aware. This option is available when you have an
active selection in the document. Photoshop analyzes the
pixels around the outside of the selection and uses them to
apply a content-aware fill inside the selection. This is one of
the easiest ways to remove unwanted objects from an image.
Simply select the item you want to remove and then apply a
content-aware fill.

• Pattern. This option enables the Custom Pattern selector,
and fills the selection with the currently selected custom
pattern.

• History. This option fills the selection with pixels from
previous state in the document history.

• Custom Pattern. This drop-down menu enables you to
specify a custom pattern.

• Mode. This drop-down menu enables you to specify which
blending mode to use when applying the fill.

• Opacity. This field specifies the opacity of the fill as you
apply it to the canvas.
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• Preserve Transparency. This option prevents the fill from
being applied to transparent pixels in the image.

• Scripted Patterns. This option applies the pattern using a
scripted method rather than the standard tiling.

• Script. This drop-down menu specifies which script to run
when applying the custom pattern to the canvas.

Figure 16.35

Using the Fill tool, you can quickly paint over a color in the
image with another color or pattern.

In addition to the standard patterns, Photoshop also enables
you to fill using a scripted pattern. Typically when you apply
a pattern fill, the pattern is tiled together to fill the area.
Photoshop applies a scripted pattern to the image based on a
predefined set of operations.

To apply a scripted pattern fill, choose Edit⇒Fill from the
main menu bar and then select the Scripted Patterns option, as

1117



shown in Figure 16.36. You can then select one of the
following predefined scripts:

• Brick fill. This pattern script offsets every second row by
half of the pattern width. Photoshop randomly varies the color
of the input pattern to increase realism.

• Cross Weave fill. This pattern script rotates the pattern by
90 degrees and offsets it to create small gaps. Once again,
Photoshop randomly varies the color and input pattern to
increase realism.

• Random fill. This pattern script places the pattern on the
canvas in random sizes and locations.

• Spiral fill. This pattern script begins at the center and spirals
the pattern outward, regardless of the shape of the paintable
area.

• Symmetry fill. This pattern script places the input pattern
into different plane tilings. You should use thinner patterns
with transparency to get the best effects from this script.

Figure 16.36 shows an example of using a scripted pattern. In
this case, we simply selected a zebra-striped pattern and then
applied the Cross Weave pattern to it. Notice that each tile is
rotated 90 degrees.

Figure 16.36

Applying the Cross Weave scripted pattern to a custom
pattern easily provides a very cool patterned background.
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Applying a gradient fill

The Gradient tool applies a gradient fill by selecting start and
end points in the image. The Gradient tool paints only on the
currently selected layer in the Layers panel. Also, if a
selection exists, the Gradient tool paints only inside that
selection.

You can set the following options when using the Gradient
tool:

• Gradient pattern. This option enables you to select a
gradient pattern or launch the Gradient Editor. We discuss the
Gradient Editor in the next section.

• Gradient style. This option enables you to set the gradient
style. You can select from the linear, radial, angled, reflected,
and diamond styles.
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• Mode. This drop-down menu enables you to select the
blending mode to use when applying the gradient fill to the
image.

• Opacity. This field sets the opacity of the filling paint.

• Reverse. This option reverses the direction of the gradient
fill.

• Dither. This option adds a dithering effect as you apply the
gradient, to make the transitions appear smoother.

• Transparency. This option causes the transparency in the
gradient to enable the pixels below to show through. When
you deselect this option, the gradient is not transparent.

Figure 16.37 shows some examples of applying paint with the
Gradient tool. In one example, we used a linear gradient to
paint inside a rectangle. Notice that the angle of the gradient
follows the angle between the two points. In the other
example, we used a radial gradient to fill in a circle. Notice
that with the radial setting, the gradient flows in all directions
from the first selected point.

Figure 16.37

Using the Gradient tool, you can add a linear gradient at an
angle or a radial gradient that radiates out from the first
selected point.
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Creating custom gradients

The Gradient Editor enables you to define your own custom
gradients. The Gradient tool is so dynamic and powerful that
there are limitless types and styles of gradient fills that you
can create for your images.

To define a new custom gradient, click the gradient pattern in
the Gradient tool options menu to open the dialog box shown
in Figure 16.38, and set the following options:

• Name. This field specifies the name of the gradient. The
name appears in the gradient lists and when you hover the
mouse above the icon.

• Gradient Type. This drop-down menu enables you to
choose from two types of gradients: Solid and Noise. The
Solid gradient is created from solid color points that blend
into each other. The Noise gradients are created by setting
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specific color channel settings and then generating a gradient
based on noise (randomly selected colors) in those channels.

• Smoothness. This field defines the smoothness of the
transition between two colors.

• Transparency stops. These sliders enable you to set the
transparency value for a specific spot in the gradient. For each
transparency stop, you can set the opacity and a location
value. The location value corresponds to the midpoint
diamond shown between two stops. The closer the location is
to the transparency stop, the less effect the stop value has in
that direction.

• Color stops. These sliders enable you to set the color value
for a specific spot in the gradient. For each color stop, you
can set the color and a location value. The location value
corresponds to the midpoint diamond shown between two
stops. The closer the location is to the color stop, the less
effect the color stop value has in that direction.

Figure 16.38

Using the Gradient Editor, you can create custom gradients
that involve several colors and transparency levels.
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Clicking the Gradient Presets menu button shown in Figure
16.38 displays a menu that enables you to select, load, and
save sets from the preset lists.

Applying Painting Techniques

The tools discussed so far in this chapter provide an
incredible arsenal for creative minds. You can apply them in
limitless ways. Up to now, we have discussed only the basic
behavior of the tools. In this section, we show some examples
and techniques that you can use to paint creatively. These are
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only a few of many techniques that can help you get the most
from the painting tools in Photoshop.

One technique not listed here is to add a stroke to
a shape or path. Using paths to create shapes and then adding
a fill and stroke to them is a great way to paint specific
objects. To learn more about paths and shapes, see Chapter
17.

Painting from a blank canvas

The most basic form of painting is to use a blank canvas and
use painting tools to paint onto the canvas. You can paint onto
a blank canvas using countless methods, and this example
simply gives you a few steps to try out some different
techniques:

1. Open a blank image using the default Photoshop size of
7 by 5 inches.

2. Select the Gradient tool, and set the foreground color to
a sky-blue and the background color to white.

3. Use the Gradient tool to create a linear gradient from
the top of the canvas down.

You can use the Shift key to help you draw the gradient in a
vertical line. We drew the gradient shown in Figure 16.39 by
dragging from the top of the image down to the center of the
image.
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4. Select the Rectangle Shape tool, and set the background
color to a soft brown.

5. Use the Rectangle Shape tool to draw a brown rectangle
on the bottom of the canvas, as shown in Figure 16.39.

You now have a skyline.

Note

If you create the rectangle as a shape layer, you need to set
the Style option to the default setting of None so that a
gradient style is not applied to the gradient.

Figure 16.39

Adding a gradient fill and a solid rectangle quickly creates the
appearance of a skyline.
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6. (Optional) Create and select a new layer.

Although this step is optional, it is a good idea and shows
how you can add to a painting on a separate layer without
affecting the bottom layer.

7. Select the Brush tool, and from the Brush Presets list,
select the grass brush, shown in Figure 16.40.

Launch the Brush panel to configure a new brush.

8. Set the size of the brush to 134, and enable the Shape
Dynamics, Scattering, Color Dynamics, and Smoothing
options.

Set the Scattering to 98 percent, the Count to 3, and the Count
Jitter to 100 percent, as shown in Figure 16.40. This creates a
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brush that scatters the grass as you paint the strokes onto the
canvas.

Figure 16.40

Selecting a grass brush style and adding a scattering effect as
well as shape and color dynamics helps create a brush that
quickly applies a grass effect to the image.

9. Set the foreground color to a soft gold, and paint the
grass onto the new layer, as shown in Figure 16.41.

Notice how the brush technique scatters the grass.
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Figure 16.41

Applying the grass brush over the soft brown gives the
appearance of a grassy field.

10. Create and select a new layer.

11. From the brush styles list, select the soft brush, shown
in Figure 16.42, and launch the Brush panel to configure a
new brush.

12. Set the size of the brush to 223, and enable the Shape
Dynamics, Scattering, and Smoothing options.

This time, on the Shape Dynamics panel, increase the Size
Jitter and Roundness Jitter to 98 percent and set the Minimum

1128



Diameter to 0, as shown in Figure 16.42. This varies the size
of the soft brush and helps create a soft cloud effect.

13. Set the foreground color to white, and paint the clouds
onto the new layer, as shown in Figure 16.43.

Notice how the brush technique varies the size of the stroke
and helps create the variance in the clouds.

Figure 16.42

Selecting a soft brush style and adding a jitter to the size as
well as a scattering effect helps create a brush that quickly
applies a cloud effect to the image.
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Figure 16.43

Applying the soft brush over the gradient sky gives the
appearance of soft clouds.
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On the Web

The project used to create the image in Figure 16.43 is
available on this book's website as Figure 16.43.psd. You
can see the different layers and the final image.

Tracing edges from an existing image

A common technique that artists use is to sketch the subject
area prior to painting it. Photoshop provides a great method
for sketching general shapes: you simply create a new layer
and then use the Pencil tool to draw the edges. Remember that
when you press and hold the Shift key, you can draw straight
vertical or horizontal strokes, and when you press and hold
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the Shift key and click in two different locations, you draw a
straight stroke between them.

When you are tracing an image, it is a good idea to create
three extra layers. The topmost layer is the layer you draw on.
The next layer should be a simple white canvas that you can
turn off when you are tracing, and turn on to see what the
tracing looks like, as shown in Figure 16.44. The next layer
down sits above the image as an adjustment layer; its purpose
is to lighten the image to make it easier to see your tracing
lines while you are tracing but still see the image behind.

Figure 16.44 shows an example of loading an image, creating
a new layer, and then using the Pencil tool to trace some
general shapes. Notice that the finished product automatically
provides a good perspective in the sketch.

On the Web

The project used to create the image in Figure 16.44 is
available on this book's website as Figure 16.44.psd. You
can see the different layers used to create the sketch.

Using wet paint on an existing image

One of the biggest advancements in Photoshop in the past few
years is the addition of the Mixer Brush tool. The Mixer
Brush tool enables you to treat pixels already existing in an
image as wet paint. You can use the Mixer Brush tool to
brush around the paint that already exists, which can fix small
areas of images, or apply an effect to larger areas. You can
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use all the power of the Brush panel to create special brushes
and then use them as wet paint on the image.

Figure 16.44

Using a new layer and the Pencil tool, you can quickly trace
shapes in the image below to create a quick sketch to paint
from.
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Tip

You could also start by choosing Filter⇒Artistic⇒Dry
Brush Filter to simulate brush strokes in the image before
applying your own wet paint technique. The Dry Brush filter
applies a similar technique, but it's very limited, whereas
you have limitless possibilities when using your own hand
and the plethora of brush styles Photoshop has to offer.

Figure 16.45 shows an example of using a simple fan brush
with the Mixer Brush tool to create brush strokes on an image
to simulate the appearance of an oil painting. The cool thing
about this effect is that it was applied in only a few minutes.
If you spend more time, you can really fine-tune the brush
strokes and create some nice artwork.

In Figure 16.45, we deselected the Load brush after stroke
option so no new paint would be added. We also selected the
Clean brush after stroke option so the brush would be clean
before touching the image again. This allowed us to keep the
paint from mixing too much.

Figure 16.45

Using the Mixer Brush tool, you can easily apply a painting
stroke technique to a photo.
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Summary

Photoshop merges its world-class photo-editing tools with its
paintbrush tools to provide the best of both worlds. This
chapter discussed the Brush tools available for editing, such
as the Dodge and Burn tools, as well as the tools Photoshop
provides for painting, such as the Paint and Mixer Brushes.
You can use these tools to edit photos, paint new images, and
even combine painting with photo editing.

The Brush panel enables you to create custom brushes that
extend your capability in editing and painting images. You
can also use Photoshop blending modes to apply the effects
from the Brush tools in a variety of ways.

In this chapter, you learned about the following:

• Customizing the Brush tool settings using the Brush panel

• Using some Brush tools for editing localized areas of images
and some for painting pixels

• Adjusting the blending mode to completely change how
Photoshop applies brush stroke effects to the pixels below
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• Erasing specific pixels in an image

• Using tracing techniques to quickly give you a basis and
perspective for painting images

• Using the wet paint capabilities of Photoshop to create a
painting from an existing image
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Chapter 17: Working with Paths and Vector Shapes

In This Chapter

Understanding vector path components

Defining vector paths

Manipulating vector paths

Adding custom vector shape layers to documents

Vector data is completely foreign to most of the other
functions in Photoshop that deal with pixel manipulation.
Vector paths and shapes are derived from a series of
mathematical functions rather than specific values for
individual pixels. This chapter focuses on helping you
understand how vector paths are created and manipulated as
well as how to use them to create selections, masks, and
shapes that you can apply to images.

Understanding Paths

You must understand the nature of paths in order to use them
when working in Photoshop. Basically, a path is a series of
lines called vectors. Each vector is made up of a coordinate in
the image, a value that defines the direction, a value that
defines the length, and parabolic parameters that define the
contours. Instead of storing an image as a series of pixel
values, the path data is stored as a series of mathematical
functions that define the vector lines that make up the image.

Paths offer some definite advantages over simple pixel data:
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• The vector data is common to many different computer
graphics applications, so you can save a vector image in one
application and then use it and even manipulate it in another
application without losing any data integrity. For example,
you could create a path shape in Photoshop and then open it
in Illustrator and still be able to manipulate it.

• Paths can be resized to a much larger size without losing
their sharpness. For example, most fonts are based on vector
paths, and that is why you can increase the size of the font
and still keep the crisp edges.

• Vector paths can be manipulated several times without
generating pixelation.

The following sections discuss the types of paths that you can
create in Photoshop as well as the components that make up
the paths.

Building path components

Two basic components are involved in creating a path: the
line segments and the anchor points. The anchor points fix the
end points of each line segment to the canvas below. Each
line segment in the path requires one anchor point at each
end. However, you can add several anchor points to a path,
and a line segment is generated between them using a
mathematical function.

The basic purpose of anchor points in a path is to provide a
fixed point that enables a change of direction or curve in the
lines. For example, Figure 17.1 displays a simple path with
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several anchor points. Notice that at each anchor point, the
path changes direction.

Figure 17.1

A path is made up of a series of anchor points connected by
line segments. The anchor points enable the path to change
direction.

The shape of the curve in each line segment is controlled by
direction points attached to the anchor points of the line
segment, as shown in Figure 17.2. The direction points
control the angle at which the line segment leaves the anchor.
Between the anchor and the direction point is another line
called the direction line, also shown in Figure 17.2.

The length of the direction line denotes how far the line
segment moves away from the anchor point before being
pulled back into the next anchor point. The longer the
direction line, the farther away from the anchor point the line
segment moves in that direction before curving back toward
the next anchor point, as shown in Figure 17.2.

Figure 17.2
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The direction point and line indicate the direction and how far
the line segment moves away from the anchor point before
moving back toward the next anchor point.

There are two types of anchor points: corner points and
smooth points. Corner points can produce sharp transitions in
direction between line segments, while smooth points always
produce a smooth transition in direction between line
segments.

The direction points in a smooth anchor move
simultaneously, so the line segments on both sides of the
anchor point are adjusted at the same time. The direction
points on a corner anchor move independently, so only one
segment attached to the anchor moves at a time. This enables
you to create a sharp corner, as shown in Figure 17.3.

Figure 17.3

The direction points attached to a smooth anchor point both
move simultaneously, resulting in a smooth curve. The
direction points attached to a corner anchor point move
independently, allowing for a sharp angle.
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Defining types of paths

You will work with several different types of paths in
Photoshop. Paths are built from a series of points that connect
lines. To create complex vector shapes requires combinations
of straight or linear paths, curved paths, open paths (which
have endpoints that don't connect to other points), and closed
paths where all points connect to each other. We will discuss
paths later in this chapter, so you need to understand the
different path types in the following list (refer to Figure 17.4):

• Linear. A linear path is a simple, straight line that moves
directly from one point to another.

• Curved. A curved path is a line that does not move in a
straight line from one point to another, but instead follows a
parabolic curve.

• Open. An open path is a set of one or more lines that has
both a starting point and an ending point.
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Note

You can convert an open path into a closed path by dragging
one of the open anchors over the top of the other one. The
mouse icon changes to indicate that the two anchors will be
linked. When you release the mouse button, the two anchors
are converted into a single corner anchor.

• Closed. A closed path is a set of one or more lines that do
not have a starting point or an ending point. You create a
closed path by placing the end point of the last line in the
exact coordinates of the starting point of the first line,
creating an entirely closed area. Closed paths are called path
components, path shapes, or path layers.

Figure 17.4

Photoshop has several different types of paths, including
linear, curved, open, and closed.
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• Working. The working path is the current set of paths that
you are actively working on that have not yet been saved.
You can have only one working path active at a time, so you
need to save the path using the Paths panel (which we discuss
later in this chapter) when you are finished with it before you
can open another working path.

• Clipping. A clipping path is a special type of path used to
control what areas of the image are visible when viewed in a
page layout or illustration application. This enables you to
hide parts of the image in the final layout without actually
deleting those areas of the image.

Paths can also be applied as vector masks. This
enables you to create complex paths using the tools described
in this chapter, and apply them as vector masks to images.
See Chapter 10 for information about how masks are used.
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Exploring the Vector Path

When working with vector paths, you use several different
tools and panels to create, manipulate, and use the paths. The
Pen tools enable you to create paths, add points, modify
points, and delete points from paths. The Path Selection tools
enable you to move entire paths as well as individual points
on a path. You use the Paths panel to manage and use paths in
your documents. This section discusses these tools; in the
following section, you learn how to use them to create and
manipulate vector paths.

Using the Pen tools

The most fundamental vector path tools are the Pen tools.
You use the Pen tools to create path anchor points when you
create your custom paths. You also use the Pen tools to delete
or add anchor points to existing paths and convert anchor
points.

There are several Pen tools, as shown in Figure 17.5. The
point-to-point and Freeform Pen tools enable you to create
paths. The other Pen tools also enable you to manipulate a
path by adding or removing individual points from it.

Figure 17.5

Using the Pen tools, you create paths, add points, modify
points, and delete points from paths.
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Pen tools

The keyboard shortcut P selects the Pen tools, and Shift+P
toggles between the Pen tool and Freeform Pen tool. The
following list describes what each of the Pen tools does:

• Pen tool. Using this tool, each time you click the document,
an anchor point is added and a straight line segment is added
between the previous anchor point and the newly created
anchor point. You can use the Pen tool to add direction points
as you are adding anchor points in a couple of different ways.

You can add points to the path as smooth anchors. When you
press and hold the mouse button and drag as you add an
anchor point, the anchor point is added as a smooth anchor, a
set of direction points/lines follows the movement of the
mouse, and the new line segment curves according to the
direction and length of the direction lines, as shown in Figure
17.6.
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Tip

If you press and hold down the Shift key when you are using
the Pen tool, the next anchor is snapped to 45-degree-angle
increments. This is useful if you need to keep your path
symmetrical or add straight horizontal or straight vertical
lines to your path.

You can also add a direction point to an anchor after you have
already added the anchor. When you click an existing anchor
(at either end of the path) using the Pen tool, a direction point/
line follows the mouse. When you release the mouse, a
direction point/line is added to the anchor and the anchor
becomes a corner anchor. When you add the next point, the
line segment between the two points adheres to the previously
added anchor point, as shown in Figure 17.6.

Figure 17.6

Using the Pen tool, you can add simple anchors by clicking
the mouse button, add curved anchors by clicking and
dragging the mouse, and add corner anchors by dragging an
existing anchor to add a single direction point/line.
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Tip

For faster manipulation of paths, use the Auto Add/Delete
option in the Pen tool. When you hover over an existing
path with the Pen tool, the Pen tool toggles between the Add
Anchor Point tool and the Delete Anchor Point tool. This
enables you to use a single tool to add and remove points
from the existing path.

• Freeform Pen tool. Using this tool, you can draw a
freehand line on the document by clicking and dragging the
mouse. As long as you are dragging the mouse, a line is
drawn. When you release the mouse, the line is converted to a
path with the necessary anchor points, as shown in Figure
17.7.

• Magnetic. Using the Freeform Pen tool gives you the
Magnetic option in the Options bar. When you select the
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Magnetic option, the line you draw with the Freeform Pen
tool tries to follow the boundaries of edges similar to creating
a selection with the magnetic lasso tool. This is a great option
when you are trying to use the Freeform Pen tool to trace
around an object in the background image.

Figure 17.7

Using the Freeform Pen tool, you can draw a line on the
document and Photoshop converts it to a path with the
necessary points.

• Add Anchor Point tool. Using this tool, you can add an
anchor to an existing path. Simply select the Add Anchor
Point tool, and click the path to add the anchor.

• Delete Anchor Point tool. Using this tool, you can remove
anchors from the path by clicking them with the mouse. The
line segments on either side of the anchor are combined into a
single line segment. Be careful when removing anchors from
the path because it may drastically alter the appearance of the
path.

• Convert Point tool. Using this tool, you can convert corner
anchor points to smooth anchor points and smooth anchor
points to corner anchor points.
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Smooth anchor points are converted to corner anchor points
when you select them with the Convert Point tool. Photoshop
displays the direction points and lines that normally move
simultaneously. Then you use the Convert Point tool to drag
one of the direction points to change the curve across the
sharp point to an angle, as shown in Figure 17.8.

Corner anchor points are converted to smooth anchor points
when you click them with the Convert Point tool and drag the
mouse to add and adjust the direction points and lines that
define the curve across the anchor point, as shown in Figure
17.8.

Figure 17.8

Using the Convert Point tool, you can toggle anchor points
between smooth anchors and corner anchors.

Pen tool options
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When you select the Pen tool, several useful options become
available in the Options bar. The Pen tool enables you to use
specific drawing modes. Depending on which drawing mode
you select, you will have slightly different options in the
Options bar, as shown in Figure 17.9. The Pen tool options
enable you to toggle among Pen, Freeform Pen, and Shape
tools; toggle among the Shape, Path, and Pixels modes; and
define how the path area is generated.

Figure 17.9

Using the Pen tool options, you can set the Pen type and
mode and define the path area.
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The following list describes the options that are available for
the Pen tool:
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• Drawing modes. Clicking this drop-down list enables you
to toggle among the Shape, Path, and Pixels modes. When
you select Shape, you are drawing to a new vector layer.
When you select Path, you are drawing to the currently
selected path in the Paths panel. When you select Pixels, you
are drawing raster pixels directly to the currently selected
layer; however, the Pixels option is not available in the Pen
tool.

• Make options. Clicking these buttons enables you to make
a selection, vector mask, or shape from the currently selected
path geometry.

• Path Operations. Clicking this drop-down list enables you
to choose an option for the currently selected paths:

• New Layer. Selecting this option creates a new vector layer
from the path.

• Combine Shapes. Selecting this option adds the path you
are creating to the current working path; any overlapping
areas are still in the path. Figure 17.10 shows how an open
path is added to the current circle path using the Combine
Shapes option.

Figure 17.10

When using the Combine Shapes option, the area inside the
new path is added to the existing working path.
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• Subtract Front Shape. Selecting this option deletes the
path you are creating from the current working path — in
other words, any overlap is removed from the working path.
Figure 17.11 shows how an open path is removed from the
current circle path using the Subtract Front Shape option.

Figure 17.11

When using the Subtract Front Shape option, the area inside
of the new path is removed from the existing working path.

• Intersect Shape Areas. Selecting this option alters the
current working path to include only those areas where the
original current working path and the newly created path
overlap each other. Figure 17.12 shows how an open path is
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intersected to the current circle path using the Intersect Shape
Areas option.

Figure 17.12

When using the Intersect Shape Areas option, the working
path is altered to include only the area of overlap between the
older working path and the newly created path.

• Exclude Overlapping Shapes. Selecting this option alters
the current working path to include only those areas where the
original current working path and the newly created path do
NOT overlap each other. This can be a bit tricky until you
figure out that all paths including the working path must
overlap. Figure 17.13 shows how the exclusion path is created
when an open path is intersected by the current circle path
using the Exclude Overlapping Shapes option.

• Merge Shape Components. Selecting this option merges
the currently selected shape components into a single shape
component based on the operation you selected in the Path
Operations menu.

Figure 17.13
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When using the Exclude Overlapping Shapes option, the
working path is altered to include only the area where the
older working path and the newly created path do not overlap.

• Path Alignment. Clicking this button displays a menu that
provides options to align and distribute the currently selected
paths based on their edges, centers, width, and height. The
Path Alignment menu is separated into the following sections:

• Alignment tools. The Alignment tools enable you to align
two or more selected paths to the left edges, horizontal
centers, right edges, top edges, vertical centers, and bottom
edges. These options are useful to arrange paths in exact lines
and position them accurately. For example, Figure 17.14
shows two items centered vertically with each other using the
Alignment tools.

Figure 17.14

Selecting multiple paths and clicking the Align Vertical
Center option aligns the centers of the paths with each other.
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The distribution options enable you to distribute three or more
selected paths evenly. There are two options, Distribute
Widths distributes the items horizontally and the Distribute
Heights option distributes the items vertically. These options
are useful to evenly arrange paths in exact lines and position
them accurately. For example, Figure 17.15 shows an
example of using the Distribute Widths option to evenly
distribute a set of four paths.

Figure 17.15

Selecting multiple paths and clicking the Distribute Widths
option aligns the centers of the paths with each other and
evenly distributes them.

• Align To options. The alignment feature takes into account
the relative placement of the currently selected paths when
you select the Align To Selection option. The alignment uses
the canvas position to align the paths when you select the
Align To Canvas option.
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• Path Arrangement. Clicking this button displays a menu
that provides options to arrange the z-position of the path
relative to the other paths in the layer. For example, you can
send the currently selected path to the back if you want it to
appear behind the other paths in the layer.

• Geometry options. Selecting the Rubber Band option
causes the segment line to be drawn and updated while you
are adding anchor points. This is an extremely useful feature,
but it does use extra processing power and might be sluggish
on slower computers.

• Auto Add/Delete. Selecting this option and hovering over
an existing path with the Pen tool, toggles the Pen tool
between the Add Anchor Point tool and the Delete Anchor
Point tool. This enables you to use a single tool to add and
remove points from the existing path.

• Align Edges. Selecting this option aligns pixel shapes to the
edges of the pixel grid.

• Fill. Clicking this field enables you to specify a fill for the
selected path. When you click Fill, the Fill dialog box appears
(refer to Figure 17.9). You can choose to fill the selected path
with nothing, a solid fill, a gradient fill, or a pattern fill, as
shown in Figure 17.16. Without a fill or stroke, the path
contains no actual pixel data that will render when printed.

• Stroke. Clicking this button displays a list where you can
select a size of stroke that will be applied along the path, or
type in a specific size.
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• Stroke fill. Clicking this button opens the Fill dialog box
(refer to Figure 17.9), where you can specify the fill to use for
the stroke.

Figure 17.16

Using the Options bar, you can easily set the fill style for the
current path.

• Stroke options. Clicking this button opens the Stroke
Options panel (refer to Figure 17.9). From this panel, you can
set the following options that define the attributes of the
stroke:

• Stroke. Enables you to select from solid, dashed, or dotted
lines.

• Align. Enables you to specify whether to align the stroke to
the inside, outside, or center of the path line.
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• Caps. Enables you to specify how the end caps of lines will
look. You can select butt, rounded, or square caps. This
option also affects the dashed lines.

• Corners. Enables you to specify how the corners of the
stroke are applied. They can be mitered, round, or beveled.

• More options. Opens the Stroke dialog box (refer to Figure
17.9). From this dialog box, you can also specify the size of
the dashes and gaps as well as up to three different dashes in a
sequence.

• Width. Typing a number in this field enables you to set the
exact width of the path.

• Link shape height and width. Clicking this button
constrains the width and height of the shape as you change
either amount so that the proportions remain the same.

• Height. Typing a number in this field enables you to
directly set the height of the path.

Using the Path Selection tools

Once you have created a path, you can adjust it using the Path
Selection tools. These tools enable you to move the path as
well as manipulate the location and behavior of individual
anchor points.

By using the Path Selection tools, shown in Figure 17.17, you
can easily manipulate the size, shape, location, and look of
the path. You also use these options to combine paths into
shapes.
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Figure 17.17

Using the Path Selection tools, you can select, move, and
scale one or more paths, as well as edit individual anchor and
direction points on a path.

Path Selection tools

The keyboard shortcut A selects the Path Selection tools, and
Shift+A toggles between the Path Selection tool and the
Direct Selection tool. The following list describes the purpose
of each Path Selection tool:

• Path Selection tool. Use this tool to select, move, or scale a
single path or a group of paths. You select multiple paths by
pressing the Shift key.
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Tip

If you press and hold down the Alt/Option key while
dragging a path with the Path Selection tool, a duplicate of
the path is created and you drag the duplicate instead of the
original path. This is a great way to create multiple copies of
the same path.

• Direct Selection tool. Use this tool to select one or more
individual anchor points on a path. You can use the Direct
Selection tool to drag and reposition the anchor points. You
can also use the Direct Selection tool to adjust the direction
points of the selected anchor to change the curve of the line.
You can select and manipulate multiple points on the path by
pressing and holding down the Shift key as you select the
anchor points.

Tip

You can change the Path Selection tool into the Direct
Selection tool on the fly by pressing and holding down the
Ctrl/ key. This saves you time if you need to toggle back
and forth.

Tip
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When you select a path using the Path Selection tool, you
can fine-tune its position by using the arrow keys on the
keyboard. When you select one or more anchor points using
the Direct Selection tool, you can fine-tune the position of
the anchor point or points by using the arrow keys.

Path Selection tool options

When you select the Path Selection tool, several useful
options become available in the Options bar, as shown in
Figure 17.18. The Path Selection tool options are similar to
those in the Options bar for the Pen tool. The menus behave
the same, depending on whether you are selecting a path in a
vector layer or in a normal layer.

Figure 17.18

Using the Path Selection tool options, you can define how
paths combine, as well as align multiple paths.
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Understanding the Paths panel

A very useful feature for working with vector paths is the
Paths panel. The Paths panel gives you a visual perspective of
the current paths. It also enables you to manage and modify
multiple paths in a single document.

The Paths panel, shown in Figure 17.19, provides buttons and
a menu that enable you to manage the current paths in your
document. From the Paths panel, you can select paths, convert
paths to selections, and vice versa, as well as create new
paths.

Figure 17.19

The Paths panel enables you to create, adjust, and manage the
paths in your images.
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From the Paths panel, you can use the following options:

• Create a path/New Path. This option adds a new path to
the Paths panel, and you can begin to add path components to
it.

• Duplicate Path. This option creates a copy of the currently
selected path and adds it to the Paths panel as a new path.

• Delete current path/Delete Path. This option removes the
currently selected path from the document.

• Make work path from selection/Make Work Path. This
option converts the current selection in the image to a path.
This is a great way to create complex paths from existing
images. For example, it was easy to select the petals of a
flower in Figure 17.20 and create a path from them.

• Load path as a selection/Make Selection. This option
creates a new selection using the line segments of the
currently selected path in the Paths panel. Creating selections
from a path is extremely useful for three purposes: to use the
capabilities of paths to create and manipulate line segments
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using the anchors; to apply a path to an image; or to alter the
pixels below the path before applying it to the image.

Figure 17.20

You can use the Make work path from selection option to
quickly create complex paths using areas of existing images
that are easy to select.

• Fill path with foreground color/Fill Path. This option fills
the currently selected path with the current foreground color.
The path does not need to be closed, but it does need at least
two line segments that do not form a straight line.

• Stroke path with brush/Stroke Path. This option applies a
bitmapped brushstroke to the path. The currently selected
brush style and size are used to trace the lines in the path on
the image. Even though the path is visible on the screen, it
isn't visible in the saved image or in the printed image unless
a fill or brushstroke is applied. For example, Figure 17.21
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shows the effect on an image when a brushstroke is applied to
a path.

Figure 17.21

Applying a brushstroke to a path makes it visible in the actual
image. The currently selected brush style and size, as well as
the current foreground color, are used.

• Clipping Path. This option creates a clipping path in the
image. The dialog box enables you to set the flatness of the
clipping path in terms of device pixels. Printers use the value
specified in the flatness field to determine the granularity to
use when applying the clipping path. The lower the flatness
value, the crisper the clipping looks. You can also select
which path to use for the clipping path.

• Panel Options. These options, found in the Paths panel
menu, display a dialog box, enabling you to set the size of the
thumbnail that is used to view the path in the Paths panel list.

Tip
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You share paths between documents by selecting them in
the Paths panel of one document and then dragging and
dropping them into another document window in Photoshop.

Applying the Free Transform Option to paths

One of the coolest features of vector paths in Photoshop is the
free transform functionality. The Free Transform option
enables you to quickly size, rotate, skew, and warp paths
using a few simple mouse strokes.

To access the Free Transform tools, right-click the path using
the Path Selection tool, and then from the popup menu, select
Free Transform Path. A bounding box appears around the
path and a new Options bar appears, as shown in Figure
17.22.

Figure 17.22

Using the Free Transform tool Options bar, you can quickly
set the size, angle, and skew of the path.

Using the Options bar, you can set precise values for the
following Free Transform options:
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• Reference point. This option specifies the pivot point for
resizing, rotating, and skewing the path.

• X position. This field specifies the x-coordinate of the pivot
point of the path. This is a quick way to place the path exactly
where you need it horizontally.

• Y position. This field specifies the y-coordinate of the pivot
point of the path. This is a quick way to place the path exactly
where you need it vertically.

• Width. This field enables you to set the exact width of the
path.

• Link shape height and width. This option constrains the
width and height of the shape as you change either one so that
the proportions remain the same.

• Height. This field enables you to set the height of the path.

• Rotation angle. This field specifies the rotation angle used
to rotate the path. You can use this option to rotate the path by
an exact number of degrees.

• Horizontal skew. This field specifies the number of degrees
to skew the path horizontally.

• Vertical skew. This field specifies the number of degrees to
skew the path vertically.

• Toggle warp. This option enables you to toggle between the
warp transform and the normal bounding box transforms.
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• Cancel transform. This option cancels the current
transform and exits out of Free Transform mode.

• Commit transform. This option commits the current
transform of the path and exits out of Free Transform mode.
You can also press the Enter key on the keyboard to commit
the transform.

In addition to setting precise values, in Free Transform mode
you have a new set of menu options when you right-click the
bounding box of the path, as shown in Figure 17.23. These
menu options make it very simple to make some quick
transformations to a path using your mouse. You can easily
apply one or more of the transformations to a path.

Figure 17.23

Using the Free Transform menu, you can quickly scale, skew,
rotate, and warp a path.
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Using the Free Transform menu, you can make the following
transformations to the path:

• Scale. This option enables you to adjust the size of the path
by dragging the control handles of the bounding box.

• Rotate. This option enables you to rotate the path by
dragging the corner of the bounding box. Figure 17.24 shows
an example of using the rotate handle to rotate a vector path.
Notice the rotation icon showing the angle of rotation.

Figure 17.24

Using the Free Transform rotate tool to rotate a path

• Skew. This option enables you to adjust the skew of the path
by dragging the control handles of the bounding box. Figure
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17.25 shows an example of dragging the bottom-right corner
of a vector path to skew the right side. Notice that the skew
angle is displayed in the skew icon.

• Distort. This option enables you to distort the path along a
corner by dragging a control handle of the bounding box.

• Perspective. This option uses the Perspective tool in
Photoshop to adjust the perspective of the path. The
Perspective tool is a great feature if you need to adjust a path
to fit the perspective of an image you are working on. Figure
17.26 shows an example of using the Perspective tool to make
a vector path representing an envelope appear to be heading
away from the screen.

Figure 17.25

Using the Free Transform skew tool, you can skew a path by
dragging a corner of the bounding box with the mouse.
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Figure 17.26

Using the Free Transform perspective tool can quickly change
the look of a vector.

• Warp. This option adds a warp mesh to the bounding box.
The Warp tool is by far the most dynamic and capable of all
of the Path Transform tools. You can grab any point in the
mesh and warp the path however you like. Figure 17.27
shows the use of the Warp tool to totally transform the look of
a vector path.

Figure 17.27

Using the Free Transform warp tool, you can manipulate the
path from any location on the grid to completely change the
dynamics of the path.
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• Rotate 180°. This option rotates the path 180 degrees.

• Rotate 90° CW. This option rotates the path 90 degrees
clockwise.

• Rotate 90° CCW. This option rotates the path 90 degrees
counter-clockwise.

• Flip Horizontal. This option flips the path along a vertical
axis.
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• Flip Vertical. This option flips the path along a horizontal
axis.

Note

The reference point location that you set in the Options bar
of the Free Transform tool is used for all of the Path
Transform tools. Make sure you set this option correctly
before you begin transforming a path.

Exploring Paths

Understanding paths can help you in many aspects of
Photoshop, from drawing vector art to creating highly
accurate masks. In the previous sections, we discussed path
components, the vector tools used to create paths, and the
Paths panel, which is used to manage paths. In this section,
we apply that knowledge to some of the common tasks that
you can perform when working with paths. The following
sections take you through some examples of creating and
using paths.

Creating a path

There are many reasons to create paths in Photoshop. You can
use paths to generate highly accurate masks or vector art, or
to define the flow of text. The first example we look at is
creating a basic path using the following steps:

1. Select the Ellipse tool.
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2. Set the mode to Path in the Options bar of the Ellipse
tool.

3. Draw two circles by pressing and holding down the
Shift key as you create them, as shown in Figure 17.28.

Figure 17.28

Selecting the Ellipse tool from the Toolbox with the mode set
to Paths enables you to add circles to the current path.

4. Use the Path Selection tool to select both circles, and
then click the Exclude Overlapping Shapes option in the
Path Operations menu of the Options bar of the Path
Selection tool to remove the center of the inner circle from
the path area.

5. Click Merge Shape Components in the Path Operations
menu of the Options bar of the Path Selection tool to
combine the paths, as shown in Figure 17.29.

Figure 17.29
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Using the Exclude Overlapping Shapes option on the two
paths removes the inner area from the path shape area.

6. Use the Pen tool to add the points shown in Figure
17.30.

Figure 17.30

Using the Pen tool, you can create a simple handle by adding
four path points.
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7. Use the Path Selection tool to move the new path so it
touches the existing circles.

8. Use the Convert Point tool to adjust the corners for the
handle so they are round by dragging the direction points,
as shown in Figure 17.31.

Click each corner to convert the corner to a smooth anchor,
and then drag away from the corner to add and shape the
curves.

Figure 17.31

Using the Convert Point tool converts the corners to smooth
anchors and enables the line segments in the handle to
become curves.

9. Select both the handle and the circles, and then select
Merge Shape Components in the Path Operations menu of
the Options bar of the Path Selection tool to combine the
paths, as shown in Figure 17.32.
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Figure 17.32

Using the Merge Shape Components option creates a single
path from the two selected paths, completing the magnifying
glass shape.

Converting paths to vector shapes

Using paths to create vector shapes enables you to add
elements to an image that can be resized and shaped and still
maintain perfectly crisp edges. In this example, we convert
the path from the previous example into a vector shape using
the following steps:

1. Select the path using the Path Selection tool.

2. Right-click the selected path to open the menu shown in
Figure 17.33.

3. Select Define Custom Shape from the menu to open the
Shape Name dialog box shown in Figure 17.33.
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4. Name the shape and click OK to add the new shape to
the Custom Vector Shapes menu, as shown in Figure
17.33.

You can view the Custom Vector Shapes menu by choosing
Edit⇒Preset Manager and then selecting Custom Shapes in
the Preset Type drop-down menu.

Figure 17.33

Converting a shape to a path is as simple as right-clicking it
and selecting Define Custom Shape from the shortcut menu.
The new shape is added to the Custom Vector Shapes list.

Creating a clipping mask
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Using a path to create a clipping mask will enable you to
create a clipping mask in an image with crisp, clean lines. The
shape of the clipping mask can be easily adjusted by adjusting
the points in the path. In this example, we create a clipping
mask that you can save with the file to mask any area outside
of a specific object when you print the file:

1. Open an image in Photoshop.

2. Use the Pen tool to create a path around an object in the
image, as shown in Figure 17.34.

3. Select Save Path from the Paths panel menu.

Photoshop doesn't enable you to make a clipping path until
you have saved the path with a new name. Name the path
“Initial Points”.

4. Select Duplicate Path from the Paths panel menu.

Name the new path “Adjusted Points” and then select it in
the Paths panel.

5. Convert the anchor points to curved points and then
adjust them using the handles to fit the perimeter of the
object, as shown in Figure 17.34.

Figure 17.34

Use the Pen tool to create a path around an object in the
picture. The object is the only thing included when you apply
the clipping mask.
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6. Select Clipping Path from the Paths panel menu, as
shown in Figure 17.35, to launch the Clipping Path dialog
box.

Figure 17.35

Use the Save Path dialog box to give the path a meaningful
name. The working path is changed to the “Adjusted Points”
name in the Paths panel.
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7. Select the “Adjusted Points” path in the Clipping Path
dialog box, shown in Figure 17.36, and set the flatness.

In this case, we set the flatness to 5 device pixels to maintain
adequate sharpness while still supporting most printers.
Flatness determines the number of lines used to draw the
curve. A lower flatness value results in a greater number of
straight lines used to draw the curve and consequently a more
accurate curve. Flatness values can range from 0.2 to 100.

Figure 17.36

Select the path and flatness when creating the clipping path.

8. Click OK to make the path a clipping path.

9. Save the file in a format that supports clipping masks,
typically PSD, EPS, or TIFF.
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The file is created with the clipping path data.

Creating vector masks

Using a path to create a vector mask will enable you to create
a mask that can be easily fine-tuned to fit a specific area of an
image. You can also resize the path to create additional
clipping masks that maintain crisp edges. In this example, you
can use the following steps to create a vector mask that will
be added to a layer to mask part of the image:

1. Open an image in Photoshop.

2. Use the vector tools to create a path around an object in
the image, as shown in Figure 17.37.

In this case, the path is a simple ellipse around the dog's face.

3. Select the working path in the Paths panel.

4. Select Save Path from the Paths panel menu.

Photoshop doesn't enable you to make a vector mask from the
path until you have saved the path, as shown in Figure 17.37.

Figure 17.37

Create a path around the area of the image that you want to
include in the vector mask.
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5. If you are using a background layer, convert the
background to an unlocked layer by double-clicking it,
and then select it in the Layers panel, as shown in Figure
17.38.

6. Select the saved path in the Paths panel so Photoshop
uses the selected path to create the vector mask.

7. Open the Properties panel if it is not already open.

8. Click the Add Mask icon in the Paths panel.

A mask is added to the Properties panel, as shown in Figure
17.38.

9. Select the Add a layer mask option in the Masks panel
to add the vector mask to the image, as shown in Figure
17.38.

The layer mask is added to the layer, and a copy of the layer
vector mask is added to the Paths panel.

Figure 17.38
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Using the selected path to create a vector mask on a layer in
the image

On the Web

You can find the image shown in Figure 17.37 on this
book's website as Figure 17.38.psd. It contains a good shape
to practice using vector paths to create masks.
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Using Vector Shape Tools

The easiest way to describe a vector shape is as a vector path
applied as a mask to a fill layer. Unlike paths, vector shapes
apply pixel data to a document. You can apply vector shapes
to a document by painting the shape pixels either directly onto
a layer or as their own layer, which is called a vector shape
layer.

When you use the Pixels option to apply vector shapes to
documents, the vector shapes you apply are immediately
rasterized and painted onto the pixels in the layer selected in
the Layers panel. This replaces the pixel data below them.

When you use the Shape option to apply vector shapes to
documents, the vector shapes are added as vector shape
layers. You can edit the vector shape layers later.

When you use the Path option, vector shapes are applied to
the current layer as a vector path. You can use all of the
features we have already discussed in this chapter to work
with the new vector path.

This section discusses the vector shape layers, although most
of the tools work the same with the Shape, Path, or Pixels
option selected.

Working with vector shape tools

Creating vector shapes is almost identical to creating vector
paths, with the exception that a color can be used to fill in the
contents of the vector shape and a stroke can be used to
represent the vector lines. You use paths when you want to
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use a vector without actually adding pixel data to the output
image, and you use shapes when you want the vector to
actually be represented in the image.

You can add vector shapes to a layer either by selecting the
Pen tool from the options menu or by selecting one of the
vector shapes from the Shape tools in the Toolbox, shown in
Figure 17.39.

Figure 17.39

Using the Shape tools, you can add vector shapes to images.

The keyboard shortcut U selects the Shape tools, and Shift+U
toggles among the Shape tools. When you select a vector
shape, a Shape tool Options bar appears, similar to the one in
Figure 17.40. Choose the Shape mode to add the vector
shapes as shape layers.
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Note

The principles you learn in this section for using the Shape
mode apply the same way to the Fill Pixels mode. The only
difference is that in the Fill Pixels mode, you are directly
writing to the background or layer instead of as a shape
layer.

Figure 17.40

The Shape tool Options bar is identical to the Pen tool
Options bar. However, when you select the Shape Layers
option, additional options become available.

Notice that the Shape tool Options bar is identical to the Pen
tool Options bar when you are in Path mode. This is a great
feature of Photoshop because it makes it easy to deal with
vector paths and layers. For example, you can add a stroke or
fill to a path now, just as you can to a vector layer. You can
also adjust the alignment and arrangement of both vector
objects and vector paths. For a more detailed explanation of
each of the menu items, refer to the vector paths sections
earlier in this chapter.

The only real difference between the options menus for vector
paths and vector shapes is in the Geometry options menu. The
geometry options are different for each type of vector shape.
The following sections describe each of the shape tools and
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the options available in the Geometry Options menu for each
of the Shape tools.

Rectangle tool

The Rectangle tool creates a rectangle when you drag the
mouse between two diagonal corners. Using the Shift key
while dragging the mouse creates a square. The Rectangle
tool provides many options in a drop-down list, as shown in
Figure 17.41.

Figure 17.41

Additional options for the Rectangle tool

Click the down arrow next to the custom shape button to view
the following options:

• Unconstrained. This option enables you to create a
rectangle at any size.

• Square. This option forces you to create a square rectangle.

• Fixed Size. This option enables you to set the height and
width of the rectangle.

• Proportional. This option forces the rectangle to match the
proportions of the height and width that you specify.
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• From Center. This option enables you to select the first
location to be the center of the rectangle and then to select
one of the corners to create the rectangle, instead of dragging
from corner to corner.

• Align Edges. This option snaps the corners to the pixel grid.

Rounded Rectangle tool

The Rounded Rectangle tool enables you to create a rectangle
with rounded corners by dragging the mouse between two
diagonal corners. Using the Shift key while dragging the
mouse creates a square. When you select this option, a Radius
option becomes available in the Options bar that enables you
to set the radius of the corners of the rectangle. The Rounded
Rectangle tool provides the same additional choices in the
options drop-down menu as the Rectangle tool.

Ellipse tool

The Ellipse tool enables you to create an ellipse by dragging
the mouse between two diagonal corners. Using the Shift key
while dragging the mouse creates a circle. The Ellipse tool
provides the same additional choices in the options
drop-down list as the Rectangle tool, with the exception that
the Square option is a Circle option and there is no Snap to
Pixels option.

Polygon tool

The Polygon tool creates a polygon with the number of sides
specified by the additional Sides option shown in Figure
17.42. You create the polygon by dragging the mouse

1191



between two diagonal corners. You can use the Shift key
while dragging the mouse to force the polygon into a
45-degree angle.

Figure 17.42

Additional options for the Polygon tool

The Polygon tool provides the following choices from the
options drop-down list:

• Radius. This option enables you to set the radius of the
polygon in inches.

• Smooth Corners. This option makes the corners of the
polygon smooth anchors instead of corner anchors.

• Star. This option indents the line segments between the
corner anchors of the polygon toward the center by the
amount you specify in the Indent Sides By field.

• Smooth Indents. This option makes the corners of the
indents smooth anchors instead of corner anchors.

• Line tool. This tool enables you to create a line with the
thickness that you specify in the Weight field. You create a
line by dragging the mouse between two points. You can use
the Shift key while dragging the mouse to force the line into a
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45-degree angle. The Line tool provides the following
arrowhead options from the options drop-down list, shown in
Figure 17.43:

Figure 17.43

Additional options for the Line tool

• Start. This option adds an arrowhead to the first point
selected.

• End. This option adds an arrowhead to the last point
selected.

• Width. This field specifies the width of the arrowhead
relative to the weight of the line.

• Length. This field specifies the length of the arrowhead
relative to the weight of the line.

• Concavity. This field specifies how concave to make the
arrowhead relative to the weight of the line.

Custom Shape tool

The Custom Shape tool creates a custom shape that you select
from the additional Shape menu, shown in Figure 17.44. You
add the custom shape to the image by selecting a shape from
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the list and then dragging the mouse between two diagonal
corners. You can use the Shift key while dragging the mouse
to create the shape in even proportions.

Figure 17.44

Additional options for the Custom Shape tool

Adding vector shape layers

Adding vector shapes as their own layer enables you to
modify the shape without affecting other layers, hide the
vector shape, and drag and drop the layer into other
documents, as well as offering several other benefits. Now
that you have a good understanding of the available vector
shape tools, you should try adding a few shapes to a
document to get the hang of it. The following examples take
you quickly through the steps to apply the vector tools in a
few different ways.

The first example we look at creates a simple square by
keeping the Rectangle tool in proportion using the Shift key.
The technique here is similar for creating all the vector shapes
in proportion. Use the following steps:

1. Select the Rectangle tool from the Toolbox.
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2. Click the Shape option in the Options bar to create a
new layer with the shape.

3. Press and hold down the Shift key and drag diagonally
across the screen to create the square, as shown in Figure
17.45.

Notice that the shape is forced into a square and that a new
shape layer is added to the Layers panel.

Figure 17.45

Using the Shift key to create a square shape layer

In the next example, we use the Polygon tool to add an
eight-sided star with an overspray technique to give it more
depth. Use the following steps:

1. Select the Polygon tool from the Toolbox.

2. Click the Shape option in the Options bar to create a
new layer with the shape.
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3. Select the Smooth Corners, Star, and Smooth Indents
options from the Polygon tool options, as shown in Figure
17.46.

Also set the Indent Sides By option to 50 percent. This makes
the polygon a star with smooth corners and indents.

Figure 17.46

Selecting the Smooth Corners, Star, and Smooth Indents
options for a polygon creates a star shape. Selecting the
Overspray Text option in the Style options applies a bevel
effect.

4. Type 8 in the Sides field in the Options bar to create an
eight-sided polygon.
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5. Position the mouse in the center location for the
polygon, and click and drag the mouse out to create the
polygon vector layer shown in Figure 17.46.

6. Click the fx button in the Layers panel and add a Bevel
& Emboss effect to the newly created vector layer.

Notice that the polygon Shape layer has the Bevel & Emboss
effects applied to create the overspray effect.

The final example we show uses the Exclude Overlapping
Shape Areas option to combine the polygon created in the
previous example with a circle to create a completely
different shape. Use the following steps after completing the
steps from the previous example:

1. Select the Ellipse tool from the Shape tool menu.

2. Select the From Center option from the Ellipse tool
options drop-down menu.

This enables you to use the center of the polygon as the
starting point, which is much easier than trying to figure out
where to draw the corner of the ellipse creation box.

3. Select the Exclude Overlapping Shape Areas option
from the Options bar so only the areas of the circle that
are outside the polygon are included in the new shape
area.

4. Position the mouse in the center of the polygon, press
and hold down the Shift key, and drag outward to create
the circle, as shown in Figure 17.47.
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Notice that oNL1y the area outside of the polygon is included
in the shape area shown in the Layers panel.

5. Use the Path Selection tool to select the circle, and then
use the keyboard arrow keys to reposition the circle so it
is exactly around the perimeter of the polygon.

6. Select Merge Shape Components from the Path
Operations menu to combine the vector shapes into a new
shape area, as shown in Figure 17.47.

Figure 17.47

Using the Exclude Overlapping Shape Areas option creates a
shape that includes only the area of the circle that is outside
the polygon.

Adding custom vector shapes
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Adding custom vector shapes works the same way as adding
normal vector shapes, with the exception that you have some
additional options for managing the custom shapes from the
Shape Selection options in the Shape options menu.

The Shape Options bar, shown in Figure 17.48, appears when
you select one of the Shape tools from the Toolbox. When
you select the drop-down arrow, the Shapes list appears, as
shown in Figure 17.48. You can select any shape, and when
you click and drag the mouse on the document, the shape is
added just as in the previous examples.

Figure 17.48

When using the Custom Shape tool, you can select custom
shapes from a drop-down list. You can also manage the
Custom Shapes lists by saving and loading list files and by
selecting preset lists.
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The Shapes list provides a menu that includes the following
options:

• Rename Shape. This option opens a dialog box where you
can change the name of the selected shape. The name appears
when you hover over the shape in the tool and in some of the
other panels in Photoshop.

• Delete Shape. This option deletes the currently selected
shape from the Shapes list.

• View options. These options enable you to set the mode for
viewing shapes. You can select Text Only, which displays
only the shape names, two sizes of thumbnails, or two sizes of
list views. The list views include a thumbnail as well as the
shape name.

• Preset Manager. This option launches the Preset Manager
dialog box with the Custom Shapes option selected, where
you can create and manage presets for the Custom Shapes list.

• Reset Shapes. This option replaces the current list of shapes
with the default list.

• Load Shapes. This option enables you to load a set of
shapes from a previously saved file. The new shapes are
added to the current list of shapes.

• Save Shapes. This option enables you to save the current set
of shapes as a file. This is useful if you are creating your own
custom shapes so you have them available later and can
distribute them to others.
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• Replace Shapes. This option enables you to load a set of
shapes from a previously saved file. The current list of shapes
is replaced by the new list.

• Preset lists. This section provides several preset lists of
shapes that make it easier to find shapes you want. You can
select any of them from the list, and the current Shapes list is
replaced by the selected preset list.

Editing a vector shape

A great feature of vector shapes is that they include the
anchor and line information from the vector paths that created
them. This enables you to edit the vector shapes after you
have added them to your document. The following example
takes you through adding a custom shape to a document and
then editing it with the vector tools:

1. Select the Custom Shape tool from the main menu bar.

2. Click the Shape Layers option in the Options bar to
create a new layer when the shape is added.

3. Select the Heart Card shape from the Shapes list in the
Options bar.

The Heart Card shape is in the Shapes preset list in the Preset
Manager.

4. Drag the mouse diagonally to add the heart to the
document.
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5. Select the Direct Selection tool from the Toolbox, and
click the heart to expose the anchors, as shown in Figure
17.49.

Figure 17.49

Shapes contain the vector anchor and line information of the
vector paths used to create them so you can edit a vector
shape at any time using the vector path tools.

6. Select the Direct Selection tool from the Toolbox and
drag the bottom anchor points of the heart, as shown in
Figure 17.49.

7. Select the Direct Selection tool from the Toolbox and
drag the direction points of the curve, as shown in Figure
17.49, to give the heart a new look.

Note

You cannot edit vector shapes that are applied to a
document using the Fill Pixels option in the Shape tool
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Options bar because the vector shape is rasterized into pixel
data and painted onto the layer.

Summary

This chapter discussed how to create and manipulate vector
paths and shapes. Vector paths provide a distinct advantage
over pixel data because you can resize them without losing
any of the image crispness. That makes them useful for
creating shapes, masks, and selections that you can resize
without losing the sharpness in the edges. Vector shape layers
are vector shapes applied as masks to a fill layer.

In this chapter, you learned these concepts:

• How to create a vector path using the vector path tools

• How to manipulate individual anchor points on a path to
define the position of line end points and the curvature of the
line

• How to create a clipping mask

• How to create a vector mask that provides a mask that can
be manipulated using the vector path tools while maintaining
its crisp edges

• How to add a stroke and fill to a vector path to make the
path visible in an image

• How to create a vector shape from a vector path
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• How to edit vector shapes after they have been added to an
image
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Chapter 18: Working with Text

In This Chapter

Reviewing compatible fonts and typefaces

Adding text to images

Applying textual effects

Text can be an extremely important element in an image, not
only to add information but also to contribute to the overall
appearance. Photoshop provides the ability to add text to
images as vector objects. This chapter discusses the tools used
to add and edit text, as well as how to apply textual elements
to images in creative ways. The tools in Photoshop enable
you to configure and control the format and flow of the text,
and provide a way to edit the text right down to the character
shapes.

Learning a Little Bit About Text

Before jumping into adding text to images, let's look at what
text really means inside Photoshop. When you initially
consider text, you probably think about letters, words, and
paragraphs. Then as you apply the term text to a computer
application, you start to include the concept of fonts or
typefaces. Although the terms font and typeface are used
interchangeably, they are actually a bit different. A font
consists of a set of letters, numbers, and symbols that have the
same weight and style. A typeface is a collection or family of
fonts that have the same overall appearance but different
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weights or styles. For example, many typefaces include
regular, bold, and italic font versions.

The following is a list of the different font types that you can
work with in Photoshop:

• PostScript. PostScript or Type 1 fonts were designed long
ago by Adobe to be used with PostScript printers. These fonts
have mostly been replaced by OpenType fonts, but you may
run into them if you need to use an older font to match older
material.

• TrueType. TrueType fonts were developed by Apple to
compete with PostScript fonts. TrueType fonts are actually
made up of vector paths and enable the text to appear crisp,
even when you resize it. These fonts also enable special
characters or symbols to be included with the font as
“glyphs.” Although TrueType fonts are still widely used, they
are being replaced by OpenType fonts.

• OpenType. OpenType fonts were developed by Adobe to
replace both PostScript and TrueType fonts by embedding the
PostScript information in with the TrueType packaging.
OpenType fonts are also made up of vector paths and enable
some additional glyph capability, including glyphs that are
created by applying two letters together (such as ff), fractions,
and superscripting suffixes, like the st in 1st.

When working in Photoshop, you should adjust your thinking
about text. In reality, Photoshop treats text as a group of
vector shapes that represent letters, words, and paragraphs.
Selecting a font simply means that you are changing the set of
shapes that are used to represent the letters. Thinking about
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text in this way helps as you start to use some of the more
advanced features and apply artistic effects with text.

Using the Text Tools to Add Text to Images

Photoshop provides several tools that give you a lot of
flexibility and control when adding text to images. Text can
be added to images to provide information or as a visual
element. The Text tools in Photoshop provide dynamic ways
of adding both. This section discusses setting up preferences
for these tools and using them to add and edit text in your
images.

Setting type preferences

Before you start working with text, you may want to set the
type preferences in Photoshop. Setting the type preferences
enables you to define how the text and paragraph tools behave
and what features are available in the panels. To set the type
preferences, press Ctrl+K/ +K to open the Preferences dialog
box and select the Type option, as shown in Figure 18.1.

Use the dialog box to set the following options:

• Use Smart Quotes. When you select this option, Photoshop
detects the open and close quote characters in the text and
treats them differently so they point in the direction that they
apply.

• Enable Missing Glyph Protection. If you open a file in
Photoshop that contains a font that is not included on the
system, you see an alert and the font is substituted by one that
is on the system. When you choose this option, Photoshop
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automatically selects an appropriate font if you enter text that
results in incorrect or unreadable characters.

• Show Font Names in English. When you select this option,
the font names appear in English, even if the font is for
another language such as Chinese or Japanese. This is useful
if you need to add characters from another language font but
do not actually read the language.

• Choose Text Engine Options. You have the ability to
specify one of two options that will define what options are
available on the Text panel and Paragraph panel. These
options are

• East Asian. When you select this option, additional options
for the Chinese, Japanese, and Korean text symbols are
visible in the Character and Paragraph panels. If you are not
working with these language sets, you should leave this
option unselected.

• Middle Eastern and South Asian. When you select this
option, additional options for the Middle Eastern and North
African MENA languages such as Arabic, Farsi, and Hebrew
will be available in the Character and Paragraph panels. Also
when you select this option, Photoshop uses the MENA text
composer to correctly compose right-to-left and complex
scripts in the type layer.

Figure 18.1

Setting the preferences for text in Photoshop
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Using the text tools to add text

Photoshop provides four Toolbox tools that enable you to add
text to your document. There are two Type tools and two
Type Mask tools.

The two Type tools, shown in the Toolbox in Figure 18.2, add
text as a vector text layer either horizontally or vertically. The
great part about adding text as a layer is that you can go back
at any time and edit or apply effects to the layer.

The two Type Mask tools, shown in the Toolbox in Figure
18.2, use the text you type to create a selection mask that can
be converted to a vector or pixel mask or used as a simple
selection.
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Note

If you add text to a document that does not support layers,
such as bitmap, the text is applied initially as a layer.
However, when you save the document in a format that
doesn't support vector layers, the text layer is converted to
raster pixels.

Figure 18.2

The Type tools enable you to add text to your documents as a
vector text layer and to create selections from the text you
type.

When you select one of the Type tools, a Type tool Options
bar becomes available, similar to the one in Figure 18.3. The
options are applied to any text that is currently selected or to
new text that you type into the document.
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Figure 18.3

The Type tool Options bar enables you to set options for
selected text or text you are typing into the document.

From the Type tool Options bar, you can set the following
options:

• Orientation. This option enables you to toggle the text
between vertical and horizontal orientation.

• Font family. This drop-down menu enables you to select
the font family.

• Style. This drop-down menu enables you to select a
typeface style such as italic, bold, hard, light, strong, and so
on. The available options depend on the font that you have
selected.

• Font size. This drop-down menu enables you to set the size
of the font used when displaying the text.

• Anti-aliasing. This drop-down menu enables you to set the
anti-aliasing method that Photoshop uses to render the edges
of the font onscreen. Anti-aliasing tries to smooth the
square-edge effect by filling in the sharp edges and blending
the text with the background. The more anti-aliasing you
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apply, the smoother the transition, although anti-aliasing that
is too aggressive can produce artifacts around the edges of the
text. You can select the following anti-aliasing options:

• None. This option does not apply any anti-aliasing.

• Sharp. This option displays type in the sharpest fashion.

• Crisp. This option displays type that is somewhat sharp.

• Strong. This option displays type with a heavier
appearance.

• Smooth. This option adds the greatest amount of smoothing
around the edges.

• Windows LCD. This option provides the best anti-aliasing
for LCD screens on Microsoft Windows systems.

• Windows. This option provides the best anti-aliasing for
other screens on Microsoft Windows systems.

Tip

Too much anti-aliasing can result in some color artifacts
around the edges of the font and may give you inconsistent
results when producing low-resolution images such as those
used on the web. To reduce the inconsistency, deselect the
Fractal Width option in the Character panel menu.
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• Alignment. You can choose to set the alignment of the text
to left, center, or right for horizontal text, and top, center, or
bottom for vertical text.

• Color. You can click this box to launch the Select Text
Color dialog box, which enables you to set the color used to
fill in the text.

• Warp. You can click this button to apply Warp effects to
distort the text.

• Toggle Paragraph/Character panels. You can click this
button to quickly open and close the Character and Paragraph
panels. Because you use these panels frequently when
working with text, this is a great option.

You can add new text by using the Type tools either as point
type or as paragraph type. Each of these options provides
different advantages that we discuss in the following sections.

Note

While you are adding text, Photoshop is in Text Edit mode,
so many of the menu options are not available. To exit Text
Edit mode, press Ctrl+Enter/ +Enter and select another
layer or another tool in the Toolbox.

Adding text as a point type

When you add text as a point type, the text flows from a point
that you place on the screen. The text flows from the point
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based on the alignment setting in the Type tool Options bar.
For example, if the text is aligned left, the text flows to the
right; if the text is centered, the text flows in both directions
away from the point. This option is useful if you want to
create unbounded text in the image, but it does not provide as
many features as a paragraph type.

To add text to an image as a point type, simply select either
the Horizontal Type or Vertical Type tool from the Toolbox
and click the document. A point appears, and you can type
text from that point, as shown in Figure 18.4. Notice that a
new vector text layer is added to the Layers panel.

Figure 18.4

Adding text as a point type
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After you have added text as a point type, you can use the
Move tool to select and change the position of the text in the
newly created layer.

Adding text as a paragraph type

When you add text as a paragraph type, the text is placed
inside a bounding box. The bounding box limits the flow of
text, which offers the advantage of forcing the text to fit into a
specified area. As text hits the side of the bounding box, it
wraps down to the next line.

However, you do need to be careful. If the flow of the text
exceeds the bounding box dimensions, some of the characters
are hidden below the bottom of the box. This can result in
missing text in the image if you do not increase the size of the
bounding box or decrease the font size. When text is hidden
below the bottom of the bounding box, the bottom-right
control handle displays a plus sign.

To add text to an image as a paragraph type, select either the
Horizontal Type or Vertical Type tool from the Toolbox and
drag the mouse diagonally to create a bounding box, as shown
in Figure 18.5. You can then type text into the box. Notice
that a new vector type layer is added to the Layers panel.

Tip

If you press and hold down the Alt/Option key while
dragging to create the paragraph type bounding box, a
dialog box appears, enabling you to set the height and width
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of the bounding box. The values in the dialog box are in
pixel/point units denoted by px/pt. However, you can also
specify the size in inches by using inches as the unit — for
example, “3 inches.”

You can change the size of the bounding box using the mouse
to drag the control handles at the corners and sides. The
bounding box provides another useful feature when working
with text in that you can use the rotation controls in the
corners to rotate the text, as shown in Figure 18.5.

Figure 18.5

Adding text as a paragraph type creates a bounding box that
limits the flow of the text. You can use the rotation controls
on the bounding box to rotate the text.
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Editing vector text layers

After adding text to your document as a vector text layer, you
can edit it at any time by selecting one of the Type tools and
clicking the text in the document window. With the text
object selected, you can use the mouse to select a portion of
the text by dragging over it just as you would in any text
editor.

Note

If you have vector text layers that overlap each other,
clicking them selects the top layer. You may need to
double-click the text thumbnail in the Layers panel to select
text in a vector text layer that is underneath another one.

It is important to keep in mind that while you are editing text,
some of the changes, such as font size and color, apply only
to the selected text, while other changes, such as alignment
and kerning, apply to the entire paragraph, regardless of what
text you have selected. Each time you press Enter/Return in a
paragraph type text box, a new paragraph begins. That means
you can make different format changes for each paragraph in
the same paragraph type bounding box.

Tip

When you are in Text Edit mode, Photoshop displays
selection guidelines and other editing aids. This can make it
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difficult to follow the text. While in Text Edit mode, you
can press the Ctrl+H/ +H hotkeys to toggle displaying the
guidelines and editing aids, and even turn the selection
highlight on and off. This makes it easier to read the text
and see the effect of making edits.

Photoshop provides a number of options to format and edit
the text and to format and affect vector text layers. Some of
these options are located in the Type tool Options bar that we
discuss earlier in this chapter. Some of them are found in the
Character and Paragraph panels, which we discuss later in this
chapter.

Several options become available when you use one of the
Type tools to right-click the text to open the Text Edit menu,
shown in Figure 18.6. If the text is already selected when you
right-click the mouse, a slightly different menu appears with
options for the selected text. The following sections cover the
options available in this menu.

Note

You should be aware that when in Text Edit mode, not all of
these options are available. For example, you cannot
rasterize the text or convert between point type and
paragraph type. Also, many of these options are available
from the Layers panel menu when you select the vector text
layer.

Edit Type
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The Edit Type option puts Photoshop in Text Edit mode in
the vector text layer that you clicked. While in Text Edit
mode, you can adjust the settings in the Type tool Options bar
or in the Character and Paragraph panels to edit and format
the text.

Figure 18.6

Right-clicking text using a Type tool displays a menu that
gives you several options to edit the vector text layer.
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Check Spelling

The Check Spelling option launches a Check Spelling dialog
box similar to the one in Figure 18.7 if there are any words in
the text that do not exist in the Photoshop dictionary. The
Check Spelling dialog box displays misspelled words, offers
suggestions, and enables you to apply changes, ignore
misspellings, or add words to the Photoshop dictionary. If you
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select the Check All Layers option, Photoshop spell-checks
all vector text layers.

Find and Replace Text

The Find and Replace Text option can be useful if you need
to quickly find text in your document or if you have been
misspelling a word and need to change the spelling in several
different places. You are not likely to add a lot of text to your
images, so you may never need this feature. However, if you
ever do, it can save a lot of time.

Rasterize Type

The Rasterize Type option converts the vector data in the
vector text layer into pixel data. You can no longer edit it as
text; instead, the layer is treated as a raster layer just as if you
had used the paint tools to create the text. Converting the text
to a raster image can be useful if you want to apply effects to
the text as a pixel image — for example, applying a filter to
soften edges.

Figure 18.7

Photoshop provides a built-in spell checker that enables you
to quickly find and fix misspelled words in your text.
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Create Work Path

The Create Work Path option uses the vector anchor and line
data from the selected text to generate the working vector
path. The new working path appears around the text and is
available in the Paths panel, as shown in Figure 18.8. The
vector text layer remains unchanged, and you can still edit
and use it as you normally would.

Figure 18.8

You can use the vector text layer to create a working path
from the vector data in the text.
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For more information about how to edit and use
vector paths, see Chapter 17.

Convert to Shape

The Convert to Shape option converts the selected vector text
layer into a vector shape layer. The new vector shape layer
replaces the vector text layer in the Layers panel, as shown in
Figure 18.9. The vector text layer is no longer available for
text editing; instead, you need to treat the layer as a vector
shape layer.
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Converting text to a vector shape opens a variety of
possibilities for editing. For example, Figure 18.9 shows how
we used the Direct Selection tool to drag some of the anchors
and adjust the direction lines to completely alter the look of
the character.

Figure 18.9

You can convert a vector text layer into a vector shape layer
and then use the vector tools to edit and use the shape.

Horizontal and Vertical options

The Horizontal and Vertical options enable you to toggle the
text arrangement between a horizontal flow and a vertical
flow.

Anti-Alias adjustment

The Anti-Alias options enable you to quickly set the type of
anti-alias adjustment to apply to the selected vector text layer.

Faux formatting
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The Faux Bold and Faux Italics options enable you to apply a
fake bold or italic style to the selected text. If you have
selected a portion of the text, this option applies only to the
selected text and not to the entire paragraph. If you have not
selected any text, this applies to the entire paragraph.
Typically, you should avoid using the Faux text options
because they don't look nearly as good as if the font family
has a supported bold or italic font.

Convert to Point Text and to Paragraph Text

The Convert to Point Text and Convert to Paragraph Text
options enable you to toggle the text between the point type
and paragraph type styles. This can be useful if you want to
add a bounding box to a point type text layer or if you want to
remove the restrictions of the bounding box from a paragraph
type text layer.

Warp Text

The Warp Text option enables you to apply a warp effect to
the selected text. A dialog box similar to the one in Figure
18.10 appears, where you can apply one of a number of
warps, such as arcs, shells, and waves.

Figure 18.10

The Warp Text option enables you to apply several warping
effects to text. You can control the amount of warp, direction,
and distribution of the distortion that is applied.
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The Warp Text dialog box enables you to set the following
options:

• Style. This drop-down menu enables you to select from one
of the available warping options. The options are arranged in
groups for arc, shell, wave, and radial distortions.

• Horizontal. This option applies the warp in a horizontal
fashion from top to bottom.

• Vertical. This option applies the warp in a vertical fashion
from left to right.

• Bend. This slider specifies the percentage of bend from
−100 percent to +100 percent. The amount of bend
determines the extent of the distortion applied to the text.

• Horizontal Distortion. This slider defines how the warp is
distributed horizontally across the text. Using negative
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horizontal distortion has the effect of increasing the height of
the text on the left side, making the text look as though it is
getting farther away from right to left. Using positive
horizontal distortion has the effect of increasing the height of
the text on the right side and decreasing its height on the left
side, making the text look as though it is getting farther away
from left to right.

• Vertical Distortion. This slider defines how the warp is
distributed vertically across the text. Using negative vertical
distortion increases the width of the top of the text while
decreasing the width of the bottom, making the text look as
though it is tipping forward. Using positive vertical distortion
decreases the width of the top of the text while increasing the
width of the bottom, making the text look as though it is
tipping backward.

Using the available options in the Warp Text dialog box, you
can create an amazing number of warping effects. Figure
18.11 shows a few of the different effects that warping can
have on the text.

Figure 18.11

Using different combinations of the settings in the Warp Text
dialog box results in an infinite number of warping effects on
the text.
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Layer Style

One of the great features of applying text as a layer is that you
can apply layer styles to create some great effects that
completely change its appearance. Because the effect is
applied as a layer style to a vector text layer, you can still edit
the text as you normally would and the layer style is applied
to the edited text.

When you select the Layer Style option, the Layer Style
dialog box appears. You can then make the layer style
adjustments and apply them to the vector text layer. After you
have applied the layer style, the applied effects are added to
the vector text layer in the Layers panel, where you can edit
them. For example, Figure 18.12 shows the Bevel & Emboss
Inner Shadow, Inner Glow, and Gradient Overlay effects
being applied to a vector text layer.

Figure 18.12
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Because vector text is applied as a layer, you can use the
Layer Style option to apply a variety of layer styles to your
text.

You can do many different things when applying
layer styles to vector text layers. For more information about
layer styles and how to apply them, see Chapter 10.

Using the Character panel

Most text settings can be applied from the Character panel.
The Character panel is useful for viewing attributes that are
applied to selected text, and it enables you to quickly change
text attributes.
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Shown in Figure 18.13, the Character panel provides most of
the options found in the Type tool Options bar, as well as
several additional options that help you define the behavior
and appearance of the text.

Figure 18.13

The Character panel provides most of the necessary options to
format text.
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From the Character panel, you can set the following attributes
of the text:

• Font family. This drop-down menu enables you to select
the font family. You can use the Type preferences settings
discussed earlier in this chapter to have Photoshop display a
sample of the font next to the font name; this makes it easier
for you to select an appropriate font because you can see how
it looks in the sample.

• Font style. This drop-down menu enables you to select a
typeface font style such as italic, bold, hard, light, strong, and
so on. The available options depend on the fonts contained in
the typeface that you have selected.

• Font size. This drop-down menu enables you to set the size
of the font used when displaying the text. You can select the
font size from the drop-down menu, type the size into the text
field, or hover the mouse over the Font Size option until the
icon changes to a bidirectional arrow, which you then drag
left or right to decrease or increase the value. By default, font
size is specified in point units; however, you can change that
by adjusting the Type setting in the Units and Rulers settings
of the General Preferences panel in Photoshop.

Tip

The actual text size varies between different fonts. You
should first select the font family and font style before
deciding on a font size.
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• Leading. This drop-down menu specifies the amount of
space between the baselines of two lines when there are
multiple lines in the text. You can set this option to the
default of Auto, which is 120 percent of the font size, or you
can specify a specific value to provide more or less space
between the lines. Because the leading measures distance
between the baselines, if the leading is smaller than the font
size, the two lines run into each other.

If you have lines of text selected when you adjust the leading
value, only those lines are changed. If you do not have any
text selected when adjusting the leading, all the lines in the
text are adjusted. Figure 18.14 shows an example of different
leading values.

Figure 18.14

Adjusting the Leading setting alters the amount of space
between the baselines of two lines.

• Kerning. This drop-down menu specifies the amount of
space between the individual characters in a word. The
purpose of kerning is to solve the spacing problem that occurs
when two letters — for example, WA — look awkward when
positioned next to each other, as shown in Figure 18.15. The
Kerning option enables you to set the kerning using one of
three methods:
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• Metrics kerning. This option uses metric information
directly from the font to apply kerning to letters that require it
when they are placed next to each other. This is by far the
best option to use because the metric information is put into
the font by the designer and usually is the most accurate. To
apply metric kerning to text, select the vector text layer and
then select Metrics from the Kerning drop-down menu.

• Optical kerning. This option uses a Photoshop algorithm
that scans the text, calculates the space between letters, and
adjusts the spacing accordingly. This is the next-best
algorithm to use because Photoshop is usually accurate at
gauging the amount of kerning necessary. To apply optical
kerning to a word, select the word and then select Optical
from the Kerning drop-down menu. To apply optical kerning
to the entire vector text layer, select the layer and then select
Optical from the Kerning drop-down menu.

• Manual. If neither of these methods works for you, you can
always manually adjust the kerning. To set the kerning value
manually, position the cursor between the two letters in Text
Edit mode and set a specific value in the Kerning field. You
can also use the Alt/Option+left or Alt/Option+right arrow
keys on the keyboard to adjust the kerning between the two
letters in increments of 20.

Figure 18.15

Adjusting the kerning in words makes letter sequences that
look awkward, such as WA, appear more aesthetically
pleasing.
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• Tracking. This drop-down menu specifies the amount of
space between the leading edge of one character and the
leading edge of the next character. Tracking is measured in
positive and negative values. Adjusting the tracking
negatively, called tight tracking, brings letters close together.
Adjusting the tracking positively, called loose tracking,
spreads the letters out. To adjust the amount of tracking in a
vector text layer, select the vector text layer and set the value
in the Tracking drop-down menu. To adjust the tracking of a
specific word or set of words, select the text you want to
adjust the tracking for and then adjust the value in the
Tracking drop-down menu.

Note

Both the Tracking and Kerning options are measured in
1/1000 em, where em refers to the width of the lowercase m
in the current font and font size. The reason em units are
used is that if you change the font or font size later,
Photoshop needs to adjust the tracking and kerning
accordingly.

• Vertical scale. This field adjusts the vertical height of
characters in relation to the current font size setting. The
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scaling is based on percentages, so 100 percent uses the
normal font height, and 200 percent uses double the normal
font height. The width is not changed by this setting. You can
use the Vertical scale setting to adjust the entire vector text
layer or just the selected text.

• Horizontal scale. This field adjusts the horizontal width of
characters in relation to the current font size setting. The
scaling is based on percentages, so 100 percent uses the
normal font width, and 200 percent uses double the normal
font width. The height is not changed by this setting. You can
use the Horizontal scale setting to adjust the entire vector text
layer or just the selected text.

• Baseline shift. This field specifies the position of the
bottom of the selected text in relation to the baseline. This
option is measured in the same units that font size is
measured in, which is points by default. You can use both
positive and negative values. Positive values raise the
characters above the baseline, while negative values lower the
characters below the baseline. The baseline shift gives you
much more control than simply applying a subscript or
superscript format to the text.

• Color. This field, when clicked, launches the Select Text
Color dialog box, where you can set the color used to fill in
the text. You can use this setting to adjust the color for either
the entire vector text layer by selecting the vector text layer in
the Layers panel, or just the selected text.

• Text format. These formatting options enable you to apply
the standard text style options. You can apply them to the
selected text while you are in Text Edit mode, or to the entire
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vector text layer if you have selected only the vector text layer
in the Layers panel. The choices are Faux bold, Faux italics,
All caps, Small caps, Superscript, Subscript, Underline, and
Strikethrough.

• Language. This drop-down menu specifies the language
option to use for the text when applying hyphenation, spell
checking, and other language-specific text options.

• Anti-aliasing. This drop-down menu enables you to set the
anti-aliasing method that Photoshop uses to render the edges
of the font on the screen. Anti-aliasing tries to smooth the
square-edge effect by filling in the sharp edges and blending
the text with the background. The more anti-aliasing you
apply, the smoother the transition, although being too
aggressive with anti-aliasing can produce artifacts around the
edges of the text. You can select the following anti-aliasing
options:

• None. This option does not apply anti-aliasing to the text.

• Sharp. This option makes the text appear sharpest.

• Crisp. This option makes the text appear somewhat sharp.

• Strong. This option makes the text appear heavier.

• Smooth. This option adds the most smoothing around the
edges.

Tip
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Too much anti-aliasing can result in some color artifacts
around the edges of the text and may give you inconsistent
results when producing low-resolution images such as those
used on the web. To reduce the inconsistency, deselect the
Fractional Width option in the Character panel drop-down
menu.

The Character panel drop-down menu enables you to set the
following additional options:

• Change Text Orientation. This option enables you to
toggle the text between vertical and horizontal orientation. It
applies to all the text in the vector text layer.

• OpenType. This submenu enables you to toggle on and off
the OpenType features that are available for the selected font.
You can use this setting to adjust the features for either an
entire vector text layer by selecting the vector text layer in the
Layers panel, or just selected text. Figure 18.16 shows some
examples of the changes in text when you apply some of the
OpenType features. The following is a list of the features that
Photoshop supports:

• Standard Ligatures. These are typographic replacements
for certain pairs of characters, such as fi, fl, ff, ffi, and ffl.

• Contextual Alternates. These are alternative characters that
are included in some typefaces to provide better joining
behavior.
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• Discretionary Ligatures. These are typographic
replacement characters for additional character pairs, such as
ct, st, and ft.

• Swash. This option substitutes swash glyphs for certain
characters. Swash glyphs are stylized letterforms with
extended strokes or exaggerated flourishes.

• Oldstyle. This option replaces regular numerals with shorter
ones. Some old-style numerals are placed lower than others
on the type baseline.

• Stylistic Alternates. This option replaces certain characters
with stylized forms for a more pleasing aesthetic effect.

• Titling Alternates. This option formats characters, typically
in all capitals, for use in large type settings, such as titles.

• Ornaments. This option adds a personal signature to the
type family. These special characters can be used as title page
decoration, paragraph markers, dividers for blocks of text, or
repeated bands and borders.

• Ordinals. This option automatically formats ordinal
numbers such as 1st and 2nd with superscript characters.

• Fractions. This option automatically converts a fraction
separated by a slash to a shilling fraction (a fraction using the
“/” character).

Figure 18.16
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Applying the OpenType options can add a different look and
feel to the text in your image.

• Fractional Widths. This option enables the text to be clear
and readable. When you select Fractional Widths, the tracking
applied to the text can use values that do not exactly conform
to the pixel width on the screen. You should leave this option
enabled most of the time. The only time that you may need to
disable it is when you are using very small fonts in images
that will appear on a computer screen — for example, web
graphics.

• System Layout. This option turns off Fractional Widths and
sets Anti-aliasing to None. It is typically used only when you
are preparing images for a small computer screen — for
example, a cell phone or PDA (personal digital assistant).

• No Break. This option prevents the selected words from
being hyphenated.

• Reset Character. This option resets the selected text to the
Photoshop defaults. This is useful if you end up making so
many changes to the text that you can't figure out why it
doesn't look right.

Applying Paragraph panel settings
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When you need to change how text flows within a paragraph
or on a line, you typically use the Paragraph panel. Many of
the settings that you apply to text are found in the Paragraph
panel.

Shown in Figure 18.17, the Paragraph panel provides the
same alignment options found in the Type tool Options bar,
along with several additional options that help you define the
layout of the paragraphs.

From the Paragraph panel, you can set the following attributes
of the text:

• Align left. This option aligns the text to the left margin, with
no justification.

• Align center. This option aligns the text to the center, with
no justification.

• Align right. This option aligns the text to the right margin,
with no justification.

• Justify left. This option aligns the last line to the left
margin, with justification in the rest of the paragraph.

• Justify center. This option aligns the last line to the center,
with justification in the rest of the paragraph.

• Justify right. This option aligns the last line to the right
margin, with justification in the rest of the paragraph.

• Justify all. This option fully justifies the paragraph,
including the last line.
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• Indent first line. This option specifies the amount to indent
the first line of each paragraph.

• Indent left margin. This option specifies the amount to
indent the paragraph relative to the left margin. Only the
selected paragraph is affected by this setting.

• Indent right margin. This option specifies the amount to
indent the paragraph relative to the right margin. Only the
selected paragraph is affected by this setting.

• Add space before paragraph. This option specifies the
amount of space to add before the paragraph. This setting is in
addition to the leading that you can specify in the Character
panel.

• Add space after paragraph. This option specifies the
amount of space to add after the paragraph. This setting is in
addition to the leading that you can specify in the Character
panel.

• Hyphenate. This option tries to hyphenate words that fall
beyond the right edge of the bounding box.

Figure 18.17

The Paragraph panel provides most of the necessary options
to format paragraphs.
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The Paragraph panel drop-down menu enables you to set the
following additional options:

• Roman Hanging Punctuation. When you select this
option, punctuation such as single quotes, double quotes,
apostrophes, commas, periods, hyphens, em dashes, colons,
and semicolons appear outside of the margin. This enables
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justified text to flow evenly down the right margin with the
punctuation hanging over the edge.

• Justification. When you select this option, the Justification
dialog box appears, as shown in Figure 18.18, where you can
control how Photoshop applies justification to the paragraph.
From this dialog box, you can set the ranges that Photoshop
uses for the word, letter, and glyph, and the amount of leading
to automatically apply to the paragraph when performing
justification.

Figure 18.18

The Justification dialog box enables you to customize how
Photoshop justifies text in the paragraph.

• Hyphenation. When you select this option, the Hyphenation
dialog box appears, as shown in Figure 18.19, where you can
control how Photoshop hyphenates words in the paragraph.
From this dialog box, you can set the minimum word size, the
minimum number of characters required on both sides of the
hyphen, the maximum hyphen limit, and whether to
hyphenate capitalized words.

Figure 18.19
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The Hyphenation dialog box enables you to customize how
Photoshop hyphenates words in the paragraph.

• Single-line Composer. When you select this option (the
default for paragraphs), Photoshop composes type one line at
a time, which is useful if you want to manually control how
lines break. The Single-line Composer option uses the
following rules: longer lines are favored over shorter ones;
compressed or expanded word spacing is preferred in justified
text; hyphenation is preferred in non-justified text;
compression is better than expansion.

• Every-line Composer. When you select this option,
Photoshop considers a network of line break points for a
range of lines, enabling it to optimize earlier lines in a
paragraph in order to reduce poor line breaks later. The
Every-line Composer option uses the following rules: lines
falling closer to the right are favored and given a lower
penalty for left-, right-, or center-aligned text; highest priority
is given to the evenness of letter and word spacing for
justified text; hyphenation is avoided when possible.

• Reset Paragraph. When you select this option, Photoshop
resets the paragraph options to the default values. This is
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useful if you make too many changes and simply want to start
over.

Using the Character and Paragraph Styles panels

The Character and Paragraph Styles panels available in the
Window menu of Photoshop enable you to create character
and paragraph presets that you can save, load, and quickly
select during your editing workflow. Using presets enables
you to organize text formatting and quickly format text.

Note

The Character and Paragraph Styles presets apply to the
selected text in a text box when in Text Edit mode, or all
text in the box when not in Text Edit mode.

Creating and managing character styles

The Character Styles panel enables you to create and manage
the character style presets using the following options from
the buttons on the bottom of the panel, and the panel menu:

• Clear override. When you select this option, any
adjustments you made to the text using the Type tool options
or the Character panel revert to the values defined for the
preset.

• Redefine character style. When you select this option, any
adjustments you made to the text using the Type tool options
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or the Type panel are applied to the preset, and the preset is
saved.

• New character style. When you select this option,
Photoshop creates a new character style preset.

• Delete character style. When you select this option,
Photoshop deletes the currently selected character style
preset.

• Style options. When you select this option, a dialog box
appears, as shown in Figure 18.20, where you can define the
values used in the preset that are applied to the text when you
select the character style. The Character Style Options dialog
box contains the following three panels that enable you to
define the character settings discussed earlier in this chapter:

• Basic Character Formats. This panel specifies the style
name, font family, style, size, color, and other basic text
features.

• Advanced Character Formats. This panel specifies the
vertical and horizontal scale, as well as the baseline shift and
language settings.

• OpenType Features. This panel allows you to enable or
disable OpenType features such as fractions, ligatures, and
ordinals.

Figure 18.20

1246



The Character Styles panel and Character Style Options
dialog box enable you to create character style presets that
improve your workflow when you add text to images.

Creating and managing paragraph styles

The Paragraph Styles panel enables you to create and manage
the paragraph style presets using the following options from
the buttons on the bottom of the panel, and the panel menu:

• Clear override. When you select this option, if you make
any adjustments to the paragraph using the Paragraph tool
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options or the Paragraph panel, those changes revert to the
values defined for the preset.

• Redefine paragraph style. When you select this option,
any adjustments you make to the paragraph using the
Paragraph panel are applied to the preset, and the preset is
saved.

• New paragraph style. When you select this option,
Photoshop creates a new paragraph style preset.

• Delete paragraph style. When you select this option,
Photoshop deletes the currently selected paragraph style
preset.

• Style Options. When you select this option, a dialog box
appears, where you can define the values used in the preset
that are applied to the paragraph when you select the
paragraph style, as shown in Figure 18.21. The Paragraph
Style Options dialog box contains the same three panels as
described in the previous section, as well as the following
four panels that enable you to define the paragraph settings
discussed earlier in this chapter:

Figure 18.21

The Paragraph Styles panel and Paragraph Style Options
dialog box enable you to create paragraph style presets.
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• Indents and Spacing. This panel specifies the paragraph
alignment as well as the left and right indents.

• Composition. This panel specifies the composer, and allows
you to enable or disable roman hanging punctuation.

• Justification. This panel specifies the word spacing, letter
spacing, glyph scaling, and auto leading percentages.

• Hyphenation. This panel allows you to enable or disable
auto-hyphenation in the paragraph and configure the settings
used to define where hyphens occur.
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Adding default type styles to documents

As you work with text more frequently, you will find that you
have default settings that you want to begin with on every
document. Photoshop enables you to save the current settings
as the defaults that will be used each time you create a new
document. That way, you do not have to remember to apply a
preset style after creating the new document.

To save the current settings as the default type styles, select
Type⇒Save Default Type Styles from the main menu. The
paragraph and character styles are saved and automatically
applied to each new document that you create.

You can also apply the default styles to existing documents
after you open them in Photoshop by selecting Type⇒Load
Default Type Styles from the main menu. The default type
styles are applied to the current document.

Applying Text to Images

Text can be applied to images in a variety of ways. You can
add text using a path to specifically control the flow. You can
create your own textual effects using the vector tools, which
enables you to create some spectacular textual elements. You
can also add text to a specific area of an image by
constraining it using a vector shape. The following sections
take you through some examples that help illustrate some of
the techniques that you can use to apply text as visual
elements to images.

Adding text on a path

1250



A great feature of Photoshop is the ability to attach text
directly to a vector path. The text flows along the line
segments of the path. When you attach text to a path, two new
anchors are added to the path to support the text: the begin
text anchor and the end text anchor. The begin text anchor
controls where the text begins to flow on the path. The end
text anchor controls where the text stops flowing on the path,
similar to the edge of a bounding box.

The text anchors provide some useful features. For example,
they are controlled by the Direct Selection tool just like other
anchors. You can reposition both begin and end text anchors
as needed on the path. If text flows past the end anchor, the
end anchor displays a plus sign to indicate that there is
additional text. You can flow text in either direction on the
path by dragging the begin anchor across to the other side of
the path line.

Applying text to a path

In this example, we added text to an image by tying it to a
curved path. Using this technique opens a variety of
possibilities when adding text to images. Use the following
steps to create a path and apply text to it:

1. Press the P hotkey to select the Pen tool from the
Toolbox.

2. Use the Pen tool to create a path, as shown in Figure
18.22.

3. Press the T hotkey to select the Horizontal Type tool
from the Toolbox.
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4. Use the Type tool to click the path you created in Step
2.

This adds a begin text anchor to the path, and Photoshop goes
into Text Edit mode with the cursor attached to the path.

5. Type the text you want to apply to the line.

The text flows with the path, as shown in Figure 18.22.
Notice the circle at the end of the path. That is the end anchor
for the text. Also notice that the text cursor moves as you type
in the text.

6. Press Ctrl+Enter/ +Enter to commit the text changes.

Figure 18.22

Using the Type tool, you can click a path and add text that is
bound to the flow of the line segments.

Editing text on a path

In this next example, we used the text applied in the previous
example, but we moved the starting point to illustrate some of
the features that are available when working with text on a
path. Follow these steps:
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1. Select the Direct Selection tool from the Toolbox.

2. Hover the Direct Selection tool over the first character
in the text until the cursor changes to an I-beam with an
arrow pointing to the right.

This is the begin text anchor.

3. Drag the text to the right.

Notice that the text moves with the mouse, as shown in Figure
18.23. You can position the text to begin at any location on
the path. Notice that the circle at the end of the line now
contains a plus sign, indicating that there is additional text
that is not visible.

4. Drag the mouse down across the path line to move the
text to the bottom of the line, as shown in Figure 18.23.

Dragging the mouse below the line forces the text to the
bottom side of the path. Notice that the begin text anchor is
now at the end of the path and the end text anchor is at the
beginning.

Figure 18.23

Dragging the begin text cursor downward across the line flips
the text to the other side.
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5. Hover the mouse over the line until the cursor changes
back to the open arrow, and click the line to reveal the
normal path anchor points.

6. Use the Direct Selection tool to adjust the position of the
anchors as well as the direction points to adjust the path.

Notice that the text still flows with the path, as shown in
Figure 18.23.

7. Press the T hotkey to select the Type tool from the
Toolbox.

8. Click the text with the Type tool.
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Photoshop enters Text Edit mode.

9. Add more text.

Notice that you can edit the text just as you normally do.

Constraining text using a vector shape

A great way to add a textual element to an image is to have
the text flow inside an object containing the image. This
enables the text to become a part of the image rather than just
sitting on top of it.

In this example, we created a vector shape from a sunset in
the image and then used that vector shape to constrain the text
to flow within the clouds. Follow these steps:

1. Open the image in Photoshop.

2. Use the Quick Selection tool to select an object in the
image.

In this case, we selected the silhouette.

3. Right-click the selection, and select Make Work Path
from the popup menu. Set the tolerance to the necessary
level.

In this case, we kept the tolerance at 2.0. A new path was
added to the image, as shown in Figure 18.24.

4. Double-click the path in the Path panel and give the
path a name.
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5. Press T to select the Type tool from the Toolbox.

6. Use the Type tool to pick a point inside the newly
created shape.

As you move the cursor into the newly created shape, the
I-beam cursor displays a circle around it, indicating that it
will use the shape as a bounding box. A new vector text layer
is added to the Layers panel, and another path to support the
bounding box for the vector text layer is added to the Paths
panel, as shown in Figure 18.24.

7. Add the text to the image.

The text flows inside the newly created shape, as shown in
Figure 18.24, and you can edit it as you normally would.

Figure 18.24

Using custom shapes, you can constrain text to flow within
the boundaries of an object in an image.
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For more information about creating vector
shapes, see Chapter 17.

Note

In case you are wondering, the text placed inside the image
is Lorem Ipsum, which is just dummy text that is frequently
used by graphic designers as filler text when demonstrating
their work. Using the dummy text keeps viewers from being
distracted by the content of the text and not focusing on the
overall design elements.

Adding text in a Smart Object

Working with vector layers can be a big problem when you're
adding text to images. Several layer options are not available
for vector layers, including vector text layers. The solution to
this problem is to convert the vector text layer to a Smart
Layer. Because the content of a Smart Object is rasterized
before applying it to the image, you can use all the raster
editing functionality associated with layers.

Tip

Remember that the content of the Smart Object is rasterized
when applied to the image. If you create your text larger
than it is used in the actual document, Photoshop doesn't
need to increase the size of the rasterized text, which
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reduces the amount of pixelation that occurs. There is still
pixelation, but it is minimized.

In this example, we converted a text layer to a Smart Object
so we could use the Warp effect to apply the text to a surface
in the image. Follow these steps:

1. Open the image in Photoshop.

2. Add text to the image, as shown in Figure 18.25.

Notice that the text sits flat on the surface of the image and
really sticks out. You are about to change that.

3. Right-click the vector text layer in the Layers panel,
and select Convert to Smart Object from the popup menu.

This converts the vector text layer to a Smart Object layer.

4. Select the new Smart Object layer in the Layers panel if
it is not already selected.

5. Press Ctrl+T/ +T to activate the Free Transform tool.

6. Use the Free Transform tool to position the text, now
encased in a Smart Object layer, on the hood of the Jeep.

7. Ctrl-drag the corner handles of the Free Transform tool
to match the general shape of the hood.

8. Right-click the text and select Warp from the popup
menu to open the Warp tool.
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Then use the Warp tool to warp the text to the surface of the
Jeep, as shown in Figure 18.26.

Figure 18.25

The text in the image appears flat and intrusive to the
photograph.

Figure 18.26
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Warping the Smart Object layer allows the text to appear as
though it is part of the Jeep hood.

9. Press Ctrl+Enter/ +Enter to accept the changes.

The results are shown in Figure 18.27. Notice that the text is
much less intrusive to the picture and almost appears as
though it was originally part of the image.

Figure 18.27

With the text warped, it is much less intrusive to the picture.
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10. Double-click the new Smart Object layer in the Layers
panel to open the document for the Smart Object.

Notice in Figure 18.28 that the Layers panel for the Smart
Object document contains the vector text layer, and you can
still edit it just as you would any other vector text layer.
Saving the document applies the changes to the original
image.

Figure 18.28

You can still edit the vector text layer by double-clicking the
Smart Object layer to load the Smart Object document.
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On the Web

You can find the project used in this example on the book's
website as Figure 18.28.psd. You can open the file in
Photoshop and play around with the Smart Object layer.

Applying text as a mask

You can use the Type Mask tools to create a selection that
looks exactly like text. The selection you create can be used
just like any other selection to create as many different effects
as you can think of.

There are two Type Mask tools: the Horizontal Type Mask
tool and the Vertical Type Mask tool. These tools work in
exactly the same way that the Type tools work: after you have
created text on your screen, you can change the font, resize it,
warp it, change the direction, or apply any one of the other
options that are available to you with the regular Text tool —
as long as it is selected. After you accept the type by clicking
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the check mark in the Options bar or choosing any other layer
or tool, the text becomes a selection and can be altered at that
point only by the selection tools and menus.

Here is an example of how it works. Create a selection mask
with the Type Mask tools by following these steps:

1. Click the Type Mask tool, which is nested with the
other Type tools in the Toolbox, or press T repeatedly
until the tool you want is activated.

2. Click your image (preferably on a second, duplicated
layer) in the area where you want to begin typing.

3. Type your text.

4. Highlight your text, and adjust the font, size, text warp,
and so on until you are satisfied with the results.

You can move the text by clicking outside of the selection
highlight and dragging, as shown in Figure 18.29.

Figure 18.29

As long as the text you type with the Type Mask tools is
selected, you can use the Character panel and Type tool
Options bar to edit it.
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5. Press Ctrl+Enter/ +Enter to accept the changes.

Your text transforms into a selection, as shown in Figure
18.30.

Figure 18.30

After you accept the text, it becomes a selection.
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From here you have several options: you can invert the
selection so that everything but the text is selected; you can
apply a fill or adjustment layer or a filter; or you can turn the
selection into a layer mask by clicking the Add Vector Mask
button in the Layers panel. In short, you can do anything to
this selection that you can do with any other selection you
make. Figure 18.31 shows the result of the selection after
clicking the Add Vector Mask button.

Figure 18.31

The selection created with your text can be edited just like
any other selection. In this case, we created a mask with it.
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You can create a clipping mask with text that
achieves the exact same results demonstrated in Figure 18.31.
We discuss masks in Chapter 10.

Creating Cool Text Effects

In this section you get a chance to create some cool textual
effects. Adding text effects involves applying styles, color
adjustments, transformations, and other changes to alter the
appearance of the text. Applying text effects offers the benefit
of not only increasing the visual appeal of your images, but
also using the actual text to emphasize a concept or make a
statement.

Text effects can include anything from a basic gradient fill to
hundreds of adjustments that include additional images,
multiple layers, styles, filters, warps, transforms — just about
everything we cover in this book. The following sections
provide basic examples of applying styles to text to get your
feet wet.
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Rock solid

In this example, we took a simple sandstone image, then
added a layer style to it and applied a text vector mask to
generate a stone effect. The steps to generate the image shown
in Figure 18.32 are listed below:

1. Open the sandstone image shown in the bottom layer in
Figure 18.32.

2. Select the layer and add a layer style.

3. Select Bevel & Emboss.

4. In the Structure section, set the style to Inner Bevel,
Technique to Smooth, Depth to 419 percent, Size to 18
pixels, and Soften to 0 pixels.

5. In the Shading section, set the Angle to 45 degrees,
Altitude to 48 degrees, Highlight Mode to Screen with an
Opacity of 50 percent, and Shadow Mode to Multiply with
an Opacity of 82 percent.

6. Enable Contour and Texture.

7. In the Texture pane, shown in Figure 18.32, select the
Black Marble pattern (included in the Rock Patterns
preset), set the Scale to 89 percent and the Depth to +79
percent, and select the Link with Layer option.

Click OK to change the sandstone to a more textured rock.
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8. Add a text vector mask to turn the rock background
into a rocky text effect, as shown in Figure 18.32.

Figure 18.32

Adding a Bevel & Emboss layer style to a basic sandstone
image creates a textured rock effect. Applying a text vector
mask to the layer creates a cool textual effect.
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On the Web

You can find the project used in this example on the book's
website as Figure 18.32.psd. You can open the file in
Photoshop and play around with different layer style settings
to create different rocky textures for the text.

Extreme solid

In this example, we took white text on a black background
and used a layer style and Liquify filter to turn it into molten
hotness. The steps to generate the image shown in Figure
18.33 are listed below:

1. Create a blank document that is 800x500 pixels.

2. Make the background black.

3. Add a text layer using a large font with a white color.

In this example, we used Segoe Marker at 400 points.

4. Select the layer and add a layer style.

5. Enable Inner Glow and set the Blend Mode to Linear
Dodge (Add), set the Opacity to 100 percent, and select a
hot yellow color. Then set the Element Size to 21 pixels.

6. Enable Satin and set the Blend Mode to Multiply, select
a deep red color, set Opacity to 50 percent, Angle to 19
degrees, Distance to 12 pixels, and Size to 21 pixels.
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7. Enable Color Overlay and select a warm orange color
for the middle tones.

8. Enable Outer Glow, set the Opacity to 90 percent, select
a hot red color, set the Spread to 21 percent, and the Size
to 13 pixels.

9. Click OK to apply the layer style, as shown in Figure
18.33.

10. Rasterize the text and layer style.

11. Use the Liquify filter on the rasterized layer to melt
the edges of the text to apply an even hotter look, as
shown in Figure 18.33.

Figure 18.33

Adding an Inner Glow, Satin, Color Overlay, and Outer Glow
layer style to a text shape layer gives the text some heat.
Applying some Liquify filter magic creates a stunning textual
effect.

1272



1273



On the Web

You can find the project used in this example on the book's
website as Figure 18.33.psd. Each major step is saved in its
own layer so you can play around with different layer style
settings, as well as use the Liquify filter to adjust the image
further.

Summary

This chapter discussed using the Type tools to add text to
images, the Character panel to format the text, and the
Paragraph panel to control the flow of paragraphs. We also
discussed some of the advanced features available in
Photoshop that enable you to make text a visual element as
well as just a textual element.

In this chapter, you learned these concepts:

• Applying Photoshop techniques to create stunning visual
effects from text

• Adding text in a bounding box

• Constraining text to fit inside a vector shape

• Applying layer styles to text

• Putting a vector text layer inside a Smart Object in order to
use raster tools such as the Warp tool
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• Applying text to a vector path, where the text flow follows
the path even if you edit the anchor points

• Using the Warp option to create some interesting textual
elements

• Using text as a mask to apply it as a visual element
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Part VI: Creating Artistic Effects

IN THIS PART

Chapter 19

Distorting Images

Chapter 20

Applying Filters

Chapter 21

Combining Images
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Chapter 19: Distorting Images

In This Chapter

Making transformations

Playing with Puppet Warp

Using Vanishing Point

Using wide-angle lens correction

Distorting images sounds so dramatic that at first, it's hard to
think of anything but special effects. On the contrary, most
image distortions are simple functions, such as resizing an
image or adjusting its perspective to make up for lens
distortions. Many of the distortions and transformations
available in Photoshop are helpful when creating image
composites. Using skew, warp, or vanishing point effects can
change the way you perceive an image and make it blend
better with other images.

This is especially true of layers that are not composed of
images. Text and other vector layers can be transformed and
distorted for the same reasons. You can use the Vanishing
Point feature to place text in perspective on any surface in an
image. You can also warp and distort shapes to give them the
appearance of motion or just to make them look
three-dimensional.

Using Transformations
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Transforming an image can involve anything from rotating it
or changing its size to making it completely unrecognizable
by warping or skewing the pixels until nothing is where it
belongs. Some of these transformations are basic fixes:
rotating an image that's been captured in portrait mode,
scaling a placed image so it fits with the original document, or
fixing perspective problems caused by camera mechanics.
Other transformations are all about creating artistic effects —
tugging and pulling objects and anatomy so they no longer
look like the original captured image.

Note

Most transformations can't be performed on a background
layer because it's locked. You must first double-click the
background layer to change it into a standard layer.

Understanding the importance of the reference point

When you choose any of the transformations, Photoshop
creates a bounding box around the image or selection. Notice
that in the center of most of the transformation bounding
boxes, you see a crosshair, as shown in Figure 19.1. This
crosshair is the reference point, and it indicates the area of
your image that is stable. When you rotate an image, it rotates
around the reference point. For example, if the reference point
is in the center of your image, it rotates in place. Placing the
reference point in the corner of the image causes the image to
rotate around that corner. The same is true of the Skew,
Distort, and Perspective transformations. If you want the
center of the image to be stationary while you perform these
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transformations, you need to center the reference point. If not,
you need to move the reference point.

You can move the reference point in two ways. One way is to
use the reference point location icon (as shown in Figure
19.1) and click any of the squares shown, moving the
reference point to that location. The other way is to simply
drag the reference point into any other position on your
image.

Figure 19.1

The reference point makes a difference in how
transformations affect your image.
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Scaling images

The Scale option simply changes the size of whatever you
have selected, whether it is a layer or an active selection. You
will probably find yourself scaling frequently. Whenever you
combine more than one file, you often need to scale one of
them so they are a good match. You can also scale elements
such as text or shape layers. To apply the Scale option,
choose Edit⇒Transform⇒Scale to create a bounding box
around the selected layer and then drag any one of the handles
in any direction to make the selection bigger or smaller, as
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shown in Figure 19.2. To scale proportionally, hold down the
Shift key while dragging one of the corner handles or click
the Maintain aspect ratio icon in the Options bar before you
drag. This constrains the height and width to the same
percentage. If you know what percentage you want your
selection to be, you can type a width and height percentage in
the appropriate boxes in the Options bar.

Figure 19.2

You can scale a selection using the handles on the bounding
box or by typing a percentage.
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Caution

If you have an active selection in your image before you
apply a transformation, only the selected area of your image
is transformed, instead of the entire image.

Rotating images
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You can use the Rotate option to straighten a photo, tilt a
photo in a collage, and angle text or other elements to create
the look you want. You probably don't want to use this option
to turn a photo that is lying on its side because it was taken by
turning your camera or scanning in the photo sideways. The
other Rotate options (180 degrees, 90 degrees CCW, 90
degrees CW) located farther down the Transform submenu
offer a much faster way to do this.

To rotate a selected layer, choose Edit⇒Transform⇒Rotate.
A bounding box appears around the image, and whenever you
hover over a handle, you see a double-headed arrow, as
shown in Figure 19.3. Click and drag your mouse to the left
or right to freely rotate the image. To constrain the rotation to
15-degree increments, hold down the Shift key while you
rotate. You can also type a specific number of degrees in the
Options bar to rotate the selection.

Figure 19.3

The Rotate transformation in action
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Skewing images

The Skew transformation enables you to move the corner
handles of the bounding box independently of one another to
pull or push the pixels in that corner closer toward or away
from the reference point. This transformation actually morphs
the pixels in the area that is being pushed or pulled by
merging them or doubling them so it looks as if the entire
image is still contained in the skewed shape.

Skewing text is more constrained. Rather than moving each
corner independently, the sides move together to create a
shearing effect, as shown in Figure 19.4. To skew a selection,
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choose Edit⇒Transform⇒Skew. This creates a bounding
box, and you can pull on the corners to transform them. You
can also type a degree of skew in the Options bar. This causes
your entire image to skew, moving two corners
simultaneously rather than one corner at a time.

Figure 19.4

Pull on the corners or type a value in the Options bar to skew
an object.
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Distorting images

Distorting an image works much like taking a printed
photograph and bending it this way and that to make it look
different. Distorting in Photoshop works better because you
can make distortions that are more dramatic without creating
any wrinkles. The Distort option can make your selection
look angled, bubbled, or squished. Choose
Edit⇒Transform⇒Distort to create a bounding box around
your selection. Use the handles to distort the selection freely,
as shown in Figure 19.5.

Figure 19.5

Using the Distort transformation can really change the look of
your object.
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Changing the perspective of images

The Perspective transformation widens either the top or the
base (or both) of your image to correct perspectives that may
have been warped by fish-eye lenses or simply by the focal
length of the lens. The need for a perspective fix is most
obvious in photos of tall buildings taken from the ground.
Because of the perspective created by the lens, the buildings
actually look as if they are leaning toward one another, as you
can see in Figure 19.6. Choose
Edit⇒Transform⇒Perspective to create a bounding box that
enables you to change the perspective of an image by using
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the bounding box corners and edges to widen or narrow the
edges of the photo.

Figure 19.6

Fixing the perspective can reduce or eliminate leaning objects
in an image.

Note

As you change the perspective of an image, the center of the
image becomes wider. After you have restored the correct
perspective, you can scale your image to be taller, taking out
the width distortion that the perspective fix introduced.

Using the Warp transformation

The Warp transformation is great for giving a
three-dimensional look to flat photos or objects. Because it
uses a grid to create multiple points that you can adjust, it
enables you to create more dynamic changes than the
transformation options that only provide you with a bounding
box.
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Selecting the Warp transformation creates a grid across your
selection that enables you to distort specific areas within that
selection. You can pull and adjust each conjunction point to
make changes that radiate from that point. Each corner of the
grid also has two control point handles that control the curve
of the grid and, therefore, the warp.

Choose Edit⇒Transform⇒Warp to create the grid around
your selection. Figure 19.7 shows how we changed an image
of a fish to look as if the fish were swimming through a
three-dimensional space, rather than the two dimensions
created by a flat screen. You can use any one of several preset
warps by choosing one from the drop-down list in the Options
bar shown in Figure 19.8.

Figure 19.7

Adding a three-dimensional look to this fish just took a little
tweaking with the Warp tool.

Figure 19.8

Using any one of these options creates a preset warp.
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Applying free transform

Using a few memorized hotkeys and a bit of ingenuity, you
can perform any one of the previous transformations with the
Free Transform option. The best thing about this option is that
it already has a hotkey assigned to it, so rather than choosing
Edit⇒Free Transform, you can simply press Ctrl+T/ +T to
open a transformation bounding box. You can use each of the
following transformation tools in this way:

• Scale. To scale your selection, just drag any of the handles
as if you were using the Scale transformation alone.
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• Rotate. To rotate your selection, hover just outside any of
the handles on the bounding box to display the curved,
double-headed arrow that indicates you can rotate the box.
Drag and rotate freely.

• Skew. To skew your selection, press and hold the
Ctrl+Shift/ +Shift keys while dragging the handles.

• Distort. To distort your selection, press and hold the Ctrl/
key while moving the handles. This enables you to distort
freely without regard to the reference point. To distort using
the reference point, press and hold the Alt/Option key.

• Perspective. To change the perspective, press and hold the
Ctrl+Shift/ +Shift or Ctrl+Alt/ +Option keys while
dragging the handles.

• Warp. To warp a selection from any of the other transform
tools, click the Toggle between Free Transform and Warp
Modes button shown in Figure 19.9. This toggles between the
standard bounding box and the grid you see when performing
a Warp transformation.

Using the Content-Aware Scale feature

The Content-Aware Scale feature enables you to make an
image larger or smaller without shrinking or distorting the
subject of the image. This is great for making photos smaller
without actually cropping out any content, or making photos
larger to expand a background to get a more dramatic effect
or to add features to the image.

Figure 19.9
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Click the Toggle between Free Transform and Warp Modes
button from any transformation Options bar to warp your
selection.

Content-Aware Scale can work automatically by letting
Photoshop guess what the main subject of the image is or by
locking any pixels that are skin tones. However, these
methods are hit-and-miss and leave you little control. The
best way to use Content-Aware Scale is to create an alpha
channel that protects the areas you want to stay constant.

Figure 19.10 is a photo of Brad in front of an Indian palace.
Using Content-Aware Scale, we can change the perspective
of the palace in the background. This is a great photo to use,
because you can see how far you can push the hard lines in
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the image before they become broken up or warped. Keep an
eye on the columns of the palace and the fence as you make
changes.

Figure 19.10

We can scale the palace and leave Brad intact.

On the Web

You can download Figure 19.10 from this book's website
and use it to experiment with the Content-Aware Scale
feature.
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We are going to show you four different ways to use the
Content-Aware Scale feature: first, without any protection at
all; second, protecting skin tones; third, protecting an alpha
channel and skin tones; and last, protecting just the alpha
channel. For this example, we created two layers, one with
the image and the second with a transparent background,
which was larger than the image so we could scale larger.

Try different methods of using the Content-Aware Scale
feature by following these steps:

1. Create a selection around the area you want to
preserve.

We created a selection around Brad. Note that it doesn't have
to be extremely precise, but a good outline is best.

2. In the Channels panel, click Save Selection as Channel
to create an alpha channel.

This channel protects Brad from getting squished.

3. Turn on the visibility of the image, and disable the
visibility of the alpha channel; then return to the Layers
panel.

4. Choose Edit⇒Content-Aware Scale to create a
bounding box around the image.

5. In the Options bar, make sure the Protect option is set
to None and the Protect Skin Tones button (the silhouette
of a man) is not highlighted.
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6. Squeeze or stretch the image, keeping an eye on Brad
and the straight lines of the palace.

You actually have quite a bit of latitude, especially side to
side. Eventually, as you squeeze the photo down, you lose
Brad's face. Figure 19.11 is slightly smaller than we could
make the picture and retain a realistic version of Brad. The
lines of the palace are starting to warp, as shown in the left
photo. This image is significantly smaller than the original, so
the Content-Aware Scale feature has worked very well.

7. Click the Protect Skin Tones button.

This shows you a real-time change, as shown in Figure 19.11
on the right. Brad's face is not as distorted and his arms look
right, but the rest of his body is hopelessly puckered and out
of shape, along with most of the surrounding palace. This isn't
the right option for this photo!

Figure 19.11

With no protection on the left, the Content-Aware Scale
feature provides quite a squeeze before collapsing Brad's face.
On the right, protecting the skin tones does nothing to protect
the white of Brad's shirt.
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8. Click the Protect drop-down menu and select Alpha 1.

The pixels protected by the alpha channel revert to their
original state. On the left of Figure 19.12, Brad looks great,
but the palace is sadly out of shape. It turns out that
Photoshop is interpreting the putty-colors of the palace as
skin tones. Maybe protecting the skin tones is not the best
option.

9. Click the Protect Skin Tones button to turn it off.

On the right of Figure 19.12, we see that protecting the alpha
channel and not the skin tones is the best option. By slightly
stretching this image, we get a satisfactory result.

Figure 19.12

Even though the subject looks great on the left, the palace is
puckered and misaligned. On the right, the subject is
protected, and the palace has very few lines that are out of
shape.
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Using the Puppet Warp tool

The Puppet Warp tool gives you a lot of control when it
comes to changing the way a previously flat, two-dimensional
image looks. This tool works by placing a mesh over the
selected area in your image, and giving you the ability to
warp and move individual areas, almost as if the image were a
piece of fabric. Using some pins to hold areas in place and
others to move your image, you can choose which areas to
move, how they'll move, and how far. Figure 19.13 shows a
boy on his own layer. Using Puppet Warp, you can move his
body freely, even moving his limbs independently.

Figure 19.13

The independent nature of the arms and legs of this boy
makes this photo ideal for playing with the Puppet Warp tool.
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Follow these steps to use the Puppet Warp tool on the boy:
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On the Web

You can find the PSD file of the boy saved as Figure 19.13
on this book's website.

1. Select the layer containing the cutout of the boy.

2. Choose Edit⇒Puppet Warp.

This changes the Options bar and places a grid over the boy,
as shown in Figure 19.14. You can change the density of the
mesh in the Options bar. Increasing the density gives you
control over more specific areas, and decreasing the density
enables you to move larger areas.

Figure 19.14

Puppet Warp places a moveable mesh over the selected layer.
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3. Set the expansion by typing an amount in the
Expansion field in the Options bar.

The expansion determines how many pixels outside the
selected object the mesh will extend. A higher expansion
number makes movements larger and less precise. The default
expansion of 2 pixels works well for this exercise.

4. Click different areas of the boy to place pins in different
locations.
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Every time you place a pin, that spot on the boy is locked
down and doesn't move uNL1ess you drag the pin. When you
do move a pin, it uses the closest pin as a pivot point to rotate
the selected area. For example, if you place just one pin on
the center of the boy and then move a second pin placed on
the boy's arm, the entire boy rotates around the pin placed on
his body. In order to move an arm by itself, you need at least
four pins: two on the body to hold it firm, one on the elbow of
the arm that you want to move, and one on the hand, as
shown in Figure 19.15.

Figure 19.15

Pin placement is an essential part of getting the adjustment
you want with the Puppet Warp tool.
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5. From the Options bar, click the Mode drop-down
arrow and select a mode that determines how the mesh
responds to movement by the pin.

Rigid keeps the distances in the mesh more stable, making it
harder to stretch the mesh and therefore the pixels. It is the
best choice for limbs or other rigid objects. Normal makes the
mesh loose, more like a fabric, as you move it, similar to
moving a rag puppet. Distort not oNL1y moves the pinned
area but also changes its perspective, making it larger or
smaller, depending on the direction you are moving it. You
want the boy's limbs to stay straight, so choose Rigid.

6. Place pins to anchor and move the limbs of the boy
however you like.

You can move him freely, even skewing his hips so that it
looks like he is dancing, as shown in Figure 19.16.

Tip

You can select and move more than one pin by pressing and
holding the Shift key as you click each pin.

7. Change the rotation of the mesh around the selected
pin.

You can do this from the Options bar by choosing Auto or
Fixed from the Rotate drop-down menu. Auto rotates the
selection automatically based on how you move the pin.
Fixed enables you to set your own rotation. You can type a
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rotation degree into the appropriate box, or you can hold
down the Alt/Option key while you hover to the outside of the
pin until a Rotation tool appears, as shown in Figure 19.16,
and enables you to rotate the mesh around your selected pin.

Figure 19.16

Using the Auto Rotate option doesn't always give you the best
results. You can hold down the Alt/Option key to freely rotate
the mesh and take out any kinks.
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8. (Optional) If you've warped too far and aren't sure how
to get back to where you started, you can delete your pins.

You can delete any of the pins you placed by holding down
the Alt/Option key and clicking directly on the pin (scissors
should appear) or by pressing the Delete button to delete any
selected pins. Removing a pin also removes all the effects that
are associated with that pin. If it held an area in place while
you moved another pin, that area moves as if the pin had
never been placed. If you used the pin to move the mesh, the
mesh returns to the starting point.

Playing with the photo of this boy as if he really were a
puppet is a fun way to learn the basics behind the Puppet
Warp tool, but although moving individual elements can be
entertaining, the Puppet Warp tool is more useful in making
adjustments and corrections in your everyday images. For
example, you could use it to correct crooked lines created by
using the Content-Aware Scale feature or to tweak the
perspective of images that have more complicated lens
aberrations than you can fix by just widening the top.

Having Fun with the Liquify Filter

The Liquify Filter uses several tools to pinch and warp the
pixels of your image in many different ways. You can use it
for creating textures, giving tummy tucks, or creating realistic
special effects. The Liquify filter is so versatile that it almost
qualifies as an application on its own. It's certainly more than
just a tool.

When you select the Liquify filter by choosing
Filter⇒Liquify, your image opens inside the Liquify utility
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workspace, as shown in Figure 19.17. Right away, you see
how much you can do here. The Liquify utility works in a
similar way to Puppet Warp. A mesh overlay appears over
your image, creating a grid that you can pull and warp to
change your image as if it were made of fabric. Each tool uses
the mesh in a different way to create a different effect. The
Reconstruct tools are also based on the mesh.

Figure 19.17

The Liquify utility in Photoshop has several tools and options.

Identifying the Liquify tools
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The Liquify tools are stacked neatly in their own Toolbox on
the left side of the Liquify workspace. Some tools will be
familiar to you, such as the Hand tool and the Zoom tool.
Other tools are unique to the Liquify utility.

Note

While you are in the Liquify workspace, you can access
each of these tools by pressing a hotkey. Hover over each
tool to see its name and hotkey.

You can find the following Liquify tools in the Toolbox:

• Forward Warp. This tool drags the pixels starting at
the center of your cursor forward, following the direction you
drag. The effect looks just like the wake of a boat. This is a
basic way to push pixels around and create very specific
results, as shown in Figure 19.18.

• Reconstruct. This tool offers a simple way to restore
specific areas of your image. Brush over areas that you've
already distorted, and they are restored to their original pixel
composition.

Tip
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Holding down the Alt/Option key while either the Forward
Warp tool or the Reconstruct tool is activated temporarily
changes it to the other tool.

• Twirl Clockwise. This tool is like a curling iron for
your pixels. To create twirls, press and hold your mouse
button to twirl them around your cursor. Be sure to hold your
mouse in one spot to do this; the longer you hold, the tighter
the twirl becomes. If you want the twirl to go
counter-clockwise, press and hold the Alt/Option key while
you twirl.

• Pucker. This tool is like having a miniature black
hole in the center of your cursor; the longer you press and
hold your mouse button, the more pixels are sucked into the
center of your cursor. It creates a pinched or puckered look,
great for hips and thighs.

• Bloat. This tool has the opposite effect of the Pucker
tool, pushing pixels out from the center of your cursor. This
makes it a great tool for lips and cheeks. Pressing and holding
the Alt/Option key with the Pucker and Bloat tools changes
one tool into the other.

• Push Left. This is another great tool for getting rid of
bulges. Dragging this tool upward literally pushes the pixels
the width of the brush to the left, blending the pixels to the
right into the space left behind. This has a dramatic effect on
hard lines. Despite its name, the tool is not limited in its
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direction: you can push pixels right by dragging downward,
push them up by dragging to the right, and push them down
by dragging left. In reality, the pixels are always pushed left
of the drag direction. Pressing and holding the Alt/Option key
reverses any one of these effects.

Figure 19.18

The effects of the Liquify tools on a subject
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• Freeze Mask. This tool enables you to freeze areas
of a preview image, thereby protecting those areas from being
changed. You can mask areas before or after you've used an
effect on them without the Freeze Mask tool changing the
effect; it just protects those areas from further changes. Click
the Freeze Mask tool, and use the brush to paint over areas
you want protected.

• Thaw Mask. This tool thaws frozen areas of a
preview image, thereby enabling you to make changes to the
previously frozen areas.

Looking at Tool Options

The Tool Options enable you to modify the behavior of the
brush used to apply the Liquify effects. They are basic brush
settings and should be familiar to you if you've used
Photoshop:

• Brush Size. This option changes the size of your brush and,
therefore, the size of the effect that you are applying. The
brush used to twirl curls in Figure 19.18 was much smaller
than the brush used to make the broad push left strokes that
changed the boy's mouth.

• Brush Density. This option sets the amount of distortion
that takes place the farther the pixels are from the cursor. If
you set your brush to a density of 100, the effects are the
same at the edges of the cursor as they are in the center.
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• Brush Pressure. This option determines how fast the
distortions are applied. If you want to apply settings slowly
and carefully, lower the brush pressure.

• Brush Rate. This option works with the tools that you apply
over time as you hold the mouse in place with the button
pressed, such as the Twirl and Turbulence tools. You can
specify the speed at which these effects are applied in this
way.

Saving a mesh

The mesh is a grid placed over the pixels of the photo in the
Liquify filter. As you use the Liquify filter, the mesh changes
and the correlating pixels change as well. Saving a mesh
enables you to re-create your Liquify settings, giving you the
option to change those settings at any time or to save multiple
Liquify transformations for the same image.

To save your current Liquify status, click Save Mesh at the
top of the options panel. You can browse and save the
document independently of the image, just as if you were
saving a new document in Photoshop. Make sure you choose
a location where you can easily find the mesh file later. To
load a saved mesh, click the Load Mesh button and browse to
the location of the mesh file. When you click the file, the
Liquify utility loads the mesh and immediately applies it to
the current image, replacing the mesh that was previously
there.

New Feature
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Photoshop CC now saves a compressed mesh as a Smart
Object layer within your document when you close Liquify.
This makes future edits to the mesh possible.

Restoring your image with Reconstruct and Restore All

When you are having fun with Liquify, it's easy to go
overboard. The Reconstruct and Restore All buttons (refer to
Figure 19.17) enable you to restore your image to its original
state or restore the image partially, applying the filters only a
fraction of the amount they were applied originally.

When you click the Reconstruct button, a popup menu
appears with a slider that lets you set the percentage to
reconstruct your image. As you move the slider, you can
preview the changes to your image. At 100 percent, your
image displays all the liquify changes you have made to it. As
you move the slider to the left, the changes you have made to
your image are gradually reduced until you reach 0 percent,
where your image is completely restored. Set the slider to the
percentage you like and click OK.

Simply click the Restore All button to restore your image to
the version that you opened. The Reconstruct Options work
by using the mesh, and the results you get are affected by any
Freeze Masks you place over your image.

Modifying the Mask Options selections

The Mask Options section in the Liquify workspace changes
the way masks interact with one another by enabling you to
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add to them, subtract from them, or intersect them. Using the
drop-down list that appears when you click any mask option,
you can create or modify an existing Freeze Mask with any
selections, transparencies, layer masks, or alpha channels
already present in your image.

Note

In order to use a selection from any of the Mask Options
menus, you need to create a selection in the original
document, save the selection using the Select menu, and
then deselect the image before opening it in Liquify. If your
image contains an active selection when you open it in
Liquify, you can alter only the selected area.

The three buttons at the bottom of the Mask Options section
(refer to Figure 19.17) are straightforward:

• None. This removes any Freeze Mask placed over the
image.

• Mask All. This creates a mask that covers the entire image.

• Invert All. This changes masked areas into unmasked areas,
and vice versa.

Using the View Options

The View Options section lets you change the way you view
an image in the Liquify workspace. You can view helpful
tools such as the mesh and any masks you've placed. Viewing
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the mesh gives you an insider's look at what is happening to
your image as you use the Liquify tools.

Here are the View Options:

• Show Image. Toggle the visibility of the image on and off
with this option. If the mesh, mask, or backdrop is visible,
you see those elements, but if not, the document window is
white.

• Show Mesh. Toggle the visibility of the mesh overlay that
enables Liquify to work its magic. You can change the size of
the mesh to small, medium, or large, which affects the detail
of the Liquify effects. You can also change the color of the
mesh.

• Show Mask. Toggle the visibility of the mask on and off
with this option. You can also change the color of the mask.

• Show Backdrop. Toggle the visibility of other layers in
your image with this option. You can't change these layers in
the Liquify utility, but they may affect the way you want to
make changes to the selected layer. You have several
different viewing options that give you versatility in viewing
other layers.

Changing Perspective with Vanishing Point

When you talk about the vanishing point in an image, you are
referring to the fact that as objects get farther away from the
camera, they become smaller, eventually vanishing against
the horizon. The rate at which this happens affects the
perspective of the image. Because every image is different,
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the vanishing points are also different. Some images that
contain hard corners, such as photos of buildings, can have
more than one vanishing point.

Different perspectives and multiple vanishing points can
make it difficult to fix an image by cloning, as well as to
create composites that look realistic. This is because it isn't
always easy to get the perspective just right, even using the
Transformation tools.

The Vanishing Point filter enables you to match the
perspective of the target image when you clone or combine
images so the new elements look realistic. Compared to trying
to free-transform or tweak an element until the perspective is
just right, the Vanishing Point filter is easy to use.

Note

Vanishing Point changes the perspective of two-dimensional
images, which usually makes them look even more
two-dimensional because there will be missing elements,
such as compensating shadows on more than one side.
Vanishing Point is ideal for creating banners, posters, car
art, or other two-dimensional elements.

Figure 19.19 shows a photo with at least two vanishing
points: the rock surface is on one perspective plane, and the
boys are on a different perspective plane. You can use the
Vanishing Point filter to place another image in the correct
perspective on the face of the rock.

1315



Figure 19.19

You can use Vanishing Point to change the perspective of
elements in the image to match the perspective of the rock
plane.

Follow these steps to learn how to use the Vanishing Point
filter:

On the Web

Download Figure 19.19 from the book's website to follow
along with this exercise.
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1. Duplicate the layer you are going to open in Vanishing
Point.

The Vanishing Point filter makes changes directly to the
layer, so you want to keep your changes non-destructive to
the original layer.

2. With the duplicate layer selected, choose
Filter⇒Vanishing Point.

The Vanishing Point utility opens, with the Create Plane tool
automatically selected. Vanishing Point uses planes that you
draw to determine perspective.

3. Use the Create Plane tool to draw a four-sided plane
that exhibits the perspective you want to emulate.

In Figure 19.20, we drew a grid that matched the plane of the
rock face.

Figure 19.20

This grid follows the perspective of the rock face.
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4. Edit the plane if needed.
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After you draw the grid, the Edit Plane tool is automatically
selected. You can move the entire grid or change it by
selecting one of the handles. If the grid is blue, you've done a
great job — it's in perspective. If it's yellow or red, you need
to readjust it.

5. Draw a second plane.

Click the Create Plane tool, and draw a plane. In our example,
the second plane is in perspective with the children, as shown
in Figure 19.21.

Figure 19.21

Two different planes are involved in this image.
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6. Choose one of the following options:
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• Clone one plane into the other. Using the Stamp tool, you
can Alt-click/Option-click in one plane and drag to clone it
into the other plane, as shown in Figure 19.22.

• Create a selection in either plane. Use the Marquee tool to
create a selection in one plane and hold down the Alt/Option
key while you drag it to another plane. The results are square
and lack the softness that can be created with the Stamp tool,
but the perspective changes and the image appears in the
second plane.

Figure 19.22

The perspective of the boys has changed from one plane to
the next.
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• Use the Transform tool to resize and rotate a newly
moved selection.
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• Use the Brush tool to paint. The color, size, and other
features of the brush are set before you open the Vanishing
Point utility. You can also use the Eyedropper tool to change
the paint color.

• Copy a selection from another document into the
Vanishing Point utility. By using Ctrl+V/ +V, you can
paste a previously copied document into Vanishing Point and
place it on a plane.

7. Click OK to exit Vanishing Point and apply the changes
to your image.

Tip

As you select each tool, the Options bar at the top of the
Vanishing Point workspace changes to reflect that tool.
Watch for options that make the tools easier to use and more
versatile.

Correcting Wide-Angle Lens Distortions

The Adaptive Wide Angle filter enables you to correct the
distortions that inevitably result when you use a wide-angle
lens to capture large buildings or expansive landscapes. It
works by taking the warp out of the image that the lens
introduced to it by bending the light. This feature will
inevitably crop some of your image, and you may lose areas
that you used your wide-angle lens to capture in the first
place; therefore, you should use the Adaptive Wide Angle
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filter only when you don't mind losing some of the outside
edges of your photo.

Figure 19.23 shows a photo taken with a wide-angle lens at a
very small focal length of 10mm. You can see obvious
distortions in the cliffs, which look stretched and bent.

On the Web

Download Figure 19.23 from the book's website to follow
along with this exercise.

Figure 19.23

Many photos taken with a wide-angle lens exhibit some
distortion.
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You can use the Adaptive Wide Angle filter to correct these
distortions. Choose Filter ? Adaptive Wide Angle to open the
Adaptive Wide Angle filter, as shown in Figure 19.24. It is a
simple utility with the Toolbox on the left and the correction
options on the right.

Figure 19.24

The Adaptive Wide Angle filter gives you the ability to adjust
your images for wide-angle distortions.

If the photo you open in the Adaptive Wide Angle filter is
digital, chances are that Photoshop will recognize the lens
used to create the photograph and adjust your photo
accordingly. In this case, the projection model is set to Auto
and theoretically, there is nothing more for you to do.
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If the Auto option is not available, you can choose from three
other projection models. Click the Correction menu and select
Fisheye, Perspective, or Full Spherical, depending on the lens
that you used to capture the photo. With any one of these
three options selected, you can customize the following
settings:

• Scale. This option shrinks or grows your image inside the
canvas. As you use the Adaptive Wide Angle filter to bend
the edges of your image, you can use this slider to increase
the size of your image, effectively cropping the uneven edges.

• Focal Length. This option enables you to set the focal
length at which your image was taken.

• Crop Factor. This option enables you to adjust the warp
placed on your image by the other settings, distorting it more
or less.

All of these settings adjust your entire image. After you have
changed them, you can customize areas of your image by
using the tools on the left side of the Adaptive Wide Angle
workspace (refer to Figure 19.24) to make custom changes.
The following tools are available to you:

• Constraint tool. This tool enables you to specify straight
lines in your image and have the perspective adjusted
accordingly.

• Polygon Constraint tool. This tool enables you to draw an
area composed of straight lines to indicate a flat plane.
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• Move tool. This tool moves the photo around inside the
canvas.

Even though the image shown in Figure 19.23 was
auto-adjusted when we brought it in, we used the Constraint
tool to make additional changes, as shown in Figure 19.25. A
horizon line usually makes a big difference, as do long lines
running along the side of the image. As you use the
Constraint tool, you can maximize its effectiveness by
choosing the orientation of each line that you draw. Use the
handles that appear on the selected constraint line to change
its orientation.

Figure 19.25

The Constraint tool enables you to customize the filter.
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The Polygon Constraint tool is best for subjects with obvious
planes, such as a building. Using an entire plane to adjust an
image can create more efficient results. When you are
finished making adjustments to your photo, click OK to exit
the Adaptive Wide Angle filter. As you can see in Figure
19.26, the distortion in our photo has greatly improved;
however, we have also lost much of the image as the altered
edges have been cropped square.

Figure 19.26

The end result of using the Adaptive Wide Angle filter

Summary

In this chapter, we showed you several ways to distort or
otherwise transform your images and several different reasons
to do so. Whether you are resizing or tweaking images so they
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fit better into composites, or simply having fun creating
artistic effects, you should have the skills to do so. You
learned how to do the following:

• Perform several transformations

• Use the Content-Aware Scale feature

• Use the Puppet Warp tool

• Work in the Liquify utility workspace

• Use Vanishing Point to change perspective

• Use the Adaptive Wide Angle filter to correct lens
distortions
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Chapter 20: Applying Filters

In This Chapter

Enhancing an image using Artistic filters

Transforming images using the Filter Gallery

Making non-destructive filter adjustments

Defining the behavior of the Photoshop filter algorithms

Most of the filters in Photoshop are just for fun. They don't
correct lighting or color, take out unwanted elements, or even
change your photo into a black-and-white image — all fixes
that are common to a photo correction workflow. Instead,
they add fun, artistic elements to your photo, such as making
it look like a watercolor painting, a stained-glass window, or
an image embossed into metal.

You can add many of these filters to an image using the Filter
Gallery, a tool that enables you to preview the filter effect,
change the filter settings, and add multiple filters in a
viewable and changeable stack. Other filters must be added
using the Filter menu.

You can add most of the filters as Smart Filters that are
non-destructive and editable. Understanding Smart Filters and
how they work gives you the flexibility to add multiple filters,
change the order in which they are applied, edit their settings,
create a blending option for each filter (an option you don't
otherwise have), disable their effects, or delete them.
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In this chapter, we focus on the fun, artistic filters as we show
you how to apply these powerful tools to an image and
modify their effects. With dozens of creative filters that you
can combine, modify, and customize, the possibilities are
seemingly endless.

Note

You can find several examples of filters in the color insert in
this book.

Looking at Artistic Effects Filters

Most of the Photoshop filters create artistic effects by
changing your image in a way that can enhance its artistic
value, at least for the project you are working on. These filters
can make a photograph look like anything from a painting to
a rubber stamp. They are divided into categories based on
their relative properties and are found in the Filter menu. The
following section contains a comprehensive list of the artistic
effects filters and descriptions of what they do.

Note

The Filter menu can be confusing because the filter options
that you can apply with the Filter Gallery no longer appear
in the Filter menu. So you might click the Distort submenu
in the Filter menu and see the Displace and Pinch options
among others, but you will not see the Diffuse Glow or
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Glass options. When you open the Filter Gallery, the
Diffuse Glow and Glass options are inside the Distort folder.
To avoid confusion, throughout this chapter, we have listed
the filters in the order of their type, noting if they can be
found in the Filter Gallery rather than the Filter menu.

You do have the option to list all of the filters in the Filter
menu by choosing Edit⇒Preferences⇒Plug-ins (Photoshop
CC ? Preferences⇒Plug-ins on a Mac) and selecting the
Show all Filter Gallery groups and names option. Once you
check this box, Photoshop lists all filters under their heading
in the Filter menu, regardless of whether they use the Filter
Gallery.

This list doesn't include the corrective filters —
namely the Sharpen, Blur, Noise, and Lens Correction filters,
which we cover in Chapter 14. We cover the new Camera
Raw filter in Chapter 8; the Liquify, Vanishing Point, and
Adaptive Wide Angle filters in Chapter 19; and the video
filters in Chapter 25.

New Feature

The Camera Raw filter is new in CC and offers a quick way
to use the Camera Raw tools on any photo. Although images
that are not shot in camera raw (such as the JPEGs common
with most point-and-shoot cameras) lack the depth and
therefore the ability to change as dramatically as their RAW
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counterparts, the adjustment tools in the Camera Raw dialog
box are very powerful and quick to use. Because this is not
an artistic filter, we don't cover it in this chapter. We give it
a brief overview in Chapter 13, but because it is essentially
the Camera Raw dialog box, we cover it completely in
Chapter 8.

Exploring Artistic filters

The Artistic filters replicate effects that are usually achieved
by hand rather than digitally. Although they don't always
create realistic results, they can give freehand-challenged
artists options for creating drawing effects. The options that
can be found in the Filter Gallery instead of the Filter menu
are indicated:

• Colored Pencil. (Filter Gallery) This filter makes your
image look as if the hard edges have been sketched using a
colored pencil. This effect uses your background color as the
color of the paper, so if your background is the default, you
may get an image that is more gray than colorful. Change it to
white or any other color to alter the look.

• Cutout. (Filter Gallery) This effect makes your image look
as if it has been constructed of roughly cut paper, similar to a
mosaic.

• Dry Brush. (Filter Gallery) This filter makes your image
look as if it was painted using a dry brush technique. The
effect is subtle, although it reduces the colors in your image.
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• Film Grain. (Filter Gallery) This filter adds a grainy look to
your image by blending the shadows and midtones.

• Fresco. (Filter Gallery) This filter creates a rough image
that mimics coarsely applied paint.

• Neon Glow. (Filter Gallery) This filter uses your foreground
color and mixes it with a specified glow color to create a glow
and soften your image. You can see an example of the Neon
Glow filter in Figure 20.1.

Figure 20.1

Applying a Neon Glow filter to this photo created a fun
contrast to the original.

• Oil Paint. This filter creates texture and specularity to
mimic the look of an oil painting. You can change the look
based on brush size and style. The end result will probably
never be worth millions, but it is a fun, artistic effect.

• Paint Daubs. (Filter Gallery) This filter lets you choose
from several brushes to create a painting from your image.
The brush you use and the settings you apply can create an
image effect ranging from slightly softer to impressionistic.
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• Palette Knife. (Filter Gallery) This filter smoothes your
image and introduces texture that simulates the canvas
underneath.

• Plastic Wrap. (Filter Gallery) This filter makes your image
look as if it's been embossed and shrink-wrapped.

• Poster Edges. (Filter Gallery) This filter introduces banding
in your image by significantly reducing the colors, and creates
black strokes along the harder edges of your image.

• Rough Pastels. (Filter Gallery) This filter simulates a
drawing made with pastel chalk. You have a lot of control
over this filter when you apply it to your image, with several
textures to choose from and settings that increase the
dimension and light of the chosen texture.

• Smudge Stick. (Filter Gallery) This filter softens an image
by reducing the colors and smudging them.

• Sponge. (Filter Gallery) This filter introduces regular
patches of missing color, as if the painting had been sponged
while it was still wet.

• Underpainting. (Filter Gallery) This is another filter
primarily for adding texture, although you can significantly
change the look by adjusting the brush strokes as well. It
simulates painting your image over a textured background
(the underpainting) and then reapplying the image over the
top.

• Watercolor. (Filter Gallery) This filter simulates your
image being painted with watercolors, giving it a soft, muted
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look. You can add contrast by increasing the shadow
intensity.

Discovering Brush Stroke filters

The Brush Stroke filters make your image look different by
changing the way the brush strokes are applied to it. Just like
the Artistic effects, these effects are meant to mimic fine art.
The options that can be found in the Filter Gallery instead of
the Filter menu are indicated:

• Accented Edges. (Filter Gallery) This filter adds highlights
or shadows to the edges of your image, accentuating them and
giving your image ultra-sharp edges while smoothing out the
other areas.

• Angled Strokes. (Filter Gallery) This filter creates the
impression that your image is painted using diagonal strokes.
The lighter strokes are painted in a different direction than the
darker strokes, creating a crosshatched appearance in areas of
high contrast.

• Crosshatch. (Filter Gallery) This filter adds a crosshatch
texture to your image. This effect creates a cleaner look than
the angled strokes because the crosshatches are kept within
the bounds of the colors contained in your image.

• Dark Strokes. (Filter Gallery) This filter creates more detail
and darkness in the dark areas of your image because it
creates short, tight strokes in those areas. It also softens the
lighter areas in your image by using long, white strokes. You
can see an image before and after we applied Dark Strokes to
it in Figure 20.2.
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Figure 20.2

Adding the Dark Strokes filter creates a high contrast in this
image.

• Ink Outlines. (Filter Gallery) This filter simulates a picture
drawn with ink, giving your image a contrasty, textured look.

• Spatter. (Filter Gallery) This filter gives your image the
look of a painting that was created using a spatter airbrush,
including a lot of splotches and texture.

• Sprayed Strokes. (Filter Gallery) This effect is very subtle,
especially if your image has a high resolution. It simulates the
effect of painting your image by making strokes with a spray
brush. You can determine which direction you want the
strokes to run.

• Sumi-e. (Filter Gallery) In true Japanese style, the Sumi-e
effect simulates a painting on rice paper using a heavily
saturated brush. The end result is a rich painting with deep
shadows.

Examining Distort filters
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The Distort filters change the way your image looks by
reshaping it in different ways. Most of these filters are not
available in the Filter Gallery simply because the dialog
boxes have more comprehensive settings than the other
filters. You can find the Diffuse Glow, Glass, and Ocean
Ripple filters in the Filter Gallery. Here's what the Distort
filters do:

• Diffuse Glow. (Filter Gallery) This filter is great for
creating the effect of an image taken with a soft diffusion
filter, which is popular with portrait and wedding
photography. The effect is a soft, ethereal look as shown in
Figure 20.3.

Figure 20.3

A Diffuse Glow creates a surreal feeling in this image.

• Displace. This filter requires that you have an image to
specify as a displacement map. Any PSD file will do. The
Displace filter uses the hard edges in the image that you
specify to warp your original image around.
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• Glass. (Filter Gallery) This filter makes your image look as
if it's being viewed through glass. Several settings simulate all
different types of glass.

• Ocean Ripple. (Filter Gallery) This filter gives your image
the illusion that it is being viewed through water.

• Pinch. This filter creates only one kind of distortion: a warp
to the center of your image that either pinches it in or bubbles
it out. Think of it as a mini-warp, similar to the Liquify effect.

• Polar Coordinates. This filter produces an interesting
effect. After it has been applied, you can place the resulting
image in a mirrored cylinder to create a cylinder
anamorphosis. When you look into the cylinder, the image
appears not only undistorted but in 3-D.

Note

For some interesting information on the cylinder
anamorphosis art form, look up anamorphosis on
Wikipedia.

• Ripple. This filter creates ripples in your image, like
disturbing water in the middle of a pond.

• Shear. This filter enables you to distort your image using a
curve.

• Spherize. This filter wraps an image around a sphere, giving
it a 3-D effect as shown in Figure 20.4.
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Figure 20.4

The Spherize filter increases the magnitude of the center of
this image, almost making it look like it was taken with an
extreme fish-eye lens.

• Twirl. This filter twists an image around a point in the
center of the image. You can choose how far to twist and in
what direction.

• Wave. This filter enables you to create waves in your
image, just as if it were the surface of a swimming pool. It
also has several controls that let you customize the look. The
results are similar to the Ripple filter, but you have much
more control over the results using the wave settings.

• ZigZag. This filter creates zigzag waves in an image,
starting in the center and gradually decreasing as the effect
moves outward.

Checking out the Pixelate filters

The Pixelate filters create different types of pixelation in your
file. The dialog boxes are simple, focusing on the size of the
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pixelation. Some of the filters, such as the Fragment filter,
don't have a dialog box at all. None of these filters are in the
Filter Gallery. Here's what you can expect from the Pixelate
filters:

• Color Halftone. This filter takes each color channel, divides
it into rectangles, and changes the rectangles into circles. The
effect is similar to watching an old television set where the
colored pixels are easy to pick out, except the pixels are round
in this case.

• Crystallize. This filter combines several adjoining pixels
together to create hard-edge polygon shapes reminiscent of
crystal formations as shown in Figure 20.5.

Figure 20.5

The Crystallize filter gives this image a sharp, colorful feel.

• Facet. This filter combines pixels in the same area to soften
the look of the image.

• Fragment. This filter adds texture to an image by averaging
adjoining pixels and then offsetting them from one another.
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Note

The Facet and Fragment filters don't have dialog boxes but
work with a set number of pixels. This means that if your
images have a high resolution, you probably won't see a
distinct difference when using either one of these filters.

• Mezzotint. This filter can create a very cool color effect by
applying strokes that are randomly assigned to be black,
white, or a fully saturated color. The result is similar to an Art
Deco effect and can really make your image pop.

• Mosaic. This filter makes your image look as if it were
created from square tiles of pixels. You can determine the
number of pixels that are grouped into each tile, which makes
it possible to create a visible effect with a high-resolution
image.

• Pointillize. This filter enables you to turn your image into a
painting that looks like it could have been created by Georges
Seurat. It does this by creating solid color points throughout
the image.

Considering the Render filters

The Render filters range from the simple Clouds filter that
creates clouds from the foreground and background colors
without any input from the user, to creating a Lighting Effects
filter that requires detailed input. These filters are not in the
Filter Gallery.
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• Clouds. This filter uses the foreground and background
colors in a blend that resembles blotches more than clouds.
You want to create a new layer on which to render the clouds,
because the effect replaces anything that was on the layer
before the clouds were rendered.

• Difference Clouds. This filter creates clouds using the
foreground and background colors just like the Clouds filter
and then blends them with the existing pixels using the
Difference Blend mode. You can apply this filter multiple
times for a different effect each time.

• Fibers. This filter creates streaks of color from the
foreground and background colors that intermix to resemble
fibers. This filter also replaces the pixels on the selected layer.

Tip

In addition to adding filters on top of one another to create
unique effects, you can also place filters such as clouds and
fibers on their own layer, and then use them with the Blend
modes to create unique effects on the layers beneath them.

• Lens Flare. This filter does a pretty good job of creating a
realistic lens flare in your image. You can choose one of
several flares and place it anywhere in your image. Figure
20.6 demonstrates how you can add “flash” to an ordinary
photograph.

Figure 20.6
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Adding a lens flare adds a lighting dimension to this image.

• Lighting Effects. This filter adds unlimited lighting effects
to your image to create dramatic results. You can create
several lights, place them anywhere in your image, and
change their properties so they resemble different types of
light, from spotlights to gel lights. You can also create your
own lighting effects and save them as additional presets.

Looking into the Sketch filters

The Sketch filters use the edges in an image to create texture,
often giving the image a rough, hand-drawn look. Many of
these filters reduce your image to two or three colors, so
simple images with a few distinct lines look better than
images that have more detail. Keep an eye on your
foreground and background colors (found in the Toolbox),
because Photoshop uses them to create most of the effects
found in this menu. You can apply all of these filters using
the Filter Gallery:

• Bas Relief. (Filter Gallery) This filter creates a low-relief
carving of your image using the foreground and background
colors.
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• Chalk & Charcoal. (Filter Gallery) This filter changes the
background to a medium gray and roughly draws the
highlights and midtone areas of your image in chalk that is
the same color as the background. Using the foreground color
as charcoal, the filter fills in the shadows. The right
foreground and background colors are vital to achieving an
aesthetically pleasing result.

• Charcoal. (Filter Gallery) This filter is made up of basically
two colors with very little variations between them; the
foreground color becomes rough charcoal strokes that trace
major edges and fill in the midtones. The background color
becomes the color of the paper. You can see an example of
this filter at work in Figure 20.7.

Figure 20.7

Adding a Charcoal filter to this photo of deadwood created a
neat texture.

• Chrome. (Filter Gallery) This filter gives your image a
liquid metal look, as if it had been embossed in chrome, but
with smooth edges.
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• Conté Crayon. (Filter Gallery) This filter makes an image
look as if it has been drawn with Conté crayons. Conté
crayons are made from a mix of clay and natural coloring
agents such as iron oxide and charcoal; they are square and
used to create rough, boldly lined sketches on textured paper.
The Conté Crayon filter uses the foreground color to fill in
the darker areas of your image and the background color for
lighter areas. Because Conté crayons are usually black, sepia,
or sanguine-colored, using these colors for your foreground
and background creates a truer effect.

• Graphic Pen. (Filter Gallery) This filter reduces your image
to two colors: the pen, which uses the foreground color to
create fine, linear strokes to bring out the detail of an image,
and the paper, which uses the background color.

• Halftone Pattern. (Filter Gallery) This filter simulates the
effect of using a halftone screen, adding a specified texture to
your image, and reducing it to a blend of your foreground and
background colors. It can have a subtle texture or a very
marked one, depending on the settings.

• Note Paper. (Filter Gallery) This filter is similar to the
Cutout filter, creating an image that looks like it was
constructed of handmade paper. Unlike the Cutout filter, it
uses the foreground and background colors to determine the
color of paper used, again creating an image from two colors.

• Photocopy. (Filter Gallery) This filter simulates a rough
photocopy of your image, using the foreground and
background colors as the paper color and toner.
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• Plaster. (Filter Gallery) This filter simulates a plaster cast,
smoothing the edges of your image and using the foreground
and background color to give the image a 3-D effect.

• Reticulation. This filter creates a grain over your image
after reducing it to the foreground and background colors.
This adds more texture and dimension.

• Stamp. (Filter Gallery) This filter gives the impression that
your image has been applied with a rubber or wooden stamp,
with the foreground color as the paper and the background
color as the ink that the stamp has been dipped in. Images
with simple lines make the best stamps.

• Torn Edges. (Filter Gallery) This filter is similar to the
Note Paper filter, but it doesn't contain the texture that
simulates the handmade paper in the Note Paper filter.
Instead, the effect of this filter is very smooth.

• Water Paper. (Filter Gallery) This filter uses the colors in
your image and “waters them down” to make your image look
softer.

Using the Stylize filters

The Stylize filters work primarily by using the edges in your
image to create interesting 3-D effects, from embossing your
image to making it look like it was created with building
blocks. Some Stylize filters mix up the pixels in your image
to look like they've been diffused or hit by a high wind. Here's
what you can expect:
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• Diffuse. This filter softens the focus of your image by
scattering pixels in a miniscule style. This effect is hardly
noticeable on high-resolution photos, because there is not a
setting that enables you to increase the amount of diffusion.
Instead, you get a different kind of blurring filter.

• Emboss. This filter gives your image the look of having
been pressed or embossed onto a gray sheet of paper. Emboss
uses the image colors for the raised outlines, giving this effect
the look of a unique piece of art.

• Extrude. This filter makes your image look as if it is
constructed of building blocks and you are looking down at it
from the top. Using pyramids for your extrusion method gives
your image a more impressionistic feel than using blocks.

• Find Edges. This simple filter doesn't use a dialog box; it
simply finds the edges of your image and places them on a
white background. It is not only useful for finding edges in
your image, but because it uses the image colors for the
edges, it also creates a beautiful effect all on its own, as
shown in Figure 20.8.

Figure 20.8

Using the Find Edges filter creates a colorful outline of the
original image.
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• Glowing Edges. (Filter Gallery) This is the only Stylize
filter found in the Filter Gallery. It finds the edges of your
image and applies a neon glow to them on a black
background. You can increase the effects of this filter by
applying it more than once.

• Solarize. This filter blends a negative image and a positive
image to create an interesting, dream-like image made up of
the correct colors blended with the eerie negative colors.

• Tiles. This filter makes an image look like it is made of
large, square tiles.

• Trace Contour. This filter creates a contour map effect by
tracing a brightness transition in each of the color channels.

• Wind. This filter simulates your image being hit by wind
while the paint was still wet. Several settings enable you to
customize the wind-blown look.

Delving into Texture filters

The Texture filters create heavy, very obvious, texture effects.
Most of these filters are self-explanatory. You can preview all
of them in the Filter Gallery:
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• Craquelure. (Filter Gallery) This filter simulates an image
painted on cracking plaster.

• Grain. (Filter Gallery) This filter enables you to add ten
different types of grain to your image to create texture. Some
of these grain types, such as Soft, create a muted look. Others,
such as Vertical, change the look of your image dramatically.
You can see an example of a Speckle grain filter in Figure
20.9.

Figure 20.9

The Grain filter can create contrast and grittiness.

• Mosaic Tiles. (Filter Gallery) This filter creates an image
that looks as if it were created with irregular-shaped tiles with
grout between them.

• Patchwork. (Filter Gallery) This filter simulates a
patchwork quilt by creating squares that are solid colors and
giving them the illusion of depth.

• Stained Glass. (Filter Gallery) This filter breaks an image
into glass cells, with a lead border between them made up of
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the foreground color and a light source to give the image the
illusion that it is backlit.

• Texturizer. (Filter Gallery) This filter applies one of four
basic textures to your image: brick, burlap, canvas, or
sandstone. You can choose several settings for each filter to
customize the size and depth.

Defining the Other menu

The filters found in the Other menu option do all sorts of
different things, from enabling you to create a Custom filter
to moving a selection in your image a specified distance and
filling in the areas left behind.

Here is a description of what each filter does:

• Custom. This option allows you to create your own Custom
filter. We show you how to do this later in this chapter.

• High Pass. This filter removes low-frequency detail in an
image, retaining the edges and smoothing the other areas into
a medium-gray color. It is commonly used in conjunction
with other filters or adjustments to apply sharpness to an
image or to delineate the edges for a continuous-tone filter or
image. For example, many of the Sketch filters use only two
colors. Figure 20.10 is an example of an image with the Note
Paper filter applied to it both before and after applying the
High Pass filter.

Figure 20.10
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Using the High Pass filter first made the Note Paper filter
more effective.

• Maximum and Minimum. These filters affect black and
white areas in your image. The Maximum filter spreads the
white areas and reduces the black areas in an image;
Minimum does the opposite. Although these filters are used
mainly to modify masks, they can have a unique effect on
images as well, giving them either a bright or dark
impressionistic look.

• Offset. This filter is used with an image that has a selection
created over it. It has the effect of moving the selection a
specified amount within the image and replacing the moved
pixels with transparent pixels, repeating edge pixels, or
wraparound pixels. If no selection is created in the image, the
entire image is offset.

Exploring the Filter Gallery
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The Filter Gallery contains many of the artistic filters that are
available in Photoshop. An incredibly useful tool, it enables
you to preview the filters, change their settings, and add
multiple filters to the same image before closing the Filter
Gallery.

To open the Filter Gallery, as shown in Figure 20.11, choose
Filter⇒Filter Gallery. The Filter Gallery contains three panes:
the preview pane, the filter thumbnail pane, and the options
pane.

Figure 20.11

The Filter Gallery is like a filter funhouse for images,
containing many of the artistic filters available in Photoshop.
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Looking at the preview pane

The left pane contains a preview of your image, showing you
what it will look like after you apply the filter or filters to it.
You can move your image around inside the preview pane by
using the Hand tool (which displays whenever you hover your
mouse over the image) to drag it around.
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You can zoom in or out of your image using the + or –
buttons at the bottom-left corner of the preview pane, or use
the drop-down menu to choose a zoom percentage. If you
choose Fit in View from the zoom options, your document
resizes to fit into the preview pane. If you choose Fit on
Screen, the Filter Gallery resizes to fit your entire screen and
the image then resizes to fit into the preview pane, giving you
the largest possible view of your entire image.

Checking out the filter thumbnail pane

The central window of the Filter Gallery contains the folders
for the filter. Click the downward-pointing triangle next to
each folder to display thumbnails of the effects contained in
the Filter Gallery. These folders correspond with the Filter
menu, but they are not comprehensive; they leave out the
corrective filters as well as some of the Artistic filters that
require either no input or more specialized input than is
available in the Filter Gallery.

Each of the thumbnails of the individual filters found in the
filter thumbnail pane gives you a basic preview of what the
filter does. As you click each thumbnail, the image in the
preview pane also takes on the characteristics of the selected
filter.

Note

Most of the filters in the Filter Gallery are
memory-intensive and can take a few seconds to preview,
especially if you have more than one applied.
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You can close and reopen the filter thumbnail pane by
clicking the double-arrow icon in the options pane. Closing
the filter thumbnail pane makes your preview pane larger and
gives you a better view of your image. You can still choose
filters from the drop-down filter selection menu in the options
pane.

Looking at the options pane

The last window in the Filter Gallery contains the settings for
the selected filter. Beneath the OK and Cancel buttons is a
drop-down menu that contains all the filters in the Filter
Gallery. Whether you use this menu or click the filter
thumbnails, the pane displays the options for the selected
filter. You can make changes to the way the filter is applied to
your image, sometimes with dramatic results.

All three filters are applied to the image preview in Figure
20.11. Each filter is listed in the order you have applied it,
with the most recent filter on top. You can create a new filter
effect layer by clicking the New effect layer icon at the
bottom of the third window. When you have more than one
filter, you can change the order in which they are applied by
dragging and dropping them in a different order, as shown in
Figure 20.12. To see what the preview looks like without one
of the filters, just toggle the eye icon off for that filter, and the
visibility of the filter is turned off.

Note
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The Filter Gallery opens with the same filters applied using
the same number of layers as the last time you opened it, no
matter how long it's been or what document you opened last.

Figure 20.12

Moving the Diffuse Glow effect below the Watercolor effect
can change the end result in the image dramatically.

Using Smart Objects to Make Filter Adjustments

Applying filters directly to your images changes the actual
pixel values and modifies the original data. Although you can
use the History option to get back to the original state, after
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you save your file, those pixels become altered beyond
recovery. Additionally, you may need to try several filter
methods and sometimes combinations of filters to get the
adjustment you are looking for; this is hard to do when you
are trying to apply more than one filter, especially if some of
your filters are not found in the Filter Gallery.

That is where Smart Objects can make a huge difference.
When you apply a filter to a Smart Object, it is applied as a
Smart Filter that you can turn on and off, adjust, reorder, and
easily remove without destroying the underlying pixel data.

The best way to apply filters to images in a non-destructive
way is to create a duplicate layer of the background and then
turn that layer into a Smart Object. You can also simply turn
the background layer into a Smart Object layer, but if you
keep the background layer around, you can always create a
new duplicate layer later to try another set of Smart Filters on.

Follow these steps to create a duplicate of the background
layer and then apply Smart Filters to it:

1. Open an image in Photoshop.

2. Right-click the background layer, and select Duplicate
Layer from the popup menu.

The Duplicate Layer dialog box appears.

3. Name the layer in the Duplicate Layer dialog box and
then click OK to create the layer.

Photoshop adds the new layer to the Layers panel.
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4. Right-click the new layer, and select Convert to Smart
Object from the popup menu.

Photoshop converts the layer to a Smart Object, and a Smart
Object icon appears on the layer thumbnail as shown in
Figure 20.13.

Figure 20.13

A Smart Object has a Smart Object icon on the layer
thumbnail.
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5. Apply a filter to the Smart Object.

In this example, we opened the Filter Gallery and applied a
Grain filter to the Smart Object. When the Filter Gallery
opens, you can make adjustments to the filter and click OK.

1360



We applied the Grain filter as a Smart Filter to the Smart
Object, and it became a sublayer that was easy to view and
edit.

6. Apply a second filter to the Smart Object.

In this example, we chose Filter⇒Oil Paint to apply the Oil
Paint filter to the Smart Object. When the Oil Paint dialog
box opens, you can make adjustments to the filter and click
OK.

We applied the Oil Paint filter as a Smart Filter above the
Grain filter (which was applied with the Filter Gallery, thus
the name of the layer), as shown in Figure 20.14.

Figure 20.14

Additional filters appear on the Layers panel, with the most
recent one on top.

7. Drag and drop the top filter below the second filter to
change the look of your image.
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In this example, we dragged and dropped Oil Paint below the
Grain Filter, as shown in Figure 20.15.

Figure 20.15

With a simple drag and drop, we changed the order of the
filters, altering the effect on the image.

You can continue to make changes to your filters by
right-clicking any Smart Filter to display the menu. You can
choose any of the options from the menu that appears, or you
can perform these functions by doing the following:

• Edit the filter settings by double-clicking the filter name.

• Double-click the Blending Options icon (to the right of the
filter name) to change the Blend mode of that filter over your
image.

• Disable the filter by clicking its eye icon, or delete the filter
entirely by dragging the filter to the trash icon.
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Creating a Custom Filter

One of the most powerful filters Photoshop provides is the
Custom filter. The Custom filter enables you to define most
of the behavior of the filter algorithms in Photoshop. Most of
these algorithms work by focusing on one pixel at a time.
Photoshop evaluates the color and brightness of the
surrounding pixels and uses various algorithms to calculate
what the new color and brightness of the current pixel should
be. Then the algorithm moves to the other pixels until it has
filtered every pixel in the image.

Note

Many of the filtering algorithms in Photoshop apply
multiple filtering effects and even additional algorithms that
are not available through the Custom filter. You can get
some pretty good results with the Custom filter, but you
cannot duplicate the results you can get in some of the other
filters in Photoshop.

You can apply a Custom filter by choosing
Filter⇒Other⇒Custom from the main menu bar in Photoshop
to launch the Custom dialog box, shown in Figure 20.16. The
Custom dialog box enables you to apply a weight to each of
the neighboring pixels as well as the surrounding pixels when
calculating the replacement pixel value.

Figure 20.16
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Using the Custom dialog box in Photoshop enables you to
define filters by setting weights for surrounding pixels, a scale
value, and an offset value.

In addition to the weight for neighboring pixels, you can
specify scale and offset values:

• Scale. The Scale value enables you to control the weight
ratio between the center pixel and the surrounding pixels.
Photoshop reduces the resulting pixel value by dividing it by
the value of the scale. This enables you to apply filters that
scale pixel values out of the 0-to-255 range by scaling them
back in.

• Offset. The Offset value enables you to specify an overall
offset in brightness that is applied to the resulting pixel.
Increasing the offset can compensate for filters that tend to
make the image too dark; decreasing the offset can
compensate for filters that make the image too light.

Here's how it all works. Photoshop selects a pixel, multiplies
it by the center value in the Custom filter, takes the

1364



surrounding pixels defined in the Custom filter, and
multiplies them by the corresponding values. Then it adds
them all up, divides by the scale, and adds the offset to that
number.

This might be a bit confusing at first, but look at the example
filter shown in Figure 20.16; starting from a center pixel with
a value of 100, one pixel up is 200, one pixel down is 200,
one pixel left is 150, and one pixel right is 150. This equation
is used to calculate the value that replaces the current pixel:

(100x10+200x-1+200x-1+150x-1+150x-1)/5
+ 0 = 60

Tip

A good rule of thumb when creating Custom filters is to try
to make the value of the equation equal 1 or –1 if all of the
pixel values are set to 1. From there, you can tweak the
values and use the offset to adjust any major problems.

As you play around with the Custom filter tool, you start to
realize the limitless possibilities of filters you can create with
it. The following are some examples of different types of
filters that you can create with the Custom filter tool shown in
Figure 20.17:

• No Filter. Applying a value of 1 for the current pixel does
not apply any filter effect.
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• Sharpen. Applying negative values symmetrically to the
surrounding pixels and a positive value to the current pixel
sharpens the image.

Figure 20.17

Some examples of Custom filters
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• Blur. Applying positive values symmetrically to the
surrounding pixels and a positive value to the current pixel
blurs the image and removes dust.

• Directional Blur. Applying positive values in only one
direction to the surrounding pixels and a positive value to the
current pixel blurs the image only in the direction of the pixel
changes.

• Enhance Edges. Applying positive values symmetrically to
the surrounding pixels and a negative value to the current
pixel enhances edges in the image.

• Highlight Edges. Applying negative values symmetrically
to corner pixels and a negative value to the current pixel
highlights the edges in the image.

• High Contrast. Applying extremely high values for both
the surrounding pixels and the current pixel results in a
high-contrast effect.

Summary

This chapter presented a comprehensive listing of the Artistic
filters and showed you how to apply them through the Filter
menu and the Filter Gallery. You learned more about Smart
Filters and how they work to create a non-destructive
sublayer in your image that you can edit, move, or delete.
And if being able to use more than a hundred filters, add them
to each other, and change their settings and blending modes
doesn't give you enough options, you can use the Custom
filter settings to create just the look you want. You should
know how to do these things:
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• Find the right Artistic filter to get your desired results

• Use the Filter Gallery to apply a filter or multiple filters

• Create a Smart Object in order to add Smart Filters

• Create Custom filters to achieve a unique result
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Chapter 21: Combining Images

In This Chapter

Creating realistic composites

Placing secondary images using masks

Creating panoramic images

When you begin to do more with Photoshop than just
correcting photos, the first thing you might think of is image
composites. An image composite is any image that has added
elements, from a simple text caption to a complex
photomontage.

Probably the most difficult part of creating a composite is
producing a realistic image that doesn't look as if it's been
made from more than one element. Even when the image is
implausible, such as a shark silhouetted in the wave holding
up a surfer, or a snowman in the desert, you want your
viewers to look twice and wonder if it might just be true.
We've lost count of the Internet photos that friends and
relatives have forwarded and asked, “Photoshopped or not?”

In this chapter, you learn a few tricks of the trade for making
your composites look great. We're sure that over time, you'll
come up with a few tricks of your own. Every composite has
its own unique problems. Having a thorough knowledge of
the tools at your disposal in Photoshop is the best way to
solve them.

Creating Seamless Composites
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Creating a composite is much more than just combining two
files and hoping they mesh well. Placement, perspective,
lighting, and color all play key roles in whether a composite
looks great or looks thrown together. Fortunately, there's a
reason why a Photoshopped image is one that is considered
too good to be real. We've shown you the tools you need to
create great composites; now we show you how to use those
tools to do just that.

Combining files

Photoshop can open over 40 different types of file formats.
You can combine most of these types; for example,
Photoshop can easily combine a 3D file with a JPEG or TIFF
image, or layer it on top of an Illustrator file. More incredibly,
Photoshop maintains the original aspects of each of these files
so they can still be edited and manipulated inside a composite
in the same way as they were edited and manipulated in a file
by themselves. In fact, in many ways, it is easier to change a
file after you have placed it. That way, you can be sure the
changes are consistent with the result you are trying to
achieve.

There are no magic tricks when combining files. It's easy, and
you can do it in many ways. If you want to copy layers from
one file to another, the easiest way, especially if you already
have the files open, is to drag the object layer from the first
file into the window of the second file. You can see how this
is done in Figure 21.1.

Figure 21.1
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Combining files can be as simple as dragging the object layer
from the file you want to move into the window of the
background file.

You can also combine files by copying and pasting a file, or a
selection from a file, into a background image. As you paste a
selection into your background file, Photoshop creates a new
layer containing that selection; this allows you to move and
edit the selection.

If you want more control over where your placed file will be
located in the background file and how large it will be, you
can use the Place function by choosing File⇒Place from the
main menu bar. When you use the Place function to import
one file into another file, the imported file is placed inside a
bounding box. You can drag and drop the bounding box
wherever you want inside the background. You can also use
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the handles on the bounding box to resize or rotate the placed
file, as shown in Figure 21.2.

You can use the numeric values in the Options bar to set the
position, size, and orientation of the placed file as well. When
you have placed the file where you want it, you simply click
the check box in the Options bar to accept the changes you
made.

Figure 21.2

Using the Place command gives you more control over the
file's size and position.

Another quick way to combine two separate files is to drag
the file you want to place from Mini Bridge into an open file.
It is placed just as if you had used the Place command — as a
new layer with a bounding box around it. If you are placing

1372



multiple files, using Mini Bridge is the easiest way to place
them.

Adjusting and transforming new layers

After you've placed a file as a new layer, you can edit and
adjust it just as you would any other layer. You can move the
contents of a layer by selecting it in the Layers panel and
using the Move tool to drag and drop it where you want it to
be.

You can change the size or rotate a layer by choosing
Edit⇒Transform from the main menu bar. The Transform
submenu has options such as Rotate, Scale, Skew, Warp, and
Flip. You choose Rotate, Scale, and Skew to create a
bounding box exactly like the one shown in Figure 21.2. You
can then use the handles on the bounding box to make
changes to the layer. The Warp option places a grid over the
layer, allowing you to pull on strategic points to warp and
bend it. You can flip your layer horizontally or vertically by
choosing the corresponding option. The flower in the
background photo shown here needed to be flipped
horizontally for the effect we had in mind, so we selected that
layer and quickly flipped the photo, as shown in Figure 21.3.

Caution

Be sure the layer of the file you are attempting to change is
highlighted in the Layers panel. If it's not, you may find
yourself making changes to the wrong layer.
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Figure 21.3

With the flower image flipped, we were able to place the girl
as if she were seated on it.

If you need more leeway to move around or enlarge your
files, you can change the canvas size by choosing
Image⇒Canvas Size from the main menu bar. From this
dialog box, you can expand the canvas without affecting the
image it contains.

Blending composite files

When you place a 3-D object within another file, you may
find that they don't really seem to fit together. You can use
the following quick tricks to make the files blend better.

Refining edges
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When you create a selection of a file to place into a new file,
you occasionally get rough, pixelated edges or an edge with a
shadow around it. You can soften these edges as you make
the selection or after you have placed it, as long as the area is
still selected. Click Refine Edges in the Selection toolbar, or
choose Select⇒Refine Edges from the main menu bar to open
the Refine Edge dialog box.

We cover the Refine Edge dialog box and all its
options in Chapter 9.

Creating a drop shadow

Most objects in a lighted environment create a shadow
somewhere in that environment. Creating a drop shadow is
limited in mimicking an actual shadow, but in the right
setting, a drop shadow works very well to create a shadow
effect. You can also add a drop shadow to help blend the
edges of an object or file you've placed.

You create a drop shadow by highlighting the desired layer
and clicking the fx icon at the bottom of the Layers panel.
You then select Drop Shadow from the option list and adjust
the settings, previewing the file until you've created the effect
you want.

We cover the layer styles, including an example
of creating a drop shadow, in Chapter 10.
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In this example, the drop shadow looks unrealistic, because it
appears even throughout the background, despite the
background being uneven. You can mimic the drop shadow in
specific areas by using the Burn tool. By applying the Burn
tool around the areas of the girl that are touching the flower,
as shown in Figure 21.4, you can give the impression that she
is casting a shadow over the flower.

Figure 21.4

Use the Burn tool to create a shadow when the Drop Shadow
option doesn't work.

On the Web
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You can try combining these two files by downloading
Figure 21.4a and Figure 21.4b from the book's website.

You can also create a shadow by painting it in with the brush
tool. Create a separate layer to paint into and use the Multiply
(or another darken) blending mode to add transparency. You
can also change the opacity of this layer until the shadow
blends well in the image.

Changing fill or opacity settings

Sometimes a selection placed in an image file looks hard,
lacking the color subtleties and the light and shadow of the
image. This is especially true of the dolphin as it was
originally placed in Figure 21.5. The gray colors do not blend
realistically with the greens of the mountain lake. Because
none of the lake color appears on the dolphin, it looks just
like what it is — a picture of a dolphin sitting on top of the
lake. You can blend the dolphin in by decreasing its fill and
opacity settings.

In many cases, decreasing these settings until just before you
can really make out any details coming through gives your
image a softer, more blended look. In this case, you definitely
want the lake to come through strongly, so decreasing the
opacity of the dolphin down to around 50 percent would give
you the best results, as you can see in Figure 21.5. The water
and the fin were placed on separate layers so that the opacity
reduction would not affect them, giving the impression that
the fin remains above the surface.

1377



On the Web

You can see how we created the final product by
downloading the file, Figure 21.5.psd, from the book's
website.

Figure 21.5

Reducing the opacity of the dolphin really helps it to blend
into the natural setting.

Changing the Blending mode

If you want to change the way a placed file blends into its
background, changing the Blending mode is a more dramatic
way to do this than changing the Opacity or Fill setting.
Blending modes are usually intended for creating artistic
effects rather than realism in a composite. You can change the
Blending mode by selecting the layer and using the Blending
mode drop-down menu in the Layers panel to select a
blending option. We used the Color Burn Blending mode to
create the composite shown in Figure 21.6.
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On the Web

You can see how we created the final product by
downloading the file, Figure 21.6.psd, from the book's
website.

You can learn the basics of Blending modes in
Chapter 10.

Figure 21.6

Using the Blending modes creates an artistic effect with
composite images.
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Creating a Fill or Adjustment layer

If you have the top layer selected when you create a Fill or
Adjustment layer, the new layer is placed over all the layers
in your document. When you make the same changes to all
the files in a composite, they have more in common and blend
better. Even something as simple as placing a warming filter
over both file layers can create depth and bond the files with a
common look. Of course, the more dramatic fills and
adjustments create an even more dramatic bond.
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You can add a Fill or Adjustment layer by clicking the icon at
the bottom of the Layers panel and choosing the fill or
adjustment you want to apply.

You can learn more about the Fill and
Adjustment layers in Chapter 13.

Using masks to tuck in a composite file

The most effective method of blending files together is to use
a mask to tuck one file behind components of another file.
This method can make viewers look twice at even the most
improbable photos. In Figure 21.7, the boy is distinctly out of
place in this city, but he isn't out of place in this photo,
because he is sitting correctly according to perspective. He's
behind the foreground, including the largest building, but he's
in front of the city in the background.

Figure 21.7

The boy overlooks a fantastic city.
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We did this by using a mask to cut the shape of the building
and foreground out of the boy so they appear to be in front of
him from the perspective of the viewer. To follow along with
this exercise, you need to choose a background that requires
you to put your selection behind a portion of the background
image.

You can use masks to tuck in a composite object by following
these steps:

On the Web

You can download Figure 21.8 and Figure 21.10 from the
book's website to follow along with this exercise.
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1. Create a selection around the object that you want to
place in a new environment, taking the time to make the
selection perfect for a seamless blend as shown in Figure
21.8.

In our example, as we selected the model, we did not select
the hair that was sticking up on the top of his head; the
resulting cutout was more realistic than fuzzy hair with a
color fringe.

2. Refine the edges of your selection.

You want the edges to be as precise and smooth as possible in
order to create a seamless blend in the composite image.

3. Press Ctrl+C/ +C to copy the selection.

4. Open the photo you want to place your cutout in, and
press Ctrl+V/ +V to paste the selection as a new layer in
this document.

Figure 21.8

Create a selection around the boy in the original photo
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5. Choose Edit⇒Free Transform from the menu to resize
and move the cutout into position.

In our example, the model is sitting in front of the entire
photo, as shown in Figure 21.9, so this is just a rough
adjustment.

Figure 21.9

Use the Free Transform tool to correctly size and place your
cutout in the background image.
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6. Click the visibility button (the “eye” icon) next to the
layer containing the cutout, to make it invisible.

7. With the background layer selected, create a selection
around the areas that should be placed in front of your
cutout.

We took a little extra time in our example to cut out the
balconies so that the boy would show through to create a
sense of realism. In areas where they don't intersect, the
selection doesn't have to be precise, as shown in Figure 21.10.

Figure 21.10

Select to create a mask that hides the areas of your cutout that
should be behind your background photo.
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8. Choose Select⇒Inverse from the menu to reverse your
selection in the background photo.

You want most of the image to be transparent. The areas that
are not selected will form the mask.

9. Refine the edges of the selection.

Don't feather the edges of this selection; you want the edges
in these files to be sharp and clear. You can smooth the edges
out a little, making sure to decontaminate any color fringes
you may have around the edges.

10. Output the selection to a layer mask, and click OK.
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Our example masked the building and the foreground in the
areas that weren't selected, so they disappeared from the
image, as shown in Figure 21.11.

Note

You can click the Add Layer Mask button in the Layers
panel to create a mask immediately from the selection.

Figure 21.11

The mask is created over the wrong layer.

11. Turn the visibility of your cutout layer back on.
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12. Click and drag the mask from the background layer to
the cutout layer, as shown in Figure 21.12.

Our example masked out the areas of the boy that covered the
foreground of the city.

Figure 21.12

Moving the mask cuts out areas of your initial selection
instead of areas of the background.

13. Click the link between the mask and the cutout to
unlink them.

This makes it possible for you to move or resize the selection
without moving or resizing the mask, which should stay
exactly where you've placed it.

14. Resize or reposition the cutout as needed to make it fit
into the image.
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The masks do most of the work when it comes to making the
boy look as if he belongs in this image, but you can do other
things as well. We cloned a building to place inside the boy's
hand so that it would look like he was building the city, and
placed a Levels adjustment over both photos that brightened
them and helped the images blend.

You can find another example of creating a mask
to tuck in a second image in Chapter 10, which also includes
more information on masks and how they work.

You can find the finished image in color in the
color insert in the middle of this book.

Changing images using transformation and cloning tools

Sometimes when you create composites by adding elements,
you don't always get an exact match. When one element
needs to interact with an element from another photo,
transformations may be necessary.

Take the photo in Figure 21.13, for example. The boy has
been added to the photo, shadows have been added, a mask
has been created, but although his hand is closed around the
front loader, it's closed too tightly to be realistic. This is a
perfect instance where the Puppet Warp transformation comes
in handy.

This exercise demonstrates how knowing when and how to
use Photoshop tools makes all the difference. Although we
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will show you specifically where and how we used the Clone
Stamp tool and the Puppet Warp tool, we will mention other
tools that we used for the final result in passing. This will
give you a chance to use the skills that we demonstrate
throughout the book to make your own changes that improve
the image.

You can open the boy's hand using Puppet Warp by following
these steps:

On the Web

You can download Figure 21.13.psd from the book's
website to follow along with this exercise.

1. Open Figure 21.13 from the website.

This Photoshop document is a composite that includes several
layers that have already been edited, adding the boy and his
shadow to the background image with a mask already in
place. Now you can immediately start to transform the hand.

2. With the ‘Boy' layer selected, create a selection around
the thumb.

You want to move and transform the thumb, so you need to
cut it out and place it on its own layer. You can disable the
mask and turn off the visibility of other layers if it makes it
easier. Select the thumb all the way past the wrist.

Figure 21.13
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The hand holding the front loader needs some adjustment so
that it will work well in this image.

3. With any selection tool highlighted, Click Refine Edge
in the Options bar to open the Refine Edge dialog box.

Smooth and decontaminate your selection as needed and
choose Output to: New Layer to create a new layer in your
document containing oNL1y the thumb, as shown in Figure
21.14. Rename this layer “Thumb”.

Figure 21.14

Select the entire thumb all the way up to the wrist and place it
on its own layer.
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4. Restore the visibility of the ‘Boy' layer and repeat Steps
2 and 3 to select the fingers and create a new layer for
them, as shown in Figure 21.15.

Rename the new layer “Fingers”.

Figure 21.15

Select the fingers and place them on their own layer as well.
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5. Restore the visibility of the ‘Boy' layer and use the
Eraser tool to erase the fingers and thumb from this layer.

You want to turn off the visibility of the ‘Thumb' and
‘Fingers' layers so that you can see what you are doing. Your
final result should look like Figure 21.16.

6. With the visibility restored to all layers, transform the
‘Thumb' layer to rotate and place the thumb in a better
location.

At this point, you are still using your best guess. You can see
hard edges and areas that should have been erased, as shown
in Figure 21.17.

1393



7. Transform the ‘Fingers' layer to place the fingers in a
better position.

The fingers need more work than the thumb, but you'll fix
them in a few steps; you are just moving them out of the way
so that you can work with the thumb.

Figure 21.16

Erase the fingers out of the original ‘Boy' layer.

Figure 21.17
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Transforming the thumb puts it in a better position but
highlights areas that still need tweaking.

8. With the ‘Thumb' layer selected, choose Edit⇒Puppet
Warp to place a mesh over the thumb and transform it.

Use the pins to round the thumb more and stretch the palm
over the wrist, as shown in Figure 21.18. Once you have
made the changes, click the check mark to accept them.

9. Clean up the image.
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Using the Eraser tool, the Blur tool, and the Dodge tool, fix
the seams of the new thumb placement so that it looks
realistic, as shown in Figure 21.19. Make sure you have the
appropriate layer selected for each adjustment.

10. Create a new layer above the ‘Fingers' layer.

This creates a layer on which you can paint a clone. Name the
layer “Finger clone”.

11. With the ‘Finger clone' layer selected, choose the
Clone Stamp tool and fix the shadows and the missing
index finger.

You need to make sure that the option to sample all layers is
selected. When you paint in the index finger, rotate the clone
source a little bit. You can see us working on the clone in
Figure 21.20. When you are finished creating your clone,
clean up any edges.

Figure 21.18

The Puppet Warp tool helps you stretch and mold the thumb
in position.
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Figure 21.19

Cleaning up the seams creates the illusion that the thumb
always belonged here.
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Figure 21.20

We used the clipped as well as the unclipped preview on the
Clone Stamp tool to get the results we needed.
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12. With both the ‘Fingers' layer and the ‘Finger clone'
layer selected, merge the layers.

Merging the layers creates a complete layer containing the
fingers.

13. Transform the ‘Fingers' layer.

You can rotate and move the fingers so that they look more
natural on the front loader, as shown in Figure 21.21.
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Figure 21.21

Transforming the fingers one more time creates a more
complete and natural placement.

14. Choose Edit⇒Puppet Warp to place a mesh over the
fingers and transform them.

You want to make them look rounder and shorter, as if they
were holding the front loader, which is more robust than what
they were originally holding.
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15. Make final changes to the fingers to make them look
more natural.

We used tools such as the Eraser, the Perspective Warp, and
the Burn tool. You can see our final result in Figure 21.22.

Figure 21.22

Using the Clone Stamp tool, the Puppet Warp tool, and a
myriad of cleanup tools, we were able to make the boy's hand
placement in this photo look a lot more natural.

Using Multiple Images to Create a Photo Collage

You can create a photo collage by combining two or more
photos in a single image to tell a bigger story than any single
photo. Photo collages can be used for a number of purposes.
For example, collages can display a photographer's work or
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tell a specific story for a magazine article. You can create
photo collages in Photoshop in several ways. Figure 21.23
shows some examples of photo collages.

Although all photo collages are different, they seem to have at
least a few basic elements that should concern you, including
the following:

• Background. Using multiple photos in the collage requires
a common background on which to place the photos. The
background can be either blank or one of the photos. If you
want a photo to be the background, you need to crop or size
that photo to the correct size of the finished collage. The
method you employ depends on how you will use the collage.

• Size. Resizing the photos is usually necessary when working
with multiple photos.

Figure 21.23

You can create collages to tell a bigger story in many ways.
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• Layout. Laying out each photo is important. The position
and angle of each photo can make all the difference in the
final appearance of a collage. Photoshop makes it easy to
rotate and move images in a collage.

• Layering. Layering is different from layout and is specific
to collages. A collage is really a 3-D photo; layout provides
the first two dimensions, and layering provides the third one.
Photoshop allows you to stack multiple photos on top of each
other and quickly determine which image is closest to the top
by dragging and dropping the layers to change their order in
the Layers panel.
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• Shape. Keeping the natural rectangular shape of a photo is
common in many collages. Usually, a layout with square,
crisp edges gives a collage a professional look and feel.
However, sometimes, changing the shape of images in a
collage is a better option. You can achieve a homey,
scrapbook look by using selections and vector shapes to
change the shape of the images in a collage.

• Layer styles. Adding layer styles such as borders, bevels, or
drop shadows to the individual photos makes them pop,
giving them a three-dimensional look and distinguishing them
from one another.

Before you create a collage, make any color corrections or
other image adjustments to the individual images you are
planning to use in the collage. Making these changes is much
easier in the original document with fewer layers.

Use the following steps to create a collage of multiple photos:

1. Create the background.

If you want a specific photo to be the background, open the
photo and crop or size it to the correct size of the finished
collage. If you are creating a background, start with a new
document and add any color, patterns, or other elements you
want.

Tip
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When building a collage on a created background, it is best
to make the background as big as possible. This allows you
to bring the images in full-size to keep as much detail in
them as possible. You can always resize the image down
after you create the collage. This won't work when you use a
photo for the background, however, because you are limited
to the size of the photo.

2. Add photos to the background.

The easiest way to do this, especially if you have several files,
is to create a collection of the files you are planning to use in
Bridge and then use Mini Bridge to drag them into the
background document, as shown in Figure 21.24. The photos
are added to the original document as layers, and you can
move and resize them as you place them.

3. Select the layer containing the photo you want to work
with.

With multiple images on multiple layers, it is more important
than ever that the Layers panel become an integral part of
your workflow. Figure 21.25 shows a Layers panel with
multiple layers representing different images placed in a
collage.

Learn how to work with the Layers panel in
Chapter 10.

4. Tweak the size and placement of your images.
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Although you were given the opportunity to resize images as
you placed them in the document, seeing them all together
and making other changes, such as the shape of the image,
usually means you'll want to tweak its size and placement.
You can move the selected image using the Move tool, or
resize or rotate it by using the Edit⇒Free Transform
command.

Figure 21.24

You can drag multiple files from Mini Bridge into one
document, and they are placed as separate layers.

Figure 21.25

Using several different images can result in a document with
a lot of layers.
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5. Adjust the order of the layers by using the Layers
panel.

If your photos overlap each other, you may need to adjust
which photo is on top. To change which photo appears on top
in the image, drag the photo layer higher or lower in the
Layers panel.

6. Change the shape of each photo.

If you want your photo to be a different shape than the
(probably) rectangular image you brought in, change the
shape by creating a selection inside the image and deleting the
unselected pixels or creating a mask to hide them, as shown in
Figure 21.26.

Figure 21.26

Changing the shape of an image is as easy as creating a
selection and deleting extra pixels or creating a mask to hide
them.
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Tip

You can use a vector shape (either a preset or one that
you've drawn) to create a path and use the Paths panel to
create a selection. You can also use a vector shape to create
a clipping mask. If your Layers panel is full of image layers,
you can create a Smart Object from each image and change
its shape in the original file.

7. Click the Layer styles icon in the Layers panel to add
one or more layer styles and create borders, bevels, drop
shadows, or other elements in your photo.

These elements change as you change your photo. For
example, if you transform your photo, the effect changes with
it. The changes add depth to individual photos, as you can see
in Figure 21.27.

8. Apply shapes and edges to each of the images in the set.

You can see the final results in Figure 21.28.

Figure 21.27
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Adding both bevel and stroke layer styles to this photo gives
it depth.

Figure 21.28

Multiple photos give much more meaning to the final image
than a single photo would.

1409



Tip

You can drag and copy the layer styles from one layer to
another by pressing and holding the Alt/Option key as you
drag the layer styles. You can also do this by right-clicking
the layer style, copying it, and then right-clicking each layer
and using the menu option to paste the layer style. You can't
use the hotkeys for this operation, because the hotkeys copy
and paste the actual layers. However, you can assign
hotkeys to this function.

Using Photomerge to Create a Panorama

Regardless of whether you have a wide-angle lens, you can
use Photoshop to create a photo panorama that is much larger
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and of higher quality than you could capture in one shot. The
Photomerge utility in Photoshop makes it relatively easy to
create panoramas from multiple photos.

The most critical part of using software to create a panoramic
photo from multiple shots is taking the appropriate photos in
the first place. Being aware of how Photomerge works to
create a panorama will give you the knowledge that you need
to take appropriate photos. These aspects of taking multiple
shots for a panorama will help you create the best results:

• Rotational positioning. Rotational positioning involves
standing in the exact same place and rotating the camera
around that single point to take the photos. The pictures
should be taken with the most stability possible, so using a
tripod or monopod is the ideal method.

• Overlap. To create the ideal conditions for blending the
images into a seamless panorama, each image should overlap
the next one by 40 to 70 percent. Less than this, and
Photomerge may not be able to line up identical areas in the
image. More than this, and it has a hard time appropriately
blending the images.

• Focal length. Be sure to maintain the same focal length in
all the images you want to use for a panorama; don't zoom
into some of the shots and not others.

• Lighting. Maintain the same exposure for each photo. This
can be trickier than it sounds. If the sun or other bright
elements are present in some, but not all, of your images, and
your camera is set for automatic exposure, then some of your
images may be much darker than other images. If you have a
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camera where you can set the exposure manually, you may
want to do that.

Use the following steps to create a single panoramic photo in
Photoshop:

On the Web

You can find the three photos used in the following
exercise, Figure 21.29a, Figure 21.29b, and Figure 21.29c,
on this book's website.

1. Open the photos you want to include in the panorama,
and close any other photos that may be open in the editor.

The three photos used in this example are shown in Figure
21.29.

Figure 21.29

These three photos taken of a hotel in India are perfect for
creating a panorama.

Caution
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Do not adjust the photos, such as their lighting and color, at
this point. Photoshop has a harder time trying to merge the
photos if there are even slight differences in these settings
between photos.

2. Choose File⇒Automate⇒Photomerge from the menu
to open the Photomerge utility, as shown in Figure 21.30.

Figure 21.30

The Photomerge utility is intuitive and easy to use.
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3. Click the Add Open Files button to load the files that
are currently open in Photoshop to the Use list.

You can also click the Browse button to browse for the files
you want to merge if you don't have them open in Photoshop.

4. Choose a layout option from the Layout menu.

You can choose from these layout options:

• Auto. This option allows Photoshop to evaluate and
determine which of the following settings works best for your
photos. Just like any of the automated processes in
Photoshop, this is a hit-and-miss setting.

• Perspective. This option uses the center photo as a guide to
match the other photos using the overlap areas, and stretches
or distorts them to create continuity with the other photos.

• Cylindrical. This option flattens out the bowtie effect that's
created when you take several images in a circle.

• Spherical. This option makes a panorama that is meant to
be seen in a circle around the viewer.

• Collage. This option resizes or rotates the images so that
overlapping areas match, but it doesn't skew or otherwise
warp the images.

• Reposition. This option doesn't transform the images in any
way; it just overlaps them in the best way possible.
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For this example, choose Reposition because the images don't
need to be transformed in any way to look good together.

Note

In Photoshop CS3, Photomerge had an interactive layout
option that allowed you to make changes to the
semi-finished panorama. In CS4, this option was removed
because of significant improvements in Photomerge. If you
would like to have more control over the Photomerge
process, you can still add this option as a plug-in.
PhotomergeUI is available in the optional downloads
provided on the Adobe website.

5. Choose any of the following operations:

• Blend Images Together. This option finds the borders of
the images and blends them together optimally for the best
results.

• Vignette Removal. This option is useful if some or all of
the images have lens vignettes, as it removes them while the
merge is taking place.

• Geometric Distortion Correction. This option is useful if
any of the photos being used have distortions caused at the
time of capture, such as barrel, pincushion, or fisheye
distortions.
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There are no vignettes or geometric distortions in the images
of the hotel, so you oNL1y need to select the Blend Images
Together option for this example.

6. Click OK.

Photoshop needs several seconds to analyze and blend the
photos together. When the merge is complete, it appears as a
new document in Photoshop, as you can see in Figure 21.31.
You'll notice that the result is not a perfect rectangle because
the photos were adjusted to fit one another; when you use
Photomerge, you have to crop the resulting document to fix
these ragged edges.

Figure 21.31

With very little effort on our part, the merged photo was
created.

Although the panorama appears as a single document in
Photoshop, it is actually composed of as many layers as there
were photographs to begin with, each with a mask that
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displays the areas that were cut from each photo to blend
them, as you can see in Figure 21.32. This makes it possible
for you to change the way the merge was created by adjusting
each layer and each layer mask.

Figure 21.32

With each photo placed on its own layer in the panorama, you
can easily change it.

Summary

This chapter demonstrated how the tools we have discussed
up to this point in the book could be used to create the best
composites. There were few examples in this chapter, but the
possibilities are unlimited. You learned techniques that will
help you create great composites, including the following:
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• Combining files in the best way

• Making a composite seamless using one of several methods

• Using masks to make an added element look like it belongs
in an image

• Using Photomerge to create seamless panoramas
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Part VII: Working with 3-D Images

IN THIS PART

Chapter 22

Creating and Manipulating 3-D Objects

Chapter 23

Editing 3-D Scenes and Settings

Chapter 24

Using Photoshop Tools with 3-D Layers
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Chapter 22: Creating and Manipulating 3-D Objects

In This Chapter

Using 3-D file formats

Understanding the 3-D workspace

Bringing 3-D objects into Photoshop

Creating 3-D objects

Moving 3-D objects

The 3-D environment in Photoshop has been evolving over
several releases to become a streamlined utility that makes
using the Photoshop tools on 3-D objects and scenes slick and
powerful. Adobe continues to simplify the tools to make them
more user friendly, and several things have been added to
make the workspace cleaner and easier to work with.

Although you can create basic 3-D models and add textures to
them in Photoshop, its main purpose is not to create, redesign,
or even animate 3-D objects or scenes. Instead, being able to
work with a 3-D object in Photoshop enables you to use the
powerful Photoshop filters, styles, and other Paint tools to
dramatically improve the way a 3-D image looks and to create
fantastic composites.

A 3-D object is usually composed of at least two different
files: the actual 3-D object, which is a vector file; and the
texture of the 3-D object, or the file that defines what the 3-D
object will look like, which is a raster file. You need to
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understand how these files work together in the 3-D
environment in order to use the capabilities of Photoshop to
change the look of a 3-D object.

The Layers panel also looks different when you select a 3-D
object. A 3-D object with a texture attached has at least one
sublayer, and often more than one. This chapter gives you a
complete overview of how to work with 3-D layers.

Understanding 3-D File Formats

Whenever you work with a 3-D model, you are working with
a vector file. Vector files consist of geometric shapes that are
defined by mathematical equations. When you change the
size of a vector object, the image is simply recomputed and
the file doesn't lose any quality.

A 3-D object rendered in wireframe mode is a basic example
of how vector images work. In the example in Figure 22.1,
the outlines of the hat are stored in the computer numerically,
with the length, width, and placement determined by
mathematical equations describing each component.

Figure 22.1

No matter how large this hat becomes, the lines that make up
its wireframe stay crisp.
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Because 3-D images are vector files, editing them is very
different from editing a raster image. You can't directly affect
a 3-D object with the raster tools, such as the Paint Brush or
filters. These tools are designed to change pixels, and a vector
file doesn't contain any pixels. Photoshop can rasterize any
vector file, making it possible to use any of the tools or filters
on that file, but rasterizing a 3-D object flattens it, turning it
into an image rather than a 3-D model. Sometimes when you
are creating a composite, you want to do just that, but most of
the time, you want your 3-D objects to maintain their 3-D
capabilities so that they can be manipulated and seen from
any angle. Fortunately, Photoshop provides several ways to
adjust the appearance of a 3-D object without affecting it
directly.

1422



By incorporating the 3-D extensions, Photoshop added a new
array of readable file formats to its already impressive
repertoire. Photoshop supports six 3-D file formats:

• 3-DS. This file format is used by 3-Ds Max, the most widely
used 3-D application. It has become the industry standard,
and so most 3-D modeling programs export their files in this
format.

• OBJ. This file format uses data that translates into 3-D
geometry. OBJ is also a widely used industry standard.

• DAE. This file format, also known as COLLADA, is used
by the video gaming industry. It was originally developed to
facilitate transporting digital content from one creation tool to
another. COLLADA is also a widely supported file format.

• U3-D. This file format, short for Universal 3-D, enables
users to share 3-D graphics with other users who don't have
the 3-D modeling program used to design the image. Like
JPEG or TIFF files, U3-D files are gradually becoming
universally available to most image viewers.

• FL3. This file format is relatively new. FL3 stands for Flash
3-D and is a native Adobe format.

• KMZ. This file format was created and is used by Google
Earth. It is specific to the 3-D geography that you see when
you explore Google Earth.

When you are finished making changes to a 3-D object, you
have the option of exporting it as a 3-D object rather than
saving it as a PSD file. Choose 3D⇒Export 3-D Layer to
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open the Save As dialog box. You can choose from several
3-D formats to save your object. You can export 3-D objects
from Photoshop in all of the above formats except 3-DS.

Looking at the 3-D Workspace

Before you start creating and working with 3-D objects in
Photoshop, it is important to be familiar with the 3-D
workspace. Because working with 3-D requires multiple
tools, layers, and options, the Essentials workspace in
Photoshop is inadequate for the job.

In order to work in 3-D, it is vital that you change to the 3-D
workspace so that you have the 3-D panel docked and ready
to use. Click the Workspace Selector button on the right of
the Tool Options bar to open the drop-down menu, and select
3-D. This opens and docks your 3-D panel and closes panels
that are not as useful in this environment. The Properties
panel remains along with the Layers panel.

The 3-D panel and the Properties panel work together to
efficiently provide you with the options you need to
manipulate and edit different objects within your 3-D scene.
There are two different looks to the 3-D panel; when you
have a 3-D layer selected, it looks completely different than
when you have a different type of layer selected. In addition,
the Properties panel changes depending on what you have
selected in the 3-D panel. It is neatly laid out, and once you
become familiar with the basics, you should have no trouble
using them to your best advantage.

Other features of the 3-D workspace that are important to
understand are the 3-D tools and the Picture in Picture
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window. The 3-D tools enable you to manipulate your 3-D
objects, and the Picture in Picture window provides you with
a secondary view of the changes you are making to your 3-D
scene.

Looking at the 3-D panel

The 3-D panel looks different depending on what type of
layer you have selected in the Layers panel. If you have a
non–3-D layer selected, the panel lists the options for creating
a 3-D layer, as shown in the first image in Figure 22.2. If you
have a 3-D layer selected, the panel changes completely,
listing the objects and materials contained in the 3-D scene as
shown in the second image in Figure 22.2.

Figure 22.2

The 3-D panel can help you create or manipulate a 3-D
object.
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The filter buttons on the 3-D panel are active when you have
a 3-D layer selected, and they enable you to filter your 3-D
layers so that only certain layer types are visible in the 3-D
panel. If you are working with the lights in your 3-D scene,
for example, you can click the Light Filter button, and only
the lights are listed in your 3-D layers.

The 3-D layers are similar to layers in the Layers panel. Each
3-D object has its own layer, and sublayers are added that
include textures, materials, and lights. Just as you need to
select a layer to work with it in the Layers panel, you need to
select the 3-D layer you want to work with in the 3-D panel.
This is true if you want to move it, transform it, or change the
textures placed on it.

Learning about the Properties panel when 3-D objects are
selected

The Properties panel has different faces. This is especially
true when you are working with 3-D layers. The type of layer
that you have selected determines the options that are
available, and there are many types of 3-D layers with
different options. You will learn more about these options in
the next two chapters; for now, we want to show you how the
Properties panel supports the 3-D panel.

Figure 22.3 shows the configuration of the Properties panel
when you select a basic 3-D layer in the 3-D panel and when
you select the material of that basic 3-D layer. The options are
very different, even though you have selected the same 3-D
layer in the Layers panel. The key to using the Properties
panel successfully with 3-D layers is to always remember that
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it portrays the properties of the 3-D layer that is selected in
the 3-D panel.

Figure 22.3

The Properties panel displays the options available for the
3-D layer that is selected in the 3-D panel.

Note

In this chapter, we are giving you a brief overview of the
3-D and Properties panels so that you will understand how
they work together in a 3-D environment. We will use them
consistently and explain them in more detail in the next two
chapters.
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Looking at 3-D objects in the Layers panel

The layers of a 3-D object are more complicated than in most
images. When you open a 3-D object in Photoshop, if that
object contains any textures at all, you have at least one
sublayer listed under a textures heading. On top of that, every
filter you add or edit can be made into a 3-D object that
involves the Layers panel in one way or another. It doesn't
take many changes to add several layers to a 3-D file or
composite. Don't panic yet: like a well-organized filing
cabinet, the Layers panel is a clean and efficient way to
organize your effects and filters.

Figure 22.4 shows the Layers panel after creating a 3-D hat
found in the 3-D mesh presets. The thumbnail of a 3-D layer
is distinctive. It includes the icon of a three-dimensional cube
in the corner in addition to the thumbnail of the actual 3-D
object. This indicates that the 3-D menu is enabled and that
you can use the 3-D tools on this layer.

Notice the sublayers. The primary sublayer is named
Textures. The Textures sublayer is a layer group containing
one or more individual textures that are placed on the 3-D
object. Contained in the Textures layer group is a sublayer
labeled Hat_Material - Default Texture. This layer is the
texture that has been applied to the 3-D mesh to give it
surface area and color. This layer is actually an embedded
file. Double-clicking it opens the default texture layer as a
separate two-dimensional file that you can change and rename
if you want. You can also add more textures to this object,
which show up as additional layers under the Textures
sublayer. You can open and edit each of these textures
individually.
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Figure 22.4

A 3-D layer in the Layers panel is distinctive.

Editing textures is a primary reason to bring a
3-D object into Photoshop. We cover this aspect of 3-D
objects in greater detail in Chapter 23.

Finding the 3-D tools

The 3-D tools are used to rotate, roll, drag, slide, and scale a
3-D object, whether that object is a camera, a light, or a mesh.
Using these tools enables you to take full advantage of adding

1429



3-D objects to your scene or composite, because you can
orient and place them anywhere you want.

You can find the 3-D tools in the Tool Options bar when you
have met two criteria. First, you must select a 3-D layer in the
Layers panel. Second, you must select the Move tool in the
Toolbox. The 3-D tools then appear in the Tool Options bar,
as shown in Figure 22.5. The tools work with the layer that
you have selected in the 3-D panel. You can select the entire
scene, a mesh, materials, cameras, or lights. When you select
any of these layers, the object contained in that layer moves
with the tools. We will show you how to use these tools later
in this chapter.

Figure 22.5

The 3-D tools enable you to manipulate the individual objects
in your 3-D scene.

Using the Picture in Picture window

A useful feature of the 3-D workspace is the Picture in Picture
window. The Picture in Picture window shows a second,
smaller view of your 3-D scene using a different view from
the main window so that you can more easily find your
bearings, a necessary task whenever you are trying to
manipulate a 3-D scene on a 2-D monitor.

When you select a 3-D layer in the Layers panel and then
select the Move tool, the Picture in Picture window appears,
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as shown in Figure 22.6. As you make changes to your scene,
you see those changes reflected in the Picture in Picture
window as well as the main view. The Picture in Picture
window has two icons that enable you to change the view of
the window or to swap the view with the main window.

Figure 22.6

The Picture in Picture window enables you to see two
different views of your scene at the same time.

Opening and Placing 3-D Files in Photoshop
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If you often work with 3-D models, you probably use a 3-D
modeling program that's built to create 3-D objects and is
much better at it than Photoshop was ever meant to be. When
you bring these models into Photoshop, your goal is to do one
of two things: to change the texture of your 3-D file or to
create an image composite using a blend of 3-D objects,
photos, text, and other Photoshop elements.

We've already shown you that a 3-D model is a vector file, or
a mesh, and it doesn't contain any color information. The
texture of a 3-D file is the raster file that is created to wrap the
3-D object in, to give it color, texture, and definition. If you
are bringing a 3-D object into Photoshop to add a texture or
edit the existing texture, you want to open it just like you
open any supported file in Photoshop: Browse to the 3-D file
in Bridge or Mini Bridge, and double-click to open it in
Photoshop.

If you are creating a composite with more than one 3-D object
or other file, you want to place any secondary files into the
first one as new layers. You can do this using the File⇒Place
command, or you can place a 3-D object by choosing
3D⇒New Layer from 3-D File.

Creating 3-D Files in Photoshop

You can create basic 3-D meshes in Photoshop in several
ways: you can use presets to create a quick and basic 3-D
object that doesn't have a texture applied and doesn't use an
image as the texture; you can use the grayscale brightness
values in an image to create a depth map; or you can use
multiple two-dimensional cross-sections to create one 3-D
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object. You can also create unique 3-D objects from vector
paths.

To create a 3-D object in Photoshop, you can use the 3-D
panel shown in Figure 22.7. The 3-D panel is versatile and
easy to access as your base of operations.

Figure 22.7

You can use the 3-D panel to create new 3-D objects.

Note

If you have a 3-D layer selected, these options in the 3-D
menu are grayed out and the panel options are different.
Although you can merge 3-D layers, you can't create more
than one 3-D object on a layer in Photoshop.

Selecting a source for a 3-D object
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When you use the 3-D panel to create a new 3-D object, you
can use the Source menu to select a source for that object.
This gives you the advantage of choosing what part of your
file you will use to create the 3-D object. You can choose
from these sources:

• Selected Layer(s). This option uses only the content of the
currently selected layer or layers to create a 3-D object.

* Work Path. This option enables you to create a 3-D object
from a selected work path. Although you can create other 3-D
objects from layers containing paths (such as turning text into
a 3-D postcard, for example), only a 3-D extrusion can be
created if you've selected this option.

• Current Selection. This option uses the current selection to
create a 3-D object, cutting the unselected areas from your
image entirely. As with the work path option, this option only
creates a 3-D extrusion.

• File. This option uses the entire file to create a 3-D object.
You can use this option if you have an image composite that
you want to wrap around a 3-D preset or manipulate into a
3-D scene.

Creating a 3-D postcard

A 3-D postcard is the simplest form of 3-D object. It is
essentially a two-dimensional image or object that has been
converted to a 3-D mesh so it can be manipulated with the
3-D tools. It maintains its two-dimensional appearance, as
you can see in Figure 22.8, but now you have the added
versatility of being able to quickly manipulate it in 3-D space,
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adjusting perspective or creating a unique look. You can also
use many of the 3-D tools to modify it, including editing its
texture, adding lights, or combining it with other 3-D objects
to create a scene.

Creating a 3-D extrusion

Creating a 3-D extrusion gives you the capability to create a
3-D object using an image or a vector path. The extrusion
properties provide many different options for how your
two-dimensional file is interpreted into a 3-D object.

Figure 22.8

A 3-D postcard is essentially a two-dimensional object that
can be manipulated with the 3-D tools.
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The vector layer can be anything: text, a shape, some clip art,
or your own custom drawing. You can also use an image
layer. The thing to remember is that extruding a drawing of a
complicated object does not look like a 3-D model of that
object. A vector image of a car, for example, is not going to
look like a die-cast model after creating a 3-D extrusion of it.
Instead, it looks more like a mold of a car, with depth, but not
much extra shape to the depth.

Of course, the result depends on the settings you choose, so
you might decide to make a 3-D swirl from the shape of the
car rather than a mold, but the important thing is that you still
are limited when it comes to creating technical 3-D objects.
That being said, creating 3-D extrusions can bring your
Photoshop creations to life and give them new depth.

Follow these steps to see how you can create a new 3-D
object by creating an extrusion from a 2D vector file:

1. Create a new blank document of any size.

2. Create a vector path in the new document.

We suggest you do something simple to start. We typed 3-D.
You could also create a simple shape using the Shape tool.

3. With the new vector layer selected, choose 3-D
Extrusion from the 3-D panel and click Create.

You are warned that the vector layer must be rasterized in
order to create a 3-D object. Click Yes. This turns your vector
layer into a 3-D layer and displays the extrusion properties in
the Properties panel, as shown in Figure 22.9.
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Figure 22.9

The Properties panel displays many options for editing a 3-D
extrusion.

You can see that the Properties panel has five different menus
for editing your extrusion. The Mesh menu enables you to
determine the initial properties of your 3-D object such as the
shape and depth of the extrusion. The Deform menu enables
you to twist, warp, and deform your 3-D object, much like the
transformation tools in Photoshop. The Cap tools change the
surfaces of the 3-D mesh, adding a bevel or inflating the front
or back surface of your object. The Coordinates tools enable
you to set the X, Y, and Z coordinates, angles, and scaling, as
well as adjust the object relative to the ground of the 3-D
scene. The 3-D Paint tools enable you to define several
settings that control the behavior of those tools when painting
on 3-D objects.

Note
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The final icon resembling a cube in the Properties panel is
the Coordinates menu. This menu is available with any 3-D
object and enables you to enter coordinates for your object.
We discuss the Coordinates menu later in this chapter.

Defining an extrusion using the Mesh properties

The Mesh properties are selected in the Properties panel by
default when you create a 3-D extrusion. Changing the mesh
options enables you to define the basic parameters of the
extrusion such as the shadows and shape. There are three
areas in the Properties panel when the Mesh properties are
selected:

• Setting shadows and opacity. These settings enable you to
add shadows and transparency to your 3-D object. When you
create a 3-D object, you generally create a 3-D scene
complete with lights. The presence of lights in your scene
gives you the option to have your object cast shadows within
the scene or catch shadows from other objects placed in the
same scene. You can click the check box next to each option
to enable or disable these shadows; and you can disable the
view of your 3-D object or reduce their transparency using
these options.

• Choosing and modifying a shape preset. This section of
the Mesh menu is defined by a Shape Preset menu that
enables you to create several extrusions, from the mundane
option of simply adding depth to the much fancier option of
creating a twist. Click the Shape Preset drop-down menu to
display these options, as shown in Figure 22.10. Once you've
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chosen an extrusion shape, you can choose a texture mapping
option and use the slider to set the depth of the extrusion.

Figure 22.10

The Shape Preset drop-down menu has different varieties of
extrusions.

• Changing the source file to modify a 3-D extrusion. This
option enables you to change the parameters of the original
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vector file, such as the color or attributes of text. The Edit
Source button returns you to the original file to make changes
that are immediately reflected in the 3-D file.

Transforming a 3-D extrusion using the Deform properties

Deform is the second option in the Properties panel when you
select a 3-D extrusion. The modifications that you can make
to your 3-D extrusion are similar to using transformation
options in Photoshop. You can twist, taper, bend, or shear
your 3-D extrusion until it is hardly recognizable. You can do
this using the Extrusion Depth, Twist, and Taper sliders (refer
to Figure 22.9) or you can use the Deformation widget that
appears over your 3-D extrusion, as shown in Figure 22.11.
Hovering over different areas of this widget highlights them
and displays the highlighted property. Then all you need to do
is click and drag to apply the deformation to your 3-D
extrusion.

Figure 22.11

The Deformation widget enables you to transform your 3-D
extrusion in several ways by clicking and dragging.
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Changing the surfaces of a 3-D extrusion using the Cap
properties

The Cap properties in the Properties panel enable you to
change just the surfaces of the 3-D extrusion, adding a bevel
or inflation to them. Like the Deform properties, you can use
the sliders and settings on the Properties panel, or you can use
the Cap widget to make these changes by clicking and
dragging the correct part of the widget, as shown in Figure
22.12. By using the Sides drop-down list, you can choose to
apply these changes to just the front of your object, just the
back, or to both the front and back.

Note
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Once you have created a 3-D extrusion, you'll notice that the
3-D panel is filled with objects, materials, lights, and
cameras. This is similar to any 3-D object that is open in
Photoshop. These components of the 3-D environment play
a vital role in manipulating and changing the texture of a
3-D object. We cover these topics in Chapters 23 and 24.

Figure 22.12

The Cap widget enables you to make changes to the surface
area of your 3-D extrusion.

Making a 3-D shape from a preset
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Photoshop ships with 12 presets that create 3-D shapes
ranging from basic shapes, such as a cube, to more complex
shapes, such as a wine bottle or a hat. These presets provide
commonly used shapes that you can modify or combine to use
in many different applications. These shapes use the selected
layer as a texture. If you have selected a white background
layer, the object is white. If you fill the background with a
color or pattern, the object has that color or pattern. If you
open or import an image and select that layer when you create
the object, the image wraps around the 3-D object and
becomes the texture, as shown in Figure 22.13.

Note

You can easily edit textures in Photoshop, so if you're not
yet sure how you want to wrap your object, don't let it stop
you from creating it. You can change the texture later.

Figure 22.13

Creating a 3-D shape from an image layer wraps the image
around the new 3-D object.
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Just as with any presets in Photoshop, you can create and save
your own objects as presets. This isn't as easy as clicking a
save preset button, however. You must export the 3-D object
as a DAE (COLLADA) file by selecting the 3-D object in the
3-D panel and then selecting Export 3-D Layer from the 3-D
panel menu. You must save the DAE file to /Program Files/
Adobe/Adobe Photoshop CC (64 bit)/Presets/Meshes (in Mac
OS, Applications/Adobe Photoshop CC/Presets/Meshes). It
then appears in the presets menu with the other shapes, ready
for you to create at any time, as shown in Figure 22.14.

Figure 22.14

When you place a new DAE file in the Meshes folder, it
shows up in the presets list.
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Creating a 3-D mesh from a depth map

Creating a 3-D mesh from a depth map works by creating a
depth map based on the brightness levels of the image that
you are using and turning that depth map into a 3-D object.
Areas of your image that have brightness values that are
brighter than midtone are pushed out, and areas that are
darker than midtone are pushed in. Midtone areas stay on the
original plane. You can see a basic representation of this in
Figure 22.15. We used a simple radial gradient, which created
a smooth depth map.

Figure 22.15

A simple radial gradient makes it easy to see how Photoshop
creates a mesh from a depth map.
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When you create a depth map, you have four options:

• Plane. Creates a depth map centered on the original plane.

• Two-sided plane. Creates a mirror image of the original
depth map.

• Cylinder. Creates a depth map and then wraps it into a
cylindrical shape.

• Sphere. Creates a depth map and then wraps it into a ball.

Note
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Your image doesn't have to be in grayscale mode for this to
work. Photoshop uses the green channel to create a depth
map.

This type of 3-D object is great for creating textures or
another unique look for an image file. You can also use it to
create planes from elevation maps or to save and re-create
planes from one 3-D modeling file to another. A simple
image file can quickly become a mountain range, as shown in
Figure 22.16.

Figure 22.16

Using an image to create a depth map can quickly create
interesting planes.

Creating a 3-D volume

The 3-D volume option is used to create 3-D objects from
several image files that are slices of 3-D objects, such as
DICOM files. Using this option enables you to create a 3-D
object from the image layers that you can move, manipulate,
and view from all angles, which gives you a versatile way to
view these medical images.
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Manipulating 3-D Objects

Imagine that you are standing in a room. As you move in a
straight line from left to right, you are moving along the
X-axis. If you were to jump up and down in place, you would
be traveling along the Y-axis. This is a two-dimensional
plane, in which coordinates can be given with two numbers:
an X location and a Y location. When you work with a
two-dimensional file in Photoshop, you are working with an
XY plane. To add the third dimension, the Z-axis is added,
creating depth to the XY plane. To move along the Z-axis,
you would walk from front to back within the room.

The 3-D tools in Photoshop enable you to move 3-D models
within all three of these planes. If you have already used any
3-D modeling software, you will be familiar with these tools.
Photoshop has designed its manipulation tools to a standard
look and feel. If you have never used 3-D tools, you will find
that they are fun and easy to use. Jumping in and working
with them as we introduce them to you in this chapter is the
best way to quickly become familiar with them.

As you work with your 3-D model, keep in mind that your
final product in Photoshop will be a two-dimensional view,
not a 3-D scene or animation. This helps you keep in
perspective what you can accomplish in Photoshop and how
to do it.

Using the 3-D tools

Using the 3-D tools enables you to manipulate and orient a
3-D object in many different ways so that you can achieve the
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view in which you want to display it, look at it as you add
textures, or place it in a composite.

When you select a 3-D layer and the Move tool, the 3-D tools
appear in the Options bar, as shown in Figure 22.17. You can
use these tools to move your object through 3-D space. They
operate on the 3-D layer that you have selected in your 3-D
panel, enabling you to modify your scenes and composites
quickly and easily.

Figure 22.17

The 3-D tools enable you to rotate, roll, drag, slide, or scale
your 3-D objects.

Tip

It is incredibly difficult to explain moving an object through
3-D space in a book with still shots. The quickest way to
understand what we are trying to teach you is to use the
tools in conjunction with this book. Create a quick 3-D
object by opening a new document, and then choosing
3D⇒New Mesh from Layer⇒Mesh Preset and choosing a
shape from the menu. An irregular shape, such as the hat, is
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the best option for seeing the difference that moving it
makes.

Turning 3-D objects around a central point

Rotating or rolling an object around a central point enables
you to look at all sides of the object without actually changing
its position in the 3-D scene. You'll use these tools to look at
the way a texture has been placed on your object or to display
a different side of your object to view.

Changing an object's orientation is the most obvious reason to
use the Rotate and Roll tools. But you can also change the
lighting on your mesh by rotating the object rather than
moving the light. As you move your object, notice that if you
have a light placed in your scene, the lighting changes on
your object.

Another use for the Rotate and Roll tools is checking the
texture of your object and making sure it is the way you want
it, especially if you made any changes to it in Photoshop. To
do this without changing the orientation of your object, select
the scene layer from the 3-D panel and rotate the entire scene
as a unit.

You can turn a 3-D object around a central point by using
tools to rotate or roll the object. Rotating or rolling an object
turns and skews it around the X-axis, Y-axis, or Z-axis. When
you use the Rotate and Roll tools, your object moves around a
center point, which never changes position.
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Rotating a 3-D object

Using the Rotate tool rotates a 3-D object around the X-axis
and Y-axis. The X-axis is a line running from side to side
through the center of the object. Like a hot dog turning on a
roasting stick, if you rotate your object only on the X-axis, the
top of the object rotates toward you or away from you. The
Y-axis runs up and down through the center of your object.
As you rotate your object around the Y-axis, the sides of the
object move toward you or away from you.

With the Rotate tool selected, click and drag back and forth
across your 3-D object to rotate it along the Y-axis, or drag up
and down to rotate it along the X-axis, as shown in Figure
22.18. You can constrain the rotation to either the Y-axis or
the X-axis by pressing and holding down the Shift key as you
drag in the appropriate direction.

Figure 22.18

Rotating an object around both the X-axis and Y-axis
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Rolling a 3-D object

Rolling your object around the Z-axis is similar to rotating
your object around the X-axis or Y-axis. Visualize a line
running from front to back through the center of your object,
enabling it to roll left to right and back again. You can roll
your object around the Z-axis by clicking and dragging back
and forth with the Roll tool, as shown in Figure 22.19.

Tip

Although you can quickly skip through the 3-D object tools
by repeatedly pressing the K key, you can also press the Alt/
Option key to temporarily change the Rotation tool to the
Roll tool, and vice versa.

Figure 22.19

Rolling an object around the Z-axis
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Moving a 3-D object through 3-D space

Dragging or sliding a 3-D object moves it to a different
location in your 3-D workspace. Moving your object enables
you to place it in the desired position so you can create
composites by adding a photo background or other 3-D
objects. Moving an object also enables you to adjust the
lighting or change the perspective.

Dragging a 3-D object

Dragging moves the object around the XY plane and is
visually similar to using the Move tool to move a selection in
a regular image file. You can drag your object by selecting
the Drag tool in the Options bar or the Toolbox, as shown in
Figure 22.20.

Figure 22.20

Using the Drag tool moves your object to a different position
in the 3-D space.
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Tip

You can toggle between the Drag and Slide tools by
pressing and holding down the Alt/Option key.

Sliding a 3-D object

Sliding moves the object along the XZ plane, so you can
move it side to side, just as you can with the Drag tool, or in
and out along the Z plane. As you move your object toward
you or away from you along the Z plane, it looks similar to
scaling, or resizing, your object, as shown in Figure 22.21.
However, although it looks the same, when working with
3-D, sliding an object is very different from actually making
the object bigger or smaller, just as walking away from an
object in real life doesn't change its actual size, just your
perspective of it.

When you have the Drag or Slide tool selected, you can
change the position of your 3-D object numerically by
entering values in the X, Y, or Z indicators in the Options bar.

Figure 22.21

Using the Slide tool doesn't change the size of your 3-D
object, just your perspective.
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Scaling a 3-D object

You can use the Scale tool to change the size of a 3-D object
so that it blends better with other elements in your document,
whether those elements are other 3-D objects or other types of
layers. Changing the size of your object actually changes its
dimensions (unlike sliding it, which just changes your
perspective of it). A 3-D file is a vector file, so scaling it
doesn't detract from its quality. The textures placed on a 3-D
file are raster files, however, so be careful not to reduce the
quality of these textures by scaling a 3-D file too large.

Scaling a 3-D object in Photoshop is similar to using the
Transform tools to scale an image or selection. By selecting
the Scale tool, you can click and drag across your object to
make it bigger or smaller, as shown in Figure 22.22. As you
change the size of your 3-D object by using the Scale tool, the
proportions of the object are automatically maintained. By
pressing and holding down the Alt/Option key while you
click and drag, you can adjust the object non-proportionally
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by making it taller or shorter. If you press and hold down the
Shift key, you can make your object wider or narrower.

When you have the Scale tool selected, you can change the
size numerically by entering values in the X, Y, or Z
indicators in the Options bar. This is a better way to scale
your object disproportionately. You can also change these
values by scrubbing across the letter that applies to the value
you want to change.

Figure 22.22

Use the Scale tool to make 3-D objects larger or smaller.

Using the 3-D Axis widget

The 3-D Axis widget is used to perform all the manipulation
techniques of the 3-D tools. Using the widget, you can rotate,
roll, drag, slide, or scale your object using the different arms
and handles. Once you get the hang of it, it is faster and more
efficient than continually switching between the standard 3-D
tools. Manipulating your 3-D objects becomes fast and easy.
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The widget has three different-colored arms extending in
different directions, as shown in Figure 22.23. Each arm
represents a different axis or plane:

• Red = X

• Green = Y

• Blue = Z

The end of each arrow has a block, then an arc, and then an
arrow handle. The handles enable you to adjust your 3-D
object along the axis represented by the arm. The block
handle scales the object along the axis, the arc handle rotates
the object around the axis, and the arrow moves the object
along the axis.

As you hover over the handles, your cursor changes to the
Scale, Rotate, or Move tool, as shown in Figure 22.24. Click
and drag to use each tool to make the adjustment.

Figure 22.23

The 3-D Axis widget has three arms that are
color-coordinated to represent the three axes.
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Figure 22.24

Use the handles at the end of the axis arm to adjust your 3-D
object along the axis. The block scales along the axis, the arc
rotates around the axis, and the arrow moves along the axis.

The 3-D Axis widget may not be the easiest tool to use at
first, especially if you want to make small, controlled
movements, but it is certainly the most convenient. With a
little practice, you can make quick, controlled manipulations
without the need to toggle through the 3-D object tools.

Typing in coordinates for your 3-D object

You can also change the attributes of a 3-D object by typing
specific coordinates that change its position, its angle, and its
size. This is a much easier way to manipulate your object, but
only if you know the coordinates that you want to use.
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To change a 3-D object's position by typing coordinates,
select the object layer in the 3-D panel. In the Properties
panel, select the Coordinates menu icon. This displays the
coordinate settings, as shown in Figure 22.25. Type the
coordinates in the appropriate boxes to place your 3-D object
in the correct position.

Figure 22.25

The Coordinates menu in the Properties panel enables you to
specifically place a 3-D object.

Summary

In this chapter, we introduced you to creating and using 3-D
objects in Photoshop. You learned about the following:
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• Working with 3-D file formats

• Understanding the 3-D workspace

• Creating 3-D objects

• Changing the position of 3-D objects
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Chapter 23: Editing 3-D Scenes and Settings

In This Chapter

Using the 3-D panel

Making changes to a 3-D scene

Editing meshes

Working with 3-D materials

Adjusting 3-D lights

When you are working with 3-D scenes and objects in
Photoshop, it is important that you use the 3-D workspace so
that you can maneuver and edit scenes and settings from the
3-D and Properties panels docked right in your work area.
The most important part of the work area is the 3-D panel,
which is similar to the Layers panel because it subdivides
each 3-D object into sublayers that include the meshes,
textures, lights, and cameras that make up the 3-D scene. You
will learn how to recognize and use these layers to change the
look of your 3-D objects and scenes.

As you work with the 3-D panel, you will also be using the
Properties panel extensively to make changes to the layer that
you have selected in the 3-D panel. The Properties panel is
incredibly versatile when it comes to 3-D objects. It can look
completely different depending on what type of layer you
have selected. You will learn how to make the best use of
these options so that you can use the powerful Photoshop
tools to create a fantastic 3-D object or scene.
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Looking at the 3-D Panel

The 3-D panel contains the sublayers that make up a single
3-D layer in the Layers panel. A 3-D object generally consists
of at least one mesh with several materials applied and at least
one light to illuminate it. The 3-D panel enables you to view,
sort, and edit these components of a selected 3-D layer.

The 3-D panel has two basic components: a main area
containing layers and a small header containing buttons,
which enable you to sort layers. Three types of layers are
found in the 3-D panel — the mesh layers, material layers,
and light layers — and they correspond to the filter buttons
shown in Figure 23.1. You can see that each layer has a
distinctive icon so that you can distinguish the layer types
when looking at the 3-D panel.

Figure 23.1

The 3-D panel contains the sublayers that make up a single
3-D layer in the Layers panel.
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Working with a Whole 3-D Scene

When you click the Filter by whole scene icon at the top of
the 3-D panel, you display every option available in your
scene: the meshes, the materials applied to those meshes, and
the lights placed in the scene. This gives you a good overview
of the elements that make up your 3-D object and how they fit
together.

At the top of the layers, you find the Environment layer, the
Scene layer, and the Current View layer. When highlighted,
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these three layers enable you to change properties that affect
the entire 3-D layer and your view of it.

Changing the properties of a 3-D environment

The Environment layer in the 3-D panel represents the
lighting and background in your 3-D scene. You can use the
Environment layer to look at and edit the settings of these
properties. To change the settings of the environment, click
the Environment layer to highlight it. The Properties panel
displays the Environment settings, as shown in Figure 23.2.
The four areas in the Properties panel that you can edit and
adjust are Global Ambient, IBL (Image Based Lighting),
Ground Plane, and Background. Each of these areas enables
you to change specific settings that can add natural light or
create special lighting effects.

Figure 23.2

When you select the Environment layer in the 3-D panel, the
Properties panel displays the properties of the lighting and
background of the 3-D environment.
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Changing the Global Ambient light

The Global Ambient light is the light that naturally exists in
the scene. Double-click the Global Ambient Color swatch to
change the color of the reflective surfaces in your 3-D scene.
This light doesn't cast any direct light or shadows, but it can
add a cool or warm tone to your scene.
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Using Image Based Lighting

Image based lighting, or IBL, enables you to add a gel
lighting effect to your scene. You can create and load images
to create an effect similar to placing a transparency over a
light to change its color and effect. Double-click the folder
icon next to the IBL image thumbnail to create or load a
texture. The texture can be a color, a pattern, or even a photo.

Note

The icon next to the IBL image thumbnail is a folder icon
before an image has been loaded and an image icon after, as
you can see in Figure 23.3.

The settings in the IBL area also enable you to control the
intensity and the shadows cast by the IBL that you are using.
Figure 23.3 demonstrates the effect that using a pattern for the
IBL has on a rendered stopwatch.

Figure 23.3

Using a pattern to create a lighting texture over this stopwatch
gives it an interesting texture and shadows.
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Adjusting the Ground Plane properties
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You can adjust the Ground Plane properties to change the
way that the ground plane in your scene catches shadows and
returns reflections. Just as in real life, different materials on
the ground create different lighting effects. For example, the
ground on a dark, wet night catches fewer shadows but has
very reflective surfaces.

You can change the color of shadows and reflections. Setting
the opacity determines how well they show up in the rendered
image. You can also change the roughness of the reflection to
add texture to it as if it is being cast on a rough surface.

Changing the Background settings

The Background settings enable you to place an image in the
background of the 3-D scene. This is one way to create a
composite with images and 3-D objects. Double-click the
image icon to create or browse to an image to place behind
your 3-D object. The image is placed so that it fits — not fills
— the canvas of your 3-D scene. For this reason, it is easier to
create composites by placing a 3-D object in an image file
rather than using this option.

Setting the properties of a 3-D scene

The Scene layer in the 3-D panel enables you to create a
cross-section of your 3-D object. This can come in handy
when you want to look inside a 3-D object or intersect that
object with something else, or if you need only part of an
object in a scene. The other properties of the Scene layer
represent the way the 3-D objects are rendered while you
work with them. The simpler the 3-D scene is displayed, the
faster you can work with it in Photoshop. You can see the
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Properties panel with the Scene layer selected in Figure 23.4.
We have selected the Cross Section check box so that you can
also see the options for creating a cross-section.

Figure 23.4

The properties of a Scene layer enable you to control the way
you view your 3-D scene.
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Creating cross-sections

A cross-section is created by cutting into a 3-D object and
looking into it. Cross-sections have several uses, enabling you
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to look inside 3-D models or to use just a portion of a model
in a composite. Cross-sections are great for use with
architectural renderings, for example, enabling you to see
inside the models of 3-D buildings. In Figure 23.5, we cut the
roof off a simple room to show you the interior. You can see
that this could be a valuable application for looking at or
editing more complex buildings or furnished rooms.

Figure 23.5

This room had a roof before a cross-section was created.

You can also use cross-sections to cut down any 3-D model
for use in a composite. You can intersect a cross-sectioned
object with another object or image, or you can just use the
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cut-down version of an object. By using two instances of the
same 3-D model, you can open a previously solid object, such
as a box, by creating matching cross-sections.

To begin, click the Cross Section check box in the Properties
panel with a Scene layer selected. Additional cross-section
options appear in the Properties panel. Your 3-D object is cut
exactly in half along the X-axis, as shown in Figure 23.6.
Using the settings, you can create a cross-section on any
plane, position it anywhere on your object, and tilt it from
side to side or back to front.

Figure 23.6

Clicking the Cross Section check box starts you out by cutting
your object exactly in half.
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When you create a cross-section, you can set the following
options:

• Slice. Use this menu to select one of the listed axes to
change the cross-section to that axis. The room in Figure 23.5
is cut along the Z-axis, while the balloon in Figure 23.6 is cut
along the X-axis.

• Offset. Use this menu to enable a cross-section to cut your
3-D object in half. By changing the offset, you can move that
dividing line to cut off more or less of your object.
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• Tilt. Use these settings to change the angle of the
cross-section. By default, the angle of the cut is parallel with
the base of your object. Tilt Y changes the angle of the
cross-section front to back, and Tilt Z changes the angle side
to side.

• Plane. Select this check box to create a plane that is a visual
aid showing you exactly how the cross-section is cutting your
object in two. You probably want to keep the plane visible
while you are adjusting the settings for your cross-section in
order to have a guide for what you are doing. You can also
change the color or opacity of the plane.

• Opacity. Use this slider to increase or decrease the opacity
of the plane.

• Intersection. Select this check box to outline the areas of
the object that have been affected by the cross-section. You
can change the color of the outline by clicking the color box
and selecting a new color.

• Side A/Side B. Click these icons to view either side of your
cross-section.

• Flip. Click this icon to specify which half of the object to
show. If we had checked this option when we created the
cross-section for Figure 23.5, we would have seen the roof of
the house instead of the floor.

Changing the render properties

When you select the Filter by whole scene icon, the layers in
the 3-D panel are headed by a layer labeled Scene. When you
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select this layer, the render settings are active in the
Properties panel (refer to Figure 23.4). You can adjust these
settings to view your 3-D scene at varying qualities and speed
up your processing time. As with all the best options in
Photoshop, a preset menu contains several options as well as
the ability to customize the settings just the way you want
them.

Using the render presets

Whenever you bring a 3-D object into Photoshop or even
create a new 3-D object from the Photoshop presets, the
render settings are already customized based on the settings
that were specified previously for that object. Most of the
time, these are higher-quality settings, giving you the best
preview of the object but using a lot of computer resources.
While you are positioning objects and creating scenes, you
may not want to wait a long time to preview the finished
object. Choosing a less-complicated render saves you time.

We wish we could tell you that the render presets were in
order from the least to the most complicated, but the list is in
alphabetical order, as shown in Figure 23.7. Most of the
render settings are self-explanatory, and clicking each one
gives you a preview. The simplest setting, Bounding Box,
creates a bounding box framing your 3-D object and turns off
the visibility of the actual object. This is the fastest and
easiest render, giving you maximum capability when it comes
to movement. Other settings fall in the middle, rendering your
object as a wireframe or shaded object. Figure 23.8 shows an
example of three render settings.
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Note

It goes without saying that the more powerful your
computer is, the better you can work with 3-D objects that
have been rendered at higher settings. The render setting
you use is based on your computer power as well as your
personal preference for viewing your objects.

Figure 23.7

The render setting presets give you many options from
simplistic to realistic.
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Figure 23.8

The more complicated the render, the more time it takes to
manipulate and edit it.

Editing the render settings

You can customize any of the render presets by using the
other settings provided in the Properties panel. These options
enable you to customize how your 3-D objects are rendered
so you can create the perfect balance between processing
speed and best view.

These options can be selected in conjunction with one
another, depending on the settings you choose. For example,
you can choose an unlit texture for the surface and create a
wireframe over it by selecting the Lines option. These are the
main options available in the 3-D Render Settings dialog box:

• Surface. These settings determine how the surfaces on your
3-D model appear. You can choose from several face styles
that include everything from the texture that has been placed
on the model to a simple paint mask. If you choose Unlit
Texture, you can use the texture option to change the way the
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texture looks. Other options are available with other face
styles.

• Lines. These settings enable you to adjust the look of your
object's edges. You can make them bolder or add more edges
by increasing the crease threshold. A basic wireframe is one
of the best options for viewing your object efficiently while
manipulating it.

• Points. These options enable you to view and make changes
to the way the vertices appear on your object. Vertices are the
points made by the junctions of the polygons that make up the
frame of the 3-D model.

Changing the Current View

The last layer to appear exclusively in the Whole Scene view
of the 3-D panel is the Current View layer. This layer enables
you to change the camera settings of your 3-D scene,
adjusting the angle at which you view your 3-D scene and
setting lens properties such as depth of field. You can also
create a finished image that can be viewed in 3-D with 3-D
glasses by changing the Stereo settings. To change your
settings, click the Current View layer in the 3-D panel to
highlight it and then change the Properties panel to the
Current View settings, as shown in Figure 23.9.

Figure 23.9

The properties of the Current View layer enable you to make
changes to the camera settings.
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Setting the view

You can change the view of your 3-D scene by changing the
position of the 3-D camera. To change the position of the
camera in the 3-D scene, click the View drop-down menu.
You can choose to position the camera in one of several
places such as the top or the back of the 3-D scene. This
immediately changes your view of the scene, and Photoshop
uses this view to create the final render.

Changing the perspective

The next area of the Custom View properties enables you to
change the perspective of the 3-D object. Changing the
perspective of your 3-D object helps you to create composites
by matching the perspective of your 3-D object with either an
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image or the surrounding 3-D scene. There are two types of
perspective settings:

• Perspective. These settings enable you to change the
perspective of the view so that it matches an image or other
objects that you are using to make a composite. FOV stands
for Field of View. You can change the field of view by
degrees horizontal, degrees vertical, or by changing the size
of the lens on your 3-D camera. This enables you to change
the view to match a photographic background that was shot
with a specific lens.

• Orthographic. This view is just a fancy way of setting the
scale of the 3-D object in proportion to the surrounding 3-D
space. You can scale the view so that the object is larger or
smaller within the scene.

Adjusting the depth of field

The Depth of Field options enable you to create blurriness in
your 3-D image based on the depth of field of the lens of your
3-D camera. This setting enables you to blend a 3-D object
better with a photographic image taken at a particular depth of
field.

Creating a stereo image

If you want to render your 3-D object so it can be viewed
with 3-D glasses, choose the Stereo option and select a Stereo
View setting. The options you have to choose from are
Anaglyph, Lenticular, and Side by Side. The Anaglyph
setting creates a 3-D image that can be seen using dual lens
glasses, with red and green lenses, or red and blue lenses. The
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Lenticular setting creates an image that is composed of strips.
Every other strip should be seen by the right eye, while the
in-between strips should be viewed by the left eye. Glasses
are not used for Lenticular 3-D; the image or video is
displayed on a corrugated screen. Side by Side 3-D uses two
images to create the illusion of 3-D. Two images appear side
by side, and an anamorphic viewer is used.

Working with Mesh Layers

The 3-D mesh is the actual object — no textures, no lights,
just the edges and vertices that make up the shape and form of
the object. To make changes to the properties of a mesh, you
must select the mesh layer in the 3-D panel. Some objects
have more than one mesh. If your 3-D object has several
meshes along with other layers, click the Filter by meshes
icon at the top of the 3-D panel to display only the mesh
layers. This makes it easier to see and select the meshes you
need to edit.

By selecting an individual mesh, you can manipulate it and
edit its properties. When you select a mesh layer, the
Properties panel displays the properties that you can adjust for
the mesh, as shown in Figure 23.10.

Figure 23.10

You can change the properties of a mesh when you select the
mesh layer in the 3-D panel.
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The sword shown in Figure 23.11 contains five meshes.
These meshes include the blade, the grip, the guard, the
ricasso, and the pommel.

Figure 23.11

This 3-D sword contains five different meshes.
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Each individual mesh has properties that you can change.
These properties have to do with the visibility of the actual
mesh and the shadows it casts. To change these properties,
select any one of these meshes from the 3-D layers and
change these settings:

• Catch Shadows. This option enables your object to catch
shadows that are cast by other objects in your scene. In order
for your object to catch shadows, you must place at least one
light in your scene.
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• Cast Shadows. This option enables your object to cast
shadows. In order for your object to cast shadows, you must
place at least one light in your scene.

• Invisible. This option turns off the visibility of the selected
mesh, but leaves the shadows cast on the surface of the mesh
behind.

Note

You can rename a mesh, or any other 3-D layer, by
double-clicking its name.

You can move and manipulate individual meshes using the
3-D tools that appear in the Options bar when you select both
the mesh layer and the Move tool in the toolbox. To use these
tools, hover over the mesh that you want to manipulate with
the selected tool. A bounding box appears around the mesh,
as shown in Figure 23.12. Click and drag to make changes to
the mesh.

Figure 23.12

You can manipulate the sword's guard by hovering over it
with the Rotate tool until the bounding box appears.
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Note

When you select the Move tool, you can use the widget to
manipulate meshes as well. You can also click the
Coordinates button in the Properties panel to open the
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coordinates interface and type in precise coordinates for the
mesh.

Editing the Textures and Materials of a 3-D Object

You can apply several texture maps to each mesh associated
with your object. These texture maps control the color,
texture, and highlights of your object. Taken together, these
textures constitute the material associated with a particular
mesh. When you have several meshes in a 3-D scene, you
also have several materials associated with that scene. When
you have a materials layer selected in the 3-D panel, you
work closely with the Layers panel to change the appearance
of your object.

Figure 23.13 shows the 3-D panel along with the Layers panel
associated with the wine bottle that can be created from the
3-D presets. You can see that three textures and three
materials are associated with the bottle. This is deceptive.
You might think that by having the same names that they are
the same thing. However, we will take you through a couple
of exercises to not only demonstrate the difference between
them, but also show you how you can make changes to them.

Figure 23.13

The 3-D panel lists the materials associated with your 3-D
object, and the Layers panel lists the textures.
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Editing textures

Textures are embedded layers in your 3-D object. You can
edit a texture by double-clicking the layer in the Layers panel.
This opens the image file used to create the texture. You can
then make changes to the image file and save it, and the
changes are immediately reflected on your 3-D object.

The label on the wine bottle created using the Wine Bottle
preset is empty. You can make a custom label by following
these steps:

1. Create a new document in Photoshop.

We created an 11 x 8.5, landscape paper-sized document with
a white background.

2. Double-click the background layer to change it to a
regular layer, and change the name of the layer to Label.

Note

It isn't necessary to change the layer from a background
layer to create a 3-D object, but you want to change the
name of this layer, so it must be changed to a regular layer.

3. Use the 3-D panel to create a new shape from a preset.

Choose Wine Bottle, and then click Create. The wine bottle
shape appears, using the white background color for the label
and leaving a transparent background, as shown in Figure
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23.14. The white background used to create the label is now a
sublayer in the 3-D object named “Label.”

Figure 23.14

Starting with a white background, we created a blank label on
the wine bottle.
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4. Double-click the Label sublayer.

A new document opens in Photoshop. It looks just like the
document you started with in Step 1.
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5. Place an image file, add text, create shapes, and paint to
your heart's content.

Use all the tools in Photoshop to create a fabulous label. You
can see ours in Figure 23.15.

Figure 23.15

You can create a label by double-clicking the Label texture
layer and editing it.

6. Press Ctrl+S/ +S to save your changes to the label and
update your 3-D file.
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You can close the label file, or just click the tab of your 3-D
file to return to it. You see your new label wrapped around
the bottle, as shown in Figure 23.16.

Tip

You probably want to leave the label file open long enough
to make sure it looks the way you want it to. After all, it
looks different on the bottle than it does as a flat document.

Figure 23.16

After you save your label, it is updated in your 3-D document.
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You can continue to make changes to the bottle and cork
textures. When you open these files, you might be surprised
to see that they are completely transparent; there is no color
information at all. That's because their color and texture are
being created in the Properties panel. We show you how in
the next section.
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Editing materials

Even with a nice label applied, the wine bottle is still a little
flat and in need of work. Editing the materials to add color,
texture, and dimension will make it look more realistic. The
cork and bottle both get their color from the Material settings
in the Properties panel. If you select the cork layer, the
Properties panel displays the Material settings for that layer.
You can see that Material settings are already applied to it.
We could open the texture layer to apply a cork texture, but
let's see if we can't make it look good by just using the
Material settings.

Change the Material settings by following these steps:

1. Select the Cork_Material layer from the 3-D panel.

You see the Properties panel change to reflect the cork's
Material settings, as shown in Figure 23.17.

2. Click the material picker to open it, as shown in Figure
23.18, and find thumbnails of available material presets.

Choose Wood Cork, and then click anywhere else in the
screen to close the material picker. The settings all change to
reflect the wood cork presets. The cork already looks
100-percent better!

Figure 23.17

You can edit the cork Material settings in the Properties
panel.
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Figure 23.18

A quick switch to the Wood Cork material makes a big
difference in the way the cork looks.
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3. Select the Glass_Material layer.

Again, the settings change. There is no preset in the material
picker that meets your requirements here, so you have to
create your own.

4. Change the settings of the glass material.
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You can change the following settings:

• Diffuse. This is the heading that all the textures are placed
under in the Layers panel. The diffuse texture is the primary
color or texture of the selected material. The diffuse texture of
the bottle is green, but the diffuse texture of the label is the
one you created. You can click the Edit the diffuse texture
icon next to the diffuse color and choose Open Texture to
open the texture file, just as you did from the Layers panel,
and edit it. In this case, you want to change the color of your
bottle to a deeper green.

• Specular. This setting determines the color of the specular
highlights on your object. The specular highlights are the
areas that are so reflective that they don't contain color
information. These highlights are shown only in the color that
you choose, not in any of the other colors placed in the
materials of your object.

• Illumination. This setting enables you to create an inner
glow. Click the color to change the color of the light. Black
creates no illumination whatsoever, and white makes your
object glow so brightly that it's transparent.

• Ambient. This setting sets the color of the ambient light.
This isn't a dramatic change, but it can give your object a
warmer or cooler look or slightly change the color.

• Shine. This setting determines how sharp the highlights are
on the object. A shininess of 100 percent creates the sharp,
clean highlights characteristic of glass. The shine can also be
applied to specified areas using a grayscale map.
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• Reflection. This setting determines the reflectivity of your
object. The glass is highly reflective, so it is set by default to
100. You can also apply reflection maps to your object to
make some areas more reflective than other areas.

• Roughness. This setting enables you to add roughness to
your object to give it texture and to reduce the reflectivity.
You can add a roughness map with this setting.

• Bump. This setting enables you to use grayscale values to
create a bump map that simulates texture on your object. You
don't want to add one of these to the glass material, but if you
select the Cork_Material layer again and open the bump
texture, you see the texture shown in Figure 23.19.

Figure 23.19

A bump map is also created by using a grayscale image.
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• Opacity. This setting changes the opacity of the material.
You can set a universal opacity by using the slider, or you can
load or create an opacity map. An opacity map uses grayscale
values to determine the opacity of the materials. White creates
100-percent opacity and black is completely translucent, with
different shades of gray being everything in between. By
creating the opacity map shown in Figure 23.20, we changed
the opacity of the top of the bottle, making it look a little
more like translucent glass while giving it the appearance of
only being partially full of liquid.

Note

Most of these options have icons to the right that enable you
to edit them. If the icon looks like a folder, a map has not
been applied. If the icon looks like a document, a map has
been applied. Clicking this icon gives you a list of options to
create, load, edit, or delete the applied map.

Figure 23.20

You can change the relative translucency of your object using
an opacity map.
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Tip

When you create a new map for any one of these settings,
make it the same size as the object you are mapping it to so
you can be sure to get specific details correct. For example,
the document from which we created our wine bottle was
the Default Photoshop size, so we created our maps to be the
same size.

• Refraction. This setting changes the way light refracts
through your scene. A setting of 1 approximates the refraction
you get when light passes through air. You see a difference in
this setting only in a final render.

• Normal. This setting uses a Normal map, which is a texture
map that simulates texture just like the bump map, but it is
much more versatile because it is based on the RGB values
rather than just grayscale values.
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• Environment. This setting uses an Environment map as a
spherical panorama of the environment around the object.
You don't actually see the Environment map around the
object. Instead, you see a reflection of the environment in
areas of your image that are reflective.

Creating and Modifying 3-D Lights

The bottom filter in the 3-D panel displays the light layers.
When you select a light layer, the Properties panel displays
the light settings, as shown in Figure 23.21. Whether you
create a model in Photoshop or import a model from another
source, Photoshop places a default infinite light in your scene.
Without these lights, you can't see the details of your object; it
appears very dark.

Figure 23.21

The Properties panel displays the properties of the selected
light layer.
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Besides the infinite lights, you can add two other types of
light to your scene: point lights and spotlights. Each type of
light is contained in its own group in the light layers. As you
add additional lights, they appear under their particular light
group. You can select a light to make changes to it or
double-click it to change its name.

When you select a light layer, you can see that light in the
document window placed in your 3-D scene, as shown in
Figure 23.22. Using the 3-D tools, you can move and scale
your light just as you can any 3-D object contained in your
scene.

Figure 23.22

When you have a light layer selected, the light is visible in
your 3-D scene.
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Adding new lights

Adding a new light is as simple as clicking the Add new light
to scene icon at the bottom of the 3-D panel. A drop-down
menu opens, and you can choose the type of light you want to
add. You can choose from the following types of light:

• Point. This type radiates light in all directions from the light
placement, creating the same effect as a light bulb would have
on the scene. Objects and surfaces that are closer to the light
are brighter than those that are farther away. You can move a
point light anywhere in your scene using the Light tools, but
because it is useless to rotate it, that option is not available.

• Spotlight. This type of light can be pointed in a specific
direction. The light emanates in a conical shape from the
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source, so the closer the object is to the light, the tighter and
more concentrated the light is.

• Infinite. This type radiates light uniformly from a single
plane toward your 3-D scene. Infinite light simulates the sun
shining from a specific direction. Like the sun, infinite lights
have a consistent intensity, so any surface that is hit directly
by this light is lit with the same intensity, even if the surfaces
are different distances from the light source. You can rotate
infinite lights around your 3-D scene.

Positioning lights

After you have created lights, you can manipulate and move
them around your scene so you can create the lighting effects
you want. You can position the lights using the 3-D tools
found in the Options bar when you select the Move tool in the
Toolbox.

Tip

It is extremely important that you position your object the
way you want it to look before you take too much time
positioning your lights. When you move your object, your
lights stay where they were placed, changing the light
settings on the object. If you do want to view your object
from a different angle without changing the light settings,
use the Camera tool to change your view of the object. This
creates the illusion of changing the position of the object as
well as the lights.
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You can also use the Properties panel to change the position
of lights using the following settings:

• Point Light at Origin. Use this button to rotate the light in
place so it is pointed directly at the center of your 3-D scene.

• Move to Current View. Use this button to move the light to
the exact position of the camera you are using to look at the
scene, showing the source of the light and illuminating the
face closest to you.

Changing the properties of a 3-D light

With a light layer selected in the 3-D panel, you can change
the light setting in the Properties panel. These settings are
available to you:

• Preset. This menu enables you to choose a lighting preset
that imitates everything from the soft lights of dawn to the
exciting, colored lights of Mardi Gras. You can also create
your own light settings and add them to the presets using the
Save Lights Preset option in the 3-D panel menu.

• Type. This menu enables you to change a selected light
from its current type to any other type of light. For example,
if you have an infinite light selected, you can change it to a
spotlight using this option.

• Color. This option opens the Select Light Color dialog box
when you click the color box. You can then choose the color
of your light. Obviously, changing the color of your light
greatly affects the color of the materials applied to your
object.
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• Intensity. This option increases the intensity or brightness
of the selected light. The default settings for newly created
lights are fairly low. If you want to get a strong lighting
effect, you can increase the intensity.

• Shadow. This option enables you to select a light that
causes your objects to cast shadows in your 3-D scene. If you
have multiple lights applied to a scene, you may want only
one or two to actually cast shadows so your scene is not busy
with them.

• Softness. This option lets you choose how diffuse the
shadow of a selected light is.

The following properties are only available when using a
spotlight:

• Hotspot. This setting determines how intense the light of
the spotlight is in the center.

• Cone. This setting determines the size of the light cone,
creating a small, hot spotlight or a larger, more diffuse light.

• Falloff. This setting determines how fast the center of the
spotlight fades to no light at all.

• Inner and Outer. These settings determine how much the
intensity changes with distance.

Summary

This chapter covered most of the changes you can make to the
look of your 3-D object with the 3-D settings. The 3-D panel,
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combined with the Properties panel, is an incredibly versatile
tool that enables you to make different kinds of changes to
several aspects of your 3-D scene, giving you a lot of creative
potential in changing the look of your 3-D scene. You learned
about the following:

• Exploring the 3-D panel

• Rendering 3-D scenes

• Changing the meshes on 3-D objects

• Editing and adding new materials to 3-D objects

• Adding and changing the lights in a 3-D scene
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Chapter 24: Using Photoshop Tools with 3-D Layers

In This Chapter

Painting 3-D objects

Adding image adjustments to 3-D objects

Creating great composites

The previous two chapters discuss how the 3-D workspace in
Photoshop functions to enable you to create, manipulate, and
change the look of 3-D objects by changing their color,
texture, and lighting. In this chapter, we show you how to
integrate 3-D objects into the Photoshop workspace, using the
tools you are probably more familiar with to paint over your
3-D objects and create adjustments, styles, and filters.

The last section of this chapter walks you through some
complex exercises that demonstrate some of the tools and
techniques that you can use to create a successful composite
with 3-D objects and images. At this point, you should be
familiar with all the techniques used to create these
composites, but completing these exercises gives you practice
using these tools and shows you how they can work together.

Using 3-D Paint Mode

You can grab a paintbrush in Photoshop and start painting a
3-D object. The paint conforms to the 3-D object because
even though you are looking at the 3-D object, you are
changing the texture file, which is wrapped around the 3-D
object. This gives you the distinct advantage of being able to
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change areas of the texture as it is mapped to your object,
instead of trying to guess where to paint in a flat, rectangular
texture file.

In addition to color, you can also paint texture, shine, opacity,
and reflection onto a 3-D object. This makes the 3-D Paint
tool a versatile way to change the materials of the 3-D object.

Before we show you how to use the 3-D Paint tool, we show
you options for selecting areas of your object to paint on and
hiding areas of your object that you want to protect. These
options in Photoshop are definitely a little rough around the
edges (literally as well as figuratively); still, they can be
useful.

Hiding areas on a 3-D object

You can create selections on a 3-D object using the Selection
tools just as you can with a two-dimensional image. The
problem is that the selections you create are two-dimensional,
and they don't conform to the 3-D object. You can see in
Figure 24.1 that, after creating a selection around the hat, we
moved the hat, but the selection didn't move with it. You can
use the Selection tools to make changes to a 3-D object, but
be sure that your object is placed just how you want it to be
viewed, because the changes don't extend to unseen areas of
your object.

Figure 24.1

The Selection tools are two-dimensional, and so rotating the
object does not adjust the selection.
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However, you can use the Selection tools to select paintable
areas of your object or to hide areas that you want to protect.
These tools are also affected by the fact that selections are
two-dimensional. You can't simply select an area of your 3-D
object and hide it or paint onto it; you are limited by the way
the two-dimensional selection interacts with the 3-D object.
This becomes apparent as you use the following tools to hide
areas of your 3-D object.

Use the Selection tools to select the area of your model that
you want to hide, and choose any one of these options from
the 3D⇒Show/Hide Polygons menu bar:

• Within Selection. This option hides all the polygons that
are enclosed within the selected area. Notice in Figure 24.2
that not all of the selected area disappears, only the complete
polygons within the selected area.

1510



• Invert Visible Surfaces. This option swaps the currently
visible polygon areas with the areas that are hidden, so you
can make changes to the opposite areas.

• Reveal All Surfaces. This option displays any areas that are
hidden.

Figure 24.2

Within Selection protects hidden areas as well as revealing
new ones inside the selection, whereas Invert Visible Surfaces
reverses visibility to the opposite, outside of the selection.

Painting on a 3-D object

One of the most versatile tools in Photoshop is the paintbrush,
which you can use to add color, erase pixels, and apply
effects to images. Using the Brush tool, you can directly paint
onto 3-D object textures. So, are you ready to paint on your
3-D object? Then grab a brush and let's start painting.

Looking at the 3-D Paint Properties panel

Photoshop provides a panel specifically for painting on 3-D
textures. Figure 24.3 shows the 3-D Paint Properties panel.
When this panel is active, you can adjust the following
settings for painting on a 3-D object:
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• Paint On. Setting this option controls the paint texture
mode. We describe the paint texture modes later in this
chapter.

• Paint System. Selecting this option toggles between
Texture and Projection painting.

• Paint Falloff. Setting these options adjusts the Min and
Max Paint falloff (the angle at which paint dissipates when
striking the 3-D surface).

• Select Paintable Area. Selecting this option creates a
selection around the paintable area. This is extremely useful,
as it allows you to see the areas that you can paint on the 3-D
object.

• Shadows. Setting this option enables shadows created by
the 3-D object to be rendered in the view.

• Unlit. Setting this option disables lighting in the rendered
view, enabling you to paint without the distraction of
highlights, bumps, and other effects created by the lighting.

• UV Overlays. Setting these options toggles the UV overlay
on and off and also sets the color and opacity used for the
overlay. The UV overlays are wireframe representations of
the texture surfaces of the 3-D objects.

Figure 24.3

Setting options in the 3-D Paint Properties panel
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Understanding 3-D painting methods

Photoshop provides several different methods for painting on
3-D objects. Each method has advantages and disadvantages;
for example, some methods have better flexibility, whereas
others provide faster performance. Having the ability to
switch between these different painting methods enables you
to be more versatile in the way you edit your 3-D images.

The first thing you need to determine when painting on 3-D
objects is what method you want to utilize. Photoshop
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provides the following four painting methods, each giving a
different degree of flexibility versus performance.

Live 3-D texture painting

The most versatile painting method is the live 3-D texture
method, which involves opening the 3-D document as well as
the texture view. When you paint in the live 3-D texture
mode, brush strokes made on the texture view also update live
as you drag the mouse during each paint stroke. Due to its
versatility, this is the default method in Photoshop.

The following steps walk you through the process of using the
live 3-D texture method to paint live on a 3-D layer:

1. Load or create a 3-D model in your primary document.

2. Choose 3D⇒Paint System⇒Texture from the main
menu in Photoshop or select Texture for the Paint System
setting in the 3-D Paint Properties pane.

3. From the Layers panel, double-click a texture in the
3-D object to open a texture document that you can paint
on.

For example, in Figure 24.4 we have opened the soda 3-D
object and double-clicked the Label_Material texture.

Note
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If you don't see the Textures list under the layer in the
Layers panel, expand the layer by clicking the triangle
button to the right.

4. Choose Window⇒Arrange⇒Tile to see both the 3-D
and texture documents on the screen at the same time.
You can also use other arrangement methods if you prefer as
long as you can see both documents.

5. Select the Paintbrush tool and configure the settings.

6. Paint on the texture document and watch the paint
strokes show up in the 3-D document as shown in Figure
24.4.

Tip

The triangular lattice shows the cylinder's 3-D geometry
map to the texture. You can toggle it on and off using the
Ctrl+H/Cmd+H hot keys when you have the texture
document selected.

Layer projection

Layer projection offers all of the performance of 2-D painting
with the accuracy of projection painting. This method has the
advantage of providing higher-quality results; however, it
requires you to do a projection or merge before you can do
any 3-D operations such as rotation or scene settings.

1515



To use the layer projection method, create an empty layer
above your 3-D object that you will actually do the painting
in. Then apply whatever painting effect you like to that layer.
When finished, merge the new layer with the paint in it into
the 3-D layer below it. Photoshop then projects the paint into
the appropriate textures based on the Texture Target you have
selected.

Note

It is important that you do not change the camera, move the
object, or apply any other 3-D operations to your 3-D layer
before merging the painted layer down into the 3-D layer.

Projection painting

This method of painting offers the advantage of being able to
paint in multiple textures at the same time, which is very
useful when trying to paint over the seam between two
different texture maps. However, this method sometimes
results in cracks in the paint, especially for 3-D objects with
complex or dense geometry.

To enable projection painting, choose 3D⇒Paint
System⇒Projection from the main menu in Photoshop. You
can also enable projection painting from the 3-D Paint
settings in the Properties panel when painting on a texture.

Figure 24.4
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When using the Texture Paint System, you can paint on a
texture document and see the brushstrokes on the 3-D
document.
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Unlit painting

Photoshop also enables you to paint on your 3-D objects in an
unlit mode, meaning that the lighting in your scene is
removed from the rendering. This enables you to see the
textures wrapped around your object. Having no lighting,
shadows, or bumps enables you to effectively match colors,
sample colors, or see textures other than diffuse wrapped on
your object.

To enable unlit painting, select the scene in the 3-D panel.
Then open the Properties panel and select Unlit Texture
render mode under the Style drop-down menu. This disables
the lighting while you are painting.

Using painting texture types

There are several additional options that you can choose from
when using the Brush tool. These options enable you to use
all of the functionality of the different brush tips to apply
diffusion, specular color, roughness, reflectiveness, and many
more aspects of the 3-D textures. You can control and adjust
each of these behaviors in the Materials section of the
Properties panel when you select a 3-D object in the 3-D
panel. To select the 3-D paint behavior, choose 3D⇒Paint on
Target Texture in the main menu bar and choose one of the
following options:

Note
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Photoshop requires a separate texture for each different
effect that you want to paint on an object. For example,
Photoshop requires a diffusion texture to paint diffusion on
the object. If a texture of the type you are trying to paint
does not exist in the 3-D object, then Photoshop prompts
you to add the texture.

• Diffuse. This option enables you to paint color onto the 3-D
object.

• Bump. This option enables you to add depressions and
bumps to your 3-D object. You can adjust the intensity of the
bump painting in the Properties panel. The darker the paint on
the bump texture, the deeper the depression in the 3-D object
surface.

• Specular Color. This option enables you to paint on the
color that is displayed as part of the specular textures, such as
shine and reflectiveness. This can be especially useful if you
are trying to add shadow effects to a highly reflective 3-D
object.

• Opacity. This option enables you to use the paintbrush tools
to apply opacity to the texture of the 3-D object. If you think
about all the things you can do with a paintbrush, you can get
some really cool effects, especially if you are working with
objects that have ambiguous surfaces such as clouds, smoke,
or fire.

• Shininess. This option enables you to use the paintbrush to
apply shine to the 3-D object. This is a great feature for
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adding effects such as surfaces that are half painted or
polished.

• Self-Illumination. This option enables you to paint on
lighting that doesn't require the background light object in the
3-D scene.

• Ambient. This option enables you to paint on the color that
is used for ambient light visible on reflective surfaces of the
object. This color interacts with whatever global ambient
color is set for the entire scene.

• Reflection. This option enables you to paint a reflectivity
texture on the object. This is great for adding effects such as
cars that are partially dirty, or dust on a mirror.

• Roughness. This option enables you to add roughness to the
texture of a 3-D object; the darker the paint color, the rougher
the area. The airbrush tips work great with this option to add
irregular texture to skin or rocks.

• Depth. This option enables you to add depth to the texture
by adjusting levels and contrast in the area.

Painting color on a 3-D object

In this example, we take you through the process of painting
on a 3-D object to make it more realistic. The cello in Figure
24.5 has blank textures, so we want to liven it up by adding
some color. You can use the following steps to add color to
the body of the cello:

1520



1. Open the 3-D panel to the material section and make
sure the cello body is selected, as shown in Figure 24.5.

2. Open the Properties panel and set Paint On to Diffuse.

3. Set Paint System to Texture.

4. From the Layers panel, shown in Figure 24.5,
double-click cello_body_cellowood.tga – Default Texture
to display the texture document.

5. Select the Paintbrush tool.

6. Select a dark-brown color and a hard, fan brush.

7. Make sure both the cello 3-D object document and the
texture document are visible at the same time.

8. Drag the Brush tool over the texture document to add
color to each texture surface, as shown in Figure 24.5.

As you drag your brush, the color is applied to the cello body
in the 3-D document. You have the freedom to make big, bold
strokes that completely fill the cello with paint because any
paint outside the lines in the texture document are not applied
to the 3-D object.

Figure 24.5

Opening the cello body texture from the Layers panel and
using the Texture paint mode in the Properties panel enables
you to paint on a separate texture document and see the
results on the live 3-D document.
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The brown is much better than the white, but it still doesn't
look much like the texture of the wood that you would see on
a real cello. You can add wood grain to the surface to make it
more realistic using the following steps:

1. Choose a bristly, angled brush to create some wood
grain on the surface of the cello.

2. Select a lighter brown color to create a deeper wood
grain.

3. Paint strokes down the vertical axis of the cello body.

This time, you have to be much more careful with your
paintbrush, creating straight, clean strokes that don't overlap.
The finished effect looks more like wood, as you can see in
Figure 24.6.
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You can open the texture file by clicking the cello body layer
in the Layers panel or by clicking the Edit the Diffuse Texture
button in the Materials section of the Properties panel (refer to
Figure 24.3) and choosing Edit Texture from the drop-down
menu.

Figure 24.6

Adding a second layer of paint makes the cello look more
realistic.
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Painting textures on a 3-D object

Now we show you how to take painting a 3-D object beyond
color. From the 3-D menu, you can choose any one of the
different textures to paint on. Follow these steps to see how
it's done:

1. Create a 3-D shape from a layer in Photoshop.

The sphere is a good shape for this exercise because the
texture isn't tiled, and the changes you make to it are not
duplicated in other areas of the sphere. Figure 24.7 shows the
basic sphere.

Figure 24.7

The sphere uses the texture map only once around it, so your
changes appear only in the area where you make them.
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2. Choose 3D⇒Paint on Target Texture⇒Bump.

Now as you paint directly onto your object, you make
changes to a bump map.

To learn more about the different types of texture
you can apply to your 3-D object and how to edit the texture
files, see Chapter 23.

3. Open the material section of the 3-D panel and select
the sphere material.

4. Open the Materials section of the Properties panel, and
click the Edit the Bump Texture button next to the bump
setting.

From the drop-down menu, select New Texture, as shown in
Figure 24.8.

Figure 24.8

Create a new bump texture to paint to.
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5. Choose the brush that suits your needs, and drag over
your 3-D object.

The paint is applied to the bump map, which adds depth
rather than color to your object, as you can see in Figure 24.9.

Figure 24.9

Painting on the bump map changes the extrusion of the
object.
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You can quickly see the merits of being able to paint directly
on your object in this manner. Placing your brush strokes
exactly where they need to be on the texture to get the effect
you want is incredibly easy. You can continue to make
changes to the different textures of your object in this manner,
simply by choosing the texture you want to change in the 3-D
menu.

Note

If the texture you choose to paint on (glossiness, opacity,
and so on) has not already been applied to your object, you
can either create a new texture in the material section of the
3-D panel as we had you do with the bump texture, or
simply drag your brush over your object. After you've tried
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to paint into a texture that doesn't exist, Photoshop creates
that texture for you.

Adjustments, Layer Styles, and Filters

You can also change the look of a 3-D object the same way
you can change the look of any image — using adjustments,
layer styles, and filters over the entire object. Especially when
you use 3-D objects in composites, you'll want to use these
tools to create just the right look. This isn't as straightforward
as working with an image file, so we show you how it works.

Note

You should not confuse using adjustments, layer styles, and
filters on a 3-D file with using these tools on a texture map.
The texture maps attached to a 3-D file are image files and
can be adjusted in the time-honored method that is always
used to adjust image files in Photoshop. This section focuses
on applying these tools to a 3-D layer.

Applying an adjustment to a 3-D layer

You can apply an adjustment to a 3-D layer in much the same
way as you would apply it to an image file and for much the
same reason. Often, as you adjust the light and color of the
diffuse texture, you find that after it has been applied to a 3-D
object, it looks much different than it did as an image. It's
much darker, for one thing. Applying an adjustment that
changes the look of the light or color directly to the 3-D
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object is often the solution to getting just the look you want
without having to go back and forth between the 3-D file and
the texture file, trying to adjust the light and color.

Tip

If you are making adjustments to just your 3-D object layer,
be sure to clip the adjustment layer to your 3-D object layer
using the Clip to layer icon at the bottom of the Properties
panel. This ensures that the adjustments are applied only to
your 3-D layer and not any other layers in your document.

Learn more about adjustments and adjustment
layers in Chapters 10 and 13.

Of course, these changes are made unilaterally to your 3-D
object, unlike the more subtle changes that you can make by
adding and changing lights or making changes to individual
texture maps. Another caveat to adding adjustments to a 3-D
layer is that you must add the adjustments through an
adjustment layer. The adjustments in the Image menu are not
available for a 3-D object. If you want to add these
adjustments, you must do one of two things:

• Rasterize your 3-D layer by choosing either
Layer⇒Rasterize⇒3D or Layer⇒Flatten Image from the
Photoshop main menu bar.
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• Turn your 3-D layer into a Smart Object layer by choosing
Convert to Smart Object from the Layers panel menu. We
discuss 3-D layers as Smart Objects later in this chapter.

Adding a layer style to a 3-D layer

Applying a layer style to a 3-D object is a wonderful way to
add an effect that can't be achieved using the 3-D textures. It
is easy to add elements such as an inner glow, drop shadow,
and stroke outline to your 3-D object and spice up the way it
looks. The best thing about using layer styles on a 3-D object
is that the style is reapplied each time you move your object,
so creating a stroke around the cone in Figure 24.10 didn't
leave behind a cone-shaped outline when we changed the
angle of the cone. This is true for all the layer styles.

Figure 24.10

Layer styles are instantly reapplied every time you manipulate
your 3-D object.
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The layer styles are added as effects sublayers right along
with the textures, as shown in Figure 24.11. You can change
the settings of the styles that are applied by double-clicking
any of the Effects layers to open the Layer Styles dialog box.

Figure 24.11

Layer styles appear as sublayers of your 3-D object layer.

The layer styles are covered in Chapter 10.

Applying a filter to a 3-D layer
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Applying a filter to a 3-D layer is trickier than adding an
adjustment or layer style, but there are benefits. The effects of
a filter look different after the texture has been wrapped
around your 3-D object, and you can preview the filter in real
time if you add it directly to your 3-D object.

Furthermore, if your texture is tiled onto your 3-D object,
adding a filter to the texture makes the tiling apparent. When
you add the filter directly to your object, it doesn't matter how
you apply the texture; the filter is applied uniformly to the
entire object.

You can add a filter directly to a 3-D object, but it affects
only the visible surfaces. If you move your 3-D object after
applying a filter, you see the filter's effects end, as shown in
Figure 24.12.

The best way to add a filter to a 3-D object is to change it to a
Smart Object. That shouldn't surprise you, because turning
your layers into Smart Objects is the best way to add filters to
them, no matter what type of layers they are. After you've
turned your 3-D layer into a Smart Object layer, you can add
filters to it just as you would a Smart Object layer created
from an image or any other kind of layer. These filters still
affect only the visible surface, but when you open a Smart
3-D Object and move it, the filter is reapplied to the new
visible surfaces.

You can learn all about filters and Smart Filters in
Chapter 20.

Figure 24.12
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We applied the Watercolor filter to the sphere and then
rotated it a little. You can see the watercolor effect come to an
abrupt stop.

Using 3-D layers as Smart Objects

To create a Smart Object from a 3-D layer, right-click it and
choose Convert to Smart Object from the menu. This converts
the 3-D layer into a Smart Object and changes the icon on the
thumbnail from the 3-D layer icon to a Smart Object icon, as
shown in Figure 24.13. Now you have texture and effect files
embedded inside a 3-D object layer, which is embedded
inside a Smart Object! It sounds complicated, but it gives you
versatility in the changes that you can make (and then change)
to your 3-D object.

Figure 24.13

When you create a Smart Object from a 3-D layer, the icon on
the thumbnail changes.
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After you've turned your 3-D layer into a Smart Object layer,
you can apply Smart Filters that show up as (yes, another set
of) sublayers. You can also add adjustments directly to your
object and use the transformations found in the Edit menu,
including the Puppet Warp.

A Smart Object layer gives you the best of both worlds. You
can still make changes to your 3-D scene by using the 3-D
Transformation tools to manipulate it, adding lights and
textures, and doing anything else you want to do. Simply
double-click the Smart Object layer, and your 3-D layer opens
as a separate file that you can change. These changes are
immediately updated to the main file, even before you save
your 3-D layer file (save it before you close it, of course).

You can also open the texture files from the 3-D layer file,
just as you always could. The changes you make to these files
are also updated in both the 3-D layer file and the Smart
Object file.
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Now that you understand how to work with 3-D objects as
3-D layers and as Smart Objects, you are ready to use these
versatile files to create fantastic composites.

Creating Composites

Now that you've gone over the basics, you can get started
with the fun stuff! You are familiar with the tools that help
you create fantastic images in Photoshop. Until now, we have
showed you the basics of working with 3-D objects. Now we
take you through some exercises that put several of these
techniques together to create composites using images and
3-D objects. This gives you a chance to walk through a few
examples before you venture out on your own. These
examples are step-intensive, but they include several different
techniques so you can see how those techniques work
together. When you're finished, you'll have a better
understanding of the fantastic things that you can do with a
3-D model in Photoshop.

Flying a carpet over the desert

The following example shows you how to create a flying
carpet over the desert. Because several different exercises go
into creating this composite, we take you through them one at
a time, with each exercise building on the last one so you can
do them in more manageable parts. These exercises will help
you understand how to use 3-D objects and tools to add visual
effects to a 2-D image.

Creating a 3-D rug
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The first exercise is to create a 3-D rug. You do this using the
3-D extrusion feature. The following steps take you through
the process of creating a 3-D rug from the extrusion of a
simple vector rectangle path:

1. Create a new blank document in Photoshop.

Tip

You'll find out quickly that working with 3-D objects in
Photoshop is a memory-intensive process. Because these
objects are vector files and can be resized without losing
quality, it's best to start with a small file. Smaller files save
you time and ultimately frustration. Remember, however,
that the textures applied to these files are raster files. You
may want to create larger textures, even when the actual 3-D
file is small.

2. Use the Pen tool to draw a rectangle in your document,
as shown in Figure 24.14.

Press and hold down the Shift key while you are drawing so
the lines are perfectly straight. After closing the rectangle, use
the Direct Selection tool to make the last line of your
rectangle straight, if needed.

Figure 24.14

Draw a rectangle to create a 3-D rug using 3-D extrusion.
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3. Choose 3D⇒3D Extrusion from Selected Path to
convert the rectangle to a 3-D object.

4. Select the Shape layer in the 3-D panel.

5. Click the Mesh button in the Properties panel and
change the depth to 0, as shown in Figure 24.15.

6. Click the Cap button in the Properties panel and create
a bevel that gives the rug a nice edge, as shown in Figure
24.15.

The numbers you use to create this edge will vary, depending
on the size of your rug.

Figure 24.15
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The 3-D extrusion option gives depth and adds a bevel to
your rectangle.

7. Double-click the texture diffusion layer.

Because you created a bevel, you have two layers; choose the
one that is not labeled “Extrusion.” This opens the rug's
texture for you to edit.

8. Use the Paint Bucket tool to fill the texture with color.

We used a deep maroon, but it's your rug, so be creative!

9. Click the Layer Styles icon (fx) at the bottom of the
Layers panel.

10. From the Layer Styles menu, choose Pattern Overlay.

This opens the Layer Styles dialog box.
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11. Click the down arrow next to the pattern thumbnail to
open the pattern selector.

Choose a pattern for your rug. We used the metal landscape.
Don't forget to click the little black arrow in the pattern
selector to open the pattern menu, where you can find
additional pattern presets. The metal landscape pattern is
found in the pattern presets.

12. Change the opacity and scale of the pattern so your
rug looks good.

These settings depend on the size and color of your rug.

13. Try different blend modes until you find one that you
like.

We chose Multiply. Click OK to close the Layer Style dialog
box, shown in Figure 24.16.

14. Save the texture document and return to the 3-D
model of the rug using the tab in the document window in
Photoshop.

Leaving the texture document open enables you to quickly
return to it to make changes if you find that you don't like the
way the 3-D object looks.

Figure 24.16

Adding color and a pattern makes the texture look more like a
rug.
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Tip

Our rug was very dark after applying the color and pattern
overlay. If your image is too dark, try adding a Levels
adjustment layer over the 3-D layer to brighten it.

15. Rotate and roll your rug until it sits at an angle as if
it's coming in for a landing, as shown in Figure 24.17.

16. Save your rug file and close it.

Figure 24.17

The rug is stiff as a board, but it is angled for a landing.
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Note

To keep these steps simple, we didn't add extra steps in
creating this rug that you could very well use to make your
rug look fantastic. For example, you can add a bump map to
give the rug a woven texture or you can add lights to create
dimension. Because the rug is a flat object, we are going to
take a shortcut in the next steps and create a drop shadow
rather than using the ground plane, but you can experiment
with the ground plane to see if you can create the shadow
that way.

Placing the flying carpet into an image

Now that you are able to create 3-D objects using the
extrusion functionality in Photoshop, you are ready to start
placing them into other images to enhance scenes. Follow
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these steps to create a flying carpet that any kid would want to
ride on:

On the Web

You will find the image file as well as the project file you
need to complete this exercise saved as Figure 24.18 on the
book's website.

1. Open Figure 24.18 from the website.

The photo, shown in Figure 24.18, works great for what you
want to do because it has large surfaces to work in.

Figure 24.18

This desert is about to get more lively.
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2. Choose File⇒Place.

3. Browse to the rug file you created in the last exercise,
and click OK.

4. Place the rug in your image file, and scale it to fit the
image.

5. Click the check mark in the Options bar to accept the
placement.
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6. If you need to make adjustments to the 3-D file, such as
changing the angle of the rug, double-click the Smart
Object thumbnail in the Rug layer to open the 3-D file and
make those changes.

Save the changes, and return to the image document. We
changed the angle of the rug, as shown in Figure 24.19.

Figure 24.19

It would be great if every 3-D object that you placed looked
just right, but it's easy to change it by opening the original
file.

7. With the Rug layer highlighted, choose Edit⇒Puppet
Warp.

8. Placing pins and using the mesh, change the rug to look
more like a soft fabric, as shown in Figure 24.20.
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Give it wrinkles, and make it look like it's traveling through
the air. This is a fun step, so play around and give your rug
personality!

9. Click the check mark in the Options bar to accept the
changes.

Note

Notice that the Puppet Warp is added as a Smart Filter? That
means that you can return and edit it whenever you want.

Figure 24.20

The Puppet Warp tool is a great way to give your rug the
illusion of motion as well as personality.

Adding details to complete the flying carpet composite
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It's all about the details, isn't it? Especially in Photoshop, the
details can make an okay image look like a great composite.
You can add details to the image to give it that final touch.
The following steps take you through the process of adding
lights and shadows to enhance the realism of 3-D objects:

1. Double-click the Smart Object thumbnail in the Rug
layer to open the 3-D object.

2. From the Lights section of the 3-D panel, click the Add
New Light icon and select Spot Light to add a spotlight to
the rug scene.

Angle it so that it lights the rug from the same direction where
the sun is shining in the photo.

3. Save the changes, and exit the 3-D file.

4. With the Rug layer highlighted, click the Layer Styles
icon in the bottom of the Layers panel and choose Drop
Shadow.

5. Set the spread and size depending on the brightness of
your background image.

The bright image used in this exercise creates hard shadows,
so set the spread and size to a smaller value. Hard suNL1ight
makes hard shadows.

6. Click OK to exit the Layer Styles dialog box.

7. Right-click the Drop Shadow sublayer, and choose
Create Layer.
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Click OK when you see the following warning: “Some
aspects of the Effects cannot be reproduced with Layers!”

8. Highlight the Drop Shadow layer.

9. Inside the image, use the Move tool to drag the shadow
below the rug to rest on the ground.

10. Reduce the opacity of the shadow layer to match the
opacity of other shadows in the image.

Your final result should be similar to Figure 24.21.

Tip

Depending on the angle of sunlight in your image, you may
want to rotate, scale, or even warp the shadow to make it
look more realistic. With the Drop Shadow layer selected,
choose Edit⇒Transform.

11. With the Rug layer highlighted, click the Layer Styles
icon in the bottom of the Layers panel and choose Stroke.

12. Set the size, position, blending mode, and opacity to
create a solid border that outlines the rug.

13. Click OK to exit the Layer Style dialog box.

Figure 24.21

Light and shadow give the rug a realistic dimension in this
image.
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The steps you took to create a flying carpet follow a precise
order. It's important to transform the rug by turning and
warping it before creating the drop shadow. After the drop
shadow has been separated into its own layer, it no longer
mimics the changes made to the rug. In fact, you can make
changes to the Drop Shadow layer separately.

These effects are just a sampling of several things that you
can do. Play around with your file, and see if you can add
even more realism to it. As with anything else you do,
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balancing the amount of time you spend with the effect you
create is the key to being efficient.

Look at the Layers panel shown in Figure 24.22. You've
created quite an array of layers. They are well organized and
easy to understand, especially after you create them yourself.
Take a moment to edit them or reorganize them if you are still
not fully familiar with how they work.

Figure 24.22

The Layers panel shows a neat array of effects.
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Giving the moon away

Now let us show you an example that uses different
techniques. In this exercise, you create cross-sections and
place more than one instance of an object in a file. You also
place a second 3-D object in the same file. You can make a
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present of the moon by following the steps in the following
sections.

Creating a gift box

A great feature of Photoshop is its ability to modify and
manipulate 3-D objects. A great way to do this is by creating
a cross-section and dividing the object. The following steps
take you through the process of starting with a simple 3-D
box, cutting it in half to make a separate lid, and then adding
an image texture to give the box a wrapped effect:

On the Web

Find the files you need to do this exercise on the book's
website. They are saved as Figures 24.23 and 24.25.

1. Open Figure 24.23 from the website.

This is a PSD file of a 3-D box with a lid, as shown in Figure
24.23.

Figure 24.23

Start with a 3-D image of a box with a lid.
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2. Open the 3-D panel to the Scene section, and select the
Scene.

3. Change the following settings in the Properties panel:
check Cross Section, click Flip Cross Section, uncheck
Intersection, set the offset to +12, and click Z-axis.

You are left with the lid of the box.

4. Rename the layer Lid by right-clicking the layer and
selecting Layer Properties.

5. Choose File⇒Place, browse to Figure 24.23, and click
Place.

6. Click the check mark to accept placement.

7. Double-click the thumbnail in the Figure 24.23 layer.
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When you are reminded to save, click OK.

8. Open the 3-D panel to the Scene section.

9. Change the following settings: check Cross Section,
uncheck Intersections, click Z-axis, and set the offset to
11.

You are left with the bottom of the box, minus the lid.

10. Use the 3-D Manipulation tools to place the bottom of
the box so you can see into it.

11. Save the changes, and exit the file.

12. Rename the Figure 24.23 layer Box by right-clicking
the layer and choosing Layer Properties.

13. Use the 3-D Manipulation tools to tilt the lid so it looks
like it is being opened, as shown in Figure 24.24.

Figure 24.24

You can open the box by creating cross-sections of both
halves.
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14. Double-click Diffuse in the lid texture in the Layers
panel of the Lid layer to open the texture.

15. Choose File⇒Place, browse to Figure 24.25
(downloaded from the website), and click OK.

This file is a pattern created from an image of a nebula, as
shown in Figure 24.25.

Figure 24.25
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This image was created using the Pattern Maker, a plug-in
filter available from Adobe.

16. Stretch the pattern to fill the texture of the box.

17. Click the check mark in the Options bar to accept the
placement of the pattern.

18. Save the changes to the texture, and close the texture
file.

The lid of the box now has a new texture.

19. Double-click the thumbnail in the Box layer.

When you are reminded to save, click OK.
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20. Double-click Diffuse in the box texture of the Box
layer in the Layers panel to open the texture.

21. Repeat Steps 16 to 20 to add the texture to the main
part of the box.

22. Save this file, and close it.

In these steps, you used the Cross Section tool to create and
place the same 3-D object in a file twice, and you added
texture to both parts of that object. Your result should be
similar to Figure 24.26. Now you are ready to create the
moon.

Figure 24.26

The box is complete.
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Creating the moon

In this section we take you through the process of applying a
mapped image to a sphere to create a 3-D moon object. Then
we take you through the process of adding lighting to give it a
realistic effect. Use the following steps to create a 3-D sphere
object that closely resembles the moon:

On the Web
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Find the texture of the moon saved on the book's website as
Figure 24.27.

1. Browse to Figure 24.27, and open it.

2. Double-click the Figure 24.27 layer, and rename the
layer Moon.

This converts the background layer to a regular layer and
gives it a descriptive name.

3. Use the 3-D Shape Preset in the 3-D panel to create a
sphere from the layer.

You see a representation of the moon, as shown in Figure
24.27.

Figure 24.27

Creating a sphere from the texture map of the moon
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4. Open the 3-D panel to the Lights section.

5. From the Light Preset drop-down menu in the
Properties panel, select Blue Lights.

6. Click the Layer Styles icon (fx) in the Layers panel, and
choose Inner Glow.

7. Adjust the settings to give the moon a nice glow.

You can see our settings in Figure 24.28.

Figure 24.28
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The moon isn't the moon without a glow. Use the layer styles
to create one.

8. In the Layer Styles dialog box, select Outer Glow.

9. Adjust the settings to give the moon a nice outer glow.

10. Click OK to exit the Layer Styles dialog box.

11. Save your file.

Making a present of the moon

Now that you've created two 3-D object files, let's add them
to an image file to make a complete composite. Follow these
steps to create a composite that gives the moon away as a gift:
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On the Web

Find the image used in this composite saved on the book's
website as Figure 24.29.

1. Browse to Figure 24.29, and open it.

2. Choose File⇒Place, browse to the 3-D file of the box
you created earlier, and click OK.

3. Position and size the box in the file however you'd like,
and click the check mark to accept placement.

Our results looked like Figure 24.29.

Figure 24.29

The box needs a mask to make it work inside this photo.

4. Note the areas that need to be masked, and then hide
the box by clicking the eye icon.
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5. Using the Selection tool of your choice, select the areas
that need to be masked, as shown in Figure 24.30.

Figure 24.30

Creating a selection of the areas that need to be masked

Tip
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We created a jagged selection along the edge of the box as
well as a selection around the face to take away the sharp
edge that should have been sunk slightly into the carpet.

6. Choose Select⇒Inverse.

Note

You can, of course, select the areas that you want to be
shown rather than the areas to be masked. Then there is no
need to invert the selection.

7. Click Refine Edge in the Options bar.

8. Adjust the settings to refine the edge of your selection.

9. Choose Output to Layer Mask and click OK to close the
Refine Edge dialog box.

10. Drag the mask from the Image layer to the Box layer.

11. Click the eye icon to restore the Box layer to view.

Your box is masked into the photo.

12. Choose File⇒Place, browse to the file of the moon, and
click OK.

13. Size the moon to fit in the box, and click the check
mark to accept placement.
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14. Drag the Moon layer to the top of the Layers panel,
placing it on top of the box.

15. Set the moon inside the box.

16. With the Moon layer highlighted, click the
Rectangular Marquee Selection tool and create a selection
that includes everything in the Moon layer that is above
the box, as shown in Figure 24.31.

Figure 24.31

Create a selection to mask the moon into the box

17. Click the Mask icon in the Layers panel to create a
mask from the selection.
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The moon is placed into the box. Your finished product
should look like Figure 24.32.

Figure 24.32

A realistic composite created with an image, 3-D objects, and
cool Photoshop tools

You can see that even the most rudimentary 3-D objects can
become very interesting by using Photoshop tools to enhance
them. Just imagine what you can do with more elaborate 3-D
models.

On the Web
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If you would like to see the final PSD file used to create
Figure 24.32, you can find it on the book's website as Figure
24.32.

Summary

In this chapter, you learned some of the advanced techniques
for working with 3-D objects, how to use the Photoshop tools
to change them, and how to successfully add them to
composite images. You learned how to do the following:

• Use the 3-D paint tools to paint textures directly onto a 3-D
object

• Use adjustment layers, layer styles, and filters on a 3-D
object

• Create composites using images and 3-D objects
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Part VIII: Working with Video and Animation

IN THIS PART

Chapter 25

Understanding Video Editing Basics

Chapter 26

Animating in the Timeline Panel

Chapter 27

Correcting Video Files and Adding Artistic Effects

Chapter 28

Animating Using Frames
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Chapter 25: Understanding Video Editing Basics

In This Chapter

Dealing with aspect ratios

Using the Timeline panel

Opening video files

Trimming video clips

Rearranging video footage

Splitting video clips

Deleting unwanted video footage

Adding files to a video project

When working with video, Photoshop enables you to bring in
pieces of video that need the special Photoshop touch and
clean them up a bit. Photoshop does not enable you to create
an extensive video project like Adobe Premiere Pro. With
Photoshop, you can create fantastic composites with video
files that you may not be able to accomplish in fine
Photoshop style anywhere else. The Timeline panel gives you
just enough capability to make working with video files an
efficient and relatively uncomplicated process.

The first step in being able to edit your video files in
Photoshop is to understand the video workspace. The
Timeline panel is practically an application all by itself,
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giving you the ability to add, edit, and move video clips not
only as layers but also through time. You can also add other
layers, such as image files, text, and 3-D objects. In this
chapter, we show you how you can open, add, and maneuver
these files within a video timeline so you are prepared to
correct lighting and color and create artistic effects with video
files and image files.

Working with Video Files

To work with video successfully, you need to know the basics
of video file formats, why they are different, and how they
work. Some file formats are of higher quality and,
consequently, larger than those of lower quality. You must
also understand aspect ratios. Photoshop has more
possibilities for changing the aspect ratio than you might
think. Using the right aspect ratio and understanding the
settings are important to creating successful video files within
Photoshop.

Review the basics of video file formats in
Chapter 3.

Setting aspect ratios

An aspect ratio is the relative width to height of a video or
image. The frame aspect ratio indicates the ratio of the video
or image frame. You are probably familiar with the 4:3 and
16:9 aspect ratios that are industry-standard television sizes.
The next step in getting to know all about pixels is
understanding the pixel aspect ratio.
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Correcting the pixel aspect ratio

Individual pixels also have aspect ratios. Depending on the
video standard, pixels have either a square aspect ratio or a
rectangular aspect ratio. A computer monitor, for example, is
usually set up for square pixels.

Televisions do not have square pixels. Their pixels match the
aspect ratio of standard video, which is rectangular. That
means that when you play a movie on your computer that is a
standard video format, the video is distorted unless you take
the pixel aspect ratio into account and adjust it.

If needed, when you import a video file into Photoshop, it
automatically performs a pixel aspect ratio correction on the
document, so it appears just as it would on a television screen.
This reduces the preview quality of the document, but it is
only for preview purposes and doesn't change the document
materially in any way, as shown in Figure 25.1.

You can turn off Pixel Aspect Ratio Correction and preview
the video with all the pixels intact. The image looks distorted,
but it actually contains the correct number of pixels. Simply
choose View⇒Pixel Aspect Ratio Correction to toggle the
correction on or off. Figure 25.2 shows an image with this
feature turned off.

Figure 25.1

When Pixel Aspect Ratio Correction is turned on, the image
looks normal.
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Figure 25.2

The pixel aspect ratio is correct for a television, but distorted
on a computer monitor.

1572



Note

You can view both pixel settings at once by choosing
Window⇒Arrange⇒New Window for (document name).
This opens a second window containing your document.
You can correct the pixel aspect ratio in one and leave the
correction off in the other.

Changing video aspect ratios

Aspect ratios such as 4:3 and 16:9 are industry standard. You
are probably less familiar with pixel aspect ratios, which is
what Photoshop uses. The Photoshop preset aspect ratios
enable you to translate pixel aspect ratios into more familiar
terms. The number listed in parentheses is the relative height
of the pixel to a width of 1. For example, D1/DV NTSC (0.9)
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has a pixel aspect ratio of 1 pixel wide and .9 pixels high,
making it slightly wider than it is high.

Here's a list of the pixel aspect ratios:

• Square. This is the pixel aspect ratio found in most
computer monitors, as they have square pixels. Some video
made for a 4:3 screen ratio is also captured at 640 x 480,
making the pixels square.

• D1/DV NTSC (0.91). This is a standard capture ratio for
pixels, with a pixel ratio of 720 x 480. Standard 4:3
televisions and video cameras both generally have this
setting. Figure 25.3 shows an example of this aspect ratio.

Figure 25.3

A pixel ratio of 1:0.9 creates nearly square pixels and is just
right for a 4:3 frame.
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• D1/DV PAL (1.09). This is the standard pixel aspect ratio
used for 4:3 screens. The PAL pixel ratios create a pixel that
is taller than it is wide. PAL is the video format used in most
countries outside North America.

• D1/DV NTSC Widescreen (1.21). This is the common
pixel aspect ratio for an NTSC 16:9 screen. Most video
cameras also shoot in this aspect ratio.

• HDV 1080/DVCPRO HD 720 (1.33). This is the standard
pixel aspect ratio for big-screen movies and is becoming more
popular with higher-quality video cameras. The frame size is
1440 x 1080 pixels for the highest-quality setting. The screen
size used for this pixel aspect ratio is 16:9.
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• D1/DV PAL Widescreen (1.46). This is the common pixel
aspect ratio for PAL 16:9 screen.

• Anamorphic 2.1 (2). This pixel ratio — obviously more
rectangular than the others — should be used only if your
footage was shot with an anamorphic lens. An anamorphic
lens creates wide pixels that condense to be shown at 4:3 or
16:9 aspect ratios.

• DVCPRO HD 1080 (1.5). This pixel ratio is used in a video
ratio of 16:9. It has a high-quality pixel level. Figure 25.4
shows an example of this aspect ratio.

Figure 25.4

A pixel ratio of 1:1.5 creates rectangular pixels.
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You can create a custom pixel aspect ratio by choosing
View⇒Pixel Aspect Ratio⇒Custom Pixel Aspect Ratio. This
opens a dialog box that allows you to name your custom ratio
and set the height of the pixel (with the width equal to 1).
Remember that you are setting only the preview ratio,
however, so no matter what you see, your video plays back on
a television at its normal aspect ratio. Figure 25.5 shows an
example of an unusual aspect ratio.

It is important to understand pixel aspect ratio, but if you are
wondering whether you are in over your head, don't worry too
much. When you open a video file, the pixel aspect ratio is
automatically set to the aspect ratio at which the video
footage was shot. As long as you are editing just one aspect
ratio, you should be okay. When it comes to adding an image
to your video footage, however, you may want to correct its
aspect ratio to match that of the video.

Figure 25.5

Although this video looks compressed in Photoshop, this is
just a preview setting, so it plays back normally on a 4:3
television.
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Correcting the aspect ratio of an image

You can add as many images to a video file as you want. The
video file can even be set to the correct aspect ratio. When
you place an image that doesn't fit the aspect ratio, any part of
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the image that doesn't fill the frame of the video is
transparent, as shown in Figure 25.6.

You can solve this problem in one of two ways: you can
create a background for all the images that are placed in the
video, or you can create a background for each image. Either
way, you need to create an image document that has the right
pixel aspect ratio.

Figure 25.6

A tall image set in a 16:9 aspect ratio shows transparency in
the areas that the image doesn't cover.

You can create a document in Photoshop with the correct
pixel aspect ratio for your video file by following these steps:

1. Choose File⇒New to open the New dialog box.
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2. From the Preset drop-down menu, choose Film &
Video.

This creates several presets for your document and gives you
several more menu options, as shown in Figure 25.7.

Figure 25.7

The Film & Video preset in the New dialog box allows you to
set the aspect ratio and resolution of your video file.

3. Choose the size of your video footage from the Size
drop-down menu.

4. From the Pixel Aspect Ratio drop-down menu, choose
the pixel aspect ratio you want for your footage.
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5. Click OK.

The default settings created by the Film & Video preset are
standard for most video files. If you want to create an HD
video, you can change the number of pixels and the resolution
to a higher quality, of course. You can also change the color
settings and background contents, among other things. The
important thing is to create a document that's the same size
and pixel resolution as the video you are trying to create.

After you click OK to create the new document, Photoshop
reminds you that it has just turned on the Pixel Aspect Ratio
Correction for this document because it assumes that the
document will eventually be part of a rendered video file.

A document you create with the Film & Video presets looks
different from the usual Photoshop document. Notice in
Figure 25.8 that guidelines are added to the blank canvas.
These guides don't print or show up on your video; they
indicate the safe zones in the video file. As long as you
contain your action within the outside bounding box and your
text within the inside bounding box, you won't lose any of the
important pieces of your video to a television that cuts out the
edges of the video and enlarges the center.

Note

The safe zones indicated by the guidelines are only relevant
when you are creating an analog video. When you are
creating or viewing digital video, the full image is
displayed.
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Figure 25.8

The Film & Video presets give you guides for placing and
editing your video.

Note

If you are creating a video for the web, you probably chose
the square pixel settings, which means you don't have to
turn on the Pixel Aspect Ratio Correction. You can
disregard the guides as well, because computer monitors
play the entire video without cropping the edges.

You can now place an image in this document. You can also
create a neutral background that you can place in the video

1582



file as a separate layer behind any photos that you place in the
video file.

Using video filters

Video filters reduce noise in a video file by removing static
(lines) in moving video and preventing oversaturation and
bleeding of colors. You can use video filters on video or
image files that you will place into video files. To access the
video filter options, choose Filter⇒Video from the main
menu bar.

De-Interlace

Interlaced video is created by generating every other line of
video in one pass and then filling in the missing lines in the
second pass. De-interlacing can clean up the appearance of
video by removing either the odd or even lines and filling
those lines in by either duplicating or interpolating the
existing lines. The difference can be dramatic, especially on a
computer monitor that has a high enough quality output to
catch the variable scans. Figure 25.9 shows the same frame
before and after de-interlacing.

Figure 25.9

The first image is fuzzy, and you can see the image echo. The
second image has been de-interlaced and is much clearer.
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Choose Filter⇒Video⇒De-Interlace to open the De-Interlace
dialog box shown in Figure 25.10. You can select whether to
use the odd or even lines of the video file and whether to use
duplication or interpolation for filling in the gaps.

Figure 25.10

The De-Interlace dialog box gives you options for
de-interlacing your video to clarify playback.

NTSC Colors

When you apply the NTSC Colors filter to an image or video
file, you are restricting the colors used in that file to those
used in analog television production. This keeps your video
clean by preventing oversaturation and bleeding of colors.
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You can change the colors to NTSC colors by choosing
Filter⇒Video⇒NTSC Colors.

Understanding the Features of the Timeline Panel

The Timeline panel consists of a timeline for creating
animations or editing video through time. It has features such
as a playhead that allows you to move through time in your
file and lists the clips that are placed in your file. You can
access clip properties that allow you to animate any clip in
your file in different ways, depending on the clip type you
select.

The Timeline panel has so many features that we break them
into three categories for you: time adjustment, work area, and
icons.

Adjusting time in the Timeline panel

Time is an important feature in any video-editing project.
Because a video includes the fourth dimension of time, there
needs to be a way of representing that dimension when you
are looking at a video layer. The Timeline is a standard way
of doing just that. When a layer is placed inside the Timeline
indicating duration, it is called a clip. The Timeline panel
includes many time indicators and time features, as shown in
Figure 25.11. These features represent how much time is
involved in your video clip and let you move through the
Timeline to explore the entire video.

Figure 25.11
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You can use the many time features of the Timeline panel to
move quickly through your video.

Here's what these features do and how to use them:

• Playback controls. The playback controls allow you to
rewind, play, pause, and fast-forward your animation or video
as well as move the playhead to the beginning of the video
clip.

Tip

You can press the spacebar to play and pause your video.

• Time ruler. The time ruler indicates the time relative to the
video clips.

• Playhead. The playhead is a slider that allows you to
preview your video, select a particular time, or frame in your
video by dragging the slider back and forth across the video
clips.
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• Current time. The current time is a numerical
representation of where the playhead is placed on the time
ruler. Notice that the time indicated in Figure 25.11 matches
exactly with the position of the playhead.

• Frame rate. The frame rate number indicates how many
frames are in every second of an animation or video. The
default setting, which is the NTSC standard rate shown in
Figure 25.11, is 29.97 frames per second.

• Zoom slider. The zoom slider is a handy feature that allows
you to expand or reduce the time ruler. When you zoom in,
the length of each second in the Timeline increases. If you
zoom all the way in, each frame takes up the same amount of
space as each second did at the lowest setting.

• Current frame. The current frame can be viewed in lieu of
the current time if you choose Panel Options from the Panel
menu and select Frame Number. You can see in Figure 25.12
how the Timeline panel changes.

• Frame ruler. When you choose Panel Option from the
Panel menu and select Frame Number, the time ruler becomes
a frame ruler, indicating the number of frames relative to the
video clips.

Figure 25.12

You can change the panel options to show the current frame
number in the Timeline panel.
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Using the work area of the Timeline panel

The work area of the Timeline panel includes the video clips
and other layers, as well as the tools that you can use to view
and manipulate them. The clips are represented by bars
distributed through the Timeline to show duration. Each clip
is labeled and has several tracks and properties that you can
manipulate in your video-editing process, as shown in Figure
25.13.

Figure 25.13

The work area features of the Timeline panel include video
clips and their properties.
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The work area of the Timeline panel includes the following
features:

• Comments track. This track provides a space to enter
comments in any area of the Timeline.

• Global lighting track. This track allows you to animate
global lighting throughout all of the clips at the same time.

Note

The Comments and global lighting tracks are not shown by
default. You can view them by clicking the Timeline panel
menu icon and choosing Show⇒Comments or
Show⇒Global Lighting.
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• Time-Vary Stopwatch. This feature can be turned on in
any clip property that you can animate. It allows you to place
keyframe indicators inside the property clip.

• Video tracks. These layers correspond exactly to those in
the Layers panel, and there is a video track for each clip layer
placed in your video file. Notice in Figure 25.13 that the top
clip is actually an adjustment layer. The video track menu,
which you access by clicking the video icon, allows you to
create groups from one or more tracks in the Timeline.

• Work area indicators. These indicators enable you to
reduce your work area to the immediate area you are working
on, by dragging them to different locations in your Timeline.
When you start a playback, it is restricted to this area. You
can also render and export just the segment of your video or
animation contained inside the work area indicators. This
feature is more useful as your file becomes longer in duration.

• Audio track. This track allows you to place an audio file
along with the video files in your Timeline. The audio track
menu, which you access by clicking the musical note icon in
the audio track, allows you to make changes to your audio
clip as well as add or delete audio tracks.

• Cached frames indicator. This indicator shows the frames
that have been cached in the computer's memory and that can
be easily previewed. When the line is solid, all the frames in
that area have been cached. If the line looks jagged, only a
few frames have been cached in that area. If the line is
nonexistent, none of the frames has been cached yet. As you
play back video, you'll notice that a limited number of frames

1590



can be cached. Consequently, past frames are discarded as
new frames become cached.

• Clip duration bar. This bar indicates the duration of the
clip inside the Timeline. Drag either end of the bar to
lengthen or shorten it. You can edit the clip position and
length in the Timeline in several ways, which we cover when
we discuss the Timeline panel menu later in this chapter.

Using the icons on the Timeline panel

The icons on the Timeline panel make certain actions, such as
changing the look of the Timeline and deleting keyframes,
quick to perform. You can perform some actions with a quick
click, and others require more input. The icons are labeled in
Figure 25.14.

Figure 25.14

The icons on the Timeline panel allow you to quickly access
different features.
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The Timeline panel icons include the following:

• Mute/Enable audio. Clicking this icon allows you to
quickly mute the audio during your video playback, or
re-enable it.

• Set playback options. Clicking this icon opens a flyout
menu that allows you to set the resolution of the video
playback (higher resolution means slower playback) and
enable loop playback.

• Split at playhead. Clicking this icon makes a break in your
video clip at the playhead, creating a new video clip in the
process.

• Select a transition and drag to apply. Clicking this icon
opens a transition menu that allows you to choose from a few
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basic transitions, set the duration, and then drop the transition
into place at either end of a video clip.

• Track menus. Clicking these icons opens a flyout menu
specific to the track on which the icon is located. These
menus give you such options as adding media to the current
track, creating groups, duplicating media, and deleting the
track. We cover these options throughout this chapter.

• Add media to track. Clicking this icon opens a browser
window that allows you to select a new file to add to the
track. In a video track, you can add video, photos, and 3-D
objects. In an audio track, you can add additional audio files.

• Convert to frame animation. Clicking this icon changes
the Timeline panel to frame animation. Your file is also
converted to a frame-based animation. This option is viable
only if you are working on an animation rather than a video
file, because video files do not play in a frame animation.

• Render video. Clicking this icon starts the video rendering
process, opening a dialog box for you to establish settings and
choose where you want to save your new video file.

• Timeline panel menu. Clicking this icon opens the
Timeline panel flyout menu. This is a hefty menu, so we
describe it in the following section.

Exploring the options in the Timeline panel menu

When you know the options that are available to you in the
Timeline panel menu, you will find that your workflow is
more efficient and productive. The Timeline panel menu has
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many features, as shown in Figure 25.15. Some of them are
intuitive, and some are covered in greater depth in this and the
following chapters. Here we give you a quick rundown of the
list so you'll have a comprehensive, at-a-glance resource.

Figure 25.15

The Timeline panel menu has all the options you need to use
the Timeline effectively.
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The Timeline panel menu includes the following options:

• Go To. This option allows you to move the playhead to any
of the following places: a specified time, the next frame, the
previous frame, the first frame, the last frame, the beginning
of the work area, or the end of the work area.
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• Split at Playhead. This option makes a break in your video
clip at the playhead, creating a new video clip in the process.

• Move & Trim. This option allows you to move your video
clips through time, or trim them using the location of the
playhead. You can see an example of a trimmed video in
Figure 25.16.

Figure 25.16

The Levels track has been trimmed so that it only affects a
part of the video track beneath it.

• Convert Frames. This option allows you to make one of the
following conversions: take an image with several layers and
create an individual frame from each layer; create a clip for
every frame in your video or animation; or convert the
Timeline to frame animation. See Chapter 28 for more
information on frames and frame animation.

• Work Area. These options allow you to create a work area
by setting the beginning or end of your work area to the
playhead, as shown in Figure 25.17. You can also lift or
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extract your work area. If you lift the work area, all the clips
in the work area are deleted, but a space the size of the work
area is left in the Timeline. Extracting the work area deletes
all the clips contained in the work area, closing the gap in the
Timeline left by the deletion.

Figure 25.17

Changing the work area highlights a section of your
animation or video so playback is restricted to that area.

• Delete Timeline. This option immediately deletes the
Timeline and compresses all of the layers in your document
so that they appear in the document window all at once. You
can re-create the Timeline, but all of the layers will begin at
the zero mark of the Timeline ruler.

• Keyframes. These options allow you to create and make
changes to keyframes in your Timeline. You learn all about
keyframes in Chapter 26.

• Comments. These options allow you to leave comments in
the Comments track, view them, and edit them.
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• Loop Playback. This option allows you to continuously
play back your video.

• Allow Frame Skipping. This option allows you to skip
frames as you preview an animation or video. This enables
Photoshop to play the preview in real time, although the
quality is not as good as the rendered version.

• Show. These options allow you to choose whether to show
all clips, or just your favorite clips. You can choose to set up
or edit your favorite clips. You can also choose to view the
comments and global lighting tracks inside the Timeline.

• Enable Timeline Shortcut Keys. This option allows you to
use the shortcut keys for the Timeline that are not available
by default.

• Enable Auto-Grouping of Clips. This option automatically
creates groups from clips in the Timeline. If you place a
Levels adjustment over a video clip, for example, it is
automatically placed in a group with that video clip.

• Enable Onion Skins. This option allows you to view an
overlay of the previous and next frame or frames. See Chapter
26 for more information.

• Enable 3-D Tracks. This option enables the tracks within a
3-D layer that you can edit using keyframes. See Chapter 26
for more information.

• Onion Skin Settings. This option opens the Onion Skin
Options dialog box, where you can set several options,
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including what frames become onion skins and their opacity.
See Chapter 26 for more information.

• Set Timeline Frame Rate. This option allows you to
change the frame rate of the Timeline, making your video a
smaller file that is lower in quality or a larger file that is
higher in quality.

• Panel Options. These options allow you to change the
thumbnail size of the clips. You can also change the ruler on
the Timeline from Timecode to Frame number.

• Render Video. This option renders your video with the
changes you've made to it so that all the video frames are
processed and cached, allowing you to watch your video in
real time at full quality. Rendering can be a time-consuming
process.

• Close. This option closes the Timeline panel.

• Close Tab Group. This option closes the entire tab group
that includes the Timeline panel, the Measurement Log, and
Mini Bridge by default.

Accessing the Video Layers menu

The Video Layers menu is an important part of working with
video and the Timeline panel. From this menu, you can create
new video layers, copy and create new frames, and otherwise
make changes to your video layers. Creating video layers is
important when you want to make frame-by-frame changes,
and as these changes are made, you'll find that being able to
copy material from one frame to the next is very useful.

1599



You can find the Video Layers menu by choosing
Layer⇒Video Layers from the menu bar. As we start to show
you more of the advanced techniques of animation and video,
you will use the Video Layers menu more frequently. You
can see this menu in Figure 25.18.

Figure 25.18

The Video Layers menu has advanced features that make
video editing in Photoshop worthwhile.

The Video Layers menu includes the following options:

• New Video Layer from File. This option allows you to
import a separate file as a layer in your existing file, similar to
the Place command.
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• New Blank Video Layer. This option adds a blank video
layer to your document. A new blank video layer is handy for
making changes to existing video, and it's imperative if you
are animating an image or rasterized layer that doesn't already
contain a video layer. In addition to the regular layer
properties, a video layer contains an Altered Video track that
allows you to make changes frame by frame. The new video
layer is completely transparent until you add changes to it.

• Insert Blank Frame. This option creates a blank frame on
the Altered Video track at the position of the playhead.

• Duplicate Frame. This option duplicates the current frame
on the Altered Video track and places it directly after the
selected frame.

• Delete Frame. This option deletes the current frame on the
Altered Video track.

• Replace Footage. This option is useful when the file
containing the original footage has changed locations and
Photoshop can't find it. Click Replace Footage, and browse to
the new location to correct the link between the original file
and the Photoshop document you've created with it.

• Interpret Footage. This option is useful if you have video
clips that contain alpha channels, as it allows you to
determine how the alpha channels are interpreted. You can
also change other options such as whether the video is
interlaced, and you can modify the frame rate.
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• Hide Altered Video. This option is the same as clicking the
eye icon on a video clip you want to hide, except that it
allows you to take the scenic route to do the same thing.

• Restore Frame and Restore All Frames. These options
enable you to discard the edits you've made to any or all
frames. All edits to video in Photoshop are non-destructive,
meaning that they do not affect the original file.

• Reload Frame. This option allows you to reload the footage
for the current frame in a video file you are working on. This
is useful if the original footage of the video file has been
changed and saved in a different application, because
Photoshop eventually synchronizes the document and reflects
those changes. Another technique is to use the playback
controls to play the footage, which also allows Photoshop to
reload the original file.

• Rasterize. This option rasterizes a video clip. A video clip
is dynamic and can be modified frame by frame. When it is
rasterized, it becomes a flat image, containing only the data in
the frame that was selected when it was rasterized. That data
plays continuously through the duration of the original video
clip.

Setting clip favorites

As your project grows, the Timeline panel becomes unwieldy
as you add more clips. You can hide clips that you are not
working on to keep your work area neater and easier to work
in. You do this by setting your clip favorites. You can set
your clip favorites at any time during your project; in fact,
you'll probably want to change your favorite clips often.
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You can set up clip favorites by following these steps:

1. Highlight the clips that you want to place among your
favorites.

You can select multiple clips by pressing and holding the
Ctrl/ key as you click each clip. You can do this in either
the Timeline panel or the Layers panel.

2. Click the Timeline panel menu icon to open the flyout
menu.

3. Choose Show⇒Set Favorite Clips.

The unselected clips no longer appear inside the Timeline, as
shown in Figure 25.19. You can still view these clips in the
Layers panel, and they still play when you preview your
video.

4. (Optional) You can change your clip favorites by
choosing Show⇒All Clips and repeating Steps 1 to 3.

Figure 25.19

Setting clip favorites cleans up the Timeline panel.
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Creating video groups

Another way of organizing your Timeline panel is to create
video groups. A video group contains one or more clips and
appears as a single track in the Timeline panel. You can see
which clips are contained in the video group by looking at the
Layers panel, as shown in Figure 25.20. These clips can be
any kind of layer, including video files, adjustment layers, or
image files. It can be incredibly convenient, for example, to
place lighting and color adjustments where they are needed
over a video clip and then to combine them all into a group.
This not only makes the Timeline panel cleaner, but it also
ensures that the adjustment clips stay where they need to be.

Figure 25.20

Creating a video group allows you to merge several tracks
into one on the Timeline panel.
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To create a video group, simply select the clips or tracks that
you want to include in the group, click the Video Track icon,
as shown in Figure 25.21, and select New Video Group from
Selection. This combines the selected clips into one track. As
always, we encourage you to immediately rename the group
so that you recognize it easily moving forward.

Figure 25.21

The Video Track icon allows you to create new groups.

Opening and Placing Video Files
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Getting started with video editing in Photoshop is as easy as
opening a video file. Once you have opened a video file, you
can edit it by adjusting the light and color, rearranging the
order of the video by splitting and moving areas of the clip, or
adding special effects by painting or changing one frame at a
time. You may even want to make changes to more than one
clip at a time. After you have opened one video file, you can
use the Place command to add more video files to the same
document to create a composite.

Opening a video file

Opening a video file in Photoshop isn't any harder than
opening any other kind of file. However, you need to import
the smallest possible file for editing. Photoshop is not meant
to create and manage extensive video projects, and a large
video file can create an unwieldy work area at best and bring
your work in Photoshop to a grinding halt at worst.

Although you shouldn't feel discouraged from bringing in as
much video as you need to edit, don't bring in any more than
is necessary. You can trim larger video files down to an
editable size in the video-editing program of your choice by
creating a work area or trimming around the area you want to
edit and rendering just that part to a separate video file that
you can then import into Photoshop. Taking the time to trim a
video file down to a manageable size saves you a lot of time
and frustration later.

To open a video file in Photoshop, choose File⇒Open and
browse to a video file with a supported extension. When the
file opens, the Timeline panel is automatically opened or
selected from its tab group, and your newly imported video
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file appears as a video group in the Timeline. Figure 25.22
shows a video file that's been imported into Photoshop.

Tip

As soon as you import your clips, you should give each
layer a descriptive and unique name so that you can easily
identify and manage them throughout the video editing
process.

Adding additional video files

You can add video files to an open video document in several
ways. For example, you can drag a video clip from another
file into the window of the file it's being placed in, or you can
choose Layer⇒Video Layers⇒New Video Layer from File.
Either of these options adds a new layer in the Layers panel,
but places the new video clip directly after the selected clip in
your file within the same video group. Figure 25.23 shows
two video clips placed together in the Timeline. Both videos
are from the same wedding.

If you are adding video clips in sequence, this is the best way
to do it. Adding video clips in sequence makes it simple to
add filters and other corrections to the group and have them
apply universally. Having all your video in one group also
keeps the Timeline neat and easy to work with.

Figure 25.22
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A newly imported video file contains one video track and the
default audio track.

Figure 25.23

Two video clips can be combined in the Timeline.
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You can also add your videos without grouping them in order
to create special effects such as transparencies, composites, or
picture-in-picture. Click the Timeline panel menu and
deselect Enable Auto-Grouping of Clips. Now, when you
import additional files, they are added both as new layers in
the Layers panel, and also as new tracks in the Timeline.

You can also create a new video group for each clip. Click the
Track Menu icon next to your first video group and choose
New Video Group. Then click the Track Menu icon next to
the new video track and choose Add Media. This allows you
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to browse for the second video file and place it at the
beginning of the new video group, as shown in Figure 25.24.

Sometimes, you may want to add a new video file differently
than just inserting it over the last one. For example, you may
want to change the size of the file to create a
picture-in-picture effect. In this case, you want to place the
new video file. To do this, you choose File⇒Place, and
browse to the new video file. The new file is placed over the
existing clips with a bounding box around it, allowing you to
scale, rotate, and place it where you want, as shown in Figure
25.25. Be sure that you place your file as a separate track to
create this effect.

Of course, you can create the same effect after the fact by
selecting the video clip and choosing Edit⇒Free Transform,
but placing the video file saves you this extra step.

Note

Whether you use the Place function or the Free Transform
function, a transformed video layer becomes a Smart Object.

Figure 25.24

Clicking the Track menu icon makes it easy to create new
video groups.
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Figure 25.25

Create a picture-in-picture effect by placing and transforming
the second file.
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Importing image sequences

An image sequence is a series of image files that are saved in
sequence for an animation or video. Usually, they are
exported out of a video project. A video file is very
memory-intensive to render, especially if it contains several
layers, high-resolution images, or 3-D objects. If you render a
video project as an image sequence rather than a video, the
rendered — and saved — images are preserved, even if your
computer crashes, allowing you to start the rendering process
where you left off. Photoshop allows you to import these
rendered images together as one animation file.
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You can import rendered images in two ways. The first way is
to import the image sequence as a single layer, creating one
video clip from the individual image files, just as if it had
been a single video file. The second way is to import the
image sequence into a stack, which gives each frame its own
individual layer without any extra steps. We show you how to
import using both methods.

Note

Before you import an image sequence, make sure it has been
saved correctly. An image sequence should be a series of
images saved with sequential filenames and placed in a
folder that doesn't contain any other files.

Importing an image sequence into one layer

Opening an image sequence as one video layer is the fastest
and preferred method of importing an image sequence.

You can open an image sequence as just one video layer by
following these steps:

1. Choose File⇒Open.

2. Browse to the folder containing the image sequence,
and select the first file in the sequence.

3. In the Open dialog box, select the Image Sequence
check box.
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4. Click Open.

5. You are prompted to enter a frame rate for your image
sequence.

If this is an exported video, select the original frame rate. If
this is a series of still shots, select the frame rate that will
work best, and click OK.

You now have a simple file that looks just like you opened a
video file, as shown in Figure 25.26. This file is generated
quickly and is easy to work with.

Figure 25.26

An image sequence can be opened to create a simple video
clip that's easy to work with.
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Importing an image sequence into multiple layers

If you need your image sequence to be placed in separate
layers, you can use a method that creates the layers, as the
images are imported and opened. With this method, there is
no waiting time to cache the frames after the file is created.

You can create an individual layer for every image in an
image sequence by following these steps:

1. Choose File⇒Scripts⇒Load Files into Stack.
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This opens the Load Layers dialog box.

2. Choose Folder from the Use drop-down menu.

3. Browse to the folder containing the image sequence you
want to open, as shown in Figure 25.27.

Figure 25.27

You can use the Load Layers dialog box to create individual
layers for every image in a sequence.

4. Click OK.

5. Click the Timeline panel menu icon, and choose
Convert Frames⇒Make Frames from Clips.
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This creates one frame for each layer and places them in
sequence to create a video. If you set your frame rate to 30
frames per second, for example, each layer is 1/30 second
long and placed just after the layer below it in the Timeline.

Caution

As you make frames from layers, be sure the playhead is at
the beginning of your Timeline. The first frame is placed at
the location of the playhead.

Now your animation contains a separate layer for every image
in your image sequence. This is handy if your image sequence
is short, containing only a few images, but it's not great if you
have several images. In Figure 25.28, you can see a view of
our Timeline panel after importing a 5-second sequence. Of
course, our frame rate is set to 30, so the file contains 150
images. That's 150 layers in the Timeline, 150 layers in the
Layers panel . . . well, you get the idea.

Figure 25.28

This figure shows just some of the layers that are actually
contained in this Timeline.
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Trimming Video Clips

As you add new video clips to a project, you may find that
you need to trim them. Trimming a video clip consists of
cutting the unwanted ends off the clip, leaving the rest of the
video intact. You can trim a clip in several ways — by
manually dragging the clip duration bar, by using the
Timeline menu options, or by splitting the clip, which we
discuss later in this chapter.

Dragging the clip duration bar
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The easiest way to trim a layer is to drag the ends of the layer
to the point where you want the video to start or end. First,
you need to place the playhead where you want to begin or
end the clip. You can probably get to that spot just by your
initial preview of your video clip. Then simply move the end
of the layer duration bar by clicking and holding it as you
drag it to the playhead. This isn't a precise method, but it
works well for a preliminary trim. Figure 25.29 shows our
attempt at lining up the layer duration bar and the playhead.

Figure 25.29

Dragging the end of the layer duration bar to trim it

When you drag the beginning of the clip to trim it, the clip
doesn't automatically reposition itself at the beginning of the
document. If you want your clip to start at the beginning of
the document, you can do one of two things: drag and drop
the already trimmed clip to reposition it or simply drag the
untrimmed clip forward, moving it out of the beginning of the
document. Place the playhead at the beginning of the
document so you can preview the video as you are moving it
out of the document.

Trimming clips using the Timeline menu option
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If you want to trim your video more precisely, you can move
the playhead to the proper area and click the Timeline panel
menu. You then select Move & Trim⇒Trim Start/End at
Playhead. This trims the clip to the current time. Again, this
leaves the beginning of your clip at the playhead rather than
at the beginning of your document, as shown in Figure 25.30.

Tip

You can move the playhead to the very frame you want to
trim to by using the Select Next/Previous Frame icons
located in the playback controls at the bottom of the
Timeline panel.

Figure 25.30

Using the Timeline panel menu to trim the clip start or end to
the current time leaves you with a gap at the front of your
video document.

Moving Video Clips

Moving video clips is a straightforward process. You'll
probably find yourself dragging clips around frequently
without even thinking about it as you work on your video
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project. You can move clips around in more than one way, so
we briefly cover each way so that you are aware of them.

Changing the clip hierarchy

You change the clip hierarchy in a video project the same as
in any other project. As you work in the Timeline, don't forget
that the Layers panel is also a part of your work area, as
shown in Figure 25.31. Each clip is shown as a layer in the
Layers panel. You can select, delete, and move layers in the
Layers panel. To move a layer up or down in the hierarchy,
you click it inside the Layers panel and drag it into position.

Figure 25.31

The Layers panel displays all the clips in the Timeline panel
as separate layers.
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As you can see in Figure 25.31, stacking many different types
of clips can make the Timeline panel look busy. When you
look at the Layers panel, you only have to understand how the
layer hierarchy works to know which clips are visible. When
you look at the Timeline panel, you need to understand the
hierarchy, and how the clip duration bar works within the
hierarchy.

In Figure 25.32, the clips are clearly marked so you can see
which clips are visible and when. At the beginning of the
Timeline, follow the clip layer hierarchy down to the first
clip. As the playhead moves along the Timeline, that clip is
visible in playback until another clip, located above it in the
hierarchy, takes precedence. After the top clip ends, the
second clip is played. The concept is simple, but as you add
more clips, it can look intimidating. Even if you understand
exactly how it works, it takes practice and experience to
understand what's happening with the clips at a glance.

Tip

You can set clip favorites to show only the clips that you are
working with at any given time. Click the Timeline Panel
Menu icon and choose Set Favorite Clips from the pop-up
menu.

Figure 25.32

To understand which clip is visible, look at the clip hierarchy,
and then look for the first active clip.
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Dragging clips inside the clip duration bar

To change the relative position of a video in your Timeline,
you can simply click and drag its clip duration bar back and
forth inside the Timeline, as shown in Figure 25.33. If your
clip is visible, you can preview the movement in the
document window. It looks like you are changing the position
of the playhead manually, but of course, the clip is moving
rather than the indicator. You can drag a clip right past the
beginning or end of the document, effectively trimming the
ends of the clip. This content remains available, because you
can always drag it back into the document.

Figure 25.33

Simply click and drag a track inside the Timeline to move
back and forth in time.
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Moving the clip start and clip end points

The most precise way to move a clip is to use the panel menu
to change the clip start or clip end point to the position of the
playhead. Simply move the playhead to the position where
you want the clip to begin or end, and choose Move &
Trim⇒Move Start/End to Playhead from the Timeline panel
menu. This slides the indicated end of the clip to the
playhead. If the clip has been previously trimmed, the Clip
Start/End point is defined as the visible end of the clip. Figure
25.34 indicates this type of clip movement.

Figure 25.34

Using the Move Start to Playhead menu option snaps the
beginning of this clip to the precise position of the playhead.

Splitting Clips

Splitting a video clip cuts it cleanly into two pieces, allowing
you to add a transition, delete part of the video, or edit part of
a clip independently from its other half. Once you have split a
clip, it becomes two separate tracks, effectively creating two
clips from one.
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To split a video clip, you move the playhead to the location
where you want the video split and click the Split at Playhead
icon at the top of the Timeline panel. When a video clip is
split, it is divided into two different layers that are placed on
one video track within the same group, as shown in Figure
25.35. If you watch a video right after you have split it, you
won't see any difference in the video playback.

Figure 25.35

Splitting a clip creates two layers from one.

Even after a video clip has been split, the full content of the
clip is on both layers. This means that you can drag either clip
to duplicate the content of the other clip. In fact, this is a good
reason to split the clip in the first place. By dragging out the
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end of one of these clips and repositioning it, you can create a
stutter effect in the video. That's great for kissing shots.

Another reason to split video clips is to insert something
between the two clips — another video, a still shot, or a title.
Figure 25.36 shows a title placed after the first segment of the
split video.

Note

You can create new tracks for each split and for your new
layers by ungrouping the original track. Choose Delete
Group from the Layers panel menu and choose Group only
from the options. This deletes the group and creates a new
video track for each new layer created in the Layers panel.

Figure 25.36

Splitting a clip allows you to insert other clips between the
two segments.
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Lifting and Extracting Unwanted Sections of Video

You can clip your video and remove unwanted sections in just
one step by lifting or extracting them. You can lift or extract
any portion of a video clip: beginning, middle, or end. Lifting
a video section creates a gap in the area that the video once
occupied, and extracting the video section takes the video out
and closes the gap, so the video clip plays continuously.

Lifting a section of a video clip
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Lifting a section of a video clip takes the work area out of the
video, leaving a gap in the video the size of the video that you
have removed.

To lift a section of your video, you select a video clip and set
the work area around the section that you want to lift. Choose
Work Area⇒Lift Work Area from the Timeline panel menu.
The video clip turns into two video clips, and a gap is created
inside the work area. You can see in Figure 25.37 that the
work area is empty. Now you can place another file to fill the
gap.

Figure 25.37

Lifting the work area deletes the video clip inside the work
area, but leaves a gap where the video used to be.
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Extracting a section of a video clip

Extracting a section of video is a little different. Rather than
deleting the video and leaving a gap, extracting it deletes the
video and closes the gap. This is the easiest way to simply
delete unwanted video from the middle of your video file.

You can extract a section of a video clip by selecting the
video clip and setting the work area around the section you
want to delete. Choose Work Area⇒Extract Work Area from
the Timeline panel menu. The video clip turns into two video
clips, and the second part of the video moves into the work
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area to close the gap created by the extraction. Figure 25.38
shows that the extracted video has been replaced by the
remaining video. This allows uninterrupted playback of your
video file without having to fill the gap created by lifting a
video file.

Figure 25.38

Extracting the work area deletes the video clip inside the
work area and closes the gap.

Adding Still Shots or Other Elements to a Video Project
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Adding still images or other elements, such as text layers or a
3-D model, to your project is similar to adding video files.
However, these kinds of files look different from a video file
in both the Timeline and the Layers panel, so we will show
you some of the things that distinguish these files.

You can add still image layers to your video project in several
ways. When we say still image, we're lumping together all the
different kinds of images that you can manipulate in
Photoshop — photos, paint, vector images, and text.
Therefore, it makes sense that you can add them in so many
ways, from creating a new layer to placing a separate file.

Adding a blank layer

If you are building an image rather than importing it, you
want to create a new layer for the image, especially if your
other layers consist of video files. To add a blank layer,
simply click the New Layer icon at the bottom of the Layers
panel. You can also choose Layer⇒New⇒Layer or press
Shift+Ctrl+N/Shift+ +N.

A new layer is created in both the Layers panel and the
Timeline, as shown in Figure 25.39. You should change the
name of the layer immediately. You can move your layer up
and down in the layer hierarchy by dragging and placing it in
the right spot in the Layers panel.

A blank layer is an empty canvas waiting for you to create
whatever you want. Once you have created a blank layer, it
appears as a new clip in the Timeline. You can then add
elements and modify this layer just as you would any video
clip.
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Figure 25.39

Adding a new layer is as easy as clicking the New Layer icon
in the Layers panel.

Adding a text layer

Adding a text layer is as simple as choosing the Text tool
from the Toolbox, clicking your document, and typing text. A
separate text layer is automatically created, which allows you
to move and edit the text separately from the rest of the file.

Creating a title for a video project is the perfect example of
optimizing the Photoshop tools to create the best results for
your video project. You can create a title for a video file in
Photoshop, or you can create a title separately to import into a
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video project being created in a different application. Either
way, the tools in Photoshop make it easy to create a custom,
classy title.

Placing an image file

If you have a photo or an image that is a separate file, you
need to add it to your video file for it to be part of your
project. You can easily do this by choosing File⇒Place and
browsing to the file you want to add. The file is added to the
video file in a bounding box that you can scale and rotate to
place the file just how you want it inside your video project.

You can drag a new file in by clicking the layer containing
the still image and dragging it into the window of your video
file. You can also copy and paste all or part of an image file.

Placing or dragging an image into your video file creates a
new clip in your video containing the new image file. If you
copy and paste an image, be sure to create a blank layer to
paste it into. However you bring an image in, make sure the
layer is clearly labeled and placed in the hierarchy where it
needs to be.

Note

When you add blank layers, text, images, or 3-D objects to
your video, they are placed so the clips are active
throughout the duration of the video. If you are creating a
title or placing a short image clip, you want it to be shorter.
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This gives you the perfect opportunity to practice moving
and trimming your clips.

Adding or placing a 3-D model

You can add or place a 3-D model in the same way you add a
still image: simply choose File⇒Place, or drag the object into
your file. You can also choose 3D⇒New Layer From 3D
File. This option adds the object as if it has been dragged in,
and so you do not have a bounding box to change your
placement options.

When a 3-D object is brought into a video file, it is treated as
a 3-D layer. You can transform the 3-D object directly from
the file you have placed it in. A 3-D object is distinguished in
the Layers panel by the 3-D icon in the corner of the layer
thumbnail, as you can see in Figure 25.40.

Figure 25.40

Three-dimensional objects have a distinct 3-D icon in the
corner of their thumbnail.

1634



Summary

This chapter covered the basics of working with video in
Photoshop. The Timeline panel has several features and
menus, and you should now be familiar with what they are
and how they work. You should also know how to do the
following in Photoshop:

• Open and place video files
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• Trim video footage

• Move video clips

• Split video clips

• Lift and extract unwanted video clips

• Add images and 3-D files to a video project
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Chapter 26: Animating in the Timeline Panel

In This Chapter

Setting and editing keyframes

Using keyframes to animate the position of a layer

Animating transformations

Changing the opacity setting over time

Animating layer styles

Using keyframes to animate global lighting

Animating text

Using keyframes to animate masks

Animating 3-D objects

Creating rotoscoping effects

Animating DICOM images

Animation and keyframes are a big part of how the Timeline
panel works and the effects you can create with your video
files. Before we show you how to perform basic color
correcting and apply image effects to your video files, we
show you how to use the keyframes in the Timeline panel to
change your effects over time.
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Just as you've known since you were a kid, video and
animation are produced by creating a series of images and
showing them at such a high speed that it fools our brains into
thinking that we are watching true motion. A standard frame
rate to create realistic motion is 30 frames per second. When
we were kids, we always wondered who had to draw and
color the millions of pictures it took to make a full-length
animation. Now we've watched enough special features titled
“The Making of…” to have a good notion that animators even
in the days before computers had many tips and tricks up their
sleeves to make the animating process smooth and efficient.

Animating in Photoshop not only employs many of the tips
and tricks of efficient animating, but it can also automate
some of the most tedious tasks. We've all seen clay animation
productions — the animations created by moving clay figures
a miniscule amount, taking a picture, and then repeating the
process until all the pictures put together create a movie.
We'll tell you up front that some of the animation in
Photoshop is going to be just like that — frame-by-frame
animation. Not all of it will be, though, and that's where
keyframes come into play.

A keyframe is one of the essential components of animating
in Photoshop. A keyframe allows you to skip many of the
tedious steps between “key” points in your animation. In this
chapter, we show you what a keyframe is, what it does, and
how you can create and edit it.

Creating and Editing Keyframes

When you are creating sequential images for an animation, a
keyframe is any frame that defines a turning point in that
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animation. For example, if you want to animate a bouncing
ball, the keyframes are the frames where the ball meets the
ground and changes direction, and where the ball experiences
the inevitable pull of gravity and begins its return to earth. All
the frames in between are just continuations of the up or
down movement.

The in-between frames are sometimes referred to as
“in-betweens” or “tweens” for short. Creating these frames is
called tweening or, in Photoshop terms, interpolating. When
you create keyframes in the Photoshop Timeline panel,
Photoshop is able to interpolate the frames between
keyframes. This provides you as the user with an animation
experience that is fun and easy, rather than tedious.

A keyframe is indicated in the Timeline by a little diamond or
square, depending on the interpolation setting applied to it.
The diamond or square is yellow if it is selected, or gray if it's
not. You can create different keyframes in your animation to
help you control position, opacity, style, and global lighting.

Creating keyframes

You create a keyframe in areas of your Timeline where you
want to make a change in the property you are animating.
This allows Photoshop to interpolate the frames in between
each keyframe to create a smooth animation.

Creating a keyframe in the Timeline is a simple process. In
the following example, we began a bouncing ball animation
by creating a layer containing a circle over a blank canvas
background.
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You can create a keyframe by following these simple steps:

1. Create a new file in Photoshop.

Use the default Photoshop size or larger.

2. Use the Ellipse tool found in the Toolbox to draw a
circle.

Press and hold the Shift key while you are drawing to
constrain the ellipse to a perfectly circular shape. You can
jazz it up by adding a color or layer style.

3. Right-click your newly created shape layer to open the
pop-up menu, and select Rasterize Layer.

4. Choose Window⇒Timeline to open the Timeline panel.

If the Timeline is in frame mode, click the Timeline panel
menu icon and choose Convert to Video Timeline.

5. Click the Timeline panel menu icon and choose Set
Timeline Frame Rate.

This opens the Document Timeline Settings dialog box. Set
the duration of the video to 20 seconds and click OK.

6. Click the triangle next to the clip name in the Timeline
panel to show the layer properties.

7. Click the Time-Vary Stopwatch icon next to the word
Position to activate it.
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8. Make sure the playhead is at the beginning of the
Timeline.

9. Move your object, or selection, through the canvas to
the position you want to use as the start of your
animation, as shown in Figure 26.1.

Figure 26.1

The ball is ready to drop.
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10. Drag the playhead forward to 1 second.

11. Move your object again.

A keyframe is automatically created, as shown in Figure 26.2.

12. Slide the playhead between the keyframes or play back
this simple animation to watch how tweening works.

Figure 26.2

We created a keyframe at the bounce.
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Now, throwing you into this exercise was like throwing you
into the deep end of a pool. Don't worry, we won't let you
sink; we just wanted you to get used to the water. We covered
a few areas that you aren't familiar with yet, so let's go over
them right now.

In Figures 26.3 and 26.4, note the differences in the layer
properties listed in the Layers panel as opposed to the
Timeline panel. The Layers panel shows the ball layer just as
it would look without the Timeline panel open. The Timeline
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panel, on the other hand, shows you all new aspects of this
layer.

Figure 26.3

The Layers panel is a familiar sight, containing the layers and
properties you expect.

Figure 26.4

The Timeline panel shows a new array of clip properties.
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When you click the triangle next to the clip name, you open a
new world of possibilities. The layer properties that open are
different areas where you can create keyframes. Anywhere
you can create a keyframe, you can also create animation. In
essence, you can animate any of the listed layer properties.
The properties listed in Figure 26.4 allow you to animate in
any of the following ways: by changing the position of the
layer, by changing the opacity of the layer, or by changing the
layer style. Other layer properties exist, including animating
transformations, global lighting, masks, and 3-D properties,
and we cover these properties later in this chapter.

The stopwatch icon next to each of these sublayers enables
you to control the Time-Vary Stopwatch. By default, the
Time-Vary Stopwatch is disabled, and you cannot create
keyframes. Clicking the Time-Vary Stopwatch icon in each of
these layers enables keyframing for that layer.
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Caution

Disabling the Time-Vary Stopwatch after you have created
keyframes deletes them. Be careful that you do not
accidentally disable the Time-Vary Stopwatch and lose all
the work you put into creating keyframes.

When you enable the Time-Vary Stopwatch, the keyframe
navigators come into view. These navigators enable you to
jump from one keyframe to the next. Of course, the direction
you jump depends on the arrow you click. You can edit the
layer properties at an existing keyframe as long as the
playhead is placed directly over the keyframe.

If the playhead is not placed directly over the keyframe, then
instead of that keyframe being edited, a new keyframe is
created. This is an excellent reason to use the keyframe
navigators. For example, in Figure 26.5, we tried to change
the drop position of the ball. The playhead wasn't placed
correctly over the keyframe indicator, so we created a new
keyframe. When we played this animation back, we were left
with a jump in the ball's position at the end. If we had used
the keyframe navigator, the playhead would be correctly
placed to make the edit.

Figure 26.5

Changing the position of the ball with the playhead in the
wrong position created a new keyframe.
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If you click between the two arrows of the keyframe
navigator, you create a new keyframe. This isn't the most
efficient method, because after you have created it, you need
to change the layer property. If you change the layer property
first, a keyframe is automatically created.

Editing keyframes

You can copy, paste, and delete keyframes inside the
Timeline. This is an incredibly useful way to create many
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keyframes in a relatively short amount of time. Follow these
steps:

1. Select a keyframe by using the keyframe navigator or
by placing the playhead over it.

A selected keyframe is highlighted in yellow. You can also
select more than one keyframe by dragging a selection
marquee around the keyframes you want to select or by
clicking the Timeline panel menu and choosing Select All
Keyframes.

2. After you select one or more keyframes, right-click one
of them to open the menu options for the selected
keyframes.

You can also find these options in the panel menu.

3. Choose Copy Keyframe, and close the menu.

4. Move the playhead to the location in the Timeline
where you want to place the first keyframe.

5. Open the Timeline panel menu, and choose
Keyframes⇒Paste.

As you can see in Figure 26.6, we created a second bounce
for the ball. You can go on copying and pasting keyframes to
continue the bouncing motion.

You can delete a keyframe in the same way, by right-clicking
it and choosing Delete Keyframes or by choosing Delete from
the panel menu.
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Caution

The hotkeys (Ctrl+C/ +C, Ctrl+V/ +V, and Ctrl+X/ +X)
for copying, pasting, and deleting keyframes don't work the
way you think they might. That's because in addition to
selecting keyframes, you also select the clip layer in the
Layers panel. If you use the hotkeys, you are copying and
pasting in the Layers panel. If you are not careful, you could
delete the layer you are working on.

You can drag selected keyframes around in the Timeline,
placing them wherever you want. For example, one second is
a very slow and ponderous bounce. Rather than creating a
new keyframe closer to the beginning of the Timeline, you
can just drag the second keyframe closer to the first one.

Figure 26.6

We copied and pasted the bouncing keyframes to create a
second bounce.
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Setting interpolation

For our purposes, interpolation is defined as the way that
Photoshop determines what happens between the keyframes.
The type of interpolation that we have demonstrated so far
has been linear interpolation. It is called linear interpolation
because the interpolation creates a path between keyframes.
That path might be a continuous change of position, or it
might be a shadow being gradually created through time. This
is commonly called tweening. A second interpolation setting
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doesn't create a steady change. This interpolation setting is
called hold interpolation. When you create a keyframe with a
hold interpolation, Photoshop holds the current status of the
layer until the next keyframe, which defines a new status.

Linear interpolation

Linear interpolation is the default setting in Photoshop; the
earlier examples in this chapter show this setting in action.
After you've created keyframes, Photoshop figures out the
difference between them and fills in the missing images at the
frame rate specified in your file.

The shortest distance between two points is a straight line,
and Photoshop doesn't take any other route. No matter what
you do with the file before creating a second keyframe,
Photoshop creates a smooth, mathematically exact transition
between the two frames.

We emphasize mathematically exact because when you first
try out this method of animation, you find more keyframes in
a movement than you expected. We don't think we've ever
seen a ball that bounced at a perfectly uniform speed. They
usually go faster right after hitting the ground, hang in the air
a little and then come down, speeding up as they do. That
adds at least four keyframes to your bounce.

Hold interpolation

Changing keyframes to a hold interpolation is as easy as
right-clicking them and choosing Hold Interpolation from the
menu. The selected keyframes change to squares rather than
diamonds, indicating that the interpolation is set to Hold. In
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Figure 26.7, we changed the keyframes in the position
Timeline to hold interpolations. Now instead of steadily
bouncing, the ball disappears and instantly reappears in a new
position at each keyframe.

You can also see in Figure 26.7 that not all of the keyframe
indicators are diamonds or squares. The last keyframe
indicator looks like it can't decide which one it wants to be.
The diamond on the left side of the keyframe indicator shows
that the transition coming in is a linear interpolation. The
square on the right half indicates that the interpolation going
out is set to Hold.

Figure 26.7

When the position of the ball is set with a hold interpolation,
the ball disappears and reappears in a new location
immediately, rather than moving through space to get there.

Creating comments

You can create keyframes to indicate comments that you want
to make on your project. You access the Comments track by
clicking the Timeline panel menu icon and choosing
Show⇒Comments Track from the menu. This displays the
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Comments track in the Timeline, as shown in Figure 26.8. In
this track, you can place comments on your project.

You create comments just like keyframes. First, click the
Time-Vary Stopwatch icon in the Comments track. This
creates your first comment box. Type your comment and click
OK, as shown in Figure 26.9. An indicator is placed inside the
Comments track, as shown in Figure 26.8. To create
subsequent comments, click between the keyframe
navigators. You can also open the Timeline panel menu and
select Edit Timeline Comment to create a new comment. Do
not click the Time-Vary Stopwatch icon again; this deletes all
your comments.

To read a comment, hover over the comment indicator until a
window pops up, displaying the comment. To edit a
comment, right-click the indicator and select Edit Comment.

Figure 26.8

A comment indicator looks and acts like a keyframe indicator
in the Timeline.

Figure 26.9
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The Edit Timeline Comment dialog box allows you to place a
comment anywhere in the Timeline.

Animating the Position of a Layer

Creating a keyframe is a relatively simple process. Creating
the right keyframe, however, can be tricky — even more so
while animating position. The timing of a movement is vital.
If you are attempting to create a realistic movement, such as a
bouncing ball, you must time it so it looks like it's truly
bouncing. Too slow and you get a floating quality; too fast
and you get a spastic ball.

Choosing how many keyframes to place in a movement is key
to creating a successful animation. Most true-to-life
movements are not mechanical and precise. Placing several
keyframes throughout a movement, even if it is in the same
direction, can add variations in movement and speed that
make it seem more realistic.

In this section, we will show you how you can animate
positions across multiple layers, animating objects together so
that they move in unison, as well as animating them
individually. These are difficult concepts to demonstrate
using still shots in a book, so follow along with the exercises
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and try them out for yourself so you can see the results on
your own computer screen.

Getting keyframe placement right

Getting keyframe placement right is vital in creating realistic
movements in your animation. The best place to start is by
watching the movement you are trying to create happen in
real life, or by imagining it in your head as you work. The
simple movement of a bouncing ball needs several keyframes
to create an animation that looks realistic. Think of how a ball
slows as it reaches its apex and almost seems to hover for a
moment before returning to the ground, building up speed as
it goes.

You can create a realistic bouncing ball by adding several
keyframes to the Timeline. Follow these steps:

1. Create a new file in Photoshop.

Use the default Photoshop size or larger.

2. Select the Ellipse tool in the Toolbox and draw a circle.

Press and hold the Shift key while you are drawing to
constrain the ellipse to a perfectly circular shape. You can
jazz it up by adding a color or layer style.

3. Right-click your newly created shape layer to open the
pop-up menu, and select Rasterize Layer.

4. Choose Window⇒Timeline to open the Timeline panel.

1655



5. Click the triangle next to the clip name in the Timeline
panel to show the layer properties, and click the
Time-Vary Stopwatch icon next to the word Position to
activate it.

6. Set the playhead to the beginning of the Timeline, and
move the ball to the top of the canvas.

7. Move the Zoom slider to the right to expand the
Timeline enough to show half-second increments.

The Zoom slider is found at the bottom of your Timeline
panel. As you increase the size of the Timeline, 15f icons
appear in the time ruler to indicate the half-second marks. The
15f indicates that 15 frames have gone by.

8. Set the playhead to one-half second, and move the ball
down to the bottom of the canvas.

9. Move the playhead about one-third of the way between
the two keyframes, and move the ball up slightly to create
a new keyframe.

This makes the first part of the ball animation drop slower
than the second part.

10. Select all three keyframes, and copy them by
right-clicking one of them and selecting Copy Keyframe
from the menu.

Tip
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You can select all the keyframes in any given layer property
by clicking the name of the layer property.

11. Move the time indicator to one second, and paste the
keyframes.

12. Move the time indicator about a third of the way
between one-half second and one second, when the ball is
on its way back up, and create a new keyframe by moving
the ball farther up along the path.

This makes the ball move faster through the first part of the
bounce.

Tip

You can adjust the position of a keyframe by clicking and
dragging it in the Timeline.

13. Copy and paste all the keyframes several times at each
new half second until the ball bounces several times in
succession.

Your Timeline should look similar to the one in Figure 26.10.

Figure 26.10

Adding a few extra keyframes can make the ball's bounce
more realistic.
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As you play this animation back, you see that adding a few
additional keyframes improves the animation. You can add
more keyframes that give the ball a brief pause at the apex of
each bounce, or you can edit the position of the ball with each
subsequent bounce so it doesn't bounce as high each time.
You could even have it bouncing all over the walls like a
trapped super ball. Trial and error will help you find the spots
where a keyframe would be beneficial.

Animating positions in multiple layers
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There may come a time when you want to animate the
position of objects in different layers at the same time. For
example, if you added text to the bouncing ball, you would
want the text to move along with the ball as it bounced around
your screen.

Note

When animating Smart Object layers or text layers, the
Position property layer is replaced by the Transform
property layer. The Transform property allows for changes
of position as well as the other transformations, as we'll
discuss in the next section.

To animate both layers at once, you simply need to select the
Position layer property in both layers by pressing and holding
the Ctrl/ key while you click each layer in turn. As you can
see in Figure 26.11, the Position property layer is highlighted
in the ball layer, and the Transform layer is highlighted in the
text layer. Meanwhile, in the Layers panel, both object layers
are highlighted as well. This allows you to move both objects
simultaneously, creating keyframes in both Position layers.
You can see how well this worked for the ball in Figure
26.12.

On the Web
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You can create keyframes and play with the bouncing ball
by downloading the file saved as Figure 26.12 on this book's
website.

Figure 26.11

You can animate the position of two layers at once by
selecting the Position properties in both layers in the Timeline
panel.

Figure 26.12

Now you can move the ball and the text together without
losing the editing capability of either layer.
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Managing Multiple Layers

The more clips you have, the more unwieldy the Timeline
panel can become, especially when you are displaying layer
properties. Remember that you can change the settings to
show only those clips you are working on.

The keyframes you have set operate whether the layer
properties are being displayed or not, so reduce the view of
the layer properties whenever you are not placing
keyframes. This is a great way to avoid accidentally clicking
the Time-Vary Stopwatch icon and deleting all those
hard-placed keyframes.

Caution

As long as the Time-Vary Stopwatch is active, you don't
even have to display the layer properties to set a keyframe.
Any change in any of the layer properties sets a new
keyframe, even if you can't see it. This means you can
wreak havoc on your animation without even thinking by
moving your layers around the document. Lock the position
of your layer (using the Lock icons at the top of the Layers
panel) whenever you are not actually creating keyframes.
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Using Smart Objects to Animate Transformations

When you have a text layer or a Smart Object layer, you can
animate transformations. This means you can scale, rotate,
pan, or zoom your layer over time as well as change the
position. You can do this with any layer, because any layer
can be turned into a Smart Object layer.

A Smart Object layer is a layer composed of an embedded
file. The embedded file is protected from changes made in the
main file. Filters placed on a Smart Object change the
appearance of the layer in the main file, for example, but the
embedded file is protected in its original state and is easily
accessed. In order to animate transformations on any layer
that is not a text layer, that layer must be converted to a Smart
Object layer.

We cover Smart Objects in Chapter 10.

You can change a layer into a Smart Object layer and animate
a transformation by following these steps:

1. Open a file with which you would like to animate a
transformation.

We used the file shown in Figure 26.13, animating the
bubbles so that they drifted and changed size and shape.

Figure 26.13
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There are several layers in this file that we can convert to
Smart Objects so that we can change their size, position, and
shape.

2. Select the layer that you would like to animate and
choose Filter⇒Convert for Smart Filters.

UNL1ess the layer you are using is already a Smart Object or
a text layer, you need to convert it in order to animate a
transformation.

3. Choose Window⇒Timeline to open the Timeline panel.

4. Click the triangle next to the clip name in the Timeline
panel to show the layer properties, and click the
Time-Vary Stopwatch icon next to the word Transform to
activate it.
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5. Set the playhead to the beginning of the Timeline and
place your object in the position from which you want it to
start.

In this example, we wanted the bubbles to start right where
they were in the image.

6. Move the playhead to the next position.

We wanted our bubbles to drift slowly, so we decided to place
our playhead at 3 seconds.

7. Transform your Smart Object to create a new
keyframe.

You can move your object just by dragging it. To transform
it, press Ctrl+T/ +T to create a bounding box and then scale
and rotate your object. We moved a bubble forward, and then
enlarged and rotated it, as you can see in Figure 26.14.

Note

Position, Scale, and Rotate are the only transformations
available to animate. If you skew, distort, or warp your
layer, you will find that those transformations do not
animate, but stay constant throughout your animation.

Figure 26.14

By moving this bubble forward and changing its size, we've
animated a transformation.
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8. Continue making changes until your animation is just
how you want it.

We wanted to add a few keyframes to our bubble, giving it a
little bit of bounce and changing its shape frequently so that it
took on the characteristics of a floating bubble. Then we
changed all the bubbles in this file.

Animating the Opacity Setting

The principles of animating opacity are essentially the same
as animating position. You can create some cool effects by
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changing the opacity of layers over time; the Opacity setting
lets you create ghosts, change the level of special effects, or
simply create a fade transition. This feature can be
particularly useful in creating video special effects. Keep in
mind that as you learn the basics of creating keyframes, the
applications of using keyframes can become very advanced.

Changing the opacity of a layer is as simple as adjusting the
Opacity setting in the Layers panel. If the Time-Vary
Stopwatch is activated in the Opacity layer property, simply
adjusting the opacity at different locations in the Timeline
creates keyframes.

With opacity, setting the keyframes isn't nearly as tricky as it
is with changing position. It's as easy as deciding what
opacity you want where in your animation and setting
keyframes at those points. It required only two keyframes to
reveal the special effect, as shown in Figure 26.15.

Figure 26.15

Animating the opacity of the background image with just two
keyframes creates a more dynamic before and after effect.
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The important thing here is not how hard it is to animate
opacity; it's the flexibility that the tools in Photoshop give to
this feature. You can animate the opacity of any layer in your
project, including a fill and adjustment layer or a layer style
that has been converted to its own layer. You can't animate
the actual creation of a paint job or text with keyframes, but
as long as it's on its own layer, you can animate its opacity,
fading it in or out over time. Of course, you can set the
keyframes to hold interpolations as well, allowing your
images or special effects to pop in and out of sight.

In Figure 26.16, we created a Gradient Map Adjustment layer
over the image of a lily to create a fun colorizing effect. By
fading the opacity of the Gradient Map Adjustment layer over
time, we can show you the original image.

Figure 26.16
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Fading out the adjustment layer is the difference between
surreal and real.

Using Keyframes to Animate Layer Styles

Animating layer styles is the most diverse of the animation
capabilities in Photoshop. Animating position or opacity
changes just one setting of the selected layer, but there are ten
different layer styles. Every time you change the setting of
any one of these styles, you can create a keyframe. Use the
styles one at a time or together, or bring styles in and out at
will. Adjusting layer styles allows you to animate a
mind-boggling number of special effects.

You can add layer styles to a layer by clicking the Layer
Styles icon (fx) at the bottom of the Layers panel and
choosing a style from the list. When you select a layer style,
the Layer Styles dialog box opens. From the dialog box, you
can edit the properties of the layer style you selected and
select additional layer styles.
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We cover the individual layer styles and their
settings in detail in Chapter 10.

After you add a layer style, click the Time-Vary Stopwatch
icon next to the Style property. Adjust the playhead, and
double-click the layer style in the Layers panel to open the
Layer Style dialog box again. Making any change in the
Layer Style dialog box — such as adjusting the settings,
adding a style, or deleting the style — creates a new
keyframe. If the playhead is positioned over an existing
keyframe, the changes you make to the layer style change the
settings for that keyframe.

In Figure 26.16, we created an adjustment layer over the lily
and animated it by fading the opacity. You can fade the
opacity of a layer style, but not by using the opacity setting in
the Layers panel. You need to set the opacity of the style in
the Layer Style dialog box.

Animating layer styles is just plain fun. By animating the
bevel and emboss on the ellipse shown in Figure 26.17, you
can create your own hypnotic device.

Figure 26.17

We created this ellipse from scratch.
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You can create a hypnotic device by animating the layer
styles on this ellipse. Follow these steps:

On the Web

For this exercise, you can find a PSD file of the ellipse
saved as Figure 26.17 on this book's website.

1. Open Figure 26.17.

This is a PSD file that contains the ellipse with several layer
styles applied, including a Bevel & Emboss layer style.

2. If the Timeline panel is not already open, choose
Window⇒Timeline to open it.
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Make sure that the playhead is positioned at the beginning of
the Timeline.

3. Click the triangle next to the Ellipse track in the
Timeline panel to open the layer properties.

4. Click the Time-Vary Stopwatch icon next to the Style
property.

5. Double-click the Bevel & Emboss layer style applied to
the Ellipse layer in the Layers panel.

This opens the Layer Style dialog box to the Bevel & Emboss
settings.

6. Change the Bevel & Emboss settings.

Play with different settings to see what effect they have.
Depth, Size, and Soften change the highlight shape. Changing
the Gloss Contour changes the highlight altogether. When
you are finished changing the settings, click OK.

7. Drag the playhead into the Timeline and repeat Step 6.

The farther along the Timeline you go, the slower your
changes happen.

8. Repeat Steps 6 and 7 until you have as many keyframes
as you want.

You want to make several keyframes so that the
transformation changes direction frequently.

1671



9. Rewind and play back your animation, making any
necessary adjustments.

You should have a hypnotic light show as shown in Figure
26.18. You may want to click the Settings icon in the
Timeline panel and select the Loop Playback option so that
your animation plays over and over again.

Tip

As you create animation files with several layers and styles,
you'll find that the playback goes slower and slower. To get
a better feel for the speed of your project, choose Allow
Frame Skipping from the Timeline panel menu. This allows
Photoshop to skip frames in playback mode. This helps
playback go much faster, if a bit choppy. The final rendered
product contains all the frames specified in the document
settings.

Figure 26.18

Animating layer styles adds another dimension to creating fun
effects.
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Animating the Global Lighting

Global Lighting is a property that is constant throughout a
project. It animates the lighting effects of all the layers
simultaneously so that shadows are consistent throughout
your project. You can view the Global Lighting track by
clicking the Timeline panel menu icon and choosing
Show⇒Global Light Track. This makes the track visible in
the Timeline panel, as you can see in Figure 26.19.

You can change lighting effects in the Layer Style dialog box
in any layer style that requires an angle of light, such as the
drop shadow or bevel and emboss. In any of the settings for
these features, you can select Global Lighting, indicating that
you would like the light settings to stay consistent throughout
all the styles applied to that particular layer. Once you've
selected this option, you can change the setting of the light in
any of the layer styles and the light will also change in all
other applicable styles.

Figure 26.19

You can view the Global Lighting track in the Timeline
panel.
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Global Lighting on the Timeline panel affects the entire
project, changing the light settings for all applicable styles
throughout the layers. You animate Global Lighting just as
you would any layer property, by clicking the Time-Vary
Stopwatch icon and setting keyframes, changing the lighting
position at each one.

In Figure 26.20, we animated the Global Lighting of the boy's
shadow. It moves gradually from one side to the other, giving
the illusion that in true teenage style, this boy is just hanging
out all day. By animating the Global Lighting, we ensured
that any other special effects we might add to this file would
be lighted in the same way.

Figure 26.20

Animating the Global Lighting moves the shadow in the
animation from one side of the boy to the other.
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Using Keyframes to Animate Text

Text is just like any other layer in the Timeline panel; you can
edit it by transforming it or changing its opacity or style. This
is a fun and easy way to create playful captions or credits for
animations, videos, or slide shows. Text has one more
property that can be animated: the Text Warp property.
Creating keyframes in the Text Warp property lets your text
morph all over the screen.

You animate the Text Warp by creating a text layer and
opening its properties in the Timeline panel. Of course, the
layer properties that you want to animate must be activated,
so click the Time-Vary Stopwatch icon in the Text Warp
layer as well as any other layer you want to animate.
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Now all you have to do is make the changes. To warp your
text, simply choose the Warp Text option from the Options
bar that appears at the top of the Photoshop work area
whenever you have the Text tool highlighted. This opens a
Warp Text dialog box where you can set the kind of text warp
you want, as shown in Figure 26.21. From the drop-down
menu, you can select several warp types, such as Arc, Wave,
Flag, and so on. Then you can adjust the look of the warp you
have chosen by moving the Bend, Horizontal Distortion, and
Vertical Distortion sliders. When you are finished, click OK.
The warp is created, and so is a keyframe, as shown in Figure
26.22.

Figure 26.21

The Warp Text dialog box allows you to distort the look of
your text.
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Figure 26.22

To begin animating text, add the text and choose a starting
position for it.

Now you can move on, creating a keyframe whenever you
want to change the warp of the text or any of the other text
properties, and really give your video some punch!

Animating Masks

When you add a mask to a layer in your image, you add two
more properties of your layer that can be animated: the Mask
Position property and the Mask Enable property. Animating
the mask position allows you to change the position of the
mask along with the position of the actual layer. If you have a
mask created over a layer and you change only the position of
that layer, the layer actually moves through the mask,
changing which areas of the layer are visible. In order to keep
the mask in place, you must animate the position of the mask
as well.
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Of course, you can also animate the mask without animating
the layer position to create a unique effect. In some cases, you
must animate the mask to create the illusion of movement in
your layer. If you create a shape, for example, you will notice
that a layer mask is created over a fill over the entire
document. You can't really animate the position of a color fill
with any noticeable results, which is why we had you
rasterize the shape layer in the first example in this chapter,
but you can animate the position of the mask to create the
illusion that the shape is moving around the document.

You can also use the Mask Enable property to turn masks on
or off in an animation. This property works only with a hold
interpolation. In other words, the mask is enabled or disabled,
never halfway in between.

Tip

Because the Mask Enable property cannot contain linear
interpolation, you can't dissolve a mask in or out. You can
create the same effect, however, by creating two layers. The
first layer contains the unmasked area and the second layer
contains the previously masked area (no mask would be
needed in this case). Then you could animate the opacity of
the second layer.

Building 3-D Animations

When you open or create a 3-D file in Photoshop, several new
properties can be animated in the Timeline. Of course, you
can animate the usual properties such as position and opacity,
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but added to that is the ability to animate the 3-D scene
position, 3-D camera position, 3-D render settings, and 3-D
cross-sections. You can also animate the lights, the materials,
and the meshes. This gives you the ability to create 3-D
animations from scratch with 3-D files. Because 3-D files are
three dimensional, you have greater latitude for creating a
realistic animation than you do with simple two-dimensional
images.

Figure 26.23 shows the Timeline with a 3-D model of a Jeep
Wrangler open in Photoshop. You can see that there are many
possibilities for animating aspects of a 3-D object. In this
particular example, we couldn't toggle the 3-D materials
properties open to show in Figure 26.23 because there are
over 30 materials that can be individually animated and the
Timeline would no longer fit in the document window of
Photoshop.

In order to animate 3-D properties, you need a
basic understanding of how to manipulate 3-D objects, which
we cover in Chapter 22. You also need to understand how to
change the properties of individual aspects of the 3-D scene,
which you can learn about in Chapter 23.

To demonstrate how quickly these properties can be
animated, we sank the model of the Jeep into the rock. Follow
these steps to learn how to animate 3-D properties:

1. Open an image file that can be used as a background
for animating your 3-D file.
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2. Choose 3D⇒New 3D Layer from File to open a 3-D
model as a new layer over your image file.

3. Open the Timeline panel.

The Timeline panel is generally docked with Mini Bridge.
Click the tab to display it. You can also choose
Window⇒Timeline.

4. With the playhead set at the beginning of the Timeline,
click the stopwatch icons in the 3-D Scene Position
property and in the 3-D Cross Section property.

This activates the keyframes for those two properties.

5. With the Scene layer selected in the 3-D panel, set the
start position of your 3-D scene using the 3-D tools found
in the Options bar.

Tip

Remember that the 3-D tools are only visible when the
Move tool is selected in the Toolbox.

Figure 26.23

A 3-D model has many properties that you can animate.
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6. Click the Cross Section check box in the Properties
panel to activate a cross-section of your 3-D scene and set
the cross-section properties.

In our scene, we wanted the Jeep to sink into the rock, so we
set the cross-section to the z-axis, flipped it so that the upper
section of the Jeep was visible, and offset it so that the
starting position was below the tires of the Jeep, leaving the
Jeep intact for now.

7. Move the playhead forward in the Timeline to the
desired time of the end result.

We wanted our animation to take four seconds, so we moved
the playhead to the four-second mark.
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8. Change the properties of your cross-section to reflect
the desired final result.

We simply changed the offset so that oNL1y the very top of
the roof was showing.

9. Change your scene position to the desired end result.

We moved our Jeep down so that the edge of the cropped roof
rested on the rock.

10. Play your animation to preview it.

We like to select another tool in the Toolbox, such as the
Hand tool, as we watch the final result so that the ground
plane and widgets disappear. You can see the results of our
simple animation in Figure 26.24.

Figure 26.24

With the placement of just four keyframes, this Jeep appears
to sink into the rock.
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Learning the Basics of Rotoscoping

Keyframes are limiting, as you can't animate filters or even
paint over time with them. However, you can animate just
about anything by employing the technique of rotoscoping.
Rotoscoping has been around almost as long as movies. It
entails tracing animated characters or scenes over live-action
film. It's a useful tool in aiding animators to create more
realistic movement because they are copying that movement
from life. It's also used to create special effects, such as the
light sabers in the Star Wars films.

Today, with the use of computers, rotoscoping has taken on a
broader definition. Now when you hear the term, it can mean
any painting or editing of a video frame, whether or not that
frame is over a live-action scene. With its powerful painting
capabilities and filters, Photoshop is the champion
rotoscoping tool. Although rotoscoping involves making
time-consuming changes to video frame by frame, the effects
that are possible are well worth the effort.

Creating a new video layer

The first thing you want to do to start animating frame by
frame in the Timeline panel is to create a new video layer.
Only video layers contain the Altered Video layer that can be
changed frame by frame, so if your document doesn't already
contain a video file, you need to create a new video layer in
order to animate changes at all. Even if you already have
video clips in your document, you want to create a new video
layer in which to store changes. In fact, it's a good idea to
create a new layer for each major element in your animation.
Creating a new video layer is as simple as choosing
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Layer⇒Video Layers⇒New Blank Video Layer. A new
video layer is added to your project.

Tip

The first thing you want to do with a blank video layer is
give it a unique name that describes the element on that
layer.

A video layer has one more property than other types of
layers in the Timeline panel. That property, as you can see in
Figure 26.25, is an Altered Video sublayer. Within that
sublayer, frames can be altered one at a time to create an
animation.

Figure 26.25

You can create an animation on a new blank video clip with
the Altered Video property.
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Creating modified frames

Now that you have a new blank video clip, you are ready to
animate. You can animate frame by frame in the Timeline by
creating modified frames in the blank video layer. By creating
modified frames, you can change your video in many ways to
add elements and create special effects. We'll show you how
this is done.

You can create individual frames inside any video layer by
following these steps:
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1. With the blank video layer highlighted, move the
playhead in the Timeline to the position where you want
to make the first change.

2. Paint or otherwise make changes to the layer.

3. Click the triangle next to the name of your blank video
layer.

This shows you the properties of that layer, including the
Altered Video sublayer. Within the Altered Video sublayer, a
small segment has appeared, indicating an altered frame, as
shown in Figure 26.26.

Figure 26.26

The highlighted segment in the Altered Video layer indicates
one altered frame.
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4. To build onto the changes you have already made,
choose Layer⇒Video Layers⇒Duplicate Frame to move
to the next frame and duplicate the frame you just
created.

5. Make further changes to your animation.

6. Continue duplicating frames and making changes to
your animation until you have completed it.
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We animated a little girl growing a profusion of hair, as
shown in Figure 26.27.

You may not want to build on the animation created in a
previous frame. That's okay; just navigate to an unaltered
frame and make new changes. You can move to the next
frame by using the frame advance in the playback controls or
by selecting Go to Next Frame in the Timeline panel menu.
You can also choose Layer⇒Video Layers⇒Insert Blank
Frame.

Figure 26.27

Using several frames, we were able to animate hair growing.
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Tip

You may have noticed that there are no shortcuts for the
menu-intensive task that we just had you complete. When
you are duplicating frames as often as building animation
requires, you get tired of constantly navigating through the
menu to do it. Bet you'd like to create a shortcut, right?
Choose Edit⇒Keyboard Shortcuts, and you can create your
very own shortcuts for the actions that you perform most
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frequently. Now your only worry is actually finding an
unused shortcut!

Using Onion Skins

An onion skin, a real onion skin right off an onion, is
semitransparent and very thin; onionskin paper is also
semitransparent and thin — that's how it got its name. This
quality has made it ideal for use in animation to make the
transitions smoother from one frame to the next. The idea is
that the previous frame can be traced onto the next frame,
making the small changes necessary to create the illusion of
movement.

Computer animation has made using Onion Skins an
incredibly simple process. By temporarily making your
animation frames semitransparent, you can create the next
step in your animation by referring to the last one.

That's the basic idea. Photoshop allows you to set parameters
for the Onion Skins feature that go far beyond just being able
to see the last frame from the present frame, such as seeing
multiple frames at once in different stages of opacity. Besides
having multiple settings for the Onion Skins themselves, there
are other benefits to using Photoshop. You can create Onion
Skins in any clip and make modifications in a different clip.
For example, you might want to animate a motion trail for
something that is moving in a video layer, such as a space
ship. You could create Onion Skins in the live-action video
layer and paint over the motion in a blank video layer.
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To access the Onion Skin settings, select Onion Skin Settings
from the Timeline panel menu. The Onion Skin Options
dialog box opens, and you can set any number of ways for
your Onion Skins to work. As you make changes in the dialog
box, you can see how they affect the view of the current
frame in the Timeline in real time, as shown in Figure 26.28.

Figure 26.28

The Onion Skin Options dialog box offers a much greater
range of options than a piece of tracing paper.

You can use the following settings to modify the Onion Skins
feature:

• Onion Skin Count. This section allows you to set the
number of frames that you want to show through to the
current frame, both before and after the current frame. You
can show up to eight frames before and eight frames after.

• Frame Spacing. This field determines whether the frames
being shown are consecutive or appear with gaps in between.
A setting of 1 means the frames are shown in consecutive
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order. A setting of 2 means that only every other frame is
shown.

• Max and Min Opacity %. These fields specify the
maximum and minimum opacity of frames. If you have more
than one Onion Skin Count, you probably want to see the
closer frames at a higher opacity than those that are farther
out from the current frame. These two settings allow you to
set the maximum opacity for the closer frames and the
minimum opacity for the farthest frames. The frames in the
middle are a setting somewhere in between the two opacities.

• Blend Mode. This drop-down menu allows you to change
the way the opacity setting is applied to the Onion Skins.
Different files are easier to work with in different blend
modes. You can choose from four blend modes: Normal,
Multiply, Screen, and Difference.

When you have made the changes to the Onion Skin options,
click OK to close the dialog box. The Onion Skins are
automatically enabled with the settings you specified. You
can toggle the Onion Skins on by choosing Enable Onion
Skins from the Timeline panel menu.

As you move along in your animation, the Onion Skins move
with you, helping you to create any frame along the Timeline.
You can change the settings at any time as your needs change.

Restoring frames

As you make changes to various frames, you might come to a
point where you want to discard the edits to one frame or all
of them. This is as easy as selecting the frame that you want
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to restore to its original appearance and choosing
Layer⇒Video Layers⇒Restore Frame. If you want to discard
all the altered frames, choose Layer⇒Video Layers⇒Restore
All Frames. Unfortunately, this process is not as easy as using
the hotkey for deletion or dropping the altered layers into the
trash, but hopefully you won't need to use it often.

Animating DICOM Files

A DICOM file is a medical image or series of images created
when you have a sonogram, a CT scan, an MRI, or any
number of procedures that take an image of the inside of your
body. Photoshop has the capability to view these files as well
as animate them. Animating a DICOM file is similar to
importing an image sequence. Of course, to create an
animation, you must have a series of DICOM images.

To open a series of DICOM files and animate them, follow
these steps:

1. Choose File⇒Open.

2. Browse to a DICOM file that is a series of images.

DICOM files have the capability of saving an image sequence
as one file. Select the file, and click OK. A dialog box opens,
allowing you to set the parameters for opening the DICOM
file, as shown in Figure 26.29.

3. Select the frames you want to animate by pressing and
holding the Ctrl/ key as you select them one by one, or
click Select All.
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4. Click the Import frames as layers radio button in the
options on the right side of the dialog box to create a layer
for each frame that is imported.

Figure 26.29

You can open a DICOM file in several ways, or you can
simply export it to a JPEG. In this example, you want to
animate it, so you need to create a layer for each image in the
DICOM file.

5. Select Anonymize if you want to scrub out the headers
contained in the DICOM images.

6. Click Open.

7. From the Timeline panel menu, select Make Frames
from Layers.
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You can see in Figure 26.30 that a frame has been created for
each image contained in the DICOM file. Now you can view
the file as an animation or export it in a video file format.

Figure 26.30

The Timeline (Frames) panel shows more clearly how each
image has become a frame in this new DICOM animation.

Summary
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In this chapter, you learned how keyframes play an important
part in making animation easy and fun. With the powerful
Photoshop tools at your disposal in creating animations, what
you can create is limited only by your imagination. You
learned how to do the following:

• Create and edit a keyframe

• Animate the different properties of a layer

• Animate a text warp

• Animate one frame at a time

• Animate DICOM files
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Chapter 27: Correcting Video Files and Adding Artistic
Effects

In This Chapter

Changing the color and tone of a video

Using videos as Smart Objects

Correcting a video layer using filters

Cloning and healing within a video file

The basics of improving your video files by correcting
lighting and color, adding artistic effects, or cloning and
healing inside of them are not much different than making
these changes to an image file. The tools are the same, and the
effect they have on video files is identical to the effect they
have on image files. The difference lies in how you want to
apply the effects to your video. You can apply effects to the
entire file, to a portion of the file, or to an individual frame.
This chapter demonstrates different methods of application
and gives examples of where you would use each one.

Enhancing Layers with Color Corrections

Color correction can enhance almost any photo, particularly
when the photo was taken in bad lighting. Videos are even
more susceptible to environmental lighting problems that
need correction. When it comes to color correcting a video
layer, you can use the Image menu to change the video frame
by frame, or you can create a fill or adjustment layer that
affects the entire video layer. Unless you are creating a
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special effect or animating a color correction, you want to
skip the tedious process of color correcting frame by frame.

This chapter assumes you know how and why to
apply adjustment layers in Photoshop. In Chapter 10, you can
learn about the individual fill and adjustment layers and what
they can do to correct not only photos but also videos.

On the other hand, color corrections apply specifically to the
image you are working with. They are different from filters in
this respect. You can sharpen (to some degree) a video file
arbitrarily over the entire file and probably not be
disappointed with the results, but if you adjust the levels of a
video file that contains a combination of lighter and darker
images, you will find that the overall results are horrible. As
you correct color, you want to carefully split the video layer
into sections that consist of similar areas in color and tone.

Adding an adjustment layer to a video clip is as simple as
selecting the video clip you would like to adjust and choosing
an adjustment layer from the Layers panel, just as you would
with an image file. The adjustment layer you choose is added
to the Layers panel and is automatically grouped with the
selected video clip. It is also linked with the video clip so that
the adjustment only affects the selected video clip, and not
any other layers that are below it, as shown in Figure 27.1.

Figure 27.1

An adjustment layer appears in a grouping with the video
layer that it affects.
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In addition, every fill or adjustment layer is created with a
layer mask. If you have an area of your video file selected, the
mask automatically reflects that selection. If you don't have
anything selected in the file, the mask is white, indicating that
the entire file is selected. You can delete or change the layer
mask at any time, keeping in mind that it also affects the
video clip for the entire duration.

When newly placed, an adjustment layer continues through
the duration of the video clip that it is linked to. For example,
you can see in Figure 27.2 that we have added a Levels
adjustment to Video Group 1 and a Hue/Saturation
adjustment to Video Group 2. Because these adjustments are
linked to their respective layers, the adjustments last for the
duration of the clip only. You can change the way the
adjustment affects your document by unclipping it from the
video layer or changing its duration.
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Note

In order for you to see the adjustment layers in Figure 27.2,
we ungrouped the adjustments from the video layers. When
these adjustments are placed in a group, they are not visible
on the Timeline.

Figure 27.2

Because the adjustment layers are automatically clipped to the
video clip that was selected when they were applied, they last
for the duration of that clip only.
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Unclipping an adjustment layer

Using the Properties panel, you can unclip the adjustment you
created from the video clip it's attached to so that it affects all
the layers. You may want to do this in order to create a Levels
adjustment over several clips that were shot in similar
lighting, or if you are adding a color effect to an entire video
project. To unclip a fill or adjustment layer from the layer
below it, select it in the Layers panel and click the New
adjustments affect all layers below icon in the Properties
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panel. Once you've done that, the fill or adjustment layer
expands to fill the entire duration of the video, as you can see
in Figure 27.3.

Figure 27.3

When you unclip a fill or adjustment layer from the video
layer below it, it affects the entire video file.

Note

A fill layer appears in the Layers panel and in the Timeline
panel as its own layer. You can't clip a fill layer to the layer
below it, only the adjustments that can be applied and
changed using the Properties panel. You can use any of the
other methods of restricting layers mentioned in this section
on a fill layer.

Changing the duration of an adjustment layer
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When you add an adjustment layer to your video, the duration
is automatically set from the position of the playhead to the
end of the video clip that you have selected. To change the
duration of the adjustment, you need to ungroup it from the
video group in which it has been placed.

Follow these steps to change the duration of an adjustment
layer:

1. Right-click the group layer in the Layers panel.

This opens a shortcut menu specific to the group layer.

2. Click Ungroup Layers.

This deletes the group layer, and each of the layers previously
contained in this group become separate from the others.
Your adjustment layer appears in the Timeline panel.

3. Drag the beginning or end of the duration bar for the
adjustment layer so it is exactly as long as you need it to
be, as shown in Figure 27.4.

Figure 27.4

Changing the duration of an adjustment layer means
ungrouping it, which enables you to access it in the Timeline.
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You can adjust the duration of any layer using
several methods outlined in Chapter 26.

Applying Smart Filters to Video Files

You can add filters to a video clip in two ways: by adding
them directly to a regular clip or by changing the clip into a
Smart Object and adding Smart Filters. This has special
implications for a video clip, because adding a filter directly
to it changes only one frame of video, causing your filter to
blip in and out of existence too fast for the eye to see. To
avoid having to add a filter one frame at a time, you need to
change your video layer into a Smart Object.

When you change a layer into a Smart Object, the thumbnail
in the Layers panel changes to show that the layer is treated
differently. After you've converted a video layer to a Smart
Object, you can see a difference in the Timeline panel as well.
Figure 27.5 shows the Timeline panel after the video layer
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has been changed to a Smart Object. There is no Altered
Video property for a Smart Object. Now this layer is just like
an image or a 3-D layer; any changes you make to it affect the
entire layer.

Figure 27.5

There is no Altered Video property in a Smart Object, even if
it was once a video layer.

Adding a Smart Filter to a Smart Object that is an embedded
video clip is no different than adding a Smart Filter to any
other Smart Object. Choose a filter from the Filter menu,
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change the settings if necessary, and add it to your file. You
can use corrective filters, such as the sharpening or blurring
filters, or you can create artistic effects by applying other
filters.

When you add a filter to a video clip that has been turned into
a Smart Object, it affects the entire layer, and the filter is
applied as a sublayer in the Layers panel, as shown in Figure
27.6. Now, as you play back your video, you see the filter's
effects all the way through.

After you've converted a video layer to a Smart Object, you
can use the embedded video clip to make changes to the
Altered Video property. You can do this by double-clicking
the Smart Object layer thumbnail. Photoshop opens the
original document containing your video layer, as shown in
Figure 27.7. When you finish making changes to the original
file, save it, and the changes are reflected in the new file
containing the Smart Object. Turning your file into a Smart
Object adds a few steps to the editing process, but if you want
to apply a filter across the entire video layer, it's the only way
to go.

Figure 27.6

A Smart Filter is applied to the entire layer.
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Figure 27.7

Double-clicking the thumbnail of a Smart Object gives you
two files to work with: one a video layer that can be changed
frame by frame and the other a Smart Object file.
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In essence, having the option to turn a video layer into a
Smart Object gives you full editing capability. You can apply
a filter frame by frame or you can apply the filter to the entire
video clip. The method you use depends on the effect you are
trying to create, of course. Using a filter to correct a video
layer usually incorporates the entire file. If you are creating
special effects, however, you may want to change your filter
frame by frame or add it to a small segment of your video.

We cover the filters, including Smart Objects and
Smart Filters, thoroughly in Chapter 20.

Cloning and Healing Over an Entire Video Layer
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As a general rule, cloning and healing in video layers is done
on a frame-by-frame basis, simply because a video involves
movement, and movement makes it difficult to clone or heal a
specific area and still achieve desirable results. There are
instances, however, where you may be able to create a fix that
lasts at least several frames, saving you from the tedious
process of cloning frames one at a time.

In order to do this, the video must be stable, probably taken
with the camera on a tripod, and the object or flaw that you
want to remove must be stationary over several frames. The
3-D video pictured in Figure 27.8 is a perfect example. The
fern in the background is stationary through several frames.
By creating a new blank layer over the video file and
sampling all layers, we were able to create one clone fix that
took the fern out over several frames, as shown in Figure
27.9. The fix worked until the shadow of the ball intersected
with the cloned area, as shown in Figure 27.10. At this point,
we ended the duration of the clone layer and used the Altered
Video property to clone each frame separately, as
demonstrated later in this chapter.

Figure 27.8

This video is stable and the fern is stationary, so we could
clone it out of several frames with just one fix.
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Figure 27.9

A blank layer placed over our video layer contained the fix,
so the default duration lasted the entire video.
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Figure 27.10

The clone no longer worked at this point in the video, so we
changed the duration of the clone layer and made
frame-by-frame fixes.

You can learn all about the cloning and healing
tools and how to use them in Chapter 15. You will also find
this video file used in another cloning example in that
chapter.

Note
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Cloning or healing on a blank layer is necessary if you want
your fix to last more than one frame. This is because
creating a cloning or healing fix on a video layer creates an
altered frame in the Altered Video property and
consequently changes only the frame you have currently
selected.

Modifying Video Clips Frame by Frame

In Chapter 26, we introduced you to the basics of rotoscoping,
and now we show you how you can use the rotoscoping
techniques to apply corrections to your video on a
frame-by-frame basis. Modifying video clips frame by frame
enables you to make corrections and add artistic effects. For
example, you can remove unwanted elements from video
clips frame by frame by using the cloning and healing tools.
You can animate transformations, such as skew, distort, and
wrap, frame by frame. You can also animate adjustments and
filters by changing them frame by frame. In Figure 27.11, we
animated a color adjustment over a still photo to give it more
life.

Tip

To animate an adjustment on a still image, you need to copy
and paste the pixels into a video layer with an Altered Video
property.

Figure 27.11
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To animate a color change, you need to apply the Color
Balance adjustment frame by frame.

Note

If you find yourself in a situation where you are repeatedly
performing the same tasks to achieve similar results — and
you usually will when you start animating frame by frame
— it's time to create an action. An action fully automates the
process. For example, you can animate a color change by
creating an action that works at any time on any video file
just by clicking the Action button. You can also create a
color change sequence that prompts the user for input when
the Color Balance dialog box is used, so that the animation
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has custom settings every time you use the action. You can
learn how to create timesaving actions in Chapter 5.

Adding an adjustment to a single frame

Throughout this book, whenever we talk about adding
adjustments to a file, we show you how to create an
adjustment layer using either the Layers panel icon or the
Adjustment panel. The versatility of having adjustments that
you can move and edit has greatly outweighed the
inconvenience of adding one more layer to the Layers panel.
If you want to add adjustments to a video frame by frame,
however, that all changes.

You can create an adjustment layer that affects only one
frame of video, but you need to reduce its duration in the
Timeline to one frame, and then create a new adjustment layer
for the next frame. You can see that unless you are planning
to change only a handful of frames — less than in the blink of
an eye in a standard video file — creating a new adjustment
layer for each frame of video quickly becomes unwieldy.

So, for the first time in this book, we are going to suggest that
you use the Image⇒Adjustments menu to apply the
adjustments directly to a video layer, creating an adjusted
frame in the Altered Video property of that layer. Although
the adjustments made in the Altered Video property are hard
to change, this is ultimately the better option.

With the video layer selected, choose Image⇒Adjustments
and select the adjustment you want to apply. The adjustment
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is added to the currently selected frame. You can then move
to the next frame of video and add a new adjustment. Most of
the adjustments have hotkeys, and an action is very useful if
you are planning to make extensive adjustment changes.

Adding a filter to a single frame

The filters are simpler to add to a single frame of video than
an adjustment. As we mentioned earlier in this chapter, you
can't add a filter to an entire video file unless it is a Smart
Object. Simply adding any filter to a video file creates a new
segment in the Altered Video property. There are several
reasons for adding a filter frame by frame. You can animate it
by applying or reducing the filter effects over time, or you
may want to apply a mask so the filter is applied only to
selected areas of a video file. As the video changes, the mask
needs to change as well, requiring work in each frame.

Cloning and healing video files

Most of the cloning and healing you do to a video file needs
to be done frame by frame. The ability to use alternate clone
sources is vital because you can clone one frame into another.
For example, Figure 27.12 shows an image of a happy couple
on their wedding day. They are preparing for a romantic kiss.
The video effect is in slow motion, there's a great love song
playing in the background, and love is in the air. Jump ahead
several frames to Figure 27.13. The kiss is still very romantic,
the music is still playing, but some unromantic company has
joined the shot.

Figure 27.12
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This shot of the happy couple is unmarred.

Figure 27.13

Unexpected company distracts from the mood of the video.
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To fix this problem, activate the Clone Stamp tool and open
the Clone Source panel. Rewind to the first frame, and
Alt-click/Option-click to use it as a source. Using the overlay,
place it over each of the next few frames to clone out the
company with a few quick swipes of the mouse. Although the
couple is moving, it's easy to use the architecture of the
building as well as the light in the flowerbed to line up the
overlay exactly, as shown in Figure 27.14. After the overlay
is lined up, you can simply click and drag the Clone Stamp
tool over the areas you want to hide, and the illusion is
perfect, as shown in Figure 27.15.

Figure 27.14

Lining up the clone source is easy using stable objects in the
video.
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Of course, you can see in Figure 27.16 that only one frame of
your video has been changed so far. You're in for a long
frame-by-frame fix. However, using the Clone Stamp is so
much fun that it might even be enjoyable. To really use the
five clone sources available to you in the Clone Source panel,
you probably want to choose five different frames to clone so
that as the camera moves even a miniscule amount, you have
a clone source that easily matches the angle and size.

Figure 27.15

Cloning out the extras restores the romance.
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Figure 27.16

The Clone Stamp tool changes a video layer frame by frame.

Locking the source frame

As you use the Cloning tool to change a video file frame by
frame, one option in the Clone Source panel is going to be
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critical to your success. When you choose a clone source
from a video file, you have the option to lock the source to the
frame that you originally sampled or to move the source the
same number of frames you move from the first target in the
Timeline. In other words, after fixing the frame in Figure
27.16, we plan to move onto the next frame of video to fix
that frame as well.

If the Lock Frame check box is selected in the Clone Source
panel, as shown in the first panel in Figure 27.17, the clone
source remains the same frame that we used to change the
previous frame of video. In this case, frame 837 continues to
be our source. If the Lock Frame check box is not selected,
the clone source moves ahead one frame in our video. The
second Clone Source panel in Figure 27.17 shows that the
frame offset remains at −3 frames, no matter what frame we
target.

Figure 27.17

Lock the target frame if you want it to be consistent
throughout your edits with the Cloning tool.
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If your video is stable, you may find that it's easier to use a
locked source that you know is clear and free of defects. If
your video is unsteady, it might be easier to use a frame offset
that is only one or two frames away from the frame you are
changing. In most cases, this helps to keep the source and
sample frames similar.

Summary

In this chapter, you learned that applying fixes to a video file
can be a tricky process involving both the Layers panel and
the Timeline panel. Mastering the properties of each one has
given you the capability to make corrections to your video as
a whole or to make them frame by frame. You learned how to
do the following:

• Add adjustments to video files

• Use filters to create fun artistic effects

• Clone and heal video layers
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Chapter 28: Animating Using Frames

In This Chapter

Exploring frame animation

Tweening between frames

Creating an animation from a layered image

Rendering video and animation projects to video files

In this chapter, we introduce you to the frame animation
version of the Timeline panel. The frame animation version is
very different from the Timeline; it has a different look and
feel and different features to go along with it.

The Animation Timeline panel is made primarily for you to
import video files and color correct, enhance, or create artistic
effects with them. The Animation (Frames) panel frame
animation version of the Timeline panel is meant primarily to
be used with the painting and drawing tools to create cartoon
animations, primarily animated GIF files for the web.

Note

Animated GIFs are small, animated images or icons that you
see almost everywhere on the web. They are usually simple,
such as animated smiley faces, and operate at an extremely
slow frame rate, giving their motion a jerky appearance.
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You'll find that the panels and menus of these two types of
animation are completely different from one another. In this
chapter, we introduce you to the frame animation version of
the Timeline panel and show you different methods of
animating using this panel.

Using the Timeline Panel's Frame Animation Interface

Although frame animation has most of the capability of the
Timeline, you'll find that its strength lies in creating short,
crude animations, such as animated GIFs. Being able to see
each frame without dragging the playhead around is very
handy. Frame animation can become unwieldy in a few
frames, however, as you'll see when you begin to create
animations in this chapter.

Some of the other advantages of frame animation are the
ability to reverse frames or set the frame rate of each frame
individually without much effort. If you change a Timeline to
a frame animation, however, you permanently lose some of
the properties of the keyframes set in your Timeline. You
must determine which animation method you want to use
before you begin a project. Before we show you how to create
animations using the frame animation version of the Timeline
panel, let's look at the features that distinguish frames from
the Timeline.

Using the panel features

With frame animation, thumbnails represent each individual
frame in your animation. This gives it an entirely different
look than the Timeline, as shown in Figure 28.1. The look of
the animation is not the only thing that's changed; the actual
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panel has completely different options. Let's look at what the
differences are and why they are different.

Figure 28.1

The frame animation version of the Timeline panel offers a
unique set of options.

Setting the frame delay time

The frame delay time allows you to quickly set the time you
want each frame to last. Click the arrow next to the frame
time below the thumbnail, and select the number of seconds
or fractions of seconds you want your frame to last. Click
Other if you would like to set a time that is not specified. You
can select one frame at a time and set different rates, or you
can select all the frames to change the rates in all of them at
the same time. When you add a new frame to the animation, it
automatically retains the delay rate of the frame immediately
before it.
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Changing the disposal method

The Disposal method icon doesn't appear by default on the
frame icons, but if you right-click one or more selected
thumbnails, you are asked to choose a disposal method.
Choosing either Do Not Dispose or Dispose creates a
different icon for each method of animation.

A disposal method simply determines whether the current
frame is disposed of as the next frame is displayed. There are
three disposal options:

• Automatic. This is the default option. It allows Photoshop
to determine the disposal method for each frame
automatically. The current frame is disposed of if the next
frame contains layer transparency. When you select this
option, no icon appears in the frame thumbnail.

• Do Not Dispose. This option preserves the current frame as
the next frame is brought into view. If any part of the frame is
transparent, the preceding frames show through.

• Dispose. This option disposes of the current frame as the
next frame is displayed, preserving the transparency of the
current frame.

Choosing your looping options

Setting the looping options simply determines how many
times your animation plays without stopping. Click the
Looping options icon to open a menu, and select Once, 3
times, Forever, or Other. If you select Other, a dialog box
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opens, allowing you to specify the number of times you want
the animation to loop.

Tweening using frames

Keyframes are no longer in the frame animation version of
the Timeline panel, but you can still take advantage of
tweening. Tweening is the process of creating frames between
two frames with different properties, making the change
gradual over several frames. When you have enough frames,
you give the change the illusion of true motion. Although the
frame animation version of the Timeline panel has no layer
properties, the properties that can be animated in the Timeline
are the same properties that can be tweened using frames.
These properties are position, opacity, and style.

To create tweening frames, select one or two frames in the
panel and click the Tweens animation frames icon, shown in
Figure 28.2. The Tween dialog box opens, as shown in Figure
28.2, allowing you to set options for the tweening.

Tween With

The first option available in the Tween dialog box is the
Tween With menu, which allows you to set which frames you
are going to tween, as follows:

• Selection. This is the default option if you've selected the
two frames that you want to tween. If you don't have two
frames selected, this option isn't active.

• First Frame. This option can be chosen only if you have
selected the last frame in the animation. If you select the First
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Frame option, Photoshop tweens between the last frame and
the first frame of the animation, creating a seamless loop.

• Last Frame. This option is available only if you have the
first frame of the animation selected. Just like the First Frame
option, this creates tweening from the last frame to the first
frame.

• Previous Frame. This option creates tweening between the
selected frame and the preceding frame.

• Next Frame. This option creates tweening between the
selected frame and the next frame.

Figure 28.2

Adding tween frames creates additional frames that transition
between two frames. You can set the tweening operation and
the number of frames to add, as well as the layer, position,
opacity, and effects options in the Tween dialog box.
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Frames to Add

The next option in the Tween dialog box is simply how many
frames you want to have created between the frames you are
tweening. You should take your frame rate into account, as
well as the complexity of the difference in the frames you
want to tween.

Layers

Next in the Tween dialog box, you can set the layers that will
be affected by the tween. Choose All Layers if you would like
to animate all the layers within the file, or choose Selected
Layers to confine the tweening to layers you have selected.
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Parameters

The Parameters setting is reminiscent of the animation
properties in the Timeline panel, where you can decide
whether to tween all changes in position, opacity, and style or
to tween only one or two of these parameters. Choosing a
parameter is the equivalent of using linear keyframes in an
interpolation, whereas deselecting a parameter is like creating
a hold keyframe.

After you set the tweening options, click OK. The frames you
have specified are created, as shown in Figure 28.2.

Duplicating selected frames

Click the Duplicate selected frames icon on the bottom of the
frame animation version of the Timeline panel, and all the
frames you have selected at the time are copied and pasted
directly behind the last frame you selected. This is a quick
and easy way to duplicate the last frame and then make
changes to it.

Converting to video timeline

To convert the frame animation version of the Timeline back
to the video Timeline, click the icon labeled Convert to video
timeline. You should do this before you start working with
your animation. Moving from the video Timeline causes
some of the properties — keyframes in particular — to be
lost. Toggling back to the video Timeline does not restore the
lost properties. It's best to decide which version of the
Timeline panel you want to work in before opening or
creating a new document, and stick to that decision.
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Activating the frame animation version of the Timeline panel
menu

Click the menu icon to activate the flyout menu for the frame
animation version of the Timeline panel. It is very different
from the Timeline menu, so we introduce you to the different
options in the next section.

Looking at the frame animation Timeline panel menu

Just in case you hadn't yet noticed, the frame animation panel
menu lets you know that you are not working with the same
tools as the video Timeline panel menu. As shown in Figure
28.3, the menus have completely different options.

These differences highlight the features of each panel and the
reasons why each panel can perform equally important but
different functions. We define the features found on the frame
animation menu here. Many of these options are
self-explanatory, but a few may be unfamiliar. If you find that
a short definition isn't enough, don't worry. You'll see more
on these features later in this chapter.

Here is a brief overview of the features:

• New Frame. This option creates a frame at the end of the
animation. This frame is a duplicate of the last frame in the
animation.

• Delete Frames. This option deletes any selected frames.

• Delete Animation. This option deletes all frames except the
first one, leaving an image rather than an animation.
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• Copy Frames. This option copies selected frames.

Figure 28.3

Comparing the frame animation version of the Timeline panel
menu with the video Timeline panel menu

• Paste Frame. This option pastes copied frames. You can
choose four options for pasting a frame:

• Replace Frames. This option replaces all selected frames
and their accompanying layers with the copied frames.

• Paste Over Selection. This option pastes the copied frames
over the selected frames, creating two levels of layers: the
layers in view, belonging to the copied frames, and the layers
that are hidden, belonging to the selected frames.
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• Paste Before Selection. This option pastes the copied
frames before the first selected frame.

• Paste After Selection. This option pastes the copied frames
after the last selected frame.

• Link Added Layers. This option works in conjunction with
the previous four options to automatically link layers in the
pasted frame. It is a good idea to link the layers of frames in
the animation so that you can more easily make adjustments
while editing your animation.

• Select All Frames. This option selects all frames within the
animation.

• Go To. This option selects the frame that you specify —
next, previous, first, or last.

• Tween. This option performs the same function as the
Tween icon in the panel. It creates a specified number of
frames in between two selected frames to bridge the gap in
their differences.

• Reverse Frames. This option reverses the order of any
selected frames. If only one frame is selected, the order of the
entire animation is reversed.

• Optimize Animation. This option allows you to reduce the
file size of an animation by optimizing the frames to include
only areas or pixels that change from frame to frame. You
have two options for optimization: Bounding Box crops each
frame to an area around the changing pixel, and Redundant
Pixel Removal makes any unchanged pixels transparent. You
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can enable both of these options when optimizing the
animation.

• Make Frames From Layers. This option is available when
the animation contains only one frame or image. When you
select Make Frames From Layers, all the layers contained in
the image become an individual frame.

• Flatten Frames Into Layers. This option allows you to
create an individual layer for each selected frame in the
Layers panel.

• Match Layer Across Frames. This option allows you to
align layers according to the parameters of position, visibility,
and style.

• Create New Layer for Each New Frame. This option
creates a new layer in the Layers panel for every frame
created in the frame animation version of the Timeline panel.

• New Layers Visible in All Frames. This option makes the
new layers that you create on any frame visible in all the
frames. Deselect this option if you want to add a layer to a
selected number of frames.

• Convert to Video Timeline. This option converts your
frame animation version of the Timeline panel to the video
Timeline panel.

• Panel Options. This option allows you to set a thumbnail
size for the frames in your animation.

Using the animation features in the Layers panel
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When you are using the frame animation version of the
Timeline panel, you not only see differences in the Animation
panel and the Panel menu, but in the Layers panel as well.
The Layers panel includes an array of tools that allow you to
unify changes made to the layers displayed in this panel. The
properties that you can unify are the same properties that you
can animate. By default, making changes to these properties
takes place only on the selected frame. By unifying these
properties, you can make changes to all the frames at once,
similar to changing an entire layer across the Timeline. Figure
28.4 shows the icons that are used for this purpose.

Figure 28.4

The Unify icons are located in the Layers panel.
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• Unify layer position. When you click this icon, you can
change the position of a layer throughout the animation.
Deselecting this option allows you to change the position of
the selected image only, leaving the rest as they were.

• Unify layer visibility. When you select this option,
changing the visibility of a layer changes the visibility in all
frames; otherwise, only the selected frames are changed.

• Unify layer style. When you select this option, Photoshop
creates a layer style across all the frames in the animation.
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• Propagate Frame 1. When you select this option, all the
changes made in the first frame of the animation are also
made to subsequent frames in the animation. This is an easy
way to make the changes that can be animated in other frames
and still be able to change the position, opacity, and style of
all the frames at once.

Creating Tweened Frame Animations

Creating tweened frame animation is the process of animating
by generating new frames that transition step by step between
two frames. This is similar to using keyframes in the video
Timeline panel. Using tween frame animation you can
quickly build an animation by just creating a few main frames
and then animating between them.

Opening an image to animate

The first step is to open or create a file in which you want to
animate at least one of three properties: position, opacity, or
effects. An image that is composed of several layers and
styles can be much more interesting and fun to animate than a
simple image. Figure 28.5 shows an image created by using a
composite of a photo, a 3-D object, and several layer styles to
show a gateway to another world. We used this image to
animate the gateway opening.

Figure 28.5

A mysterious gateway

1737



After opening a file, choose Window⇒Animation if you don't
already have the Animation panel open. The Animation panel
opens by default to the video Timeline panel. Use the Convert
to frame animation icon at the bottom-right corner of the
panel to convert the panel to the frame animation version of
the Timeline panel. You can also choose Convert to frame
animation from the Panel menu.

Your image becomes the first frame in your new frame
animation. For simple animations, you may want to take a
moment to change the frame rate to a slower speed, such as
15 frames per second, by clicking the arrow at the bottom of
the frame thumbnail. This makes the file smaller, but less
smooth in transitions. Remember that you can also change the
size of the thumbnails by opening the Panel menu and
choosing Panel Options.

Creating keyframes
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Now that you've opened a document and the animation panel,
you need to create keyframes. The video Timeline panel
allows you to create keyframe icons that let you visualize
where the changes are being made. It's also true that a
keyframe is defined as a frame that determines a change in the
animation process. In frame animation mode, you can actually
visualize your keyframes, because they each have a frame
thumbnail in the panel. The downside is that after you've
tweened those keyframes, nothing distinguishes them from
any other frame in the panel.

To create a keyframe, you need to determine what you plan to
animate and how you want that animation to proceed. Is the
image you opened the first, middle, or last of your animation?
Before you create a new frame, change anything you need to
in the first image to make it look like you want your first
frame to look.

We wanted to make two new keyframes for our gateway to
another world. First, we wanted the gateway to appear, and
then to activate. Because we started with a view of just the
photo, we changed the opacity of the layer containing the arch
and the layer style to zero, as shown in Figure 28.6.

Figure 28.6

The first keyframe is a photo of a simple desert scene.
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Now you are ready to create a new frame. Click the Duplicate
selected frames icon at the bottom of the frame animation
panel. A new frame is created that has the exact same features
of the first frame — the same frame rate and image. You need
to make changes to this second frame to make it your second
keyframe.

In our example, we turned the opacity of the gate up to 100
percent to create our second keyframe. The gate was in
Dissolve Blend mode. After tweening these two frames, our
gate came into view over several frames, as shown in Figure
28.7. We wanted our gate to dissolve in more slowly than we
wanted it to activate, so we changed the frame rate of our
second keyframe to one-half second, which was half the rate
of the first keyframe.

Figure 28.7

1740



We added an arch that was going to dissolve in slowly for the
second keyframe.

You can continue to create keyframes just like this — create a
new frame and make changes to it to create one more step in
your animation. We had one more keyframe to create in our
animation, so we created another frame and turned the opacity
of the layer style up to 100 percent in that layer. Now we had
the same image that we brought in, creating three distinct
keyframes, as shown in Figure 28.8.

Figure 28.8

We created three distinct keyframes.
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Tweening keyframes

Now that you've created the keyframes, it's time to create an
animation by tweening them. Select the first keyframe, and
click the Tweens animation frames icon at the bottom of the
animation panel. The Tween dialog box opens, allowing you
to specify the tween settings. Tween to the next frame, and
enter the number of frames to add to the animation. If you
made changes to more than one layer, choose All Layers; if
not, choose Selected Layers. Deselect any properties that are
not being tweened.

With our first frame selected, we added five frames to tween
it to the next frame. The only parameter we changed between
the first frame and the second frame was the opacity of the
gateway, so we chose Selected Layers and Opacity, as shown
in Figure 28.9. After we added the frames between the first
and second frame, we selected the second keyframe and
repeated the process. The result was 13 frames, creating the
animation of the gateway appearing, as shown in Figure
28.10.

Figure 28.9

You can customize the Tween dialog box to reflect your
animation properties.
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Figure 28.10

By tweening three keyframes, we created a complete
animation.

As you create more frames, you start to see the limitations of
frame animation. If you created an animation at the video
standard, it would be 30 frames per second of animation. Our
gateway animation was 9.5 seconds long; it was very jerky,
and with the relatively miniscule number of 13 frames, it was
already unwieldy and hard to manage. You can imagine what
it would be like if we had tweened it out to nearly 300 frames
to create a smooth animation!

So even though the frame animation version of the Timeline
panel can animate almost anything that the video Timeline
panel can, its feasibility is limited to small, animated GIFs.
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On the Web

The project file used in Figures 28.5 through 28.10 is
available as Figure 28.10, a PSD file, on the book's website.
You can play the animation and try adding your own
background and adjusting the animation.

Creating a Frame-by-Frame Animation

When you want to create an animation using the Paint tools in
Photoshop, you need to animate it frame by frame, using a
new layer for every frame. This enables you to add whatever
paint or effects you want to each frame without affecting any
of the other frames.

In this section, we show you how to use the Photoshop Paint
tools to build an animation frame by frame. You can do this
in two different ways: you can create a layered image,
containing all the elements needed for an animation and then
turn it into an animation, or you can simply start building the
animation right in the frame animation version of the
Timeline panel. We show you how to create an animation
using both ways.

Creating an animation from a layered image

When you create an animation from a layered image, you
need to first create an image with several layers that
eventually become frames in your animation. You can create
an image in Photoshop that contains all the layers needed to
turn it into an animation in just a few simple steps. The
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following example takes you through animating the process
of adding flowers to a meadow in an existing image.

On the Web

You should try to do this activity with your own animation,
just to get the hang of it. If you want to look at our final
project, however, it is available as Figure 28.15, a PSD file,
on the book's website.

1. Open an image containing a meadow in Photoshop.

2. Open another image with flowers.

3. Create a cutout selection of the flowers.

In this example, we created four separate sizes of the flowers
by resizing the selection and placing each size in its own layer
in the image with the meadow, as shown in Figure 28.11.

4. Create a new blank layer.

5. Use the Clone Stamp tool to add multiple copies of the
flowers to the new blank layer.

We discuss the Clone Stamp tool in Chapter 15.

Figure 28.11

Cut out the flowers in multiple sizes to add to the meadow
layer.
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6. Repeat Steps 4 and 5 several times, each time creating a
new layer and adding additional flowers of different sizes
to the new layer, as shown in Figure 28.12.

Toggle your views of previous layers on and off when
necessary. When you are finished, you should have a file that
contains several layers, as shown in Figure 28.12.

7. Save your file.

8. Choose Window⇒Timeline to open the Timeline panel.
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9. Click the Convert to frame animation icon at the
bottom-left corner of the Timeline panel.

This converts it to the frame animation version of the
Timeline panel.

Figure 28.12

To animate adding flowers, you need to create several layers,
each with more flowers than the last.

10. From the frame animation panel menu, choose Make
Frames from Layers.

Each layer of your project becomes a separate frame inside
the animation. Remove the flower cutout layers to get the
result shown in Figure 28.13.

Figure 28.13

Before and after making frames from layers
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11. For each frame in the animation, adjust the visibility
of the layers in the Layers panel so that the correct frames
are visible, as shown in Figure 28.14.

Figure 28.14

Enabling visibility of layers in the appropriate frames

12. With the first frame selected, choose Match Layer
Across Frames from the Timeline panel menu.

13. From the Timeline panel menu, choose Select All
Frames.

14. Click the arrow in the bottom-right corner of the first
frame, and change the frame delay time to 1 frame per
second.
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Now your animation is ready to preview, as shown in Figure
28.15.

Figure 28.15

With the frame delay set, you now have your animation.

Creating an animated GIF with this method has several
advantages. Although the Layers panel can eventually
become unwieldy, it really is a neater alternative to trying to
work with frames and layers at the same time, as you do in
building an animation in the animation version of the
Timeline panel. The disadvantage to this method is that any
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frame that includes changes in position, opacity, or effects
must be re-created in a new layer.

Building an animation in the animation version of the
Timeline panel

When building an image from scratch, you use the frame
animation version of the Timeline panel to create new frames
as you create new layers, or vice versa. Each new frame
contains a change from the last frame, and over several
frames, they turn into an animation.

You can build an animation by creating a new frame each
time you make a change to your image.

On the Web

You can find the final version of this animation saved as
Figure 28.17 on the book's website.

1. Open a new document in Photoshop.

2. Open the Animation panel by choosing
Window⇒Animation.

3. Click the Convert to frame animation icon at the base
of the video Timeline panel to convert it to the frame
animation version of the Timeline panel.

4. In the panel menu, select Create New Layer for Each
New Frame.
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5. In the panel menu, deselect New Layers Visible in All
Frames.

6. Create a background for your animation on the existing
frame, or leave it blank and create a new frame on which
to create a background.

Tip

To change the background layer into a regular layer that you
can paint on, right-click it in the Layers panel and choose
Layer From Background.

Note

As you create new frames, leave the visibility of the
background on. This saves the extra step of matching the
layer across frames.

7. Click the Duplicate selected frames icon at the base of
the frame animation version of the Timeline panel.

A new frame is created, as well as a new layer in the Layers
panel. This frame initially has the same properties as your
preceding frame.

Note
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Because you are working in a new layer, you can change
anything you want about your image and the changes are not
reflected in any other frames. If you do want your changes
to be consistent across frames, select New Layers Visible in
All Frames from the frame animation panel menu.

8. Use the Photoshop tools to create the next frame for
your animation.

9. Repeat Steps 7 and 8 until you have completed your
animation, as shown in Figure 28.16.

10. Discard any background frames apart from the
animation.

Figure 28.16

Build an animation by drawing on one frame at a time.

When you build an animation using frames and layers, you
can animate position, opacity, and effects instead of creating a
new layer. For example, in the animation of our crayon
family, each member of the family only had three poses: two
walking poses and a face front pose. In frame 2, we showed
Dad entering the picture; in frame 3, he walked farther into it
with a different stride; in frame 4, we discarded the new layer
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and turned on the visibility of frame 2, moving Dad forward
again. Figure 28.17 shows frames 2, 3, and 4 of our
animation. We did the same with each figure in our
animation.

Figure 28.17

As you build frames, you can reuse layers to animate position.

Looking at the Layers panel in Figure 28.18, you see that the
frames are not in order. That's because the last few frames of
our animation show a dog running in and joining the family.
We wanted the dog to run behind the family, so after creating
the layers that animated the dog, we dragged them under the
layers that contained the family.

Figure 28.18

Your frames don't have to be in order on your Layers panel.
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We also created a Hue/Saturation adjustment layer and
changed the hue of the entire image every other frame by
simply clicking the visibility of this layer on and off. You
may be able to see the difference in Figure 28.17. We added
this element so the whole picture would seem to change
slightly between frames, not unlike storyboard animations
that can be seen in commercials or children's television. You
can add any filters or adjustment layers as you change each of
your frames. Unlike the tweening process, you can animate
anything as long as you are creating new layers.

Rendering Video

Once you are finished editing an animation or video project,
you can render the project to a video file. Rendering a video
is the process of combining all of the audio and video tracks
into a single video file that contains all elements in final form.
The video file can then be played on the computer, or
distributed to others via the web, DVD, or other medium. To
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render the animation or video to a video file, choose
File⇒Export⇒Render Video from the main menu bar to
launch the dialog box shown in Figure 28.19.

Figure 28.19

The Render Video dialog box allows you to define the options
used when rendering video and animation projects to video
files.

In the Render Video dialog box, set the following options and
click the Render button to create the rendered video file:

1755



Chapter 30 discusses outputting animations to
web file formats that can be incorporated into web pages.

• Name. This option specifies the name of the video file that
will be rendered.

• Select Folder. This option allows you to specify the
location to store the rendered video file.

• Create New Subfolder. This option creates a new subfolder
in the location specified by the Select Folder option.

• Media Encoder. This option allows you to select which
media encoder to utilize to render the animation or video as a
video file.

• Adobe Media Encoder. This option allows you to specify
the file format to use when rendering the video file. The file
options are DPX (Digital Picture Exchange) and H.264. The
second drop-down menu allows you to adjust the audio and
video settings used to render the final video file.

• Photoshop Image Sequence. This option renders the
animation or video as a sequence of images of the type
specified by the drop-down menu. Clicking the Settings
button allows you to adjust the settings, such as compression,
used to generate the image files.

• Size. This option specifies the document size used to
generate the image files. You can select a standard format,
such as NTSC, PAL, HDTV, and so on, from the drop-down
menu.
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• Frame Rate. This option specifies the number of frames per
second that will be rendered in the video.

• Field Order. This option sets the field order mode for the
rendered video and can be set to Progressive, Upper First, or
Lower First.

• Aspect. This option allows you to set the aspect ratio of the
output video.

• Color Manage. This option allows you to enable or disable
the Adobe Color Manager, which is used when rendering the
output video.

• Range. This option allows you to specify whether to use all
frames or only the currently selected frames when rendering
the video.

• Alpha Channel. This option allows you to specify how to
matte alpha channels into the video. Matting makes the partial
transparency in the alpha channel blend better. The options
are

• None. This option does not apply alpha channels to the
rendered video.

• Straight Unmatted. This option does not matte the alpha
channel when rendering.

• Premultiplied with Black. This option uses a black
background matte to render the semi-transparency in the
alpha channel. This option is often the best for video that will
be displayed on TVs.
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• Premultiplied with White. This option uses a white
background matte to render the semi-transparency in the
alpha channel.

• Premultiplied with Color. This option allows you to
specify a custom color to use for the background matte to
render the semi-transparency in the alpha channel. You select
the color by clicking the color box to the right.

• 3D Quality. This option allows you to set the quality level
at which 3-D objects will be rendered: Interactive, Ray
Traced Draft, or Ray Traced Final. Ray Traced Final is the
highest quality, but is the slowest rendering option.

Summary

In this chapter, we showed you everything you need to know
about the animation version of the Timeline panel and how to
use it, by covering these topics:

• Working in the frame animation version of the Timeline
panel

• Using tweening in frame animation

• Using the animation version of the Timeline panel to create
a frame-by-frame animation
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Part IX: Using Advanced Output Techniques
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Automating and Scripting Workflow in Photoshop

1759



Chapter 29: Printing and Color Management

In This Chapter

Understanding color management

Calibrating color profiles for devices

Configuring color management in Photoshop

Using color management to print accurate colors

Color is one of the most important aspects of digital images.
In fact, the look of most images completely depends upon
their color composition. Unfortunately, color is not consistent
as you move from device to device, so it is difficult to
guarantee that the color corrections you make on one
computer will match what you see on another or when you
print the image.

Color management solves these problems by assigning color
profiles that describe the colors in a device, and then using
those profiles to convert the image data as you transfer it from
device to device. This chapter discusses color management
and how Photoshop uses it to ensure the colors in your images
are consistent as they are transferred to other devices and
printed.

Understanding the Importance of Color Accuracy and
Consistency

Few things are more frustrating than spending hours editing
an image only to find that the finished product looks terrible

1760



when you print it. Differences in monitor quality, type, age,
and even viewing angle can result in severe variations in the
color of an image. Additionally, differences in printers, ink,
and paper also result in a high variance of color output. A
good color management workflow helps you overcome these
problems and gives you the best chance of matching the
edited color with the final results when you output the image.

The following list describes a good color management
workflow that helps you ensure accuracy when editing,
distributing, and outputting images:

1. Calibrate your monitor using either a software
application or a hardware calibration device.

Because the pixels in your monitor fade with age, you may
need to calibrate your monitor monthly or at least at the start
of any big projects.

2. Add color profiles that describe how color will appear
on the output devices you are using.

Output devices can be specific monitors, portable devices, or
printers.

3. Set up color management in the Adobe software.

Photoshop provides proofing options to preview the way that
images will appear when you output them.

4. Save the color management data with the edited
document.
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This ensures that the edited document will contain the
information you expect to use to output the image.

Understanding ICC color profiles

Color profiles mathematically define the way that a device
interprets the level values that determine color in an image.
International Color Consortium (ICC) color profiles define
the gamut (range) of colors that a device is capable of
reproducing, because not all devices can produce the same
color ranges.

Color Management Modules (CMMs), also called Color
Matching Modules, such as Apple ColorSync and the
Microsoft Windows Color System (WCS), use the ICC color
profiles to match or convert the color levels between input
sources and output devices. CMMs work by using the source
ICC color profile provided, along with the original file and
the destination ICC color profile for the output device to
convert the colors in the original file to the appropriate values
that will give the most consistent color result in the output.

Manufacturers of monitors, printers, and other devices
typically provide ICC profiles. Although these profiles are
usually good enough for most needs, you may also want to
develop your own profiles that take into account factors such
as ambient lighting in your workspace, age of the monitor,
and other variable conditions. Many high-end printing
facilities provide profiles that enable you to accurately
preview the final output from Photoshop before delivering the
finished documents.

Embedding color profiles in image files
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ICC profiles can be embedded into most of the popular image
file types, such as PSD, JPEG, EPS, TIFF, and PSB.
Embedding the color profiles inside the actual document
ensures that the images display correctly when you transfer
them among different devices.

To embed a color profile in an image, simply select the ICC
Profile option, shown in Figure 29.1, when you use the
File⇒Save As command from the main menu bar in
Photoshop. The ICC Profile option displays only if you have
added a color profile to the image and if the image file type
supports color profiles.

Figure 29.1

You can embed a color profile in an image by selecting the
ICC Profile option in the Save As dialog box.
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You can also embed a color profile in an image when you are
using the File⇒Save for Web command. When you select a
file type that supports color profiles in the Save for Web
dialog box, the option to embed a color profile becomes
available.

Note

Most images automatically use the sRGB color profile
because the web is the most common destination of images,
and sRGB is the profile used for web production.
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Using device-independent color profiles

A problem can occur with CMMs using the ICC color
profiles: the RGB and CMYK colors can vary between
different devices. This means that you can get inaccurate
translation between the two color modes.

To solve this problem, the Commission Internationale de
l'Éclairage (CIE) developed a set of device-independent color
models; the CIE XYZ and CIE LAB color spaces are two
examples. These color spaces are used as interim spaces when
converting between the different color models.

Calibrating Color for Monitors and Printers

The most important step in color management is to calibrate
the monitor on the computer where you are editing images. If
the monitor is not calibrated, you could spend hours getting
the perfect color tones in the image only to find that your
monitor was inaccurate and the colors don't really look that
good.

You can use two different methods for calibrating a monitor.
The simplest, but least accurate, is to use software to
manually adjust the gamma, brightness, contrast, and color
that the system uses for the display. On Windows 7 systems,
you can calibrate the monitor by selecting Start⇒Control
Panel⇒Hardware and Sound⇒Display⇒Calibrate Color to
bring up the calibration utility shown in Figure 29.2. On Mac
OS systems, you can calibrate the monitor by using the
Display Calibrator Assistant found in the Color panel of the
Displays pane in System Preferences.
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The most accurate method of calibrating a monitor is to attach
a device called a calorimeter flat to the display surface. The
calorimeter and display must be shielded from all ambient
light. Then calibration software that comes with the
calorimeter sends a series of color signals to the display and
compares the values detected by the calorimeter with known
expected values. This establishes the current offsets in the
color display, and the software uses this information to create
ICC profiles that will adjust the display's brightness, contrast,
and RGB settings.

Because ink and paper quality affect printer output so much,
you cannot adjust the settings on a printer to calibrate color
output. Instead, printers use ICC profiles that are created by
printing a test sample with known output gamma, brightness,
contrast, and color outputs. The sample test print is then
analyzed by a photometer (sometimes called a
spectrophotometer) to determine the actual output with
known CMYK colors. Software that comes with the
photometer then uses the difference between the two printouts
to create the ICC profile. Although the photometer and
software are expensive, you can typically find an ICC profile
for your printer/ink combination on the Internet for a
reasonable price (usually about 20 to 30 dollars).

Figure 29.2

Calibrating color on the display in Windows is a process that
involves adjusting the gamma, brightness, contrast, and
colors.
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Using Color Management in Photoshop

Photoshop provides several different tools that enable you to
define a specific set of colors that apply to an image, manage
the display, and print color of images, as well as apply other
color profiles to images. These tools help you to ensure that
the same colors you see in Photoshop are the colors that
others will see in the printed and distributed digital versions.
If you plan to send your images to a printer or output them for
others to view, you should become familiar with color
management in Photoshop. The following sections discuss
how to configure the color management settings in
Photoshop, assign color profiles to images, and proof images
using different color profiles.

Configuring color settings in Photoshop
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Configuring color settings in Photoshop enables you to make
sure that the same color ranges you are seeing on the screen
can be transferred to other output devices such as printers.
Photoshop provides a Color Settings utility, shown in Figure
29.3, to enable you to easily configure the color settings.

You launch the Color Settings dialog box by pressing
Ctrl+Shift+K/ +Shift+K on the keyboard or by choosing
Edit⇒Color Settings from the main menu bar. At first
appearance, the dialog box may seem unfamiliar and
daunting. The next few sections discuss each of the options
available in the Color Settings dialog box and will hopefully
dispel any apprehension you have about using them.

Figure 29.3

The Color Settings dialog box enables you to configure the
color workspaces and the color management policies.
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Tip

If you save your color settings as a preset file, you can use
that preset in the Adobe Bridge Suite Color Settings dialog
box (which you launch by pressing Ctrl+Shift+K/
+Shift+K in Bridge). The Suite Color Settings utility
enables you to synchronize the color management profiles
between Creative Suite applications.

Setting color options

The Settings menu option offers a list of preset color
configurations that set the color options for the workspace
and management policies for general purposes. If you really
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don't want to take the time to set up your own custom color
configuration, you can use one of these presets. The list
contains presets for North America, Europe, and Japan that
fall into the following categories:

• Monitor Color. Choose this setting if you plan to use the
images in a video or onscreen presentation. This setting uses
the Monitor RGB option, which uses the current monitor's
color space and in effect acts as if color management is turned
off in Photoshop.

• General Purpose. Choose this setting if you need to use the
image for both print and onscreen viewing. This setting uses
the sRGB color profile that best supports most monitors as
well as the U.S. Web Coated (SWOP) v2 color profile for
CMYK that works well for printing.

• Newspaper. Choose this setting for images that are intended
for output to newsprint. The CMYK workspace is set to U.S.
Newsprint, and the Gray and Spot colors are set to use a
25-percent dot gain that works well for printing to
newspaper-type material.

• Prepress. Choose this setting for images that are intended
for output to a printer. The RGB workspace is set to Adobe
RGB, which provides a good range of colors that map well to
the CMYK color model used for printing; the CMYK
workspace is set to U.S. Web Coated (SWOP) v2, which
generally works well for printing.

• Web/Internet. Choose this setting for images that you
intend to display on the web. This option sets the RGB
workspace to sRGB, which is the best one for supporting a
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variety of computer monitors; the Gray workspace is set to
Gray Gamma 2.2, which works best for displaying grayscale
images on a variety of monitors.

• Color For Newspaper. Choose this setting for newspaper
images that you intend to print in color. This option sets the
RGB workspace to Adobe RGB and specifies the correct dot
gain for the spot channels as well as the appropriate textual
Gamma setting.

• Magazine Advertisement Color. Choose this setting for
images that you intend to be printed in a full-color
glossy-magazine medium. This option sets the CMYK
workspace to Web Coated (Ad), allowing for a richer color
output.

You can also save any custom configuration that you define
using the Save button and then load it later, even on another
computer, by clicking the Load button.

Configuring color profiles

The Working Spaces settings enable you to configure the ICC
color profiles that the RGB, CMYK, Grayscale, and Spot
models use to display the images on your monitor while you
are editing them. Using the appropriate color model helps you
edit and adjust your images so they look their best when they
are viewed on the output medium.

The following list describes some of the profiles that are
available in each of the workspaces:
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• RGB. This color model is the most commonly used for
digital images. Although there are many RGB color profiles,
you will likely work with only two or three. The most
common ones are Adobe RGB and sRGB IEC61966-2.1
(sRGB). The difference between the two is that the sRGB
profile has reduced the gamut of colors it allows around the
outer edges. This reduces the number of colors that can exist
in the image so that the colors are supported on the widest
range of computer displays possible. That way, the image
looks exactly the same on all displays.

Another RGB color profile that you might use is Monitor
RGB. This profile sets the RGB working space to the current
monitor space, which causes Photoshop to behave as if color
management was turned off. This is handy if you are
outputting the images to a medium that doesn't support color
management, such as a video or a presentation application.

• CMYK. This color model is typically used for printed
images. Therefore, each of the available CMYK color profiles
actually corresponds to a specific ink-and-paper combination.
When you convert an image from RGB to CMYK using the
Image ? Mode⇒CMYK color option, the CMYK color
profile is used as a basis for the conversion between the two
color models.

The most common profile you will use is U.S. Web Coated
(SWOP) v2. Other color profiles may be provided by your
printing press or by a printer manufacturer.

• Gray. These color profiles define the dot gain used to
display images converted into grayscale when you choose the
Image⇒Mode⇒Grayscale command. There are two basic
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options: one is to set the percent of dot gain, and the other is
to select a gamma option that uses the gamma setting of your
monitor to define the brightness of the midtones in the
grayscale image. The most commonly used gamma option is
Gray Gamma 2.2 because it supports most of the current
monitors.

• Spot. This profile specifies the dot gain to use when
displaying spot color channels and duotones.

Controlling the color profile in open images

The Color Management Policies section of the Color Settings
dialog box provides control over how Photoshop manages the
RGB, CMYK, and grayscale images that you have open.
Many images already have ICC color profiles embedded in
them, and the settings in this panel enable you to define how
Photoshop applies color from those images in relation to the
color profiles defined in the Working Spaces section.

For each of the three color modes, you can set the following
options:

• Off. When you select Off, color management is disabled in
images that you open or create. If you open an image with an
embedded color profile, Photoshop ignores the color profile.
You should be careful if you use this option while copying
and pasting from one image to another, because although the
color data is preserved, the colors may look different.

• Preserve Embedded Profiles. When you select this option,
Photoshop maintains the embedded color profile information.
This is the default option and is the best one to ensure the

1773



most consistent colors between images that are edited on
different computers.

• Convert to Working Profile. When you select this option,
Photoshop uses the color profile in the image to convert the
data in the image to the working color profile. The working
color profile is then embedded in the image when you save it.

The Color Management Policies section also contains check
boxes that enable you to activate dialog boxes that pop up if
you open, or paste data into, an image that has an embedded
color profile that either doesn't match the working profile or is
missing. The dialog box warns you and enables you to
determine at that time how to handle color management for
that image, as shown in Figure 29.4.

Figure 29.4

Enabling the Ask When Opening and Ask When Pasting
options in the Color Settings dialog box presents notifications
that enable you to handle images that either do not have an
embedded color profile or have a color profile that does not
match the current working color space.
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Note

Photoshop enables you to open multiple images that use
different color profiles. This can be useful if you are
working on projects with images that are destined for
different types of output. However, you should be careful if
you need to share pixels between images — for example,
cutting and pasting or selecting colors from one image that
you want to be used in another image, or sharing channels.

Controlling conversion between color profiles

When you click the More Options button in the Color Settings
dialog box, the dialog box expands and displays a section that
provides control over conversion between color profiles.
Figure 29.5 shows the Conversion Options and the Advanced
Controls settings.

In the Conversion Options section, you can configure the
following options:

• Engine. This option enables you to specify the CMM that
Photoshop will use to manage conversion between color
profiles. Typically, you have two options: Adobe ACE is
provided by Adobe and is available on both Windows and
Mac OS; the other option is the default CMM that is provided
with your operating system — for example, Microsoft ICM
on Windows or Apple CMM on Mac OS.
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• Intent. This option enables you to select one of the
following settings that determine how the CMM interprets
colors between color spaces:

• Perceptual. When you select this option, all colors in the
source color profile are compressed to fit in the destination
color profile's gamut. Neighboring pixels are taken into
consideration so the colors are adjusted proportionally. This
provides a better perceptual translation because the
relationship between the pixel and its neighbors is more
important than finding the closest matching color.

• Saturation. When you select this option, colors in the
source color profile that do not exist in the destination color
profile's gamut are changed to the closest color value in the
destination color profile without considering neighboring
pixel values. This can result in a color shift that increases
saturation in the image. Typically, this option is used only for
images with many solid colors, and not for photographs.

• Relative Colorimetric. When you select this option,
Photoshop translates colors between profiles by mapping
white in the source color profile with white in the destination
color profile and then using that mapping to adjust the rest of
the colors. This option usually works very well; however, if
you are converting a smaller color space to a larger color
space (CMYK to RGB, for example), a banding and dithering
effect can result in the darker areas of the image.

• Absolute Colorimetric. When you select this option,
Photoshop maps the colors between the two spaces by
mapping between the absolute lab coordinates in each color
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profile. This option is used for hard proofing and simulating
output on a specific printer.

• Use Black Point Compensation. This option simulates the
entire dynamic range of the printer to ensure that the shadow
details in the image are preserved. You should select it if you
plan to use black point compensation when printing the
image.

• Use Dither. This option mixes colors in the destination
color profile to simulate colors in the source color profile.
This helps reduce blocky and banding artifacts that can
otherwise occur.

• Compensate for Scene-referred Profiles. This option
compares the video contrast when converting from scene to
output color profiles, similar to color management in After
Effects. This option is specific to working with video files in
Photoshop.

Figure 29.5

The More Options button extends the Color Settings dialog
box and enables you to configure conversion and advanced
controls for color management.

1777



Configuring the Advanced Controls options

In addition to the Conversion Options described in the
previous section, Photoshop provides more Advanced
Controls options when you click the More Options button. In
the Advanced Controls section, you can configure the
following options:
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• Desaturate Monitor Colors By. This option specifies a
percentage to desaturate colors when they appear on the
monitor. Selecting this option helps you visualize the full
range of color spaces with a similar gamut to the monitor.
However, this can result in color mismatches between
monitor display and output. Deselecting this option can result
in two distinct colors appearing as the same color on the
monitor.

• Blend RGB Colors Using Gamma. This option controls
how RGB colors in the image blend together to produce
composite data, such as blending layers or painting. Selecting
this option blends the RGB colors in the color space based on
the specified gamma setting. A gamma of 1.00 is considered
“colorimetrically correct” and generally produces the fewest
edge artifacts.

• Blend Text Colors Using Gamma. This option controls
how text colors in the image blend together to produce
composite data, such as blending layers or painting. Selecting
this option blends the text colors in the color space based on
the specified gamma setting. A gamma of 1.00 is considered
“colorimetrically correct” and generally produces the fewest
edge artifacts.

Note

When you select the Blend RGB Colors Using Gamma
option, layered documents look different when viewed in
other applications than they appear in Photoshop.
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Assigning color profiles to images

Photoshop enables you to assign color profiles to images. If
the image already contains an embedded color profile,
Photoshop replaces that color profile with the newly assigned
color profile, but the level values in the image do not change.

To assign a color profile to an image, open the image in
Photoshop and choose Edit ? Assign Profile from the main
menu bar. A dialog box similar to the one shown in Figure
29.6 appears, enabling you to set the following options:

Caution

Because layer adjustments, filters, and Blending modes are
based on the original colors, assigning a color profile to the
image may alter the appearance of the layers. You should
always assign a color profile to the image before you begin
editing it, if possible.

• Don't Color Manage This Document. This option removes
any existing color profiles from the document, and Photoshop
displays the image according to the current working color
space.

• Working [Color Model]: [Color Profile]. This option adds
the current working color profile to the image and uses that
profile to display it while editing.

• Profile. This option enables you to use a drop-down menu
to select a color profile that is embedded in the image. Which
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color profile Photoshop uses to display the image depends on
the color management settings described earlier.

Converting images to other color profiles

Photoshop enables you to convert images from one color
profile to another. If the image already contains an embedded
color profile, you likely want to keep the colors intact when
moving from one profile to the next. Converting color profiles
uses the color profile in the image to convert the color levels
to match a new color profile and then embeds the new color
profile in the image.

Figure 29.6

Using the Edit⇒Assign Profile option, you can add a color
profile to an image or replace the currently embedded color
profile.
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To convert an image from one color profile to another, open
the image in Photoshop and choose Edit⇒Convert to Profile
from the main menu bar. A dialog box similar to the one
shown in Figure 29.7 appears. Clicking the Advanced option
button expands the dialog box, and you can set the following
options:

• Source Space. This option displays the source color space
that was already embedded in the image.

• Destination Space. In the Basic dialog box, this option
enables you to select the ICC profile to convert the image. In
the Advanced dialog box, this option enables you to select the
color mode and color profile to use when converting the
image. This option is often a better method to change the
color mode because it gives you direct control over both the
color mode and color profile.
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• Conversion Options. These options — Engine, Intent, Use
Black Point Compensation, and Use Dither — were discussed
earlier in this chapter. The Flatten Image to Preserve
Appearance option is provided to overcome the problem of
blending layers. The problem with blending layers is that
converting the layers individually and then flattening them
results in a different pixel color than flattening first and then
converting. This can be a tough choice if you need to use the
layers later.

Figure 29.7

Using the Edit⇒Convert to Profile option, you can use the
currently embedded color profile in an image to convert the
image to another color profile and embed that color profile.
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Proofing images using color management

In addition to embedding color profiles in images and
controlling the working color management settings,
Photoshop provides quick proofing of images to see how they
will appear in some of the common color profiles. This
process is known as soft proofing.

To set up the proofing color space, choose View⇒Proof
Setup and then select the color space. Photoshop uses the
color space you selected when proofing. Choosing
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View⇒Proof Setup⇒Custom displays the Customize Proof
Condition dialog box, shown in Figure 29.8.

Figure 29.8

Configuring the options in the Customize Proof Condition
dialog box enables you to proof images in some of the
common color profiles.

In the Customize Proof Condition dialog box, you can set the
following customized color proofing options:

• Device to Simulate. This option enables you to select the
color or device profile to use when proofing the colors in the
image.

• Preserve Numbers. This option causes the colors to appear
without being converted to the color space of the specified
output device.

• Rendering Intent. This option specifies how Photoshop
converts colors from the document's gamut to the proofing
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gamut. When proofing photos, you likely want to use
Perceptual or Relative Colorimetric.

• Black Point Compensation. This option simulates the
entire dynamic range of the printer to ensure that the shadow
details in the image are preserved when proofing. You should
select it when proofing if you plan to use black point
compensation when printing the image.

• Simulate Paper Color. This option is useful if you select a
CMYK-based device profile. When you choose Simulate
Paper Color, Photoshop simulates the slightly off-white
property of actual paper according to the settings in the color
profile.

• Simulate Black Ink. This option is useful if you select a
CMYK-based device profile. When you choose Simulate
Black Ink, Photoshop simulates the dark gray that the color
profile specifies represents solid black.

• Load/Save. These buttons enable you to load and save the
custom proof settings.

After you have set up the proofing profile, you can proof the
current image by choosing View⇒Proof Colors from the
main menu bar. The setting that you specified in the Proof
Setup menu is used to display the image in the colors that
match the output device. This is a great way to work in one
color space but still see the results in another.

A useful aspect of the Photoshop proofing option is the ability
to preview items using the Color Blindness options from the
View⇒Proof Setup menu. Many governments and other
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institutions now require commonly used public websites to
use these profiles when displaying images. Even if you are
not embedding one of these profiles in the image, you can use
the proofing option to view what the image will look like if
these profiles are used.

Printing Images from Photoshop

Printing your adjusted images from Photoshop enables you to
distribute your creative work to others. This can be as simple
as pressing Ctrl+Alt+Shift+P/ +Option+Shift+P to print a
single copy using the configured print settings. Photoshop
also provides much more control over printing of images
when you press Ctrl+P/ +P to display the Photoshop Print
Settings dialog box. Shown in Figure 29.9, the Photoshop
Print Settings dialog box enables you to set up printing
options, implement color management, access the printer
settings, and add additional output to the printed image. Each
of these settings allows for additional flexibility and enhanced
quality in the printed version of the image.

Figure 29.9

When printing in Photoshop using the Photoshop Print
Settings dialog box, you can set print size and orientation and
use color management to ensure that the printed colors match
those you saw when editing the image.
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Configuring general printing options

The Print dialog box, displayed when you select File⇒Print
from the main menu, offers the following general printing
options that enable you to control the orientation, size, and
location of the printed image, as well as the printer settings:

• Preview. This window displays the image and its general
location on the printed sheet of paper. The size of the paper
also appears above the preview. The size of the paper is
controlled by the Photoshop Print Settings dialog box.

• Printer. This menu enables you to select the printer from
the list of installed system printers. This option also displays a
notification that the printer needs calibration if it has not
already been calibrated. You should calibrate the printer
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before printing from Photoshop so the output provides the
best results.

• Copies. This field sets the number of copies to print.

• Print Settings. This button launches the settings dialog box
for the print driver. The settings dialog box for the printer
generally gives you even more control over options such as
paper size, paper type, print quality, and so on.

• Layout. These buttons enable you to switch between
landscape and portrait layout when printing the image.

• Position. These options enable you to set the position that
the printed image will be placed on the printed page page.
Using the Center option centers the image in the printable
area on the printer. If the Center option is not selected, the
Top and Left fields specify the relative position of the top-left
corner of the image to the top-left corner of the printable area
of the paper.

• Scaled Print Size. This option enables you to scale the size
of the image so that it fits on the printed area perfectly. The
Scale field specifies the size percentage, where 100 percent is
the original size. The Height and Width fields specify the
height and width of the printed image. Selecting the Scale to
Fit Media option disables the Scale, Height, and Width
options, and Photoshop sizes the image automatically to the
same size as the printable area.

• Print Selected Area. This option allows you to select a
specific area of the image to be printed. Only the selected area
of the image will be printed.
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• Units. This setting determines the units used for the Position
and Scaled Print Size options.

Using color management to print accurate colors

The most important aspect of color management is the ability
to keep the output colors consistent with the colors that you
see when editing the image. Therefore, printing with color
management is an extremely important part of Photoshop.
Two options are available to use color management when
printing from Photoshop: you can either let Photoshop
manage the colors or let the printer manage the colors.

Caution

When you use Photoshop for color management, you need
to disable color management in the printer driver. This
varies from driver to driver, so you need to check the printer
manual to find out how to do this. Conversely, if you are
using the printer to manage color profiles, you must enable
color management in the printer driver. If you ignore either
of these steps, the printer will print the wrong set of colors.

Using Photoshop to manage the colors means that Photoshop
sends the color data to the printer already converted to the
appropriate color profile gamut for that device. For accurate
results, this requires the appropriate ICC profile that defines
the color space for the printer.

Using the printer to manage colors means that Photoshop
sends the printer the necessary color profile information for

1790



the current values in the image, and the printer converts the
image data to the appropriate gamut.

To print an image using color management, make sure the
color management settings have been configured properly and
press Ctrl+P/ +P to open the Photoshop Print Settings dialog
box. Expand the Color Management heading, and configure
the following settings:

• Color Handling. This menu enables you to select the
Printer Manages Colors option to use the printer for color
management; the Photoshop Manages Colors option to use
Photoshop for color management; or the Color Separations
option (if the color model of the image is CMYK) to print a
set of color separations or spot plates using the actual color
values.

• Printer Profile. This option specifies the ICC color profile
to use for the destination device. When you select the
Photoshop Manages Colors option, this setting defines the
color profile that Photoshop uses as the destination color
profile when preparing the image to print.

• Normal Printing. This option uses the embedded color
profile in the document or the working color profile
configured in the Color Settings dialog box if a profile is not
present.

• Hard Proofing. This option simulates a printer's output. If
you select this option instead of the Document option,
Photoshop emulates output from a different device than the
current printer. This is known as a hard proof. Hard proofs
are useful to test the output on less-expensive devices before
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sending the output to a high-quality printer. You need to set
up proofing by choosing View⇒Proof Setup ? Custom to
configure the device you want to emulate.

• Rendering Intent. This option, available when Normal
Printing is selected, enables you to specify how Photoshop
converts colors from the document's gamut to the printer's
gamut. When printing photos, you likely want to use
Perceptual or Relative Colorimetric. See the conversion
options section earlier in this chapter for more details on the
available options.

• Black Point Compensation. This option, available when
Normal Printing is selected, enables you to activate black
point compensation that will adjust for the differences
between what the image and the output device consider to be
black. This option is most useful if the gamut of the image
and the gamut of the output device are similar but one is
darker than the other.

• Proof Setup. This option, available when Hard Proofing is
selected, enables you to select either the current working
color profile or the custom profile that you defined by
choosing View⇒Proof Setup⇒Custom.

• Simulate Paper Color. This option, available when Hard
Proofing is selected, enables you to select a CMYK-based
device profile, and simulates the slightly off-white property of
actual paper according to the settings in the color profile.

• Simulate Black Ink. This option, available when Hard
Proofing is selected, enables you to select a CMYK-based
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device profile, and simulates the dark gray that the color
profile specifies represents solid black.

• Match Print Colors. This option causes the print preview
to show the colors as they will actually print. This is available
only if Photoshop is used for color management.

• Gamut Warning. This option causes colors that are out of
gamut in the image to be highlighted in the preview window.
This is extremely useful for determining the amount of color
translation that must take place to print the image using the
printer color profile. This is available only if Photoshop is
used for color management and you have selected the Match
Print Colors option.

• Show Paper White. This option matches the paper portion
of the print preview to the color of white specified by the
printer color profile. This gives you the most realistic preview
of the printed area because paper is really off-white and can
change the colorcast of the image. This option is available
only if Photoshop is used for color management.

Adding crop marks and additional output to printed images

When outputting an image, an important part of the printing
workflow is adding additional information to be used when
processing. Photoshop enables you to quickly add and print
additional information with your images, such as calibration
bars, crop marks, and registration marks.

To control the additional output options when printing the
image, expand the Printing Marks and Function headings,
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shown in Figure 29.10, and then configure the following
settings:

• Corner Crop Marks. This option adds corner crop marks
to the printed image so you can easily trim the printed
document.

• Center Crop Marks. This option adds center crop marks to
the printed image to aid in trimming the edges from the paper.

• Registration Marks. This option adds registration marks on
the corners of the image. Registration marks are used to align
color separations.

• Description. This option prints the description contained in
the file. You can add a description by choosing File⇒File
Info from the main menu bar.

• Labels. This option prints the filename above the image.
When printing color separations, the separation name is
printed as part of the label.

• Emulsion Down. This option prints the image backward so
text is readable when the emulsion is down — in other words,
when the printed side of the paper is facing away from you.
Typically, this is used for printing images on film.

• Negative. This option prints a color negative of the image,
including all masks and background colors. This is a bit
different from using Image⇒Adjustments⇒Invert to create a
negative because it converts the output and not the onscreen
image.

1794



• Background. This option launches a dialog box that enables
you to specify the background color to be printed in the
printable area outside of the image. For most images, the
background color should be white or possibly black.

• Border. This option launches a dialog box that enables you
to set the size of a black border that is printed around the
image. The default size is 0, which means no border.

• Bleed. This option launches a dialog box that enables you to
set the position of the crop marks in relation to the actual edge
of the printed image. This allows space for ink to bleed into
the paper without losing full quality around the edges.

Figure 29.10

When printing in Photoshop, you can use the Photoshop Print
Settings dialog box to add crop marks, registration marks,
calibration bars, and additional output to the printed image.
You can also control the output form of the image by printing
negative, emulsion down.
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Summary

This chapter discussed using color management to keep
colors consistent in your images from device to device. Color
is one of the most important aspects of digital images and one
of the most difficult things to get right when printing images
or transferring them between systems.

Color management provides a means to keep colors consistent
between devices by using profiles that define the color gamut
in each device. These color profiles are then used to convert
the color values in an image as it is transferred from device to
device.

In this chapter, you learned the following:

• How ICC color profiles define the color gamut of a device,
to accurately convert color data in images between devices
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• How color profiles are embedded in images when you save
them in Photoshop

• How to calibrate your monitor to ensure that the colors you
see in Photoshop are consistent

• How to configure color management in Photoshop

• How to convert an image from one color profile to another
without losing color consistency

• How to proof images for different devices in Photoshop

• How to easily include output options such as crop marks and
calibration bars in your images

• How to use color management when printing images from
Photoshop to ensure consistency of color in the printed image
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Chapter 30: Creating Images for the Web

In This Chapter

Getting images ready for the web

Converting images to web formats

Enabling zooming and panning in web images

Although Photoshop is not typically thought of as a tool used
for creating web pages, it does have some powerful features
that can aid graphic designers in preparing images for web
applications. One of the biggest obstacles to overcome when
preparing images for the web is adjusting the size and file
format to support the limited capabilities of browsers when
viewing images on the web. That's where Photoshop comes
in.

This chapter discusses how and why images are prepared for
viewing on the web. For example, we look at color settings,
slicing images, and adding transparency and animation. We
also discuss the Save for Web utility that you use to prepare
and output images in formats that are supported on the web
with the necessary HTML data.

Preparing Images for the Web

You can prepare images for use on the web in many ways.
Only a limited number of file formats are supported when
viewing images on the web, so you must convert images to
one of these formats. You may also need to reduce images to
reasonable sizes that can be supported by limited network
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bandwidth. The following sections cover the basic web
formats, using color management to ensure consistency
between browsers, adding animation to images, and adding
transparency to make images look better against web page
backgrounds.

Understanding web image formats

One of the most basic decisions that you face when preparing
an image for the web is the file format of the image. You
should decide on the file format before you make too many
changes to the image, because formats vary in color and
transparency support. The following list describes the most
common file formats used for the web:

For more information about different file types,
see Chapter 3.

• GIF. Graphic Interchange Format (GIF) was the standard
format for web images for a long time because the file size is
very small relative to the image size. GIFs support only 256
colors, which is good for web icons, logos, and text but not so
good for photographs. GIF images also support embedded
animation that is triggered when the file is loaded. Another
advantage of GIF files is that they support transparency,
which enables the background color and patterns on the web
page to show through parts of the image.

Tip
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If you plan to create GIF or PNG-8 images, you should
change the color mode to Indexed color, because that's the
basic format of these file types. This keeps the colors in the
image limited to the 256 colors of the indexed color table
that are supported when you save the file, so you aren't
editing colors that won't exist in the final image.

• JPEG. Joint Photographic Experts Group (JPEG) images
support 16.7 million colors, so they are much better for
displaying photographs or colorful images. They are
supported by most web browsers, so they can easily be
embedded in web pages or viewed as standalone files.

JPEG images do not support animation or transparency, so
they aren't commonly used for buttons, logos, and icons.
Another downside to using the JPEG format is that unless you
specify a lossless JPEG compression algorithm, JPEG
compression can result in artifacts in the images.

• PNG-8 and PNG-24. Portable Network Graphic (PNG)
images were created to replace GIF and, to an extent, JPEG
images. PNG-8 images are similar to GIFs in that they use an
8-bit format and so support only 256 colors. PNG-8 files also
support transparency and animation just like GIFs.

PNG-24 is similar to JPEG in that it supports the same
number of colors. However, because PNG-24 files use a
lossless compression, file sizes are usually larger than JPEGs,
although they do not exhibit the same types of artifacts. A big
advantage of PNG-24 is that they support transparency in the
image using an alpha channel.
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• WBMP. Wireless Bitmap (WBMP) files use a 1-bit format
that is widely supported by mobile devices that can display
only black and white pixels. Most current devices support
color images, such as JPEG and PNG, but if you are creating
an image that needs to be displayed on all devices, you may
want to create a WBMP copy along with the color copy.

Selecting the right color profile

When working with images that are intended for the web, you
want to use the RGB color mode by choosing
Image⇒Mode⇒RGB Color from the main menu bar. This is
because RGB is the color mode that computer screens use to
display images in web browsers.

You should use the sRGB color profile when editing images
for the web. The colors in the sRGB profile are supported on
most displays, so your images will look the same no matter
what computer is accessing them.

Tip

You can proof the way that images will look on the web by
choosing View⇒Proof Setup⇒Internet Standard RGB and
then using the View⇒Proof Colors menu option to toggle
proofing on and off. For more information about proofing
and color profiles, see Chapter 29.

Slicing images for web use

1801



Another task you may need to perform when preparing
images for the web is to slice them up. Slicing an image
involves dividing the image into a series of smaller images or
slices. Photoshop generates the necessary HTML code to
combine the individual slices as an HTML table, a series of
DIVs or CSS layers.

This enables you to assign different areas of the full image as
hot points that have meaning in the web page. These hot
points can be assigned descriptions that pop up when the
mouse hovers over that area of the image, and even links that
enable users to navigate to different web pages or locations on
the same web page by clicking different areas in the image.
The following sections discuss the different types of slices
that you can create and the tools that you can use to create
and define the slices in the image.

Understanding slices

Photoshop provides four types of slices that vary in their
behavior and how you create them. Slices are designated by a
bounding box with an icon in the upper-left corner. The icon
and color of the bounding box designate the type of slice.
Figure 30.1 shows the icons used for each type:

Figure 30.1

The user, layer-based, and no image slices are designated by
different icons in the upper-left corner. The auto slices are
designated by a gray bounding box and icon.
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The following list describes the types of slices.

• User slice. User slices are the basic slices that you draw
yourself. They are designated by a blue bounding box and the
icon shown in Figure 30.1.

• Layer-based slice. Layer-based slices are created by
selecting a layer in the Layers panel and then choosing
Layer⇒New Layer Based Slice from the main menu bar. This
creates a rectangular slice the size of the content of the layer.
A great feature of layer-based slices is that Photoshop
automatically adjusts the slice boundary if you change the
size of the content in the layer or add a drop shadow.

• No image slice. A no image slice instructs Photoshop to
treat that region in the image as HTML-encoded text. You
can configure the text that displays in the web page using the
Slice Options dialog box, which we discuss later in this
chapter.

Using HTML-encoded text areas in the image keeps the text
crisp even if a user changes the display size in the browser.
Another important benefit is that the encoded text is readable
by search engines, making the content available for web
searches.
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• Auto slice. Auto slices are slices that Photoshop
automatically generates and assigns to the areas of the image
that are not defined as user, layer-based, or no image slices.
Auto slices are designated by the same icon as user slices but
have a gray bounding box instead of blue.

Creating slices

The Slice tool, shown in Figure 30.2, is used to quickly carve
up an image into slices. Using the Slice tool, you can create
slices in one of three ways:

• Manually. You can create slices manually by dragging the
Slice tool across an image to create a bounding box. The Style
setting in the Slice tool options menu enables you to control
how slices are created. The Normal style enables you to create
a simple rectangle by dragging the cursor. Holding down the
Shift key while dragging creates a square box. The Fixed
Aspect Ratio style forces the rectangle to match the ratio
specified by the Width and Height settings. The Fixed Size
style creates a bounding box that is the exact size specified by
the Width and Height settings.

Figure 30.2

The Slice tool enables you to quickly carve up an image into
slices either manually or by using guidelines.
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Figure 30.3 shows how you create the slices by dragging the
Slice tool. Notice that the area selected is defined as a user
slice and the rest of the area is automatically sliced up into
auto slices.

• Using guidelines. A great way to create slices is to define
guidelines in the document by choosing View⇒New Guide
from the main menu bar. After all guidelines are created, you
can click Slices From Guides to create a set of slices based on
the guidelines. Figure 30.3 shows how the slices are created
from guidelines. Notice that all the slices created are user
slices.

• From layers. You can create a slice by selecting a layer
from the Layers panel and then choosing Layer⇒New Layer
Based Slice. Figure 30.3 shows how a layer-based slice is
created from a layer that contains an image. Notice that a
layer-based slice is created around the image, and the rest of
the document is carved up into auto slices.

Figure 30.3
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You can create slices manually by dragging the Slice tool,
automatically based on guidelines, or from a layer.
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Tip

You should use the fewest slices you can to keep the HTML
code as simple as possible. Avoid having slices overlap each
other, and try not to leave gaps between the slices because
this forces Photoshop to create auto slices to fill those areas.
It might help to choose View⇒Snap To⇒Slices to have the
slices snap to each other to avoid gaps as you draw them.

Configuring slices

The Slice Select tool, shown in Figure 30.4, enables you to
select, manipulate, and configure the slices after you have
created them. Using the Slice Select tool, you can change the
size of the slices by selecting them and dragging the control
handles on their bounding boxes.

Figure 30.4

The Slice Select tool enables you to quickly manipulate and
configure slices.
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Note

You can access most of the slice configuration options by
right-clicking the icon in the upper-left corner of the slice to
display the Slice popup menu. From this menu, you can
change the order of the slice as well as promote, delete, and
divide it.

You can select one or more slices and use the following
options in the Slice Select tool Options bar to organize and
configure the selected slices:

• Ordering. These options adjust the order of the selected
slices to the top, up one, down one, or to the bottom.

• Promote. This button promotes an auto or layer slice to a
user slice.

• Divide. This button launches the Divide Slice dialog box,
shown in Figure 30.5. From the Divide Slice dialog box, you
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can specify either evenly spaced or fixed slice divisions to be
added to the current slice. The result is that the current slice is
divided into the specified set of slices, as shown in Figure
30.5.

• Alignment. These options enable you to quickly align the
selected slices with each other. Only the selected slices are
affected.

• Hide Auto Slices. This button hides the auto slices from the
document display window. This enables you to more easily
see the interaction with the other slices.

• Slice Options. This button launches the Slice Options dialog
box shown in Figure 30.6. From the Slice Options dialog box,
you can set the type of the slice to Image, No Image, and
Table. When you set the slice to Image, you can configure the
HTML tag information for the image slice, as shown in
Figure 30.6. When you select No Image, you can set the text
that is converted to HTML-encoded text.

You can set the dimensions of the slice in the Dimensions
settings. The X and Y fields specify the coordinates of the
top-left corner of the slice box. The W and H fields set the
width and height in pixels.

Figure 30.5

Using the Divide Slice dialog box, you can divide a slice
horizontally and/or vertically into a set of equally spaced
slices.
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The Slice Background Type option enables you to set the
background type to black, white, or a custom color. You can
also set the background to matte. The Matte setting is used for
the partially transparent areas in images. PNG and GIF files
support only fully opaque or fully transparent pixels, so the
matte color is used to blend in the partially transparent pixels
to fully opaque pixels. Typically, you would set the matte
color to the same color as the background of the web page.

Figure 30.6

The Slice Options dialog box enables you to configure the
HTML settings, dimensions, and background options for the
slice.

Adding transparency to images

An important aspect of some web images is the ability to use
transparency to help an image blend better into a web page.
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Image files are always rectangular with a height and width
dimension. When you place a rectangular image in a web
page, it stands out from the background.

The way to solve that problem is to add transparency to the
image and save it as a GIF or PNG file. The transparent areas
of the image enable the background of the web page to show
through it, making the image blend with the background.

Tip

When adding transparency to images that are intended for
the web, keep in mind that PNG and GIF files support only
fully opaque or fully transparent pixels. So you want to use
either only fully transparent pixels or a matte color that
matches the background color of the web page. The matte
color is used to blend in the partially transparent pixels to
fully opaque pixels.

The simplest way to create transparency is to add a layer
mask alpha channel to the image that masks the area of the
image you want to be opaque. You can do this by following
these steps:

1. Open the image in Photoshop.

2. Select the area of the image that you want to remain
opaque in the web page.

Figure 30.7 shows that the moon is selected in the image.
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Figure 30.7

To add transparency in an image, simply select the areas that
you want to remain opaque and click the Add layer mask icon
in the Layers panel.
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3. Click the Add layer mask icon in the Layers panel
shown in Figure 30.7.

Photoshop creates a new layer mask using the current
selection with a corresponding layer mask alpha channel. The
area outside the selection becomes transparent.

Figure 30.7 also shows the layer mask and alpha channel that
result from adding the pixel mask. Notice the transparency in
the image that results from the layer mask alpha channel.
Because the alpha channel is embedded in a GIF or PNG file,
the transparency is also embedded. Figure 30.8 shows the
difference that transparency makes when adding the image of
the moon to a web banner.

You can easily tweak the mask used for
transparency by using the techniques we discuss in Chapters
10 and 11. This enables you to fine-tune which areas of the
image are transparent.

Figure 30.8

Using transparency helps the image fit better with the
background of the web page.
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Animating images

Another important aspect of web page images is animation.
You can use animation in a variety of ways, from dancing
icons to web ads. Animation in web ads is particularly
important because you can get much more information to the
viewer by changing the text and images displayed in the ad.
For example, Figure 30.9 shows a simple animated web ad
that updates the text over a period of time to display features
of the website.

To learn how to animate the image using the
Photoshop timeline, see Chapter 28.

Figure 30.9
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Animating an image by replacing text enables you to show
different messages in a web image without needing to load a
separate file.

Outputting Images to the Web

The most powerful tool that Photoshop provides to output
images to the web is the Save for Web utility. This interface
has three basic purposes. One is to preview how the resulting
image will look and behave. The second is to convert the
image to a size, format, and set of colors that are supported in
web browsers. The third is to save the image to the
appropriate format with the needed supporting HTML code to
render the image in a browser.

To launch the Save for Web utility, shown in Figure 30.10,
choose File⇒Save for Web or press Ctrl+Alt+Shift+S/
+Option+Shift+S. The Save for Web utility has a lot going on
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in it, but don't be intimidated. After you get the hang of using
it, you'll appreciate how well it is laid out. The following
sections discuss the various parts of the interface to
familiarize you with the workflow of outputting images to the
web.

Figure 30.10

The Save for Web utility enables you to make the necessary
adjustments to the file format, size, colors, and other items to
prepare images for the web.

Using the preview layout and toolbar
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The preview layout is designed to give you a sense of what
the final image will look like as you prepare it for the web.
The preview layout offers four tabs that define what version
or versions of the image appear in the preview pane. The
options are Original, Optimized, 2-Up, and 4-Up.

The optimized preview shows what the image will look like
based on the values in the file output settings to the right of
the preview. The 2-Up and 4-Up tabs display either two or
four versions of the image, respectively. You can select a
version by clicking in the preview pane and using the control
settings on the right to adjust the values of that version. Using
the 2-Up and 4-Up options is a great way of previewing
different versions of the image, as shown in Figure 30.11. In
the example, we use three file formats, but you could just use
the 4-Up view to compare four optimization settings for the
same file type.

Figure 30.11

Using the 4-Up preview, you can compare four versions of
the image to see which file output settings are best.
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Notice in each of the preview panes that the file format
appears along with the size and download time. The image
size can be important if you need your web image to conform
to a standard that limits the maximum image size, such as for
advertisements. You can adjust the download rate using the
popup menu.

Below the preview panes you can see the RGB levels as you
pass the cursor over pixels in the image. Also displayed on
that line are the Alpha, Hex, and Index values of the pixel
currently under the mouse. Here's what those settings mean:
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• Alpha. The Alpha value displays the value of the alpha
channel, with 255 being completely opaque and 0 being
completely transparent.

• Hex. The Hex value shows the hexadecimal value of the
pixel. The hexadecimal value is useful if you are trying to
match colors in the HTML code with colors in the image.

• Index. The Index value is the index in the color lookup table
for the pixel directly under the cursor.

You can use the following tools to control and manipulate the
image in the preview shown in Figure 30.12:

Figure 30.12

You can control and manipulate the image in the preview
pane using the tools in the toolbar.

• Hand. This tool moves the image inside the preview pane.
This is especially useful if you are zoomed in on an image
and want to check out different locations. Using the Hand tool
moves the images in all preview panes.
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• Slice Select. This tool works just like the one in the
Photoshop Toolbox described earlier in this chapter. You can
manipulate the slices using the control handles, right-click to
display the slice options, and double-click a slice to set the
HTML options.

• Zoom. This tool enables you to zoom in on a specific area
of the slice by dragging a rectangle around that portion.

• Eyedropper. This tool enables you to select colors in the
image. The color is selected in the color table, which we
discuss later in this section.

• Eyedropper color. This icon displays the currently selected
color. Clicking this icon displays the color chooser.

• Slice visibility. This tool toggles the visibility of slices on
and off. You typically want slices to be visible only when you
are editing them.

• Zoom level. This tool gives you the ability to quickly set a
specific zoom level for the preview pane.

Setting file output options

The most important aspect of the Save for Web utility is the
ability to convert images from the editing format to a format
that is suitable for display on a web page. The file output
settings pane in the Save for Web utility enables you to define
the web file format and parameters used to convert the image
to that format.
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Each file format provides different output options used in
conversion. Figure 30.13 shows the options for GIF, JPEG,
and PNG-24. (PNG-8 is not shown because the options are
identical to GIF with the exception that the Lossy option is
omitted.)

Figure 30.13

The file output settings pane enables you to control options
used when converting the image from the editing format to
the web file format.

The following list describes each of the output options:

• Preset. This menu provides a list of predefined settings for
general purposes such as JPEG High Quality or PNG-8 128
Dithered.

• File Format. This menu enables you to specify the output
file format. We discuss file formats earlier in this chapter.

• Color Reduction Algorithm. This menu enables you to
specify the conversion method used to convert the image
from the current format to the web format. When converting
color images to another format, especially one supporting
fewer colors, Photoshop must decide what colors to use in the
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destination file for source pixels that don't match up. The
following list describes how each conversion option maps
colors:

• Perceptual. This option gives priority to colors for which
the human eye has greater sensitivity. This is often the best
choice because most web images are intended for viewing
only.

• Adaptive. This option creates a palette from the colors that
appear most often in the image. This typically keeps the most
detail in the image because there is a wider range of pixels in
that area to support detail.

• Selective. This option is similar to the perceptual option, but
it favors broad areas of color while preserving the web colors.
This usually produces images with the highest color integrity,
if not the best perceptual integrity.

• Restrictive. This option uses a standard 216-color table
common to both Windows and OS X, ensuring that no
browser dither is applied to colors when the image is
displayed using 8-bit color. Because this option creates larger
files, you should use it only if browser dithering is of high
priority.

• Custom. This option enables you to create your own custom
color palette when converting the image. The color palette is
customized in the Color Table pane in the Save for Web
utility.

• Black-White. This option uses only black and white in the
output image.
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• Grayscale. This option uses a grayscale tonal palette to
convert the image to grayscale.

• OS X. This option uses the OS X color palette to convert the
image. You should only use this option for images that will be
viewed from Mac OS browsers.

• Windows. This option uses the Windows color palette to
convert the image. You should only use this option for images
that will be viewed from Windows browsers.

• Colors. This field specifies the number of colors in the color
palette that is used by the conversion algorithm to convert the
image. A smaller number here usually results in a smaller file
size.

• Dither. This field enables you to select the method
Photoshop uses to dither the image during conversion.
Dithering simulates colors not available in the color display
system of the computer. When you convert an image with
continuous color tones to a smaller number of colors, banding
is often the result. One downside of dithering is that it
increases the size of the image.

Figure 30.14 shows an example of the banding that occurs in
an image when you convert it to 64 colors, as well as the
effect that dithering has to simulate more colors by diffusing
the pixels on the boundaries. Notice the banding in the
non-dithered image and how using diffused dithering results
in the appearance of more skin tones than exist in the actual
image.

Figure 30.14
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Using dithering when reducing the number of colors in an
image can resolve banding effects and give the appearance of
more colors in the image than actually exist.

You can specify the following methods for applying dithering
to the image during conversion:

• No Dither. This option applies no dithering to the images.
This results in a smaller file size but may also result in
banding, as shown in Figure 30.14.

• Diffusion. This option attempts to smooth transitions by
scattering the colors of the two neighboring pixels along the
edges. When you select this option, you can control the
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amount of dithering by adjusting the percentage value in the
Dither field to the right. The more you increase the Dither
setting, the larger the file size that results.

• Pattern. This option applies dithering by using a predefined
pattern of pixels to attempt to produce the intermediate colors
between the bands.

• Noise. This option applies dithering by introducing random
pixels in the image. This usually gives you the least appealing
results.

• Dither. This field specifies the percentage of dithering to
apply to the image. A larger amount of dithering softens
edges and removes pixelation but results in some blurring of
the overall image.

• Transparency. This option tells Photoshop to attempt to
preserve the semitransparent information, such as drop
shadows, by applying a matte to the semitransparent pixels to
create a fully opaque pixel. GIF, PNG-8, and PNG-24 files
support transparency, but only in the fully transparent pixels.

The Matte setting determines the color of the matte. If the
matte color matches the background color of the web page,
the image looks much better when it is viewed on the web
page.

If you enable transparency, you can also specify a dithering
option in the drop-down menu below Transparency. The
dithering options are the same as for the image conversion,
but they apply only when adding the matte to semitransparent
pixels.
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• Interlaced. This option sends a version of your image that
contains information for every other line of pixels to the
browser first so the browser can render a low-resolution copy
to the user while the rest of the image is downloaded. This
can improve the speed with which web pages are loaded, but
it also results in a larger image file. This option is not used
very much anymore because Internet connections are much
faster now.

• Web Snap. This field specifies a tolerance level that is used
to shift colors to the closest web palette equivalents. This
prevents the colors from dithering in the browser. The higher
the value, the more colors are being shifted.

• Lossy. This field enables you to control how aggressive the
GIF compression algorithm is when compressing the images.
The higher the number, the more aggressive the algorithm is,
thus reducing the file size. However, this also results in more
data being lost during compression. Typically, you can get
away with a value of 5 to 10 for most GIF images without
sacrificing too much quality.

• Quality. This field specifies the JPEG image quality setting
from Low to Maximum. This setting is a tradeoff: the higher
the quality, the better the image but the larger the file size.
You can also control this option by setting a value between 0
and 100, where 100 is the maximum quality.

• Progressive. This option displays the image progressively
in the web browser. Progressive means that the image is
displayed as a series of overlays, enabling the browser to
display a low-resolution image that progressively gains
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quality as more of the image is downloaded. Using this option
results in a larger file size.

• Blur. This field specifies an amount of blur that is added to
the image. Adding blur applies a Gaussian Blur filter to the
image and allows JPEG images to be compressed more,
resulting in a smaller file size.

• Optimized. This option creates an enhanced JPEG file with
a slightly smaller file size. This is great for reducing the file
size, but some older browsers do not support enhanced JPEG
images.

• Embed Color Profile. This option embeds the color profile
in the image.

Color management is an important aspect of web
images because the images will be viewed on a variety of
displays and you want the images to appear the same on all of
them. See Chapter 29 for more information about the sRGB
color profile and color profiles in general.

• Convert to sRGB. This option converts the image to the
sRGB color profile, which is the default color model for
displaying images in web browsers on many different
displays.

• Preview. This menu enables you to specify the color profile
used to render the images in the preview pane of the Save for
Web utility. Basically, this option controls the gamma used to
display the image in the preview pane. Because OS X prior to
OS X 10.6 used a different gamma than Windows, images
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display differently and are sometimes washed out on one
system when they look fine on another. Take a minute to use
the different preview options to verify how the image will
look on the different platforms.

• Metadata. This menu enables you to set the metadata
information to include with the converted file. Metadata is a
great way to keep track of information in the file. The
problem is that sometimes the metadata contains information
you do not want to distribute to anyone downloading the file
from the web — for example, camera settings or personal
information.

The Metadata menu enables you to control what metadata is
included in the web image. The options are None, Copyright,
Copyright and Contact Info, All Except Camera Info, and All.
The excess metadata items are stripped out of the converted
file.

In addition to the settings in the file output pane, you can also
use the following options from the side menu that help when
configuring the file output settings:

• Optimize to File Size. This option, in the Save for Web
dialog menu, launches the Optimize to File Size dialog box,
shown in Figure 30.15, which enables you to specify a file
size and then use that size to automatically configure the
options to match the desired output settings. The Start With
options enable you to use the currently selected file format or
enable the dialog box to choose either JPEG or GIF. The Use
options enable you to control how the output is applied to
slices in the image.
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Figure 30.15

The Optimize to File Size menu option in the file output
settings pane enables you to specify a desired output size for
the image, and Photoshop automatically sets the output
options necessary to result in the specified file size.

• Edit Output Settings. This option launches the Output
Settings dialog box, which controls how the image is actually
finalized for the web. The Output Settings dialog box is really
four different dialog boxes, shown in Figure 30.16, which
enable you to set the following output options:

• HTML. This section enables you to configure the HTML
settings such as using XHTML, tag casing, line endings, and
how to encode the HTML tags.

• Slices. This section enables you to specify whether slices are
encoded as an HTML table or CSS, as well as the default
naming scheme used for slices. The naming options should be
familiar to you by now.

• Background. This section enables you to control whether
the image is to be viewed as the background for the web page
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or just an image. You can also specify the color to use as the
background for the web page.

• Saving Files. This section enables you to configure the file
naming, compatibility, and location to output images to.
When Photoshop saves the image, it generates several
supporting HTML, CSS, and other files.

Figure 30.16

The Output Settings dialog box enables you to configure how
the image is actually finalized for the web, including HTML,
CSS, slice, background, and other settings.

Manipulating the Color Table
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The Color Table pane in the Save for Web utility enables you
to control and manipulate the color palette used for GIF and
PNG-8 file conversion. Only colors in the color palette will
exist in the outputted image, so manipulating the colors in the
Color Table pane lets you control the colors in the outputted
image.

You can select colors in the table by clicking the table with
the mouse or by clicking in the image using the Eyedropper
tool. You can select multiple colors in the table by holding
down the Shift key while you click them. After you have
colors selected in the table, you can use the following options,
shown in Figure 30.17, to control the color palette:

Figure 30.17

The Color Table pane enables you to use the color palette to
manipulate the colors and transparency that will be included
in the outputted image.
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• Number of Colors. This field displays the number of colors
in the color table.

• Map to Transparent. This option maps the currently
selected color or colors in the Color Table to transparent
pixels. The pixels that are this color will be transparent in the
outputted GIF or PNG-8 image. This can be useful if you
have solid colors in the image that you want to make
transparent.

• Shift to Web Palette. This option shifts a color in or out of
the web palette. If the currently selected color is outside the
web palette, it is shifted into the web palette. If the currently
selected color is already shifted into the web palette, it is
“un-shifted” back out.

• Lock Colors. This option locks the currently selected color
so it isn't dropped from the outputted image. This option is
especially useful if you have a specific one-color item — such
as a logo or symbol — that you want to ensure remains in the
original color in the outputted image.

• Add to Palette. This option adds the color from the Color
tool in the preview area to the color palette. This enables you
to define specific colors that you want included in the color
palette.

• Remove from Palette. This option removes the selected
color or colors from the color palette, enabling you to add
additional colors.

Setting the image size
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The Image Size pane in the Save for Web utility, shown in
Figure 30.18, enables you to control the size of the outputted
file without affecting the size of the original. The Image Size
pane enables you to set a specific height and width for the
image using the H and W settings. If you select the lock icon,
height and width changes are proportional. You can also set
the size of the output image using the Percent field, where
100 percent is the original size.

When changing the size of the image, Photoshop must
interpolate the values of pixels that either didn't exist in the
original image because the size is increasing, or are the result
of multiple pixels if the size is decreasing. The Quality option
enables you to specify which of the Photoshop interpolation
algorithms to use. The options are Nearest Neighbor, Bilinear,
Bicubic, Bicubic Smoother, and Bicubic Sharper.

Figure 30.18

The Image Size pane enables you to control the size of the
outputted image without affecting the size of the original
image.

Image resizing, including the various algorithms
used in the Quality setting, is discussed in more detail in
Chapter 3. See the resizing section of that chapter when
deciding which algorithm to use.
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Previewing animation controls

The Animation pane in the Save for Web utility provides two
features. The first is to set the Looping Options that will be
embedded with the animated image. You can set the Looping
Options to Once, Forever, and Other. If you select Other, a
dialog box appears that enables you to set the number of
times to loop the animation. How many loops you choose is
purely subjective. Playing the animation too many times can
be annoying with some images but is necessary with others.

The Other setting of the Animation pane, shown in Figure
30.19, enables you to preview the animation in the preview
pane. The Play, Rewind, and Fast Forward options enable you
to see each of the frames in the animation and preview their
behavior.

Figure 30.19

The Animation pane enables you to preview the animation as
well as control the number of times the animation plays when
the image is viewed.

Previewing output in a browser

A great feature of the Save for Web utility is the ability to
quickly preview the image in a web browser by clicking the
Preview button. When you click the Preview button, the
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image displays in the web browser based on the output
settings.

All the supporting web code appears below the image, as
shown in Figure 30.20. The HTML files are also created in
the output directory so you can actually test the images in the
web browser.

Note

The list to the right of the Preview button in the Save for
Web utility enables you to configure a list of web browsers
to test and to select the web browser used by the Preview
button. This enables you to quickly test web images in a
series of browsers.

Figure 30.20

The Preview button in the Save for Web utility launches a
web browser that enables you to quickly preview the look and
behavior of the image before saving it.
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Adding Zoomable Images to Websites

Photoshop provides the Zoomify plug-in as an additional
feature to output images to the web. Zoomify carves an image
up into a series of JPEG tiles that can be used by a Flash
browser utility to quickly zoom in and out, as well as pan
images in a web page. By breaking the image up into a series
of tiles, less data needs to be sent to the web browser, so the
performance in viewing images is very good.

To launch the Zoomify tool, shown in Figure 30.21, choose
File⇒Export⇒Zoomify from the main menu bar in
Photoshop. The Zoomify utility enables you to specify the
output location and a base name to use for the output files.
You can also specify the JPEG quality using the Image Tile
Options settings. The Browser Options enable you to set the
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width and height, in pixels, which the Zoom utility takes up in
the browser.

Figure 30.21

The Zoomify utility is used to carve up a high-definition
image into a series of smaller JPEG tiles so the image can be
easily zoomed in and out and panned using a Flash Player in a
web browser.

The following is a list of the files and folders that the
Zoomify tool generates in the Output Location. You can
transfer these files and folders to your web browser to be
included in your website:

• <Base Name>.html. This is the HTML file based on the
Base Name setting that is used to display the Zoomify Flash
Player utility. The appropriate code in this file can be cut and
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pasted into your web page code to include the image on your
website.

• <Base Name>. This is a folder based on the Base Name
setting that contains the following items:

• ImageProperties.xml. This specifies data necessary for the
Zoomify Flash Player.

• zoomifyViewer.swf. This is the Zoomify Flash Player
utility that renders the images and provides the controls in the
browser to zoom in and out on the image.

• TileGroup#. This is a series of folders that contain the
JPEG tiles of the image. Each tile is named using the
#-#-#.jpg filename format. Each number represents a location
in the image and zoom scale, and the numbers are used to
display the zoomed portions of the image.

Figure 30.22 shows how a Zoomified image appears in a web
browser. Using the utility, you can easily zoom in and pan to
an individual balloon.

Note

When you click the OK button in the Zoomify Export dialog
box, a web browser launches to display the Zoomified
image. You may need to enable the Zoomify ActiveX
application when the browser launches.

Figure 30.22
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You can easily zoom in on and pan around a high-resolution
image that has been Zoomified.

Applying CSS to Photoshop Images

Photoshop is an important tool for generating content for web
pages. Currently most formatting of text and images on web
pages is done using CSS. Adobe provides a few great tools
that enable you to interact with the CSS code that applies to
the web pages your images display on.

The following sections discuss how to use the Adobe CSS/
HTML tools to better prepare images for web pages. You will
get a chance to see how to export settings from Photoshop as
CSS code, as well as how to import the colors defined in the
CSS document into Photoshop.

Generating CSS styles from text and shape layers

A great new feature in Photoshop is the ability to export the
Photoshop styles applied to text and vector layers as CSS
properties that can be directly used in web pages. Photoshop
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is able to export several different CSS style properties,
including the following:

• font-size. Defines the size at which text displays in the web
browser.

• font-family. Defines which font is used for the text.

• color. Defines the color of text and other elements.

• background-color. Defines the background color applied
behind the web elements.

• text-align. Defines whether the text is left, right, or center
aligned.

• position. Defines the position type for the text or shape.
This can be absolute, meaning that it is positioned in a
specific place on the web page; relative, meaning that it is
positioned in a specific place relative to a parent HTML
element; or static, meaning that the text or shape flows with
the other HTML elements around it. This attribute is also
combined with the top and left properties that define the
top-left position to place the text or vector element.

• width. Defines the width of a shape or text area in the web
page.

• height. Defines the height of a shape or text area in the web
page.
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• z-index. Defines the stack level of the text or shape element.
Elements with larger numbers are stacked on top of elements
with smaller numbers, similar to papers on a desk.

• border. Defines the color, line type, and thickness of the
border of a shape. If the shape has no stroke, but only fill, it
does not include a border style when exported.

• border-radius. Defines the radius size of the border, where
0 is a perfectly square border.

To export CSS data from vector shape and text layers, select
the layer in the Layers panel and then select Layer⇒Copy
CSS from the main menu. The CSS properties for that layer
are copied to the clipboard and you can then paste them into a
CSS editor.

Figure 30.23 shows the process of copying the CSS properties
out of a text layer in Photoshop and then pasting them into a
CSS editor. Notice that the font, color, and text-align
properties are set, among others.

Figure 30.23

Selecting Layer⇒Copy CSS allows you to copy the CSS
properties that match the text or shape layer settings to the
clipboard and then paste them into an editor.
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Importing swatches from HTML/CSS files

Photoshop also enables you to import the color properties of
elements from HTML/CSS documents. This helps you to
keep web images consistent with the colors of other web
elements such as menus, banners, buttons, and text. To do
this, Photoshop enables you to load an HTML/CSS file as a
swatch source using load options in the Swatches panel menu.
Figure 30.24 shows an example of replacing the current
swatch set with one imported from a CSS document using the
following steps:

1. Click the Swatches panel menu.

2. Select Replace Swatches to load the Load dialog box.

3. Select CSS or HTML from the file type drop-down
menu.

4. Navigate to the CSS or HTML file.

5. Click Load.
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Notice that the swatches are replaced by the color settings
from the CSS or HTML file.

Figure 30.24

Selecting Replace Swatches from the Swatches panel menu
allows you to load a new set of swatch colors from the
settings in an HTML or CSS document.

Summary

Photoshop provides several powerful features that can aid
graphic designers in creating and preparing images for web
applications. It provides the tools necessary to convert image
formats to formats supported by web browsers, set the size of
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images to reduce the bandwidth they require for download,
and apply color profiles to ensure that the image colors are
consistent across multiple web browsers.

Photoshop also provides features that enable you to quickly
add animation and transparency to give your images a much
better look and feel. This chapter discussed the Save for Web
utility, which enables you to quickly configure image file
formats, preview output, convert images, and generate the
HTML output necessary to support them.

In this chapter, you learned the following:

• How to use CSS and HTML documents to generate
Photoshop swatches

• How to convert images to file formats that web browsers
can support

• How to use color profiles to ensure that image colors remain
consistent between web browsers

• How to add transparency to web images so they blend in
better with the web page

• How to use Zoomify to add high-resolution images that can
be zoomed and panned to web pages

• How the Save for Web utility enables you to control what
image metadata is included in web images so you can, for
example, show copyright information but hide camera
settings
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• How to preview images in web browsers before outputting
them to the new file format
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Chapter 31: Automating and Scripting Workflow in
Photoshop

In This Chapter

Using scripts to simplify workflow tasks

Assigning actions and scripts to Photoshop events to automate
tasks

Photoshop is a powerful application with many tools and
utilities that provide limitless ways to create and edit images.
The power of Photoshop comes with one big drawback: it has
so many tools, menu options, and panels that navigating
through them can be difficult, especially if you need to
perform repetitive tasks on several files.

To solve that problem, Photoshop has provided several tools
that make it possible to automate much of your workflow by
using batch processing and scripting. Batch processing
involves performing the same set of commands on a group of
files. Scripting involves applying a script as either a one-time
command or each time a workflow event occurs. The
following sections discuss using the Photoshop automation
and scripting tools to make your image editing easier and
faster.

Automating Workflow in Photoshop

When editing images, one of the best ways to save time and
increase your productivity is to automate repetitive tasks that
need to be done on a series of photos. For example, a set of
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photos taken with the same lens at a wedding dinner may all
need a lens correction filter applied as well as a color
correction to adjust for the lighting at the event. If you were
to make those adjustments to each image individually, it
would take a lot of time.

Photoshop has a couple of great utilities that help you
automate the workflow necessary to make the same
adjustments to a series of photos with one simple command.
The Batch and Droplet utilities enable you to quickly apply
custom actions to files to save time when editing.

We cover custom actions in Chapter 5. You can
refer to that chapter to find out how to build the actions and
action sets that the Batch and Droplet utilities can then use.

Batching multiple images

The Batch processing utility enables you to apply a
customizable action to a set of images and control how the
images are processed.

The way batch processing works is that you define a location
for a set of files, select one of the customized actions defined
in the Actions panel, and then define how you want
Photoshop to output the processed photos. When the batch of
images is processed, Photoshop opens each image, performs
the steps in the selected action on the image, and saves the
adjusted image to disk where you can then perform custom
adjustments later.
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You can start batch processes in a couple of different ways:
by selecting the files in Bridge and then choosing
Tools⇒Photoshop⇒Batch from the main menu bar, or by
choosing File⇒Automate⇒Batch from the Photoshop menu
bar. Whichever way you choose, Photoshop opens the dialog
box shown in Figure 31.1.

Figure 31.1

Using the Batch dialog box, you can define a custom action
that is applied to a set of source files, and define a location
and file-naming format to use when saving the edited images.
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Bridge is a great application for organizing and
managing your images, and we discuss it in Chapter 6.

The batch dialog box is usually the best way to perform batch
edition on images. It is flexible and consistent and can be set
up to run for as long as necessary to edit a large amount of
images. The following options are available in the Batch
dialog box:

• Play. This section enables you to define what action to
perform on each of the files specified by the Source settings.
You can choose from the following options:

• Set. This menu displays a list of the defined sets in
Photoshop. The default set provides some standard actions
such as Vignette and Custom RGB to Grayscale. However,
you will likely be creating your own action sets with
customizable actions. For example, you may want to create an
action set with lens-correction filter actions for each of your
lenses.

• Action. This menu enables you to specify the action to be
performed on each image when the files are processed.
Actions can perform anything from a simple one-step edit to a
series of complex edits. The options available from the Action
menu represent the list of actions that are contained in the
selected set in the Actions panel.

• Source. This menu enables you to define where Photoshop
gets the source images to be edited. You can select files from
four different sources: Folder, Import, Opened Files, and
Bridge.
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When you select Folder, you can click the Choose button to
launch a dialog box that enables you to select a folder that
contains files to be included in the batch edit.

When you select Import, you can process images from a
digital camera, scanner, or PDF. The Import option is
available only if you specify that you want to batch process
folders when you are importing them into Photoshop or
Bridge.

When you select Opened Files, this batch processes all
images currently open in Photoshop.

When you select Bridge, Photoshop batch processes the files
currently selected in Bridge. The Bridge option is available
only when you are using the Bridge interface to launch the
Batch processing utility.

The Source option also enables you to use the following
settings to control how Photoshop handles image files from
the source location:

• Override Action “Open” Commands. When you select
this option, batch processing overrides the choice of files
specified for an “Open” command in the action. This does not
override the settings in the Open command, just the choice of
files.

This option is necessary for actions that include Open
commands for the most recent or current files because the
most recent file is always the first image in the set of source
files. You should not enable this option for actions that do not
contain an Open command.
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You can leave this option disabled if the action does not
include an Open command or if the Open command is on
another file that is required for the action but not the actual
file that is being edited.

• Include All Subfolders. When you select this option,
images in all subfolders in the selected folder are also batch
processed. This allows you to process images in multiple
folders so you can keep your files well organized.

• Suppress File Open Options Dialogs. When you select this
option, Photoshop hides the File Open dialog boxes. Instead
of requiring you to specify the open options, Photoshop uses
the default values. This option is especially useful if you are
batch processing Camera Raw images, because you can preset
how to treat the images and bypass the dialog box when batch
editing.

• Suppress Color Profile Warnings. When you select this
option, the color policy messages, such as color mismatch or
missing color profiles, do not appear.

• Destination. This menu enables you to control how and
where the edited images are saved to disk. You can specify
one of three different destinations: None, Save and Close, and
Folder.

If you select None, the images are edited but left open in
Photoshop unless the action includes a Save or Save As
command. If you select Save and Close, the original image is
overwritten by the edited image on disk.
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If you select Folder, you can use the Choose button to select a
destination folder to save the edited images. The edited
images are saved in that location using the name formatting
you specified in the File Naming section.

The following options enable you to override the Save As
command and define the file naming convention:

Caution

You should select the Save and Close option only if you are
confident that the action will give you the best results. After
the original file is overwritten, you cannot go back and undo
the edits.

• Override Action “Save As” Commands. When you select
this option, batch processing overrides the destination folder
and the filenames specified by a Save or Save As command in
the action. This does not override the settings in the Save
commands, just the destination and name of the files.

You do not need to enable this option for actions that do not
contain a Save or Save As command.

Note

A lot of options are available in the Save As dialog box in
Photoshop that are not available in the Batch dialog box —
for example, compression, saving layers, and so on.
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Typically, you want to record a Save As command into the
editing that sets these options. In addition, you can use a
Save As command in the action to change the file type of
the images during the batch process.

• File Naming. This section enables you to set the naming
convention that Photoshop uses to save the edited file. You
define the file convention by selecting the appropriate
components from the menus shown in Figure 31.2. You can
also type into one of the field components static text that is
included in the filename.

When Photoshop saves the edited file, it uses these
components in the order specified to create the filename.
When you use the components, you can include the document
name and extension in different casing formats, serial letters,
multi-digit numbers, and different date formats.

Note

When using Digit Serial Numbers, the numbers start with
the number specified in the Starting serial# field and are
prefixed by enough zeros to force them to the number of
specified digits. When using serial letters, the first image
starts with a/A.

Figure 31.2
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The File Naming options in the Batch dialog box enable you
to select filename components based on date, document name,
extension, and serialized letters or numbers.

• Compatibility. These options enable you to limit the
naming conventions to support Windows, OS X, and Linux/
Unix systems. This is useful if you plan to share your images
with others who may be using different systems.

• Errors. This menu enables you to control how errors in the
batch processing are handled. You have two options:

• Stop for Errors. When you select this option and an error
occurs when editing one of the files in the batch, an error
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message appears and the processing stops there. No additional
files are processed.

• Log Errors to File. When you select this option and an
error occurs when editing one of the files in the batch,
Photoshop logs the error message to a file and the processing
continues. You can set the location of the log file by clicking
the Save As button. The log file is in text format and you can
read it with any text editor to determine which files failed and
why.

Creating droplets to process images

Droplets are similar to batch operations with the exception
that instead of selecting a source for files, you specify a
location where you want to save the processing information in
the file system. The processing data is converted to an
executable file that processes any files or folders that you
drag and drop onto it.

You can create a droplet by choosing
File⇒Automate⇒Create Droplet from the Photoshop menu
bar. Notice that the options in the Create Droplet dialog box,
shown in Figure 31.3, are similar to the Batch options. The
only difference is that instead of a Source option, you have a
Save Droplet In option that enables you to select a location to
save the droplet.

Figure 31.3

Using the Create Droplet dialog box, you can create an
executable file that applies an action to any image files that
you drag and drop onto it.
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To create the droplet, fill in the Save Droplet In, Play,
Destination, and Errors settings, and then click OK.
Photoshop creates an executable file in the location you
specified. To use a droplet, simply use the file system
interface to drag and drop files or folders onto the droplet.
The droplet uses Photoshop to perform the specified action
and save the adjusted files.

Tip

You can move a droplet between Windows and OS X
systems. When moving a droplet from Windows to OS X, or
vice versa, drag and drop it onto the Photoshop application
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icon on the new system. Photoshop converts the droplet so
that it can be used on that system. If you are planning to
move a droplet from OS X to Windows, make sure to name
it with the “.exe” extension once it is on the Windows
system so it can be executed on the Windows system.

You should be aware, however, that file references in
actions do not work across Windows and OS X systems. If
an action refers to a file, such as in an “Open” or “Save As”
command, the droplet prompts for the location of the file if
it is used on a different system.

Using Scripting to Speed Up Workflow

Another great way to save time and increase your
productivity when editing images is to use the scripting
capabilities in Photoshop. Two main types of scripts are
available in Photoshop: predefined scripts and event-driven
scripts. Predefined scripts run once when you select them
from the File⇒Scripts menu shown in Figure 31.4.
Event-driven scripts are triggered and executed by events in
your normal editing workflow. The following sections discuss
how to use each type of script.

Figure 31.4

The File⇒Scripts menu in Photoshop provides several
predefined scripts that perform tasks to speed up your
workflow.
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Using the Photoshop scripts

Predefined scripts are similar to other commands in
Photoshop with the exception that they typically perform
more than just one task on a single item. The predefined
scripts are JavaScript or AppleScript scripts that perform a
series of Photoshop tasks to reduce the number of keystrokes
and mouse clicks you need to make. While the JavaScript
scripts are cross-platform, the AppleScript scripts only work
on Macs. The following is a list that describes the predefined
scripts available from the File⇒Scripts menu:
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• Image Processor. This option launches a dialog box that
enables you to process a set of files, for example, by
converting the format, changing names, running actions, and
so on.

The best place to use the Image Processor is from
Bridge while you are managing your files. To find out how to
use the Image Processor utility to convert and process images
from Bridge, see Chapter 6.

• Delete All Empty Layers. This option removes empty
layers from the image. This can be a useful tool to clean up an
image when you have used a lot of layers while editing.

• Flatten All Layer Effects. This option flattens all the
effects that apply to the currently selected layer in the Layers
panel. This rasterizes all of the layer effects so you can apply
additional filters or other tools that require the layer to be
flattened.

• Flatten All Masks. This option applies the layer masks in
all layers. The layer masks affect only the layer to which they
are linked.

• Layer Comps to Files. This option opens a dialog box,
similar to the one in Figure 31.5, which enables you to
specify a file type and location using the following options:

• Destination. This field specifies the location on disk where
you want to create the files.
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• File Name Prefix. This field specifies the name prefix that
is applied to the saved files. The rest of the filename includes
a numerical index and the file extension that you specify in
the File Type drop-down menu.

• Selected Layer Comps Only. This option enables only the
currently selected Layer Comps in the image to be saved as
individual image files in the specified location. Otherwise, all
Layer Comps are saved as individual files.

• File Type. This menu specifies the file format to use when
saving the image. You can select BMP, JPEG, PDF, PSD,
Targa, TIFF, PNG-8, or PNG-24.

• Include ICC Profile. This option specifies whether to
include the current ICC color profile with the saved images. It
is always a good idea to include a color profile when saving
images.

• PSD Options. This section contains any additional options
for the selected file type.

Figure 31.5

You can use the Layer Comps to Files script utility to convert
the Layer Comps in the current document into individual
files.
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• Layer Comps to PDF. This option flattens each Layer
Comp and saves it to a single PSD file; then it launches PDF
Presentation to convert each file into a PDF page. Photoshop
enables you to convert all Layer Comps or just the selected
ones.

• Export Layers to Files. This option opens a dialog box,
similar to the one in Figure 31.5, except that instead of only
saving Layer Comps, all layers are saved to files.

• Script Events Manager. This option enables you to attach
specific actions to workflow events in Photoshop. We discuss
the Script Events Manager in more detail later in this chapter.

• Load Files into Stack. This option opens the Load Layers
dialog box, shown in Figure 31.6, which enables you to
combine a set of files into a stack. A stack is a set of image
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files taken of the same subject from the same camera position.
Image stacks loaded as layers can be converted to a Smart
Object and then processed using the options located in the
Layer⇒Smart Objects⇒Stack Mode options discussed in the
next section.

From the Load Layers dialog box, you can configure the
following options:

• Use. This menu enables you to specify whether to use files
or a folder as the source for the set of files. The Browse,
Remove, and Add Open Files buttons enable you to add files
and remove files and folders from the Use list.

• Attempt to Automatically Align Source Images. This
option causes Photoshop to search for common edges in the
images and automatically adjust the rotation and position so
the images are as closely aligned as possible. Aligning the
images is important for the stack mode algorithms to work
well.

• Create Smart Object after Loading Layers. This option
automatically creates a Smart Object from all the images. If
you do not select this option, the images are loaded as
individual layers that you can edit before combining them
into a Smart Object. The stack mode algorithms are based on
processing a Smart Object.

Figure 31.6

The Load Files into Stack script utility provides a simple
dialog box that enables you to select files and define how the
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individual files are added to a newly created stacked
document.

Another great place to create image stacks is from
Bridge while you are managing your files. We cover using the
Bridge application to stack and unstack images in Chapter 6.

• Load Multiple DICOM Files. This option opens a dialog
box that enables you to select a folder containing a set of
DICOM image files. The DICOM files in the folder are added
as individual layers to a new document in Photoshop.

• Statistics. This option opens the Image Statistics dialog box,
shown in Figure 31.7. This is similar to the Load Files into
Stack option, except that it automatically converts the images
into a single Smart Object and then applies the stack mode
that you specified in the Choose Stack Mode drop-down
menu. Statistics is a better option than Load Files into Stack if
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you do not want to align the images manually, or if you don't
want to edit any of the layers before applying the stack mode
to the set.

Figure 31.7

The Image Statistics dialog box enables you to set the stack
mode that is applied after some files are automatically
converted into a single Smart Object.

Using stack modes to analyze multiple images and reduce
noise

Photoshop provides several options for processing images
that have been stacked into a Smart Object using the Load
Files into Stack script described in the previous section. These
stack mode options can analyze the differences between
images and combine the images to reduce noise. You can find
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the following stack mode options in the Layer⇒Smart
Objects⇒Stack Mode menu:

• Mean. This option averages the pixels for all images in the
stack and uses the average value for the stacked image. This
is usually the best option for noise reduction if the images are
very similar.

• Summation. This option calculates the pixel values in the
stacked image by adding values from all images in the stack.
This increases the resolution in the more faint areas of the
images, but the brighter areas just become white.

• Minimum. This option uses the minimum channel value for
all non-transparent pixels in the stacked image. This is good
for stacks of images where you want to darken the overall
image.

• Maximum. This option uses the maximum channel value
for all non-transparent pixels in the stacked image. This is
good for stacks of images where you want to lighten the
overall image.

• Median. This option takes the middle value for all images in
the stack and uses that value for the stacked image. This
option works better than the Mean mode for noise reduction if
there is a lot of variance in the lighting and color of the
images, such as scratches or dark areas.

Figure 31.8 shows an example of how you can use the
Median mode to remove unwanted items. Notice that the
three images of the moon have a silhouette of a bird in front,
so none of them is a clean shot. You can remove the bird by
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stacking the three images and applying the Median mode as
shown in the results.

Figure 31.8

Using the Median mode, three images of the moon with a
silhouette in front can be processed into a single clean image.

• Variance. This option is similar to the Standard Deviation
option. Areas that match are black, and areas that do not
match are gray to white, based on the variance in the stacked
image.

• Standard Deviation. This option calculates the stacked
image values based on the standard deviation from the square
root of the variance. This can help you analyze areas of the
images that are different; the different areas show up as a
lighter value based on the amount of variance, while areas
that are the same across all stacked images are black.

• Skewness. This option calculates the pixel value based on
the variance of the pixels away from the average. This shows
how close the pixel values are to each other.

• Kurtosis. This option calculates the stacked image based on
peakedness or flatness of the levels in the image. Areas that
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match a normal distribution of levels appear lighter while
areas that are flat or overpeaked appear darker.

• Range. This option calculates the pixel value in the stacked
image based on the maximum pixel value minus the
minimum pixel value. This shows the range of variance in the
stacked images.

• Entropy. This is calculated based on the number of bits that
would be necessary to encode the data from all images in a
set. Areas of the image that are different show up as white in
the resulting image and areas with little difference show up as
black. This is a great option for locating missing items
between one image and another or embedding hidden
copyright notices.

Figure 31.9 shows an example of using the Entropy stack
mode to analyze two digital images. Notice that they both
look the same, but when the Entropy mode is used, a clear
copyright notice is shown. The copyright notice is added by
creating a text selection mask (as we discuss in Chapter 18),
copying it to a new layer, and then slightly adjusting the
position. You can't see the change because it is in a busy area
of the image.

Figure 31.9

Using the Entropy mode, you can quickly compare a digital
image with the original to reveal an embedded copyright
message.
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Tip

For the best results, images that you intend to edit using the
stack mode options should be taken from a fixed position
such as a tripod with a stationary subject. At the very least,
the images must be similar enough that you can align them
in the set.

Use the following steps to apply a stack mode to a series of
photographs:

1. Choose File⇒Scripts⇒Load Files into Stack from the
main menu bar.

2. Add the files you want to apply to the stack as described
earlier.
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3. Select the Attempt to Automatically Align Source
Images option.

This option tries to align the images so that they match up
correctly.

Note

You may need to manually align the images in the Smart
Object if the Attempt to Automatically Align Source Images
option fails to align them completely. To align the images
manually, double-click the Smart Object layer to open the
Smart Object. The images are in separate layers, and you
can use the Move tool to move the images in each layer until
they are aligned.

4. Select the Create Smart Object after Loading Layers
option.

This converts the image layers into a single Smart Object.

5. Click OK.

The images are processed into a single document in
Photoshop with a Smart Object layer.

6. Select the newly created Smart Object layer.

7. Open the Layer⇒Smart Objects⇒Stack Mode menu
and select the stack mode that you want to apply to the
image.
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The resulting image in the document window is changed to
the results of the stack mode.

Scripting workflow events

Photoshop provides the Script Events Manager, shown in
Figure 31.10, which gives you access to certain program
events that occur during a normal editing workflow. The
Script Events Manager lets you attach scripts or actions to
these events so that the script or action runs each time an
event occurs during your editing workflow.

Scripting workflow events can be a big timesaver because
they automatically perform actions you want to happen
without needing to remember them. For example, you can
configure the open file event to automatically save a JPEG
copy, so that each time you start editing a file, you have a
JPEG backup.

You can load the Script Events Manager utility by choosing
File⇒Scripts⇒Script Events Manager from the Photoshop
menu bar. The Script Events Manager enables you to use the
following options to assign scripts and actions to workflow
events:

• Enable Events to Run Scripts/Actions. This option
activates the associations in the scripted events list when you
are working in Photoshop. When you deselect this option,
Photoshop ignores the events and no action or script runs.

• Scripted Events List. This field lists the current
associations between events and actions or scripts. The Add
button enables you to add the association defined by the
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Photoshop Event, Script, and Action settings to this list. The
Remove and Remove All buttons enable you to remove
associations from the list.

• Photoshop Event. This menu displays a set of Photoshop
events that you will encounter during the normal workflow,
including Start Application, New Document, Open
Document, Start Save Document, Save Document, Close
Document, Print Document, Export Document, and
Everything (all available events).

• Script. This menu specifies a script that should be
associated with an event and that should run each time the
event occurs. The menu displays the available scripts. The
default script options are limited; however, the menu also
provides a browse option so that you can select a JavaScript
or AppleScript script from the file system.

• Action. This option specifies an action that should be
associated with an event and that should run each time the
event occurs. The first drop-down menu enables you to select
the action set from the available action sets defined in the
Actions panel. The second drop-down menu enables you to
select the action from the available actions defined in the
Actions panel. Because you can easily create custom actions
using the Actions panel, you have a lot of options when
associating actions with events.

We cover custom actions in Chapter 5. You can
refer to that chapter for the information necessary to build the
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actions and action sets that can be associated with workflow
events.

Figure 31.10

The Script Events Manager enables you to associate an action
or a script with normal workflow events so that each time an
event occurs, Photoshop performs the action or runs the
script.

Summary

This chapter discussed using the Photoshop automation and
scripting tools to speed up your image-editing workflow.
Photoshop provides the Batch and Droplet tools, which
enable you to perform the same set of commands on a set of
files without opening each file individually.
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Photoshop also provides several scripts that perform a set of
repetitive operations, such as flattening layer masks using a
single menu option. In addition to the scripts, Photoshop
provides the Script Events Manager, which enables you to
associate actions and scripts with normal workflow events.
Each time an event occurs during your workflow, Photoshop
performs the associated action.

In this chapter, you learned the following:

• How to use custom actions to process a set of image files all
at once

• How to save a predefined action as a droplet, and how to
drag and drop a file onto that droplet in order to apply the
action

• How to use Photoshop scripts that enable you to perform
repetitive actions

• How to use the Statistics scripts to load a series of photos
into a stack and then automatically process the set of files to
clean up noise in a way that is not possible with a single file

• How normal workflow events such as opening or saving a
file can be tied to actions such that Photoshop automatically
applies the action when the event occurs
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Appendix A: Timesaving Keyboard Shortcuts

IN THIS APPENDIX

Getting familiar with standard toolbar shortcuts

Using common menu command shortcuts

Working with extended toolbar shortcuts

Learning keyboard shortcuts is one of the best ways to
improve your performance and experience with Photoshop.
With hundreds of tools and menus, navigating with the mouse
can take time. Knowing the keyboard shortcuts for actions
that you frequently perform can make editing faster and less
cumbersome.

The purpose of this appendix is to give you a sample of the
most common shortcuts you will encounter in Photoshop.
Both the Mac and PC keyboard shortcuts are listed in the
tables.

Using Toolbox Shortcuts

The Toolbox shortcuts in Photoshop provide quick access to
common Toolbox options such as selecting the Brush tool or
cycling through the Brush, Pencil, Color Replacement, and
Mixer Brush tools. When you press the shortcut keys, the tool
is selected and ready to use. When you press a cycle shortcut
key sequence, Photoshop cycles through each of the different
tools located in the toolset of the Toolbox.
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Table A.1 provides a list of most of the standard Toolbox
shortcuts.

Table A.1 Standard Toolbox Shortcuts

Photoshop CC Standard Toolbar PC
Shortcut

Mac
Shortcut

Move tool V V

Rectangular Marquee tool M M

Cycle Marquee tools Shift+M Shift+M

Lasso tool L L

Cycle Lasso tools Shift+L Shift+L

Quick Selection, Magic Wand tools W W

Cycle Quick Selection, Magic Wand
tools Shift+W Shift+W

Crop tool C C
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Cycle Crop, Slice tools Shift+C Shift+C

Eyedropper tool I I

Cycle Eyedropper, Color Sampler,
Ruler, Note, and Count tools Shift+I Shift+I

Spot Healing Brush J J

Cycle Spot Healing Brush, Healing
Brush, Patch, and Red Eye tools Shift+J Shift+J

Brush tool B B

Cycle Brush, Pencil, Color
Replacement, and Mixer Brush tools Shift+B Shift+B

Clone Stamp tool S S

Cycle Clone Stamp, Pattern Stamp tools Shift+S Shift+S

History Brush tool Y Y
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Cycle History Brush, Art History Brush
tools Shift+Y Shift+Y

Eraser tool E E

Cycle Eraser, Background Eraser, and
Magic Eraser tools Shift+E Shift+E

Gradient tool G G

Cycle Gradient, Paint Bucket tools Shift+G Shift+G

Blur, Smudge, Sharpen tools None None

Dodge tool O O

Cycle Dodge, Burn, Sponge tools Shift+O Shift+O

Pen tool P P

Cycle Pen, Freeform Pen tools Shift+P Shift+P

Add, Delete, Convert Anchor Point tools None None
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Horizontal Type tool T T

Cycle Horizontal Type, Vertical Type,
Horizontal Type Mask, and Vertical
Type Mask tools

Shift+T Shift+T

Path Selection tool A A

Cycle Path Selection, Direct Selection
tools Shift+A Shift+A

Rectangle tool U U

Cycle Rectangle, Rounded Rectangle,
Ellipse, Polygon, Line, and Custom
Shape tools

Shift+U Shift+U

Hand tool H H

Rotate View tool R R

Zoom tool Z Z

Swap Foreground, Background Color X X

1879



Default Foreground and Background
Colors D D

Edit in Quick Mask Mode Q Q

Accessing Menu Options Quickly

The menu command shortcuts in Photoshop provide quick
access to common menu options. Rather than using the mouse
to cycle through the menu, you can simply press the keyboard
shortcut.

Table A.2 provides a list of most of the common menu
shortcuts.

Note

On Macs, shortcuts requiring F-keys, such as Shift+F5, may
also require the Fn key to be pressed depending on the
physical keyboard and the settings in the Keyboard System
Preferences.

Table A.2 Common Menu Command Shortcuts

Popular Menu Commands PC Shortcut Mac Shortcut

New Document Ctrl+N +N

1880



Open Document Ctrl+O +O

Browse in Bridge Ctrl+Alt+O +Option+O

Close Document Ctrl+W +W

Close all Documents Ctrl+Alt+W +Option+W

Print Document Ctrl+P +P

Undo Ctrl+Z +Z

History Step Forward Ctrl+Shift+Z +Shift+Z

History Step Backward Ctrl+Alt+Z +Option+F

Fade Ctrl+Shift+F +Shift+F

Fill Shift+F5 Shift+F5

Free Transform Ctrl+T +T

Color Settings Ctrl+Shift+K +Shift+K
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Image Size Ctrl+Alt+I +Option+I

Canvas Size Ctrl+Alt+C +Option+C

Levels Ctrl+L +L

Curves Ctrl+M +M

Hue/Saturation Ctrl+U +U

Color Balance Ctrl+B +B

New Layer Ctrl+Shift+N +Shift+N

New Layer via Copy Ctrl+J +J

Group Layers Ctrl+G +G

Select All Ctrl+A +A

Deselect All Ctrl+D +D

Inverse Selection Ctrl+Shift+I +Shift+I
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Refine Edge Ctrl+Alt+R +Option+R

Proof Colors Ctrl+Y +Y

Gamut Warning Ctrl+Shift+Y +Shift+Y

Zoom In Ctrl+plus(+) +plus(+)

Zoom Out Ctrl+minus(–) +minus(−)

Fit on Screen Ctrl+0 +0

Show Actual Pixels Ctrl+1 +1

Show/Hide Extras Ctrl+H +H

Rulers Ctrl+R +R

Brush panel F5 F5

Layers panel F7 F7

Info panel F8 F8
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Photoshop Help F1 +/ or Help

Increase Brush Diameter ] ]

Decrease Brush Diameter [ [

Increase Brush Hardness Shift+[ Shift+[

Decrease Brush Hardness Shift+] Shift+]

Working with Extended Toolbox Shortcuts

The extended Toolbox shortcuts in Photoshop provide quick
access to the CC extended Toolbox options, such as selecting
the 3D Rotate tool or cycling through the 3D Object Rotate,
3D Object Roll, 3D Object Pan, 3D Object Slide, and 3D
Object Scale tools. When you press the shortcut key, the tool
is selected and ready to use. When you press a cycle shortcut
key sequence, Photoshop cycles through each of the different
tools located in the toolset of the Toolbox.

Table A.3 provides a list of most of the extended Toolbox
shortcuts.

Table A.3 Extended Toolbox Shortcuts
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Photoshop CC Extended Tools PC
Shortcut

Mac
Shortcut

3D Object Rotate tool K K

Cycle 3D Object Rotate, 3D Object Roll,
3D Object Pan, 3D Object Slide, and 3D
Object Scale tools

Shift+K Shift+K

3D Rotate Camera tool N N

Cycle 3D Rotate Camera, 3D Roll
Camera View, 3D Pan Camera View, 3D
Walk Camera View, and 3D Zoom
Camera tools

Shift+N Shift+N
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Appendix B: Extending the Capabilities of Photoshop with
Plug-Ins

IN THIS APPENDIX

Installing plug-ins to extend Photoshop

Downloading optional plug-ins from the Adobe website

Photoshop is a powerful image-editing application. However,
one of the best features of Photoshop is that you can install
plug-ins that add features and functionality that don't already
exist or even improve functionality that does. A lot of
plug-ins are available from Adobe as well as other sources
that provide specialized functionality for a variety of
purposes.

Installing Optional Photoshop Plug-Ins

You can install Photoshop plug-ins by copying the plug-in
file into the Adobe Photoshop CC/Plug-Ins folder where
Photoshop is installed. When Photoshop loads, the plug-in is
automatically loaded along with Photoshop.

Note

You need to restart Photoshop after installing a plug-in.
Some plug-ins require additional steps, so make sure you
check out the readme file that comes with the plug-in. You
can disable a plug-in from being loaded by putting a tilde
(~) character in front of the filename or the name of the
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folder that contains the plug-in file. If you put a tilde in front
of a folder name, all plug-ins in that folder and any
subfolders are ignored.

Photoshop does provide some configurations for plug-ins. To
set the configuration options, press Ctrl+K/?+K to open the
Preferences dialog box and select the Plug-Ins option, as
shown in Figure B.1.

Figure B.1

You can configure plug-in options from the Photoshop
Preferences dialog box.

1887



From the Plug-In Preferences panel, you can control the
following features of plug-ins:

• Show all Filter Gallery groups and names. When you
select this option, the Filter Gallery groups appear as
submenus in the Filter menu.

• Allow Extensions to Connect to the Internet. When you
select this option, the optional plug-ins are allowed to access
the Internet from your computer when Photoshop is running.
This allows them to update or provide functionality from web
services. However, you should be sure that you trust the
plug-in provider before enabling this option.

• Load Extension Panels. When you select this option, the
extension panels are loaded in addition to the normal
Photoshop panels. These panels typically provide important
functionality for using the plug-in.

Caution

Do not move plug-ins from previous versions of Photoshop,
or third-party plug-ins that have not been updated, into the
Photoshop CC Plug-Ins folder. In addition, if you are
running the 64-bit edition of your operating system, all
third-party plug-ins must be updated for 64-bit operating
systems before you install them into the 64-bit version of
Photoshop.

You can get plug-ins from the following locations:
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• Adobe download site/CC installation disk. Provides
optional plug-ins that you can download and install at no cost.

• Adobe Marketplace for Photoshop. Provides a lot of great
plug-ins that are available for purchase. The plug-ins here are
from Adobe-approved publishers, meaning that Adobe has
reviewed and accepted the publisher. Plug-ins from the
marketplace are more likely to work well than those from
other locations. You can find the Adobe Marketplace at
www.adobe.com/cfusion/marketplace/
index.cfm?event=marketplace.home&marketplaceid=2.

• Third-party websites. Provides information on Photoshop
CC websites that offer to sell you plug-ins. Keep in mind that
these plug-ins may not be Adobe certified like the ones on the
Adobe Marketplace website.

Using Optional Plug-Ins from Adobe

Adobe provides several optional plug-ins on their website for
downloading. These plug-ins provide some great additional
features to Photoshop that are very useful and can be fun to
use. Some of the optional plug-ins available for download are
as follows:

Tip

You can view information about an installed plug-in by
choosing Help⇒About Plug-in from the main menu in
Photoshop and then selecting the installed plug-in from the
list.
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• SGIRGB. The SGIRGB format plug-in allows you to read
and write files in the SGI image format. This format is
commonly used by software on the Silicon Graphics platform.
The SGI image format plug-in recognizes the file extensions
.sgi, .rgb, .rgba, and .bw.

• Softimage. The Softimage format plug-in allows you to read
and write files in the Softimage picture format. This format is
commonly used by 3-D rendering software from Softimage.

• Pattern Maker. The Pattern Maker plug-in provides a user
interface in Photoshop that allows you to create patterns by
slicing up an image and reassembling it. The pattern can be
made of one large tile or multiple duplicate tiles. You can
then save the patterns and use them in other images.

• PhotomergeUI. The PhotomergeUI plug-in provides a
step-by-step user interface that operates in conjunction with
the Photoshop Photomerge utility. This gives you greater
control and provides better results when combining two or
more images into a panorama.

• Digimarc. The Digimarc plug-in provides a panel and tools
that allow you to quickly define and embed watermarks in
your photos to protect them from unauthorized use.

• Web Photo Gallery. The Web Photo Gallery is a popular
plug-in that allows you to output images to a web gallery. The
Web Photo Gallery that existed in Adobe Bridge CS6 has
been removed in Adobe Bridge CC.
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Appendix C: Finding Resources

IN THIS APPENDIX

Finding help

Obtaining general information

Downloading resources

Finding professional resources

Exploring opportunities for training and conferences

Considering certification

Although this book covers most of the information you need
to create fantastic and professional results in Photoshop, you
should check out what other resources are available to
increase your Photoshop skill set. This appendix provides
some starting points to find additional resources, such as
where to find help, get general information about Photoshop,
download resources from the web, find professional
organizations, and get professional training.

Getting Started

An important part of learning to use Photoshop is recognizing
when you need help and ideas. Another important part is
being able to find the information you need. Help comes in
many different forms. These websites provide the
information, tutorials, and tips as well as downloads such as
brushes and patterns to help you get started:
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• www.adobe.com/support/photoshop

This is the official Adobe help site, offering the latest
information on Photoshop.

• www.adobe.com/designcenter/
video_workshop

This site contains several video tutorials on Adobe products
including Photoshop.

• www.dayleycreations.com

This is the authors' website. We publish some tips and
tutorials and other items related to Photoshop here. This is
also a place where you can go to leave feedback about the
book.

• www.photoshoptips.net

This site publishes articles, tutorials, and tips.

• www.smashingmagazine.com

This site is mostly dedicated to web development. However,
they provide some great Photoshop tutorials as well as
general image creation techniques.

• www.photoshopessentials.com

This site has several useful tutorials and tips as well as some
brush downloads.
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• www.layersmagazine.com

This site provides a number of tutorials for most Adobe
products. They also provide some useful reviews of
Photoshop plug-ins.

• www.photoshopuser.com

This site is run by the National Association of Photoshop
Professionals (NAPP) and contains video tutorials, articles,
and a help desk.

• www.brushes.obsidiandawn.com

This site allows you to download free brushes, images,
patterns, and shapes.

Finding General Information

Photoshop is by far the most popular photo-editing
application on the market. Consequently, many websites
provide good information on Photoshop. The following
websites are great places for general information about using
Photoshop and learning about digital image editing:

• www.photoshopnews.com

This site publishes the latest news and rumors about
Photoshop and contains a great list of links to sites that
provide resources on Photoshop.

• www.creativepro.com
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This site publishes articles on Photoshop and provides
community blogs and forums.

• www.retouchpro.com

This membership community provides blogs and chats about
digital retouching.

• www.digitaldog.net

This site publishes articles, tutorials, and tips on Photoshop
and digital editing.

In addition to online digital websites, several magazines
provide a lot of good tips, tutorials, and other general
information. Often the content of these magazines are of a
higher quality than you may find on websites. The following
are just a few magazines you may want to look into:

• Photoshop User

• Photoshop

• Practical Photoshop

• Photoshop Creative

• Advanced Photoshop

Acquiring Professional Resources
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If you're serious about working with Photoshop and you want
to mingle with other Photoshop professionals, these websites
can help you find the best information available:

• www.photoshopuser.com

This site is operated by NAPP, the largest organization for
Photoshop professionals. It offers tons of information,
articles, tutorials, downloads, and a professional help desk.

• www.istockphoto.com

This site provides a service to buy and sell stock photos.

Benefitting from Training and Conferences

Adobe offers some great training opportunities and the
Photoshop community at large offers even more training.
Taking advantage of these opportunities can increase your
skill set and help you connect with other professionals:

• www.adobe.com/training

This site provides information about Adobe Certified
instructors and training centers in your area.

• www.photoshopworld.com

This site provides all the information you need about the
largest Photoshop conference, which is held twice a year.

• www.lynda.com

1895

http://www.photoshopuser.com
http://www.photoshopuser.com
http://www.istockphoto.com
http://www.istockphoto.com
http://www.adobe.com/training
http://www.adobe.com/training
http://www.photoshopworld.com
http://www.photoshopworld.com
http://www.lynda.com
http://www.lynda.com


This site provides online training resources for several
products, including Photoshop.

• www.photoshopcafe.com

This site provides several tutorials on Photoshop.

Getting Certified on Adobe Products

Being certified on Adobe products can improve your
productivity, increase your employment options, and greatly
enhance your career. You'll find no better place than the
official Adobe website:

• www.adobe.com/support/certification

This website contains information about how to become an
Adobe Certified Associate, Expert, or Instructor.
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